Mailinglist Archive: opensuse-factory (237 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190603 released!
  • From: Dominique Leuenberger <dimstar@xxxxxxx>
  • Date: Wed, 05 Jun 2019 01:01:41 +0000
  • Message-id: <155969650140.31404.4400543209464327255@go-agent-stagingbot-5>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190603

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
Mesa (19.0.4 -> 19.0.5)
Mesa-drivers (19.0.4 -> 19.0.5)
NetworkManager (1.16.0 -> 1.16.2)
accountsservice (0.6.54 -> 0.6.55)
ceph (14.2.1.448+g1bd10a856f -> 14.2.1.463+g99339b576a)
drbd (9.0.17+git.b9abab2d -> 9.0.18+git.08cff482)
drbd-utils (9.8.0 -> 9.9.0)
eog (3.32.1 -> 3.32.2)
flatpak (1.2.4 -> 1.4.0)
gd
gimp
glib2 (2.60.2 -> 2.60.3)
gnome-control-center (3.32.1 -> 3.32.2)
gnome-documents (3.30.1 -> 3.32.0)
gnome-maps (3.32.2 -> 3.32.2.1)
gnome-shell (3.32.1 -> 3.32.2)
gnome-shell-extensions
gnome-software (3.32.2 -> 3.32.3)
gpg2 (2.2.15 -> 2.2.16)
gtksourceview4
gupnp (1.0.3 -> 1.0.4)
inkscape
kimap
kmail
libpsl (0.20.2 -> 0.21.0)
libstorage-ng (4.1.121 -> 4.1.125)
mutter (3.32.1 -> 3.32.2)
nautilus
openal-soft
par
perl-MailTools (2.20 -> 2.21)
php7 (7.3.5 -> 7.3.6)
polari (3.32.1 -> 3.32.2)
python-ndg-httpsclient
python-numpy (1.16.3 -> 1.16.4)
strace (5.0 -> 5.1)
system-config-printer
systemd
tlp
ufraw
xterm (344 -> 345)

=== Details ===

==== Mesa ====
Version update (19.0.4 -> 19.0.5)
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- Update to 19.0.5
* Things have slowed back down from the last release, which is
good for this late in the series. No one area has received too
much work, with a little bit sprinkled in here and there in
both core code and drivers.

==== Mesa-drivers ====
Version update (19.0.4 -> 19.0.5)
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- Update to 19.0.5
* Things have slowed back down from the last release, which is
good for this late in the series. No one area has received too
much work, with a little bit sprinkled in here and there in
both core code and drivers.

==== NetworkManager ====
Version update (1.16.0 -> 1.16.2)
Subpackages: NetworkManager-lang libnm0 typelib-1_0-NM-1_0

- Update to version 1.16.2:
+ Use FQDN for persistent hostname on Slackware.
+ Fix wrong permissions of the /var/lib/NetworkManager/secret_key
file.
+ Don't terminate teamd when assuming existing team connections.
+ Fix incorrect persistence of connections with EAP-TLS and a
PKCS#12 certificate when using the ifcfg-rh plugin.
+ Fix reapply of the MTU property on devices.
+ Restore IPv6 configuration when the link goes up.
+ Fix build with sanitizers.
+ Other various bug fixes and improvements.

==== accountsservice ====
Version update (0.6.54 -> 0.6.55)
Subpackages: accountsservice-lang libaccountsservice0
typelib-1_0-AccountsService-1_0

- Update to version 0.6.55:
+ Memory leak fix.
+ Improved heuristics for identifying user session.
+ Export interfaces directory to pkgconfig.
+ Lock down state directory from prying eyes to be more friendly to
accountsservice extensions that require privacy.
+ Misc fixes.
+ Updated translations.
- Drop accountsservice-upstream-fixes.patch: Fixed upstream.
- Refresh patches with refresh_patches osc service.

==== ceph ====
Version update (14.2.1.448+g1bd10a856f -> 14.2.1.463+g99339b576a)
Subpackages: librados2 librbd1

- Update to 14.2.1-463-g99339b576a:
+ qa/deepsea: redirect journalctl output to a logfile
+ spec: install/package ceph-volume lvmcache plugin
+ common: make ms_bind_msgr2 default to "false" (bsc#1124957)
- Update to 14.2.1-457-gb42e3171b3:
+ qa/deepsea/salt:
* 1node5disks salt configuration
* grafana_service_check validation test
* Disk drive replacement test
* use "ceph_cm_ansible: false" instead of "ceph_cm: salt"
+ spec: Disable LTO in spec when being used (bsc#1135030)
- civetweb: fix file descriptor leak (bsc#1125080, CVE-2019-3821)
(fix has been in since February 2019)
- rgw: sanitize customer encryption keys from log output in v4 auth
(bsc#1121567, CVE-2018-16889) (fix has been in since February 2019)

==== drbd ====
Version update (9.0.17+git.b9abab2d -> 9.0.18+git.08cff482)
Subpackages: drbd-kmp-default

- Upgrade to 9.0.18-1
* Fix an IO deadlock under memory pressure
* Fix disconnect timing in case the network connection suddenly
drops all packets
* Fix some misbehavior that surfaced with Ahead/Behind
* Fix potential spinlock deadlock in IRQ
* Minor fixes: forget-peer, _rcu iterators
* Quickly stop resync during AHEAD/BEHIND by introducing new
packet for that purpose.
* The quorum feature can now use the connectivity to
the majority of Diskless nodes as tiebreaker
* Access meta-data using DAX if it is on persistent memory
(NVDIMM or PMEM); For write intense workloads this is a x2 to x4 speedup!
- Remove patch fix-make-error.patch since merged into upstream(46e8e3fc)

==== drbd-utils ====
Version update (9.8.0 -> 9.9.0)

- Update to 9.9.0
* drbdadm,v9: do not ignore stacked/upper implicit paths.
* docker: provide initial integration.
* doc,v9: document transport keyword
* drbdmeta,v9: support for PMEM activity log format
* drbdadm: allow faking of drbdsetup show output
* drbdmeta,v9: fix forget-peer

==== eog ====
Version update (3.32.1 -> 3.32.2)
Subpackages: eog-lang

- Update to version 3.32.2:
+ Fix PNG file displayed darker after conversion from JPEG file.
+ Only build and attach RGB color profiles to PNGs when both gAMA
and cHRM are present.
+ Updated translations.

==== flatpak ====
Version update (1.2.4 -> 1.4.0)
Subpackages: libflatpak0 typelib-1_0-Flatpak-1_0

- Update to version 1.4.0:
+ This is the new stable series, ending the 1.3.x series. The
major changes since the 1.2.x is the improved I/O use for
system-installed applications, and the new format for
pre-configured remotes.

==== gd ====
Subpackages: libgd3

- change order while installing splitted library [bsc#1136574]

==== gimp ====
Subpackages: gimp-lang gimp-plugin-aa gimp-plugins-python libgimp-2_0-0
libgimpui-2_0-0

- No more need pkgconfig(glib-2.0) >= 2.56.0 for build.
pkgconfig(glib-2.0) >= 2.54.2 is enough.

==== glib2 ====
Version update (2.60.2 -> 2.60.3)
Subpackages: glib2-lang glib2-tools libgio-2_0-0 libglib-2_0-0 libgmodule-2_0-0
libgobject-2_0-0 libgthread-2_0-0

- Set umask to 022 before running glib-compile-schemas
(boo#1131761).
- Update to version 2.60.3:
+ * Various fixes to small key/value support in `GHashTable`.
* Bugs fixed:
- Critical in g_socket_client_async_connect_complete.
- New GHashTable implementation confuses valgrind.
- test_month_names: assertion failed.
- GNetworkAddressAddressEnumerator unsafely modifies cache in
GNetworkAddress.
- Leaks in gsocketclient.c connection code.
- glib/date test fails.
- GDB pretty-printer for GHashTable no longer works
+ Updated translations.

==== gnome-control-center ====
Version update (3.32.1 -> 3.32.2)
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-lang gnome-control-center-user-faces

- Update to version 3.32.2:
+ Applications: Use larger icons.
+ Display:
- Set Night Light screen temperature strings as translatable.
- Fix crash if a monitor has no preferred mode.
+ Mouse & Touchpad: Reinstate keyboard navigation in the panel.
+ Power: Correct the value of 90 minutes to 5400.
+ Region & Language: Fix input source options not being applied.
+ Sound: Clean up labels of devices without origin.
+ Updated translations.

==== gnome-documents ====
Version update (3.30.1 -> 3.32.0)
Subpackages: gnome-documents-lang gnome-shell-search-provider-documents

- Update to version 3.32.0:
+ Updated translations.
- Pass getting_started=false to meson, no longer build
getting-started pdf.
- Drop gnome-documents_books-common sub-package, now that
gnome-books is a separate package, it no longer makes sense. Also
add Obsoletes/Provides to smooth out upgrades.
- Update to version 3.31.92:
+ Bugs fixed:
- glgo#GNOME/gnome-documents!21, glgo#GNOME/gnome-documents#24.
+ Updated translations.
- Update to version 3.31.90:
+ Updated menus for 3.32 recommendations.
+ Bugs fixed: glgo#GNOME/gnome-documents#11,
glgo#GNOME/gnome-documents#12, glgo#GNOME/gnome-documents#21,
glgo#GNOME/gnome-documents#30.
+ Updated translations.
- Changes from version 3.31.1:
+ Allow libgdprivate-1.0.so to find libgd.
+ Search: be more careful when constructing a GFile.
+ build:
- Update to latest libgd.
- Ensure that the Git submodules are kept updated.
- Remove unused variable.
+ Updated translations.
- Drop gnome-books sub-package as it was split out into a separate
project. Keeping the common package for now, but that one will
probably be folded into the main package in the future.

==== gnome-maps ====
Version update (3.32.2 -> 3.32.2.1)
Subpackages: gnome-maps-lang

- Update to version 3.32.2.1:
+ Make the shape layer renderer use the tile size specified in
the dynamic service file, fixing an issue with misaligned shape
layer (GeoJSON, GPX, KML) rendering with the new 512 pixel
tiles.
+ Updated translations.

==== gnome-shell ====
Version update (3.32.1 -> 3.32.2)
Subpackages: gnome-shell-calendar gnome-shell-lang

- Update to version 3.32.2:
+ Fix tablet button mapping overlay.
+ Fix ellipsization in dialog subtitles/bodies.
+ Don't crash for world clock locations with no timezone.
+ Handle network interface name changes.
+ Don't leak old on-screen keyboard layout groups.
+ Avoid unnecessary style changes when computing
:first/:last-child.
+ Misc. bug fixes.
- Drop gnome-shell-do-not-chain-up-to-parent-allocate.patch: Fixed
upstream.

==== gnome-shell-extensions ====
Subpackages: gnome-shell-classic gnome-shell-extensions-common
gnome-shell-extensions-common-lang

- Split the architecture dependent session file to a new package
gnome-shell-classic-session required by gnome-shell-classic.
- Move BuildArch: noarch to subpackages to enable %ifarch macro
(bsc#1129412).

==== gnome-software ====
Version update (3.32.2 -> 3.32.3)
Subpackages: gnome-software-lang

- Update to version 3.32.3:
+ Add missing XbSilo locking, hopefully fixing a large number of
reported crashes.
+ Fix a regression that caused the fonts category to go missing.
+ Show a placeholder on the details page when we don't have the
actual icon.
+ Plug a large memory leak.
+ Use nicer arrows for version numbers on the updates page.
+ Fix an issue that led to screenshots not being correctly scaled
on hidpi.
+ flatpak:
- Fix several double-uses of GErrors.
- Handle failure of a libflatpak function updating permissions.
+ rpm-ostree: Implement what-provides decompose.

==== gpg2 ====
Version update (2.2.15 -> 2.2.16)
Subpackages: gpg2-lang

- Update to 2.2.16
* gpg: Fixed i18n markup of some strings.
* gpg: Allow deletion of subkeys with --delete-[secret-]key.
* gpg: Do not bail on an invalid packet in the local keyring.
* gpg: Do not allow creation of user ids larger than our parser allows.
* gpg: Do not delete any keys if --dry-run is passed.
* gpg: Fix using --decrypt along with --use-embedded-filename.
* gpg: Improve the photo image viewer selection.
* gpg: enable OpenPGP export of cleartext keys with comments.
* gpg: Do not print a hint to use the deprecated --keyserver option.
* gpg: Change update_keysig_packet to replace SHA-1 by SHA-256.
* gpg: Use just the addrspec from the Signer's UID.
* gpg: Accept also armored data from the WKD.
* gpg: Set a limit of 5 to the number of keys imported from the WKD.
* gpg: Don't use EdDSA algo ID for ECDSA curves.
* agent: Stop scdaemon after reload when disable_scdaemon.
* agent: For SSH key, don't put NUL-byte at the end.
* agent: correct length for uri and comment on 64-bit big-endian platforms
* dirmngr: Allow for other hash algorithms than SHA-1 in OCSP.
* dirmngr: Improve domaininfo cache update algorithm.
* dirmngr: Better error code for http status 413.
* g10: Fix possible null dereference.
* g10: Fix double free when locating by mbox.
* g10: Fix symmetric cipher algo constant for ECDH.
* sm: Avoid confusing diagnostic for the default key.
* sm: Fix a warning in an es_fopencooie function.
* gpgconf: Before --launch check that the config file is fine.
* gpgconf: Support --homedir for --launch.
* build: Update m4/iconv.m4.
* doc: correct documentation for gpgconf --kill.
* scd: Add dummy option --application-priority.
* common: Fix AWK portability.

==== gtksourceview4 ====
Subpackages: gtksourceview4-lang libgtksourceview-4-0 typelib-1_0-GtkSource-4

- Rename glade-catalog-gtksourceview to
glade-catalog-gtksourceview4: do not use the same name as
gtksourceview (3.x) is using. The new package is obsoleting the
old one (including the one from 3.x).

==== gupnp ====
Version update (1.0.3 -> 1.0.4)

- Update to version 1.0.4:
+ Fix some win32-specific warnings.
+ Backport meson support form master.
+ Fix introspection annotations for get_icon_url
+ Avoid static buffer in linux context manager.
+ Fix wrong include in ACL header.
+ Fix endless loop in service proxy.

==== inkscape ====
Subpackages: inkscape-extensions-extra inkscape-extensions-gimp
inkscape-extensions-skencil inkscape-lang

- Add inkscape-fix-for-poppler-0.76.patch: Fix build with poppler
0.76, patch from upstream git.
- Disable LTO (boo#1135211).

==== kimap ====
Subpackages: kimap-lang libKF5IMAP5

- Use FAT lto objects as the package ships a static library
(boo#1136681).

==== kmail ====
Subpackages: kmail-application-icons kmail-lang ktnef

- Add Fix-Bug-407967.patch to ensure that the "To:" field always
has focus when creating a new mail (boo#1136481, kde#407967)

==== libpsl ====
Version update (0.20.2 -> 0.21.0)

- update to 0.21.0:
* Add -b/--batch to 'psl' to suppress printing the domain

==== libstorage-ng ====
Version update (4.1.121 -> 4.1.125)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#650
- sort block devices when creating btrfs (needed in testsuite)
- 4.1.125
- merge gh#openSUSE/libstorage-ng#649
- use devid from devicegraph when resizing btrfs
- extended integration test
- added note
- fix resizing btrfs on e.g. LVM
- 4.1.124
- merge gh#openSUSE/libstorage-ng#648
- allow to reuse commands and files in mockup files
- read sub uuid in blkid output
- updated devicegraphs
- add id to FilesystemUser
- removed obsolete setenv calls to enable multiple devices btrfs
- work on btrfs multiple device support
- 4.1.123
- merge gh#openSUSE/libstorage-ng#647
- Enable multi-device Btrfs probing by default
- Bump lib version
- Enable multi-device Btrfs by default
- 4.1.122

==== mutter ====
Version update (3.32.1 -> 3.32.2)
Subpackages: libmutter-4-0 mutter-data mutter-lang

- Drop unneeded and unused libtool BuildRequires.
- Update to version 3.32.2:
+ Disable mouse keys with Numlock on.
+ Fix crash when restarting on X11.
+ Fix mapping of touchscreens that don't report dimensions.
+ Fix spurious idle signals that prevent session unblank.
+ Misc. bug fixes and cleanups.
- Update spec to reflect the rebase of
mutter-xwayland-create-xauthority.patch (bsc#1084737).
- Update mutter-xwayland-create-xauthority.patch (bsc#1084737).

==== nautilus ====
Subpackages: gnome-shell-search-provider-nautilus libnautilus-extension1
nautilus-lang

- Require tracker-miner-files (boo#1135652).

==== openal-soft ====
Subpackages: libopenal1 openal-soft-data

- Use more of macros for building
- Build gui config tool as well

==== par ====

- Trim name repetition from summary.

==== perl-MailTools ====
Version update (2.20 -> 2.21)

- updated to 2.21
see /usr/share/doc/packages/perl-MailTools/ChangeLog
version 2.21: Tue 21 May 16:26:30 CEST 2019
Fixes:
- fix metadata [Mohammad S Anwar]
Improvements:
- add more to the README
- add Mail::Mailer option StartSSL for smtp backend
rt.cpan.org#125871 [Guilhem Moulin]
- deprecate Mail::Mailer backend smtps
- document need for escaping docs for Mail::Send
rt.cpan.org#129627 [Jonathan Kamens]
- document limit on parameters for Mail::Send::new()
rt.cpan.org#129633 [Sven Neuhaus]

==== php7 ====
Version update (7.3.5 -> 7.3.6)
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pgsql php7-shmop php7-snmp
php7-sockets php7-sqlite php7-sysvsem php7-sysvshm php7-tidy php7-tokenizer
php7-wddx php7-xmlreader php7-xmlwriter php7-xsl php7-zlib

- updated to 7.3.6: This is a security release which also contains
several bug fixes. See https://www.php.net/ChangeLog-7.php#7.3.6
- check via apache-rex
- build for 42.3

==== polari ====
Version update (3.32.1 -> 3.32.2)
Subpackages: polari-lang typelib-1_0-Polari-1_0

- Update to version 3.32.2:
+ Improve connectivity handling.
+ Misc. bug fixes and cleanups.

==== python-ndg-httpsclient ====

- Use noun phrase in summary.

==== python-numpy ====
Version update (1.16.3 -> 1.16.4)
Subpackages: python2-numpy python3-numpy

- Disable LTO in order to address boo#1136831.
- update to version 1.16.3
* The NumPy 1.16.4 release fixes bugs reported against the 1.16.3 release, and
also backports several enhancements from master that seem appropriate for a
release series that is the last to support Python 2.7.
+ New deprecations
* Writeable flag of C-API wrapped arrays
+ Compatibility notes
* Potential changes to the random stream

==== strace ====
Version update (5.0 -> 5.1)

- Update to strace 5.1
* Bug fixes
* Fixed decoding of last two arguments of clone syscall on riscv.
* Improvements
* Added C-SKY architecture support.
* Implemented decoding of SO_TIMESTAMP*_NEW control messages.
* Implemented decoding of clock_gettime64, clock_settime64, clock_adjtime64,
clock_getres_time64, clock_nanosleep_time64, timer_gettime64,
timer_settime64, timerfd_gettime64, timerfd_settime64, utimensat_time64,
pselect6_time64, ppoll_time64, io_pgetevents_time64, recvmmsg_time64,
mq_timedsend_time64, mq_timedreceive_time64, semtimedop_time64,
rt_sigtimedwait_time64, futex_time64, sched_rr_get_interval_time64,
pidfd_send_signal, io_uring_setup, io_uring_enter, and io_uring_register
syscalls.
* Enhanced decoding of bpf syscall.
* Wired up getegid, geteuid, getppid, io_pgetevents, statfs64, and fstatfs64
syscalls on alpha.
* Wired up kexec_file_load and migrate_pages syscalls on arm.
* Wired up io_pgetevents, perf_event_open, seccomp, and statx syscalls
on ia64.
* Wired up seccomp syscall on m68k.
* Wired up statx syscall on sh.
* Wired up pkey_mprotect, pkey_alloc, and pkey_free syscalls on alpha, hppa,
ia64, m68k, s390, s390x, sh, sparc, and sparc64.
* Wired up rseq syscall on alpha, hppa, ia64, m68k, sh, sparc, sparc64,
and xtensa.
* Wired up direct ipc syscalls on m68k, mips o32, powerpc, powerpc64,
s390, s390x, sh, sparc, sparc64, and x86.
* Updated lists of BPF_*, FAN_*, F_SEAL_*, IPV6_*, NT_*, PR_SPEC_*, SO_*,
and V4L2_* constants.
* Updated lists of ioctl commands from Linux 5.1.

==== system-config-printer ====
Subpackages: python3-cupshelpers system-config-printer-applet
system-config-printer-common system-config-printer-common-lang
system-config-printer-dbus-service udev-configure-printer

- Require python3-requests by python3-cupshelpers (boo#1116867).

==== systemd ====
Subpackages: libsystemd0 libudev-devel libudev1 systemd-container
systemd-logger systemd-sysvinit udev

- Import commit eaa7b8b148927d471609de75e542dffcc1b36df4
7e58b89136 udevd: change the default value of udev.children-max (again)
(bsc#1107617)
- Add 0001-rc-local-generator-deprecate-halt.local-support.patch
/etc/init.d/halt.local support will removed from the next systemd
version (v243) so for now on warn (hopefully the few) users who rely
on this script so they have a chance to switch to systemd-shutdown
interface.
- Add 0001-Revert-insserv.conf-generator.patch (bsc#1052837)
All remaining packages have been fixed so they don't rely on the
insser-generator to generate proper deps. So let's drop it as all
services should carry the proper dependencies itself.
- Drop debug-only-remove-new-policies.patch
The new DBUS methods have been reviewed by the security team.

==== tlp ====
Subpackages: tlp-rdw

- Use noun phrase in summary.

==== ufraw ====
Subpackages: gimp-ufraw ufraw-lang

- Update descriptions.

==== xterm ====
Version update (344 -> 345)
Subpackages: xterm-bin

- Patch #345
* modify treatment of reverseVideo for dynamic colors
* correct a typo in setDirectFG
* add resource useBorderClipping
* fix a special case in XTPOPSGR to check direct colors
* increase response-buffer size
* reduce the number of buffer-flashes for tcap-query batches


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages