Mailinglist Archive: opensuse-factory (387 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190521 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190521

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
attica-qt5 (5.57.0 -> 5.58.0)
baloo5 (5.57.0 -> 5.58.0)
bluez-qt (5.57.0 -> 5.58.0)
breeze5-icons (5.57.0 -> 5.58.0)
ceph (14.2.1.345+g040ffffe0e -> 14.2.1.431+gd032e5dd80)
e2fsprogs (1.45.0 -> 1.45.1)
ethtool (5.0 -> 5.1)
flatpak
frameworkintegration (5.57.0 -> 5.58.1)
glibc
glibc
iproute2 (4.20 -> 5.1)
kactivities-stats (5.57.0 -> 5.58.0)
kactivities5 (5.57.0 -> 5.58.0)
karchive (5.57.0 -> 5.58.0)
kauth (5.57.0 -> 5.58.0)
kbookmarks (5.57.0 -> 5.58.0)
kcmutils (5.57.0 -> 5.58.0)
kcodecs (5.57.0 -> 5.58.0)
kcompletion (5.57.0 -> 5.58.0)
kconfig (5.57.0 -> 5.58.0)
kconfigwidgets (5.57.0 -> 5.58.0)
kcoreaddons (5.57.0 -> 5.58.0)
kcrash (5.57.0 -> 5.58.0)
kdbusaddons (5.57.0 -> 5.58.0)
kdeclarative (5.57.0 -> 5.58.0)
kded (5.57.0 -> 5.58.0)
kdelibs4support (5.57.0 -> 5.58.0)
kdesu (5.57.0 -> 5.58.0)
kdnssd-framework (5.57.0 -> 5.58.0)
kdoctools (5.57.0 -> 5.58.0)
kemoticons (5.57.0 -> 5.58.0)
kfilemetadata5 (5.57.0 -> 5.58.0)
kglobalaccel (5.57.0 -> 5.58.0)
kguiaddons (5.57.0 -> 5.58.0)
kholidays (5.57.0 -> 5.58.0)
khtml (5.57.0 -> 5.58.0)
ki18n (5.57.0 -> 5.58.0)
kiconthemes (5.57.0 -> 5.58.0)
kidletime (5.57.0 -> 5.58.0)
kimageformats (5.57.0 -> 5.58.0)
kinit (5.57.0 -> 5.58.0)
kio (5.57.0 -> 5.58.0)
kirigami2 (5.57.0 -> 5.58.0)
kitemmodels (5.57.0 -> 5.58.0)
kitemviews (5.57.0 -> 5.58.0)
kjobwidgets (5.57.0 -> 5.58.0)
kjs (5.57.0 -> 5.58.0)
kjsembed (5.57.0 -> 5.58.0)
knewstuff (5.57.0 -> 5.58.0)
knotifications (5.57.0 -> 5.58.0)
knotifyconfig (5.57.0 -> 5.58.0)
kpackage (5.57.0 -> 5.58.0)
kparts (5.57.0 -> 5.58.0)
kpeople5 (5.57.0 -> 5.58.0)
kplotting (5.57.0 -> 5.58.0)
kpty (5.57.0 -> 5.58.0)
kross (5.57.0 -> 5.58.0)
krunner (5.57.0 -> 5.58.0)
kservice (5.57.0 -> 5.58.0)
ktexteditor (5.57.0 -> 5.58.0)
ktextwidgets (5.57.0 -> 5.58.0)
kunitconversion (5.57.0 -> 5.58.0)
kwallet (5.57.0 -> 5.58.0)
kwayland (5.57.0 -> 5.58.0)
kwidgetsaddons (5.57.0 -> 5.58.0)
kwindowsystem (5.57.0 -> 5.58.0)
kxmlgui (5.57.0 -> 5.58.0)
kxmlrpcclient5 (5.57.0 -> 5.58.0)
libKF5ModemManagerQt (5.57.0 -> 5.58.0)
libKF5NetworkManagerQt (5.57.0 -> 5.58.0)
libvirt
ncurses
oxygen5-icon-theme (5.57.0 -> 5.58.0)
perl-Mojolicious (8.15 -> 8.16)
plasma-framework (5.57.0 -> 5.58.0)
polkit
prison-qt5 (5.57.0 -> 5.58.0)
purpose (5.57.0 -> 5.58.0)
python-Pygments (2.3.1 -> 2.4.0)
rdma-core (23.0 -> 23.1)
rubygem-ffi (1.10.0 -> 1.11.0)
solid (5.57.0 -> 5.58.0)
sonnet (5.57.0 -> 5.58.0)
suil (0.10.0 -> 0.10.2)
syndication (5.57.0 -> 5.58.0)
syntax-highlighting (5.57.0 -> 5.58.0)
sysprof
systemd (241 -> 242)
threadweaver (5.57.0 -> 5.58.0)
util-linux (2.33.1 -> 2.33.2)
util-linux-systemd (2.33.1 -> 2.33.2)
yast2 (4.2.2 -> 4.2.3)
yast2-iscsi-client (4.1.7 -> 4.2.0)
yast2-ruby-bindings (4.1.4 -> 4.2.1)
yast2-trans (84.87.20190504.69fe46292b -> 84.87.20190511.bc4a9329cc)
yast2-users (4.2.0 -> 4.2.1)

=== Details ===

==== attica-qt5 ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Attica5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== baloo5 ====
Version update (5.57.0 -> 5.58.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* [baloo_file] Wait for extractor process to start
* [balooctl] Add command to show files failed to index
* Add QML to source code types
* [Transaction] Minor code cleanup/optimization
* [balooctl] Capture the constant totalsize in the lambda
* [balooctl] Switch multiline output to new helper
* [balooctl] Use new helper in json output
* [balooctl] Use new helper for simple format output
* [balooctl] Factor out file index status collection from output
* Keep empty Json metadata docs out of DocumentData DB
* [balooshow] Allow referencing files by URL from hardlink
* [balooshow] Suppress warning when URL refers to unindexed file
* Simplify orPostingIterator and make it faster
* Ensure QFileInfo is valid for the first FilteredDirIterator entry
* [MTimeDB] Allow timestamp newer than the newest document in range match
* [MTimeDB] Use exact match when exact match is requested
* [balooctl] Cleanup handling of different positional arguments
* [balooctl] Extend options help text, improve error checking
* [balooctl] Use more understandable names for size in status output
* [balooctl] clear command: Remove bogus check for documentData, cleanup
* [kio_search] Fix warning, add UDSEntry for "." in listDir
* Use hex notation for DocumentOperation flag enum
* Calculate total DB size correctly
* Postpone term parsing until needed, do not set both term and searchstring
* Dont add default valued date filters to json
* Use compact Json format when converting query URLs
* [balooshow] Do not print a bogus warning for a non-indexed file

==== bluez-qt ====
Version update (5.57.0 -> 5.58.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== breeze5-icons ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Add non-symbolic 16px versions of find-location and mark-location
* Symlink preferences-system-windows-effect-flipswitch to
preferences-system-tabbox
* Rename "edit-remove" icon to "edit-delete-remove" to support Oxygen and
other icon themes
* Add "edit-remove" icon symlink and add 22px version of "paint-none" and
"edit-none"
* Use consistent default Kickoff user icon
* Add an icon for Thunderbolt KCM
* Sharpen Z's in system-suspend* icons
* Improve "widget-alternatives" icon
* Add go-up/down/next/previous-skip
* Update KDE logo to be closer to original
* Add alternatives icon

==== ceph ====
Version update (14.2.1.345+g040ffffe0e -> 14.2.1.431+gd032e5dd80)
Subpackages: librados2 librbd1

- Update to 14.2.1-431-gd032e5dd80:
+ ReplicatedPG: add CHECKSUM->CMPEXT req translation (bsc#1123360)
+ MDS + libcephfs snapshot btime support (jsc#SES-183)
- Update to 14.2.1-423-g3df171fd28:
+ rgw: cloud sync fixes (jsc#SES-97)
- Update to 14.2.1-419-gb72ca927c1:
+ rebase on top of upstream nautilus branch, SHA1
8e188313cf2f790f131e21a3a02094e32cf02087
+ replaced ~25 downstream ceph-volume lvmcache commits with a single squashed
commit
+ rgw: object expirer fixes (bsc#1133139)
+ rgw_lc: use a new bl while encoding RGW_ATTR_LC (jsc#SES-327)
+ rgw: beast IPv6 (jsc#SES-454)
- Update to 14.2.1-426-g7a12897012:
+ nautilus: core: Give recovery for inactive PGs a higher priority
(bsc#1133461)
+ spec: new subpackage ceph-prometheus-alerts
+ nautilus: librbd: re-add support for nautilus clients talking to jewel
clusters
+ systemd: ceph-mgr: set MemoryDenyWriteExecute to false

==== e2fsprogs ====
Version update (1.45.0 -> 1.45.1)
Subpackages: e2fsprogs-devel libcom_err-devel libcom_err2 libcom_err2-32bit
libext2fs-devel libext2fs2

- Remove unused configure-Fix-autoheader-failure.patch.
- Update to 1.45.1
* Remove configure-Fix-autoheader-failure.patch (fixed upstream)
* Debugfs now supports non-printable chars
* E2fsck now checks to make sure all unused bits in block are set
* E2fsck now supports writing out a problem code log
* Fixed various casefold bugs
* Fix mke2fs support for < 900TB disks
* E2scrub will take its snapshots with UDISK_IGNORE
* Dropped utf8/nls symbols from libext2fs shared library

==== ethtool ====
Version update (5.0 -> 5.1)

- Update to new upstream release 5.1
* support for 200Gbps (50Gbps per lane) link modes
* support for new PHY tunable Fast Link Down
* new 'start N' option when setting Rx flow indirection table
* add bash completion script
* support show and set of per queue coalescing
* fec: add pretty dump

==== flatpak ====
Subpackages: libflatpak0 typelib-1_0-Flatpak-1_0

- Replace systemd-gtk BuildRequires with pkgconfig(systemd): make
the build cheaper by not having to wait for the 'real' systemd
package to have built, but allow to use systemd-mini. The change
in the stack causing this was polkit dropping its hard dep on
systemd.
- Add systemd-gtk BuildRequires: Needed now after changes elsewhere
in the stack.

==== frameworkintegration ====
Version update (5.57.0 -> 5.58.1)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.58.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.1.php
- Changes since 5.58.0:
* search in the new location for knsrc files
- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== glibc ====

- dl-show-auxv.patch: Fix output of LD_SHOW_AUXV=1
- s390-vx-vxe-hwcap.patch: S390: Mark vx and vxe as important hwcap
- taisho-era-string.patch: ja_JP: Change the offset for Taisho gan-nen
from 2 to 1 (BZ #24162)
- malloc-tracing-hooks.patch: malloc: Set and reset all hooks for tracing
(BZ #16573)
- pldd-inf-loop.patch: elf: Fix pldd (BZ#18035)
- malloc-large-bin-corruption-check.patch: malloc: Check for large bin
list corruption when inserting unsorted chunk (BZ #24216)
- wfile-sync-crash.patch: Fix crash in _IO_wfile_sync (BZ #20568)

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale glibc-locale-base
nscd

- dl-show-auxv.patch: Fix output of LD_SHOW_AUXV=1
- s390-vx-vxe-hwcap.patch: S390: Mark vx and vxe as important hwcap
- taisho-era-string.patch: ja_JP: Change the offset for Taisho gan-nen
from 2 to 1 (BZ #24162)
- malloc-tracing-hooks.patch: malloc: Set and reset all hooks for tracing
(BZ #16573)
- pldd-inf-loop.patch: elf: Fix pldd (BZ#18035)
- malloc-large-bin-corruption-check.patch: malloc: Check for large bin
list corruption when inserting unsorted chunk (BZ #24216)
- wfile-sync-crash.patch: Fix crash in _IO_wfile_sync (BZ #20568)

==== iproute2 ====
Version update (4.20 -> 5.1)

- Revert-tc-ematch-fix-deprecated-yacc-warning.patch:
fix build on SLE12 and openSUSE Leap 42.3
- Update to new upstream release 5.1
* bridge: fdb: add support for src_vni option
* devlink: report cell size
* devlink: add dev info and dev flash subcommands
* devlink: add health subcommand
* ip link: display netrom link type
* ip link: bond_slave: add xstats support
* ip link: bridge: support mcast to unicast flag
* ip netns: add attach subcommand to attach existing netns
* ip xfrm: add option to hide keys in state output
* ip xfrm: support xfrm interfaces
* rdma: add unbound workqueue to list of poll context types
* rdma: provide parent context index for all objects except CM_ID
* rdma: add prefix for driver attributes
* ss: support AF_XDP
* tc: add hit counter for matchall
* tc: add kind property to csum action
* tc: q_cake: support fwmark option
* improve batch and dump performance by caching link lookups
* more JSON support
* many text/JSON output fixes
- Update to new upstream release 5.0.0
* ip route: get print JSON output when -j is given
* ip route: print route type in JSON output
* tc: m_connmark: fix action error messages
* ipaddress: print error messages on stderr
* iprule: fix printing hint about unresolved iifname + oofname
* man: Document COLORFGBG environment variable
* tcpedit: Fix wrong pedit ipv6 structure id
* ss: Render buffer to output every time a number of chunks alloc
* ss: fix compilation under glibc < 2.18
- Add patches which enable support of BPF global data section,
pulled from https://github.com/cilium/iproute2/tree/static-data
* bpf-bss-section-poc.patch
* bpf-data-section-support-poc.patch

==== kactivities-stats ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kactivities5 ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== karchive ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* KTar: Protect against negative longlink sizes
* Fix invalid memory write on malformed tar files
* Fix memory leak when reading some tar files
* Fix uninitialized memory use when reading malformed tar files
* Fix stack-buffer-overflow read on malformed files
* Fix null-dereference on malformed tar files
* autotests: Fix leak in karchivetest
* Install krcc.h header
* Fix double delete on broken files
* Disallow copy of KArchiveDirectoryPrivate and KArchivePrivate
* "Fix" KArchive::findOrCreate running out of stack on VERY LONG paths
* Introduce and use KArchiveDirectory::addEntryV2
* removeEntry can fail so it's good to know if it did
* Fix obviously wrong comment
* KZip: fix Heap-use-after-free in broken files

==== kauth ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang libKF5AuthCore5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Force KAuth helpers to have UTF-8 support (kde#384294)

==== kbookmarks ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Fix KBoomarkMenuTest when Bookmarks Editor is not installed
* Fix compile with Qt 5.10
* Add support for KBookmarkOwner to communicate if it has tabs open
* Replace count() == 0 by isEmpty()

==== kcmutils ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* use size hints from the ApplicationItem itself
* Revert "Revert "Fix Oxygen background gradient for QML modules""

==== kcodecs ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kcompletion ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kconfig ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Add Notify capability to KConfigXT
* Fix typo in KConfig documentation.

==== kconfigwidgets ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kcoreaddons ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Fix wrong "Unable to find service type" warnings
* New class KOSRelease - a parser for os-release files
* Fix bug about "** foo **"
* Not necessary to have %2 here as we use %1
* Skip running benchmarks when in debug mode.

==== kcrash ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kdbusaddons ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kdeclarative ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* [KeySequenceItem] Make the clear button have the same height as shortcut
button
* Plotter: Scope GL Program to lifespan of scenegraph node (kde#403453)
* use the base implementation hints
* KeySequenceHelperPrivate::updateShortcutDisplay: Don't show english text to
the user
* [ConfigModule] Pass initial properties in push()
* Enable glGetGraphicsResetStatus support by default on Qt >= 5.13
(kde#364766)

==== kded ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kded-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Install .desktop file for kded5 (kde#387556)

==== kdelibs4support ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kdesu ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kdnssd-framework ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kdoctools ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kemoticons ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Mark archive and directory as const
* [kemoticons] make it compile without foreach

==== kfilemetadata5 ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kfilemetadata5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Reorder includes
* [TaglibExtractor] Feed non-ogg *.spx file into extractor test
* [TagLibExtractor] Fix crash on invalid Speex files (kde#403902)
* Fix exivextractor crash with malformed files (kde#405210)
* Declare properties as meta type
* Change properties attributes for consistency
* Handle variant list in formatting functions
* add license to python test files
* Force en locale for propertyinfotest
* Fix for Windows' stupid LARGE_INTEGER type
* Fix (compilation) errors for Windows UserMetaData implementation
* remove unnecessary parenthesis
* add missing mimetype to taglib writer
* Test all extractors with strict mime type
* fix warnings
* Use new mimetype helper in taglib extractor test
* [UserMetaData] Handle changes in attribute data size correctly
* [UserMetaData] Untangle Windows, Linux/BSD/Mac and stub code.

==== kglobalaccel ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Copy container in Component::cleanUp before interating
* Don't use qAsConst over a temporary variable
* Remove two ';'
- Dropped patches, now upstream:
* 0001-Copy-container-in-Component-cleanUp-before-interatin.patch
* Dont-use-qAsConst-over-a-temporary-variable.patch

==== kguiaddons ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kholidays ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* holidays/plan2/holiday_zm_en-gb - add Zambia holidays
* holidays/plan2/holiday_lv_lv - fix Midsummer's Day
* holiday_mu_en - Holidays 2019 in Mauritius
* holiday_th_en-gb - update for 2019
* Update Japanese holidays by N.Higa
* Add public holidays for Lower Saxony (Germany) Committed for mmustac

==== khtml ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== ki18n ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kiconthemes ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kidletime ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kimageformats ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kimageformats-eps

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* tga: don't try to read more than max_palette_size into palette
* tga: memset dst if read fails
* tga: memset the whole palette array, not only the palette_size
* Initialize the unread bits of _starttab
* xcf: Fix uninitialized memory use on broken documents
* ras: Don't overread input on malformed files
* xcf: layer is const in copy and merge, mark it as such
* No & is a bit faster here
* const & is a bit faster here
* QStringLiteral is a bit faster here

==== kinit ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kinit-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Replace count() == 0 by isEmpty()

==== kio ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kio-core kio-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* [FileWidget] Replace "Filter:" with "File type:" when saving with a limited
list of mimetypes (kde#79903)
* use actually existing breeze icon for the new file Program.desktop
* Reword some text, a couple clean ups, add a separator
* autotests: adapt to QUrl behaviour change in Qt 5.12.1
* autotests: adapt to shared-mime-info change
* Use regular stat when resolving a symlink
* autotests: kfileitemtest: close file before inspecting it
* [Properties dialog] Use the string "Free space" instead of "Disk usage"
(kde#406630)
* Remove TODO
* Truncate trailing forward slashes(/)
* Fix signed/unsigned warning after statx change
* Fill UDSEntry::UDS_CREATION_TIME under linux when glibc >= 2.28
* [KUrlNavigator] Fix URL navigation when exiting archive with krarc and
Dolphin (kde#386448)
* [KDynamicJobTracker] When kuiserver isn't available, also fall back to
widget dialog (kde#379887)

==== kirigami2 ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* dd the new files to the pri file
* [aboutpage] hide Authors header if there are no authors
* Update qrc.in to match .qrc (missing ActionMenuItem)
* fix formatting in android build instructions
* DesktopIcon -> Icon
* Make sure we don't squeeze out the ActionButton (kde#406678)
* make it work
* single event filter in a singleton
* Revert "make it an attached property"
* make it an attached property
* final api, documentation++
* add blockTargetWheel property
* add a wheelhandler event filter
* fix implicitWidth
* remove all the custom mouse wheel handling
* remove extra debug
* propagate hints to ColumnView and PageRow
* ensure layout is done right after component.oncompleted
* Pages: export correct contentHeight/implicit sizes
* [ColumnView] Also check for index in child filter...
* [ColumnView] Don't let mouse back button go back beyond first page
* header has immediately the proper size

==== kitemmodels ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kitemviews ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kjobwidgets ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* [KUiServerJobTracker] Track kuiserver service life time and re-register
jobs if needed

==== kjs ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kjsembed ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== knewstuff ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Remove pixelated border (kde#391108)
* Minor documentation clearup (missing support variable)

==== knotifications ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* [Notify by Portal] Support default action and priority hints
* [KNotification] Add HighUrgency
* [KNotifications] Update when flags, urls, or urgency change
* Allow to set urgency for notifications

==== knotifyconfig ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* [knotifyconfig] make it compile without foreach

==== kpackage ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kpackage-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Add missing properties in kpackage-generic.desktop
* kpackagetool: read kpackage-generic.desktop from qrc
* AppStream generation: make sure we look up for the package structure on
packages that have metadata.desktop/json too
* autotests: don't fail appstream test because of anything on stderr
* autotests: display command being executed, to help debugging failures
* autotests: make output nicer
* Don't use qAsConst over a temporary variable
- Dropped patches, now upstream:
* Dont-use-qAsConst-over-a-temporary-variable.patch

==== kparts ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kpeople5 ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kpeople5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kplotting ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kpty ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kross ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kross-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== krunner ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== kservice ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kservice-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== ktexteditor ====
Version update (5.57.0 -> 5.58.0)
Subpackages: ktexteditor-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Too many changes to list here

==== ktextwidgets ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* [ktextwidget] compile without foreach

==== kunitconversion ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Fix l/100 km to MPG conversion (kde#378967)

==== kwallet ====
Version update (5.57.0 -> 5.58.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Fix add_test command
* Set correct kwalletd_bin_path
* Export path of kwalletd binary for kwallet_pam

==== kwayland ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Add CriticalNotification window type to PlasmaShellSurface protocol
* Implement wl_eglstream_controller Server Interface

==== kwidgetsaddons ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* autotests: fix kcharselect unittest so it can find the data file uninstalled
* KCharSelect: remove unnecessary call
* KCharSelect: add unittest. Hits the assert in QHeaderView.
* Update kcharselect-data to Unicode 12.1
* KCharSelect's internal model: ensure rowCount() is 0 for valid indexes
* Replace count() == 0 by isEmpty()

==== kwindowsystem ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* API dox: fix typo
* Introduce CriticalNotificationType
* Adjust unit test for newly added state
* Support NET_WM_STATE_FOCUSED
* Document that modToStringUser and stringUserToMod only deal with english
strings
* Replace count() == 0 by isEmpty()

==== kxmlgui ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* KKeySequenceWidget: Don't show English strings to the user

==== kxmlrpcclient5 ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== libKF5ModemManagerQt ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== libKF5NetworkManagerQt ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Add WireGuard device support to manager
* Add WireGuard device
* WireGuard: Do not require 'private-key' to be non-empty for
'private-key-flags'
* WireGuard: workaround wrong secret flag type
* WireGuard: private-key and preshared-keys can be requested together

==== libvirt ====
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- cpu_map: add cpu feature md-clear. CVE-2018-12126,
CVE-2018-12127, CVE-2018-12130, CVE-2019-11091
5cd9db3a-cputest-add-data-E3-1225-v5.patch,
538d8735-cpu_map-Define-md-clear-CPUID-bit.patch
bsc#1111331, bsc#1135273

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo
terminfo-base terminfo-screen

- Make pkg-config files .pc consistent
- Add ncurses patch 20190511
+ fix a spurious blank line seen with "infocmp -1fx xterm+x11mouse"
+ add checks in repair_subwindows() to keep the current position and
scroll-margins inside the resized subwindow.
+ add a limit check in newline_forces_scroll() for the case where the
row is inside scroll-margins, but not at the end (report by Toshio
Kuratomi, cf: 20170729).
+ corrected a warning message in tic for extended capabilities versus
number of parameters.
- Add ncurses patch 20190504
+ improve workaround for Solaris wcwidth versus line-drawing characters
(report by Pavel Stehule).
+ add special case in tic to validate RGB string-capability extension.
+ corrected string/parameter-field for RGB in Caps-ncurses.
- Add ncurses patch 20190427
+ corrected problem in terminfo load/realignment which prevented
infocmp from comparing extended capabilities with the same name
but different types.
- Add ncurses patch 20190420
+ improve ifdef's for TABSIZE variable, to help with AIX/HPUX ports.
- Add ncurses patch 20190413
+ check for TABSIZE variable in test/configure script.
+ used test/test_arrays.c to improve Caps.aix1 and Caps.hpux11
+ corrected filtering of comments in MKparametrized.sh
+ reduce duplication across Caps* files by moving some parts which do
not depend on order into Caps-ncurses.
- Add ncurses patch 20190406
+ modify MKcaptab.sh, MKkey_defs.sh, and MKhashsize.sh to handle
split-up Caps-files.
+ build-fixes if extended-functions are disabled.
- Add ncurses patch 20190330
+ add "screen5", to mention italics (report by Stefan Assmann)
+ modify description of xterm+x11hilite to eliminate unused p5 -TD
+ add configure script checks to help with a port to Ultrix 3.1
(report by Dennis Grevenstein).
+ check if "b" binary feature of fopen works
+ check for missing feature of locale.h
+ add fallback for strstr() in test-programs
+ add fallback for STDOUT_FILENO in test-programs
+ update config.guess, config.sub

==== oxygen5-icon-theme ====
Version update (5.57.0 -> 5.58.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== perl-Mojolicious ====
Version update (8.15 -> 8.16)

- updated to 8.16
see /usr/share/doc/packages/perl-Mojolicious/Changes
8.16 2019-05-14
- Improved Mojo::Headers to reject characters in header values that would
corrupt the HTTP message.
- Fixed getopt function in Mojo::Util to behave more like GetOptionsFromArray.
(jberger, reneeb)

==== plasma-framework ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Too many changes to list here

==== polkit ====
Subpackages: libpolkit0 typelib-1_0-Polkit-1_0

- Use systemd_ordering instead of systemd_requires: strictly
speaking, polkit does not require systemd to be present. Just
that when we install on a system with systemd (e.g outside
containers) we would want systemd to be present before
installing polkit. Help also reduce a cycle without special hacks
in systemd.spec.

==== prison-qt5 ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Aztec: Fix padding if the last partial codeword is all one bits

==== purpose ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Ignore some qtcreator file

==== python-Pygments ====
Version update (2.3.1 -> 2.4.0)

- Update to 2.4.0
* Add solarized style
* Add support for Markdown reference-style links
* Add license information to generated HTML/CSS files
* Change ANSI color names
* Fix catastrophic backtracking in the bash lexer
* Fix documentation failing to build using Sphinx 2.0
* Fix incorrect links in the Lisp and R lexer documentation
* Fix rare unicode errors on Python 2.7
* Fix lexers popping from an empty stack
* TypoScript uses .typoscript now
* Updated Trove classifiers and pip requirements

==== rdma-core ====
Version update (23.0 -> 23.1)
Subpackages: libibverbs libibverbs1 libmlx4-1 libmlx5-1 librdmacm1

- Update to rdma-core v23.1
- No release notes available
- Replace prebuild-pandoc.sh by post_download.sh to patch the spec
file form upstream for OBS setup

==== rubygem-ffi ====
Version update (1.10.0 -> 1.11.0)

- updated to version 1.11.0
see installed CHANGELOG.md
[#] Added
* Add ability to disable or force use of system libffi.
[#669] Use like gem inst ffi -- --enable-system-libffi
* Add ability to call FFI callbacks from outside of FFI call frame. #584
* Add proper documentation to FFI::Generator and ::Task
* Add gemspec metadata. #696, #698
[#] Changed
* Fix stdcall on Win32. #649, #669
* Fix load paths for FFI::Generator::Task
* Fix FFI::Pointer#read_string(0) to return a binary String. #692
* Fix benchmark suite so that it runs on ruby-2.x
* Move FFI::Platform::CPU from C to Ruby. #663
* Move FFI::StructByReference to Ruby. #681
* Move FFI::DataConverter to Ruby (#661)
* Various cleanups and improvements of specs and benchmarks
[#] Removed
* Remove ruby-1.8 and 1.9 compatibility code. #683
* Remove unused spec files. #684

==== solid ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* [Fstab] Add support for non-network filesystems
* [FsTab] Add cache for device file system type
* [Fstab] Preparatory work for enabling filesystems beyond NFS/SMB
* Fix no member named 'setTime_t' in 'QDateTime' error while building
(kde#405554)

==== sonnet ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== suil ====
Version update (0.10.0 -> 0.10.2)

- Update to version 0.10.2
* Fix resizing and add idle and update rate support for Qt5 in
Gtk2
* Fix various issues with Qt5 in Gtk2
- Use python3 for build
- Added suil-wrong-cocoa-detection.patch
- Spec cleanup

==== syndication ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== syntax-highlighting ====
Version update (5.57.0 -> 5.58.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- Changes since 5.57.0:
* Use override as for other virtual method in this module
* Add syntax highlighting for fish shell
* AppArmor: don't highlight variable assignments and alias rules within
profiles

==== sysprof ====
Subpackages: sysprof-lang

- Replace systemd-gtk BuildRequires with pkgconfig(systemd): make
the build cheaper by not having to wait for the 'real' systemd
package to have built, but allow to use systemd-mini. The change
in the stack causing this was polkit dropping its hard dep on
systemd.
- Add systemd-gtk BuildRequires: Now needed due to changes
elsewhere in the stack.

==== systemd ====
Version update (241 -> 242)
Subpackages: libsystemd0 libsystemd0-32bit libudev-devel libudev1
libudev1-32bit systemd-32bit systemd-logger systemd-sysvinit udev

- Import commit 9984a86d0d2259d54c7060f9c09f214202b4efa7
f2459bf373 random-util: eat up bad RDRAND values seen on AMD CPUs
c90a2e9793 util-lib: fix a typo in rdrand
4db1cc9d46 random-util: rename "err" to "success"
981a62a102 random-util: hash AT_RANDOM getauxval() value before using it
64a9c3d918 random-util: use gcc's bit_RDRND definition if it exists
c5d6ecfdca random-util: rename RANDOM_DONT_DRAIN ? RANDOM_MAY_FAIL
298d13df7e network: remove redunant link name in message
77cbde31f2 hwdb: Align airplane mode toggle key mapping for all Acer series
460f03794e Revert "hwdb: Apply Acer mappings to all Gateway and Packard Bell
models"
fe9271ad84 test: return a non-zero return code when 'nobody' user doesn't
exist
29d355e755 fstab-generator: Prevent double free of reused FILE*
f30f1adc11 meson: make source files including nspawn-settings.h depend on
libseccomp
84bab914b8 alloc-util: don't use malloc_usable_size() to determine allocated
size
5240972d8d units: drop reference to sushell man page
0a26de5e33 codespell: fix spelling errors
582de105c8 nspawn-expose-ports: fix a typo in error message
- Buildrequire polkit so /usr/share/polkit-1/rules.d has an owner
Otherwise the "post build checks" would complain and would force
systemd to own this directory. The owner should still be "polkit"
and the perms should be in sync with the perm set by polkit
itself.
- Add debug-only-remove-new-policies.patch
A temporary patch to suppress the new DBUS methods introduced by
v242 until they are reviewed and whitelisted by the secteam.
- Add a comment explaining why static enablement symlinks in /etc are suppressed
Also remove any /etc/systemd/system/*.requires/ symlinks for the
same reason.
- preset remote-cryptsetup.target during package installation
This target is supposed to be part of the targets that should be
enabled (or not depending on the presets) at package installation.
- Upgrade to v242 (commit 071c380dcc434dca2a0c8b6de0519cc9e816c6d6)
See https://github.com/openSUSE/systemd/blob/SUSE/v242/NEWS for
details.
- Drop "BuildRequires: -post-build-checks" from the specfile (bsc#1130230)
The syntax of this directive is obsolete and should be replaced by
"#!BuildIgnore: post-build-checks".
However there's no good reasons to disable these SUSE extra checks,
so let's re-enable them and fix the few errors it detected.

==== threadweaver ====
Version update (5.57.0 -> 5.58.0)

- Update to 5.58.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.58.0.php
- No code changes since 5.57.0

==== util-linux ====
Version update (2.33.1 -> 2.33.2)
Subpackages: libblkid-devel libblkid1 libblkid1-32bit libfdisk1 libmount1
libmount1-32bit libsmartcols1 libuuid-devel libuuid1 libuuid1-32bit
util-linux-lang

- Update to version 2.33.2 (bsc#1134337):
* agetty: Fix 8-bit processing in get_logname() (bsc#1125886).
* mount: Fix "mount" output for net file systems (bsc#1122417).
* Many Other fixes, see
https://www.kernel.org/pub/linux/utils/util-linux/v2.33/v2.33.2-ReleaseNotes
- Fix problems in reading of login.defs values (bsc#1121197,
util-linux-login_defs-priority1.patch,
util-linux-login_defs-priority2.patch,
util-linux-login_defs-SYS_UID.patch).
- Perform one-time reset of /etc/default/su (bsc#1121197).
- Add virtual symbols for login.defs compatibility (bsc#1121197).
- Add login.defs safety check util-linux-login_defs-check.sh
(bsc#1121197).

==== util-linux-systemd ====
Version update (2.33.1 -> 2.33.2)

- Update to version 2.33.2 (bsc#1134337):
* agetty: Fix 8-bit processing in get_logname() (bsc#1125886).
* mount: Fix "mount" output for net file systems (bsc#1122417).
* Many Other fixes, see
https://www.kernel.org/pub/linux/utils/util-linux/v2.33/v2.33.2-ReleaseNotes
- Fix problems in reading of login.defs values (bsc#1121197,
util-linux-login_defs-priority1.patch,
util-linux-login_defs-priority2.patch,
util-linux-login_defs-SYS_UID.patch).
- Perform one-time reset of /etc/default/su (bsc#1121197).
- Add virtual symbols for login.defs compatibility (bsc#1121197).
- Add login.defs safety check util-linux-login_defs-check.sh
(bsc#1121197).

==== yast2 ====
Version update (4.2.2 -> 4.2.3)
Subpackages: yast2-logs

- Make sure the wizard buttons always remain visible in NCurses
(bsc#1133367)
- 4.2.3

==== yast2-iscsi-client ====
Version update (4.1.7 -> 4.2.0)

- iscsiadm may have exit code 21 on success (bsc#1131049)
- 4.2.0

==== yast2-ruby-bindings ====
Version update (4.1.4 -> 4.2.1)

- Fixup the textdomain change so that yast2.rpm builds (bsc#1130822)
- 4.2.1
- Raise (an Internal Error) if no textdomain is declared for
a translatable text and Y2STRICTTEXTDOMAIN is in the environment
(bsc#1130822)
- 4.2.0

==== yast2-trans ====
Version update (84.87.20190504.69fe46292b -> 84.87.20190511.bc4a9329cc)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv
yast2-trans-ta yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi
yast2-trans-wa yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20190511.bc4a9329cc:
* Fixed errors in format strings
* Fixed errors in format strings (bsc#1134685)
* Fixed errors in format strings: %1 %d mismatch
* Fixed errors in format strings: %1 vs % 1
* Fixed errors in format strings: %1 vs %{device}
* Fixed errors in format strings: %1$s vs %2$s confusion
* Fixed errors in format strings: %1{foo} %{foo}
* Fixed errors in format strings: %2 vs 2%
* Fixed errors in format strings: mistaken duplication
* Fixed errors in format strings: spurious %1 duplication
* Fixed errors in format strings: typo
* New POT for text domain 'base'.
* New POT for text domain 'control'.
* New POT for text domain 'journal'.
* New POT for text domain 'samba-client'.
* New POT for text domain 'services-manager'.
* New POT for text domain 'storage'.
* Translated using Weblate (Catalan)
* Translated using Weblate (Czech)
* Translated using Weblate (Danish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Finnish)
* Translated using Weblate (German)
* Translated using Weblate (Japanese)
* Translated using Weblate (Portuguese (Brazil))

==== yast2-users ====
Version update (4.2.0 -> 4.2.1)

- Fix the user creation in the installed systems, obeying the
decision about creating the user's home as a plain directory
or as a Btrfs subvolume (bsc#1134970).
- 4.2.1


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages