Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
Re: [opensuse-factory] Repository 'openSUSE-20181126-0 (20190320)' is invalid
Hello,

Am Montag, 29. April 2019, 20:39:59 CEST schrieb Oleksii Vilchanskyi:
Can do I prevent this from happening in the future? I see that it's
possible to set priorities on repos, can you recommend any strategy
with that? I would like zypper to pull from oss if there is a package
in oss, even if older, and only then look at other repos.

First of all: lowest priority number will win.

Default priority is 99, and I'd recommend to keep that for the main
repos (oss, update, non-oss, debug).

For the other repos, use a higher number, maybe 120.

This should fulfil your wish, with one exception: if one of the packages
in the extra repos requires a newer version than a package in Tumbleweed
provides, then this newer version will be installed, even if it's in an
extra repo.

BTW: It seems you accidently removed the Tumbleweed update repo during
your cleanup. Please re-add it. It's rarely used, but if it contains an
important quickfix, you really want to have it ;-)


Regards,

Christian Boltz
--
Eine Katze hat einen Schwanz mehr als keine Katze. Keine Katze hat
zwei Schwänze, also hat eine Katze drei Schwänze.
[Bernd Brodesser in suse-linux]



--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >