Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190426 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190426

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.8.40 -> 7.0.8.41)
MozillaFirefox-branding-openSUSE (45 -> 60)
akonadi-calendar (18.12.3 -> 19.04.0)
akonadi-calendar-tools (18.12.3 -> 19.04.0)
akonadi-contact (18.12.3 -> 19.04.0)
akonadi-import-wizard (18.12.3 -> 19.04.0)
akonadi-mime (18.12.3 -> 19.04.0)
akonadi-notes (18.12.3 -> 19.04.0)
akonadi-search (18.12.3 -> 19.04.0)
akonadi-server (18.12.3 -> 19.04.0)
akregator (18.12.3 -> 19.04.0)
alsa
ark (18.12.3 -> 19.04.0)
baloo5-widgets (18.12.3 -> 19.04.0)
binutils
bzip2
calendarsupport (18.12.3 -> 19.04.0)
dolphin (18.12.3 -> 19.04.0)
dragonplayer (18.12.3 -> 19.04.0)
eventviews (18.12.3 -> 19.04.0)
fuse
glusterfs
grantleetheme (18.12.3 -> 19.04.0)
gwenview5 (18.12.3 -> 19.04.0)
incidenceeditor (18.12.3 -> 19.04.0)
kaccounts-integration (18.12.3 -> 19.04.0)
kaccounts-providers (18.12.3 -> 19.04.0)
kaddressbook (18.12.3 -> 19.04.0)
kalarmcal (18.12.3 -> 19.04.0)
kamera (18.12.3 -> 19.04.0)
kate (18.12.3 -> 19.04.0)
kcalc (18.12.3 -> 19.04.0)
kcalcore (18.12.3 -> 19.04.0)
kcalutils (18.12.3 -> 19.04.0)
kcharselect (18.12.3 -> 19.04.0)
kcolorchooser (18.12.3 -> 19.04.0)
kcontacts (18.12.3 -> 19.04.0)
kdav (18.12.3 -> 19.04.0)
kdenetwork4-filesharing (18.12.3 -> 19.04.0)
kdepim-addons (18.12.3 -> 19.04.0)
kdepim-apps-libs (18.12.3 -> 19.04.0)
kdepim-runtime (18.12.3 -> 19.04.0)
kdialog (18.12.3 -> 19.04.0)
khelpcenter5 (18.12.3 -> 19.04.0)
kidentitymanagement (18.12.3 -> 19.04.0)
kimap (18.12.3 -> 19.04.0)
kio-extras5 (18.12.3 -> 19.04.0)
kio_audiocd (18.12.3 -> 19.04.0)
kitinerary (18.12.3 -> 19.04.0)
kldap (18.12.3 -> 19.04.0)
kleopatra (18.12.3 -> 19.04.0)
kmag (18.12.3 -> 19.04.0)
kmail (18.12.3 -> 19.04.0)
kmail-account-wizard (18.12.3 -> 19.04.0)
kmailtransport (18.12.3 -> 19.04.0)
kmbox (18.12.3 -> 19.04.0)
kmime (18.12.3 -> 19.04.0)
kmousetool (18.12.3 -> 19.04.0)
knotes (18.12.3 -> 19.04.0)
kompare (18.12.3 -> 19.04.0)
konsole (18.12.3 -> 19.04.0)
kontact (18.12.3 -> 19.04.0)
kontactinterface (18.12.3 -> 19.04.0)
kopete (18.12.3 -> 19.04.0)
korganizer (18.12.3 -> 19.04.0)
kpimtextedit (18.12.3 -> 19.04.0)
kpkpass (18.12.3 -> 19.04.0)
kruler (18.12.3 -> 19.04.0)
ksmtp (18.12.3 -> 19.04.0)
ktnef (18.12.3 -> 19.04.0)
kwalletmanager5 (18.12.3 -> 19.04.0)
ldb (1.4.3 -> 1.5.4)
libdrm (2.4.97 -> 2.4.98)
libgravatar (18.12.3 -> 19.04.0)
libkcddb (18.12.3 -> 19.04.0)
libkcompactdisc (18.12.3 -> 19.04.0)
libkdcraw (18.12.3 -> 19.04.0)
libkdepim (18.12.3 -> 19.04.0)
libkexiv2 (18.12.3 -> 19.04.0)
libkgapi (18.12.3 -> 19.04.0)
libkipi (18.12.3 -> 19.04.0)
libkleo (18.12.3 -> 19.04.0)
libkomparediff2 (18.12.3 -> 19.04.0)
libksane (18.12.3 -> 19.04.0)
libksieve (18.12.3 -> 19.04.0)
libqt5-qtbase (5.12.2 -> 5.12.3)
libqt5-qtconnectivity (5.12.2 -> 5.12.3)
libqt5-qtdeclarative (5.12.2 -> 5.12.3)
libqt5-qtgraphicaleffects (5.12.2 -> 5.12.3)
libqt5-qtimageformats (5.12.2 -> 5.12.3)
libqt5-qtlocation (5.12.2 -> 5.12.3)
libqt5-qtmultimedia (5.12.2 -> 5.12.3)
libqt5-qtnetworkauth (5.12.2 -> 5.12.3)
libqt5-qtquickcontrols (5.12.2 -> 5.12.3)
libqt5-qtquickcontrols2 (5.12.2 -> 5.12.3)
libqt5-qtscript (5.12.2 -> 5.12.3)
libqt5-qtsensors (5.12.2 -> 5.12.3)
libqt5-qtserialport (5.12.2 -> 5.12.3)
libqt5-qtspeech (5.12.2 -> 5.12.3)
libqt5-qtsvg (5.12.2 -> 5.12.3)
libqt5-qttools (5.12.2 -> 5.12.3)
libqt5-qttranslations (5.12.2 -> 5.12.3)
libqt5-qtvirtualkeyboard (5.12.2 -> 5.12.3)
libqt5-qtwayland (5.12.2 -> 5.12.3)
libqt5-qtwebchannel (5.12.2 -> 5.12.3)
libqt5-qtwebengine (5.12.2 -> 5.12.3)
libqt5-qtwebsockets (5.12.2 -> 5.12.3)
libqt5-qtx11extras (5.12.2 -> 5.12.3)
libqt5-qtxmlpatterns (5.12.2 -> 5.12.3)
mailcommon (18.12.3 -> 19.04.0)
mailimporter (18.12.3 -> 19.04.0)
mbox-importer (18.12.3 -> 19.04.0)
messagelib (18.12.3 -> 19.04.0)
mobipocket (18.12.3 -> 19.04.0)
myspell-dictionaries (20181025 -> 20190423)
nodejs10 (10.15.2 -> 10.15.3)
okular (18.12.3 -> 19.04.0)
package-update-indicator
pim-data-exporter (18.12.3 -> 19.04.0)
pim-sieve-editor (18.12.3 -> 19.04.0)
pimcommon (18.12.3 -> 19.04.0)
pipewire
python-requests
quagga
samba (4.9.4+git.138.e50f45d83ad -> 4.10.2+git.78.0c89af72312)
signon-plugin-oauth2
spectacle (18.12.3 -> 19.04.0)
sssd (2.0.0 -> 2.1.0)
talloc (2.1.14 -> 2.1.16)
tdb (1.3.16 -> 1.3.18)
tevent (0.9.37 -> 0.9.39)
usbmuxd
vim (8.1.1137 -> 8.1.1198)

=== Details ===

==== ImageMagick ====
Version update (7.0.8.40 -> 7.0.8.41)
Subpackages: ImageMagick-config-7-SUSE ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI6 libMagickWand-7_Q16HDRI6 perl-PerlMagick

- version update to 7.0.8.41
* Fixed a number of issues (reference
https://github.com/ImageMagick/ImageMagick/issues).
* Honor SOURCE_DATE_EPOCH environment variable (reference
https://github.com/ImageMagick/ImageMagick/pull/1496/).
* Standardize on UTC time for any image format timestamp.
* Add MagickAutoThresholdImage(), MagickCannyEdgeImage(),
MagickComplexImages(), MagickConnectedComponentsImage(),
MagickHoughLineImage(), MagickKuwaharaImage(), MagickLevelizeImageColors(),
MagickLevelImageColors(), MagickMeanShiftImage(), MagickPolynomialImage(),
MagickRangeThresholdImage(), MagickSetSeed(), MagickWaveletDenoiseImage()
methods to MagickWand API.
-bsc#1133110 - Remove jasper dependency from ImageMagick

==== MozillaFirefox-branding-openSUSE ====
Version update (45 -> 60)

- bump version to 60 for SLE compatibility (bsc#1128316)
- removed intl.locale.matchOS
* it's not used in recent versions and it was set in the general
openSUSE Firefox package since 2011

==== akonadi-calendar ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Fix crash due to using an attribute from a collection that went out of scope
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Fix some clazy warning
* Remove QT_CHECK

==== akonadi-calendar-tools ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-calendar-tools-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix minor Doxygen issues
* Remove space as it's not necessary now
* Remove kdelibs4support
* use nullptr
* Initialize pointer

==== akonadi-contact ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* contact-editor/.../CMakeLists.txt - don't build in nicknamewidget
* Workaround qt5.13 bug
* Fix broken unittest
* Make attribute const
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Reduce duplicate code
* Make it compile against qt5.13
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Add support for "PROFILE" web site as GMail has.
* Add support for QQ protocol
* Increase version here too
* Fix some clazy warning
* Remove QT_CHECK
* Minor: Fix string according to KDE HIG

==== akonadi-import-wizard ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== akonadi-mime ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== akonadi-notes ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== akonadi-search ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Bump versions in BuildRequires for KF5 libraries matching the
specified versions in CMakeLists.txt, to force correct build order.
- Add explicit BuildRequires for kdbusaddons-devel
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Make attribute const
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix some clazy watning
* Port Q_FOREACH
* Use KF5_MIN_VERSION instead of KF5_VERSION
* Remove QT_CHECK
* Make sure xapian.h is always included first

==== akonadi-server ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* ItemSync: skip handling remote items if local changes failed
* autotests: remove unused variables
* Fix compiler warning about invalid varargs usage in macro
* Remove unused member fetchAllAttributes in CollectionFetchScope
* Fix the Akonadi detection with older CMake versions
* Add unittest for clearPayload. Unfortunately it passes :-)
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Don't install unexported class
* Fix handling of collectionChanged() in AgentBase (kde#403642)
* Fix unhandled exception from DataStream::operator<<
* Fix collection detaching at the wrong time in attribute()
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here
- Dropped patches, now upstream:
* fix-regression-when-updating-attributes.patch
* fix-collection-detaching.patch

==== akregator ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akregator-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== alsa ====
Subpackages: libasound2 libasound2-32bit

- Move definition of _lto_cflags into %build.
- Disable LTO (boo#1133086).

==== ark ====
Version update (18.12.3 -> 19.04.0)
Subpackages: ark-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Handle locked RAR archives (kde#368851)
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* clirar: Remove double backslashes in isPasswordPrompt()
* Fix progress info for CreateJob (kde#382599)
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here
- Refreshed patches:
* lower-libarchive-minimum-version.patch

==== baloo5-widgets ====
Version update (18.12.3 -> 19.04.0)
Subpackages: baloo5-widgets-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* [tagsaction] Don't crash on multiple files (kde#401733)
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Fix lengthy URLs in tooltips
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== binutils ====
Subpackages: binutils-devel

- Add rx-gas-padding-pr24464.patch: fix for PR24464.

==== bzip2 ====
Subpackages: libbz2-1 libbz2-1-32bit libbz2-devel

- add bzip2-1.0.6-CVE-2016-3189.patch to fix a heap use after
free vulnerability that was reported in bzip2recover [bsc#985657]
[CVE-2016-3189]

==== calendarsupport ====
Version update (18.12.3 -> 19.04.0)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Make it compile without foreach
* Workaround qt5.13 bug
* Make Attribute const, in preparation for akonadi being stricter
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Make it compile against qt5.13
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000

==== dolphin ====
Version update (18.12.3 -> 19.04.0)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Don't show "Open With" menu items for empty directories
* [DolphinMainWindowTest] Fix testNewFileMenuEnabled
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Move Safely Remove down in places context menu
* When hovering over a file on the not-focus view panel, the information
panel gets updated
* [InformationPanel] Hide the video when the preview is disabled, avoid
computing the preview when it is disabled
* Revert "Create a global launch shortcut (Meta+E)"
* [PhononWidget] Fix layout warning
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== dragonplayer ====
Version update (18.12.3 -> 19.04.0)
Subpackages: dragonplayer-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Port away from foreach
* Bump min deps to Qt 5.9 & KF 5.53
* Deploy ui.rc file via qrc
* Port away from deprecated QLayout::setMargin()
* Remove hardcoded spacing/margin from AdjustSizeButton
* Remove unused dragonlogo.png (also wrongly installed as kxmlgui data)
* Embed metadata json also with kparts plugin
* Remove outdated & usually ignored Version= entry from desktop file
* Enforce modern Qt API
* Use Qt-namespace signal/slot keywords
* Use consistently CamelCase includes for Qt classes
* Install kparts plugin into kf5/parts subdir
* Use more https in links
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Include phonon imclude dirs as SYSTEM, to avoid compiler checks
* Remove unused includes of cmake macros
* Use KF5_MIN_VERSION also for ECM, now that is part of KF
* Bump min cmake version to 3.0
* Use <gui> instead of deprecated <kpartgui>
* Use nullptr consistently
* Use override consistently
* Remove unneeded call of setOrganizationDomain, done by KAboutData later
* No need to repeat work of KAboutData::setupCommandLine()

==== eventviews ====
Version update (18.12.3 -> 19.04.0)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Workaround qt5.13 bug
* Make Attributes const, to prepare for akonadi changes
* Fix misuse of QColor API, the return value was ignored so
these lines were no-ops
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix compile against qt5.13
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Remove QT_CHECK

==== fuse ====
Subpackages: libfuse2

- Move definition of _lto_cflags into %build.
- Disable LTO (boo#1133101).

==== glusterfs ====
Subpackages: libgfapi0 libgfrpc0 libgfxdr0 libglusterfs0

- Move definition of _lto_cflags into %build.
- Disable LTO (boo#1133088).

==== grantleetheme ====
Version update (18.12.3 -> 19.04.0)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== gwenview5 ====
Version update (18.12.3 -> 19.04.0)
Subpackages: gwenview5-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Add HiDPI support for thumbnails
- Dropped patches, now upstream:
* 0001-Add-HiDPI-support-for-thumbnails.patch
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* HiDPI Support for Gwenview (kde#373178)
* Fix -Wreturn-type warning for jpeg version check
- Add upstream patch for HiDPI support in thumbnails (kde#373178):
* 0001-Add-HiDPI-support-for-thumbnails.patch
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix compilation in some systems
* Touch support for Gwenview
* Deprecated--
* Remove deprecated method
* [MainWindow] Navigate through mouse forward/back buttons
* Compile tests files with enabled exceptions, required for exiv2 0.27
* Allow Gwenview to be able to open .kra (Krita) files
* Set the same image mime types in all desktop files
* Add mime types for raw image formats to desktop file
* Create shortcut to focus navigator bar
* Use semantically correct restoration icon
* Use user-trash icon for Trash action (kde#391078)
* Port to new connect api
* Use Ctrl+i to trigger a name filter, which matches Dolphin (kde#386531)
* Ignore files
* Const'ify, add const'ref found by clazy
* Bump max thumbnail size to 512px
* Compile more files with enabled exceptions, required for exiv2 0.27
* Use forward declaration for Exiv2::Image, port to std::unique_ptr
* Use FlowLayout for Crop toolbar
* Fix mem leak found by asan
* [ThumbnailView] Fix mouse buttons handling
- Dropped patches, now upstream:
* 0001-Compile-more-files-with-enabled-exceptions-required-.patch
* 0002-Use-forward-declaration-for-Exiv2-Image-port-to-std-.patch

==== incidenceeditor ====
Version update (18.12.3 -> 19.04.0)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Compile without foreach
* Don't install unexported class
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* increase version
* KCombobox--
* Make it compile against qt5.13
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Fix some clazy warning
* Remove QT_CHECK
* Minor: Respect HIG for button title
* dialogdesktop: Add a lot more icons, fix layouts
* Fix minor EBN issues
* Fix minor typos and EBN issues

==== kaccounts-integration ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== kaccounts-providers ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kaccounts-providers-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== kaddressbook ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kaddressbook-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kalarmcal ====
Version update (18.12.3 -> 19.04.0)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the kholidays detection with older CMake versions.
* Add ignore file
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Minor comment fixes
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Turn nullptr into {} when initializing flags
* Use more nullptr
* Fix Doxygen list
* Fix minor Doxygen issues
* Replace nullptr which aren't pointers
* Minor: Use more nullptr
* Fix minor EBN issues and typo

==== kamera ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kamera-lang kio_kamera

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Remove deprecated method

==== kate ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kate-lang kate-plugins

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* improve comment
* fix handling of sub modules in git rely on ls-files --recurse-submodules,
there since end of 2016
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here
- Refreshed patches:
* 0001-Defuse-root-block.patch

==== kcalc ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kcalc-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kcalcore ====
Version update (18.12.3 -> 19.04.0)

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Fix compile, KCalCore doesn't depend on Qt5Widgets, so use Qt5Gui instead
* Workaround a Qt 5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* compile without foreach
* We use find_dependency, so we need to include CMakeFindDependencyMacro.
* Support static builds
* Add property for productId
* Fix some clazy warning

==== kcalutils ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the frameworks detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* it compiles fine without foreach
* Fix minor typos and EBN issues

==== kcharselect ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kcharselect-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix compile without foreach
* Do not duplicate work done by KAboutData::setupCommandLine()
* Use <gui> instead of deprecated <kpartgui>
* It compiles fine with strict compile flags
* Fix some clazy warning
* Use https here

==== kcolorchooser ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kcolorchooser-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* add appstream metainfo
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Increase version

==== kcontacts ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix kf5 lib with old CMake version
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Make compile: kcontacts doesn't include widgets, so use Qt5Gui_VERSION
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Compile without foreach
* Don't include newlines in address if only country is available
* Remove Q_REQUIRED_RESULT from assignment operator
* Increase version
* Use int here
* Fix minor typos and EBN issues

==== kdav ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kdav-lang libKPimKDAV5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix kf5 lib with old CMake version
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Remove QT_CHECK
* Fix minor EBN issues and typos

==== kdenetwork4-filesharing ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kdenetwork4-filesharing-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== kdepim-addons ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kdepim-addons-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix autotest
* Fix autotest
* Don't show a qwarning when we have an empty text
* Fix Bug 405434 - KMail crashes when trying to switch on add-blocker
(kde#405434)
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Allow to add text in subject too
* Fix insert special characters
* Allow to close grammar checker
* Convert to camelcase include
* Minor optimization
* Fix save adblock list name
* Fix Bug 405791 - Crash when clicking on a mail that contains vcard.vcf
attachment (kde#405791)
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kdepim-apps-libs ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kdepim-apps-libs-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Remove AkonadiCore from target include directories
* Remove unused void argument

==== kdepim-runtime ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kdepim-runtime-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Revert the kalarm changes and fix the race condition differently.
* IMAPResource: Defer task if we get disconnected during login
* Fix constness of Attributes, in preparation for changes in Akonadi
* Update the comment.
* Allow running the pimkolab tests.
* Try to fix the FreeBSD build when ECM_ENABLE_SANITIZERS is enabled.
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kdialog ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kdialog-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Use CamelCase includes for KF headers
* Ensure modern Qt code
* Bump min cmake dep to 3.0
* Add --imgbox and --imginputbox support for KDialog
* Fix some clazy warning
* Set window icon with --icon argument

==== khelpcenter5 ====
Version update (18.12.3 -> 19.04.0)
Subpackages: khelpcenter5-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Bump version number
* Fix opening URL's to help files
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Follow kde hig for the search field
* Add <launchable> entry to appdata
* No need to duplicate work done by KAboutData::setupCommandLine()
* Remove no longer used version header includes
* Respect BUILD_TESTING
* Use more https in links
* Use <gui> instead of deprecated <kpartgui>
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Fix clazy warning

==== kidentitymanagement ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the kcoreaddons detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Make it compile when we have kf5 < 5.57 (FOREACH)
* Convert to camelcase include
* Fix compile: replace foreach with std::remove_if + erase
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Fix minor typos
* Fix whatsthis
* Fix some clazy warning
* Fix minor typos

==== kimap ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kimap-lang libKF5IMAP5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the KF5CoreAddons detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Remove QT_CHECK
* Install NamespaceJob and RFCCodecs camelcase headers

==== kio-extras5 ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kio_audiocd ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kio_audiocd-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Use the correct MIME type for CDDB information.txt (kde#405783)
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix stat to actually recognize the info dir exists
* Use more https in links
* Include KDECMakeSettings & KDECompilerSettings first
* Use KF_MIN_VERSION also for ECM, given it's released as part of KF now
* Bump min cmake version to 3.0
* Remove not existing include dir
* Install kio binary into kf5/kio subdir, like other kio binaries
* Fix minor typos
* Add Audiocd KCM docs
* Use override as suggested by compiler
* Use tabs consistently, add some initialization (do not know if it works).
* Add Opus support for KIO AudioCD (kde#313768)
* Use more loose permissions for the ripped files (kde#203183)
* Fix KCM installation
* Fix minor typos and antics
* Add Mainpage.dox to test Doxygen documentation with Krazy

==== kitinerary ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix extraction of arrival/departure time for Brussels Airlines
* Add airline IATA code as trigger criteria for Brussels Airlines too
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Don't block airport name disambiguation on the "international" fragment
* Make the email parser handle all kinds of line breaks
* Normalize all place names, not just those of airports
* Extend Amadeus filter
* Support one more Lufthansa variation of this
* Support English BCD ical files too
* Fix compile, Qt5Widgets_VERSION isn't defined, use Qt5Core_VERSION instead
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kldap ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kldap-lang libKF5Ldap5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* It compiles fine without foreach
* Remove KCombobox
* Remove deprecated methods
* use isEmpty()

==== kleopatra ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kleopatra-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kmag ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kmag-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kmail ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix autotest
* Fix crash in autotest
* Fix Bug 406324 - Messages detected as scam are deleted when moved to trash
(kde#406324)
* Fix bug Bug 406324 - Messages detected as scam are deleted when moved to
trash
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Fix insert text even in subject
* Remove unused include
* When we double click on a message we must use the same settings
* Convert to camelcase include
* Fix Bug 405775 - 'Impossible to send email' notification is too intrusive
(kde#405775)
* Allow to insert emoticon in subject too
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kmail-account-wizard ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kmail-account-wizard-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Port to for(...:...)
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Update copyright

==== kmailtransport ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the kwallet detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Make it compile without foreach
* Make it compile against qt5.13
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Fix minor typos
* Fix minor EBN issues
* Remove QT_CHECK

==== kmbox ====
Version update (18.12.3 -> 19.04.0)

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Fix compile, Qt5Widgets_VERSION isn't defined, use Qt5Core_VERSION instead
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Make it compile without foreach
* Fix minor typos

==== kmime ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kmime-lang libKF5Mime5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Increase version
* Allow to detect attachment when mail use alternative
* Add more autotest
* Export kmime_codecs.h.
* It seems that it 's not used
* Add missing override
* parsedatetimetest: Fix -Wunused-result warning
* parsedatetimetest: Reformat code
* Use nullptr

==== kmousetool ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kmousetool-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix clazy warning

==== knotes ====
Version update (18.12.3 -> 19.04.0)
Subpackages: knotes-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Make it compiles against qt5.10
* They changed datastream for QFont...
* Fix constness of Attributes, in preparation for changes in akonadi
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kompare ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kompare-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Deploy ui.rc files via qrc files
* Port away from foreach
* Port away from deprecated QLayout::setMargin()
* Bump min deps to Qt 5.9 & KF 5.53
* Bump min Qt version to 5.6, as implied by KF min version 5.35
* Use KF5_MIN_VERSION also for ECM, now that it is released together
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Add JSON metadata to plugin binaries
* Install kparts plugins consistently to kf5/parts subdir

==== konsole ====
Version update (18.12.3 -> 19.04.0)
Subpackages: konsole-part konsole-part-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Fixes minor memory leaks
* Use QTEST_GUILESS_MAIN
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here
- Dropped patches, now upstream:
* Fix-bold-font.patch
* Add-special-support-for-block-characters.patch
* Extend-character-clipping-by-grouping-it-with-spaces.patch
* Improve-built-in-line_block-characters-drawing.patch
* Fix-ibeam-and-underline-cursor-rendering.patch

==== kontact ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kontact-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Make it compiles against qt5.13
* USe QStringLiteral
* Update copyright
* Fix minor EBN issues and typo

==== kontactinterface ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix kf5 lib with old CMake version
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Make it compiles without foreach
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000

==== kopete ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kopete-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix minor Doxygen issues
* Fix minor typos
* Add caption to the screenshot

==== korganizer ====
Version update (18.12.3 -> 19.04.0)
Subpackages: korganizer-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Don't install unexported class
* Workaround qt5.13 bug
* Fix constness of Attributes, in preparation for changes in Akonadi
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kpimtextedit ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Signal when there is a problem for loading emoticons
* Add missing emoticons
* Fix the ktextwidgets detection with older CMake versions.
* Add more emoticons
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Too many changes to list here
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== kpkpass ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKPimPkPass5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix kf5 lib with old CMake version
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* It compile fine without foreach
* Fix compile, Qt5Widgets_VERSION isn't defined, use Qt5Core_VERSION instead
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix some clazy warning
* Mark transitType property CONSTANT

==== kruler ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kruler-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Make it compile with qt5.13
* Bump min cmake dep to 3.0

==== ksmtp ====
Version update (18.12.3 -> 19.04.0)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the kcoreAddons detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* it compiles fine without foreach
* Fix some clazy warning
* Remove QT_CHECK

==== ktnef ====
Version update (18.12.3 -> 19.04.0)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Add platform information to the metainfo file. This information is required
within metainfo.yaml files when they are present, otherwise the CI system
cannot perform necessary checks and builds will fail.
* Fix minor typos

==== kwalletmanager5 ====
Version update (18.12.3 -> 19.04.0)
Subpackages: kwalletmanager5-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* it compiles fine without foreach
* Port to for(...:...)
* Use <gui> instead of deprecated <kpartgui>
* Remove deprecated method
* Silence some warnings
* remove some clazy warning
* Make it readable
* USe https here

==== ldb ====
Version update (1.4.3 -> 1.5.4)
Subpackages: libldb1 libldb1-32bit python3-ldb

- Update to 1.5.4
+ Fix standalone build of ldb.
+ C99 build fixes.
+ CVE-2019-3824 out of bounds read in wildcard compare (bug#13773)
- Update to 1.5.3
+ Avoid inefficient one-level searches (bug#13762)
+ The test api.py should not rely on order of entries in dict (bug#13772)
- Update to 1.5.2
+ dirsync: Allow arbitrary length cookies (bug #13686)
+ The build uses python3 by default: --extra-python would take
python2 now
+ To build with python2 only use:
PYTHON=python2 ./configure
PYTHON=python2 make
PYTHON=python2 make install

==== libdrm ====
Version update (2.4.97 -> 2.4.98)
Subpackages: libdrm-devel libdrm2 libdrm_amdgpu1 libdrm_intel1 libdrm_nouveau2
libdrm_radeon1

- Update to version 2.4.98
* This release adds marketing names for AMDGPU devices, a
fallback path in drmDevice for devices lacking OF data
and drmIsMaster API, amongst other changes.

==== libgravatar ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* compile without foreach
* Fix missing delete reply. Found by new Gammaray feature "network
* Fix forward declaration
* Install headers
* Fix autotests + split gravatarconfiguresettingsdialog
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000

==== libkcddb ====
Version update (18.12.3 -> 19.04.0)

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== libkcompactdisc ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Add .arcconfig
* Define _BSD_SOURCE for strdup and timerclear
* Include <strings.h> for strcasecmp
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix minor EBN issues

==== libkdcraw ====
Version update (18.12.3 -> 19.04.0)

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix the maintainer username.

==== libkdepim ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Fix order item when we load the first time. Otherwise we can
change order
* Add parent to widget
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* update version
* Make it compile against qt5.13
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Fix bug found by david avoid <foo <bla@xxxxxxx>>
* Fix check return value
* Extract widget.
* Remove QT_CHECK

==== libkexiv2 ====
Version update (18.12.3 -> 19.04.0)

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Fix building against exiv2-0.27 (kde#402644)
- Drop D17799-Fix_building_against_exiv2-0.27.diff. Fixed upstream.

==== libkgapi ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== libkipi ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Use CamelCase includes for KF headers
* Remove Qt module prefixes from includes
* Remove no longer existing subdir imageio from include_directories()
* Use nullptr
* Use consistently override, not Q_DECL_OVERRIDE
* Port ECMPackageConfigHelpers -> CMakePackageConfigHelpers
* Fix minor EBN issues and typos

==== libkleo ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Port to for(...:...) here
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== libkomparediff2 ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Use modern cmake add_test() signature
* Use non-deprecated KDEInstallDirs variables
* Be more precise about deps in the public interface
* Port away from foreach
* Find package Qt5 with COMPONENTS
* Bump min deps to Qt 5.9 & KF 5.53
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH

==== libksane ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5Sane5 libksane-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Bump version
* Fix zooming in/out with a touchpad
* Don't apply options change if scanning is in progress
* Static version of toQImageSilent()
* Fix mem leak found by asan
* Honor BUILD_TESTING
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Fix Windows CI build issues caused by startPreviewScan slot
* Minor fix to API docs
* Fix minor EBN issues and typos
* Export startPreviewScan slot

==== libksieve ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libksieve-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the syntax-highlighting detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Fix crash when we uncomment text
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Make it compiles against qt5.13
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* obsolete url
* Remove QT_CHECK

==== libqt5-qtbase ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5Concurrent5 libQt5Core5 libQt5DBus5 libQt5Gui5
libQt5Network5 libQt5OpenGL5 libQt5PrintSupport5 libQt5Sql5 libQt5Sql5-mysql
libQt5Sql5-sqlite libQt5Test5 libQt5Widgets5 libQt5Xml5
libqt5-qtbase-platformtheme-gtk3

- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.12.3/?h=v5.12.3
- Add fix-fixqt4headers.patch to use the include path used by our
Qt5 packages.

==== libqt5-qtconnectivity ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5Bluetooth5 libQt5Bluetooth5-imports libQt5Nfc5
libQt5Nfc5-imports libqt5-qtconnectivity-tools

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtconnectivity.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtdeclarative ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtdeclarative.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtgraphicaleffects ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtgraphicaleffects.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtimageformats ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtimageformats.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtlocation ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5Location5 libQt5Positioning5 libQt5PositioningQuick5

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtlocation.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtmultimedia ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtmultimedia.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtnetworkauth ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtnetworkauth.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtquickcontrols ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtquickcontrols.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtquickcontrols2 ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5QuickControls2-5 libQt5QuickTemplates2-5

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtquickcontrols2.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtscript ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtscript.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtsensors ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5Sensors5 libQt5Sensors5-imports

- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtsensors.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtserialport ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtserialport.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtspeech ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5TextToSpeech5 libqt5-qtspeech-plugin-speechd

- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtspeech.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtsvg ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtsvg.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qttools ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5Designer5 libQt5Help5 libqt5-qdbus libqt5-qtpaths

- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qttools.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qttranslations ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qttranslations.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtvirtualkeyboard ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5HunspellInputMethod5 libQt5VirtualKeyboard5
libqt5-qtvirtualkeyboard-hunspell

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtvirtualkeyboard.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtwayland ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5WaylandClient5 libQt5WaylandCompositor5

- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtwebchannel ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5WebChannel5 libQt5WebChannel5-imports

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebchannel.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtwebengine ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.12.3/?h=v5.12.3
- Refresh chromium-non-void-return.patch

==== libqt5-qtwebsockets ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5WebSockets5 libQt5WebSockets5-imports

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebsockets.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtx11extras ====
Version update (5.12.2 -> 5.12.3)

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtx11extras.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== libqt5-qtxmlpatterns ====
Version update (5.12.2 -> 5.12.3)
Subpackages: libQt5XmlPatterns5 libqt5-qtxmlpatterns-imports

- Update to 5.12.3:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtxmlpatterns.git/plain/dist/changes-5.12.3/?h=v5.12.3

==== mailcommon ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the kcompletion detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Remove -DQT_NO_FOREACH
* Don't install unexported class
* Workaround qt5.13 bug
* Stricter constness for Attributes, in preparation for changes in akonadi
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== mailimporter ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the karchive detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== mbox-importer ====
Version update (18.12.3 -> 19.04.0)
Subpackages: mbox-importer-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* It compile fine without foreach
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Update copyright

==== messagelib ====
Version update (18.12.3 -> 19.04.0)
Subpackages: messagelib-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* We need GUI support
* Fix crash in autotest
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Fix Bug 406208 - "#" in a title news then only a part of the
title is transmitted in subject of a mail (kde#406208)
* Try to fix string
* Add signal when we want to insert text
* Convert to camelcase include
* AttachmentUpdateJob needs to be exported even without BUILD_TESTING
* Fix includes
* Fix: no install not exported class
* Remove unused includes
* Don't install debug files + fix build
* Remove bad includes
* Don't install/export class when not necessary
* Don't install not exported symbol
* Make Attributes const in preparation for changes in akonadi
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== mobipocket ====
Version update (18.12.3 -> 19.04.0)

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* No code changes since 18.12.3

==== myspell-dictionaries ====
Version update (20181025 -> 20190423)
Subpackages: myspell-cs_CZ myspell-da_DK myspell-de myspell-de_DE myspell-el_GR
myspell-en myspell-en_GB myspell-en_US myspell-es myspell-es_ES myspell-fr_FR
myspell-hu_HU myspell-it_IT myspell-lightproof-en myspell-lightproof-hu_HU
myspell-lightproof-pt_BR myspell-lightproof-ru_RU myspell-pl_PL myspell-pt_BR
myspell-ru_RU

- Update to 20190423:
* Serbian dictionary updated
* Update af_ZA hunspell
* Update Spanish dictionary
* Update Slovenian dictionary
* Update Breton dictionary
* Update Galician dictionary

==== nodejs10 ====
Version update (10.15.2 -> 10.15.3)
Subpackages: nodejs10-devel npm10

- Add _constraints file to avoid OOM errors
- flaky_test_rerun.patch: rework patch to account for tests that
end with an exception and are not actually re-run...
- New upstream LTS version 10.15.3
* http: fix error check in Execute()
* stream: fix end-of-stream for HTTP/2
- fix_ci_tests.patch: refreshed

==== okular ====
Version update (18.12.3 -> 19.04.0)
Subpackages: okular-lang okular-spectre

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Update version
* Set Qt::AA_CompressTabletEvents attribute to avoid latency when scrolling
with a tablet (kde#399208)
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* No code changes since 19.03.80
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== package-update-indicator ====
Subpackages: package-update-indicator-lang

- Remove useless clang dependency

==== pim-data-exporter ====
Version update (18.12.3 -> 19.04.0)
Subpackages: pim-data-exporter-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- No code changes since 19.03.90
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Make it compiles without foreach
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Export kleopatracertificateselectiondialogrc too
* Add missing texttospeechrc
* Fix compile with Qt 5.13 and QT_DISABLE_DEPRECATED_BEFORE=0x060000
* Update copyright

==== pim-sieve-editor ====
Version update (18.12.3 -> 19.04.0)
Subpackages: pim-sieve-editor-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix show "go to line" menu entry
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Convert to camelcase include
* Workaround qt5.13 bug
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Make it compiles against qt5.13
* Fix copyright
* Remove this obsolete line

==== pimcommon ====
Version update (18.12.3 -> 19.04.0)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Fix the kconfig detection with older CMake versions.
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Fix crash when applying collection ACL changes (kde#405975)
* Make it compiles without foreach
* Remove extra margin
* Convert to camelcase include
* Fix: no install not exported class
* Workaround qt5.13 bug
* Stricter use of constness for Attribute, preparing for changes in akonadi
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here

==== pipewire ====

- Add patch to fix use of headers from C++:
* avoid-invalid-conversion-error-with-C++.patch

==== python-requests ====

- Do not hardcode version requirements in setup.py allowing us to
update and verify functionality on our own:
* requests-no-hardcoded-version.patch

==== quagga ====
Subpackages: libospf0 libospfapiclient0 libzebra1

- bsc#1130588: Require shadow instead of old pwdutils

==== samba ====
Version update (4.9.4+git.138.e50f45d83ad -> 4.10.2+git.78.0c89af72312)
Subpackages: libdcerpc-binding0 libdcerpc-binding0-32bit libdcerpc0
libdcerpc0-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0
libndr-nbt0-32bit libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit
libnetapi0 libnetapi0-32bit libsamba-credentials0 libsamba-credentials0-32bit
libsamba-errors0 libsamba-errors0-32bit libsamba-hostconfig0
libsamba-hostconfig0-32bit libsamba-passdb0 libsamba-passdb0-32bit
libsamba-policy0-python3 libsamba-util0 libsamba-util0-32bit libsamdb0
libsamdb0-32bit libsmbclient0 libsmbconf0 libsmbconf0-32bit libsmbldap2
libsmbldap2-32bit libtevent-util0 libtevent-util0-32bit libwbclient0
libwbclient0-32bit samba-client samba-client-32bit samba-doc samba-libs
samba-libs-32bit samba-libs-python3 samba-python3 samba-winbind
samba-winbind-32bit

- Update to samba-4.10.2:
+ CVE-2019-3870 (World writable files in
Samba AD DC private/ dir); (bso#13834).
+ CVE-2019-3880 (Save registry file outside share as
unprivileged user); (bso#13851).
+ py/kcc_utils: py2.6 compatibility; (bso#13837).
+ libcli: permit larger values of DataLength in
SMB2_ENCRYPTION_CAPABILITIES of negotiate response;
(bso#13869).
+ regfio: Improve handling of malformed registry hive files;
(bso#13840).
+ ctdb-version: Simplify version string usage; (bso#13789).
+ lib: Make fd_load work for non-regular files; (bso#13859).
+ dbcheck: in the middle of the tombstone garbage collection
causes replication failures,
dbcheck: add --selftest-check-expired-tombstones cmdline
option; (bso#13816).
+ ndr_spoolss_buf: Fix out of scope use of stack variable in
NDR_SPOOLSS_PUSH_ENUM_OUT(); (bso#13818).
+ s4/messaging: Fix undefined reference in linking
libMESSAGING-samba4.so; (bso#13854).
+ acl_read: Fix regression for empty lists; (bso#13836).
+ s4:dlz make b9_has_soa check dc=@ node; (bso#13841).
+ s3:client: Fix printing via smbspool backend with kerberos
auth; (bso#13832).
+ s4:librpc: Fix installation of Samba; (bso#13847).
+ s3:lib: Fix the debug message for adding cache entries;
(bso#13848).
+ s3:utils: Add 'smbstatus -L --resolve-uids' to show username;
(bso#13793).
+ s3:lib: Fix the debug message for adding cache entries;
(bso#13848).
+ s3:waf: Fix the detection of makdev() macro on Linux;
(bso#13853).
* ctdb-build: Drop creation of .distversion in tarball;
(bso#13789).
* ctdb-packaging: Test package requires tcpdump, ctdb package
should not own system library directory; (bso#13838).
- Update to samba-4.10.1:
+ py/kcc_utils: py2.6 compatibility; (bso#13837);
+ libcli: permit larger values of DataLength in
SMB2_ENCRYPTION_CAPABILITIES of negotiate response; (bso#13869);
+ regfio: Improve handling of malformed registry hive files; (bso#13840);
+ ctdb-version: Simplify version string usage; (bso#13789);
+ lib: Make fd_load work for non-regular files; (bso#13859);
+ dbcheck in the middle of the tombstone garbage collection causes
replication failures, dbcheck: add --selftest-check-expired-tombstones
cmdline option; (bso#13816);
+ ndr_spoolss_buf: Fix out of scope use of stack variable in
NDR_SPOOLSS_PUSH_ENUM_OUT(); (bso#13818);
+ s4/messaging: Fix undefined reference in linking
libMESSAGING-samba4.so; (bso#13854);
+ acl_read: Fix regression for empty lists; (bso#13836);
+ s4:dlz make b9_has_soa check dc=@ node; (bso#13841);
+ s3:client: Fix printing via smbspool backend with kerberos auth;
(bso#13832);
+ s4:librpc: Fix installation of Samba; (bso#13847);
+ s3:lib: Fix the debug message for adding cache entries; (bso#13848);
+ s3:utils: Add 'smbstatus -L --resolve-uids' to show username; (bso#13793);
+ s3:lib: Fix the debug message for adding cache entries; (bso#13848);
+ s3:waf: Fix the detection of makdev() macro on Linux; (bso#13853);
+ ctdb-build: Drop creation of .distversion in tarball; (bso#13789);
+ ctdb-packaging: Test package requires tcpdump, ctdb package
should not own system library directory; (bso#13838);
- Update to samba-4.10.0:
+ s4-server: Open and close a transaction on sam.ldb at startup; (bso#13760);
+ access_check_max_allowed() doesn't process "Owner Rights" ACEs; (bso#13812);
+ s4/scripting/bin: Open unicode files with utf8 encoding and write
+ unicode string.
+ sambaundoguididx: Use the right escaped oder unescaped sam ldb
files; (bso#13759);
+ Fix idmap cache pollution with S-1-22- IDs on winbind hickup; (bso#13813);
+ passdb: Update ABI to 0.27.2.
+ lib/winbind_util: Add winbind_xid_to_sid for --without-winbind; (bso#13813);
+ lib:util: Move debug message for mkdir failing to log level 1; (bso#13823);
- Update to samba-4.9.5
+ audit_logging: Remove debug log header and JSON Authentication:
prefix; (bso#13714);
+ Fix upgrade from 4.7 (or earlier) to 4.9; (bso#13760);
+ s3: lib: nmbname: Ensure we limit the NetBIOS name correctly; (bso#
CID: 1433607; (bso#11495);
+ smbd: uid: Don't crash if 'force group' is added to an existing
share connection; (bso#13690);
+ s3: VFS: vfs_fruit. Fix the NetAtalk deny mode compatibility
code; (bso#13770);
+ s3: SMB1 POSIX mkdir does case insensitive name lookup; (bso#13803);
+ s3:utils/smbget fix recursive download with empty source
directories; (bso#13199);
+ samba-tool drs showrepl: Do not crash if no dnsHostName found; (bso#13716);
+ s3:libsmb: cli_smb2_list() can sometimes fail initially on a
connection; (bso#13736);
+ join: Throw CommandError instead of Exception for simple errors;
(bso#13747);
+ ldb: Avoid inefficient one-level searches; (bso#13762);
+ s3: libsmb: use smb2cli_conn_max_trans_size() in
cli_smb2_list(); (bso#13736);
+ tldap: Avoid use after free errors; (bso#13776);
+ Fix idmap xid2sid cache churn; (bso#13802);
+ access_check_max_allowed() doesn't process "Owner Rights" ACEs; (bso#13812);
+ s3-smbd: Avoid assuming fsp is always intact after close_file
call; (bso#13720);
+ s3-vfs-fruit: Add close call; (bso#13725);
+ s3-smbd: Use fruit:model string for mDNS registration; (bso#13746);
+ s3-vfs: add glusterfs_fuse vfs module; (bso#13774);
+ printing: Check lp_load_printers() prior to pcap cache update; (bso#13766);
+ vfs_ceph: vfs_ceph strict_allocate_ftruncate calls (local FS)
ftruncate and fallocate; (bso#13807);
+ lib/audit_logging: Actually create talloc; (bso#13737);
+ netcmd/user: python[3]-gpgme unsupported and replaced by
python[3]-gpg; (bso#13728);
+ dns: Changing onelevel search for wildcard to subtree; (bso#13738);
+ samba-tool: Don't print backtrace on simple DNS errors; (bso#13721);
+ sambaundoguididx: Use the right escaped oder unescaped sam ldb
files; (bso#13759);
+ ctdb: Print locks latency in machinereadable stats; (bso#13742);
+ messages_dgm: Messaging gets stuck when pids are recycled; (bso#13786);
+ audit_logging: auth_json_audit required auth_json; (bso#13715);
+ man pages: Document prefork process model; (bso#13765);
+ CVE-2019-3824 ldb: Release ldb 1.4.6; (bso#13773);
+ s3:auth: ignore create_builtin_guests() failing without a valid
idmap configuration; (bso#13697);
+ s3:auth_winbind: Ignore a missing winbindd as NT4 PDC/BDC
without trusts; (bso#13722);
+ s3:auth_winbind: return NT_STATUS_NO_LOGON_SERVERS if winbindd
is not available; (bso#13723);
+ s4:server: Add support for 'smbcontrol samba shutdown' and
'smbcontrol <pid> debug/debuglevel'; (bso#13752);
+ Python: Ensure ldb.Dn can doesn't rencoded str with py2; (bso#13616);
+ vfs_glusterfs: Adapt to changes in libgfapi signatures; (bso#13330);
+ s3-vfs: Use ENOATTR in errno comparison for getxattr; (bso#13774);
+ notifyd: Fix SIGBUS on sparc; (bso#13704);
+ waf: Check for libnscd; (bso#13787);
+ s3:vfs: Correctly check if OFD locks should be enabled or not; (bso#13770);
+ lib/util: Count a trailing line that doesn't end in a newline; (bso#13717);
+ Recovery lock bug fixes; (bso#13800);
+ s3: net: Do not set NET_FLAGS_ANONYMOUS with -k; (bso#13726);
+ s3:libsmb: Honor disable_netbios option in smbsock_connect_send;
(bso#13727);
+ vfs_fileid: Fix get_connectpath_ino; (bso#13741);
+ vfs_fileid: Fix fsname_norootdir algorithm; (bso#13744);

==== signon-plugin-oauth2 ====

- Don't treat use of deprecated declarations as error to fix build
against Qt 5.13

==== spectacle ====
Version update (18.12.3 -> 19.04.0)
Subpackages: spectacle-lang

- Update to 19.04.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-19.04.0.php
- Changes since 19.03.90:
* Change default compression quality from 90 to 89
- Update to 19.03.90
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-rc.php
- Changes since 19.03.80:
* Add missing QMimeData include to fix compilation on older Qt versions
* Make "Quit after copy" feature work (kde#393708)
* Change i18n of filename formatting options
- Update to 19.03.80
* New feature release
* For more details please see:
* https://kde.org/announcements/announce-applications-19.04-beta.php
- Changes since 18.12.3:
* Too many changes to list here
- Add 0001-Use-qdbus-qt5-instead-of-qdbus.patch to ensure the right
qdbus command is used by spectacle

==== sssd ====
Version update (2.0.0 -> 2.1.0)
Subpackages: libnfsidmap-sss libsss_certmap0 libsss_idmap0 libsss_nss_idmap0
sssd-32bit sssd-krb5-common sssd-ldap

- Update to new upstream release 2.1.0
* Any provider can now match and map certificates to user
identities.
* pam_sss can now be configured to only perform Smart Card
authentication or return an error if this is not possible.
* pam_sss can also prompt the user to insert a Smart Card if,
during an authentication it is not available.
* A new configuration option ad_gpo_implicit_deny was added.
This option (when set to True) can be used to deny access to
users even if there is not applicable GPO.
* The dynamic DNS update can now batch DNS updates to include
all address family updates in a single transaction.

==== talloc ====
Version update (2.1.14 -> 2.1.16)
Subpackages: libtalloc2 libtalloc2-32bit python3-talloc

- Update to version 2.1.16
+ Fix standalone build of talloc.
- Update to version 2.1.15
+ Deprecate talloc_set_memlimit() and talloc_autofree_context()
+ Fix undefined behavior in talloc_memdup
+ The build uses python3 by default:
+ --extra-python would take python2 now
+ To build with python2 only use:
PYTHON=python2 ./configure
PYTHON=python2 make
PYTHON=python2 make install

==== tdb ====
Version update (1.3.16 -> 1.3.18)
Subpackages: libtdb1 libtdb1-32bit python3-tdb

- Update to 1.3.18
+ Fix build problems with older python versions.
+ C99 build fixes.
+ Fix standalone build of tdb.
- Update to 1.3.17

==== tevent ====
Version update (0.9.37 -> 0.9.39)
Subpackages: libtevent0 libtevent0-32bit python3-tevent

- Update to version 0.9.39
+ py_tevent: add_timer takes float argument
+ C99 build fixes.
+ Fix standalone build of tevent.
- Update to version 0.9.38
+ Deprecate tevent wrapper api again
+ Build fixes
+ The build uses python3 by default:
+ --extra-python would take python2 now
+ To build with python2 only use:
PYTHON=python2 ./configure
PYTHON=python2 make
PYTHON=python2 make install

==== usbmuxd ====

- bsc#1130588: Require shadow instead of old pwdutils

==== vim ====
Version update (8.1.1137 -> 8.1.1198)
Subpackages: gvim vim-data vim-data-common

- Updated to version 8.1.1198, fixes the following problems
* Xterm mouse wheel escape sequence is not tested.
* Plugins don't get notified when the popup menu changes.
* No test for what is fixed in patch 8.1.0716.
* Not easy to find out what neighbors a window has.
* Terminal winpos test fails with very large terminal. (Dominique Pelle)
* No test for dragging the window separators with the mouse.
* May pass weird strings to file name expansion.
* Too strict checking of the 'spellfile' option.
* Compiler warning for unused function. (Tony Mechelynck)
* Desktop file translations are requiring manual updates.
* CTRL-L with 'incsearch' does not pick up char under cursor. (Smylers)
* Building desktop files fails with older msgfmt.
* Generating desktop files not tested on Travis.
* Build fails when using shadow directory.
* Msgfmt complains about missing LINGUAS file. (Tony Mechelynck)
* Getting a newer msgfmt on Travis is too complicated.
* Termcodes tests can be improved.
* Unicode emoji and other image characters not recognized.
* Unicode tables are out of date.
* Json encoded string is sometimes missing the final NUL.
* Termcodes test would fail in a very big terminal.
* Unreachable code.
* Incorrect coverage information; typo in color name.
* Codecov does not report all the coverage information.
* Gettitle test is failing when server name differs. (Kenta Sato)
* No test for mouse clicks in the terminal tabpage line.
* Gettitle test can still fail when another Vim is running.
* No test for closing tab by click in tabline.
* Not all screen update code of the terminal window is executed in tests.
* Writing coverage info in a separate dir is not needed.
* Terminal ANSI color test does not cover all colors.
* Statusline test could fail in large terminal.
* Cursor properties were not fully tested.
* Suspend test has duplicated lines.
* No test for dragging a tab with the mouse and for creating a new tab by
double clicking in the tabline.
* Test for dragging a tab is flaky.
* .ts files are recognized as xml, while typescript is more common.
* When mouse click tests fails value of 'ttytype' is unknown.
* No test for mouse clicks in the fold column.
* Vim script debugger tests are old style.
* Tests for mouse clicks are a bit flaky when run in an interactive terminal.
* Some function prototypes are outdated.
* Typos in VisVim comments.
* Undo file left behind after running test.
* Mapping for CTRL-X is inconsistent.
* readdir() allocates list twice.
* Cannot recognize Pipfile.
* Not all Vim variables require the v: prefix.
* Mode is not cleared when leaving Insert mode.
* has('vimscript-3') does not work.
* Not all debug commands are covered by a test.
* Mode is not cleared when leaving Insert mode with mapped Esc.
* Typos and small problems in test files.
* Typos and small problems in source files.
* Vim script debugger functionality needs cleanup.
* Parallel build may fail.
* When starting with multiple tabs file messages is confusing.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages