Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
Re: [opensuse-factory] Qt4 Removal: Status update
  • From: Christophe Giboudeaux <christophe@xxxxxxx>
  • Date: Wed, 17 Apr 2019 15:03:29 +0200
  • Message-id: <1901330.03k4YyahTH@yuuko>
On mercredi 17 avril 2019 14:58:21 CEST Takashi Iwai wrote:
On Wed, 17 Apr 2019 14:19:57 +0200,

Christophe Giboudeaux wrote:
Candidates for deletion:
....

- ibus-qt (origin: M17N)

This one should be fine to drop. It's only for Qt4, and Qt5 has
already its own ibus support, IIRC.


Indeed, and I keep the fcitx and scim changes for when kdelibs4 is gone (which
should happen in a couple weeks)

Cleanup needed (to remove the Qt4 optional dependency / subpackage):
....

- gcin (origin: M17N)

This one should be easy; qt4 is built only with is_opensuse flag in
the current spec file, so just need to replace these checks.

Any reference (bugzilla, whatever) to be mentioned in the changelog
for this action?


No, you can just mention Qt4 is EOL.

Thanks






--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups