Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
Re: [opensuse-factory] Leap 15.1 Build 450.2 - user report
On 4/16/19 5:46 PM, Ancor Gonzalez Sosa wrote:
On 4/16/19 3:25 PM, Neil Rickert wrote:
On 4/15/19 1:59 PM, Carlos E. R. wrote:

[...]>

As I read it, Carlos' original mail points several things in the
installation process that has changed for the worse. So I triggered an
installation of 42.3 and 15.1 to compare some of those points, to see
what can be fixed or worked-around.

Thanks.

The thing that worries me most is that the loading of the kernel took seven minutes - I timed it. I don't remember in which version this started to deteriorate, perhaps the kernel was simply smaller back then.

Yes, it is the BIOS that is used by Grub, I know.


Activation of crypto mounts was impossible> > I wouldn't say "impossible" but it is a
weak spot.> > For my recent
installs, I have been writing down the UUID of the> encrypted partitions
before starting, so that I could recognize them.> The use of UUID for
identifying the partition is just a bad idea. UUIDs> are for machines;
they are not for people.
That can be fixed for 15.2, please report the bug in bugzilla so it can
be tracked and prioritized.

Crypto partitions have no labels, unfortunately. They may have partition-label in GPT disks, though, but I'm unsure if LUKS support them.

The thing to improve is to try the given password on all LUKS filesystems found.

Ok, I'll write a bugzilla.


IMO, some of the screens are not nice, they do not look professional,
they look antique. The system role display, for instance.  In the past
these things were nicer.

This did not bother me. Yes, it is less compact than for the 42.3 or
earlier installs, because there are more choices. But they were easy
enough to read and select.

This is how it looked in 42.3
http://paste.opensuse.org/view//44062587

And this is how it looks in one of the early 15.1 beta
http://paste.opensuse.org/view//24875858

We can discuss which one looks "nicer" (I guess it's a matter of taste).
But I believe there is no question about which one is more informative.


I should have taken a photo. This looks nice, but what I got was not so nice; perhaps the proportions in my display were wrong.



The expert partitioner has changed, and IMO it is not better. Huge display.

What does "huge display" mean?

Again, this is how it looked in 42.3
http://paste.opensuse.org/view//99085952

And this is how it looks in 15.1
http://paste.opensuse.org/view//10725727

What is so different or so huge in the general display? It looks very
similar to me.

Except when one has perhaps fifty partitions and several disks, and the default expands them all...


And about "being not better", I can tell you the partitioner in 15.1
contain less bugs than the version in 43.2 (that one was full of
pitfalls). In addition, it can now directly format full disks, create
software MD RAIDs on top of disks without partitions, create partitions
within a software-defined MD RAID and many others combinations that were
impossible in the past. It also makes possible to setup bcache devices.
So from both reliability and functionality point of views, I would dare
to say it IS better. ;-)

I have not tested all that, but I'm sure it is true :-)

It is the visual aspect, and that "settings" has fewer things that perhaps 13.1 had. I miss choosing the default type of partition.

One question. Is it possible to set all system encrypted, without using LVM? This is possible to do manually, but there was talk of including it in YaST.


It took me a while to get used to this. But by now it seems to work
pretty well.

Since the new one have many more options per each device, the buttons
had to be rearranged a bit (remember the interface has to fit in small
text-mode displays). Some operations take one more click now... that was
the price of having more options to choose from. But in general we have
tried to preserve the overall experience.

And we are VERY open to constructive feedback about how to make it better.

I could select "mount by Label" as default, but not say that I prefer
ext4. This was possible in the past.

I think you can do that if you click the "Guided" instead of "Expert
Partitioner".

I don't think Carlos is talking about selecting Ext4 per EACH
filesystem. Of course that can be done one by one in both the
Partitioner and the Guided Setup.

He is talking about going to "Settings" as a first step in the
Partitioner. Then, all partitions created at a later point already has
"ext4" preselected.

Right.

Again, if you miss that, open a bug report. We can bring it back at some
point (likely for SP2).

Ok, I will.


Import mount points worked, once I found where it was and how it
worked. And unclick "format system volumes". This is very dangerous!

It's EXACTLY in the same place it was in 42.3. That can be checked in
the previous comparison screenshots.

And it works EXACTLY in the same way it used to work in 42.3. With
"format system volumes" being preselected by default... exactly as it
was in 42.3.

Maybe, but the way I remember was from 13.1 ;-)

In this design, I find it difficult to find it, because when going to "disks" it disappears.



Again, let's compare screenshots of 42.3...
http://paste.opensuse.org/view//60097489

and 15.1
http://paste.opensuse.org/view//90586477

One of the points that people disliked in 15.0 was that we had
simplified that option too much. Now it works exactly as it always did.
How it comes that classic behavior we have cloned 1:1 on popular demand
is suddenly hard to find, hard to understand and dangerous?

I only said that I found it hard to find. I didn't say any of the others, it worked well. I found the meaning of the "next" and "previous" button not trivial.


Import previous users did not default to import from the same partition
as selected on partition import. And it appears not to import user groups.

I think it imports from the most recently booted linux system. I'm not
sure if it is using file system time stamps, or something else. And
yes, it does not import groups.

Another thing that has not changed. It has always imported from the most
recently accessed Linux.

Wouldn't it make sense to import from the same partition that it imported fstab from?


Default was network manager; this is a desktop machine.

There's a place you can click to switch to "wicked", though I have not
tried that. If you select "Generic desktop" (or whatever it is called)
you get "wicked" and "Icewm".

Yes, that default was changed after some discussions in the mailing
lists. To make the change less painful an option to go back to wicked
with a single click was added in the installation summary screen.

Ok.

The installation setting display lacks a view of the affected
partitions, for one last check before proceeding with installation.

It's there, a choice near the bottom of the left column.

If it's there I didn't find it. But again, this is NOT a change compared
to Leap 42.3. That version didn't include the partitioning information
in the installation summary either, as far as I can tell.

True.


I did not notice where to select extra language :-?

And where was that option in the past? It looks like another thing that
has not changed since 42.3.

I don't remember, somewhere after choosing the timezone or in the summary. I will try to find out, later.


To be honest, I was a little bit worried reading the original mail to
see some many things that has become worse than in the good old times.
Now I feel much better after checking that most of those changes... had
actually not changed anything if you really compare 42.3 and 15.1
installation side by side.

Most of the things I mentioned are not that important, only details. Thanks for looking and commenting.

--
Cheers / Saludos,

Carlos E. R.

(from openSUSE, Leap 15.1 x86_64 (ssd-test))
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >