Mailinglist Archive: opensuse-factory (307 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190403 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190403

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
NetworkManager
abcde
autoyast2 (4.1.4 -> 4.1.5)
dav1d
delayacct-utils (4.20.4 -> 5.0.5)
ffmpeg-4 (4.1.1 -> 4.1.2)
firewalld
gobject-introspection (1.58.3 -> 1.60.0)
gucharmap (11.0.3 -> 12.0.1)
k4dirstat (3.1.3 -> 3.1.4)
kdeconnect-kde
libgtop (2.38.0 -> 2.40.0)
libsoup (2.64.2 -> 2.66.0)
mdadm
perl-Inline (0.81 -> 0.82)
plasma-browser-integration (5.15.3 -> 5.15.4)
quota (4.04 -> 4.05)
rubygem-nokogiri (1.10.1 -> 1.10.2)
rubygem-parallel (1.12.1 -> 1.16.2)
rubygem-pkg-config (1.3.6 -> 1.3.7)
shared-mime-info (1.10 -> 1.12)
simple-scan (3.30.2 -> 3.32.0)
xdm
yast2-drbd (4.1.0 -> 4.2.0)
yast2-kdump (4.1.1 -> 4.2.0)
yast2-storage-ng
zbar (0.21 -> 0.22)

=== Details ===

==== NetworkManager ====
Subpackages: NetworkManager-lang libnm0 typelib-1_0-NM-1_0

- Fix systemd-network-config.patch which added lines starting with "+"
to NetworkManager-wait-online.service

==== abcde ====

- Re-enabled musicbrainz, as both perl(MusicBrainz::DiscID) and
perl(WebService::MusicBrainz) are accepted into Factory now.
Note that abcde uses both MusicBrainz and CDDB by default.
Build without MusicBrainz can be made by setting
%_without_musibrainz 1 in prjconf.

==== autoyast2 ====
Version update (4.1.4 -> 4.1.5)
Subpackages: autoyast2-installation

- Removed check for available devices. When there are no devices,
the proposal issues will be shown (needed for bsc#1130256).
- 4.1.5

==== dav1d ====

- Add baselibs.conf: ffmpeg, which is the main consumer of Dav1d,
produces -32bit packages that would be uninstallable otherwise.

==== delayacct-utils ====
Version update (4.20.4 -> 5.0.5)

- BuildRequire kernel-devel because we want to rebuild
when it gets updated

==== ffmpeg-4 ====
Version update (4.1.1 -> 4.1.2)
Subpackages: libavcodec58 libavdevice58 libavfilter7 libavformat58
libavresample4 libavutil56 libpostproc55 libswresample3 libswscale5

- Update to version 4.1.2:
* Updates and bug fixes for codecs, filters and formats.
- Add ffmpeg-avcodec-libdav1d-AV1-decoder-wrapper.patch: Backport
dav1d decoder support for aom (av1) codec. Following this, add
conditional pkgconfig(dav1d) BuildRequires and pass conditional
- -enable-libdav1d to configure. Also add libdav1d to
enable_decoders.

==== firewalld ====
Subpackages: firewalld-lang python3-firewall

- Revert last change: the macros DO reference firewall-cmd, but as
they are expanded during build time of the package, not at
runtime, the point in time is wrong to require firewalld. The
consumer of the macro is responsible to ask for the right
commands to be present at runtime of the scripts
(boo#1125775#c9).

==== gobject-introspection ====
Version update (1.58.3 -> 1.60.0)
Subpackages: girepository-1_0 libgirepository-1_0-1

- Update to version 1.60.0:
+ gir: Update glib annotations.
- Update to version 1.59.5:
+ gir:
- Include C header in cairo gir file.
- Skip glib-enumtypes.h for GObject-2.0.
- Update to version 1.59.4:
+ tests: Add functions using flat struct arrays.
+ Clean shebangs out of non-executable scripts and drop exec perm
from xmlwriter.py.
+ maintransformer: parse deprecation annotations for section
blocks.
+ repository: g_irepository_get_object_gtype_interfaces.
+ message: handle fatal errors even if warnings are disabled.
+ autotools: Fix build with ``-Wl,--as-needed``.
+ maintransformer: Don't warn on (optional) annotations on
(inout).
+ girepository: Fix a possible use-after-free if
g_mapped_file_new() fails and fix possible leak of transitive
dependency names.
- Fix shebangs for files installed to /usr/bin to not use
/usr/bin/env.
- Update to version 1.59.3:
+ meson:
- Use underscore as a separator in build options (gtk-doc->
gtk_doc etc).
- Warn that not all tests will be run if building without
cairo/doctool.
+ scanner:
- Merge specifiers and qualifiers when merging basic types.
Fixes "unsigned char" being wrongly parsed as "unsigned" etc.
- Rework source root directory guessing code to not depend on
the build directory.
- Remove incorrect c:type generated for array of synthesized
unions.
- Flatten multi-dimensional arrays fields.
+ website: add cppgir C++ binding.
- Replace -Dgtk-doc=true call to meson with -Dgtk_doc=true.
- Pass -Ddoctool=true and -Dcairo=true to meson, build and install
g-ir-doc-tool and use cairo during meson_check (tests).
- Update to version 1.59.2:
+ Everything included in 1.58.3.
+ meson: Various fixes and all tests have been ported.
+ scanner: Save preprocessor input and output files with
``save-temps``.
+ automake: Use the wildcard function where needed.
+ build: extend ``PYTHONPATH`` instead of replacing it.
+ gir/cairo: add ``cairo_rectangle_t``.
+ Add a ``--version`` option to g-ir-compiler and g-ir-generate.
+ tests: various test improvements.
+ ccompiler: don't use Python compiler flags.
+ parser: Do not bail out when parsing GIR files without doc
positions.
+ gimarshallingtests: Remove declarations of nonexistent
functions.
- Changes from version 1.59.1:
+ Everything included in 1.58.2.
+ build:
- Drop Python 2 support, require Python 3.4+.
- Add option to make .gir files installation paths
configurable.
- Skip gobject/gvaluecollector.h when constructing GObject GIR.
- Port various tests to work with meson.
+ regress:
- Add test for write-only property.
- Implement interface and override properties.
+ writer: Include documentation and symbol position in source
files.
+ giscanner:
- Print relative filename paths when warning.
- Define grefcount and gatomicrefcount as aliases to gint.
- Allow empty declarations. Fixes warnings with mingw headers.
- Replace linked lists with arrays in source scanner.
+ girepository:
- Various docs cleanups and fixes.
- Don't abort when calling g_base_info_get_name() on a
GITypeInfo.
- Add version macros and functions.

==== gucharmap ====
Version update (11.0.3 -> 12.0.1)
Subpackages: gucharmap-lang libgucharmap_2_90-7

- Update to version 12.0.1:
+ checksums: Update for unicode 12.0.0.
- Update to version 12.0.0:
+ unicode:
- Update to version 12.0.0.
- Fix name buffer length.
+ help: Update screenshots for GNOME 3.32.
+ Updated translations.

==== k4dirstat ====
Version update (3.1.3 -> 3.1.4)
Subpackages: k4dirstat-lang

- Update to 3.1.4:
* No longer ignore files containing dot when reading cache file
* Remove trailing slash from command line argument

==== kdeconnect-kde ====
Subpackages: kdeconnect-kde-lang

- Use noun phrase in descriptions.

==== libgtop ====
Version update (2.38.0 -> 2.40.0)
Subpackages: libgtop-2_0-11 libgtop-lang

- Update to version 2.40.0:
+ Fixed array and transfer annotations for documentation.
- Update to version 2.39.91:
+ Replace deprecated gnome-common with autoreconf.
- Update to version 2.39.90:
+ Fixed compile warnings
+ Linux: Get procmap doesn't need suid.
+ Updated translations.

==== libsoup ====
Version update (2.64.2 -> 2.66.0)
Subpackages: libsoup-2_4-1 libsoup-lang typelib-1_0-Soup-2_4

- Update to version 2.66.0:
+ Fix lookup for libxml2 on Visual Studio builds.
- Add meson_test macro in check section, run tests during build.
- Update to version 2.65.92:
+ SoupConnection: Fix check for remote disconnectin idle state.
+ Code cleanups and warnings fixed.
+ Remove stale .pc.in files.
+ Updated translations.
- Update to version 2.65.91:
+ Remove RFCs from sources.
- Update to version 2.65.90:
+ Avoid using threads in SoupRequestFile asynchronous API.
- Fix translation-update-upstream call, needed after update of
translation-update-upstream in distro.
- Update to version 2.65.2:
+ Remove autotools build system and change to meson by default.
+ Many fixes to Meson.
+ Improvements to the continuous integration infrastructure
+ Make sure SoupSession features are not disposed until all
pending messages are processed.
+ Updated translations.
- Update to version 2.65.1:
+ Added MTLMv2 responses support.
+ Many fixes to the meson build system.
+ Remove Visual Studio project files.
+ Enable VAPI by default.
+ New strict header field parameter parsing API.
+ Code cleanups.
+ Updated translations.
- Drop meson and apidocs beconds and conditionals, fixed upstream.

==== mdadm ====

- imsm: finish recovery when drive with rebuild fails (bsc#1126975)
0010-imsm-finish-recovery-when-drive-with-rebuild-fails.patch
- mdmon: don't attempt to manage new arrays when terminating
(bsc#1127526)
0011-mdmon-don-t-attempt-to-manage-new-arrays-when-termin.patch

==== perl-Inline ====
Version update (0.81 -> 0.82)

- updated to 0.82
see /usr/share/doc/packages/perl-Inline/Changes
0.82 Sun 31 Mar 2019 04:10:24 PM CEST
- Another fix for @INC PR#69 TINITA

==== plasma-browser-integration ====
Version update (5.15.3 -> 5.15.4)
Subpackages: plasma-browser-integration-lang

- Update to 5.15.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.4.php
- Changes since 5.15.3:
* Update description before processing job state or error
* [Host] Add Message.sh

==== quota ====
Version update (4.04 -> 4.05)
Subpackages: quota-nfs

- Install the license
- Update to 4.05 release jsc#SLE-5734:
* This release includes mostly various smaller cleanups and fixes
in various areas.
* Most visible changes are addition of f2fs and exfs among recognized
filesystems.
- Drop merged patch quota-4.04-Listen-on-a-TCP-socket.patch
- Remove quot binary functionality could be achieved by using
repquota instead

==== rubygem-nokogiri ====
Version update (1.10.1 -> 1.10.2)

- updated to version 1.10.2
no changelog found

==== rubygem-parallel ====
Version update (1.12.1 -> 1.16.2)

- updated to version 1.16.2
no changelog found
- updated to version 1.14.0
no changelog found

==== rubygem-pkg-config ====
Version update (1.3.6 -> 1.3.7)

- updated to version 1.3.7
see installed NEWS
== 1.3.7 - 2019-03-17
=== Improvements
* Added support for alphabet and _ only version.
[GitHub#17][Reported by xiejiangzhi]
=== Thanks
* xiejiangzhi

==== shared-mime-info ====
Version update (1.10 -> 1.12)
Subpackages: shared-mime-info-lang

- Update to version 1.12:
+ Fix build from tarball.
- Changes from version 1.11:
+ Add mime-type for:
- reStructuredText.
- Groovy scripting language.
- Gradle build tool.
- Maven.
- WarpScript source code.
- zstd and tar.zst archives.
+ Change the preferred suffix for image/jpeg from .jpeg to .jpg.
+ Assign *.html to XHTML pages.
+ Better detection for *.key files (Apple Keynote vs. GPG keys).
+ Give weight to one of the appimage patterns.
+ Tools:
- Link to GitLab for contributions and bug reports.
- Loads of memory and file descriptor leak fixes.
+ Spec: Clarify the availability of C character escape support.
- Update URL and use source service to checkout exact tag, upstream
have an ever changing tarball url, so we go with source checkout.
- Following the above, add libtool BuildRequires and pass
autogen.sh, bootstraping is now needed.
- Modernize spec.

==== simple-scan ====
Version update (3.30.2 -> 3.32.0)
Subpackages: simple-scan-lang

- Update to version 3.32.0:
+ Updated translations.
- Update to version 3.31.92:
+ Updated translations.
- Update to version 3.31.91:
+ Fix save overwriting existing file when user decided not to.
+ Make save button insensitive while saving.
- Update to version 3.31.90.1:
+ Fix crash when detecting scanners.
- Changes from version 3.31.90:
+ Support non-standard Epson ADF scanner options.
- Update to version 3.31.4:
+ Updated translations.
- Drop adwaita-icon-theme BuildRequires and old workaround for icon
brpcheck. No longer needed.
- Update to version 3.31.3:
+ Updated translations.
- Changes from version 3.31.2:
+ Use Gtk.FileChooserNative for save dialog so works in sandboxed
environments.
+ Use GLib.List.deep_copy() to fix type-argument mismatch.
- Changes from version 3.31.1:
+ Replace scan menu with a popdown.
+ Make ActionBar buttons wide to match design.
+ Drop legacy toolbar support.

==== xdm ====
Subpackages: xdm-xsession

- n_Allow-the-greeter-to-set-the-input-fields-bg-color.patch
* reverse applied in order to fix greeter again; related to our
heavily adjusted xdm Xresources (boo#1130321)

==== yast2-drbd ====
Version update (4.1.0 -> 4.2.0)

- Removed unused BuildRequires (bsc#1131234)
- 4.2.0

==== yast2-kdump ====
Version update (4.1.1 -> 4.2.0)

- Removed unused BuildRequires (bsc#1131234)
- 4.2.0

==== yast2-storage-ng ====

- Fixed unit tests to also work in ARM architecture (bsc#1130957).

==== zbar ====
Version update (0.21 -> 0.22)

- Update to version 0.22:
* zbarcam-qt: allow changing resolutions in real time
* zbarcam-qt: better support ZBar options
* zbarcam-qt: do several visual improvements
* zbarcam-qt: make it remember the geometry
* zbarcam-qt: allow show/hide control and options bars
* zbarcam-qt: remember lastly used settings and camera controls
* zbarcam-qt: allow changing ZBar decode options via GUI
* Add API to allow get/set resolutions
* img_scanner: add handler for color-inverted codes
* img_scanner: fix get_config parameter validation
* scan_video: improve logic to remove duplicated/invalid devnodes
* symbol.c: fix symbol hash logic (prevents crash with QR options)
* configure.ac: fix an error at libv4l2 package check
* fix some typos
* exit gracefully when decoding split QR codes


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages