Mailinglist Archive: opensuse-factory (401 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190321 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190321

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
AppStream
Mesa
Mesa-drivers
attica-qt5 (5.55.0 -> 5.56.0)
autoyast2 (4.1.2 -> 4.1.4)
baloo5 (5.55.0 -> 5.56.0)
bluez-qt (5.55.0 -> 5.56.0)
breeze5-icons (5.55.0 -> 5.56.0)
frameworkintegration (5.55.0 -> 5.56.0)
installation-images-Kubic (14.415 -> 14.417)
kactivities-stats (5.55.0 -> 5.56.0)
kactivities5 (5.55.0 -> 5.56.0)
karchive (5.55.0 -> 5.56.0)
kauth (5.55.0 -> 5.56.0)
kbookmarks (5.55.0 -> 5.56.0)
kcmutils (5.55.0 -> 5.56.0)
kcodecs (5.55.0 -> 5.56.0)
kcompletion (5.55.0 -> 5.56.0)
kconfig (5.55.0 -> 5.56.0)
kconfigwidgets (5.55.0 -> 5.56.0)
kcoreaddons (5.55.0 -> 5.56.0)
kcrash (5.55.0 -> 5.56.0)
kdbusaddons (5.55.0 -> 5.56.0)
kdeclarative (5.55.0 -> 5.56.0)
kded (5.55.0 -> 5.56.0)
kdelibs4support (5.55.0 -> 5.56.0)
kdesu (5.55.0 -> 5.56.0)
kdnssd-framework (5.55.0 -> 5.56.0)
kdoctools (5.55.0 -> 5.56.0)
kemoticons (5.55.0 -> 5.56.0)
kfilemetadata5 (5.55.0 -> 5.56.0)
kglobalaccel (5.55.0 -> 5.56.0)
kguiaddons (5.55.0 -> 5.56.0)
kholidays (5.55.0 -> 5.56.0)
khtml (5.55.0 -> 5.56.0)
ki18n (5.55.0 -> 5.56.0)
kiconthemes (5.55.0 -> 5.56.0)
kidletime (5.55.0 -> 5.56.0)
kimageformats (5.55.0 -> 5.56.0)
kinit (5.55.0 -> 5.56.0)
kio (5.55.0 -> 5.56.0)
kirigami2 (5.55.0 -> 5.56.1)
kitemmodels (5.55.0 -> 5.56.0)
kitemviews (5.55.0 -> 5.56.0)
kjobwidgets (5.55.0 -> 5.56.0)
kjs (5.55.0 -> 5.56.0)
kjsembed (5.55.0 -> 5.56.0)
knewstuff (5.55.0 -> 5.56.0)
knotifications (5.55.0 -> 5.56.0)
knotifyconfig (5.55.0 -> 5.56.0)
kpackage (5.55.0 -> 5.56.0)
kparts (5.55.0 -> 5.56.0)
kpeople5 (5.55.0 -> 5.56.0)
kplotting (5.55.0 -> 5.56.0)
kpty (5.55.0 -> 5.56.0)
kross (5.55.0 -> 5.56.0)
krunner (5.55.0 -> 5.56.0)
kservice (5.55.0 -> 5.56.0)
ktexteditor (5.55.0 -> 5.56.0)
ktextwidgets (5.55.0 -> 5.56.0)
kunitconversion (5.55.0 -> 5.56.0)
kwallet (5.55.0 -> 5.56.0)
kwayland (5.55.0 -> 5.56.0)
kwidgetsaddons (5.55.0 -> 5.56.0)
kwindowsystem (5.55.0 -> 5.56.0)
kxmlgui (5.55.0 -> 5.56.0)
kxmlrpcclient5 (5.55.0 -> 5.56.0)
libKF5ModemManagerQt (5.55.0 -> 5.56.0)
libKF5NetworkManagerQt (5.55.0 -> 5.56.0)
libqt5-qtbase (5.12.0 -> 5.12.2)
libqt5-qtconnectivity (5.12.0 -> 5.12.2)
libqt5-qtdeclarative (5.12.0 -> 5.12.2)
libqt5-qtgraphicaleffects (5.12.0 -> 5.12.2)
libqt5-qtimageformats (5.12.0 -> 5.12.2)
libqt5-qtlocation (5.12.0 -> 5.12.2)
libqt5-qtmultimedia (5.12.0 -> 5.12.2)
libqt5-qtnetworkauth (5.12.0 -> 5.12.2)
libqt5-qtquickcontrols (5.12.0 -> 5.12.2)
libqt5-qtquickcontrols2 (5.12.0 -> 5.12.2)
libqt5-qtscript (5.12.0 -> 5.12.2)
libqt5-qtsensors (5.12.0 -> 5.12.2)
libqt5-qtserialport (5.12.0 -> 5.12.2)
libqt5-qtspeech (5.12.0 -> 5.12.2)
libqt5-qtsvg (5.12.0 -> 5.12.2)
libqt5-qttools (5.12.0 -> 5.12.2)
libqt5-qtwayland (5.12.0 -> 5.12.2)
libqt5-qtwebchannel (5.12.0 -> 5.12.2)
libqt5-qtwebengine (5.12.0 -> 5.12.2)
libqt5-qtwebsockets (5.12.0 -> 5.12.2)
libqt5-qtx11extras (5.12.0 -> 5.12.2)
libqt5-qtxmlpatterns (5.12.0 -> 5.12.2)
libstorage-ng (4.1.98 -> 4.1.101)
mkfontscale (1.1.3 -> 1.2.0)
oxygen5-icon-theme (5.55.0 -> 5.56.0)
plasma-framework (5.55.0 -> 5.56.1)
prison-qt5 (5.55.0 -> 5.56.0)
purpose (5.55.0 -> 5.56.0)
solid (5.55.0 -> 5.56.0)
sonnet (5.55.0 -> 5.56.0)
syntax-highlighting (5.55.0 -> 5.56.0)
threadweaver (5.55.0 -> 5.56.0)
yast2-country (4.1.9 -> 4.1.11)
yast2-installation (4.1.43 -> 4.1.45)
yast2-ntp-client (4.1.7 -> 4.1.8)
yast2-packager (4.1.32 -> 4.1.33)
yast2-schema (4.1.3 -> 4.1.5)
yast2-storage-ng (4.1.71 -> 4.1.75)
yast2-theme (4.1.10 -> 4.1.11)
yast2-trans (84.87.20190309.125b762b7d -> 84.87.20190320.750cf6aee8)

=== Details ===

==== AppStream ====
Subpackages: AppStream-lang libAppStreamQt2 libappstream4

- Replace boilerplate and em-dash summaries.

==== Mesa ====
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- Remove imx from ARM drivers (dropped upstream)

==== Mesa-drivers ====
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- Remove imx from ARM drivers (dropped upstream)

==== attica-qt5 ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Attica5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles fine with qt5.13
* Remove deprecated QSignalMapper
* Fix some clazy error
* Port to for(...:...)

==== autoyast2 ====
Version update (4.1.2 -> 4.1.4)
Subpackages: autoyast2-installation

- Postpone disabling local repositories if the second stage is
required (bsc#1127818).
- 4.1.4
- Add Bcache related elements to the partitioning schema
(fate#325346).
- 4.1.3

==== baloo5 ====
Version update (5.55.0 -> 5.56.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Replace several Q_ASSERTs with proper checks
* Check string length to avoid crash for "tags:/" URL
* [tags_kio] Fix local file tagging by checking only tag: urls for double
slashes.
* add baloo engine debugging category
* Hardcoding the Remaining Time Update Interval
* Fix regression for matching explicitly included folders
* Cleanup idempotent entries from mimetype mapper table
* [baloo/KInotify] Notify if folder was moved from unwatched place
(kde#342224)
* Simplify term debug output
* Handle folders matching substrings of included/excluded folders correctly
* [balooctl] Normalize include/exclude pathes before using it for the config
* Optimize Baloo::File copy assign operator, fix Baloo::File::load(url)
* Use content to determine mime type
* Get rid of mostly unused filePathToStat overload
* [Extractor] Exclude GPG encrypted data from being indexed
* [balooctl] Actually abort a malformed command instead of just saying so
* [balooctl] Add missing help for "config set", normalize string
* Replace recursive isDirHidden with iterative one, allow const argument
* Make sure only directories are added to the inotify watcher
- Dropped patches, now upstream:
* 0001-Check-string-length-to-avoid-crash-for-tags-URL.patch

==== bluez-qt ====
Version update (5.55.0 -> 5.56.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== breeze5-icons ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Add code-oss icon
* [breeze-icons] Add video camera icons
* [breeze-icons] Use new suspend, hibernate and switch user icons in Breeze
icon theme
* Add 16 px and 22 px versions of the gamepad icon to devices/
* Make Breeze theme tooltip texts consistent
* Add battery icons
* Rename "visibility" and "hint" icons to "view-visible" and "view-hidden"
Also add compatibility symlinks pointing to the original names
* [breeze-icons] Add monochrome/smaller SD card and memory stick icons
(kde#404231)
* Add device icons for drones
* Change C/C++ header/source mimetype icons to circle/line style
* Fix missing shadows on C/C++ header mimetype icons (kde#401793)
* Remove monochrome font preferences icon
* Improve font selection icon
* Use new bell-style icon for all users of preferences-desktop-notification
(kde#404094)
* [breeze-icons] Add 16px versions of gnumeric-font.svg and link
gnumeric-font.svg to font.svg
* Add preferences-system-users symlinks that point to yast-users icon
* Add edit-none icon

==== frameworkintegration ====
Version update (5.55.0 -> 5.56.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== installation-images-Kubic ====
Version update (14.415 -> 14.417)

- merge gh#openSUSE/installation-images#302
- fine-tune RPi firmware inclusion (jsc:SLE-4394)
- 14.417
- adjust build contraints to require 24GB to build
- disable SLED build (fcrozat)
- merge gh#openSUSE/installation-images#301
- Package mkfontdir is optional. So it can be obsoleted by package
mkfontscale.
- 14.416

==== kactivities-stats ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kactivities5 ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Use natural sorting in ActivityModel

==== karchive ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Revert "Return KFilterBase::End if KGzipFilter::uncompress_noop() finished
reading"
* Return KFilterBase::End if KGzipFilter::uncompress_noop() finished reading
* Make it compiles without foreach
* Guard KCompressionDevice::open being called with no backend available
(kde#404240)

==== kauth ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Tell people they should mostly be using KF5::AuthCore
* Namespace find_file result
* Compile our own helper against AuthCore and not Auth
* Fix Windows build [hopefully]
* Introduce KF5AuthCore
- Add a new subpackage for the KF5AuthCore5 library

==== kbookmarks ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Replace KIconThemes dependency with equivalent QIcon usage

==== kcmutils ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods
* Use KCM name in KCM header
* Add missing ifndef KCONFIGWIDGETS_NO_KAUTH
* Fix build without kauth
* Adapt to changes in kconfigwidgets
* Revert "Add missing dependency on KAuth"
* Add missing dependency on KAuth
* Sync QML module padding to reflect system setting pages

==== kcodecs ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* We can compile with QT_DISABLE_DEPRECATED_BEFORE=0x050d00
* Use constiterator
* Make it compiles without foreach
* Fix for CVE-2013-0779
* QuotedPrintableDecoder::decode: return false on error instead of asserting
* Bring back ECM to 5.55
* Mark KCodecs::uuencode does nothing
* Remove unused hexChars global variable
* nsEUCKRProber/nsGB18030Prober::HandleData don't crash if aLen is 0
* nsBig5Prober::HandleData: Don't crash if aLen is 0
* KCodecs::Codec::encode: Don't assert/crash if makeEncoder returns null
* nsEUCJPProbe::HandleData: Don't crash if aLen is 0

==== kcompletion ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods
* Use QStringLiteral here

==== kconfig ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* improve documentation on global config cascading (kde#306923)
* KConfig: Assign documentation to correct enum value
* Write valid UTF8 characters without escaping. (kde#403557)
* KConfig: handle directory symlinks correctly.

==== kconfigwidgets ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Remove deprecated method
* Skip benchmark if no scheme files can be found
* Add a note for KF6 to use the core version of KF5::Auth
* Cache the default KColorScheme configuration

==== kcoreaddons ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Fix compile kpimtextedit when we remove all deprecated method against
* Port deprecated methods
* Namespace find_file call
* Create tel: links for phone numbers

==== kcrash ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles fine in qt5.13
* It compiles fine without foreach
* We can remove it

==== kdbusaddons ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Make it compile without Q_FOREACH

==== kdeclarative ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* use KPackage::fileUrl to support rcc KCMs packages
* Remove not necessary flags
* [GridDelegate] Fix long labels blending into each other (kde#404389)
* [GridViewKCM] improve contrast and legibility for delegates' inline hover
buttons (kde#395510)
* Correct the accept flag of the event object on DragMove (kde#396011)
* Use different "None" item icon in grid view KCMs

==== kded ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kded-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kdelibs4support ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods

==== kdesu ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* kdesud: KAboutData::setupCommandLine() already sets help & version

==== kdnssd-framework ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kdoctools ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles find with QT5.13 without deprecated method
* Make it compiles without foreach
* Port cross-compilation support to KF5_HOST_TOOLING
* Only report DocBookXML as found if it was actually found
* Update Spanish entities

==== kemoticons ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kfilemetadata5 ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kfilemetadata5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* cleanup and slightly enhance display formatting test
* Fix typo in exiv extractor
* [Extractor] Add metadata to extractors
* add test which checks the property types
* Add extractor for AppImage files
* Cleanup ffmpeg extractor
* Add a test for ffmpeg extractor
* [ExternalExtractor] Provide more helpful output when extractor fails
* Fix minor typo
* Format EXIF photo flash data
* Fix build with cmake 3.5
* Avoid side effects due to stale errno value
* Try to fix test on windows
* Use Kformat for bit and sample rate
* Add units to framerate and gps data
* Add string formatting function to property info
* Avoid leaking a QObject in ExternalExtractor
* Handle <a> as container element in SVG
* Check Exiv2::ValueType::typeId before converting it to rational
- Dropped patches, now upstream:
* fix-build-with-cmake-3.5.patch

==== kglobalaccel ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kguiaddons ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kholidays ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Rename as REQUIRED_QT_VERSION. All other module use it
* Make it compiles without foreach
* I don't know why it's not sync with other modules.

==== khtml ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== ki18n ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port some code to for(...:...)

==== kiconthemes ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles fine without it
* Port deprecated methods

==== kidletime ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kimageformats ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kimageformats-eps

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* ras: fix crash on broken files
* Use auto here too
* compile without foreach
* ras: protect the palette QVector too
* ras: tweak max file check
* xcf: Fix uninitialized memory use on broken documents
* add const, helps understand the function better
* ras: tweak max size that "fits" in a QVector
* ras: don't assert because we try to allicate a huge vector
* ras: Protect against divide by zero
* xcf: Don't divide by 0
* tga: fail gracefully if readRawData errors
* ras: fail gracefully on height*width*bpp > length

==== kinit ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kinit-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kio ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kio-core kio-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods
* kioexec: KAboutData::setupCommandLine() already sets help & version
* Fix crash in Dolphin when dropping trashed file in trash (kde#378051)
* Use correct prefix for static variable
* Middle-elide very long filenames in error strings (kde#404232)
* Add support for portals in KRun
* [KPropertiesDialog] Fix group combobox (kde#403074)
* properly attempt to locate the kioslave bin in $libexec AND $libexec/kf5
* Use AuthCore instead of Auth
* Add icon name to service providers in .desktop file
* Read IKWS search provider icon from desktop file
* [PreviewJob] Also pass along that we're the thumbnailer when stat'ing file

==== kirigami2 ====
Version update (5.55.0 -> 5.56.1)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.56.1
* New bugfix release
- Changes since 5.56.0:
* avoid parenting OverlaySheet to ColumnView
* hide breadcrumb on pages that don't want a toolbar (kde#404481)
- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Too many changes to list here

==== kitemmodels ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Fix example in documentation
* KRearrangeColumnsProxyModel: make the two column-mapping methods public

==== kitemviews ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods

==== kjobwidgets ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles fine with qt5.13
* [KJobWidget] remove deprecated method
* Port deprecated methods

==== kjs ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kjsembed ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods

==== knewstuff ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods
* Filter out invalid content in lists
* Fix mem leak found by asan

==== knotifications ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods
* fix some compile error
* port to findcanberra from ECM
* List Android as officially supported

==== knotifyconfig ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods

==== kpackage ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kpackage-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles fine with qt5.13
* extend documentation of kpackage_install_bundled_package
* remove kpackage_install_package deprecation warning

==== kparts ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles fine with qt5.13
* Make strict compile flags
* templates: KAboutData::setupCommandLine() already sets help & version

==== kpeople5 ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kpeople5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Port deprecated methods

==== kplotting ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kpty ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Remove not necessary virtual keyword

==== kross ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kross-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Install Kross modules to ${KDE_INSTALL_QTPLUGINDIR}
* Port deprecated methods

==== krunner ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles fine without deprecated methods

==== kservice ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kservice-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* kbuildsycoca5: no need to repeat work of KAboutData::setupCommandLine()

==== ktexteditor ====
Version update (5.55.0 -> 5.56.0)
Subpackages: ktexteditor-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Remove override keyword
* Use isEmpty here
* Remove deprecated method
* try to improve painting height for text lines - bug 403868 avoid to cut _
and other parts still broken: double height things like mixed
english/arab, see bug 404713 (kde#403868)
* Use QTextFormat::TextUnderlineStyle instead of QTextFormat::FontUnderline
(kde#399278)
* Make it possible to show all spaces in the document (kde#381267, kde#342811)
* Do not print indent lines
* KateSearchBar: Show also search has wrapped hint in nextMatchForSelection()
aka Ctrl-H
* katetextbuffer: refactor TextBuffer::save() to better separate code paths
* Use AuthCore instead of Auth
* Remove dead code
* Explicitly link against KAuth
* Refactor KateViewInternal::mouseDoubleClickEvent(QMouseEvent *e)
* Improvements to completion
* Add TODO KF6 note
* Set the color scheme to Printing for Print Preview (kde#391678)
- Refreshed patches:
* 0001-Disable-KAuth-integration.patch

==== ktextwidgets ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles find with qt5.13
* Port deprecated methods

==== kunitconversion ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles with qt5.13
* Make it compile without foreach

==== kwallet ====
Version update (5.55.0 -> 5.56.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Remove deprecated method

==== kwayland ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Only commit XdgOutput::done if changed
* FakeInput: add support for pointer move with absolute coordinates
* Add explicit SurfaceInterface::commited signal
* Add missing XdgShellPopup::ackConfigure
* Update copy paste error in XdgShellPopupStable member vars
* [server] Add surface data proxy mechanism
* [server] Add selectionChanged signal

==== kwidgetsaddons ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Remove deprecated method
* Port deprecated methods
* Use correct KStandardGuiItem "no" icon

==== kwindowsystem ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== kxmlgui ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Windows: fix the fix for... etc. Can't use a switch here.
* Fix the fix for Windows compilation
* Fix compile on windows
* [kxmlgui] remove deprecated method
* Port deprecated methods

==== kxmlrpcclient5 ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== libKF5ModemManagerQt ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== libKF5NetworkManagerQt ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== libqt5-qtbase ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5Concurrent5 libQt5Core5 libQt5DBus5 libQt5Gui5
libQt5Network5 libQt5OpenGL5 libQt5PrintSupport5 libQt5Sql5 libQt5Sql5-mysql
libQt5Sql5-sqlite libQt5Test5 libQt5Widgets5 libQt5Xml5
libqt5-qtbase-platformtheme-gtk3

- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.12.2/?h=5.12.2
- Replace 0001-Revert-White-list-more-recent-Mesa-version-for-multi.patch with
* 0001-Revert-Blacklist-nouveau-and-llvmpipe-for-multithrea.patch
* 0002-Revert-qtlite-Fix-build-libs-with-no-feature-regular.patch
* 0003-Revert-White-list-more-recent-Mesa-version-for-multi.patch
- Remove 0002-Revert-QImage-merge-the-size-calculations-with-prope.patch,
fixed upstream
- Clean %install a bit
- Use %license
- Add patch to fix crashes with nouveau (QTBUG-73715):
* 0001-Revert-White-list-more-recent-Mesa-version-for-multi.patch
- Add patch to fix apparent memory leaks (QTBUG-73731):
* 0002-Revert-QImage-merge-the-size-calculations-with-prope.patch
- Refresh tell-the-truth-about-private-api.patch to apply cleanly
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.12.1/?h=v5.12.1
- xkbcommon not bundled anymore, removed now obsolete option
- Refresh patches:
* 0001-Add-remote-print-queue-support.patch
* 0001-Fix-qfloat16-methods-definition-without-declaration-.patch
- Drop patches, now upstream:
* 0001-Fix-compile-issue-with-gcc-9.patch

==== libqt5-qtconnectivity ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5Bluetooth5 libQt5Bluetooth5-imports libQt5Nfc5
libQt5Nfc5-imports libqt5-qtconnectivity-tools

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtconnectivity.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtconnectivity.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtdeclarative ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtdeclarative.git/plain/dist/changes-5.12.2/?h=5.12.2
- Work around cmake issue by expanding make_jobs manually, ignoring
cmake breaks autoprovides
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtdeclarative.git/plain/dist/changes-5.12.1/?h=v5.12.1
- cmake breaks %make_jobs - ignore it (boo#1091864)

==== libqt5-qtgraphicaleffects ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtgraphicaleffects.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtgraphicaleffects.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtimageformats ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtimageformats.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtimageformats.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtlocation ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5Location5 libQt5Positioning5 libQt5PositioningQuick5

- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtlocation.git/plain/dist/changes-5.12.2/?h=5.12.2
- Disable the gypsy plugin
- Mention all location plugins explicitly
- Move QtPositioning QML plugin to libQt5PositioningQuick5 package
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtlocation.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtmultimedia ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtmultimedia.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtmultimedia.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtnetworkauth ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtnetworkauth.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtnetworkauth.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtquickcontrols ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtquickcontrols.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtquickcontrols.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtquickcontrols2 ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5QuickControls2-5 libQt5QuickTemplates2-5

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtquickcontrols2.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtquickcontrols2.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtscript ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtscript.git/plain/dist/changes-5.12.2/?h=5.12.2
- Remove patches, now upstream:
* libqt5-qtscript-toplevel-asm.patch
- Use %license
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtscript.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtsensors ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5Sensors5 libQt5Sensors5-imports

- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtsensors.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtsensors.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtserialport ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtserialport.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtserialport.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtspeech ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtspeech.git/plain/dist/changes-5.12.2/?h=5.12.2
- Add packageand(speech-dispatcher:%{libname}) supplements to the speechd plugin
- Add the plugin to baselibs.conf
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtspeech.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtsvg ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtsvg.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtsvg.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qttools ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5Designer5 libQt5Help5 libqt5-qdbus libqt5-qtpaths

- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qttools.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qttools.git/plain/dist/changes-5.12.1/?h=v5.12.1
* qcollectiongenerator got reintroduced as wrapper for qhelpgenerator

==== libqt5-qtwayland ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5WaylandClient5 libQt5WaylandCompositor5

- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtwebchannel ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5WebChannel5 libQt5WebChannel5-imports

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebchannel.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebchannel.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtwebengine ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.12.2/?h=5.12.2
- Remove patches, now upstream:
* cve-2019-5786.patch
- Add cve-2019-5786.patch
Backport fix for CVE-2019-5786
https://bugreports.qt.io/browse/QTBUG-74254
- Fix build on Leap 42.3 by adding c++14 to QT_CONFIG
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.12.1/?h=v5.12.1
- Refresh disable-gpu-when-using-nouveau-boo-1005323.diff
- Remove patches, now upstream:
* gn-fix_arm.patch
* chromium-66.0.3359.170-gcc8-alignof.patch

==== libqt5-qtwebsockets ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5WebSockets5 libQt5WebSockets5-imports

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebsockets.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebsockets.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtx11extras ====
Version update (5.12.0 -> 5.12.2)

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtx11extras.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtx11extras.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libqt5-qtxmlpatterns ====
Version update (5.12.0 -> 5.12.2)
Subpackages: libQt5XmlPatterns5 libqt5-qtxmlpatterns-imports

- Update to 5.12.2:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtxmlpatterns.git/plain/dist/changes-5.12.2/?h=5.12.2
- Update to 5.12.1:
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtxmlpatterns.git/plain/dist/changes-5.12.1/?h=v5.12.1

==== libstorage-ng ====
Version update (4.1.98 -> 4.1.101)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- Translated using Weblate (Slovak)
- 4.1.101
- Translated using Weblate (Galician)
- Translated using Weblate (Portuguese (Brazil))
- Translated using Weblate (German)
- Translated using Weblate (Polish)
- 4.1.100
- Unifying name Bcache/bcache to bcache (#629)
- 4.1.99

==== mkfontscale ====
Version update (1.1.3 -> 1.2.0)

- Update to version 1.2.0
* Starting with this release, 1.2.0, it now includes the
mkfontdir script previously distributed separately for
compatibility with older X11 versions.
- provide/obsolete mkfontdir package

==== oxygen5-icon-theme ====
Version update (5.55.0 -> 5.56.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* No code changes since 5.55.0

==== plasma-framework ====
Version update (5.55.0 -> 5.56.1)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Add patch to make certain .svgz work with Qt 5.12.2 (kde#405548):
* 0001-Fix-breeze-dialog-background-with-Qt-5.12.2.patch
- Update to 5.56.1
* New bugfix release
- Changes since 5.56.0:
* Remove crash in plasmashell
- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Make it compiles without deprecated method
* [Icon Item] Block next animation also based on window visibility
* it's already defined in KDEFrameworkCompilerSettings
* Show a warning if a plugin requires a newer version
* Bump the theme versions because icons changed, to invalidate old caches
* [breeze-icons] Revamp system.svgz
* Make Breeze theme tooltip texts consistent
* Change glowbar.svgz to smoother style (kde#391343)
* Do background contrast fallback at runtime (kde#401142)
* [breeze desktop theme/dialogs] Add rounded corners to dialogs
* Fix warning
- Refreshed patches:
* 0001-Revert-Remove-Qt-version-check.patch

==== prison-qt5 ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles with QT_NO_FOREACH

==== purpose ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* pastebin: don't show progress notifications
* sharetool: Show shared url on top
* Fix sharing files with spaces or quotes in names via Telegram
* Have ShareFileItemAction provide an output or an error if they are provided
* Enable sharing URLs via email

==== solid ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Hopefully fix compilation on Windows after commit c9a135579431
* It compile fine against qt5.13 without deprecated method
* Bring FindUDev.cmake up to ECM standards

==== sonnet ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* It compiles fine with qt5.13
* Port deprecated methods
* Handle the case if createSpeller is passed an unavailable language

==== syntax-highlighting ====
Version update (5.55.0 -> 5.56.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Too many changes to list here

==== threadweaver ====
Version update (5.55.0 -> 5.56.0)

- Update to 5.56.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.56.0.php
- Changes since 5.55.0:
* Make it compile without foreach

==== yast2-country ====
Version update (4.1.9 -> 4.1.11)
Subpackages: yast2-country-data

- Fix command line parameter to systemd-firstboot (--root instead
of -root) (part of bsc#1121256).
- 4.1.11
- Add support to set the language as read-only in the control file,
which allows to change it during the installation without
persisting it in the installed system (bsc#1121256).
- 4.1.10

==== yast2-installation ====
Version update (4.1.43 -> 4.1.45)

- revert SSH textmode patches (bsc#1129375, bsc#1047470)
- 4.1.45
- ensure that installation with VNC + textmode still installs
via VNC (bsc#1129073)
- 4.1.44

==== yast2-ntp-client ====
Version update (4.1.7 -> 4.1.8)

- Activate translations for the SelectFrom widget (bsc#1126523,
bsc#1126520).
- 4.1.8

==== yast2-packager ====
Version update (4.1.32 -> 4.1.33)

- AutoYaST: Disabling local repositories in second stage only.
(bsc#1127818)
- 4.1.33

==== yast2-schema ====
Version update (4.1.3 -> 4.1.5)

- Add Bcache related elements to the partitioning schema
(fate#325346).
- 4.1.5
- Updated build requ. due tag home_btrfs_subvolume and smt.
(bsc#1128707)
- 4.1.4

==== yast2-storage-ng ====
Version update (4.1.71 -> 4.1.75)

- Fix bcache and AutoYaST related tests (related to fate#325346).
- 4.1.75
- Show new icons for the options of the Configure menu button
(related to bsc#1122174).
- 4.1.74
- Unifying name Bcache/bcache to bcache (fate#325346).
- 4.1.73
- Add support for Bcache to AutoYaST (fate#325346).
- Fix reuse of RAID partitions for LVM volume groups and bcache
devices.
- 4.1.72
- Only exports the partition_type attribute when it belongs to a
partition table with support for extended partitions
(bsc#1115751).

==== yast2-theme ====
Version update (4.1.10 -> 4.1.11)
Subpackages: yast2-theme-breeze yast2-theme-oxygen

- Require yast2-qt-branding-openSUSE for openSUSE distros
so YaST firstboot has some branding (bsc#1105792)
- 4.1.11

==== yast2-trans ====
Version update (84.87.20190309.125b762b7d -> 84.87.20190320.750cf6aee8)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv
yast2-trans-ta yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi
yast2-trans-wa yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20190320.750cf6aee8:
* Fixed string interpolations
* Fixed string interpolations
* New POT for text domain 'packager'.
* New POT for text domain 'autoinst'.
- Update to version 84.87.20190319.0220aaa5b1:
* Fixed inconsistent line endings
* Fixed inconsistent line endings
* Translated using Weblate (Hungarian)
* Translated using Weblate (Spanish)
* Translated using Weblate (Russian)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Arabic)
* Translated using Weblate (Russian)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Polish)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Dutch)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Arabic)
* Translated using Weblate (Spanish)
* Translated using Weblate (Russian)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Arabic)
* Translated using Weblate (Spanish)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (Arabic)
* Translated using Weblate (Russian)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Polish)
* Translated using Weblate (Korean)
* Translated using Weblate (Japanese)
* Translated using Weblate (Italian)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Spanish)
* Translated using Weblate (Russian)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Arabic)
* Translated using Weblate (Swedish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Russian)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Arabic)
* Translated using Weblate (Swedish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Russian)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Arabic)
* Translated using Weblate (Swedish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Russian)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (Arabic)
* Translated using Weblate (Swedish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Russian)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Arabic)
* Translated using Weblate (Spanish)
* Translated using Weblate (Catalan)
* Translated using Weblate (Swedish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Russian)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Polish)
* Translated using Weblate (Korean)
* Translated using Weblate (Japanese)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Catalan)
* Translated using Weblate (Arabic)
* Translated using Weblate (Swedish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Russian)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Dutch)
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Arabic)
* Translated using Weblate (Swedish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Polish)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Swedish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Russian)
* Translated using Weblate (Polish)
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Arabic)
* Translated using Weblate (Swedish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Russian)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Korean)
* Translated using Weblate (Italian)
* Translated using Weblate (Hungarian)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Arabic)
* Add missing hu translations
* New POT for text domain 'registration'.
* New POT for text domain 'country'.
* Translated using Weblate (German)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Dutch)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (Catalan)
* Translated using Weblate (German)
* Translated using Weblate (Dutch)
* Translated using Weblate (German)
* Translated using Weblate (Slovak)
* Translated using Weblate (German)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (German)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (German)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Polish)
* Translated using Weblate (German)
* Translated using Weblate (German)
* Translated using Weblate (Czech)
* Translated using Weblate (Polish)
* Translated using Weblate (Italian)
* Translated using Weblate (Polish)
* Translated using Weblate (German)
* New POT for text domain 'control'.
* Translated using Weblate (Japanese)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Japanese)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* Fixed text interpolations
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Polish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Polish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Polish)
* Translated using Weblate (Polish)
* Translated using Weblate (Polish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Polish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Polish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Czech)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* New POT for text domain 'storage'.
* Add missing supported po files
* Remove mess from en_US translations
* Delete empty en_US "translations"
* New POT for text domain 'storage'.
* New POT for text domain 'qt-pkg'.
* New POT for text domain 'control'.
* Translated using Weblate (Dutch)
* Translated using Weblate (Chinese (China))
* New POT for text domain 'registration'.
* Translated using Weblate (Korean)
* Translated using Weblate (Dutch)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Dutch)
* Translated using Weblate (Czech)
* Translated using Weblate (Arabic)
* Translated using Weblate (Czech)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Korean)
* Translated using Weblate (Czech)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Albanian)
* Translated using Weblate (Albanian)
* Translated using Weblate (Korean)
* Translated using Weblate (Dutch)
* Translated using Weblate (Chinese (China))
* New POT for text domain 'users'.
* New POT for text domain 'http-server'.
* Translated using Weblate (Czech)
* Translated using Weblate (Japanese)
* Translated using Weblate (Slovak)
* Translated using Weblate (Czech)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Czech)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Danish)
* Translated using Weblate (Catalan)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Galician)
* Translated using Weblate (Galician)
* Translated using Weblate (Galician)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Galician)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Dutch)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Japanese)
* Translated using Weblate (Danish)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages