Mailinglist Archive: opensuse-factory (276 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190312 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190312

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
akonadi-calendar (18.12.2 -> 18.12.3)
akonadi-calendar-tools (18.12.2 -> 18.12.3)
akonadi-contact (18.12.2 -> 18.12.3)
akonadi-import-wizard (18.12.2 -> 18.12.3)
akonadi-mime (18.12.2 -> 18.12.3)
akonadi-notes (18.12.2 -> 18.12.3)
akonadi-search (18.12.2 -> 18.12.3)
akonadi-server (18.12.2 -> 18.12.3)
akregator (18.12.2 -> 18.12.3)
analitza (18.12.2 -> 18.12.3)
apr-util
ark (18.12.2 -> 18.12.3)
audacity (2.3.0 -> 2.3.1)
automake
baloo5-widgets (18.12.2 -> 18.12.3)
blinken (18.12.2 -> 18.12.3)
bogofilter
bovo (18.12.2 -> 18.12.3)
branding-openSUSE
calendarsupport (18.12.2 -> 18.12.3)
cervisia (18.12.2 -> 18.12.3)
curl
dolphin (18.12.2 -> 18.12.3)
dracut
dragonplayer (18.12.2 -> 18.12.3)
drkonqi5
dwz
efivar
eventviews (18.12.2 -> 18.12.3)
ffmpeg-4
ffmpegthumbs (18.12.2 -> 18.12.3)
ghostscript
glibc
glibc
grantleetheme (18.12.2 -> 18.12.3)
grub2
gstreamer-plugins-good
gwenview5 (18.12.2 -> 18.12.3)
incidenceeditor (18.12.2 -> 18.12.3)
juk (18.12.2 -> 18.12.3)
k3b (18.12.2 -> 18.12.3)
kaccounts-integration (18.12.2 -> 18.12.3)
kaccounts-providers (18.12.2 -> 18.12.3)
kaddressbook (18.12.2 -> 18.12.3)
kalarmcal (18.12.2 -> 18.12.3)
kalgebra (18.12.2 -> 18.12.3)
kalzium (18.12.2 -> 18.12.3)
kamera (18.12.2 -> 18.12.3)
kanagram (18.12.2 -> 18.12.3)
kapptemplate (18.12.2 -> 18.12.3)
kate (18.12.2 -> 18.12.3)
katomic (18.12.2 -> 18.12.3)
kblackbox (18.12.2 -> 18.12.3)
kblocks (18.12.2 -> 18.12.3)
kbounce (18.12.2 -> 18.12.3)
kbreakout (18.12.2 -> 18.12.3)
kbruch (18.12.2 -> 18.12.3)
kcachegrind (18.12.2 -> 18.12.3)
kcalc (18.12.2 -> 18.12.3)
kcalcore (18.12.2 -> 18.12.3)
kcalutils (18.12.2 -> 18.12.3)
kcharselect (18.12.2 -> 18.12.3)
kcolorchooser (18.12.2 -> 18.12.3)
kcontacts (18.12.2 -> 18.12.3)
kcron (18.12.2 -> 18.12.3)
kdav (18.12.2 -> 18.12.3)
kde-print-manager (18.12.2 -> 18.12.3)
kdeedu-data (18.12.2 -> 18.12.3)
kdegraphics-thumbnailers (18.12.2 -> 18.12.3)
kdenetwork4-filesharing (18.12.2 -> 18.12.3)
kdepim-addons (18.12.2 -> 18.12.3)
kdepim-apps-libs (18.12.2 -> 18.12.3)
kdepim-runtime (18.12.2 -> 18.12.3)
kdf (18.12.2 -> 18.12.3)
kdialog (18.12.2 -> 18.12.3)
kdiamond (18.12.2 -> 18.12.3)
kdump
kgeography (18.12.2 -> 18.12.3)
kget (18.12.2 -> 18.12.3)
kgoldrunner (18.12.2 -> 18.12.3)
khangman (18.12.2 -> 18.12.3)
khelpcenter5 (18.12.2 -> 18.12.3)
kidentitymanagement (18.12.2 -> 18.12.3)
kig (18.12.2 -> 18.12.3)
kimagemapeditor (18.12.2 -> 18.12.3)
kimap (18.12.2 -> 18.12.3)
kio-extras5 (18.12.2 -> 18.12.3)
kio_audiocd (18.12.2 -> 18.12.3)
kiriki (18.12.2 -> 18.12.3)
kiten (18.12.2 -> 18.12.3)
kitinerary (18.12.2 -> 18.12.3)
kjumpingcube (18.12.2 -> 18.12.3)
kldap (18.12.2 -> 18.12.3)
kleopatra (18.12.2 -> 18.12.3)
klettres (18.12.2 -> 18.12.3)
klines (18.12.2 -> 18.12.3)
kmag (18.12.2 -> 18.12.3)
kmahjongg (18.12.2 -> 18.12.3)
kmail (18.12.2 -> 18.12.3)
kmail-account-wizard (18.12.2 -> 18.12.3)
kmailtransport (18.12.2 -> 18.12.3)
kmbox (18.12.2 -> 18.12.3)
kmime (18.12.2 -> 18.12.3)
kmines (18.12.2 -> 18.12.3)
kmousetool (18.12.2 -> 18.12.3)
kmouth (18.12.2 -> 18.12.3)
kmplot (18.12.2 -> 18.12.3)
knavalbattle (18.12.2 -> 18.12.3)
knetwalk (18.12.2 -> 18.12.3)
knotes (18.12.2 -> 18.12.3)
kolf (18.12.2 -> 18.12.3)
kollision (18.12.2 -> 18.12.3)
kolourpaint (18.12.2 -> 18.12.3)
kompare (18.12.2 -> 18.12.3)
konquest (18.12.2 -> 18.12.3)
konsole (18.12.2 -> 18.12.3)
kontact (18.12.2 -> 18.12.3)
kontactinterface (18.12.2 -> 18.12.3)
kopete (18.12.2 -> 18.12.3)
korganizer (18.12.2 -> 18.12.3)
kpat (18.12.2 -> 18.12.3)
kpimtextedit (18.12.2 -> 18.12.3)
kpkpass (18.12.2 -> 18.12.3)
kqtquickcharts (18.12.2 -> 18.12.3)
krdc (18.12.2 -> 18.12.3)
kreversi (18.12.2 -> 18.12.3)
krfb (18.12.2 -> 18.12.3)
kruler (18.12.2 -> 18.12.3)
kshisen (18.12.2 -> 18.12.3)
ksirk (18.12.2 -> 18.12.3)
ksmtp (18.12.2 -> 18.12.3)
kspaceduel (18.12.2 -> 18.12.3)
ksquares (18.12.2 -> 18.12.3)
ksudoku (18.12.2 -> 18.12.3)
ksystemlog (18.12.2 -> 18.12.3)
kteatime (18.12.2 -> 18.12.3)
ktimer (18.12.2 -> 18.12.3)
ktnef (18.12.2 -> 18.12.3)
ktouch (18.12.2 -> 18.12.3)
ktuberling (18.12.2 -> 18.12.3)
kturtle (18.12.2 -> 18.12.3)
kubrick (18.12.2 -> 18.12.3)
kwalletmanager5 (18.12.2 -> 18.12.3)
kwin5
kwordquiz (18.12.2 -> 18.12.3)
libgravatar (18.12.2 -> 18.12.3)
libidn
libixion
libkcddb (18.12.2 -> 18.12.3)
libkcompactdisc (18.12.2 -> 18.12.3)
libkdcraw (18.12.2 -> 18.12.3)
libkdegames (18.12.2 -> 18.12.3)
libkdepim (18.12.2 -> 18.12.3)
libkeduvocdocument (18.12.2 -> 18.12.3)
libkexiv2 (18.12.2 -> 18.12.3)
libkgapi (18.12.2 -> 18.12.3)
libkipi (18.12.2 -> 18.12.3)
libkleo (18.12.2 -> 18.12.3)
libkmahjongg (18.12.2 -> 18.12.3)
libkomparediff2 (18.12.2 -> 18.12.3)
libksane (18.12.2 -> 18.12.3)
libksieve (18.12.2 -> 18.12.3)
libmspack (0.9.1 -> 0.10.1)
liborcus
libreoffice
libunistring
libvirt (5.0.0 -> 5.1.0)
lokalize (18.12.2 -> 18.12.3)
lskat (18.12.2 -> 18.12.3)
mailcommon (18.12.2 -> 18.12.3)
mailimporter (18.12.2 -> 18.12.3)
man
man-pages (4.16 -> 5.00)
mbox-importer (18.12.2 -> 18.12.3)
messagelib (18.12.2 -> 18.12.3)
mobipocket (18.12.2 -> 18.12.3)
net-snmp
okular (18.12.2 -> 18.12.3)
openSUSE-build-key
openldap2
parley (18.12.2 -> 18.12.3)
patterns-base
php7 (7.3.2 -> 7.3.3)
pim-data-exporter (18.12.2 -> 18.12.3)
pim-sieve-editor (18.12.2 -> 18.12.3)
pimcommon (18.12.2 -> 18.12.3)
postgresql (10 -> 11)
postgresql11-libs (10.7 -> 11.2)
python-certifi (2018.11.29 -> 2019.3.9)
python-cffi
python-dnspython (1.15.0 -> 1.16.0)
python-libvirt-python (5.0.0 -> 5.1.0)
python-msgpack (0.5.6 -> 0.6.1)
python-packaging (17.1 -> 19.0)
python-pip (19.0.2 -> 19.0.3)
python-psutil (5.5.1 -> 5.6.0)
python-pyOpenSSL
python-pyzmq (17.1.2 -> 18.0.1)
python-rpm-macros (20190221.08f1194 -> 20190307.81ca329)
python-tornado
qemu
redland
rsyslog
signon-kwallet-extension (18.12.2 -> 18.12.3)
spectacle (18.12.2 -> 18.12.3)
step (18.12.2 -> 18.12.3)
sweeper (18.12.2 -> 18.12.3)
system-tuning-common-SUSE
umbrello (18.12.2 -> 18.12.3)
xprop (1.2.3 -> 1.2.4)
yast2-pkg-bindings (4.1.1 -> 4.1.2)
zbar

=== Details ===

==== akonadi-calendar ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== akonadi-calendar-tools ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-calendar-tools-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== akonadi-contact ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Don't duplicate items

==== akonadi-import-wizard ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== akonadi-mime ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== akonadi-notes ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== akonadi-search ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== akonadi-server ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Small code cleanup: use local var instead of pimItems.at(i) many times
* Fix intermittent race in collectionattributetest
* Use an emit syntax that QtCreator understands better.
* Remove unneeded warning for killed subjobs, error string was just "".
* Add missing Q_EMIT before signal emission.
* collectionattributetest: small cleanups
* Server: Improve debug, warning and error log messages
* Destroy the Connection Through the Session Thread (kde#381636)
* Akonadi: fix racy code in (MimeType|Resource)::retrieveByNameOrCreate
* Akonadi: fix timing-dependent failure of partstreamertest
* Akonadi: add missing dependencies on included XSL files
* Fix SQLite backend foreign key PRAGMAs
* Simplify AggregatedFetchScope code, removing all setters.
* Fix tag change notification shipping a bogus name.
* AggregatedFetchScope: fix fetchAllAttributes for tags.
* Properly clean up scopes when deregistering a subscriber.
* Fix "QIODevice::read" warnings.
* autotests: partstreamertest: show more info on failure

==== akregator ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akregator-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== analitza ====
Version update (18.12.2 -> 18.12.3)
Subpackages: analitza-lang libAnalitza5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== apr-util ====
Subpackages: apr-util-devel libapr-util1

- apr-util-postgresql.patch: PostrgeSQL's pg_config is meant for
linking server extensions, use libpq's pkg-config, if pg_config
is missing. This fixes build with PostgreSQL 11.

==== ark ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ark-lang libkerfuffle18

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix loading of tar.zst archives (kde#404464)
* cli7ztest: add failing test case for zip folders with RDA attributes

==== audacity ====
Version update (2.3.0 -> 2.3.1)
Subpackages: audacity-lang

- Update to release 2.3.1 and remove incorporated patch:
0001-Fix-bug-1992.patch.
- Upstream changes:
Over 20 bugs fixed since 2.3.0, including:
A crashing bug on Linux that made Audacity 2.3.0. unsuitable for
Linux.
Problems with Change Pitch, including not remembering parameter
values.
Options and preferences:
Microfades are now an opt-in feature. They were always on in
2.3.0.
The advanced vertical zooming option is now available in the
View->Zoom menu.
Regular interval labels now support range labels.

==== automake ====

- Drop info requires: this is not actually true: automake works
perfectly without the info tool present.

==== baloo5-widgets ====
Version update (18.12.2 -> 18.12.3)
Subpackages: baloo5-widgets-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== blinken ====
Version update (18.12.2 -> 18.12.3)
Subpackages: blinken-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== bogofilter ====
Subpackages: bogofilter-common bogofilter-db

- Swallow old bogofilter pkgs in the db subpkg (bsc#1128219)
fix change from April 2015
- Require subpkgs from the very same build

==== bovo ====
Version update (18.12.2 -> 18.12.3)
Subpackages: bovo-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== branding-openSUSE ====
Subpackages: grub2-branding-openSUSE libreoffice-branding-openSUSE
plymouth-branding-openSUSE wallpaper-branding-openSUSE
xfce4-splash-branding-openSUSE yast2-qt-branding-openSUSE

- Fix systemd logo icons package
- Prevent tiny installation font (bsc#1124508)

==== calendarsupport ====
Version update (18.12.2 -> 18.12.3)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== cervisia ====
Version update (18.12.2 -> 18.12.3)
Subpackages: cervisia-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== curl ====
Subpackages: libcurl4

- Add patches to fix use-after-free (boo#1127849):
* 0001-connection_check-set-data-to-the-transfer-doing-the-.patch
* 0002-connection_check-restore-original-conn-data-after-th.patch

==== dolphin ====
Version update (18.12.2 -> 18.12.3)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix crash during shutdown (kde#402784)
* Word-wrap KMessageWidget text
* [DolphinView] Use correct color group
* Sort preview plugins case-insensitively

==== dracut ====

- Check SUSE kernel module dependencies recursively (bsc#1127891)
* adds 0594-Check-SUSE-kernel-module-dependencies-recursively.patch
- Handle non-versioned dependency in purge-kernels.

==== dragonplayer ====
Version update (18.12.2 -> 18.12.3)
Subpackages: dragonplayer-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Set StartupWMClass in desktop file

==== drkonqi5 ====
Subpackages: drkonqi5-lang

- Add ptools as runtime dependency to get required tool
pbuildid for fetching symbols

==== dwz ====

- Add dwz-low-mem-Fix-DW_OP_GNU_parameter_ref-handling-in-read_exprloc.patch
to fix assert on cc1 binary from gcc bootstrap-lto [swo#24195].

==== efivar ====

- Add efivar-bsc1127544-fix-ucs2len.patch to fix logic that checks
for UCS-2 string termination (boo#1127544)
- Add efivar-fix-efidp_ipv4_addr-fields-assignment.patch to fix the
casting of IPv4 address.

==== eventviews ====
Version update (18.12.2 -> 18.12.3)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ffmpeg-4 ====
Subpackages: libavcodec58 libavdevice58 libavfilter7 libavformat58
libavresample4 libavutil56 libpostproc55 libswresample3 libswscale5

- Add a new filter line to rpmlintrc
(addFilter("no-dependency-on ffmpeg-4-lib*")).
- Add trivial encoder rawvideo, already enabled in decoders

==== ffmpegthumbs ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ffmpegthumbs-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Bail out if stream is negative

==== ghostscript ====
Subpackages: ghostscript-x11

- Fix IJS printing problem (bsc#1128467)
* added ijs_exec_server_dont_use_sh.patch
* allow exec'ing hpijs in apparmor profile

==== glibc ====

- add-new-Fortran-vector-math-header-file.patch: Update from upstream

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale glibc-locale-base
nscd

- add-new-Fortran-vector-math-header-file.patch: Update from upstream

==== grantleetheme ====
Version update (18.12.2 -> 18.12.3)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Fix LOADER_TYPE parsing in grub2-once (boo#1122569)

==== gstreamer-plugins-good ====
Subpackages: gstreamer-plugins-good-extra gstreamer-plugins-good-gtk
gstreamer-plugins-good-jack gstreamer-plugins-good-lang
gstreamer-plugins-good-qtqml

- Require automake >= 1.14

==== gwenview5 ====
Version update (18.12.2 -> 18.12.3)
Subpackages: gwenview5-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== incidenceeditor ====
Version update (18.12.2 -> 18.12.3)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== juk ====
Version update (18.12.2 -> 18.12.3)
Subpackages: juk-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix displaying covers from cover.jpg files
* Fix crash in filtering playlist to playing album/artist. (kde#402355)

==== k3b ====
Version update (18.12.2 -> 18.12.3)
Subpackages: k3b-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kaccounts-integration ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kaccounts-providers ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kaccounts-providers-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kaddressbook ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kaddressbook-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kalarmcal ====
Version update (18.12.2 -> 18.12.3)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kalgebra ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kalgebra-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kalzium ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kalzium-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kamera ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kamera-lang kio_kamera

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kanagram ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kanagram-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kapptemplate ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kapptemplate-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kate ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kate-lang kate-plugins

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== katomic ====
Version update (18.12.2 -> 18.12.3)
Subpackages: katomic-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kblackbox ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kblackbox-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kblocks ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kblocks-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2
- Avoid name repetition in summary (rpmlint).

==== kbounce ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kbounce-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kbreakout ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kbreakout-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kbruch ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kbruch-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kcachegrind ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kcachegrind-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Set StartupWMClass in desktop file

==== kcalc ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kcalc-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kcalcore ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kcalutils ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kcharselect ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kcharselect-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kcolorchooser ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kcolorchooser-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kcontacts ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kcron ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kcron-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdav ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdav-lang libKPimKDAV5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kde-print-manager ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kde-print-manager-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdeedu-data ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdegraphics-thumbnailers ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdenetwork4-filesharing ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdenetwork4-filesharing-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdepim-addons ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdepim-addons-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdepim-apps-libs ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdepim-apps-libs-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdepim-runtime ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdepim-runtime-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdf ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdf-lang kwikdisk

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdialog ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdialog-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdiamond ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdiamond-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kdump ====

- kdump-remove-noefi-and-acpi_rsdp-for-efi-firmware.patch: Remove
noefi and acpi_rsdp for EFI firmware (bsc#1123940).

==== kgeography ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kgeography-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix appstream data

==== kget ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kget-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kgoldrunner ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kgoldrunner-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== khangman ====
Version update (18.12.2 -> 18.12.3)
Subpackages: khangman-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== khelpcenter5 ====
Version update (18.12.2 -> 18.12.3)
Subpackages: khelpcenter5-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kidentitymanagement ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kig ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kig-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kimagemapeditor ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kimagemapeditor-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kimap ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kimap-lang libKF5IMAP5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kio-extras5 ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kio_audiocd ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kio_audiocd-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Remove incorrect <provides><library> from appdata, not a real library
* Call KLocalizedString::setApplicationDomain only after QApp instance done
* Fix Ogg Vorbis logic for Average and Min/Max bitrates

==== kiriki ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kiriki-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kiten ====
Version update (18.12.2 -> 18.12.3)
Subpackages: fonts-KanjiStrokeOrders kiten-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kitinerary ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kjumpingcube ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kjumpingcube-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kldap ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kldap-lang libKF5Ldap5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kleopatra ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kleopatra-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== klettres ====
Version update (18.12.2 -> 18.12.3)
Subpackages: klettres-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== klines ====
Version update (18.12.2 -> 18.12.3)
Subpackages: klines-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmag ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmag-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmahjongg ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmahjongg-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmail ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix Bug 403313 - Encoding problem on kmail2 5.10.1 when creating composer
from command line (kde#403313)

==== kmail-account-wizard ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmail-account-wizard-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmailtransport ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmbox ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmime ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmime-lang libKF5Mime5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmines ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmines-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmousetool ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmousetool-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmouth ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmouth-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kmplot ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kmplot-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== knavalbattle ====
Version update (18.12.2 -> 18.12.3)
Subpackages: knavalbattle-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== knetwalk ====
Version update (18.12.2 -> 18.12.3)
Subpackages: knetwalk-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== knotes ====
Version update (18.12.2 -> 18.12.3)
Subpackages: knotes-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kolf ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kolf-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kollision ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kollision-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kolourpaint ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kolourpaint-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kompare ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kompare-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Set StartupWMClass in desktop file

==== konquest ====
Version update (18.12.2 -> 18.12.3)
Subpackages: konquest-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== konsole ====
Version update (18.12.2 -> 18.12.3)
Subpackages: konsole-part konsole-part-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2
- Add upstream patches to improve and/or fix rendering of
line/block chars, cursors, and characters with wide glyphs:
* Add-special-support-for-block-characters.patch
* Extend-character-clipping-by-grouping-it-with-spaces.patch
(kde#401298)
* Improve-built-in-line_block-characters-drawing.patch
(kde#402415)
* Fix-ibeam-and-underline-cursor-rendering.patch (kde#402589)
- Drop patches to disable antialiasing as the rendering problems
are fixed by above patches:
* 0001-Revert-fix-drawing-box-chars-avoid-storing-and-savin.patch
* 0002-Revert-Antialias-line-drawing-characters.patch

==== kontact ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kontact-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kontactinterface ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kopete ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kopete-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== korganizer ====
Version update (18.12.2 -> 18.12.3)
Subpackages: korganizer-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kpat ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kpat-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kpimtextedit ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kpkpass ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKPimPkPass5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kqtquickcharts ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== krdc ====
Version update (18.12.2 -> 18.12.3)
Subpackages: krdc-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Set StartupWMClass in desktop file

==== kreversi ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kreversi-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== krfb ====
Version update (18.12.2 -> 18.12.3)
Subpackages: krfb-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kruler ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kruler-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kshisen ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kshisen-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ksirk ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ksirk-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ksmtp ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kspaceduel ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kspaceduel-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ksquares ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ksquares-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ksudoku ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ksudoku-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ksystemlog ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ksystemlog-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kteatime ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kteatime-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ktimer ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ktimer-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ktnef ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ktouch ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ktouch-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== ktuberling ====
Version update (18.12.2 -> 18.12.3)
Subpackages: ktuberling-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kturtle ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kturtle-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kubrick ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kubrick-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kwalletmanager5 ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kwalletmanager5-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== kwin5 ====
Subpackages: kwin5-lang

- Add Set-m_windowmode-in-screenshotWindowUnderCursor.patch to fix
"Capture the current pop-up only" mode in spectacle (boo#1123638,
kde#374864)

==== kwordquiz ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kwordquiz-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libgravatar ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libidn ====

- Add disable-rwlock-test.patch to disable broken tests
(bnc#1120894).

==== libixion ====

- Add missing dependency on libboost_system-devel

==== libkcddb ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkcompactdisc ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkdcraw ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkdegames ====
Version update (18.12.2 -> 18.12.3)
Subpackages: kdegames-carddecks-default libkdegames-lang libkf5kdegames6

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkdepim ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix building with akonadi search support
- Dropped patches, now upstream:
* Fix-building-with-akonadi-search-support.patch

==== libkeduvocdocument ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKEduVocDocument5 libkeduvocdocument-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkexiv2 ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkgapi ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix googletalk protocol.
* Contacts: fix email type deserialization (kde#398847)
- Dropped patches, now upstream:
* Contacts-fix-email-type-deserialization.patch

==== libkipi ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkleo ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkmahjongg ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5KMahjongglib5 libkmahjongg-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libkomparediff2 ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libksane ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5Sane5 libksane-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libksieve ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libksieve-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== libmspack ====
Version update (0.9.1 -> 0.10.1)

- Update to version 0.10.1
* Bugfix release, no functional changes
- Update to version 0.10:
* Fix Heap buffer overflow in chmd_read_headers()
* Fix memory exhausted in chmd_read_headers()
* Fix memory exhausted in oabd_decompress()

==== liborcus ====

- Add missing dependency on libboost_system-devel

==== libreoffice ====
Subpackages: libreoffice-base libreoffice-base-drivers-firebird
libreoffice-calc libreoffice-draw libreoffice-filters-optional
libreoffice-gnome libreoffice-gtk3 libreoffice-icon-themes libreoffice-impress
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-en_GB libreoffice-l10n-es
libreoffice-l10n-fr libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja
libreoffice-l10n-pl libreoffice-l10n-pt_BR libreoffice-l10n-ru
libreoffice-l10n-zh_CN libreoffice-l10n-zh_TW libreoffice-mailmerge
libreoffice-math libreoffice-pyuno libreoffice-qt5 libreoffice-writer
libreofficekit

- boost_169.patch: fix build with Boost 1.69

==== libunistring ====
Subpackages: libunistring2 libunistring2-32bit

- Add disable-broken-tests.patch in order to fix broken
tests (bnc#1128460).

==== libvirt ====
Version update (5.0.0 -> 5.1.0)
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- util: skip RDMA detection for non-PCI network devices
f38ef0fa-no-RDMA-check.patch
bsc#1112182
- qemu: s390: show correct CPU status after guest crash
0001-qemu-Fix-query-cpus-fast-target-architecture-detecti.patch
bsc#1127841
- apparmor: fix more fallout from changing libvirtd profile to a
named profile
4ec3cf9a-apparmor-rules.patch,
0001-apparmor-Check-libvirtd-profile-status-by-name.patch
boo#1125841
- Update to libvirt 5.1.0
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
11c8aca9-libxl-set-mem-after-balloon.patch,
70c2933d-apparmor-named-profiles.patch,
a3ab6d42-apparmor-conv-libvirtd-named-profile.patch,
b6440119-qemu-conf-sev.patch,
a404ac34-qemu-cgroup-sev.patch,
6fd4c8f8-qemu-domain-sev.patch,
17f6a257-security-dac-sev.patch,
a2d3dea9-qemu-caps-dac-override-sev.patch,
620d9dd5-qemu-no-dac-override-nonroot.patch
- jsc#SLE-3887, jsc#SLE-4480, jsc#SLE-4577

==== lokalize ====
Version update (18.12.2 -> 18.12.3)
Subpackages: lokalize-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Update indonesian nplurals
* Do not launch pology on non-existent .po (kde#401393)
* Revert "Add support for viewing the translation source with a custom editor"
* Only display the first line of messages in the catalog (kde#402931)
* Add support for viewing the translation source with a custom editor
(kde#403743)

==== lskat ====
Version update (18.12.2 -> 18.12.3)
Subpackages: lskat-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== mailcommon ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== mailimporter ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== man ====

- Ah ... yes, manual pages are also provides by e.g. mandoc
- Skip %verify(not link mtime) from symbolic links %_bindir even if
those should not hurt but avoid superfluous verify messages
- Minor corrections on %ghost /var/cache/man and link to apropos
- Use update-alternatives to allow that man(1), apropos(1), whatis(1)
can be overwritten by an other package like mandoc
- Reintroduce wrapper for man(1) but without mapping to user man to
be able to reset the PATH to the standard for any preprocessor

==== man-pages ====
Version update (4.16 -> 5.00)

- update to 5.00:
* new or rewritten pages:
s390_guarded_storage.2
address_families.7
bpf-helpers.7
* newly documented interfaces:
fanotify_init.2
fanotify.7
Document FAN_REPORT_TID
fanotify_init.2: add new flag FAN_REPORT_TID
fanotify.7: update description of member pid in
struct fanotify_event_metadata
Document FAN_MARK_FILESYSTEM
Monitor fanotify events on the entire filesystem.
Document FAN_OPEN_EXEC and FAN_OPEN_EXEC_PERM
io_submit.2
Document IOCB_FLAG_IOPRIO
msgctl.2
semctl.2
shmctl.2
Document STAT_ANY commands
prctl.2
Document PR_SET_SPECULATION_CTRL and PR_GET_SPECULATION_CTRL
sched_setattr.2
Document SCHED_FLAG_DL_OVERRUN and SCHED_FLAG_RECLAIM
socket.2
Document AF_XDP
Document AF_XDP added in Linux 4.18.
inotify.7
Document IN_MASK_CREATE
unix.7
Document SO_PASSSEC
Document SCM_SECURITY ancillary data

==== mbox-importer ====
Version update (18.12.2 -> 18.12.3)
Subpackages: mbox-importer-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== messagelib ====
Version update (18.12.2 -> 18.12.3)
Subpackages: messagelib-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix runtime warning when calling deleteLater on a null object.

==== mobipocket ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== net-snmp ====
Subpackages: libsnmp30 perl-SNMP snmp-mibs

- Remove FIRST_ARG usage from spec file (bsc#1126426).

==== okular ====
Version update (18.12.2 -> 18.12.3)
Subpackages: okular-lang okular-spectre

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== openSUSE-build-key ====

- drop arm specific key again
=> ARM sub project is considered to be equal trustworthy

==== openldap2 ====
Subpackages: libldap-2_4-2 libldap-2_4-2-32bit libldap-data openldap2-client
openldap2-devel

- Corrected moduleload back_mdb.la to get a working configuration
right after package installation.

==== parley ====
Version update (18.12.2 -> 18.12.3)
Subpackages: parley-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt
patterns-base-base patterns-base-console patterns-base-documentation
patterns-base-enhanced_base patterns-base-enhanced_base_opt
patterns-base-minimal_base patterns-base-sw_management
patterns-base-transactional_base patterns-base-x11 patterns-base-x11_enhanced
patterns-base-x11_opt

- Re-run pre_checkin.sh, updating -32bit patterns
- Add pattern x11_raspberrypi (fate#326509, jsc#SLE-4142)
This is to cover the delta between SLES 15 GA and SP1 JeOS images
to allow the user to recreate its IceWM desktop without requiring
a lengthy list of packages.
Extended to openSUSE on request by fcrozat.
- Insert comments to keep format_spec_file from reordering too much

==== php7 ====
Version update (7.3.2 -> 7.3.3)
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pgsql php7-shmop php7-snmp
php7-sockets php7-sqlite php7-sysvsem php7-sysvshm php7-tidy php7-tokenizer
php7-wddx php7-xmlreader php7-xmlwriter php7-xsl php7-zlib

- updated to 7.3.3: This is a security release which also contains
several bug fixes. See
http://www.php.net/ChangeLog-7.php#7.3.3
- deleted patches
- php-systzdata-v17.patch (upstreamed)
- added patches
+ php-systzdata-v18.patch (thanks to remirepo)
- asan_build: build ASAN included
- debug_build: build more suitable for debugging

==== pim-data-exporter ====
Version update (18.12.2 -> 18.12.3)
Subpackages: pim-data-exporter-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== pim-sieve-editor ====
Version update (18.12.2 -> 18.12.3)
Subpackages: pim-sieve-editor-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== pimcommon ====
Version update (18.12.2 -> 18.12.3)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== postgresql ====
Version update (10 -> 11)
Subpackages: postgresql-contrib postgresql-devel postgresql-docs
postgresql-server

- Drop use of $FIRST_ARG in .spec
The use of $FIRST_ARG was probably required because of the
%service_* rpm macros were playing tricks with the shell positional
parameters. This is bad practice and error prones so let's assume
that no macros should do that anymore and hence it's safe to assume
that positional parameters remains unchanged after any rpm macro
call.
- Change the persmissions for /var/run/postgresql to 1775, so that
the directory can only be used by users in the postgres group
(bsc#1123886).
- Move bash profile out of /var/lib to allow transactional updates
(bsc#1100397).
- Use /run/postgresql instead of /var/run/postgresql in %ghost and
postgresql-tmpfiles.conf to avoid rpmlint warnings and errors.
- add /var/run/postgresql to the filelist. as %ghost for systemd
systems and directly for non systemd systems
- fix the unexpanded macro in the description of server-devel
- Also bump the default package to 11.
- add server-devel and llvmjit package file sections
- Add the new subpackages server-devel and llvmjit that were
introduced with postgresql11.
- bump to 11

==== postgresql11-libs ====
Version update (10.7 -> 11.2)
Subpackages: libecpg6 libpq5

- Update to 11.2:
* https://www.postgresql.org/docs/11/release-11-2.html
* https://www.postgresql.org/about/news/1920/
* By default, panic instead of retrying after fsync() failure,
to avoid possible data corruption.
* Fix handling of unique indexes with INCLUDE columns on
partitioned tables.
* Ensure that NOT NULL constraints of a partitioned table are
honored within its partitions.
* Numerous other bug fixes.
- Overhaul README.SUSE
- The release tags between the main package build and libs might
be different, but that's not a problem, so we can relax the tight
dependency of server-devel on devel.
- Adjust the line between headers going to devel and server-devel.
Now everything under /usr/include/pgsql/server is in server-devel
and the rest of /usr/include/pgsql is in devel (bsc#1120035).
- move the server-devel package definition into the buildmain
section
- Add sha256 file to list of sources
- Update v11.1 files from upstream
- Update to 11.1:
* CVE-2018-16850, bsc#1114837: Improper quoting of transition
table names when pg_dump emits CREATE TRIGGER can cause
privilege escalation
* Numerous bug fixes, see the release notes:
https://www.postgresql.org/docs/current/release-11-1.html
* Remove unneeded library dependencies from PGXS.
- Update to 11.0.
* https://www.postgresql.org/about/news/1894/
* https://www.postgresql.org/docs/11/static/release-11.html
- Improvements to partitioning functionality, including:
* Add support for partitioning by a hash key
* Add support for PRIMARY KEY, FOREIGN KEY, indexes, and triggers
on partitioned tables.
* Allow creation of a ?default? partition for storing data that
does not match any of the remaining partitions.
* UPDATE statements that change a partition key column now cause
affected rows to be moved to the appropriate partitions.
* Improve SELECT performance through enhanced partition
elimination strategies during query planning and execution.
- Improvements to parallelism, including:
* CREATE INDEX can now use parallel processing while building a
B-tree index.
* Parallelization is now possible in CREATE TABLE ... AS, CREATE
MATERIALIZED VIEW, and certain queries using UNION.
* Parallelized hash joins and parallelized sequential scans now
perform better.
- SQL stored procedures that support embedded transactions.
- Optional Just-in-Time (JIT) compilation for some SQL code,
speeding evaluation of expressions (new subpackage: -llvmjit).
- Window functions now support all framing options shown in the
SQL:2011 standard, including RANGE distance PRECEDING/FOLLOWING,
GROUPS mode, and frame exclusion options.
- Covering indexes can now be created, using the INCLUDE clause of
CREATE INDEX.
- Many other useful performance improvements, including the ability
to avoid a table rewrite for ALTER TABLE ... ADD COLUMN with a
non-null column default.
- Split a new -server-devel subpackage from -devel.
- update to 11 beta3
https://www.postgresql.org/docs/11/static/release-11.html
https://www.postgresql.org/about/news/1878/
CVE-2018-10925 CVE-2018-10915
- initial package

==== python-certifi ====
Version update (2018.11.29 -> 2019.3.9)

- Update to 2019.3.9:
* Add emSign Root CA - G1
* Add emSign ECC Root CA - G3
* Add Hongkong Post Root CA 3
- Rebase python-certifi-shipped-requests-cabundle.patch

==== python-cffi ====
Subpackages: python2-cffi python3-cffi

- Remove test suite exception which was fixed by 7a76a38153*.patch
- Add doc/*/*.rst to %doc

==== python-dnspython ====
Version update (1.15.0 -> 1.16.0)
Subpackages: python2-dnspython python3-dnspython

- Update to 1.16.0:
* various fixes for wheel/cryptodome/etc
- Remove all patches, merged upstream:
* 210.patch
* pycryptodome.patch
* readme.patch

==== python-libvirt-python ====
Version update (5.0.0 -> 5.1.0)

- Update to 5.1.0
- Add all new APIs and constants in libvirt 5.1.0
- jsc#SLE-3887, jsc#SLE-4480, jsc#SLE-4577

==== python-msgpack ====
Version update (0.5.6 -> 0.6.1)

- update to 0.6.1
* unpackb(data) configures max_*_len options from len(data), instead
of static default sizes.
* Unpacker(max_buffer_len=N) configures max_*_len options from N, instead
of static default sizes.
* max_bin_len, max_str_len, and max_ext_len are deprecated.
* unpacker: Default value of input limits are smaller than before to
avoid DoS attack
* Unpacker doesn't wrap underlaying ValueError (including UnicodeError)
into UnpackValueError. If you want to catch all exception during unpack,
you need to use try ... except Exception with minimum try code block.
* PackValueError and PackOverflowError are also removed. You need to catch
normal ValueError and OverflowError.
* Unpacker has strict_map_key option now. When it is true, only bytes
and str (unicode in Python 2) are allowed for map keys.
* Extension modules are merged. There is msgpack._cmsgpack instead
of msgpack._packer and msgpack._unpacker.
* Add Unpacker.getbuffer() method.
* unpacker: msgpack.StackError is raised when input data contains too nested
data
* unpacker: msgpack.FormatError is raised when input data is not valid
msgpack format.

==== python-packaging ====
Version update (17.1 -> 19.0)
Subpackages: python2-packaging python3-packaging

- Fix check that egg-info is a directory to work with %check enabled,
and better explain how it works
- Remove unnecessary build dependency on base
- Re-add test dependency on pyparsing with minimum version defined upstream,
and replace inline comment with GitHub issue URL
- Add LICENSE.APACHE LICENSE.BSD to %license
- Update to v19.0
* Fix string representation of PEP 508 direct URL requirements with markers.
* Better handling of file URLs
This allows for using ``file:///absolute/path``, which was previously
prevented due to the missing ``netloc``
This allows for all file URLs that ``urlunparse`` turns back into the
original URL to be valid
- from v18.0
* Improve error messages when invalid requirements are given

==== python-pip ====
Version update (19.0.2 -> 19.0.3)

- update to version 19.0.3:
* Fix an IndexError crash when a legacy build of a wheel
fails. (#6252)
* Fix a regression introduced in 19.0.2 where the filename in a
RECORD file of an installed file would not be updated when
installing a wheel. (#6266)

==== python-psutil ====
Version update (5.5.1 -> 5.6.0)

- update to version 5.6.0:
* Enhancements
+ 1379: [Windows] Process suspend() and resume() now use
NtSuspendProcess and NtResumeProcess instead of
stopping/resuming all threads of a process. This is faster and
more reliable (aka this is what ProcessHacker does).
+ 1420: [Windows] in case of exception disk_usage() now also shows
the path name.
+ 1422: [Windows] Windows APIs requiring to be dynamically loaded
from DLL libraries are now loaded only once on startup (instead
of on per function call) significantly speeding up different
functions and methods.
+ 1426: [Windows] PAGESIZE and number of processors is now
calculated on startup.
+ 1428: in case of error, the traceback message now shows the
underlying C function called which failed.
+ 1433: new Process.parents() method. (idea by Ghislain Le Meur)
+ 1437: pids() are returned in sorted order.
+ 1442: python3 is now the default interpreter used by Makefile.
* Bug fixes
+ 1353: process_iter() is now thread safe (it rarely raised
TypeError).
+ 1394: [Windows] Process name() and exe() may erroneously return
"Registry". QueryFullProcessImageNameW is now used instead of
GetProcessImageFileNameW in order to prevent that.
+ 1411: [BSD] lack of Py_DECREF could cause segmentation fault on
process instantiation.
+ 1419: [Windows] Process.environ() raises NotImplementedError
when querying a 64-bit process in 32-bit-WoW mode. Now it raises
AccessDenied.
+ 1427: [OSX] Process cmdline() and environ() may erroneously
raise OSError on failed malloc().
+ 1429: [Windows] SE DEBUG was not properly set for current
process. It is now, and it should result in less AccessDenied
exceptions for low-pid processes.
+ 1432: [Windows] Process.memory_info_ex()'s USS memory is
miscalculated because we're not using the actual system
PAGESIZE.
+ 1439: [NetBSD] Process.connections() may return incomplete
results if using oneshot().
+ 1447: original exception wasn't turned into NSP/AD exceptions
when using Process.oneshot() ctx manager.
* Incompatible API changes
+ 1291: [OSX] Process.memory_maps() was removed because inherently
broken (segfault) for years.

==== python-pyOpenSSL ====

- Remove no longer necessary pytest argument -k "not test_export_text"

==== python-pyzmq ====
Version update (17.1.2 -> 18.0.1)

- update to version 18.0.1:
* Fixes installation from source on non-unicode locales with Python
3. There are no code changes in this release.
- specfile:
* update copyright year
- update to version 18.0.0:
* Update bundled libzmq to 4.3.1 (fixes CVE-2019-6250)
* Added :func:`~zmq.proxy_steerable` and
:class:`zmq.devices.ProxySteerable`
* Added bind_{in|out|mon}_to_random_port variants for proxy device
methods
* Performance improvements for sends with asyncio
* Fix sending memoryviews/bytearrays with cffi backend
- changes from version 17.1.3:
* Fix compatibility with tornado 6 (removal of stack_context)

==== python-rpm-macros ====
Version update (20190221.08f1194 -> 20190307.81ca329)

- Update to version 20190307.81ca329:
* We should preserve existing PYTHONPATH.
- bsc#1128323: Update to version 20190307.fbaed33 bsc#1128323:
* Add --ignore to pytest calls to ignore build directories.

==== python-tornado ====

- Fix fdupes macro expansion

==== qemu ====
Subpackages: qemu-arm qemu-block-curl qemu-block-dmg qemu-block-gluster
qemu-block-iscsi qemu-block-nfs qemu-block-rbd qemu-block-ssh qemu-extra
qemu-guest-agent qemu-ipxe qemu-ksm qemu-kvm qemu-lang qemu-ppc qemu-s390
qemu-seabios qemu-sgabios qemu-tools qemu-ui-curses qemu-ui-gtk qemu-ui-sdl
qemu-vgabios qemu-x86

- Again address ipxe GCC 9 incompatibilities. Previously included
patch to disable unneeded warning got muffed somehow (bsc#1121464)

==== redland ====

- PostrgeSQL's pg_config is meant for linking server extensions,
use libpq's pkg-config instead (redland-postgresql.patch).
This is needed to fix build with PostgreSQL 11.

==== rsyslog ====

- Add rsyslog-pgsql-pkg-config.patch: use pkgconfig to find the
right libraries/directories for postgresql. According to pgsql
upstream, pg_config must only be used to buildpgsql modules.

==== signon-kwallet-extension ====
Version update (18.12.2 -> 18.12.3)

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== spectacle ====
Version update (18.12.2 -> 18.12.3)
Subpackages: spectacle-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== step ====
Version update (18.12.2 -> 18.12.3)
Subpackages: step-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== sweeper ====
Version update (18.12.2 -> 18.12.3)
Subpackages: sweeper-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* No code changes since 18.12.2

==== system-tuning-common-SUSE ====

- Do not automagically online memory on s390x (bsc#1127557)
* update 80-hotplug-cpu-mem.rules

==== umbrello ====
Version update (18.12.2 -> 18.12.3)
Subpackages: umbrello-lang

- Update to 18.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.3.php
- Changes since 18.12.2:
* Fix 'No tree view update of entity unique and check constraint'
* Fix moving entities by property dialog
* Fix 'Cannot move entities, components, subsystems and nodes from sub folder
to root folder' (kde#404892)
* Fix allowing moving of ports to a sub folder in the tree view
* Fix 'No tree view update of entity primary key constraint' (kde#350241)
* Add typedef to class UMLForeignKeyConstraintDialog
* Fix 'Cannot add foreign key to entity' (kde#404891)
* release-windows-packages: auto detect version
* release-windows-packages: fix fetching source tar ball name
* Fix 'Non-optimal vertical position of added messages to sequence diagrams'
(kde#404422)
* Handle default case in ChildWidgetPlacementPort::setNewPositionWhenMoved
* Fix crash on adding ports to component widget by context menu

==== xprop ====
Version update (1.2.3 -> 1.2.4)

- Update to version 1.2.4
* Add missing braces around else clause in Read_Quoted()
* Fix -Wsign-compare warning in dsimple.c
* Fix typo in xprop.man
* Update configure.ac bug URL for gitlab migration
* Update README for gitlab migration

==== yast2-pkg-bindings ====
Version update (4.1.1 -> 4.1.2)

- zypp::TriBool now needs an explicit cast to bool (bsc#1128364)
(since boost-1.69.0)
- 4.1.2

==== zbar ====

- Use gcc7 in SLE_12


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages