Mailinglist Archive: opensuse-factory (276 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190306 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190306

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
glibc
glibc
libstorage-ng (4.1.95 -> 4.1.96)
patterns-yast (20181130 -> 20190228)
rzip
virt-manager
yast2 (4.1.56 -> 4.1.60)
yast2-configuration-management (4.1.5 -> 4.1.6)
yast2-control-center (4.1.6 -> 4.1.7)
yast2-installation (4.1.37 -> 4.1.39)
yast2-iscsi-client (4.1.5 -> 4.1.6)
yast2-network (4.1.42 -> 4.1.43)
yast2-packager (4.1.29 -> 4.1.30)
yast2-ruby-bindings (4.1.2 -> 4.1.4)
yast2-storage-ng (4.1.68 -> 4.1.70)
yast2-users (4.1.9 -> 4.1.10)

=== Details ===

==== glibc ====

- regex-read-overrun.patch: fix read overrun (CVE-2019-9169, bsc#1127308,
BZ #24114)
- ldconfig-concurrency.patch: Avoid concurrency problem in ldconfig
(bsc#1117993, BZ #23973)

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale glibc-locale-base
nscd

- regex-read-overrun.patch: fix read overrun (CVE-2019-9169, bsc#1127308,
BZ #24114)
- ldconfig-concurrency.patch: Avoid concurrency problem in ldconfig
(bsc#1117993, BZ #23973)

==== libstorage-ng ====
Version update (4.1.95 -> 4.1.96)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#621
- handle entries in crypttab whose block device do not exist
(bsc#1123342)
- added unit test
- added documentation
- added explanation
- renamed variable
- 4.1.96

==== patterns-yast ====
Version update (20181130 -> 20190228)
Subpackages: patterns-yast-x11_yast patterns-yast-yast2_basis
patterns-yast-yast2_install_wf

- Added yast2-alternatives to the "yast2_basis" pattern (opensuse
only) (bsc#1125040).
- 20190228

==== rzip ====

- Modernise spec file
- Install license

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- Temporarily disable Xen PVH support until feature is more usable
(bsc#1125889)
virtinst-add-pvh-support.patch

==== yast2 ====
Version update (4.1.56 -> 4.1.60)
Subpackages: yast2-logs

- added "Modify" button label (related to gh#yast/yast-yast2#713)
- 4.1.60
- Added command line support also for the other Report module
methods (related to bnc#1127685)
- 4.1.59
- Fixed a failing testsuite, the Report.LongError used in the
global exception handler did not support the command line mode
(related to bnc#1127685)
- 4.1.58
- bnc#1127685
- made Report module long message reporting popups adjustable
- 4.1.57

==== yast2-configuration-management ====
Version update (4.1.5 -> 4.1.6)

- Fix $visibleIf condition evaluation when the left value is "false"
or when the path is absolute (bsc#1127402).
- 4.1.6

==== yast2-control-center ====
Version update (4.1.6 -> 4.1.7)
Subpackages: yast2-control-center-qt

- Introduce very effective fallback for icons (boo#1127245)
- 4.1.7

==== yast2-installation ====
Version update (4.1.37 -> 4.1.39)

- Do not write the displaymanager value (part of bsc#1125040).
- 4.1.39
- Respect Textmode=1 when installing over SSH with a DISPLAY (bsc#1047470)
- 4.1.38

==== yast2-iscsi-client ====
Version update (4.1.5 -> 4.1.6)

- fixed parsing of iscsiadm -m node -P 1 (bsc#1121806)
- 4.1.6

==== yast2-network ====
Version update (4.1.42 -> 4.1.43)

- Fixed "can't modify frozen String" crashes (related to
bsc#1125006 and gh#yast/yast-ruby-bindings#228)
- 4.1.43

==== yast2-packager ====
Version update (4.1.29 -> 4.1.30)

- fix showing help text for product license (bsc#1126491)
- 4.1.30

==== yast2-ruby-bindings ====
Version update (4.1.2 -> 4.1.4)

- Always return frozen strings from the translation functions,
make the results unified (related to bsc#1125006)
- 4.1.4
- bnc#1127685
- Internal error message popup is scaled according to its content
- 4.1.3

==== yast2-storage-ng ====
Version update (4.1.68 -> 4.1.70)

- Fixed "can't modify frozen String" crashes (related to
bsc#1125006)
- Fixed missing translation (bsc#1127181)
- 4.1.70
- Translates the filesystem roles properly (bsc#1127756).
- 4.1.69

==== yast2-users ====
Version update (4.1.9 -> 4.1.10)

- Removed "btrfs_subvolume" from user default values (bsc#1125779)
- Added AutoYaST support for home Btrfs subvolumes.
- 4.1.10


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages