Mailinglist Archive: opensuse-factory (276 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190301 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190301

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
NetworkManager (1.14.4 -> 1.14.6)
SuSEfirewall2
a52dec
apache-commons-io (2.4 -> 2.6)
apache2
apparmor
attica-qt5
autoyast2 (4.1.1 -> 4.1.2)
avalon-logkit
baloo5
bluedevil5 (5.15.0 -> 5.15.2)
bluez-qt
breeze (5.15.0 -> 5.15.2)
breeze-gtk (5.15.0 -> 5.15.2)
breeze4-style (5.15.0 -> 5.15.2)
breeze5-icons
brotli
createrepo_c (0.10.0.git20170131.04828e6 -> 0.12.0)
cups-filters (1.22.0 -> 1.22.1)
curl (7.63.0 -> 7.64.0)
discover (5.15.0 -> 5.15.2)
dnsmasq
drkonqi5 (5.15.0 -> 5.15.2)
frameworkintegration
freeipmi (1.6.2 -> 1.6.3)
ghostscript
git (2.20.1 -> 2.21.0)
gnome-control-center
gnome-shell
gpg2
gsound
health-checker (1.1 -> 1.2)
ibus
ibus-table-chinese (1.8.2 -> 1.8.3~pre.1531454400.f1f6a33)
icu4j
iftop
installation-images-Kubic (14.410 -> 14.411)
irssi (1.1.2 -> 1.2.0)
iw (5.0 -> 5.0.1)
java-12-openjdk (12.0.0.0~26 -> 12.0.0.0~31)
kactivities-stats
kactivities5
kactivitymanagerd (5.15.0 -> 5.15.2)
karchive
kauth
kbookmarks
kcm_sddm (5.15.0 -> 5.15.2)
kcmutils
kcodecs
kcompletion
kconfig
kconfigwidgets
kcoreaddons
kcrash
kdbusaddons
kde-cli-tools5 (5.15.0 -> 5.15.2)
kde-gtk-config5 (5.15.0 -> 5.15.2)
kde-user-manager (5.15.0 -> 5.15.2)
kdeclarative
kded
kdelibs4support
kdesu
kdnssd-framework
kdoctools
kemoticons
kernel-source (4.20.10 -> 4.20.12)
kfilemetadata5
kgamma5 (5.15.0 -> 5.15.2)
kglobalaccel
kguiaddons
kholidays
khotkeys5 (5.15.0 -> 5.15.2)
khtml
ki18n
kiconthemes
kidletime
kimageformats
kinfocenter5 (5.15.0 -> 5.15.2)
kinit
kio
kipi-plugins
kirigami2
kitemmodels
kitemviews
kjobwidgets
kjs
kjsembed
kmenuedit5 (5.15.0 -> 5.15.2)
knewstuff
knotifications
knotifyconfig
kpackage
kparts
kpeople5
kplotting
kpty
kross
krunner
kscreen5 (5.15.0 -> 5.15.2)
kscreenlocker (5.15.0 -> 5.15.2)
kservice
ksshaskpass5 (5.15.1 -> 5.15.2)
ksysguard5 (5.15.0 -> 5.15.2)
ktexteditor
ktextwidgets
kunitconversion
kwallet
kwayland
kwayland-integration (5.15.0 -> 5.15.2)
kwidgetsaddons
kwin5 (5.15.0 -> 5.15.2)
kwindowsystem
kxmlgui
kxmlrpcclient5
lftp
libKF5ModemManagerQt
libKF5NetworkManagerQt
libcontainers-common
libgsm (1.0.14 -> 1.0.18)
libgweather (3.28.2 -> 3.28.3)
libidn2 (2.1.0 -> 2.1.1)
libkdecoration2 (5.15.0 -> 5.15.2)
libkdepim
libkgapi
libkscreen2 (5.15.0 -> 5.15.2)
libksysguard5 (5.15.0 -> 5.15.2)
liblouis
libqt4
librsvg (2.44.12 -> 2.44.13)
libssh (0.8.6 -> 0.8.7)
libstorage-ng (4.1.91 -> 4.1.95)
libteam
libvirt
libxkbcommon (0.8.3 -> 0.8.4)
libzypp (17.11.1 -> 17.11.2)
mariadb-connector-c (3.0.8 -> 3.0.9)
milou5 (5.15.0 -> 5.15.2)
mutter
nodejs-common (2.0 -> 3.0)
nodejs10 (10.15.0 -> 10.15.1)
obs-service-download_files
obs-service-tar_scm (0.9.4.1537959361.56833cb -> 0.10.5.1551309990.79898c7)
openSUSE-build-key
openssh
oxygen5 (5.15.0 -> 5.15.2)
oxygen5-icon-theme
patterns-base (20180616 -> 20190206)
perl-AnyEvent (7.14 -> 7.15)
perl-DBD-Pg
perl-DBD-mysql
perl-IO-Socket-SSL (2.060 -> 2.062)
perl-JSON (4.01 -> 4.02)
php7
plasma-browser-integration (5.15.1 -> 5.15.2)
plasma-framework
plasma-nm5 (5.15.0 -> 5.15.2)
plasma5-addons (5.15.0 -> 5.15.2)
plasma5-desktop (5.15.0 -> 5.15.2)
plasma5-integration (5.15.0 -> 5.15.2)
plasma5-openSUSE (15.0~git20181114T190445~21cb8a6 ->
15.0~git20190223T194652~7f4983a)
plasma5-pa (5.15.0 -> 5.15.2)
plasma5-workspace (5.15.0 -> 5.15.2)
polkit-kde-agent-5 (5.15.0 -> 5.15.2)
postgresql10 (10.5 -> 10.7)
powerdevil5 (5.15.0 -> 5.15.2)
prison-qt5
protobuf
purple-rocketchat (0.0+hg20180817 -> 0.0+hg20181203)
purpose
python-Twisted
python-keyring (15.1.0 -> 18.0.0)
python-matplotlib
python-numpy
python-py (1.7.0 -> 1.8.0)
python-pyOpenSSL
python-service_identity (17.0.0 -> 18.1.0)
python-sip
python-urlgrabber (3.9.1 -> 4.0.0)
remmina (1.3.2 -> 1.3.3)
ruby-common (2.1 -> 2.6)
ruby2.6
rubygem-gem2rpm
rubygem-parallel_tests (2.27.0 -> 2.27.1)
sblim-sfcb
schily
solid
sonnet
spice-gtk (0.35 -> 0.36)
sshfs (2.10 -> 3.5.0)
sssd
syndication
syntax-highlighting
sysdig (0.23.1_k4.20.10_1 -> 0.24.2_k4.20.12_1)
systemsettings5 (5.15.0 -> 5.15.2)
threadweaver
tracker-miners (2.1.5 -> 2.1.6)
vim (8.1.0877 -> 8.1.0892)
virtualbox (5.2.22_k4.20.10_1 -> 6.0.4_k4.20.12_1)
xdg-desktop-portal-kde (5.15.1 -> 5.15.2)
xf86-input-wacom
xorg-x11-server (1.20.3 -> 1.20.4)
xterm (343 -> 344)
yast2 (4.1.55 -> 4.1.56)
yast2-auth-client (4.1.0 -> 4.1.1)
yast2-bootloader (4.1.17 -> 4.1.19)
yast2-configuration-management (4.1.3 -> 4.1.5)
yast2-country (4.1.8 -> 4.1.9)
yast2-hardware-detection (4.0.0 -> 4.1.0)
yast2-ldap (4.0.0 -> 4.1.0)
yast2-metapackage-handler (4.0.0 -> 4.1.0)
yast2-network (4.1.39 -> 4.1.42)
yast2-nfs-client (4.1.4 -> 4.1.5)
yast2-nfs-server (4.0.3 -> 4.1.0)
yast2-online-update (4.0.2 -> 4.1.0)
yast2-packager (4.1.27 -> 4.1.29)
yast2-pam (4.0.0 -> 4.1.0)
yast2-perl-bindings (4.0.1 -> 4.1.0)
yast2-printer (4.0.3 -> 4.1.0)
yast2-python-bindings (4.0.9 -> 4.1.0)
yast2-scanner (4.0.3 -> 4.1.0)
yast2-slp (4.0.0 -> 4.1.0)
yast2-sudo (4.0.1 -> 4.1.0)
yast2-transfer (4.0.0 -> 4.1.0)
yast2-tune (4.0.2 -> 4.1.0)
yast2-users (4.1.8 -> 4.1.9)
yast2-vpn (4.0.1 -> 4.1.0)
yast2-xml (4.0.0 -> 4.1.0)
zypper (1.14.25 -> 1.14.26)

=== Details ===

==== NetworkManager ====
Version update (1.14.4 -> 1.14.6)
Subpackages: NetworkManager-lang libnm0 typelib-1_0-NM-1_0

- Update to version 1.14.6:
+ Fix memory corruption in internal DHCPv6 client
(CVE-2018-15688).
+ No longer limit number of search entires in resolv.conf to 6.
+ Support restricting NetworkManager.conf device configuration
based on used DHCP plugin.
+ Add "${MAC}" specifier for connection.stable-id. This uses the
current MAC address for seeding the stable generation of MAC
address, DHCP client-id or IPv6 stable-privacy interface
identifier.
+ Support special value "duid" for "ipv4.dhcp-client-id". This
generates an RFC4361-compliant client-id like the internal DHCP
client used to do by default. Previously, there was no explicit
name for such a client-id and it was not usable with dhclient
DHCP plugin. This also generates the same client-id as
systemd-networkd does by default.
+ Support and use a new kind of secret-key in
"/var/lib/NetworkManager/secret_key". The secret-key represents
the identity of the machine that is used for various purposes
like generating IPv6 stable privacy addesses. It is now
combined with "/etc/machine-id" so that changing only the
machine-id results in new identifiers. That matters for example
when cloning a virtual machine. Previously, the user hard to
prune NetworkManager's secret-key to get a new identity, now
regenerating machine-id suffices. Secret-keys generated by
earlier versions of NetworkManager are not affected and keep
their previous behavior.
+ Fix the DHCP client-ids based on the MAC address of
IPoIB/infiniband devices.
+ Fix restoring IP configuration after interface went down.
+ No longer let NetworkManager touch rp_filter setting. The
rp_filter sysctl must now be set outside of NetworkManager
according to the admin's preference. Note that a strict
rp_filter may break valid use-cases and interacts badly with
connectivity checking.
+ Various bug fixes and improvements.

==== SuSEfirewall2 ====

- Add deprecation warning messages for zypper to make the last users more
aware of the upcoming removal of SuSEfirewall2.
- Drop use of $FIRST_ARG in .spec
The use of $FIRST_ARG was probably required because of the
%service_* rpm macros were playing tricks with the shell positional
parameters. This is bad practice and error prones so let's assume
that no macros should do that anymore and hence it's safe to assume
that positional parameters remains unchanged after any rpm macro
call.

==== a52dec ====

- altivec.patch: always use the GNU version of the altivec insns

==== apache-commons-io ====
Version update (2.4 -> 2.6)

- Update to upstream version 2.6
* many bugfixes, features and enhancenments, like
Automatic-Module-Name entry in manifest
* requires jdk7 or later
* see RELEASE-NOTES.txt for details
- Generated a build.xml to be able to build with ant
- Build with tests is now optional
- Removed patch:
* commons-io-version-property.patch
+ not needed anymore in this version

==== apache2 ====
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- added patches
fix https://github.com/icing/mod_h2/issues/167 [bsc#1125965]
+ apache2-mod_http2-issue-167.patch
- Replace old $RPM_* shell vars. Avoid old tar syntax.
- Tag scriptlets as explicitly requiring bash.

==== apparmor ====
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser
apparmor-parser-lang apparmor-profiles apparmor-utils apparmor-utils-lang
pam_apparmor pam_apparmor-32bit perl-apparmor python3-apparmor

- add dnsmasq-revert-alternation.diff: revert path alternation in
dnsmasq profile and re-add peer=/usr/sbin/libvirtd rules to avoid
breaking libvirtd (boo#1127073)

==== attica-qt5 ====
Subpackages: libKF5Attica5

- Downgrade the Qt version requirement to build with 5.9

==== autoyast2 ====
Version update (4.1.1 -> 4.1.2)
Subpackages: autoyast2-installation

- Avoid to crash when the profile has a not valid sofware section
(bsc#1125959).
- 4.1.2

==== avalon-logkit ====

- Build against the glassfish-servlet-api

==== baloo5 ====
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Fix crashing kdeinit, add
0001-Check-string-length-to-avoid-crash-for-tags-URL.patch
- Add 0001-Do-not-use-qfileinfo-metadatachangetime-if-Qt-lt-5.10.patch to
revert a change by upstream that removes support for Qt < 5.10
- Downgrade the Qt version requirement to build with 5.9

==== bluedevil5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: bluedevil5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== bluez-qt ====
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Downgrade the Qt version requirement to build with 5.9

==== breeze ====
Version update (5.15.0 -> 5.15.2)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers libbreezecommon5-5

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== breeze-gtk ====
Version update (5.15.0 -> 5.15.2)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== breeze4-style ====
Version update (5.15.0 -> 5.15.2)
Subpackages: libbreezecommon4-5

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== breeze5-icons ====

- Downgrade the Qt version requirement to build with 5.9

==== brotli ====
Subpackages: libbrotlicommon1 libbrotlidec1 libbrotlienc1

- Add brotli_Verbose-CLI+Shared-Brotli.patch: Verbose CLI + start
pulling "Shared-Brotli".
* verbose CLI output; fix gh#google/brotlie#666.
* pull `SHIFT` transforms; currently this is semantically dead
code; later it will be used by "Shared-Brotli".
- Add brotli_Ensure-decompression-consumes-all-input.patch: Ensure
decompression consumes all input. If not, it's a corrupt stream.
- Tweak spec slightly.

==== createrepo_c ====
Version update (0.10.0.git20170131.04828e6 -> 0.12.0)
Subpackages: libcreaterepo_c0 python3-createrepo_c

- Backport fixes from upstream
* 0001-zck_end_chunk-returns-number-of-bytes-written-or-1-f.patch
* 0002-Add-missing-sentinal.patch
* 0003-Fix-misc-test.patch
- Update to 0.12.0
+ Add basic support for zchunk metadata
+ Add support for building wheels to upload to PyPI
- Drop Python 2 subpackage
- Enable drpm support
- Enable zchunk for openSUSE Leap 15.1+ and Tumbleweed
- Adjust changes entries to use full author identities
- Update to 0.11.1
+ Add support for RPMs with large files
+ Identify Requires(missingok) as Recommends correctly
+ Enable legacy tags by default
+ Fix missing packages in mergerepo_c with multiple VR of same name
+ Add mergerepo_c --repo-prefix-search and --repo-prefix-replace
+ Build against Python 3 by default for bindings
- Drop snapshot source service and snapshot tarball
- Use license macro for license file
- Drop trailing whitespace
- Fix comment about drpm support

==== cups-filters ====
Version update (1.22.0 -> 1.22.1)

- Update to version 1.22.1:
* braille: Use sort command with LC_ALL=C for reproducibility
of the genrated files, needed for distribution packaging.
* cups-browsed, driverless: When polling the printer's
capabilities via get-printer-attributes IPP request for
driverless printing, use the attributes "all" and
"media-col-database". Without "all" some printers do not report
"urf-supported" and without "media-col-database" not all paper
size and marging info gets reported.
* braille: Document how to rework output before embossing.

==== curl ====
Version update (7.63.0 -> 7.64.0)
Subpackages: libcurl4

- BuildRequire libcurl4-mini for !bootstrap to avoid build cycles
due to cmake pulling libcurl4
- update to version 7.64.0
[bcs#1123371, CVE-2018-16890][bcs#1123377, CVE-2019-3822]
[bcs#1123378, CVE-2019-3823]
* Changes:
- cookies: leave secure cookies alone
- hostip: support wildcard hosts
- http: Implement trailing headers for chunked transfers
- http: added options for allowing HTTP/0.9 responses
- timeval: Use high resolution timestamps on Windows
* Bugfixes:
- CVE-2018-16890: NTLM type-2 out-of-bounds buffer read
- CVE-2019-3822: NTLMv2 type-3 header stack buffer overflow
- CVE-2019-3823: SMTP end-of-response out-of-bounds read
- FAQ: remove mention of sourceforge for github
- OS400: handle memory error in list conversion
- OS400: upgrade ILE/RPG binding.
- README: add codacy code quality badge
- Revert http_negotiate: do not close connection
- THANKS: added several missing names from year <= 2000
- build: make 'tidy' target work for metalink builds
- cmake: added checks for variadic macros
- cmake: updated check for HAVE_POLL_FINE to match autotools
- cmake: use lowercase for function name like the rest of the code
- configure: detect xlclang separately from clang
- configure: fix recv/send/select detection on Android
- configure: rewrite --enable-code-coverage
- conncache_unlock: avoid indirection by changing input argument type
- cookie: fix comment typo
- cookies: allow secure override when done over HTTPS
- cookies: extend domain checks to non psl builds
- cookies: skip custom cookies when redirecting cross-site
- curl --xattr: strip credentials from any URL that is stored
- curl -J: refuse to append to the destination file
- curl/urlapi.h: include "curl.h" first
- curl_multi_remove_handle() don't block terminating c-ares requests
- darwinssl: accept setting max-tls with default min-tls
- disconnect: separate connections and easy handles better
- disconnect: set conn->data for protocol disconnect
- docs/version.d: mention MultiSSL
- docs: fix the --tls-max description
- docs: use $(INSTALL_DATA) to install man page
- docs: use meaningless port number in CURLOPT_LOCALPORT example
- gopher: always include the entire gopher-path in request
- http2: clear pause stream id if it gets closed
- if2ip: remove unused function Curl_if_is_interface_name
- libssh: do not let libssh create socket
- libssh: enable CURLOPT_SSH_KNOWNHOSTS and CURLOPT_SSH_KEYFUNCTION for libssh
- libssh: free sftp_canonicalize_path() data correctly
- libtest/stub_gssapi: use "real" snprintf
- mbedtls: use VERIFYHOST
- multi: multiplexing improvements
- multi: set the EXPIRE_*TIMEOUT timers at TIMER_STARTSINGLE time
- ntlm: fix NTMLv2 compliance
- ntlm_sspi: add support for channel binding
- openssl: adapt to 3.0.0, OpenSSL_version_num() is deprecated
- openssl: fix the SSL_get_tlsext_status_ocsp_resp call
- openvms: fix OpenSSL discovery on VAX
- openvms: fix typos in documentation
- os400: add a missing closing bracket
- os400: fix extra parameter syntax error
- pingpong: change default response timeout to 120 seconds
- pingpong: ignore regular timeout in disconnect phase
- printf: fix format specifiers
- runtests.pl: Fix perl call to include srcdir
- schannel: fix compiler warning
- schannel: preserve original certificate path parameter
- schannel: stop calling it "winssl"
- sigpipe: if mbedTLS is used, ignore SIGPIPE
- smb: fix incorrect path in request if connection reused
- ssh: log the libssh2 error message when ssh session startup fails
- test1558: verify CURLINFO_PROTOCOL on file:// transfer
- test1561: improve test name
- test1653: make it survive torture tests
- tests: allow tests to pass by 2037-02-12
- tests: move objnames-* from lib into tests
- timediff: fix math for unsigned time_t
- timeval: Disable MSVC Analyzer GetTickCount warning
- tool_cb_prg: avoid integer overflow
- travis: added cmake build for osx
- urlapi: Fix port parsing of eol colon
- urlapi: distinguish possibly empty query
- urlapi: fix parsing ipv6 with zone index
- urldata: rename easy_conn to just conn
- winbuild: conditionally use /DZLIB_WINAPI
- wolfssl: fix memory-leak in threaded use
- spnego_sspi: add support for channel binding
- Fix wrong summary, curl is at version 7, not 4.

==== discover ====
Version update (5.15.0 -> 5.15.2)
Subpackages: discover-backend-flatpak discover-backend-packagekit discover-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- Changes since 5.15.1:
* Provide a better package icon
* Mark all radio buttons as such (kde#404400)
* Make sure we connect the action to its bridge (kde#403378)
* Remove connectivity flash at start (kde#404610)
* [Updates page] Try our best to not elide version strings (kde#404624)
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* ApplicationPage: Fix crash when the sources model gets refreshed
(kde#404402)
* fwupd: warn if threads could not be killed
* UpdatesPage: Fix icon sizing on small screens (kde#404070)
* Set parent on newly created fwupd resource (kde#402328)
* Don't show tooltip when search field has text and set a timeout period
* Add a timeout for KNS backends (kde#399981)
* Don't enable the install button in the app page until we know the state

==== dnsmasq ====

- Drop use of $FIRST_ARG in .spec
The use of $FIRST_ARG was probably required because of the
%service_* rpm macros were playing tricks with the shell positional
parameters. This is bad practice and error prones so let's assume
that no macros should do that anymore and hence it's safe to assume
that positional parameters remains unchanged after any rpm macro
call.

==== drkonqi5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: drkonqi5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== frameworkintegration ====
Subpackages: frameworkintegration-plugin libKF5Style5

- Downgrade the Qt version requirement to build with 5.9

==== freeipmi ====
Version update (1.6.2 -> 1.6.3)
Subpackages: libfreeipmi17 libipmiconsole2 libipmidetect0 libipmimonitoring6

- Update to 1.6.3
o In ipmi-locate, support parsing SPMI tables exported via sysfs.
o Support Intel S2600GZ OEM sensor and SEL events.
o Support Intel S2600WP OEM sensor and SEL events.
o Support Gigabyte MG20-OP0-ZB OEM SEL events.
o Fix DISCRETE_READING workaround in libipmimonitoring.
o In libfreeipmi, add workaround for packets that are re-ordered
during sensor bridging.
o Minor bug fixes.
o Various documentation updates/fixes.

==== ghostscript ====
Subpackages: ghostscript-x11

- Added apparmor_usr.bin.gs. This profile prevents execution of
executables to serve as hardening for the binaries that process
ghostscript. This is of limited use but prevents simple exploits.

==== git ====
Version update (2.20.1 -> 2.21.0)
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- git 2.21.0
* Historically, the "-m" (mainline) option can only be used for "git
cherry-pick" and "git revert" when working with a merge commit.
This version of Git no longer warns or errors out when working with
a single-parent commit, as long as the argument to the "-m" option
is 1 (i.e. it has only one parent, and the request is to pick or
revert relative to that first parent). Scripts that relied on the
behaviour may get broken with this change.
* Small fixes and features for fast-export and fast-import.
* The "http.version" configuration variable can be used with recent
enough versions of cURL library to force the version of HTTP used
to talk when fetching and pushing.
* "git push $there $src:$dst" rejects when $dst is not a fully
qualified refname and it is not clear what the end user meant.
* Update "git multimail" from the upstream.
* A new date format "--date=human" that morphs its output depending
on how far the time is from the current time has been introduced.
"--date=auto:human" can be used to use this new format (or any
existing format) when the output is going to the pager or to the
terminal, and otherwise the default format.
- Fix worktree creation race (bsc#1114225).
worktree-fix-worktree-add-race.patch
setup-don-t-fail-if-commondir-reference-is-deleted.patch

==== gnome-control-center ====
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-lang gnome-control-center-user-faces

- Add control-center-network-fix-ce-apply-button.patch:
network: disable the "Apply" button until a change has been made
(glgo#GNOME/gnome-control-center!402 bsc#1040054).

==== gnome-shell ====
Subpackages: gnome-shell-browser-plugin gnome-shell-calendar gnome-shell-lang

- Add upstream bug fix patches from the stable branch:
+ gnome-shell-panel-Dont-allow-opening-hidden-menus.patch: panel:
Don't allow opening hidden menus via keybindings.
+ gnome-shell-disable-POPUP-keybindings-in-unlock-screen.patch:
shellActionModes: disable POPUP keybindings in unlock screen.
+ gnome-shell-inputMethod-Avoid-calling-set_preedit_text.patch:
inputMethod: Avoid calling set_preedit_text() if unnecessary.
+ gnome-shell-inputMethod-Keep-track-preedit-string-visibility.patch:
inputMethod: Keep track of preedit string visibility.

==== gpg2 ====
Subpackages: gpg2-lang

- Fix build with gcc9 [bsc#1121223]
* Avoid using compound literals
- Upstream bug: https://dev.gnupg.org/T4367
* Added upstream patches:
- 0001-libdns-Avoid-using-compound-literals.patch
- 0002-libdns-Avoid-using-compound-literals-2.patch
- 0003-libdns-Avoid-using-compound-literals-3.patch
- 0004-libdns-Avoid-using-compound-literals-4.patch
- 0005-libdns-Avoid-using-compound-literals-5.patch
- 0006-libdns-Avoid-using-compound-literals-6.patch
- 0007-libdns-Avoid-using-compound-literals-7.patch
- 0008-libdns-Avoid-using-compound-literals-8.patch
- Allow coredumps in X11 desktop sessions (bsc#1124847)
gpg-agent unconditionally disables coredumps, which is not
supposed to happen in the code path that does just exec(argv[])
gnupg-gpg-agent-ulimit.patch

==== gsound ====
Subpackages: libgsound0 typelib-1_0-GSound-1_0

- Add gsound-gsound-play-Call-setlocale.patch: gsound-play: Call
setlocale in main function. It is required to correctly show
translated messages on some locales (bgo#760429).
- Run spec-cleaner, modernize spec.

==== health-checker ====
Version update (1.1 -> 1.2)
Subpackages: health-checker-plugins-MicroOS

- Update to version 1.2
* Add hooks to send telemetrics events

==== ibus ====
Subpackages: ibus-gtk ibus-gtk-32bit ibus-gtk3 ibus-lang libibus-1_0-5
libibus-1_0-5-32bit typelib-1_0-IBus-1_0

- Fix boo#1126011: fix unexpected LibreOffice's dependency on IBus
* Remove "Supplements" for libreoffice-gnome

==== ibus-table-chinese ====
Version update (1.8.2 -> 1.8.3~pre.1531454400.f1f6a33)
Subpackages: ibus-table-chinese-array ibus-table-chinese-cangjie
ibus-table-chinese-cantonese ibus-table-chinese-easy ibus-table-chinese-erbi
ibus-table-chinese-jyutping ibus-table-chinese-quick ibus-table-chinese-scj
ibus-table-chinese-stroke5 ibus-table-chinese-wu
ibus-table-chinese-wubi-haifeng ibus-table-chinese-wubi-jidian
ibus-table-chinese-yong

- update version 1.8.3~pre.1531454400.f1f6a33
* update jyutping and cantonese tables
* fix character frequency of 'zou'
* add cantonyale table
* use nicer values for symbol and status prompt
* support pinyin mode also for stroke5 table
- fix Tumbleweed build

==== icu4j ====

- Added patch:
* icu4j-63.1-java8compat.patch
+ Prevent use of Jdk >= 9 functions
- Clean up the file and sanitize osgi bundle versions

==== iftop ====

- 0001-Prefer-ncurses6w.patch: prefer ncursesw6, previously force-fed
via CFLAGS/LDFLAGS but did not really work.

==== installation-images-Kubic ====
Version update (14.410 -> 14.411)

- merge gh#openSUSE/installation-images#296
- remove dependency on pciutils-ids
- 14.411

==== irssi ====
Version update (1.1.2 -> 1.2.0)

- update to 1.2.0
* Improved the /STATUSBAR commands (#858)
* /SET no longer shows `=' between setting and value (#886)
* /CUBES removed from default config (available as script)
(#956)
* /1 /2 /3 ... removed from default config (available as new
setting window_number_commands) (#958)
* Always redraw the screen on resize. By David Phillips (#896)
* Private notices intended for channels are now displayed on
the channel (new setting notice_channel_context) (#959)
+ Imported the "Off-the-record" module into Irssi tree (#854,
[#589], #196)
+ Initial support for sideways split windows (#697, #431,
[#224], #807, FS#310, #947, #955, #989)
+ Change the implementation of `wcwidth'. This is used to
calculate the width of emojis on your terminal screen (#917,
[#720])
+ Make the wcwidth functions available from Perl (#973):
string_width(str)
string_chars_for_width(str, width)
wcwidth(char)
+ Added completion_keep_word setting (#979)
+ Allow activity_hide_targets to hide activity in itemless
windows (#967, #997, #1001, #1003)
+ Added activity_hide_visible setting (#990)
+ Allow hiding of lines through the /IGNORE system (#901,
[#900], #892, #890, #884, #937)
+ Add window_default_hidelevel setting. By Doug Freed (#941)
+ Add activity_hide_window_hidelevel setting, defaulting to ON
(#938)
+ Add autolog_only_saved_channels setting, to autolog only
channels that are in the config (#968)
+ Add format support for the input line. By Ben Paxton,
originally by Jonas Hurrelmann (#764, FS#621, #1004)
use Irssi::TextUI;
gui_input_set_extent(pos, text)
gui_input_set_extents(pos, len, left, right)
gui_input_clear_extents(pos, len)
gui_input_get_extent(pos)
gui_input_get_text_and_extents()
gui_input_set_text_and_extents(...)
+ Parsing of IRCv3 CAP 3.2 (#775, #869)
+ Show CAP-related events in the user interface (#918, #916,
[#870], #704)
+ Continue using separators when addressing multiple nicks
with tab completion. By Manish Goregaokar (#822)
+ Bind Shift-tab by default. By Niklas Luokkala (#830, #829)
+ Fuzzing more things (#913, #780, #813)
- Disconnect SASL properly in case the SASL module got
unloaded from server (#931, #629, #618, #616)
- Fix backward completion jumping to the first instead of last
word (#979)
- Improve empty topic handling (#961, #905, #911, #897, #888)
- Prevent config truncation when no space left. By dequis and
Lukas Waymann (#922, #925, #910, #909, #906, #871, #817)
- Also time-out servers in lookup phase (#866, #130)
- Fix build with LibreSSL 2.7. By Dorian Harmans (#865)
- Fix a crash when appending to a textbuffer without
line. Reported by Jari Matilainen (#862)
- Fix segfault on sending large messages (#803, #796, #802)
- Fix segfault on invalid statusbar config (#993, #994)
- Fix random memory writes on restoring queries of foreign
protocols (#999, #1000)
- Make default keybinds deletable (#859, #507)
- Fix freeze when resizing Irssi very small (#946)
- Compare channels case-insensitively, avoiding confusions
with the config file (#857, #856)
- Fix DCC GET on Android. By Martin Staron (#844)
- Improve rawlog performance (#957)
- Fix nick escaping erroneously escaping quotes (#978, #974,
[#709])
- Protect against theme recursion, improve padding
performance, limit alignment padding. Credit to Oss-Fuzz
(#835, #851, #850, #846, #848)
- Fix recursive loop in replaces (#833, GL#23)
- Fix headers for compilation of C modules (#939)
- Documentation. By Zero King (#814). (#852)
- Sync NEWS, docs, scripts (#849, #855)
- Build system (#868, #867, #985, #988)
- Fix build on IBM i and AIX. By Calvin Buckley (#975)
- Misc fixes (#840, #839, #843, #953, #962). Tests (#806,
[#875], #905, #964, #1011). Fuzzing (#929).

==== iw ====
Version update (5.0 -> 5.0.1)

- Update to version 5.0.1
* Fixed typo introduced by previous change
* Re-added DEPEND line

==== java-12-openjdk ====
Version update (12.0.0.0~26 -> 12.0.0.0~31)

- Upgrade to upsteam tag jdk-12+31
* Fixes:
+ S8178798: Two compiler/aot/verification/vmflags tests fail by
timeout with UseAVX=3
+ S8214935: Upgrade IANA LSR data
+ S8216541: CompiledICHolders of VM locked unloaded nmethods
are released too late
+ S8216546: Support new Japanese era in java.lang.Character for
Java SE 11
+ S8217352: Remove EA from version string starting with Initial
RC promotion
+ S8217892: Clarify the support for the new Japanese era in
java.time.chrono.JapaneseEra
+ S8218020: Fix version number in mesa.md 3rd party legal file
+ S8218025: disable pop_frame and force_early_return caps for
Graal
+ S8218079: cleanup hotspot ProblemList files
+ S8218134: Modify the jQuery.md file to reflect the exact
jQuery license content
+ S8218162: problem list
j/u/s/t/o/o/t/java/util/stream/StreamLinkTest.java on solaris
w/ Xcomp
+ S8218168: clean up hotspot ProblemList
+ S8218178: vmTestbase/vm/mlvm/mixed/stress/regression/
/b6969574/INDIFY_Test.java fails with -Xcomp
+ S8218197: [failurehandler] parent processes shouldn't be
killed till their children are handle
- Upgrade to upstream tag jdk-12+30
* Fixes:
+ S8067250: [mlvm] vm/mlvm/mixed/stress/regression/b6969574
fails and perf regression
+ S8150757: [TESTBUG] compiler/ciReplay/TestVM.sh and
compiler/ciReplay/TestVM_no_comp_level.sh fail when no
compilations are happening
+ S8158646: [jittester] generated tests may not compile by javac
+ S8167276: jvmci/compilerToVM/MaterializeVirtualObjectTest.java
fails with -XX:-EliminateAllocations
+ S8207922: ctw of jdk.security.auth failed with "Unexpected
zero exit codebefore finishing all compilations"
+ S8213231: ThreadSnapshot::_threadObj can become stale
+ S8213825: assert(false) failed: Non-balanced monitor
enter/exit! Likely JNI locking
+ S8215921: There is no change when select different Foreground
and Background by mouse.
+ S8216180: [AOT] compiler/intrinsics/bigInteger/TestMulAdd.java
crashed with AOT enabled
+ S8217309: ZGC: Fix ZNMethodTable corruption
+ S8217579: TLS_EMPTY_RENEGOTIATION_INFO_SCSV is disabled after
8211883
+ S8217580: Remove tests from problemList as bugs has been
closed
+ S8217657: Move the test for default value of
jdk.includeInExceptions into own test
+ S8217666: gc/nvdimm/* should not be included any tiers
+ S8217678: [AOT] jck Math/IncrementExact and
Math/DecrementExact tests fail when test classes are AOTed
+ S8217699: add java/util/concurrent/CountDownLatch/Basic.java
to ProblemList-Xcomp
+ S8217717: ZGC: Broken oop map in C1 load barrier stub
+ S8217770: problem list
org.graalvm.compiler.debug.test.DebugContextTest
+ S8217797: ProblemList LongMulOverflowTest.java
+ S8217828: Un-ProblemList LongMulOverflowTest.java
+ S8217852: problem-list ctw of jdk.jconsole and java.desktop
on windows
+ S8217854: [TESTBUG] runtime/CompressedOops/
/UseCompressedOops.java fails with Shenandoah
- Upgrade to upstream tag jdk-12+29
* Fixes:
+ S8203687: javax/net/ssl/compatibility/Compatibility.java
supports TLS 1.3
+ S8207404: MulticastSocket tests failing on AIX
+ S8213695: gc/TestAllocateHeapAtMultiple.java is slow in some
configs
+ S8215375: [Graal] jck:vm/jvmti/Exception/excp001/excp00101
fails in Graal as JIT mode and -Xcomp mode
+ S8216045: The size of key_exchange may be wrong on FFDHE
+ S8216280: Allow later Symantec Policy distrust date for two
Apple SubCAs
+ S8216532: tools/launcher/Test7029048.java fails (Solaris)
+ S8216965: crash in freetypeScaler.c CopyBW2Grey8
+ S8217230: assert(t == t_no_spec) failure in
NodeHash::check_no_speculative_types()
+ S8217349: Problem list java/lang/invoke/LFCaching/
/LFMultiThreadCachingTest.java
+ S8217359: C2 compiler triggers SIGSEGV after transformation
in ConvI2LNode::Ideal
+ S8217394: Remove org.graalvm.compiler.debug.test.TimerKeyTest
from problem list
+ S8217427: (dc) nio/channels/DatagramChannel/UseDGWithIPv6.java
fails without IPv6
+ S8217438: Adapt tools/launcher/Test7029048.java for Aix.
+ S8217467: Access barriers are missing in C2 intrinsic for
Base64
- Upgrade to upstream tag jdk-12+28 (Oracle January 2019 CPU)
* Security fixes:
+ S8206290, CVE-2019-2422, bsc#1122293: Better FileChannel
transfer performance
+ S8209094, CVE-2019-2426: Improve web server connections
+ S8210866, CVE-2018-11212, bsc#1122299: Improve JPEG
processing
* Security-In-Depth fixes:
+ S8199156: Better route routing
+ S8199166: Better interface lists
+ S8199552: Update to build scripts
+ S8200659: Improve BigDecimal support
+ S8203955: Improve robot support
+ S8204895: Better icon support
+ S8205709: Proper allocation handling
+ S8205714: Initial class initialization
+ S8206295: More reliable p11 transactions
+ S8206301: Improve NIO stability
+ S8210094: Better loading of classloader classes
+ S8210598: Strengthen Windows Access Bridge Support
+ S8210606: Improved data set handling
+ S8210610: Improved LSA authentication
+ S8210870: Libsunmscapi improved interactions
* Fixes
+ S8196568: [Graal] LongMulOverflowTest.java fails with
"runTestOverflow() did not overflow"
+ S8198526: getAnnotatedOwnerType does not handle static nested
classes correctly
+ S8203654: Improve cypher state updates
+ S8203688: [testbug] Nashorn test
test/nashorn/script/nosecurity/treeapi/diagnostic.js fails
+ S8205360: Choose printer defaults
+ S8210392: assert(Compile::current()->live_nodes() <
Compile::current()->max_node_limit()) failed: Live Node limit
exceeded limit
+ S8210561: Command-line help wrong for javac --module
+ S8210624: Clean up better loading tests
+ S8210669: Some launcher tests assume a pre-JDK 9 run-time
image layout
+ S8211841: [testbug] sun/nio/cs/OLD/TestIBMDB.java does not
compile (aix)
+ S8212233: javadoc fails on jdk12 with "The code being
documented uses modules but the packages defined in $URL are
in the unnamed module."
+ S8213299: runtime/appcds/jigsaw/classpathtests/
/EmptyClassInBootClassPath.java failed with
java.lang.NoSuchMethodException
+ S8214418: half-closed SSLEngine status may cause application
dead loop
+ S8214440: ldap over a TLS connection negotiate failed with
"javax.net.ssl.SSLPeerUnverifiedException: hostname of the
server '' does not match the hostname in the server's
certificate"
+ S8214827: Incorrect call
ClassLoaders.toFileURL("jrt:/java.compiler")
+ S8215112: String::transform spec clarification
+ S8215244: jdk/jshell/ToolBasicTest.java testHistoryReference
failed
+ S8215280: Double click on titlebar not working for Frame with
extended state set to MAXIMIZED_BOTH
+ S8215308: pandoc-html-manpage-filter.js does not work for
[un]pack200
+ S8215313: [AOT] java/lang/String/Split.java fails with AOTed
java.base
+ S8215489: Remove String::align
+ S8215493: String::indent inconsistency with blank lines
+ S8215648: remove equals and hashCode implementations from
j.l.i.VarHandle
+ S8215694: keytool cannot generate RSASSA-PSS certificates
+ S8215724: Epsilon: ArrayStoreExceptionTest.java fails;
missing arraycopy check
+ S8215748: Application fails when executed with Graal
+ S8215754: ZGC: nmethod is not unlinked from Method before
rendezvous handshake
+ S8215757: C2: PhaseIdealLoop::create_new_if_for_predicate()
computes wrong IDOM
+ S8215889: assert(!_unloading) failed: This oop is not
available to unloading class loader data with ZGC
+ S8216050: Superword optimization fails with assert(0 <= i &&
i < _len) failed: illegal index
+ S8216135: C2 assert(!had_error) failed: bad dominance
+ S8216151: [Graal] Module jdk.internal.vm.compiler.management
has not been granted
accessClassInPackage.org.graalvm.compiler.debug
+ S8216314: SIGILL in CodeHeapState::print_names()
+ S8216316: Tests fail due to too low specified TLAB size
+ S8216362: Better error message handling when there is an
invalid Manifest
+ S8216376: [PPC64] Possibly unreliable stack frame resizing in
template interpreter
+ S8216427: ciMethodData::load_extra_data() does not always
unpack the last entry
+ S8216482: Shenandoah: typo in
ShenandoahBarrierSetC2::clone_barrier_at_expansion() causes
failed compilations
+ S8216490: Spammy periodic GC log message contains random time
stamp with periodic gc disabled
+ S8216549: Mismatched unsafe access to non escaping object
fails
+ S8217042: Shenandoah: write barrier on backedge of strip
mined loop causes c2 crash at expansion time
+ S8217043: Shenandoah: SIGSEGV in Type::meet_helper() at
barrier expansion time
- Upgrade to upstream tag jdk-12+27
* Fixes:
+ S6714324: Removing a component from a JTabbedPane does not
clear its accessibleParent
+ S6996807: FieldReflectorKey hash code computation can be
improved
+ S8076988: reevaluate trivial method policy
+ S8179943: Typo in javax.net.ssl.SSLSession.removeValue(String)
method documentation
+ S8182992: Typo in DatagramPacket constructor API doc
+ S8196347: LogCompilation: generate log file on the fly for
input to junits
+ S8196681: Java Access Bridge logging and debug flags
dynamically controlled
+ S8208184: IllegalArgumentException while invoking code
completion on netbeans IDE
+ S8209414: AArch64: method handle invocation does not respect
JVMTI interp_only mode
+ S8210788: Javadoc for Thread.join(long, int) should specify
that it waits forever when both arguments are zero
+ S8211267: StackOverflowError happened by
TextField.setFont(...)
+ S8213001: vmTestbase/nsk/jvmti/ThreadStart/threadstart002/
/TestDescription.java debug agent times out
+ S8213457: serviceability/sa/ClhsdbInspect.java time out
+ S8214122: JDWP is broken on 32 bit Windows: transport library
missing onLoad entry
+ S8214442: Improve stack walk API by adding handle marks
+ S8214461: Some unused classes may be removed
+ S8214738: javadoc should honor styles in doc-files
+ S8214862: assert(proj != __null) at compile.cpp:3251
+ S8215044: C2 crash in loopTransform.cpp with
assert(cl->trip_count() > 0) failed: peeling a fully unrolled loop
+ S8215123: Crash in runtime image built with jlink --compress=2
+ S8215200: IllegalArgumentException in
sun.lwawt.macosx.CPlatformWindow
+ S8215265: C2: range check elimination may allow illegal out
of bound access
+ S8215330: javax.xml.catalog.CatalogResolverImpl:
GroupEntry.matchURI fails to match
+ S8215398: -Xlog option usage => Invalid decorator
'\temp\app_cds.log'.
+ S8215400: Warn on usage of trampolines with gcc
+ S8215412: Optimize PrintStream.println methods
+ S8215438: jshell tool: Ctrl-D causes EOF
+ S8215495: Set isCopy to JNI_FALSE if len == 0
+ S8215510: j.l.c.ClassDesc is accepting descriptors not
allowed by the spec
+ S8215572: Add new Arrays micros
+ S8215575: C2 crash: assert(get_instanceKlass()->is_loaded())
failed: must be at least loaded
+ S8215583: Exclude
runtime/handshake/HandshakeWalkSuspendExitTest.java
+ S8215643: Microbenchmarks for KeyAgreement and Cipher
+ S8215644: Clean up globalDefinitions_<compiler>.hpp
+ S8215681: Remove compiler support for Raw String Literals
from JDK 12
+ S8215708: ZGC: Add missing LoadBarrierNode::size_of()
+ S8215724: Epsilon: ArrayStoreExceptionTest.java fails;
missing arraycopy check
+ S8215731: Move forward class definitions out of
globalDefinitions.hpp
+ S8215755: ZGC: split_barrier_thru_phi: check number of inputs
of phi
+ S8215756: Memory leaks in the AWT on macOS
+ S8215771: The jfr tool should pretty print reference chains
+ S8215773: applications/kitchensink/Kitchensink.java crash
with "assert(ZAddress::is_marked(addr)) failed: Should be marked"
+ S8215791: Tiny bug in VM monitoring/management
+ S8215798: Use {@systemProperty} for definition of
org.openjdk.java.util.stream.tripwire property
+ S8215888: Register to register spill may use AVX 512 move
instruction on unsupported platform.
+ S8215901: [TESTBUG] TestCheckedEnsureLocalCapacity.java fails
intermittently
+ S8215909: Typo in Swing ProcessMouseEvent method documentation
+ S8215910: Typo in AWT InvocationEvent Method Documentation.
+ S8215911: Various Typos in SQL Method Documentation
+ S8215912: Various Typos in java.net Method Documentation
+ S8215913: [Test_bug]java/util/Locale/LocaleProvidersRun.java
failed on de_DE and ja_JP locale.
+ S8215947: JVM crash with -XX:+DumpSharedSpaces
+ S8215951: AArch64: jtreg test
vmTestbase/nsk/jvmti/PopFrame/popframe005 segfaults
+ S8215961: jdk/jfr/event/os/TestCPUInformation.java fails on
AArch64
+ S8215962: Support ThreadPriorityPolicy mode 1 for non-root
users on linux/bsd
+ S8215975: [testbug] Adapt nsk tests to the PPC, S390 and AIX
platforms.
+ S8215985: ZGC: Simplify reference processing in light of
JDK-8175797
+ S8215990: Avoid using reflection to create common default
URLStreamHandlers
+ S8215991: Stop hiding exception from ArtifactResolver
failures in tests
+ S8215994: JDK 12 l10n resource file update - msg drop 10
+ S8215995: Add specialized toArray methods to immutable
collections
+ S8216010: Change callers of build_u2_from() to call
Bytes::get_Java_u2() instead
+ S8216021: RunTest.gmk might set concurrency level to 1 on
Windows
+ S8216048: Fix devkit creation in WSL
+ S8216059: nsk_jvmti_parseoptions still has dependency on
tilde separator
+ S8216067: Unused local vars in
windows/native/libjava/io_util_md.c
+ S8216134: (process) ProcessBuilder startPipeline does not
hide piped streams
+ S8216154: C4819 warnings at HotSpot sources on Windows
+ S8216155: C4819 warning at libfreetype sources on Windows
+ S8216157: Enable inlining of java_lang_Class::is_primitive
+ S8216176: Clarify the singleton description in
j.t.c.JapaneseEra class
+ S8216188: Remove expired flags in JDK 13
+ S8216189: Remove Klass::compute_is_subtype_of
+ S8216191: Remove FastSuperclassLimit
+ S8216197: Remove unused new_hash methods
+ S8216199: Local variable arg defined but never used in
BCEscapeAnalyzer::compute_escape_for_intrinsic()
+ S8216200: BCEscapeAnalyzer::ArgumentMap::set_intersect() is
incorrect
+ S8216205: Java API documentation formatting error in
System.getEnv
+ S8216262: Remove develop flag DelayCompilationDuringStartup
+ S8216266: ProblemList PeelingZeroTripCount.java
+ S8216267: Fix hotspot-ide-project target on WSL
+ S8216269: [s390] Debug build broken because CodeBlob has not
been declared
+ S8216271: Make AllocateOldGenAt an unsupported option on AIX.
+ S8216275: Disable annotation processing lint warnings when
building microbenchmarks
+ S8216285: Enable inlining of
CollectedHeap::obj-/array-/class_allocate
+ S8216302: StackTraceElement::fill_in can use cached Class.name
+ S8216322: Missing since information in deprecation of
constructor visitors
+ S8216335: Minor cleanups to javax.annotation.processing and
javax.lang.model javadoc
+ S8216359: Remove develop flags TraceCompilationPolicy and
TimeCompilationPolicy
+ S8216366: Add rationale to PER_CPU_SHARES define
+ S8216372: ZGC: Put C2 load barrier stub routines in separate
codeblobs
+ S8216375: Revert JDK-8145579 after JDK-8076988 is resolved
+ S8216385: ZGC: Fix building without C2
+ S8216403: Allocate fewer EnumSets in JavacFileManager#list
+ S8216413: Long.parseLong() is specified to throw unless
string contains parsable {@code int}; should be {@code long}
+ S8216423: Remove FillDelaySlots

==== kactivities-stats ====

- Downgrade the Qt version requirement to build with 5.9

==== kactivities5 ====
Subpackages: kactivities5-imports libKF5Activities5

- Downgrade the Qt version requirement to build with 5.9

==== kactivitymanagerd ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kactivitymanagerd-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== karchive ====

- Downgrade the Qt version requirement to build with 5.9

==== kauth ====
Subpackages: libKF5Auth5 libKF5Auth5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kbookmarks ====
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kcm_sddm ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kcm_sddm-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kcmutils ====
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kcodecs ====
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kcompletion ====
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kconfig ====
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Downgrade the Qt version requirement to build with 5.9

==== kconfigwidgets ====
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kcoreaddons ====
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Add 0001-Do-not-use-functor-if-Qt-lt-5.10.patch to revert the removal of
support for Qt 5.9
- Downgrade the Qt version requirement to build with 5.9

==== kcrash ====

- Downgrade the Qt version requirement to build with 5.9

==== kdbusaddons ====
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kde-cli-tools5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kde-cli-tools5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kde-gtk-config5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- Changes since 5.15.1:
* Check whether the list of entries is empty before accessing it (kde#401002)
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kde-user-manager ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kde-user-manager-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kdeclarative ====
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Downgrade the Qt version requirement to build with 5.9

==== kded ====
Subpackages: kded-lang

- Downgrade the Qt version requirement to build with 5.9

==== kdelibs4support ====
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Downgrade the Qt version requirement to build with 5.9

==== kdesu ====
Subpackages: libKF5Su5 libKF5Su5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kdnssd-framework ====
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kdoctools ====
Subpackages: kdoctools-lang libKF5DocTools5

- Downgrade the Qt version requirement to build with 5.9

==== kemoticons ====

- Downgrade the Qt version requirement to build with 5.9

==== kernel-source ====
Version update (4.20.10 -> 4.20.12)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms kernel-vanilla

- Linux 4.20.12 (bnc#1012628).
- dsa: mv88e6xxx: Ensure all pending interrupts are handled
prior to exit (bnc#1012628).
- net: fix IPv6 prefix route residue (bnc#1012628).
- net: ipv4: use a dedicated counter for icmp_v4 redirect packets
(bnc#1012628).
- vsock: cope with memory allocation failure at socket creation
time (bnc#1012628).
- vxlan: test dev->flags & IFF_UP before calling netif_rx()
(bnc#1012628).
- mlxsw: __mlxsw_sp_port_headroom_set(): Fix a use of local
variable (bnc#1012628).
- net: Fix for_each_netdev_feature on Big endian (bnc#1012628).
- net: ip6_gre: initialize erspan_ver just for erspan tunnels
(bnc#1012628).
- net: phy: xgmiitorgmii: Support generic PHY status read
(bnc#1012628).
- net: stmmac: Fix a race in EEE enable callback (bnc#1012628).
- net: stmmac: handle endianness in dwmac4_get_timestamp
(bnc#1012628).
- sky2: Increase D3 delay again (bnc#1012628).
- vhost: correctly check the return value of translate_desc()
in log_used() (bnc#1012628).
- net: Add header for usage of fls64() (bnc#1012628).
- tcp: clear icsk_backoff in tcp_write_queue_purge()
(bnc#1012628).
- tcp: tcp_v4_err() should be more careful (bnc#1012628).
- net: netcp: Fix ethss driver probe issue (bnc#1012628).
- net: Do not allocate page fragments that are not skb aligned
(bnc#1012628).
- af_packet: fix raw sockets over 6in4 tunnel (bnc#1012628).
- arm64, mm, efi: Account for GICv3 LPI tables in static memblock
reserve table (bnc#1012628).
- efi/arm: Revert "Defer persistent reservations until after
paging_init()" (bnc#1012628).
- PCI: Fix __initdata issue with "pci=disable_acs_redir" parameter
(bnc#1012628).
- scsi: target/core: Use kmem_cache_free() instead of kfree()
(bnc#1012628).
- mmc: meson-gx: fix interrupt name (bnc#1012628).
- hwmon: (lm80) Fix missing unlock on error in set_fan_div()
(bnc#1012628).
- netfilter: nf_nat_snmp_basic: add missing length checks in
ASN.1 cbs (bnc#1012628).
- net/x25: do not hold the cpu too long in x25_new_lci()
(bnc#1012628).
- mISDN: fix a race in dev_expire_timer() (bnc#1012628).
- ax25: fix possible use-after-free (bnc#1012628).
- commit b35c1fc
- net: crypto set sk to NULL when af_alg_release (CVE-2019-8912
bsc#1125907).
- commit e1b5b1f
- config: enable PREEMPT_VOLUNTARY (bsc#1125004)
Switch to PREEMPT_VOLUNTARY everywhere except s390x/zfcpdump.
[js] switch also armv7hl. armv6hl seems to have PREEMPT=n.
- commit 5cf91fd
- Linux 4.20.11 (bnc#1012628).
- dt-bindings: eeprom: at24: add "atmel,24c2048" compatible string
(bnc#1012628).
- eeprom: at24: add support for 24c2048 (bnc#1012628).
- blk-mq: fix a hung issue when fsync (bnc#1012628).
- drm/amdgpu/sriov:Correct pfvf exchange logic (bnc#1012628).
- ACPI: NUMA: Use correct type for printing addresses on i386-PAE
(bnc#1012628).
- perf stat: Fix endless wait for child process (bnc#1012628).
- perf report: Fix wrong iteration count in --branch-history
(bnc#1012628).
- perf test shell: Use a fallback to get the pathname in
vfs_getname (bnc#1012628).
- soc: renesas: r8a774c0-sysc: Fix initialization order of
3DG-{A,B} (bnc#1012628).
- tools uapi: fix RISC-V 64-bit support (bnc#1012628).
- riscv: fix trace_sys_exit hook (bnc#1012628).
- cpufreq: check if policy is inactive early in __cpufreq_get()
(bnc#1012628).
- csky: fixup relocation error with 807 & 860 (bnc#1012628).
- csky: fixup CACHEV1 store instruction fast retire (bnc#1012628).
- irqchip/csky: fixup handle_irq_perbit break irq (bnc#1012628).
- drm/amd/powerplay: avoid possible buffer overflow (bnc#1012628).
- drm/bridge: tc358767: add bus flags (bnc#1012628).
- drm/bridge: tc358767: add defines for DP1_SRCCTRL & PHY_2LANE
(bnc#1012628).
- drm/bridge: tc358767: fix single lane configuration
(bnc#1012628).
- drm/bridge: tc358767: fix initial DP0/1_SRCCTRL value
(bnc#1012628).
- drm/bridge: tc358767: reject modes which require too much BW
(bnc#1012628).
- drm/bridge: tc358767: fix output H/V syncs (bnc#1012628).
- nvme-pci: use the same attributes when freeing
host_mem_desc_bufs (bnc#1012628).
- nvme-pci: fix out of bounds access in nvme_cqe_pending
(bnc#1012628).
- nvme-multipath: zero out ANA log buffer (bnc#1012628).
- nvme: pad fake subsys NQN vid and ssvid with zeros
(bnc#1012628).
- nvme: introduce NVME_QUIRK_IGNORE_DEV_SUBNQN (bnc#1012628).
- drm/amdgpu: fix CPDMA hang in PRT mode for VEGA20 (bnc#1012628).
- drm/amdgpu: set WRITE_BURST_LENGTH to 64B to workaround SDMA1
hang (bnc#1012628).
- drm/amdgpu: disable system memory page tables for now
(bnc#1012628).
- ARM: dts: da850-evm: Correct the audio codec regulators
(bnc#1012628).
- ARM: dts: da850-evm: Correct the sound card name (bnc#1012628).
- ARM: dts: da850-lcdk: Correct the audio codec regulators
(bnc#1012628).
- ARM: dts: da850-lcdk: Correct the sound card name (bnc#1012628).
- ARM: dts: kirkwood: Fix polarity of GPIO fan lines
(bnc#1012628).
- csky: fixup compile error with CPU 810 (bnc#1012628).
- gpio: pl061: handle failed allocations (bnc#1012628).
- drm/nouveau: Don't disable polling in fallback mode
(bnc#1012628).
- drm/nouveau/falcon: avoid touching registers if engine is off
(bnc#1012628).
- cifs: Limit memory used by lock request calls to a page
(bnc#1012628).
- CIFS: Fix credits calculation for cancelled requests
(bnc#1012628).
- CIFS: Move credit processing to mid callbacks for SMB3
(bnc#1012628).
- CIFS: Fix error paths in writeback code (bnc#1012628).
- kvm: sev: Fail KVM_SEV_INIT if already initialized
(bnc#1012628).
- CIFS: Fix credit calculations in compound mid callback
(bnc#1012628).
- CIFS: Do not assume one credit for async responses
(bnc#1012628).
- CIFS: Fix mounts if the client is low on credits (bnc#1012628).
- gpio: mxc: move gpio noirq suspend/resume to syscore phase
(bnc#1012628).
- Revert "Input: elan_i2c - add ACPI ID for touchpad in ASUS
Aspire F5-573G" (bnc#1012628).
- Input: elan_i2c - add ACPI ID for touchpad in Lenovo V330-15ISK
(bnc#1012628).
- arm64: dts: rockchip: enable usb-host regulators at boot on
rk3328-rock64 (bnc#1012628).
- ARM: OMAP5+: Fix inverted nirq pin interrupts with irq_set_type
(bnc#1012628).
- perf/core: Fix impossible ring-buffer sizes warning
(bnc#1012628).
- perf/x86: Add check_period PMU callback (bnc#1012628).
- ALSA: hda - Add quirk for HP EliteBook 840 G5 (bnc#1012628).
- ALSA: usb-audio: Fix implicit fb endpoint setup by quirk
(bnc#1012628).
- ALSA: pcm: Revert capture stream behavior change in blocking
mode (bnc#1012628).
- ASoC: hdmi-codec: fix oops on re-probe (bnc#1012628).
- tools uapi: fix Alpha support (bnc#1012628).
- riscv: Add pte bit to distinguish swap from invalid
(bnc#1012628).
- x86/kvm/nVMX: read from MSR_IA32_VMX_PROCBASED_CTLS2 only when
it is available (bnc#1012628).
- kvm: vmx: Fix entry number check for add_atomic_switch_msr()
(bnc#1012628).
- mmc: sunxi: Disable HS-DDR mode for H5 eMMC controller by
default (bnc#1012628).
- mmc: sunxi: Filter out unsupported modes declared in the device
tree (bnc#1012628).
- mmc: block: handle complete_work on separate workqueue
(bnc#1012628).
- Input: bma150 - register input device after setting private data
(bnc#1012628).
- Input: elantech - enable 3rd button support on Fujitsu CELSIUS
H780 (bnc#1012628).
- Revert "nfsd4: return default lease period" (bnc#1012628).
- Revert "mm: don't reclaim inodes with many attached pages"
(bnc#1012628).
- Revert "mm: slowly shrink slabs with a relatively small number
of objects" (bnc#1012628).
- mm: proc: smaps_rollup: fix pss_locked calculation
(bnc#1012628).
- alpha: fix page fault handling for r16-r18 targets
(bnc#1012628).
- alpha: Fix Eiger NR_IRQS to 128 (bnc#1012628).
- s390/suspend: fix stack setup in swsusp_arch_suspend
(bnc#1012628).
- s390/zcrypt: fix specification exception on z196 during ap probe
(bnc#1012628).
- tracing: probeevent: Correctly update remaining space in
dynamic area (bnc#1012628).
- x86/platform/UV: Use efi_runtime_lock to serialise BIOS calls
(bnc#1012628).
- powerpc/64s: Fix possible corruption on big endian due to
pgd/pud_present() (bnc#1012628).
- scsi: sd: fix entropy gathering for most rotational disks
(bnc#1012628).
- crypto: ccree - fix resume race condition on init (bnc#1012628).
- md/raid1: don't clear bitmap bits on interrupted recovery
(bnc#1012628).
- x86/a.out: Clear the dump structure initially (bnc#1012628).
- sunrpc: fix 4 more call sites that were using stack memory
with a scatterlist (bnc#1012628).
- dm crypt: don't overallocate the integrity tag space
(bnc#1012628).
- dm thin: fix bug where bio that overwrites thin block ignores
FUA (bnc#1012628).
- drm: Use array_size() when creating lease (bnc#1012628).
- drm/vkms: Fix license inconsistent (bnc#1012628).
- drm/sched: Always trace the dependencies we wait on, to fix
a race (bnc#1012628).
- drm/i915: Block fbdev HPD processing during suspend
(bnc#1012628).
- drm/i915: Prevent a race during I915_GEM_MMAP ioctl with WC set
(bnc#1012628).
- commit eba2b68

==== kfilemetadata5 ====
Subpackages: kfilemetadata5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kgamma5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kgamma5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kglobalaccel ====
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Downgrade the Qt version requirement to build with 5.9

==== kguiaddons ====

- Downgrade the Qt version requirement to build with 5.9

==== kholidays ====
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Downgrade the Qt version requirement to build with 5.9

==== khotkeys5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: khotkeys5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* Harmonize usage of HAVE_X11, using #if and #cmakedefine01.

==== khtml ====
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Downgrade the Qt version requirement to build with 5.9

==== ki18n ====
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kiconthemes ====
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kidletime ====

- Downgrade the Qt version requirement to build with 5.9

==== kimageformats ====
Subpackages: kimageformats-eps

- Downgrade the Qt version requirement to build with 5.9

==== kinfocenter5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kinfocenter5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- Changes since 5.15.1:
* only enable the module help button if the module actually has help
* unbreak help button activation by not double-resetting the view (kde#392597)
* [about-distro] let distributions choose VERSION_ID or VERSION
* [about-distro] run logo lookup via osrelease
* [about-distro] run variant through os-release
* [about-distro] update osrelease parser for latest values in spec
* [about-distro] run absolute paths through qicon intead of qpixmap
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kinit ====
Subpackages: kinit-lang

- Downgrade the Qt version requirement to build with 5.9

==== kio ====
Subpackages: kio-core kio-lang

- Downgrade the Qt version requirement to build with 5.9

==== kipi-plugins ====
Subpackages: kipi-plugins-lang

- Initial stand-alone package, based on digikam-5.9.0

==== kirigami2 ====
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Downgrade the Qt version requirement to build with 5.9

==== kitemmodels ====

- Downgrade the Qt version requirement to build with 5.9

==== kitemviews ====
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kjobwidgets ====
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kjs ====
Subpackages: libKF5JS5 libKF5JSApi5

- Downgrade the Qt version requirement to build with 5.9

==== kjsembed ====
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kmenuedit5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kmenuedit5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== knewstuff ====
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Downgrade the Qt version requirement to build with 5.9

==== knotifications ====
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Downgrade the Qt version requirement to build with 5.9

==== knotifyconfig ====
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kpackage ====
Subpackages: kpackage-lang

- Downgrade the Qt version requirement to build with 5.9

==== kparts ====
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kpeople5 ====
Subpackages: kpeople5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kplotting ====

- Downgrade the Qt version requirement to build with 5.9

==== kpty ====
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kross ====
Subpackages: kross-lang

- Downgrade the Qt version requirement to build with 5.9

==== krunner ====

- Downgrade the Qt version requirement to build with 5.9

==== kscreen5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kscreen5-lang kscreen5-plasmoid

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kscreenlocker ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kservice ====
Subpackages: kservice-lang

- Downgrade the Qt version requirement to build with 5.9

==== ksshaskpass5 ====
Version update (5.15.1 -> 5.15.2)
Subpackages: ksshaskpass5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1

==== ksysguard5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: ksysguard5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== ktexteditor ====
Subpackages: ktexteditor-lang

- Downgrade the Qt version requirement to build with 5.9

==== ktextwidgets ====
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kunitconversion ====
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kwallet ====
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Downgrade the Qt version requirement to build with 5.9

==== kwayland ====

- Downgrade the Qt version requirement to build with 5.9

==== kwayland-integration ====
Version update (5.15.0 -> 5.15.2)

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== kwidgetsaddons ====
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Add 0001-Do-not-use-AnimationDuration-if-Qt-lt-5.10.patch to build with
Qt 5.9
- Downgrade the Qt version requirement to build with 5.9

==== kwin5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: kwin5-lang

- Add "AND GPL-3.0-or-later" to the license
- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- Changes since 5.15.1:
* Don't destroy DecorationRenderer in setup/finish compositing
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* [effects/desktopgrid] Don't copy windows on X11 (kde#404442)
* Enable -DQT_NO_URL_CAST_FROM_STRING and fix compilation
* Make the new Window Decoration KCM translatable
* Copy layer repaints to Deleted

==== kwindowsystem ====
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kxmlgui ====
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Downgrade the Qt version requirement to build with 5.9

==== kxmlrpcclient5 ====
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Downgrade the Qt version requirement to build with 5.9

==== lftp ====

- Add "relax-ssh-password-prompt-recognition.patch" to make sure
the SSH login handling code detects password prompts more
reliably. [bsc#1120946]

==== libKF5ModemManagerQt ====

- Downgrade the Qt version requirement to build with 5.9

==== libKF5NetworkManagerQt ====

- Downgrade the Qt version requirement to build with 5.9

==== libcontainers-common ====

- Update to libpod v1.1.0
* Rootless Podman can now forward ports into containers (using the same -p
and -P flags as root Podman)
* Rootless Podman will now pull some configuration options (for example, OCI
runtime path) from the default root libpod.conf if they are not explicitly set
in the user's own libpod.conf

==== libgsm ====
Version update (1.0.14 -> 1.0.18)

- Update to version 1.0.18
* Remove the MacOS "quarantine" files that I didn't know I'd
shipped.
* Remove some trailing spaces.
* Bump up the patchlevel in inc/gsm.h (I'd forgotten that in
release 17.)
- Changes from version 1.0.17
* New email addresses in the README.
* Avoid left-shifting signed integers.
* Don't print longwords using %d or %ld, cast them to (long)
first.
* Don't compare longwords as longs in addtest, we only care for
the lower 32 bits. (The math works, but the test failed).
- Changes from version 1.0.16
* New email addresses in the manual pages (patch 16).
* Removed a stray .orig file (in patch 15).
- Rebase libgsm-1.0.13.patch.
- Drop libgsm-strict-aliasing.patch: Applied upstream.
- Drop ancient Obsoletes/Provides.

==== libgweather ====
Version update (3.28.2 -> 3.28.3)
Subpackages: gweather-data libgweather-3-15 libgweather-lang
typelib-1_0-GWeather-3_0

- Update to version 3.28.3:
+ Fix METAR weather extraction.
+ Fix multilib problem in enum header.
+ Fix infinite loop calculating sunset/sunrise for named
timezones.
+ Fix a possible crash in gnome-shell.
+ Fix "nearest station" fallback code.
+ Updated translations.

==== libidn2 ====
Version update (2.1.0 -> 2.1.1)

- updat to 2.1.1:
* Revert SONAME bump from release 2.1.0
* Fix NULL dereference in idn2_register_u8() and
idn2_register_ul()
* Fix free of random value in idn2_to_ascii_4i()
* Improved fuzzer (which found the above issues)
* Check for valid unicode input in punycode encoder
* Avoid excessive CPU usage in punycode encoding with
large inputs
* Deprecate idn2_to_ascii_4i() in favor of idn2_to_ascii_4i2()
* Restrict output length of idn2_to_ascii_4i() to 63 bytes

==== libkdecoration2 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: libkdecorations2-5 libkdecorations2-5-lang libkdecorations2private6

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== libkdepim ====
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Add Fix-building-with-akonadi-search-support.patch to re-enable
akonadi-search support that unconditionally was disabled by
mistake

==== libkgapi ====
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Add Contacts-fix-email-type-deserialization.patch to fix broken
email fields in google contacts (boo#1126614, kde#398847)
- Use < %{version} again for obsoleting sasl2-kdexoauth2-3

==== libkscreen2 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* Exclude kscreen backend launcher from session management

==== libksysguard5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: libksysguard5-helper libksysguard5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* Add some returns to make gcc happy
* Add missing break in ProcessesLocal::Private::getNiceness

==== liblouis ====
Subpackages: liblouis-data liblouis17 python3-louis

- Add gcc9-fixed-memory-leaks-created-by-block-scope-compound-l.patch
(boo#1122169).

==== libqt4 ====
Subpackages: libqt4-32bit libqt4-qt3support libqt4-qt3support-32bit libqt4-sql
libqt4-sql-32bit libqt4-sql-sqlite libqt4-sql-sqlite-32bit libqt4-x11
libqt4-x11-32bit

- Drop libqt4-devel-doc, fails to build with GCC9
- Add patch to fix build with GCC 9 (boo#1121214):
* 0001-Redo-the-Q_FOREACH-loop-control-without-GCC-statemen.patch

==== librsvg ====
Version update (2.44.12 -> 2.44.13)
Subpackages: gdk-pixbuf-loader-rsvg librsvg-2-2 rsvg-thumbnailer
typelib-1_0-Rsvg-2_0

- Update to version 2.44.13:
+ Updated compilation docs for Debian.
+ Fix glgo#GNOME/librsvg#415: Register RsvgHandleFlags and the
RsvgError enum values in a thread-safe fashion.

==== libssh ====
Version update (0.8.6 -> 0.8.7)

- Avoid build cycle between curl and libssh by using obs hint to
prefer curl-mini
- Update to version 0.8.7
* Fixed handling extension flags in the server implementation
* Fixed exporting ed25519 private keys
* Fixed corner cases for rsa-sha2 signatures
* Fixed some issues with connector

==== libstorage-ng ====
Version update (4.1.91 -> 4.1.95)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#620
- extended documentation
- 4.1.95
- merge gh#openSUSE/libstorage-ng#619
- disable parted-sector-bug workaround on virtio-blk DASDs
(bsc#1112037)
- avoid empty nodes in mockup files
- extended testsuite helper TsCmpActiongraph
- added unit tests
- throw exception based on Exception class
- enable verbose output of checks during build
- 4.1.94
- merge gh#openSUSE/libstorage-ng#618
- updated pot and po files
- 4.1.93
- merge gh#openSUSE/libstorage-ng#617
- extended parser for lvs command
- added function to join Texts
- added unit tests
- use callback to report unsupported logical volumes (bsc#1099744)
- coding style
- allow to ignore errors during in probe utility
- consistent message style
- added function to join names of block devices
- improved messages for creating volume groups and mds
- consistent naming style
- use new join function in message about deleting filesystems
- fixed typo
- 4.1.92

==== libteam ====

- Drop use of $FIRST_ARG in .spec
The use of $FIRST_ARG was probably required because of the
%service_* rpm macros were playing tricks with the shell positional
parameters. This is bad practice and error prones so let's assume
that no macros should do that anymore and hence it's safe to assume
that positional parameters remains unchanged after any rpm macro
call.

==== libvirt ====
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- spec: disable VirtualBox driver

==== libxkbcommon ====
Version update (0.8.3 -> 0.8.4)
Subpackages: libxkbcommon-x11-0 libxkbcommon0

- Update to new upstream release 0.8.4
* Only changes to the build procedure.

==== libzypp ====
Version update (17.11.1 -> 17.11.2)

- Correctly handle exceptions when verifying the medium (bsc#1065022)
- Only write type field when probing (bsc#1114908)
- Don't blame user on TargetAbortedException (bsc#978193)
- version 17.11.2 (9)

==== mariadb-connector-c ====
Version update (3.0.8 -> 3.0.9)

- New upstream version 3.0.9
* CONC-384: Incorrect packet when a connection attribute name or
value is equal to or greater than 251
* CONC-388: field->def_length is always set to 0 (only used by
deprecated function mysql_list_fields)
* Getter should get and the setter should set
CLIENT_CAN_HANDLE_EXPIRED_PASSWORDS
* CONC-385: Removed some cmake system checks
* CONC-387: Fix case sensitive include file names for cross
compiling
* Fixed cnake policy CMP007
* Support static linking auth plugins
* Fix build with deprecated OpenSSL API: replaced ERR_remove_state
by ERR_remove_thread_state
* Disable LOAD DATA LOCAL INFILE suport by default and auto-enable
it for the duration of one query, if the query string starts with
the word "load". In all other cases the application should enable
LOAD DATA LOCAL INFILE support explicitly
* Changed return code for mysql_optionv/mysql_get_optionv to 1
(was -1) and added CR_NOT_IMPLEMENTED error message if a option
is unknown or not supported. This will fix possible error when
setting connection attribute failed

==== milou5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: milou5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== mutter ====
Subpackages: libmutter-3-0 mutter-data mutter-lang

- Add bug fix patches from upstream stable branch:
+ mutter-Avoid_double-free_crash.patch: cogl-auto-texture: Avoid
a double-free crash.
+ mutter-clutter-offscreen-effect-fix.patch:
clutter-offscreen-effect: Disable if no texture.
+ mutter-clutter-Avoid-rounding-compensation.patch: clutter:
Avoid rounding compensation when invalidating 2D actors.
+ mutter-Fix-monitor-recording-on-HiDPI.patch: screen-cast: Fix
monitor recording on HiDPI.
+ mutter-monitor-manager-Dont-use_switch-config.patch:
monitor-manager: Don't use switch-config when ensuring
configuration.
- Add mutter-Lower-HIDPI_LIMIT-to-144.patch: mutter will set
scaling factor to 2 when the monitor's dpi is greater than 144
(96*1.5) to keep GNOME's behavior consistent with YaST Installer
(fate#326682, bsc#1125467).

==== nodejs-common ====
Version update (2.0 -> 3.0)

- Change the shell script to regular executable

==== nodejs10 ====
Version update (10.15.0 -> 10.15.1)
Subpackages: nodejs10-devel npm10

- nodejs.keyring: update keyring to today's list as per
https://github.com/nodejs/node
- New upstream LTS version 10.15.1
* tls: throw if protocol too long
- fix_ci_tests.patch: refreshed

==== obs-service-download_files ====

- fix dependency to perl(YAML::XS) for appimage parser

==== obs-service-tar_scm ====
Version update (0.9.4.1537959361.56833cb -> 0.10.5.1551309990.79898c7)
Subpackages: obs-service-obs_scm obs-service-obs_scm-common

- Update to version 0.10.5.1551309990.79898c7:
* Prefer UTF-8 locale as output format for changes
- Update to version 0.10.4.1551193322.b7a79f4:
* added KankuFile
* fix problems with unicode source files
* added python-six to Requires in specfile
* better encoding handling
- Update to version 0.10.1.1550758451.f88bd41:
* fixes bsc#1082696 and bsc#1076410
* more fixes py3 unicode
* fix unicode in containers
- Update to version 0.10.0.1550647779.25999e8:
* fix spec for RH/Fedora - glibc-locale -> glibc-common
- Update to version 0.10.0.1550589094.e2ae17d:
* move to python3
* add python 3.6 and 3.7 to testing
* added logging for better debugging changesgenerate
* raise exception if no changesauthor given
* removed python 2.6 from travis
- Update to version 0.9.5.1548407358.b62685b:
* Stop using @opensuse.org addresses to indicate a missing address
* move argparse dep to -common package
* allow submodule and ssl options in appimage
* sync spec file as used in openSUSE:Tools project
- Update to version 0.9.5.1545082095.8dbc95f:
* [dist] fix service files installation in Makefile
- Update to version 0.9.5.1545064321.5c10ac0:
* check encoding problems for svn and print proper error msg
* added new param '--locale'
* separate service file installation in GNUmakefile
* added glibc as Recommends in spec file
* cleanup for broken svn caches
* another fix for unicode problem in obs_scm
- Update to version 0.9.5.1544099104.f52adb7:
* Final fix for unicode in filenames
* Another attempt to fix unicode filenames in prep_tree_for_archive
- Update to version 0.9.5.1544015491.08dd948:
* Another attempt to fix unicode filenames in prep_tree_for_archive
- Update to version 0.9.5.1543865445.4e2fbad:
* fix bug with unicode filenames in prep_tree_for_archive
* reuse _service*_servicedata/changes files from previous service runs
- Update to version 0.9.5.1543588452.b19491f:
* fix problems with unicode characters in commit messages for
changeloggenerate
- Update to version 0.9.5.1543502111.e576bd6:
* fix encoding issues if commit message contains utf8 char
- Update to version 0.9.5.1543424658.8740ef1:
* revert encoding for old changes file
- Update to version 0.9.5.1543418966.30359e4:
* change pylint/flake8 back to 2.7 for now
* remove hardcoded utf-8 encodings
- Update to version 0.9.5.1542905297.a6e346a:
* make code python3 ready
* Add support for extract globbing

==== openSUSE-build-key ====

- add project keys for architecture ports projects
gpg-pubkey-bbac6b14-5c755908.asc: openSUSE:Factory:ARM
gpg-pubkey-697ba1e5-5c755904.asc: openSUSE:Factory:RISCV
gpg-pubkey-8ede3e07-5c755f3a.asc: openSUSE:Factory:PowerPC
gpg-pubkey-f6ab3975-5ad08cb7.asc: openSUSE:Factory:zSystems
- package needs to become arch specific again to avoid the import
of foreign ports projects

==== openssh ====
Subpackages: openssh-helpers

- Correctly filter out non-compliant algorithms when in FIPS mode
(bsc#1126397)
* A hunk was applied to a wrong place due to a patch fuzz when
the fips patch was being ported to openssh 7.9p1
- update openssh-7.7p1-fips.patch
- Remove the "KexDHMin" config keyword (bsc#1127180)
It used to allow lowering of the minimal allowed DH group size,
which was increased to 2048 by upstream in the light of the Logjam
attack.
The code was broken since the upgrade to 7.6p1, but nobody noticed.
As apparently no one needs the functionality any more, let's drop
the patch.
It's still possible to use the fixed 1024-bit diffie-hellman-group1-sha1
key exchange method when working with legacy systems.
- drop openssh-7.7p1-disable_short_DH_parameters.patch
- updated patches:
openssh-7.7p1-fips.patch
openssh-7.7p1-fips_checks.patch
openssh-7.7p1-gssapi_key_exchange.patch

==== oxygen5 ====
Version update (5.15.0 -> 5.15.2)

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0
- Wording: "K Desktop Environment" -> "KDE Plasma"
- "Noarch" for Sounds and Cursors

==== oxygen5-icon-theme ====
Subpackages: oxygen5-icon-theme-large

- Downgrade the Qt version requirement to build with 5.9

==== patterns-base ====
Version update (20180616 -> 20190206)
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt
patterns-base-base patterns-base-basesystem patterns-base-console
patterns-base-documentation patterns-base-enhanced_base
patterns-base-enhanced_base_opt patterns-base-minimal_base
patterns-base-sw_management patterns-base-transactional_base patterns-base-x11
patterns-base-x11_enhanced patterns-base-x11_opt

- Strip down minimal_base pattern:
* Drop elfutils Requires: all tools from elfutils exist in
binutils, without the eu- prefix.
* Drop openssh requires: forcing a user to have openssh present no
matter what, without a possibility to uninstall it, is not
wanted.
* Drop sysvinit requires: this is a dependency to systemd after
all.
- Move systemd-coredump and busybox-static from requires in
minimal_base to recommends in base (users are free to uninstall
those tools and their use in e.g. containers is questionable).
- ppc64-diag is required on ppc64le (bsc#1098849).
- Pull in below changes made to SLE / openSUSE 15.1 patterns by
kukuk@xxxxxxx
- Rename base pattern to "Minimal Base System" to match description
and make clear, that this is not a full base system.
- Rename minimal_base to "Minimal Appliance Base" to match description
and avoid to have to patterns called "Base System" with different
content.
- Version: 20190206
- Remove minimal_base_conflicts, its not in SLE or Leap anymore
(boo#1103325)
- Change all the Recommends in minimal_base to Requires,
minimal_base is always installed and can't be installed with
- -no-recommends (boo#1103326)
- Hardware specific packages should be in base pattern not
minimal_base (boo#1106405)
- busybox should be in minimal_base to allow recovery from a big
system failure
- Remove some duplicate entries between base and minimal_base
- Suggest rather then recommend man-pages (boo#1116987)
- Require xorg-x11-essentials rather then recommending xorg-x11
(boo#1121730)
- Recommend Web-web_browser and suggest Firefox to make it possible
to install chromium instead
- Recommend rather then require multipath-tools, it is only in
enhanced_base so requiring it doesn't make sense, if it Should
be required it likely should be in base
- general cleanup, fix meta info spec-cleaner re arranged remove
commented out packages
- update version number to current date

==== perl-AnyEvent ====
Version update (7.14 -> 7.15)

- updated to 7.15
see /usr/share/doc/packages/perl-AnyEvent/Changes
7.15 Tue Feb 26 03:07:42 CET 2019
- INCOMPATIBLE CHANGE: AnyEvent::Handle's tls_detect documentation gave
separate major and minor versions, while code passed only a single
value. This version follows the documentation and now passes separate
major and minor values.
- work around Net::SSLeay not having been ported to openssl 1.1, but many
distributions compiling it against openssl 1.1, which unfortunately
succeeds and results in a very broken module.
- AnyEvent::DNS::dns_unpack now stores the original DNS packet
in the __ member, to allow decoding of undecodable resouce records
containing compressed domian names.
- AnyEvent::Socket::parse_ipv6 would NOT, as advertised, accept ipv4
addresses. It now does and converts them to ipv4 mapped addresses.
- support CAA records, based on patch by Steve Atkins.
- add freenom and cloudflare nameservers as dns fallback.
- AnyEvent::Strict would not properly ward against io watchers
on files when the handle passed was a file descriptor.
- document "internal" variables used by the dns en-/decoder to allow
enterprising users to extend them in a semi-official way.

==== perl-DBD-Pg ====

- apply disable-attr.patch to disable broken test:
https://rt.cpan.org/Public/Bug/Display.html?id=128529

==== perl-DBD-mysql ====

- put back zlib-devel BuildRequires, otherwise the package doesn't
build with the latest OpenSSL
- add zlib-devel to the cpanspec.yml so it won't get dropped
on the next automatic update

==== perl-IO-Socket-SSL ====
Version update (2.060 -> 2.062)

- updated to 2.062
see /usr/share/doc/packages/perl-IO-Socket-SSL/Changes
2.062
- Enable X509_V_FLAG_PARTIAL_CHAIN if supported by Net::SSLeay (1.83+) and
OpenSSL (1.1.0+). This makes leaf certificates or intermediate certificates
in
the trust store be usable as full trust anchors too.
- updated to 2.061
see /usr/share/doc/packages/perl-IO-Socket-SSL/Changes
2.061
- Support for TLS 1.3 session reuse. Needs Net::SSLeay 1.86+.
Note that the previous (and undocumented) API for the session cache has been
changed.
- Support for multiple curves, automatic setting of curves and setting of
supported curves in client. Needs Net::SSLeay 1.86+.
- Enable Post-Handshake-Authentication (TLSv1.3 feature) client-side when
client certificates are provided. Thanks to jorton[AT]redhat[DOT]com.
Needs Net::SSLeay 1.86+.
- Removed patch:

IO-Socket-SSL-2.060-make-all-tests-which-use-fork-also-ignore-signal-PIP.patch

==== perl-JSON ====
Version update (4.01 -> 4.02)

- updated to 4.02
see /usr/share/doc/packages/perl-JSON/Changes
4.02 2019-02-23
- fixed a test that breaks if perl is compiled with -Dquadmath
(RT-128589)

==== php7 ====
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pgsql php7-shmop php7-snmp
php7-sockets php7-sqlite php7-sysvsem php7-sysvshm php7-tidy php7-tokenizer
php7-wddx php7-xmlreader php7-xmlwriter php7-xsl php7-zlib

- Disable tests that do deadlock now with curl update, this is
fixed in next release 7.3.3 thus reenable here when released
- rename php7-*.patch to more general php-#1.patch
why: this aligns with maintenance patch names, which are in
changelogs comfortably copied over php72, php7, php5, php53;
moreover, php$N prefix causes issues when package is renamed,
e. g. php7 to php72
- deleted patches
- php7-crypt-tests.patch (upstreamed)
- php7-date-regenerate-lexers.patch (upstreamed)
- php7-embed.patch (upstreamed)
- php7-fix_net-snmp_disable_MD5.patch (upstreamed)
- php7-ini.patch (upstreamed)
- php7-no-build-date.patch (upstreamed)
- php7-odbc-cmp-int-cast.patch (upstreamed)
- php7-openssl.patch (upstreamed)
- php7-php-config.patch (upstreamed)
- php7-phpize.patch (upstreamed)
- php7-pts.patch (upstreamed)
- php7-systemd-unit.patch (upstreamed)
- php7-systzdata-v17.patch (upstreamed)
- added patches
+ php-crypt-tests.patch
+ php-date-regenerate-lexers.patch
+ php-embed.patch
+ php-fix_net-snmp_disable_MD5.patch
+ php-ini.patch
+ php-no-build-date.patch
+ php-odbc-cmp-int-cast.patch
+ php-openssl.patch
+ php-php-config.patch
+ php-phpize.patch
+ php-pts.patch
+ php-systemd-unit.patch
+ php-systzdata-v17.patch
- fix wrongly ported patch, using the one from remirepo (Thanks!)
[bsc#1126449]
- modified patches
% php7-systzdata-v17.patch

==== plasma-browser-integration ====
Version update (5.15.1 -> 5.15.2)
Subpackages: plasma-browser-integration-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1

==== plasma-framework ====
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Add 0001-Revert-Remove-Qt-version-check.patch to revert the commit
that removes support for Qt < 5.10
- Downgrade the Qt version requirement to build with 5.9

==== plasma-nm5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== plasma5-addons ====
Version update (5.15.0 -> 5.15.2)
Subpackages: plasma5-addons-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- Changes since 5.15.1:
* [PotD] Port mostly to QQC2 (kde#404248)
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* [weather] Center align the warning heading
* [weather] Fix weather Notices tab not showing
* [comic dataengine] Do not cache identifier only requests
* [comic] Update comic strip on current identifier only
* [comic] Fix max cache limit
* [comic] Request current identifier on data change
* [comicupdater] Fix last day check

==== plasma5-desktop ====
Version update (5.15.0 -> 5.15.2)
Subpackages: plasma5-desktop-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- Changes since 5.15.1:
* [Kickoff] Don't respond to window resizing/tiling shortcuts (kde#402614)
* [Kickoff] remove hint state
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* [Kickoff] Return Kickoff to Favorites page after running a search
* Use Dialog's visibility directly rather than relying on the mainItem's
* [Containment Actions Configuration] Fix changing plugin
* Sort setting grid views alphabetically (kde#400404)
* [Activities KCM] Properly vertically center the buttons
* Revert "[Activities KCM] vertically center the buttons"

==== plasma5-integration ====
Version update (5.15.0 -> 5.15.2)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* autotests: remove KDE_FORK_SLAVES, to see if CI works better.

==== plasma5-openSUSE ====
Version update (15.0~git20181114T190445~21cb8a6 ->
15.0~git20190223T194652~7f4983a)
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.15.2
- Update to version 15.0~git20190223T194652~7f4983a:
* konversationrc: change #opensuse to #suse
- Generate the tarball during build and enable changelog generation
- Update to 5.15.1

==== plasma5-pa ====
Version update (5.15.0 -> 5.15.2)
Subpackages: plasma5-pa-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== plasma5-workspace ====
Version update (5.15.0 -> 5.15.2)
Subpackages: gmenudbusmenuproxy plasma5-session plasma5-session-wayland
plasma5-workspace-lang plasma5-workspace-libs xembedsniproxy

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- Changes since 5.15.1:
* [weather] envcan: Fix typo in lowercase icon lookup string
* Don't show entries with NoDisplay=true with the applauncher
containmentaction
* improve screen filtering for global menu applet (kde#404500)
- Drop patches, now upstream:
* 0001-Don-t-show-entries-with-NoDisplay-true-with-the-appl.patch
- Add patch to honour NoDisplay in the applauncher containmentaction
(boo#1125901):
* 0001-Don-t-show-entries-with-NoDisplay-true-with-the-appl.patch
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* [ksmserver] Restore legacy sessions (kde#404318)
* Exclude kuiserver from session management
* [Digital Clock] Fix 24h tri-state button broken in port to QQC2 (kde#404292)
* Harmonize usage of HAVE_X11, using #if and #cmakedefine01 everywhere
* [weather dataengine] bbc,envcan,noaa: fix day/night calculation for observe
* [weather dataengine] envcan: fix forecast icons to match "ice pellets"
* Fix System Tray popup interactivity after echanging item visiblity
(kde#393630)

==== polkit-kde-agent-5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== postgresql10 ====
Version update (10.5 -> 10.7)
Subpackages: libecpg6 libpq5 postgresql10-contrib postgresql10-devel
postgresql10-docs postgresql10-server

- Update to 10.7:
* https://www.postgresql.org/docs/10/release-10-7.html
* https://www.postgresql.org/about/news/1920/
* By default, panic instead of retrying after fsync() failure,
to avoid possible data corruption.
* Ensure that NOT NULL constraints of a partitioned table are
honored within its partitions.
* Numerous other bug fixes.
- Overhaul README.SUSE
- Update to 10.6:
* CVE-2018-16850, bsc#1114837: Improper quoting of transition
table names when pg_dump emits CREATE TRIGGER can cause
privilege escalation
* Numerous bug fixes, see the release notes:
https://www.postgresql.org/docs/10/release-10-6.html
* Remove unneeded library dependencies from PGXS.
- add provides for the new server-devel package that will be
introduced in postgresql 11

==== powerdevil5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: powerdevil5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- Changes since 5.15.0:
* Exclude powerdevil from session management

==== prison-qt5 ====
Subpackages: libKF5Prison5 prison-qt5-imports

- Downgrade the Qt version requirement to build with 5.9

==== protobuf ====
Subpackages: libprotobuf-lite17 libprotobuf17

- Add upstream patch which fixes build with Bazel 0.22.0.
* 0001-remove-PACKAGE_NAME-and-REPOSITORY_NAME-deprecated.patch

==== purple-rocketchat ====
Version update (0.0+hg20180817 -> 0.0+hg20181203)
Subpackages: libpurple-plugin-rocketchat pidgin-plugin-rocketchat

- Update to version 0.0+hg20181203 (changes since 0.0+hg20180817):
* Attempt to add support for "Personal Access Token"s.
* Add support for server path.
* Prevent server path from being NULL, fix default path.
* Fix for messages from unknown channels appearing as one-to-one
IM's.
* Further tweaks to the unknown channels.

==== purpose ====
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Downgrade the Qt version requirement to build with 5.9

==== python-Twisted ====

- Add another patch for openssl 1.1.1 (from upstream git):
* openssl-errormsg.aptch

==== python-keyring ====
Version update (15.1.0 -> 18.0.0)

- Add LICENSE
- Remove tests from runtime package
- Fix test failure occurring in test_packaging.py
- Use pytest --ignore to avoid removing build directories in %check
- Remove unnecessary build dependency pytest-sugar
- Update to v18.0.0
* On macOS, the backend now raises a ``KeyringLocked``
when access to the keyring is denied (on get or set) instead
of ``PasswordSetError`` or ``KeyringError``. Any API users
may need to account for this change, probably by catching
the parent ``KeyringError``.
Additionally, the error message from the underying error is
now included in any errors that occur.
- from 17.1.1
* Update packaging technique to avoid 0.0.0 releases.
- from 17.1.0
* When calling ``keyring.core.init_backend``, if any limit function is
supplied, it is saved and later honored by the ``ChainerBackend`` as well.
- from 17.0.0
* Remove application attribute from stored passwords
using SecretService, addressing regression introduced in
10.5.0 (#292). Impacted Linux keyrings will once again
prompt for a password for "Python program".
- from 16.1.1
* Fix error on import due to circular imports on Python 3.4.
- from 16.1.0
* Refactor ChainerBackend, introduced in 16.0 to function
as any other backend, activating when relevant.
- 16.0.2
* In Windows backend, trap all exceptions when attempting to import pywin32.
- from 16.0.1
* Once again allow all positive, non-zero priority keyrings to participate.
- from 16.0.0
* Fix race condition in delete_password on Windows.
* All suitable backends (priority 1 and greater) are
allowed to participate.
- from 15.2.0
* Added new API for ``get_credentials``, for backends
that can resolve both a username and password for a service.

==== python-matplotlib ====
Subpackages: python3-matplotlib python3-matplotlib-cairo python3-matplotlib-gtk3

- Disable Qt4 support on Tumbleweed by default

==== python-numpy ====
Subpackages: python2-numpy python3-numpy

- Do not bother with standard flavor, just make it default
- Execute the tests only on standard package for now not hpc variants
- Add constraints for testsuite to not run out of mem/disk space
- Use %license macro
- Enable testsuite

==== python-py ====
Version update (1.7.0 -> 1.8.0)

- Update to 1.8.0:
* add ``"importlib"`` pyimport mode for python3.5+, allowing unimportable
test suites
to contain identically named modules.
* fix ``LocalPath.as_cwd()`` not calling ``os.chdir()`` with ``None``, when
being invoked from a non-existing directory.
- Drop merged patch separators.patch

==== python-pyOpenSSL ====

- Add fetch-intersphinx-inventories.sh to sources
- add local-intersphinx-inventories.patch for generating the docs
correctly
- add fetch-intersphinx-inventories.sh to fetch the inventories

==== python-service_identity ====
Version update (17.0.0 -> 18.1.0)

- update to 18.1.0
- drop fetch-intersphinx-inventories.sh
- drop local-intersphinx-inventories.patch
- cleanup spec + enable tests
* pyOpenSSL is optional now if you use service_identity.cryptography.* only.
* Added support for iPAddress subjectAltNames.
- add fetch-intersphinx-inventories.sh to the sources
- add local-intersphinx-inventories.patch for generating the docs
correctly
- add fetch-intersphinx-inventories.sh to fetch the inventories

==== python-sip ====
Subpackages: python-sip-common python3-sip

- Add fix_qt4_code_gen.patch
Fixes python-qt4 building. Should be in next upstream release.
See:
http://python.6.x6.nabble.com/PyQt4-compilation-error-with-sip-4-19-14-convert-std-nullptr-t-to-int-in-initialization-td5248504.html
From: https://www.riverbankcomputing.com/hg/sip/rev/7bd4d19479ad

==== python-urlgrabber ====
Version update (3.9.1 -> 4.0.0)

- Drop patch grabber_fix.diff that was never upstreamed. Should
not be needed anymore
- Update to the upstream version 4.0.0:
* Port to Python 3 rocket
* Add curl_obj option to grabber
* Throw an obvious error message when urlgrabber-ext-down is
missing when attempting to use external downloader
* Use setuptools for setup.py instead of distutils
- Remove merged patches:
* declare-dollar-sign-as-safe-in-urlquote.patch
* python-urlgrabber-3.9.1-set-SSL_VERIFYHOST-correct.dif
* python-urlgrabber-3.9.1-preserve-queryparams-in-urls.patch

==== remmina ====
Version update (1.3.2 -> 1.3.3)
Subpackages: remmina-lang remmina-plugin-rdp remmina-plugin-secret
remmina-plugin-vnc remmina-plugin-xdmcp

- Update to new upstream release 1.3.3
* Fix ?Utranslated? typo + XHTML 1.0 strictness + move div CSS rule in style
block
* Revert autoclosed <script> tags. It seems to be badly surported
* Remmina connection window refactoring
* Adding Serial and parallel ports sharing
* RemminaMain window refactoring - Removing deprecated functions.
* Fix #1836 implementing the correct message panel when authenticating
* Make ssh tunnel pwd user manageable and public key import
* Fix Yes/No inversion
* Updated translations: de, zh_CN, it, fr, tr, da, it

==== ruby-common ====
Version update (2.1 -> 2.6)

- rails.macros: add macro to fix ruby shebang line
- rails.macros: always use ./bin/* stubs for calling binaries
- do not try to delete git files in the rails macros
- --no-rdoc/--no-ri are obsolete in, if we get it passed in convert
them to --no-document

==== ruby2.6 ====
Subpackages: libruby2_6-2_6 ruby2.6-devel

- replace the awk based provides generation with the new file-attr
handler in ruby-bundled-gems-rpmhelper
This kills one provides rubygem-name = version
But this should not have be used since a while anymore.
- allow bundler bin stubs to be handled by update-alternative

==== rubygem-gem2rpm ====

- Update from git. Add:
A 0027-quote-version_suffix-in-gem2rpm.yml.documentation-to.patch
A 0028-add-binary_map-support.patch
A 0029-Use-or-for-the-conditions-instead-of-and.patch
A 0030-gem_package.spec.erb-sync-with-ruby-common.patch
A 0031-use-template-opensuse-on-openSUSE-Tumbleweed-where-e.patch
A 0032-Replace-no-rdoc-no-ri-with-no-document.patch
And refresh all others
Remove:
D binary_map.patch
D enhances.patch
- Use less strict PreReq replacements.

==== rubygem-parallel_tests ====
Version update (2.27.0 -> 2.27.1)

- updated to version 2.27.1
no changelog found

==== sblim-sfcb ====

- Drop use of $FIRST_ARG in .spec
The use of $FIRST_ARG was probably required because of the
%service_* rpm macros were playing tricks with the shell positional
parameters. This is bad practice and error prones so let's assume
that no macros should do that anymore and hence it's safe to assume
that positional parameters remains unchanged after any rpm macro
call.

==== schily ====
Subpackages: cdda2wav cdrecord libcdrdeflt1_0 libdeflt1_0 libedc_ecc1_0
libedc_ecc_dec1_0 libfile1_0 libfind3_0 libparanoia1_0 librmt1_0 librscg1_0
libscg1_0 libscgcmd1_0 libschily2_0 mkisofs readcd spax star

- Update to new upstream release 2019.02.18
* star 1.6: Two more FIFO problems (mainly visible on Linux)
have been fixed.

==== solid ====
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Downgrade the Qt version requirement to build with 5.9

==== sonnet ====
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Downgrade the Qt version requirement to build with 5.9

==== spice-gtk ====
Version update (0.35 -> 0.36)
Subpackages: libspice-client-glib-2_0-8 libspice-client-glib-helper
libspice-client-gtk-3_0-5

- Update to version 0.36:
+ Deprecate PulseAudio backend: it will be removed in a future
release
+ Add H265 stream support
+ Add SpiceQmpPort helper to interact with QEMU monitor over a Spice port
+ Display a message if EGL support is required (with dmabuf local rendering)
+ Many GstVideoOverlay improvements
+ Smooth-scrolling improvements
+ Miscellaneous fixes
Dropped patches (needed changes in base version):
0001-lz-Avoid-buffer-reading-overflow-checking-for-image-.patch
0002-lz-More-checks-on-image-sizes.patch
bb15d481-Fix-flexible-array-buffer-overflow.patch

==== sshfs ====
Version update (2.10 -> 3.5.0)

- Update to new upstream release 3.5.0
* Fixed error code returned by rename(), allowing proper fallback.
* Make utimens(NULL) result in timestamp "now" -- no more
touched files dated 1970-01-01.
* SSHFS now supports (or rather: ignores) some options that it
may receive as result of being mounted from /etc/mtab.
This includes things like user, netdev, or auto.
* Dropped support for writeback caching (and, as a consequence,
"unreliable append" operation). As of kernel 4.14, the FUSE
module's writeback implementation is not compatible with
network filesystems and there are no imminent plans to change
that.
* Add support for mounting from /etc/fstab
* SSHFS now supports O_APPEND.
* Fixed a crash due to a race condition when listing directory
contents.
* For improved backwards compatibility, SSHFS now also silently
accepts the old -o cache_* options.

==== sssd ====
Subpackages: libnfsidmap-sss libsss_certmap0 libsss_idmap0 libsss_nss_idmap0
sssd-32bit sssd-krb5-common sssd-ldap

- Install systemd service unit file created from source's template
(bsc#1120852)
- Install logrotate configuration (bsc#1004220)
- Set journald as system logger

==== syndication ====

- Downgrade the Qt version requirement to build with 5.9

==== syntax-highlighting ====
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Downgrade the Qt version requirement to build with 5.9

==== sysdig ====
Version update (0.23.1_k4.20.10_1 -> 0.24.2_k4.20.12_1)

- Update to version 0.24.2:
* Added the ability to specify a set of ports where data is captured with
bigger snaplen (20000) (#1256)
* Made fd resolution work for getsockopt (#1280)
* Check getsockopt event before accessing it (#1284)
* Fixed snprintf placeholder for size_t/{u,}int64_t (#1279)
* Disabled reading environment from /proc by default (#1272)
* Excluding suppressed processes during initial /proc scan (#1269)
* Fixed Windows build in CYGWIN environment (#1270)
* Changes to eliminate warnings with gcc 5.4 (#1271)
* Trigger build errors for extra compiler warnings (#1265)
* Handling thread table overflows (#1263)
* Deleted threadinfos that we failed to add to the thread table (#1260)
* Reduce CPU usage (#1261)
* Lua parser interfaces (#1254)
* Fixed a compile issue when trying to make the project using VS2017 on
Windows 10 (#1248)
* Added ifdef guards to socket options with (#1257),(#1258)
* Improved getsockopt()/setsockopt() support (#1188)
* Fix fd.net comparisons with in operator (#1252)
* Only check out sysdig for initial invocation (#1251)
* Build probe modules only with sysdig directory (#1244)
* Fixed spelling and copy/pased comment errors (#1250)
- Changes for version 0.24.1:
* Fix struct packing
- Changes for version 0.24.0:
* Switch to Apache 2.0 License: All userspace code moves from GPL to Apache 2
license. Kernel module switches to dual-license MIT + GPLv2. Enjoy! [#1233]
[#1242]
* Complete IPv6 Support. Sysdig previously had partial IPv6 support, but this
release rounds out full support for ipv6 addresses in filter fields, csysdig,
etc. [#1204]
* loginuid support. Add user.loginuid & user.loginname to track login users,
which do not change despite sudo/su operations. [#1189] [#1214] [#1218] [#1219]
[#1227]
* Track connections by domain name: New fields fd.*ip.name allow matching
connection ips with resolved domain names. [#1213]
* Add endswith filter to support suffix matching on strings [#1209]
* Add minikube support to the kernel module probe loader script [#1205]
* Improve error string return handling at startup/when reading capture files
[#1215]
* Disable boot2docker kernel module builds for pre-built kernel modules
[#1232]
* eBPF Support Improvements/Fixes [#1235] [#1236] [#1237] [#1239]
* Improve/fix windows build [#1242]
* Don't drop setns events when in dropping mode [#1198]
* At startup, wait a bit for an existing sysdig-probe module to be unloaded
before loading a new one [#1201]
* Support extracting container metadata for containers spawned with just an
image id and not an image name [#1207]
* Properly extract image metadata when the image contains a host:port
component [#1206]
* Minor compilation bug fixes [#1212]
* Small packaging fixes [#1228] [#1229] [#1231]
* Fix an inconsistency when writing capture files containing unknown fds
[#1234]

==== systemsettings5 ====
Version update (5.15.0 -> 5.15.2)
Subpackages: systemsettings5-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- No code changes since 5.15.1
- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== threadweaver ====

- Downgrade the Qt version requirement to build with 5.9

==== tracker-miners ====
Version update (2.1.5 -> 2.1.6)
Subpackages: tracker-miner-files tracker-miners-lang

- Update to version 2.1.6:
+ Multiple meson build fixes.
+ Test fixes.
+ Updated translations.

==== vim ====
Version update (8.1.0877 -> 8.1.0892)
Subpackages: gvim vim-data vim-data-common

- Updated to version 8.1.0892, fixes the following problems
* New buffer used every time the quickfix window is opened.
* Can execute shell commands in rvim through interfaces.
* Checking for FEAT_MBYTE which doesn't exist anymore.
* Missing some changes for Ex commands.
* Double check for bsd systems.
* Compiler warning for adding to NULL pointer and a condition that is
always true.
* The 'l' flag in :subsitute is sticky.
* The a: dict is not immutable as documented.
* Pty allocation wrong if using file for out channel and using null for
in channel and null for error channel.
* Substitute command inssuficiently tested.
* Failure when closing a window when location list is in use.

==== virtualbox ====
Version update (5.2.22_k4.20.10_1 -> 6.0.4_k4.20.12_1)
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- Remove requires on libvncserver for virtualbox-vnc.
- Add changes requested by Security - new file "security_fixes.patch"
File UserManual.pdf is resent to clear error in build.
- Part of the API changes for kernel 5.0 are not fixed upstream. Add file
"fixes_for_5.0" back in.
- Version bump to 6.0.4 (released January 28 2019 by Oracle)
Files "fixes_for_5.0" and "fixes_for_gcc9" are deleted - the code was fixed
upstream.
This is a maintenance release. The following items were fixed and/or added:
Virtualization core: support Shanghai/Zhaoxin CPUs.
User interface: handle command line arguments to VirtualBox correctly (bugs
#18206 and #18197)
User interface: improvements to machine manager window, virtual optical disk
creator, storage selector window and log viewer window
User interface: various small fixes and improvements
Audio: implemented time scheduling for the AC'97 device emulation to keep
audio and video in sync
Graphics: basic support for VMSVGA graphics device in virtual machines using
EFI
Network: fix occasional NATNet crashes (bug #13899)
Network: worked around problems in certain PCnet drivers on old operating
systems
Serial: fixed connecting to pseudo terminals on POSIX hosts (6.0.0
regression; bug #18319)
Linux hosts and guests: fix for building kernel modules against Linux 5.0.
Thank you Kyle Laker
- Converted vboxwebsrv to a systemd service. Previously, this was started
through init.d. bsc#1116050
Files "vboxweb-service.service" and "vboxweb-service.sh" are added.
File "vbox-vboxweb-init-script.diff" is removed.
File "fixes_for_4.20.patch" is removed - the code was fixed upstream.
File "fix_lib_search.patch" is added to fix the build of VBox0GL.
File "fixes_for_5.0.patch" is added to compensate for API changes in kernel
5.0.
File "virtualbox-system-x.patch" is removed.
File "fixes_for_Leap15.1.patch" is added to fix build errors on Leap 15<F5>.1.
- Version bump to 6.0.2 (released January 15 2019 by Oracle)
This is a maintenance release. The following items were fixed and/or added:
User interface: fixed creation of desktop shortcuts for starting virtual
machines (bug #18207)
User interface: allow the first run window to selecting host drives (bug
#18230)
User interface: fixed attaching empty host optical drives (bug #18223)
User interface: implemented a new virtual optical disk creation window
USB: modified Linux backends to reset USB devices (previously, most guest
attempts to reset USB devices were ignored)
PCnet: fixed a regression which caused some PCnet PCI guest drivers to not
detect the emulated hardware (bug #18286)
Linux hosts: fixed conflict between Debian and Oracle build desktop files
(bug #18264)
Linux and MacOS hosts: VirtualBoxVM command not accessible (bug #18257)
Windows guests: multiple monitor fixes with VBoxSVGA graphics
Windows guests: black screen with VBoxSVGA graphics when 3D is disabled (bug
#18205)
Linux guests: fixed building drivers on SLES 12.4 (bug #18213)
Linux guests: fixed building shared folder driver with older kernels (bug
#18238)
OS/2 shared folders: fixed write regression introduced in 6.0.0 GA
-Version bump to 6.0.0 (released December 18 2018 by Oracle)
This is a major update. The following major new features were added:
Implemented support for exporting a virtual machine to Oracle Cloud
Infrastructure
User interface: greatly improved HiDPI and scaling support, including better
detection and per-machine configuration
Major rework of user interface with simpler and more powerful application and
virtual machine set-up
User interface: a new file manager enabling user to control the guest file
system and copy files between host and guest.
Graphics: major update of 3D graphics support for Windows guests, and VMSVGA
3D graphics device emulation on Linux and Solaris guests
Added support for surround speaker setups (as used by Windows 10 Build 1809)
Added utility vboximg-mount on Apple hosts to access the content of guest
disks on the host
Added support for using Hyper-V as the fallback execution core on Windows
host, to avoid inability to run VMs at the price of reduced performance
In addition, the following items were fixed and/or added:
Execution core: fixed single-stepping in certain circumstances (bug #17316)
User interface: video and audio recording can now be separately enabled
Audio/Video recording fixes and improvements
Audio: better support for attaching and detaching remote desktop connections
Serial port emulation fixes
Serial ports: allow changing the serial port attachment while a machine is
running (bug #6115)
Networking: Added a workaround for older guests which do not enable bus
mastering for the virtio PCI device
Networking: fixed wrong RCODE from DNS AAAA query with --natdnshostresolver1
(bug #18171)
iSCSI: In cases where there is no ambiguity, the LUN of an iSCSI target is
automatically determined, for targets with non-zero LUNs
Transparently resize disk images when merging if possible
VBoxManage: support for DHCP options
Fixed VNC/RDP (bug 18153)
Guest Control: various new interfaces and features (see SDK documentation)
Linux hosts: support Linux 4.20 (thank you Larry Finger)
Shared folders: performance improvements
Guest Additions: improved shared folder auto-mounting
Windows Guest Additions: fix incorrect tablet co-ordinate handling with
recent Windows 10 builds
Linux Additions: fix for building vboxvideo on EL 7.6 standard kernel,
contributed by Robert Conde (bug #18093)
Linux guests: support Linux 4.20 (thank you Larry Finger)
Linux guests: support VMSVGA in the Linux and X11 Additions
MacOS Guest Additions: initial support
OS/2 Guest Additions: initial shared folder support
BIOS fixes
ACPI: Up to four custom ACPI tables can now be configured for a VM

==== xdg-desktop-portal-kde ====
Version update (5.15.1 -> 5.15.2)
Subpackages: xdg-desktop-portal-kde-lang

- Update to 5.15.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.2.php
- Changes since 5.15.1:
* Fix selection of multiple files (kde#404739)
* Properly convert filename to string from bytearray (kde#404445)

==== xf86-input-wacom ====

- readded support for serial input devices (boo#1120405)

==== xorg-x11-server ====
Version update (1.20.3 -> 1.20.4)
Subpackages: xorg-x11-server-extra xorg-x11-server-sdk xorg-x11-server-wayland

- xorg-server 1.20.4
* A variety of bugfixes across the board, but primarily in
Xwayland. Thanks to all who contributed with testing and
fixes!

==== xterm ====
Version update (343 -> 344)
Subpackages: xterm-bin

- Patch #344
* add ASCII escape to default for disallowedPasteControls
* fix typo in ctlseqs.ms
* implement DEC Cyrillic NRCS
* correct control returning sixel geometry max vs. actual size
* improve man page for resize
* improve mem management for parser to handle response strings
* disallow recursion which could happen in answerbackString

==== yast2 ====
Version update (4.1.55 -> 4.1.56)
Subpackages: yast2-logs

- Use /sbin/rpcinfo only, /usr/sbin/rpcinfo is gone (bsc#1127138).
- Use the correct path for /usr/bin/ifconfig (bsc#1127138).
- 4.1.56

==== yast2-auth-client ====
Version update (4.1.0 -> 4.1.1)

- yast auth-client and krb5.conf wrong domain_realm entry; (bsc#1122026)
- 4.1.1

==== yast2-bootloader ====
Version update (4.1.17 -> 4.1.19)

- Use the correct path for /usr/bin/mkdir (bsc#1127138).
- 4.1.19
- Relax check for bios_boot when logical device over more disks is
used to check that at least one disk can be bootable.
(bsc#1125792)
- Also relax installation of grub2. When at least one location
success then do not complain, just log it.
- 4.1.18

==== yast2-configuration-management ====
Version update (4.1.3 -> 4.1.5)

- fate#322722:
- Display a tree to navigate through form sections.
- Set default values for nested collections.
- Export correctly date/time and number values.
- 4.1.5
- Fixed test-suite instability by adding missing requires. (fate#322722)
- 4.1.4

==== yast2-country ====
Version update (4.1.8 -> 4.1.9)
Subpackages: yast2-country-data

- Fix OS detection and use correct keyboard file for opensuse
(bsc#1124921).
- Remove incompatible Lithuanian layout from opensuse file.
- 4.1.9

==== yast2-hardware-detection ====
Version update (4.0.0 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-ldap ====
Version update (4.0.0 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-metapackage-handler ====
Version update (4.0.0 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-network ====
Version update (4.1.39 -> 4.1.42)

- Installation proposal (bsc#1127228, bsc#1124478, bsc#1124498):
- Fixed issue refreshing the list of packages needed for the
default backend the first time the proposal is called.
- Do not cache the default network backend but only the current
one when modified by the user in the proposal
- Fallback to :wicked when saving the network if NetworkManager
is selected as the service to be used but not installed.
- 4.1.42
- When renaming an interface (bsc#1060207):
- Offer to the user the option to update device routes that
belongs to the previous interface name.
- Update the Routing devices list with the new one when needed.
- Do not drop configured elements from the list when canceling
an edition (bsc#998540)
- 4.1.41
- Installation proposal (bsc#1124478, bsc#1124498):
- Do not offer NetworkManager when the package is not available
- Respect the network backend selected in the proposal at the end
of the installation
- Removed the hostname write (127.0.0.2) from the summary
- 4.1.40

==== yast2-nfs-client ====
Version update (4.1.4 -> 4.1.5)

- Use /sbin/rpcinfo only, /usr/sbin/rpcinfo is gone (bsc#1127138).
- 4.1.5

==== yast2-nfs-server ====
Version update (4.0.3 -> 4.1.0)
Subpackages: yast2-nfs-common

- Version bump (bsc#1124009)
- 4.1.0

==== yast2-online-update ====
Version update (4.0.2 -> 4.1.0)
Subpackages: yast2-online-update-frontend

- Version bump (bsc#1124009)
- 4.1.0

==== yast2-packager ====
Version update (4.1.27 -> 4.1.29)

- Use the correct path for /usr/bin/eject (bsc#1127138)
- 4.1.29

==== yast2-pam ====
Version update (4.0.0 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-perl-bindings ====
Version update (4.0.1 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-printer ====
Version update (4.0.3 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0

==== yast2-python-bindings ====
Version update (4.0.9 -> 4.1.0)
Subpackages: yast2-python3-bindings

- Version bump (bsc#1124009)
- 4.1.0

==== yast2-scanner ====
Version update (4.0.3 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0

==== yast2-slp ====
Version update (4.0.0 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-sudo ====
Version update (4.0.1 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0

==== yast2-transfer ====
Version update (4.0.0 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0
- Changed dir of COPYING file.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-tune ====
Version update (4.0.2 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0

==== yast2-users ====
Version update (4.1.8 -> 4.1.9)

- Delete remaining dead code for encrypted homes
(bsc#1127138, fate#323541).
- 4.1.9

==== yast2-vpn ====
Version update (4.0.1 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0

==== yast2-xml ====
Version update (4.0.0 -> 4.1.0)

- Version bump (bsc#1124009)
- 4.1.0
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== zypper ====
Version update (1.14.25 -> 1.14.26)
Subpackages: zypper-aptitude zypper-log

- Offer to change the 'runSearchPackages' config option at the prompt
(bsc#1119373, FATE#325599)
- Prompt: provide a 'yes/no/always/never' prompt.
- Prompt: support "#NUM" as answer to select the NUMth option...
- Augeas: enable writing back changed option values (to ~/.zypper.conf)
- removelocale: fix segfault
- Move needs-restarting command to subpackage (fixes #254)
- Allow empty string as argument (bsc#1125415)
- Provide a way to delete cache for volatile repositories (bsc#1053177)
- Adapt to boost-1.69 requiring explicit casts tribool->bool (fixes #255)
- Show support status in info if not unknown (bsc#764147)
- version 1.14.26


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups