Mailinglist Archive: opensuse-factory (602 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190224 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190224

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.8.26 -> 7.0.8.28)
Mesa (18.3.2 -> 18.3.4)
Mesa-drivers (18.3.2 -> 18.3.4)
MozillaThunderbird (60.5.0 -> 60.5.1)
augeas
binutils (2.31 -> 2.32)
bison (3.3.1 -> 3.3.2)
c-ares (1.14.0 -> 1.15.0)
cifs-utils
clazy (1.4 -> 1.5)
colord
dialog
dpdk
dracut
elfutils (0.175 -> 0.176)
fftw3
flatpak (1.2.0 -> 1.2.3)
fontconfig
glib2
glibc
glibc
gnome-online-accounts (3.30.1 -> 3.30.2)
gpg2 (2.2.12 -> 2.2.13)
grep
groff
groff-full
hdparm (9.57 -> 9.58)
hplip
installation-images-Kubic (14.408 -> 14.410)
intel-vaapi-driver
libXau (1.0.8 -> 1.0.9)
libassuan (2.5.2 -> 2.5.3)
libbluray (1.0.2 -> 1.1.0)
libcontainers-common (20190125 -> 20190219)
libdrm
libdvdread (6.0.0 -> 6.0.1)
libfontenc (1.1.3 -> 1.1.4)
libgit2-glib (0.27.7 -> 0.27.8)
libimagequant
libopenmpt (0.4.2 -> 0.4.3)
libssh
libstorage-ng (4.1.88 -> 4.1.91)
libvirt
libxcrypt (4.1.0 -> 4.4.3)
llvm
mdadm
mozjs60
mutt (1.11.2 -> 1.11.3)
ncurses
openblas_pthreads
openjpeg2
ovmf (2018+git1542164568.85588389222a -> 2019+git1550452308.c417c1b33d06)
php7 (7.3.1 -> 7.3.2)
plasma-browser-integration (5.15.0 -> 5.15.1)
polkit-default-privs (13.2+20190207.4d86620 -> 13.2+20190213.2f39f9b)
publicsuffix (20181227 -> 20190205)
python-Jinja2
python-Pygments (2.2.0 -> 2.3.1)
python-cairo (1.15.1 -> 1.18.0)
python-gevent
python-pip (18.1 -> 19.0.2)
python-psutil (5.5.0 -> 5.5.1)
python-pytz (2018.5 -> 2018.9)
python-setuptools (40.7.2 -> 40.8.0)
rhino
sddm
suse-module-tools (15.1.10 -> 15.1.11)
syslinux
tracker (2.1.6 -> 2.1.8)
udisks2
unar
valgrind
vlc
vpnc
webkit2gtk3 (2.22.5 -> 2.22.6)
whois (5.4.0 -> 5.4.1)
xdg-desktop-portal-kde (5.15.0 -> 5.15.1)
xdm
xf86-video-intel
xhost (1.0.7 -> 1.0.8)
xlsatoms (1.1.2 -> 1.1.3)
xmodmap (1.0.9 -> 1.0.10)
xrdb (1.1.1 -> 1.2.0)
xstdcmap (1.0.3 -> 1.0.4)
xvinfo (1.1.3 -> 1.1.4)
yast2 (4.1.54 -> 4.1.55)
yast2-country (4.1.7 -> 4.1.8)
yast2-python-bindings (4.0.8 -> 4.0.9)
yast2-samba-client (4.1.0 -> 4.1.1)
yast2-storage-ng (4.1.59 -> 4.1.67)
yast2-users (4.1.7 -> 4.1.8)
zeitgeist (1.0.1 -> 1.0.2)

=== Details ===

==== ImageMagick ====
Version update (7.0.8.26 -> 7.0.8.28)
Subpackages: ImageMagick-extra libMagick++-7_Q16HDRI4 libMagickCore-7_Q16HDRI6
libMagickWand-7_Q16HDRI6 perl-PerlMagick

- updated to 7.0.8-28
* Fixed a number of issues (reference
https://github.com/ImageMagick/ImageMagick/issues).
- deleted patches
- ImageMagick-test-FITS.patch (upstreamed)
- deleted sources
- input.fits (not needed)
- added patches
https://github.com/ImageMagick/ImageMagick/issues/1484
+ ImageMagick-montage.t.patch
- update to 7.0.8-27:
* Mod patch to properly handle subimage ranges (e.g. image.gif[2-3]).
- added ImageMagick-test-FITS.patch and input.fits temporarily
https://github.com/ImageMagick/ImageMagick/issues/1478
- remove ImageMagick-clamp-after-edge.patch, it is solved another
way (see [bsc#1106415c#10])

==== Mesa ====
Version update (18.3.2 -> 18.3.4)
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1

- remove n_Disable-Xshm-for-now-since-it-results-in-render-erro.patch;
keeping that one reintroduced render errors and missing screen
refreshes on GNOME3 in a qemu VM (cirrus emulation); the issue has
been fixed in a different and better way since 18.3.3; this is
related to bsc#1118149
- Update to 18.3.4
* A fix in the XvMC state-tracker, which was causing some video attributes to
not take affect. On the video front the VAAPI state tracker has seen
improvements with VP9 streams while the amdgpu driver advertises all
available
profiles.
* On Intel side we have compiler fixes and extra PCI IDs for Coffee Lake and
Ice Lake parts. In the Broadcom drivers a couple of memory leaks were
addressed and the NEON assembly should compile properly on armhf.
* Other drivers such as radeonsi, nouveau and freedreno have also seen some
love. The RADV driver has seen addressed to compile correctly with GCC9
amongst other changes.
* The Xlib based libGL have been addressed to work with X servers, which lacks
the MIT-SHM extension such as XMing.
* To top it up we have a few fixes to the meson build system.
- Update to 18.3.3
* In this release we have:
A memory leak fix in the etnaviv driver, better NEON assembly code in vc4
and
couple of stability improvements to the radeonsi driver. Another memory leak
affecting all gallium drivers have also been addressed.
* The time required to compile GLSL shaders with large amount of uniforms,
such
as Godot, has been improved.
* GLX and swrast have also seen some improvements.
* On the Vulkan side, the ANV driver adjusted the number of images supported
for gen8 and earlier to 8, while for newer hardware it remains the same 64.
The RADV driver has seens a collection of stability improvements and fix for
the Vulkan version advertised in some corner cases.
* To top it all up, the meson build system has seen a steady amount of fixes:
the DSO version for the VDPAU drivers is now included, ICC compatibility
patches, opencl handling and relaxed handling when building osmesa.
- adjusted n_Disable-Xshm-for-now-since-it-results-in-render-erro.patch
- Build Mesa with meson instead of automake
+ Build classic swrast with Mesa, as its a dependency for osmesa - delete it
while installing
+ Build egl with Mesa-drivers as it demands one windowing-system -
delete it while installing

==== Mesa-drivers ====
Version update (18.3.2 -> 18.3.4)
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- remove n_Disable-Xshm-for-now-since-it-results-in-render-erro.patch;
keeping that one reintroduced render errors and missing screen
refreshes on GNOME3 in a qemu VM (cirrus emulation); the issue has
been fixed in a different and better way since 18.3.3; this is
related to bsc#1118149
- Update to 18.3.4
* A fix in the XvMC state-tracker, which was causing some video attributes to
not take affect. On the video front the VAAPI state tracker has seen
improvements with VP9 streams while the amdgpu driver advertises all
available
profiles.
* On Intel side we have compiler fixes and extra PCI IDs for Coffee Lake and
Ice Lake parts. In the Broadcom drivers a couple of memory leaks were
addressed and the NEON assembly should compile properly on armhf.
* Other drivers such as radeonsi, nouveau and freedreno have also seen some
love. The RADV driver has seen addressed to compile correctly with GCC9
amongst other changes.
* The Xlib based libGL have been addressed to work with X servers, which lacks
the MIT-SHM extension such as XMing.
* To top it up we have a few fixes to the meson build system.
- Update to 18.3.3
* In this release we have:
A memory leak fix in the etnaviv driver, better NEON assembly code in vc4
and
couple of stability improvements to the radeonsi driver. Another memory leak
affecting all gallium drivers have also been addressed.
* The time required to compile GLSL shaders with large amount of uniforms,
such
as Godot, has been improved.
* GLX and swrast have also seen some improvements.
* On the Vulkan side, the ANV driver adjusted the number of images supported
for gen8 and earlier to 8, while for newer hardware it remains the same 64.
The RADV driver has seens a collection of stability improvements and fix for
the Vulkan version advertised in some corner cases.
* To top it all up, the meson build system has seen a steady amount of fixes:
the DSO version for the VDPAU drivers is now included, ICC compatibility
patches, opencl handling and relaxed handling when building osmesa.
- adjusted n_Disable-Xshm-for-now-since-it-results-in-render-erro.patch
- Build Mesa with meson instead of automake
+ Build classic swrast with Mesa, as its a dependency for osmesa - delete it
while installing
+ Build egl with Mesa-drivers as it demands one windowing-system -
delete it while installing

==== MozillaThunderbird ====
Version update (60.5.0 -> 60.5.1)
Subpackages: MozillaThunderbird-translations-common

- Mozilla Thunderbird 60.5.1
* CalDav access to some servers not working
MFSA 2019-06 (bsc#1125330)
* CVE-2018-18356 bmo#1525817
Use-after-free in Skia
* CVE-2019-5785 bmo#1525433
Integer overflow in Skia
* CVE-2018-18335 bmo#1525815
Buffer overflow in Skia with accelerated Canvas 2D
* CVE-2018-18509 bmo#1507218
S/MIME signature spoofing

==== augeas ====
Subpackages: augeas-lenses libaugeas0

- Don't ignore %check test result, the testsuite now successfully
passes

==== binutils ====
Version update (2.31 -> 2.32)
Subpackages: binutils-devel

- Add disk and RAM (for ppc, ppc64 and ppc64le) constraint with _constraints.
- Update to binutils 2.32:
* The binutils now support for the C-SKY processor series.
* The x86 assembler now supports a -mvexwig=[0|1] option to control
encoding of VEX.W-ignored (WIG) VEX instructions.
It also has a new -mx86-used-note=[yes|no] option to generate (or
not) x86 GNU property notes.
* The MIPS assembler now supports the Loongson EXTensions R2 (EXT2),
the Loongson EXTensions (EXT) instructions, the Loongson Content
Address Memory (CAM) ASE and the Loongson MultiMedia extensions
Instructions (MMI) ASE.
* The addr2line, c++filt, nm and objdump tools now have a default
limit on the maximum amount of recursion that is allowed whilst
demangling strings. This limit can be disabled if necessary.
* Objdump's --disassemble option can now take a parameter,
specifying the starting symbol for disassembly. Disassembly will
continue from this symbol up to the next symbol or the end of the
function.
* The BFD linker will now report property change in linker map file
when merging GNU properties.
* The BFD linker's -t option now doesn't report members within
archives, unless -t is given twice. This makes it more useful
when generating a list of files that should be packaged for a
linker bug report.
* The GOLD linker has improved warning messages for relocations that
refer to discarded sections.
- Remove binutils-2.31-branch.diff.gz, fix-pr23919-1.diff,
fix-pr23919-2.diff, fix-pr23919-3.diff,
gold-depend-on-opcodes.diff and s390-relro.diff.
- Refresh binutils-skip-rpaths.patch, s390-biarch.diff, cross-avr-size.patch
and binutils-revert-plt32-in-branches.diff.

==== bison ====
Version update (3.3.1 -> 3.3.2)
Subpackages: bison-lang

- Run profiling without parallelism for reproducible build results
(boo#1040589)
- bison 3.3.2:
* bison 3.3 failed to generate parsers for grammars with unused
nonterminal symbols

==== c-ares ====
Version update (1.14.0 -> 1.15.0)

- Version update to 1.15.0:
* Add ares_init_options() configurability for path to resolv.conf file
* Ability to exclude building of tools (adig, ahost, acountry) in CMake
* Report ARES_ENOTFOUND for .onion domain names as per RFC7686
(bsc#1125306)
* Apply the IPv6 server blacklist to all nameserver sources
* Prevent changing name servers while queries are outstanding
* ares_set_servers_csv() on failure should not leave channel in a
bad state
- enable unit tests
- disable-live-tests.patch: disable tests to live servers
- onion-crash.patch: backport fix for a crash affecting .onion TLD

==== cifs-utils ====

- Allow cached DNS entry to expire
* add allow-dns-resolver-key-to-expire.patch
- Document new SMB2.1+ defaults
* be more verbose on mount errors, especially with EHOSTDOWN which
is often returned on SMB version issues.
* add suse-document-new-vers-default-SMB2.1.patch
- Fix python dependency stalemate by requiring python3 version of
samba-libs.

==== clazy ====
Version update (1.4 -> 1.5)

- Update to 1.5
* New Checks:
ifndef-define-typo
lowercase-qml-type-name
qrequiredresult-candidates
* New Fixits:
range-loop now supports adding missing refs or const-ref
range-loop now supports adding qAsConst()
function-args-by-ref now adding missing refs or const-ref (experimental)
Introduced CLAZY_FIXIT_SUFFIX env variable
* Removed support for the obscure -DCLAZY_BUILD_UTILS_LIB to
simplify the CMakeLists.txt
* Renamed the clazy plugin from ClangLazy.so to ClazyPlugin.so
* fully-qualified-moc-types now warns for slot/invokable return
values too. They need to be fully qualified for QML.
* Fixed a crash (clang assert) in raw-environment-function
- BuildRequire ncurses-devel instead of pkgconfig(ncurses) on Leap
42.3 to fix build

==== colord ====
Subpackages: colord-color-profiles colord-lang libcolord2 libcolorhug2

- Fix meson parameters: -Dargyllcms-sensor=true must be
- Dargyllcms_sensor=true (boo#1124388).

==== dialog ====
Subpackages: dialog-lang

- Update to version 1.3-20190211
+ modify to work with ncurses' threaded-library, which does not allow
assignment to LINES/COLS (report by Marcus Roeckrath).
+ correct clearing after text in progressbox from 2018/06/21 changes
for resizing (reports by David Boyd, Alan Somers).
+ improved configure macros CF_GNU_SOURCE, CF_POSIX_C_SOURCE,
CF_XOPEN_SOURCE
+ update config.guess, config.sub
- Includes also version 1.3-20181107
+ convert ja.po to UTF-8 for consistency (suggested by Stanislav
Brabec).
+ repair mis-encoded hi.po (report/analysis by Stanislav Brabec).
- Includes also version 1.3-20181022
+ improved configure macros CF_CC_ENV_FLAGS, CF_LD_RPATH_OPT,
CF_LIBRARY_PATH, CF_SHARED_OPTS, CF_WITH_MAN2HTML,
CF_WITH_VERSIONED_SYMS from ncurses
+ add ast.po, from
http://translationproject.org/latest/dialog/
- Includes also version 1.3-20180621
+ improve file-offset computation in textbox.c (Werner Fink).
+ fix an overlooked case with real_auto_size() to maximize when
height or width is given as -1.
+ build-fixes for configure options "--disable-Xdialog2" and
"--disable-form"
+ add traces for each widget to show its parameters.
+ modify color scheme for mixedgauge to use the dialog window colors,
like the captions.
+ fix a too-small malloc in the mixedgauge widget.
+ fix a use-after-free in dlg_remove_callback().
+ improve handling of SIGWINCH for several widgets (Debian #865840).
+ menubox, the point of the Debian report was that it would be nice
to increase the window size if the terminal size increases. Did
that as a special case less problematic than decreasing the
terminal size. Added samples/menubox11 to demonstrate by
comparison with menubox10 a problem with debconf which puts extra
newlines in the caption that interfere with autowrap.
+ progressbox and derived prgbox, programbox, now handle resizing.
+ yesno, window was cleared
+ add dlg_ttysize() to support new options, allowing scripts to obtain
some text-formatting details without initializing the terminal.
+ add options --print-text-only, and --print-text-size for scripts that
adjust the widget size according to how the captions are formatted.
+ improve dialog.pl:
+ add demo.pl, to demonstrate the functions
+ quote/escape string parameters passed to dialog.
+ ensure all "integer" parameters are really integers.
+ use actual screensize for list captions rather than assuming 24
lines.
+ when trimming blanks, treat unconverted tabs the same as spaces.
+ correct parameter to test when trimming blanks from the script,
e.g., with "--trim" (report by Jarno Suni).
+ improve documentation of the various whitespace-filtering options,
to show which take precedence (Debian #867536, cf: Debian #102942).
+ modify msgbox.c, yesno.c to bind SCROLLKEY_BINDINGS before
TRAVERSE_BINDINGS so that up/down arrow will by default scroll the
message up/down rather than be aliases for tab-traversal (report by
Fredrik Kers).
+ modify dump_one_binding() to show when a binding is overridden.
+ improve format of trace-file, making comment-syntax consistent,
as well as showing argv-splitting as a series of comments.
+ modify dlg_string_to_argv() to change the quoting behavior to be
more consistent with shell behavior (patch by Denilson Sa Maia).
+ modify dlg_getc() to return ESC when a timeout expires, notifying
callers that a quit occurred rather than exiting the application
(suggested by Rodrigo Freitas).
+ modify handle_inputs() to ensure cursor-visibility is restored when
there is no input character available (report by Guillaume Vareille).
+ improve comment in manual page regarding which widgets can use the
"--help-button" (prompted by discussion with Csanyi Pal).
+ add a check for valid object pointer in tailbox's main loop since
the getc-callback may have been freed within ui_getc.c (report by
"David").
+ improved configure macros for ncurses: CF_GNU_SOURCE, CF_SHARED_OPTS,
CF_CURSES_LIBS, CF_CURSES_FUNCS, CF_NCURSES_CONFIG
+ improved configure script checks for groff vs man2html:
CF_PROG_GROFF and CF_WITH_MAN2HTML
+ build-fix from lynx for AM_WITH_NLS configure macro
+ update config.guess, config.sub
- Remove fix for Hindi translation as now upstream
- Remove patch textbox-file_size.patch now upstream
- Remove dialog.ko.po.bz2 as ko.po now upstream
- Modify patch dialog-1.2-20121230.dif

==== dpdk ====

- Add 0002-fix-cpu-compatibility.patch to address issue with older
CPUs (bsc#1125961)
[+ 0002-fix-cpu-compatibility.patch]

==== dracut ====

- Avoid "Failed to chown ... Operation not permitted" when run from non-root,
by not copying xattrs. (osc#1092178)
* adds 0593-dracut-only-copy-xattr-if-root.patch
- Correct fix for displaying text on emergency consoles (boo#1124088)
* removes 0589-Fix-displaying-text-on-emergency-consoles.patch
* adds 0589-Fix-98dracut-systemd-dracut-emergency.sh.patch
- 95iscsi: handle qedi like bnx2i (bsc#1113712)
* adds 0592-95iscsi-handle-qedi-like-bnx2i.patch

==== elfutils ====
Version update (0.175 -> 0.176)
Subpackages: elfutils-lang libasm1 libdw1 libebl-plugins libelf-devel libelf1

- Add elfutils.keyring and verify signature.
- Update to version 0.176
build: Add new --enable-install-elfh option.
Do NOT use this for system installs (it overrides glibc elf.h).
backends: riscv improved core file and return value location support.
Fixes CVE-2019-7146, CVE-2019-7148, CVE-2019-7149, CVE-2019-7150,
CVE-2019-7664, CVE-2019-7665

==== fftw3 ====
Subpackages: libfftw3-3 libfftw3_threads3

- Add FFTW_BIN to environment variable with module file (bsc#1125824).

==== flatpak ====
Version update (1.2.0 -> 1.2.3)
Subpackages: libflatpak0 typelib-1_0-Flatpak-1_0

- Update to version 1.2.3:
+ Don't expose /proc in apply_extra script sandbox. The CVE-2019-5736
runc vulnerability is about using /proc/self/exe to modify the host
side binary from the sandbox. This mostly does not affect flatpak
since the flatpak sandbox is not run with root permissions.
However, there is one case (running the apply_extra script for
system installs) where this happens, so this release contains a fix
for that.
- Update to version 1.2.2:
+ Reverted green checkbox as they caused table alignment issues
+ Fix a division by zero if the terminal reports a zero terminal
width (which happens in the flathub build environment).
- Update to version 1.2.1:
+ Ensure flatpak builds with older versions of glib and
appstream-glib.
+ build-commit-from: Fix the new --extra-id option.
+ build-export: Allow disabling the sandboxing of the icon validator
and do so during the tests.
+ profile: Don't break if debug logging is enabled.
+ Better handling of the appdata release attribute.
+ Don't install polkit agent when not needed, avoiding some
unnecessary log lines in some cases.
+ Fix the output of the sandboxed icon validator not being visible.
+ builld-init: Allow specifying a full ref for the sdk, which is
used to select the branch name when checking sdk extensions.
+ Make the ok checks in the output green

==== fontconfig ====
Subpackages: fontconfig-devel fontconfig-lang libfontconfig1
libfontconfig1-32bit

- Add fontconfig-do-not-remove-UUID-file.patch: Removing .uuid
files caused frequent rescanning of all system fonts causing
intermittent CPU usage surges, for example, when browsing using
firefox; patch taken from upstream commit (boo#1124816,
https://gitlab.freedesktop.org/fontconfig/fontconfig/merge_requests/8).

==== glib2 ====
Subpackages: glib2-lang glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- BuildIgnore glib2-devel: since we have to require gtk-doc in
order to produce the doc, we gained an implicit dependency on
ourselves. The gtk-doc dependency is correct, but glib happens
to be buildable without this dependency too.
- Rework the check section to be in an own if/endif block so that
spec-cleaner is not getting confused by it.

==== glibc ====

- Add add-new-Fortran-vector-math-header-file.patch.
- pthread-rwlock-trylock-stalls.patch: nptl: Fix pthread_rwlock_try*lock
stalls (BZ #23844)
- arm-systemtap-probe-constraint.patch: arm: Use "nr" constraint for
Systemtap probes (BZ #24164)
- pthread-mutex-barrier.patch: Add compiler barriers around modifications
of the robust mutex list for pthread_mutex_trylock (BZ #24180)
- fork-handler-lock.patch: nptl: Avoid fork handler lock for
async-signal-safe fork (BZ #24161)
- pthread-join-probe.patch: nptl: Fix invalid Systemtap probe in
pthread_join (BZ #24211)
- riscv-clone-unwind.patch: RISC-V: Fix elfutils testsuite unwind failures
(BZ #24040)

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale glibc-locale-base
nscd

- Add add-new-Fortran-vector-math-header-file.patch.
- pthread-rwlock-trylock-stalls.patch: nptl: Fix pthread_rwlock_try*lock
stalls (BZ #23844)
- arm-systemtap-probe-constraint.patch: arm: Use "nr" constraint for
Systemtap probes (BZ #24164)
- pthread-mutex-barrier.patch: Add compiler barriers around modifications
of the robust mutex list for pthread_mutex_trylock (BZ #24180)
- fork-handler-lock.patch: nptl: Avoid fork handler lock for
async-signal-safe fork (BZ #24161)
- pthread-join-probe.patch: nptl: Fix invalid Systemtap probe in
pthread_join (BZ #24211)
- riscv-clone-unwind.patch: RISC-V: Fix elfutils testsuite unwind failures
(BZ #24040)

==== gnome-online-accounts ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gnome-online-accounts-lang libgoa-1_0-0 libgoa-backend-1_0-1
typelib-1_0-Goa-1_0

- Update to version 3.30.2:
+ google: Only request the email field when getting the user's
identity.
+ Updated translations.

==== gpg2 ====
Version update (2.2.12 -> 2.2.13)
Subpackages: gpg2-lang

- Update to 2.2.13:
* gpg: Implement key lookup via keygrip (using the & prefix).
* gpg: Allow generating Ed25519 key from existing key.
* gpg: Emit an ERROR status line if no key was found with -k.
* gpg: Stop early when trying to create a primary Elgamal key.
* gpgsm: Print the card's key algorithms along with their keygrips
in interactive key generation.
* agent: Clear bogus pinentry cache in the error case.
* scd: Support "acknowledge button" feature.
* scd: Fix for USB INTERRUPT transfer.
* wks: Do no use compression for the the encrypted challenge and response.
Release-info: https://dev.gnupg.org/T4290
See-also: gnupg-announce/2019q1/000434.html

==== grep ====
Subpackages: grep-lang

- test-pcre-jitstack.diff: avoid false positive upon stack overflow

==== groff ====

- install essential build files needed by ghostscript-fonts-grops

==== groff-full ====
Subpackages: gxditview

- install essential build files needed by ghostscript-fonts-grops

==== hdparm ====
Version update (9.57 -> 9.58)

- Update to 9.58
* fix segfault with -I onr non-ATA drives.

==== hplip ====
Subpackages: hplip-hpijs hplip-sane

- Fix hang during GNOME session logout (bsc#1112331, lp#1721534)
* added ui5-systemtray.py-make-children-exit-if-no-systray-f.patch
* added ui5-systemtray-wait-only-10s-for-system-tray.patch

==== installation-images-Kubic ====
Version update (14.408 -> 14.410)

- merge gh#openSUSE/installation-images#295
- make openssl-hmac optional
- 14.410
- merge gh#openSUSE/installation-images#294
- include the full set of kernel modules on ppc (bsc#1123349)
- 14.409

==== intel-vaapi-driver ====

- Pass -Denable_hybrid_codec=true instead of false, build hybrid
codec support.

==== libXau ====
Version update (1.0.8 -> 1.0.9)
Subpackages: libXau-devel libXau6 libXau6-32bit

- Update to version 1.0.9:
* Update configure.ac bug URL for gitlab migration
* autogen.sh: use quoted string variables
* autogen: add default patch prefix
* autogen.sh: use exec instead of waiting for configure to finish
* XauFileName: always go through buf allocation if buf is NULL
* XauFileName: reset bsize when malloc failed
* AuDispose.c:remove redundant null check on calling free()
* AuFileName.c: remove redundant null check on calling free()
* AuRead.c: remove redundant null check on calling free()
* Avoid out of boundary read access
- supersedes U_0001-XauFileName-reset-bsize-when-malloc-failed.patch,
U_0002-XauFileName-always-go-through-buf-allocation-if-buf-.patch

==== libassuan ====
Version update (2.5.2 -> 2.5.3)

- Update to 2.5.3:
* Add a timeout for writing to a SOCKS5 proxy.
* Add workaround for a problem with LD_LIBRARY_PATH on newer systems.

==== libbluray ====
Version update (1.0.2 -> 1.1.0)

- Update to version 1.1.0:
+ Add initial support for OpenJDK 11.
+ Add initial support for UHD disc BD-J menus.
+ Add support for compiling .jar file with Java 9+ compiler.
+ Move AWT classes to separate .jar file.
+ Update libudfread submodule repository URL.
+ Improve main title selection.
+ Improve error resilience and stability.
+ Improve BD-J compability.
+ Fix playback of some broken BD-J discs.
+ Fix playback of discs without normal titles (only TopMenu /
FirstPlay title).

==== libcontainers-common ====
Version update (20190125 -> 20190219)

- Upgrade to storage v1.10
* enable parallel blob reads
* Teach images to hold multiple manifests
* Move structs for storage.conf to pkg/config
- Upgrade to libpod v1.0.1
* Do not unmarshal into c.config.Spec
* spec: add nosuid,noexec,nodev to ro bind mount

==== libdrm ====
Subpackages: libdrm-devel libdrm2 libdrm_amdgpu1 libdrm_intel1 libdrm_nouveau2
libdrm_radeon1

- back to subpackage name libdrm-tools as requested by
jengelh@xxxxxxx
- Switch to meson buildsystem:
* Update Git-clone/web to new gitlab home.
* Add meson BuildRequires and macros.
* Add fdupes BuildRequires and macros, remove duplicate files.
* Rename libdrm-tools to drm-tools, follow openSUSE packaging
guidelines and silence a rpmlint warning. Add Obsoletes and
Provides to ensure smooth upgrades.
* Tweak descriptions for several sub-packages.
* Drop custom test install and run, run plain meson_test provided
by upstream.

==== libdvdread ====
Version update (6.0.0 -> 6.0.1)

- Update to version 6.0.1:
* fix a regression on some DVDs, like Resident Evil
* check InternalUDFReadBlocksRaw I/O issues
* fix issues with some DVD burnt by Nero

==== libfontenc ====
Version update (1.1.3 -> 1.1.4)
Subpackages: libfontenc-devel libfontenc1

- Update to version 1.1.4
* This release fixes a bug that would cause mkfontscale(1) to
fail to produce entries for the iso8859-7 encoding because of
wrong Unicode mappings for the iso8859-7 codepage.

==== libgit2-glib ====
Version update (0.27.7 -> 0.27.8)

- Add libgit2-glib-libgit2_028-compat.patch: Fix build with libgit2
0.28 version. Patch from upstream merge requests.
- Update to version 0.27.8:
+ Add body property to DiffFormatEmailOptions.
+ Add submodule update.
+ Fix missing struct field init in branch enumerator.
+ Fix cross compilation builds.
+ Several meson improvements.

==== libimagequant ====

- Ensure neutrality of descriptions.

==== libopenmpt ====
Version update (0.4.2 -> 0.4.3)
Subpackages: libmodplug1 libopenmpt0

- Update to version 0.4.3:
* [Sec] Possible crash due to null-pointer access when doing a
portamento from an OPL instrument to an empty instrument note
map slot.
* IT: Various fixes for note-off + instrument number in
Old Effects mode.
* MO3: Import IT row highlights as written by MO3 2.4.1.2 or
newer. Required for modules using modern tempo mode.

==== libssh ====

- Drop doxygen from dependencies to avoid buildcycle
* the documentation is available online anyway for anyone to
consume and consult http://api.libssh.org

==== libstorage-ng ====
Version update (4.1.88 -> 4.1.91)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#615
- Workaround upgrade with multiple mout points per block device
(bsc#1118865)
- 4.1.91
- merge gh#openSUSE/libstorage-ng#616
- added debugging code
- extended unit test
- 4.1.90
- merge gh#openSUSE/libstorage-ng#613
- Rename method
- Add method for removing a bcache cset
- Add actions to modify an existing bcache
- Increase minor version
- Fix error messages
- Small fixes
- Allow to modify Bcache devices
- 4.1.89

==== libvirt ====
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- qemu: don't use CAP_DAC_OVERRIDE capability if non-root
620d9dd5-qemu-no-dac-override-nonroot.patch
boo#1125665

==== libxcrypt ====
Version update (4.1.0 -> 4.4.3)
Subpackages: libcrypt1 libcrypt1-32bit libxcrypt-devel

- format-overflow.patch: Fix -Werror=format-overflow
- Update to version 4.4.3:
* Add libxcrypt.so, libxcrypt.a and xcrypt.h.
* Add new man3 manual pages.

==== llvm ====

- Remove ppc from Exclude field in spec file
- Allow use of Gold linker to be conditional
- Disable Gold linker on ppc

==== mdadm ====

- Detail.c: do not skip first character when calling xstrdup in
Detail() (bsc#1123814)
0009-Detail.c-do-not-skip-first-character-when-calling-xs.patch

==== mozjs60 ====

- riscv-support.patch: fix last change

==== mutt ====
Version update (1.11.2 -> 1.11.3)
Subpackages: mutt-doc mutt-lang

- Update to mutt 1.11.3
* This is a bug-fix release, fixing compilation with LibreSSL
and various other bug fixes.
* Show top-level decoded smime text/plain parts.
* Improve attachment menu for s/mime parts. (closes #113)
* Fix tunnels to also retry and write full buffer.
* Fix raw socket read/write to follow expected behavior.
* Fix gnutls tls_socket_write() to properly retry.
* Update the muttrc man page with added commands.
* Wrap ssl init calls for LibreSSL too.
- Modify the patches
* mutt-1.10.0.dif
* mutt-1.5.23-carriage-return.path

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo
terminfo-base terminfo-screen

- Add ncurses patch 20190216
+ improve manual page description of TABSIZE.
+ add test/demo_tabs program.
- Implement library packaging guideline: split static libraries.

==== openblas_pthreads ====

- Add OPENBLAS_INC and OPENBLAS_DIR to HPC environment (bsc#1125547).
- Fix https://github.com/xianyi/OpenBLAS/issues/2014
Add 0001-Add-a-register-to-the-clobber-list-for-the-mul-instr.patch

==== openjpeg2 ====

- Change openjpeg2 Recommends in the devel package to Requires.

==== ovmf ====
Version update (2018+git1542164568.85588389222a ->
2019+git1550452308.c417c1b33d06)
Subpackages: qemu-ovmf-x86_64

- Add TPM2_CONFIG_ENABLE build flag to enable TPM2 config menu
- Update to 2019+git1550452308.c417c1b33d06
+ BaseTools: Fixed an issue about StructurePcd
+ UefiCpuPkg/SecCore: Support EFI_PEI_CORE_FV_LOCATION_PPI
+ OvmfPkg: Add TCG2 Configuration menu to the Device Manager menu
+ FatPkg/FatPei/Gpt.c: Fix uninitialized variable issue
+ Make BaseTools compatible with python3
+ CryptoPkg/BaseCryptLib: split CryptPkcs7Verify.c on behalf
of runtime
+ MdeModulePkg/UefiBootManagerLib: Match the nested partitions
+ ArmPkg/ArmMmuLib AARCH64: get rid of needless TLB invalidation
+ Upgrade UEFI supporting TCG spec info
+ MdeModulePkg Variable: Add emulated variable NV mode support
+ Code clean-up in the network packages
+ OvmfPkg: add MmServicesTableLib resolution
+ ArmPkg/ArmMmuLib AARCH64: fix out of bounds access
+ BaseTools/VfrCompile: report error for Integer overflow
+ OvmfPkg: require GCC48 or later
+ MdePkg/BaseLib: Introduce new SpeculationBarrier API
+ Remove the obsolete network packages in MdeModulePkg
+ Upgrade OpenSSL to 1.1.0j
+ MdePkg/Base: introduce MAX_ALLOC_ADDRESS
+ MdeModulePkg/PciBus: Fix system hang when no PCI Option ROM exists
+ BaseTools/tools_def AARCH64 RELEASE: move GCC49/GGC5 to 4 KB
alignment
+ SecurityPkg: Remove dead code and inf redundant definitions
+ UefiCpuPkg/Cpuid.h: Sync CPUID definition to latest SDM
+ MdeModulePkg/PciBus: Shadow option ROM after BARs are programmed
+ ArmVirtPkg/QemuVirtMemInfoLib: trim the MMIO region mapping
+ ArmVirtPkg/XenVirtMemInfoLib: refactor reading of the PA space
size
+ ArmVirtPkg/QemuVirtMemInfoLib: remove 1:1 mapping of top of
PA range
+ ArmVirtPkg/NorFlashQemuLib: discover NOR flash banks dynamically
+ ArmPkg/ArmSmcPsciResetSystemLib: add missing call to
ExitBootServices()
+ SecurityPkg: Update TCG PFP spec revision.
+ OvmfPkg: simply use the Bochs interface for vmsvga
+ ArmPlatformPkg & ArmVirtPkg: clear frame pointer in startup
code
+ Remove unused DuetPkg, EdkShellBinPkg, and UnixPkg
+ ArmPkg/ArmGicDxe ARM: fix encoding for GICv3 interrupt
acknowledge
+ MdePkg/BaseIoLibIntrinsicArmVirt ARM: avoid double word loads
and stores
- Refresh patches
+ ovmf-add-exclude-shell-flag.patch
+ ovmf-disable-ia32-firmware-piepic.patch
- Enable Python3 support in BaseTools (bsc#1075770)

==== php7 ====
Version update (7.3.1 -> 7.3.2)
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pgsql php7-shmop php7-snmp
php7-sockets php7-sqlite php7-sysvsem php7-sysvshm php7-tidy php7-tokenizer
php7-wddx php7-xmlreader php7-xmlwriter php7-xsl php7-zlib

- updated to version 7.3.2: This is a bugfix release, with several
bug fixes included. See
http://php.net/ChangeLog-7.php#7.3.2
- php7-systzdata-v16.patch modified and renamed to
php7-systzdata-v17.patch

==== plasma-browser-integration ====
Version update (5.15.0 -> 5.15.1)
Subpackages: plasma-browser-integration-lang

- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== polkit-default-privs ====
Version update (13.2+20190207.4d86620 -> 13.2+20190213.2f39f9b)

- Update to version 13.2+20190213.2f39f9b:
* add whitelisting file for files installed in polkit-1/rules.d *
(bsc#1125314)
* the new whitelisting is packaged in a separate subpackage, because it is
not needed for normal operation, only during OBS build time for rpmlint to
find it.

==== publicsuffix ====
Version update (20181227 -> 20190205)

- Update to version 20190205:
* Add domains of Individual Network Berlin e.V. (#711)
* Added bss.design to PSL (#685)
* Add fastly-terrarium.com (#729)
* Add Swisscom Application Cloud domains (#698)
* Update public_suffix_list.dat with api.stdlib.com (#751)
* Add regional domain for filegear.me (#713)
* Remove bv.nl (#758)
* Update public_suffix_list.dat
- Link public_suffix_list.dat to effective_tld_names.dat for the
purpose of httpcomponents-client

==== python-Jinja2 ====

- Activate test suite
- Add minimum build dependency to match runtime dependency

==== python-Pygments ====
Version update (2.2.0 -> 2.3.1)

- Avoid name in summary (rpmlint).
- Ensure neutrality of description.
- Update to 2.3.1:
* Update lexers
* Minimum Python versions changed to 2.7 and 3.5
* Added support for Python 3.7 generator changes (PR#772)
* Fix incorrect token type in SCSS for single-quote strings (#1322)
* Use `terminal256` formatter if `TERM` contains `256` (PR#666)
* Fix incorrect handling of GitHub style fences in Markdown (PR#741, #1389)
* Fix `%a` not being highlighted in Python3 strings (PR#727)
- Drop patch python_37.diff which was merged upstream
- Refresh patch denose.patch

==== python-cairo ====
Version update (1.15.1 -> 1.18.0)
Subpackages: python2-cairo python3-cairo

- Update to version 1.18.0:
+ typing: Add missing annotations for __enter__/__exit__
+ New API:
- CAIRO_VERSION, CAIRO_VERSION_STRING, CAIRO_VERSION_MAJOR,
CAIRO_VERSION_MINOR, CAIRO_VERSION_MICRO
- Status.TAG_ERROR, Status.FREETYPE_ERROR, Status.PNG_ERROR,
Status.WIN32_GDI_ERROR
- SVGUnit, PDFMetadata, PDFOutlineFlags
- FontOptions.set_variations(), FontOptions.get_variations()
- Context.tag_begin(), Context.tag_end(), TAG_DEST, TAG_LINK
- PDFSurface.set_page_label(), PDFSurface.set_metadata(),
PDFSurface.set_thumbnail_size(), PDFSurface.add_outline(),
PDF_OUTLINE_ROOT
- SVGSurface.set_document_unit(),
SVGSurface.get_document_unit()
- MIME_TYPE_CCITT_FAX, MIME_TYPE_CCITT_FAX_PARAMS,
MIME_TYPE_EPS, MIME_TYPE_EPS_PARAMS, MIME_TYPE_JBIG2,
MIME_TYPE_JBIG2_GLOBAL, MIME_TYPE_JBIG2_GLOBAL_ID
+ docs: Remove a broken link
+ Various meson build fixes
+ setup.py: Support specifying custom --pkgconfigdir
+ Dropped Python 3.3 support
- Changes from version 1.17.1:
+ Meson build support
- Changes from version 1.17.0:
+ cairo.Surface and cairo.Device can now be used as context
managers
+ Fix a leak when a cairo error was raised
+ Fix a leak when a mapped surface was GCed instead of unmapped
+ Make it possible to use the C API with Python 3 outside of the
compilation unit doing the import by defining PYCAIRO_NO_IMPORT
+ Implement PEP 561
- Changes from version 1.16.3:
+ Ship Python type annotation stubs.
- Changes from version 1.16.2:
+ setup.py: Some fixes for Debian pybuild quirks
- Changes from version 1.16.1:
+ setup.py: correctly install pkgconfig into /usr/lib* again
- Changes from version 1.16.0:
+ Add a get_include() function which returns the compiler include
path needed for interfacing with the Pycairo C API
- Changes from version 1.15.6:
+ Experimental PyPy and PyPy3 support
- Changes from version 1.15.5:
+ Support Unicode paths under Windows with cairo 1.15.10+
+ Don?t include the pkg-config file when building a wheel
- Changes from version 1.15.4:
+ Fix some enum conversation errors with (unused) large and
negative values
+ tests: Fix a rare test error
- Changes from version 1.15.3:
+ setup.py: Install pkgconfig file into /usr/share/pkgconfig to
work around JHBuild on Fedora not picking it up.
+ tests: Fix tests on big endian machines.
+ Support building with MSVC
- Changes from version 1.15.2:
+ setup.py: Install pkgconfig file to the same library prefix
that Python uses (replaces logic in spec file)
- Activate test suite.
- Use license macro.
- Requires cairo >= 1.13.1.

==== python-gevent ====

- Skip the SSL tests as they just only triggers false positives
with hope upstream sorts it out someday
- Switch to pkgconfig requirements as c-ares was renamed between
SLE12 and SLE15

==== python-pip ====
Version update (18.1 -> 19.0.2)

- Avoid name repetition in summary. Summary should not be a
sentence (let alone three).
- Update to 19.0.2 (2019-02-09):
+ Bug Fixes
* Fix a crash where PEP 517-based builds using --no-cache-dir
would fail in some circumstances with an AssertionError due
to not finalizing a build directory internally. (#6197)
* Provide a better error message if attempting an editable
install of a directory with a pyproject.toml but no setup.py.
(#6170)
* The implicit default backend used for projects that provide a
pyproject.toml file without explicitly specifying build-
backend now behaves more like direct execution of setup.py,
and hence should restore compatibility with projects that
were unable to be installed with pip 19.0. This raised the
minimum required version of setuptools for such builds to
40.8.0. (#6163)
* Allow RECORD lines with more than three elements, and display
a warning. (#6165)
* AdjacentTempDirectory fails on unwritable directory instead
of locking up the uninstall command. (#6169)
* Make failed uninstalls roll back more reliably and better at
avoiding naming conflicts. (#6194)
* Ensure the correct wheel file is copied when building PEP 517
distribution is built. (#6196)
* The Python 2 end of life warning now only shows on CPython,
which is the implementation that has announced end of life
plans. (#6207)
+ Improved Documentation
* Re-write README and documentation index (#5815)
- Update to 19.0.1 (2019-01-23):
+ Bug Fixes
* Fix a crash when using ?no-cache-dir with PEP 517
distributions (#6158, #6171)
- Update to 19.0 (2019-01-22):
+ Deprecations and Removals
* Deprecate support for Python 3.4 (#6106)
* Start printing a warning for Python 2.7 to warn of impending
Python 2.7 End-of-life and prompt users to start migrating to
Python 3. (#6148)
* Remove the deprecated --process-dependency-links option.
(#6060)
* Remove the deprecated SVN editable detection based on
dependency links during freeze. (#5866)
+ Features
* Implement PEP 517 (allow projects to specify a build backend
via pyproject.toml). (#5743)
* Implement manylinux2010 platform tag support. manylinux2010
is the successor to manylinux1. It allows carefully compiled
binary wheels to be installed on compatible Linux platforms.
(#5008)
* Improve build isolation: handle .pth files, so namespace
packages are correctly supported under Python 3.2 and
earlier. (#5656)
* Include the package name in a freeze warning if the package
is not installed. (#5943)
* Warn when dropping an --[extra-]index-url value that points
to an existing local directory. (#5827)
* Prefix pip?s --log file lines with their timestamp. (#6141)
+ Bug Fixes
* Avoid creating excessively long temporary paths when
uninstalling packages. (#3055)
* Redact the password from the URL in various log messages.
(#4746, #6124)
* Avoid creating excessively long temporary paths when
uninstalling packages. (#3055)
* Avoid printing a stack trace when given an invalid
requirement. (#5147)
* Present 401 warning if username/password do not work for URL
(#4833)
* Handle requests.exceptions.RetryError raised in PackageFinder
that was causing pip to fail silently when some indexes were
unreachable. (#5270, #5483)
* Handle a broken stdout pipe more gracefully (e.g. when
running pip list | head). (#4170)
* Fix crash from setting PIP_NO_CACHE_DIR=yes. (#5385)
* Fix crash from unparseable requirements when checking
installed packages. (#5839)
* Fix content type detection if a directory named like an
archive is used as a package source. (#5838)
* Fix listing of outdated packages that are not dependencies of
installed packages in pip list --outdated --not-required
(#5737)
* Fix sorting TypeError in move_wheel_files() when installing
some packages. (#5868)
* Fix support for invoking pip using python src/pip ....
(#5841)
* Greatly reduce memory usage when installing wheels containing
large files. (#5848)
* Editable non-VCS installs now freeze as editable. (#5031)
* Editable Git installs without a remote now freeze as
editable. (#4759)
* Canonicalize sdist file names so they can be matched to a
canonicalized package name passed to pip install. (#5870)
* Properly decode special characters in SVN URL credentials.
(#5968)
* Make PIP_NO_CACHE_DIR disable the cache also for truthy
values like "true", "yes", "1", etc. (#5735)
+ Vendored Libraries
* Include license text of vendored 3rd party libraries. (#5213)
* Update certifi to 2018.11.29
* Update colorama to 0.4.1
* Update distlib to 0.2.8
* Update idna to 2.8
* Update packaging to 19.0
* Update pep517 to 0.5.0
* Update pkg_resources to 40.6.3 (via setuptools)
* Update pyparsing to 2.3.1
* Update pytoml to 0.1.20
* Update requests to 2.21.0
* Update six to 1.12.0
* Update urllib3 to 1.24.1
+ Improved Documentation
* Include the Vendoring Policy in the documentation. (#5958)
* Add instructions for running pip from source to Development
documentation. (#5949)
* Remove references to removed #egg=<name>-<version>
functionality (#5888)
* Fix omission of command name in HTML usage documentation
(#5984)
- Fix patch pip-8.1.2-shipped-requests-cabundle.patch
this version is long gone
- Rename patch to pip-shipped-requests-cabundle.patch
- Fix and show shebang removal

==== python-psutil ====
Version update (5.5.0 -> 5.5.1)

- update to version 5.5.1:
* Enhancements
+ 1348: [Windows] on Windows >= 8.1 if Process.cmdline() fails due
to ERROR_ACCESS_DENIED attempt using NtQueryInformationProcess +
ProcessCommandLineInformation. (patch by EccoTheFlintstone)
* Bug fixes
+ 1394: [Windows] Process.exe() returns "[Error 0] The operation
completed successfully" when Python process runs in "Virtual
Secure Mode".
+ 1402: psutil exceptions' repr() show the internal private module
path.
+ 1408: [AIX] psutil won't compile on AIX 7.1 due to missing
header. (patch by Arnon Yaari)

==== python-pytz ====
Version update (2018.5 -> 2018.9)

- Use more useful and clean https://pythonhosted.org/pytz/ as URL
- Use fdupes
- Add missing dependency on Python runtime, and install using setuptools.
- update to 2018.9
* IANA 2018i
* Replace all references to deprecated easy_install with pip
* Add _all_timezones_lower_to_standard to gen_tzinfo
* timezone constructor arg is case-insensitive
* Use early python2 compatible str formatting
* Raise UnknownTimeZoneError if provided timezone name is None
* Make timezone lookup case insensitive
- from 2018.7
* IANA 2018g
- from 2018.6
* IANA 2018f
* Promote BaseTzInfo to public API for type checking
* Update dev notes for Ubuntu 18.04 containers
* Add warnings to examples showing what not to do

==== python-setuptools ====
Version update (40.7.2 -> 40.8.0)
Subpackages: python2-setuptools python3-setuptools

- update to version 40.8.0:
* #1652: Added the build_meta:__legacy__ backend, a "compatibility
mode" PEP 517 backend that can be used as the default when
build-backend is left unspecified in pyproject.toml.
* #1635: Resource paths are passed to pkg_resources.resource_string
and similar no longer accept paths that traverse parents, that
begin with a leading /. Violations of this expectation raise
DeprecationWarnings and will become errors. Additionally, any
paths that are absolute on Windows are strictly disallowed and
will raise ValueErrors.
* #1536: setuptools will now automatically include licenses if
setup.cfg contains a license_file attribute, unless this file is
manually excluded inside MANIFEST.in.
- changes from version 40.7.3:
* #1670: In package_index, revert to using a copy of splituser from
Python 3.8. Attempts to use urllib.parse.urlparse led to problems
as reported in #1663 and #1668. This change serves as an
alternative to #1499 and fixes #1668.

==== rhino ====

- Do not buildrequire jline, since it is only runtime dependency
- Do not run ant with -v and -d options during the product build

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Add patch to fix reading garbage from getpwnam (boo#1125624):
* 0001-Use-C-scoping-for-handling-buffer-deletion.patch

==== suse-module-tools ====
Version update (15.1.10 -> 15.1.11)

- Update to version 15.1.11 (git 54df192):
* spec file: use more gentle wording in blacklist files
* spec file: drop jffs2 and ubifs from blacklist

==== syslinux ====

- syslinux-4.04-lzo.diff: fix lzo memory aliasing issue (bsc#1125616)

==== tracker ====
Version update (2.1.6 -> 2.1.8)
Subpackages: libtracker-common-2_0 libtracker-control-2_0-0
libtracker-miner-2_0-0 libtracker-sparql-2_0-0 tracker-lang
typelib-1_0-Tracker-2_0 typelib-1_0-TrackerControl-2_0

- Update to version 2.1.8:
+ Do not rely on hash table iteration order being stable.
+ Update FTS if base tables were updated.
- Update to version 2.1.7:
+ Fix build order with libtracker-sparql generated headers.
+ Fix ontology update with SQLite 3.25.
+ Fix build with Vala 0.43.
- Drop tracker-sqlte-3.25-rename-tables.patch: Fixed upstream.

==== udisks2 ====
Subpackages: libudisks2-0 libudisks2-0_btrfs udisks2-lang

- Generalize VDO description.
- Fix faulty grammar.
- Add more info to description of vdo.
- Add libblockdev-vdo-devel BuildRequires: Build the new vdo
module. Following this, add new vdo sub-package.

==== unar ====

- add unar-1.10.1-self-extracting_rar.patch to support RAR
self-extracting (SFX) archives [bsc#1110754]
- fix bash completion path for lsar and unar

==== valgrind ====

- add 0001-Bug-385411-s390x-Add-z13-vector-floating-point-suppo.patch
0001-Bug-385411-s390x-Tests-and-internals-for-z13-vector-.patch
0001-Bug-399444-s390x-Drop-unnecessary-check-in-s390_irge.patch
0001-Bug-403552-s390x-Fix-vector-facility-bit-number.patch (bsc#1124111)
- Don't package files twice on ppc64

==== vlc ====
Subpackages: libvlc5 libvlccore9 vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt

- Add fix-build-with-fdk-2.0.patch to fix building vlc with
libfdk-aac v2
- Add 0001-codec-vpx-Detect-libvpx-1.8.0.patch to fix building vlc
with libvpx 1.8.0
- Add the libx26410b_plugin.so codec plugin when building with
BUILD_ORIG

==== vpnc ====

- Fix references path below legacy directory /var/run -> /run
- Run %tmpfiles_create macro in %post
- Fix env-script-interpreter error

==== webkit2gtk3 ====
Version update (2.22.5 -> 2.22.6)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Replace webkit2gtk3-boo1088932-a11y-state-set.patch with a patch
proposed for webkit#188599. The original patch didn't always
prevent crashes.
- Update to version 2.22.6 (boo#1124937):
+ Make kinetic scrolling slow down smoothly when reaching the
ends of pages, instead of abruptly, to better match the GTK+
behaviour.
+ Fix Web inspector magnifier under Wayland.
+ Fix garbled rendering of some websites (e.g. YouTube) while
scrolling under X11.
+ Fix several crashes, race conditions, and rendering issues.
- CVE identifiers fixed: CVE-2019-6212, CVE-2019-6215,
CVE-2019-6216, CVE-2019-6217, CVE-2019-6226, CVE-2019-6227,
CVE-2019-6229, CVE-2019-6233, CVE-2019-6234.

==== whois ====
Version update (5.4.0 -> 5.4.1)

- whois 5.4.1:
* Add the .mw TLD server

==== xdg-desktop-portal-kde ====
Version update (5.15.0 -> 5.15.1)
Subpackages: xdg-desktop-portal-kde-lang

- Update to 5.15.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.1.php
- No code changes since 5.15.0

==== xdm ====
Subpackages: xdm-xsession

- %post: get rid of DISPLAYMANAGER in /etc/sysconfig/displaymanager
(boo#1125040)

==== xf86-video-intel ====

- removed recommends to intel-gpu-tools (boo#1125156)

==== xhost ====
Version update (1.0.7 -> 1.0.8)

- Update to version 1.0.8
* This release hardens xhost against corrupted or malicious responses from
the X server, as well as some minor bug & compatibility fixes, and general
janitorial maintenance.

==== xlsatoms ====
Version update (1.1.2 -> 1.1.3)

- Update to version 1.1.3
* This release fixes issues with listing ranges of atoms, as
well as including general janitorial maintenance.

==== xmodmap ====
Version update (1.0.9 -> 1.0.10)

- Update to version 1.0.10
* This release provides a man page update and some small build
fixes & janitorial cleanups.

==== xrdb ====
Version update (1.1.1 -> 1.2.0)

- Update to version 1.2.0
* This release adds a -E flag to see the preprocessor command
issued and the output of the preprocessor, to aid in debugging.
- run cpp with "-x assembler-with-cpp" in order to get rid of
warnings when parsing valid comments (bsc#1120004)

==== xstdcmap ====
Version update (1.0.3 -> 1.0.4)

- Update to version 1.0.4
* This release delivers some minor cleanups and janitorial
maintenance.

==== xvinfo ====
Version update (1.1.3 -> 1.1.4)

- Update to version 1.1.4
* This release delivers some small bug fixes and janitorial
cleanups.

==== yast2 ====
Version update (4.1.54 -> 4.1.55)
Subpackages: yast2-logs

- Fixed license file ordering issue causing a random test failure
(bsc#1125722)
- 4.1.55

==== yast2-country ====
Version update (4.1.7 -> 4.1.8)
Subpackages: yast2-country-data

- fix timezone setting when switching utc/local time (bsc#1087228)
- 4.1.8

==== yast2-python-bindings ====
Version update (4.0.8 -> 4.0.9)
Subpackages: yast2-python3-bindings

- Fix python3 bindings error showning 'unexpect exception' and no
trace information for errors; (bsc# 1126112).
- 4.0.9

==== yast2-samba-client ====
Version update (4.1.0 -> 4.1.1)

- Perform the workgroup lookup using samba python bindings;
(bsc#1124390).
- 4.1.1

==== yast2-storage-ng ====
Version update (4.1.59 -> 4.1.67)

- Partitioner: improve "Import Mount Points" feature.
Now, a fstab entry cannot be imported when the filesystem type
is not supported. Moreover, the "mount by" type is assigned
according to the fstab entry and the label of the previous
filesystem is preserved (bsc#1103391).
- 4.1.67
- Suggest /boot/efi as the mount point for EFI System Partitions
(bsc#1088120)
- 4.1.66
- filesystem label is kept when using existing partitioning
(bsc#1087229)
- 4.1.65
- Partitioner: add new tab in Bcache section to show all caching
set devices (part of fate#325346).
- 4.1.64
- Partitioner: new option "Provide Crypt Passwords" (bsc#1113515).
- 4.1.63
- Partitioner: allow to edit bcache devices (part of fate#325346).
- 4.1.62
- Added help texts for guided setup (bsc#1121801)
- 4.1.61
- AutoYaST: handle device_order for MD RAIDs during installation
(bsc#1083542)
- 4.1.60

==== yast2-users ====
Version update (4.1.7 -> 4.1.8)

- Fixed console warning produced by Users.pm module.
(bsc#1121070)
Fixed typo CRACKLIB_DICT_PATH in security setting.
- 4.1.8

==== zeitgeist ====
Version update (1.0.1 -> 1.0.2)
Subpackages: libzeitgeist-2_0-0

- Update to version 1.0.2:
+ Overall:
- Fix compile errors and warnings with new vala.
- fts: Correctly implement the org.gnome.zeitgeist.Index DBus
interface.
- test-log: Use correct free function for ZeitgeistResultSet.
- Do not require rapper as it is not used anymore.
- Make ontology2code work with python3.
- Properly fallback with the Zeitgeist version.
- rdflib directly to parse the trig files.
- Update Ontology2code to ba able to specify the output path.
+ Libzeitgeist: Asynchronous out-parameters are only allowed at
the end of argument lists. THIS IS AN UNAVOIDABLE VALA API
BREAK.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages