Mailinglist Archive: opensuse-factory (602 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190214 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190214

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.8.25 -> 7.0.8.26)
MozillaFirefox (64.0 -> 65.0)
NetworkManager-applet (1.8.18 -> 1.8.20)
NetworkManager-openvpn (1.8.8 -> 1.8.10)
akonadi-calendar (18.12.1 -> 18.12.2)
akonadi-calendar-tools (18.12.1 -> 18.12.2)
akonadi-contact (18.12.1 -> 18.12.2)
akonadi-import-wizard (18.12.1 -> 18.12.2)
akonadi-mime (18.12.1 -> 18.12.2)
akonadi-notes (18.12.1 -> 18.12.2)
akonadi-search (18.12.1 -> 18.12.2)
akonadi-server (18.12.1 -> 18.12.2)
akregator (18.12.1 -> 18.12.2)
apr
ark (18.12.1 -> 18.12.2)
attica-qt5 (5.54.0 -> 5.55.0)
baloo5 (5.54.0 -> 5.55.0)
baloo5-widgets (18.12.1 -> 18.12.2)
bash
bitmap (1.0.8 -> 1.0.9)
bluedevil5 (5.14.5 -> 5.15.0)
bluez-qt (5.54.0 -> 5.55.0)
breeze (5.14.5 -> 5.15.0)
breeze-gtk (5.14.5 -> 5.15.0)
breeze4-style (5.14.5 -> 5.15.0)
breeze5-icons (5.54.0 -> 5.55.0)
calendarsupport (18.12.1 -> 18.12.2)
clutter-gst (3.0.26 -> 3.0.27)
cronie
cups-filters (1.21.6 -> 1.22.0)
desktop-translations (84.87.20180507.9a26f9e2 -> 84.87.20190131.bc9de591)
discover (5.14.5 -> 5.15.0)
dolphin (18.12.1 -> 18.12.2)
dragonplayer (18.12.1 -> 18.12.2)
drkonqi5 (5.14.5 -> 5.15.0)
elementary-xfce-icon-theme (0.13.1~git11.25ff77b0 -> 0.13.1~git12.5a5d511b)
epiphany (3.30.2 -> 3.30.3)
eventviews (18.12.1 -> 18.12.2)
evolution (3.30.4 -> 3.30.5)
evolution-data-server (3.30.4 -> 3.30.5)
evolution-ews (3.30.3 -> 3.30.5)
expat
flatpak (1.0.6 -> 1.2.0)
flatpak-builder
frameworkintegration (5.54.0 -> 5.55.0)
gdbm (1.14.1 -> 1.18.1)
gitg
gnome-chess (3.30.0 -> 3.30.1)
gnome-control-center (3.30.2 -> 3.30.3)
gnome-desktop (3.30.2 -> 3.30.2.1)
grantleetheme (18.12.1 -> 18.12.2)
gssdp (1.0.2 -> 1.0.3)
gwenview5 (18.12.1 -> 18.12.2)
hwdata (0.319 -> 0.320)
ibus-libpinyin (1.10.92 -> 1.11.0)
incidenceeditor (18.12.1 -> 18.12.2)
iw (4.14 -> 5.0)
kaccounts-integration (18.12.1 -> 18.12.2)
kaccounts-providers (18.12.1 -> 18.12.2)
kactivities-stats (5.54.0 -> 5.55.0)
kactivities5 (5.54.0 -> 5.55.0)
kactivitymanagerd (5.14.5 -> 5.15.0)
kaddressbook (18.12.1 -> 18.12.2)
kalarmcal (18.12.1 -> 18.12.2)
kamera (18.12.1 -> 18.12.2)
karchive (5.54.0 -> 5.55.0)
kate (18.12.1 -> 18.12.2)
kauth (5.54.0 -> 5.55.0)
kbookmarks (5.54.0 -> 5.55.0)
kcalc (18.12.1 -> 18.12.2)
kcalcore (18.12.1 -> 18.12.2)
kcalutils (18.12.1 -> 18.12.2)
kcharselect (18.12.1 -> 18.12.2)
kcm_sddm (5.14.5 -> 5.15.0)
kcmutils (5.54.0 -> 5.55.0)
kcodecs (5.54.0 -> 5.55.0)
kcolorchooser (18.12.1 -> 18.12.2)
kcompletion (5.54.0 -> 5.55.0)
kconfig (5.54.0 -> 5.55.0)
kconfigwidgets (5.54.0 -> 5.55.0)
kcontacts (18.12.1 -> 18.12.2)
kcoreaddons (5.54.0 -> 5.55.0)
kcrash (5.54.0 -> 5.55.0)
kdav (18.12.1 -> 18.12.2)
kdbusaddons (5.54.0 -> 5.55.0)
kde-cli-tools5 (5.14.5 -> 5.15.0)
kde-gtk-config5 (5.14.5 -> 5.15.0)
kde-user-manager (5.14.5 -> 5.15.0)
kdeclarative (5.54.0 -> 5.55.0)
kded (5.54.0 -> 5.55.0)
kdelibs4
kdelibs4support (5.54.0 -> 5.55.0)
kdenetwork4-filesharing (18.12.1 -> 18.12.2)
kdepim-addons (18.12.1 -> 18.12.2)
kdepim-apps-libs (18.12.1 -> 18.12.2)
kdepim-runtime (18.12.1 -> 18.12.2)
kdesu (5.54.0 -> 5.55.0)
kdialog (18.12.1 -> 18.12.2)
kdnssd-framework (5.54.0 -> 5.55.0)
kdoctools (5.54.0 -> 5.55.0)
kemoticons (5.54.0 -> 5.55.0)
kernel-source (4.20.6 -> 4.20.7)
kfilemetadata5 (5.54.0 -> 5.55.0)
kgamma5 (5.14.5 -> 5.15.0)
kglobalaccel (5.54.0 -> 5.55.0)
kguiaddons (5.54.0 -> 5.55.0)
khelpcenter5 (18.12.1 -> 18.12.2)
kholidays (5.54.0 -> 5.55.0)
khotkeys5 (5.14.5 -> 5.15.0)
khtml (5.54.0 -> 5.55.0)
ki18n (5.54.0 -> 5.55.0)
kiconthemes (5.54.0 -> 5.55.0)
kidentitymanagement (18.12.1 -> 18.12.2)
kidletime (5.54.0 -> 5.55.0)
kimageformats (5.54.0 -> 5.55.0)
kimap (18.12.1 -> 18.12.2)
kinfocenter5 (5.14.5 -> 5.15.0)
kinit (5.54.0 -> 5.55.0)
kio (5.54.0 -> 5.55.0)
kio-extras5 (18.12.1 -> 18.12.2)
kio_audiocd (18.12.1 -> 18.12.2)
kirigami2 (5.54.0 -> 5.55.0)
kitemmodels (5.54.0 -> 5.55.0)
kitemviews (5.54.0 -> 5.55.0)
kitinerary (18.12.1 -> 18.12.2)
kjobwidgets (5.54.0 -> 5.55.0)
kjs (5.54.0 -> 5.55.0)
kjsembed (5.54.0 -> 5.55.0)
kldap (18.12.1 -> 18.12.2)
kleopatra (18.12.1 -> 18.12.2)
kmag (18.12.1 -> 18.12.2)
kmail (18.12.1 -> 18.12.2)
kmail-account-wizard (18.12.1 -> 18.12.2)
kmailtransport (18.12.1 -> 18.12.2)
kmbox (18.12.1 -> 18.12.2)
kmenuedit5 (5.14.5 -> 5.15.0)
kmime (18.12.1 -> 18.12.2)
kmousetool (18.12.1 -> 18.12.2)
knewstuff (5.54.0 -> 5.55.0)
knotes (18.12.1 -> 18.12.2)
knotifications (5.54.0 -> 5.55.0)
knotifyconfig (5.54.0 -> 5.55.0)
kompare (18.12.1 -> 18.12.2)
konsole (18.12.1 -> 18.12.2)
kontact (18.12.1 -> 18.12.2)
kontactinterface (18.12.1 -> 18.12.2)
kopete (18.12.1 -> 18.12.2)
korganizer (18.12.1 -> 18.12.2)
kpackage (5.54.0 -> 5.55.0)
kparts (5.54.0 -> 5.55.0)
kpeople5 (5.54.0 -> 5.55.0)
kpimtextedit (18.12.1 -> 18.12.2)
kpkpass (18.12.1 -> 18.12.2)
kplotting (5.54.0 -> 5.55.0)
kpty (5.54.0 -> 5.55.0)
kross (5.54.0 -> 5.55.0)
kruler (18.12.1 -> 18.12.2)
krunner (5.54.0 -> 5.55.0)
kscreen5 (5.14.5 -> 5.15.0)
kscreenlocker (5.14.5 -> 5.15.0)
kservice (5.54.0 -> 5.55.0)
ksmtp (18.12.1 -> 18.12.2)
ksshaskpass5 (5.14.5 -> 5.15.0)
ksysguard5 (5.14.5 -> 5.15.0)
ktexteditor (5.54.0 -> 5.55.0)
ktextwidgets (5.54.0 -> 5.55.0)
ktnef (18.12.1 -> 18.12.2)
kunitconversion (5.54.0 -> 5.55.0)
kwallet (5.54.0 -> 5.55.0)
kwalletmanager5 (18.12.1 -> 18.12.2)
kwayland (5.54.0 -> 5.55.0)
kwayland-integration (5.14.5 -> 5.15.0)
kwidgetsaddons (5.54.0 -> 5.55.0)
kwin5 (5.14.5 -> 5.15.0)
kwindowsystem (5.54.0 -> 5.55.0)
kxmlgui (5.54.0 -> 5.55.0)
kxmlrpcclient5 (5.54.0 -> 5.55.0)
libKF5ModemManagerQt (5.54.0 -> 5.55.0)
libKF5NetworkManagerQt (5.54.0 -> 5.55.0)
libgravatar (18.12.1 -> 18.12.2)
libkcddb (18.12.1 -> 18.12.2)
libkcompactdisc (18.12.1 -> 18.12.2)
libkdcraw (18.12.1 -> 18.12.2)
libkdecoration2 (5.14.5 -> 5.15.0)
libkdepim (18.12.1 -> 18.12.2)
libkexiv2 (18.12.1 -> 18.12.2)
libkgapi (18.12.1 -> 18.12.2)
libkipi (18.12.1 -> 18.12.2)
libkleo (18.12.1 -> 18.12.2)
libkomparediff2 (18.12.1 -> 18.12.2)
libksane (18.12.1 -> 18.12.2)
libkscreen2 (5.14.5 -> 5.15.0)
libksieve (18.12.1 -> 18.12.2)
libksysguard5 (5.14.5 -> 5.15.0)
libostree (2018.9 -> 2019.1)
libqt5-qtbase
libqt5-qtspeech
libvirt
libwacom (0.30 -> 0.32)
libxkbcommon (0.8.2 -> 0.8.3)
mailcommon (18.12.1 -> 18.12.2)
mailimporter (18.12.1 -> 18.12.2)
mariadb-connector-c (3.0.6 -> 3.0.8)
messagelib (18.12.1 -> 18.12.2)
milou5 (5.14.5 -> 5.15.0)
mobipocket (18.12.1 -> 18.12.2)
ncurses
okular (18.12.1 -> 18.12.2)
open-vm-tools
openpgm
orca (3.30.1 -> 3.30.2)
osc (0.164.1 -> 0.164.2)
oxygen5 (5.14.5 -> 5.15.0)
oxygen5-icon-theme (5.54.0 -> 5.55.0)
pcsc-lite
perl-DateTime-Format-Strptime (1.75 -> 1.76)
perl-SOAP-Lite
perl-Task-Weaken
perl-Test-Simple (1.302160 -> 1.302162)
perl-XML-LibXML (2.0133 -> 2.0134)
php7
pimcommon (18.12.1 -> 18.12.2)
pkcs11-helper (1.22 -> 1.25.1)
plasma-browser-integration (5.14.5 -> 5.15.0)
plasma-framework (5.54.0 -> 5.55.0)
plasma-nm5 (5.14.5 -> 5.15.0)
plasma5-addons (5.14.5 -> 5.15.0)
plasma5-desktop (5.14.5 -> 5.15.0)
plasma5-integration (5.14.5 -> 5.15.0)
plasma5-openSUSE
plasma5-pa (5.14.5 -> 5.15.0)
plasma5-workspace (5.14.5 -> 5.15.0)
polkit-kde-agent-5 (5.14.5 -> 5.15.0)
postfix
powerdevil5 (5.14.5 -> 5.15.0)
prison-qt5 (5.54.0 -> 5.55.0)
purpose (5.54.0 -> 5.55.0)
python-certifi (2018.4.16 -> 2018.11.29)
python-pycurl
python-qt5 (5.11.3 -> 5.12)
python-sip (4.19.13 -> 4.19.14)
python-wxWidgets-3_0
read-only-root-fs (1.0+git20180606.046b099 -> 1.0+git20190206.586e9f1)
rpm
rubygem-addressable (2.5.2 -> 2.6.0)
schily
shotwell (0.30.1 -> 0.30.2)
solid (5.54.0 -> 5.55.0)
sonatype-oss-parent
sonnet (5.54.0 -> 5.55.0)
spectacle (18.12.1 -> 18.12.2)
spice
syndication (5.54.0 -> 5.55.0)
syntax-highlighting (5.54.0 -> 5.55.0)
systemsettings5 (5.14.5 -> 5.15.0)
tagsoup
threadweaver (5.54.0 -> 5.55.0)
tiff
transactional-update (2.12 -> 2.13)
virt-manager (2.0.0 -> 2.1.0)
virt-sandbox (0.6.0 -> 0.8.0)
xdg-desktop-portal (1.0.3 -> 1.2.0)
xdg-desktop-portal-gtk (1.0.2 -> 1.2.0)
xdg-desktop-portal-kde (5.14.5 -> 5.15.0)
xfce4-terminal
yast2 (4.1.53 -> 4.1.54)
yast2-bootloader (4.1.14 -> 4.1.16)
yast2-network (4.1.36 -> 4.1.37)
zypper (1.14.24 -> 1.14.25)

=== Details ===

==== ImageMagick ====
Version update (7.0.8.25 -> 7.0.8.26)
Subpackages: ImageMagick-extra libMagick++-7_Q16HDRI4 libMagickCore-7_Q16HDRI6
libMagickWand-7_Q16HDRI6 perl-PerlMagick

- update to 7.0.8-26:
* Fixed a number of issues (reference
https://github.com/ImageMagick/ImageMagick/issues).

==== MozillaFirefox ====
Version update (64.0 -> 65.0)
Subpackages: MozillaFirefox-translations-common

- Mozilla Firefox 65.0
* Enhanced tracking protection
* allow switching of UI locales within preferences
* support for the WebP image format
* "top"-like about:performance
MFSA 2019-01 (bsc#1122983)
* CVE-2018-18500 bmo#1510114
Use-after-free parsing HTML5 stream
* CVE-2018-18503 bmo#1509442
Memory corruption with Audio Buffer
* CVE-2018-18504 bmo#1496413
Memory corruption and out-of-bounds read of texture client
* CVE-2018-18505 bmo#1497749
Privilege escalation through IPC channel messages
* CVE-2018-18506 bmo#1503393
Proxy Auto-Configuration file can define localhost access to be proxied
* CVE-2018-18502 bmo#1499426 bmo#1480090 bmo#1472990 bmo#1514762
bmo#1501482 bmo#1505887 bmo#1508102 bmo#1508618 bmo#1511580
bmo#1493497 bmo#1510145 bmo#1516289 bmo#1506798 bmo#1512758
Memory safety bugs fixed in Firefox 65
* CVE-2018-18501 bmo#1512450 bmo#1517542 bmo#1513201 bmo#1460619
bmo#1502871 bmo#1516738 bmo#1516514
Memory safety bugs fixed in Firefox 65 and Firefox ESR 60.5
- requires
NSS 3.41
rust/carge 1.30
rust-cbindgen 0.6.7
- rebased patches
- remove workaround for build memory consumption on i586; other
mitigations meanwhile introduced (mainly parallelity) will be
sufficient
mozilla-reduce-files-per-UnifiedBindings.patch
- Increase disk constraint.
- Remove -v from mach build in order to work-around bmo#1500436.
- Set %clang_build to false on all architectures
- Do not use -fno-delete-null-pointer-checks and -fno-strict-aliasing:
it should not be needed anymore
- Do not overwrite enable-optimize and when possible
enable --enable-debug-symbols.
- Add -v to mach in order to make build verbose.
- Mozilla Firefox 64.0.2:
* Update the Japanese translation for missing strings (bmo#1513259)
* Properly restore column sizes in developer tools inspector (bmo#1503175)
* Fixed video stuttering on Youtube (bmo#1513511)
* Fix updates for some lightweight themes (bmo#1508777)
- Enable build_hardened for all architectures
- Switch back aarch64 to clang as '-fPIC' fixes bmo#1513605
- Remove obolete '--enable-pie' as -pie is always enabled for
gcc and clang

==== NetworkManager-applet ====
Version update (1.8.18 -> 1.8.20)
Subpackages: NetworkManager-applet-lang NetworkManager-connection-editor
libnma0 nma-data typelib-1_0-NMA-1_0

- Update to version 1.8.20:
+ Build of libnm-gtk, a libnm-glib compatibility library, is
disabled by default. It can be enabled by passing
- -with-libnm-gtk to configure script. Nobody should need it by
now. Users that still use this are encouraged to let us know
before the libnm-glib support is removed for good.
+ Improve the mobile broadband wizard.
+ Fix a bug in the wifi dialog that made widgets disappear when
selecting a different device.
+ Support secret agent hints needed when using IWD as wireless
backend.
+ Updated translations.
- Drop nm-applet-revert-no-show-all.patch: Fixed upstream.

==== NetworkManager-openvpn ====
Version update (1.8.8 -> 1.8.10)
Subpackages: NetworkManager-openvpn-gnome NetworkManager-openvpn-lang

- Update to version 1.8.10:
+ Fix changing the proxy port in the editor.
+ Drop the file extension check when importing a file.
+ Support loading the editor shared object from the same
directory of plugin for development purposes.
+ Updated translations.

==== akonadi-calendar ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== akonadi-calendar-tools ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-calendar-tools-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== akonadi-contact ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== akonadi-import-wizard ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== akonadi-mime ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== akonadi-notes ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== akonadi-search ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== akonadi-server ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Fix aggregation logic for cacheOnly and ignoreErrors.
* autotests: rename notificationmanagertest to notificationsubscribertest
* Extend tagtest with more checks that the full tag information is sent.
* autotests: remove QEXPECT_FAIL, the mysql bug got fixed.
* Fix tag name/type/gid missing in notifications about tags.
* Minor: improve QDebug output for Akonadi::Tag
* actually look for mysql binaries in PATH
* Allow to exclude unified mailbox from local subscription

==== akregator ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akregator-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== apr ====
Subpackages: apr-devel libapr1

- increase timeout to fix random failure of testsuite
+ apr-test-sendfile-timeout.patch
- fix build for SLE11 again
- linux version is now checked correctly, drop
- apr-1.4.5-linux3.patch
(see change log from Sun Aug 7 01:21:44 UTC 2011)

==== ark ====
Version update (18.12.1 -> 18.12.2)
Subpackages: ark-lang libkerfuffle18

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Remember part URL to delete the tempfile even if the user used save as.
(kde#402529)

==== attica-qt5 ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Attica5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== baloo5 ====
Version update (5.54.0 -> 5.55.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix ResultIterator
* [tags_kio] Disable access with a double slashed url, i.e. "tags://".
(kde#400594)
* Instantiate QApplication before KCrash/KCatalog
* Ignore all non-storage deviceAdded signals from Solid
* IndexerConfig: Delete copy constructor and assignment operator
* delete copy constructor and assignment operator of some internal classes
* Use the nicer K_PLUGIN_CLASS_WITH_JSON
* Remove Qt 5.10 checks now that we require it as min version

==== baloo5-widgets ====
Version update (18.12.1 -> 18.12.2)
Subpackages: baloo5-widgets-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== bash ====
Subpackages: bash-doc bash-lang

- Add upstream patches bash50-001 and bash50-002

==== bitmap ====
Version update (1.0.8 -> 1.0.9)

- update to version 1.0.9:
* This release fixes a long standing bug in the bitmap editor
where operations would not work properly when NumLock was on.

==== bluedevil5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: bluedevil5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle

==== bluez-qt ====
Version update (5.54.0 -> 5.55.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix fall-through warning

==== breeze ====
Version update (5.14.5 -> 5.15.0)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers libbreezecommon5-5

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* Use correct window for getting ComboBox current icon pixmap
* Update Breeze Dark Look and Feel theme previews
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* Export path of installed color-schemes in BreezeConfig cmake
* Translate color scheme names
* Fix typo
* enable animations for standalone created buttons
* Fix build of libbreezecommon with USE_KDE4
* [libbreezecommon] Use box blur instead of FFT blur
* Improve accuracy of some window decoration options' labels BUG: 399602
FIXED-IN: 5.15.0 (kde#399602)
* Fix logic typo
* Add KDE4 guard round mouse synthesised test
* Don't drag windows in empty areas from touch/pen events
* Link *-resize to the right icons
* [cursors] Also link for Breeze Snow
* [Cursors] link *-resize to *_corner cursor (kde#399194)
- Does not use FFTW anymore

==== breeze-gtk ====
Version update (5.14.5 -> 5.15.0)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* Cosmetic fixes for build_theme.sh
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Too many changes to list here
- CSS files are now generated during build using Python and SASS

==== breeze4-style ====
Version update (5.14.5 -> 5.15.0)
Subpackages: libbreezecommon4-5

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* Use correct window for getting ComboBox current icon pixmap
* Update Breeze Dark Look and Feel theme previews
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* Export path of installed color-schemes in BreezeConfig cmake
* Translate color scheme names
* Fix typo
* enable animations for standalone created buttons
* Fix build of libbreezecommon with USE_KDE4
* [libbreezecommon] Use box blur instead of FFT blur
* Improve accuracy of some window decoration options' labels BUG: 399602
FIXED-IN: 5.15.0 (kde#399602)
* Fix logic typo
* Add KDE4 guard round mouse synthesised test
* Don't drag windows in empty areas from touch/pen events
* Link *-resize to the right icons
* [cursors] Also link for Breeze Snow
* [Cursors] link *-resize to *_corner cursor (kde#399194)
- Does not use FFTW anymore

==== breeze5-icons ====
Version update (5.54.0 -> 5.55.0)

- Workaround yast2-theme incompatibility by adding a symlink
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Too many changes to list here

==== calendarsupport ====
Version update (18.12.1 -> 18.12.2)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== clutter-gst ====
Version update (3.0.26 -> 3.0.27)
Subpackages: gstreamer-plugin-cluttergst3 libclutter-gst-3_0-0
typelib-1_0-ClutterGst-3_0

- Update to version 3.0.27:
+ Explicitly link to gdk-pixbuf.
- Add explicit pkgconfig(gdk-pixbuf-2.0) BuildRequires following
upstream changes.

==== cronie ====
Subpackages: cron

- cron.service: No limit on the number of processes spawned by cron
shall be imposed.

==== cups-filters ====
Version update (1.21.6 -> 1.22.0)

- Update to version 1.22.0:
* From this release on the pdftopdf filter flattens interactive
PDF forms and annotations internally, using QPDF, instead of
calling external utilities. This especially eliminates slowing
factors as additional piping of the data and unneeded use of
PDF interpreters. Using external utilities for flattening is
still possible in case of problems. In addition, a crash bug in
cups-browsed got fixed and compatibility of the filters with
Poppler 0.72 assured.
- Drop upstream fixed patches:
* 0001-Raise-minimum-poppler-version-from-0.18-to-0.19.patch
* 0002-Adapt-code-for-SplashXPathScanner-state-handling-sin.patch
* 0003-Support-some-more-methods-returning-const.patch
* 0004-Support-GooString-c_str-introduced-by-poppler-0.72.patch

==== desktop-translations ====
Version update (84.87.20180507.9a26f9e2 -> 84.87.20190131.bc9de591)

- Update to version 84.87.20190131.bc9de591:
* update desktop file data
* adjust for 15.1
* Also translate X-SuSE-YaST-Keywords entries in .desktop files
* Consistently use LF line ending
* Run generation with new enabled keys
* Translated using Weblate (Arabic)
* Translated using Weblate (Catalan)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Czech)
* Translated using Weblate (Danish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Finnish)
* Translated using Weblate (Galician)
* Translated using Weblate (German)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Italian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Kabyle)
* Translated using Weblate (Persian)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Romanian)
* Translated using Weblate (Russian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Spanish)
* Translated using Weblate (Swedish)
* Translated using Weblate (Turkish)
* Update appstreamdata.po
* Update mimeinfo.po

==== discover ====
Version update (5.14.5 -> 5.15.0)
Subpackages: discover-backend-flatpak discover-backend-packagekit discover-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* [Updates page] Use a more universally-available arrow character (kde#403544)
* Search-enable the application page
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Too many changes to list here

==== dolphin ====
Version update (18.12.1 -> 18.12.2)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Fix member initialization
* [versioncontrolobserver] Update working directory on tab activation
* [versioncontrolobserver] Do not use static plugin objects

==== dragonplayer ====
Version update (18.12.1 -> 18.12.2)
Subpackages: dragonplayer-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== drkonqi5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: drkonqi5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Properly link to zlib
* lldb and Mac support
* Debugger: Add missing include
* debugger: DataLocation is deprecated, move to AppDataLocation
* Use new syntax
* We depend against 5.11
* Make it compile with KDEFrameworkCompilerSettings

==== elementary-xfce-icon-theme ====
Version update (0.13.1~git11.25ff77b0 -> 0.13.1~git12.5a5d511b)

- Update to version 0.13.1~git12.5a5d511b:
* added blueberry tray icons

==== epiphany ====
Version update (3.30.2 -> 3.30.3)
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Update to version 3.30.3:
+ Fix height of new windows.
+ Add missing space to encoding dialog.
+ Disallow bookmarks tags with empty names.
+ Fix crash loading unexpected URLs.
+ Fix remote inspector.
+ Fix crash syncing bookmarks with Firefox Sync.
+ Fix saving changes to web app icons.
- Drop upstream fixed patches:
+ epiphany-bookmark-ensure-tags-sequence-is-created.patch.
+ epiphany-Fix-saving-web-app-icons.patch.
+ epiphany-window-Set-correct-current-height.patch.
+ epiphany-encoding-dialog-add-some-column-spacing.patch.
+ epiphany-Tags-with-empty-labels.patch.
+ epiphany-Fix-remote-inspector-support.patch.
+ epiphany-web-view-Handle-NULL-URIs.patch.

==== eventviews ====
Version update (18.12.1 -> 18.12.2)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== evolution ====
Version update (3.30.4 -> 3.30.5)
Subpackages: evolution-lang evolution-plugin-bogofilter
evolution-plugin-pst-import evolution-plugin-spamassassin

- Update to version 3.30.5:
+ Event with empty summary can cause crash.
+ [Composer] Draft email can lose attachments when opened.
+ Initialize 'cache' variable in e_http_request_process_sync().
+ Bugs fixed: glgo#GNOME/evolution#76, glgo#GNOME/evolution#250,
glgo#GNOME/evolution#275, glgo#GNOME/evolution#277,
glgo#GNOME/evolution#278, glgo#GNOME/evolution#282,
glgo#GNOME/evolution#283, glgo#GNOME/evolution#284,
glgo#GNOME/evolution#288.
+ Updated translations.

==== evolution-data-server ====
Version update (3.30.4 -> 3.30.5)
Subpackages: evolution-data-server-lang libcamel-1_2-62 libebackend-1_2-10
libebook-1_2-19 libebook-contacts-1_2-2 libecal-1_2-19 libedata-book-1_2-25
libedata-cal-1_2-29 libedataserver-1_2-23 libedataserverui-1_2-2

- Update to version 3.30.5:
+ Bugs fixed: glgo#GNOME/evolution-data-server#75,
glgo#GNOME/evolution-data-server#81,
glgo#GNOME/evolution-data-server#82.
+ Updated translations.

==== evolution-ews ====
Version update (3.30.3 -> 3.30.5)
Subpackages: evolution-ews-lang

- Update to version 3.30.5:
+ Bugs fixed: glgo#GNOME/evolution-ews#25,
glgo#GNOME/evolution-ews#30, glgo#GNOME/evolution-ews#31,
glgo#GNOME/evolution-ews#32.
- Changes from version 3.30.4:
+ Updated translations.

==== expat ====
Subpackages: libexpat-devel libexpat1 libexpat1-32bit

- Add expat-2.2.6-fix-make-clean.patch
- Allow profile guided optimization again

==== flatpak ====
Version update (1.0.6 -> 1.2.0)
Subpackages: libflatpak0 typelib-1_0-Flatpak-1_0

- Update to version 1.2.0:
+ Ensure DeployCollectionID works in flatpakrepo files in all
cases.
+ Don't error out with empty installations in uninstall.
+ Add helper that validates icon files during export.
+ Don't allow root to modify the (non-root) per-user flatpak
installation, as this risks causing problems later.
+ Remove some incorrect warnings from flatpak repair.
+ Allow multiple name segments after prefix when exporting files.
+ Allow specification of ellipsization in --colums options.
+ Handle dates as well as timestamps in appdata
+ Fixed a bug where flatpak remote-delete removed too many refs.
+ Now we use raw terminal mode during a transaction to a avoid
problems with input during the operation causing problems with
escape sequences.
+ Generate a fontconfig directory remapping snippet as will be
needed for newer versions of fontconfig.
+ Support --extra-collection-id in build-commit-from to bind the
commit to multiple collection ids. This is work in progress in
ostree.
- Add pkgconfig(dconf) BuildRequires: New dependency.

==== flatpak-builder ====

- Switch from Requires to Recommends for bzr. bzr only works for
python2 and on a python3 only system, bzr is not available
(bsc#1082696)

==== frameworkintegration ====
Version update (5.54.0 -> 5.55.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== gdbm ====
Version update (1.14.1 -> 1.18.1)
Subpackages: gdbm-devel gdbm-lang libgdbm6 libgdbm_compat4

- update to 1.18.1:
* Fix debian bug 910911: This restores backward compatibility with
databases created by version 1.8 (and some later versions, with
mmapped I/O disabled).
- update to 1.18:
* Fix directory entry validation
* Fix improper use of GDBM_DEBUG macro
* Fix spurious error from gdbm_dump and gdbm_export
* Make sure gdbm_sync always returns a meaningful value
- includes changes from 1.17:
* Fix bug in gdbm_dump function, it did not clear the
GDBM_ITEM_NOT_FOUND error marker, which is set upon its normal
termination
- changes upstreamed:
* gdbm_close() and gdbm_sync() now return 0 on success. On error,
they return -1 and set gdbm_errno and errno to the appropriate
error codes - drop gdbm-close-and-sync-return-value.patch
- update to 1.16:
* Fix typo
* New gdbmtool variables: coalesce and centfree
* src/falloc.c (avail_lookup): Remove the start parameter.
(_gdbm_put_av_elem): Rewrite the "can_merge" loop.
- added gdbm-close-and-sync-return-value.patch
see https://puszcza.gnu.org.ua/bugs/index.php?399
- update to 1.15:
* Extensive database consistency checking
* Improved error checking
* Removed gdbm-1.8.3 compatibility layer
* Commands can be given to gdbmtool in the command line
* Fixed data conversion bugs in storing structured keys or content
* New member in the gdbm_recovery structure: duplicate_keys
* New error codes

==== gitg ====
Subpackages: gitg-lang libgitg-1_0-0 libgitg-ext-1_0-0

- Fix build with new translations-update-upstream.

==== gnome-chess ====
Version update (3.30.0 -> 3.30.1)
Subpackages: gnome-chess-lang

- Update to version 3.30.1:
+ Fix "computer player is confused" when CECP engine claims a
draw.

==== gnome-control-center ====
Version update (3.30.2 -> 3.30.3)
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-lang gnome-control-center-user-faces

- Update to version 3.30.3:
+ Display: Various bugfixes.
+ Network: Move AP list population into an idle handler.
+ Power: Fix device label alignment.
+ Thunderbolt: Fix double free in bolt client.
+ Universal Access: Reverse Repeat Keys Speed direction.
+ Updated translations.

==== gnome-desktop ====
Version update (3.30.2 -> 3.30.2.1)
Subpackages: gnome-desktop-lang gnome-version libgnome-desktop-3-17
libgnome-desktop-3_0-common typelib-1_0-GnomeDesktop-3_0

- Update to version 3.30.2.1:
+ Fix slow thumbnailer due to missing font cache.
+ Updated translations.

==== grantleetheme ====
Version update (18.12.1 -> 18.12.2)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== gssdp ====
Version update (1.0.2 -> 1.0.3)

- Update to version 1.0.3:
+ Meson build fixes.
+ Fix running sniffer from meson build.
+ Fix issue on OS X when socket is destroyed after suspend.
+ Fix a memory leak in the device sniffer.
+ Fix a crash when sending a SSDP message after clearing the
custom headers.
+ Use utsname.release for Server: header.
+ Bugs fixed in this release: glgo#GNOME/gssdp#1, bgo#794340.
- Switch to meson buildsystem, add meson and gtk-doc BuildRequires
and macros. Also run tests in new check section.

==== gwenview5 ====
Version update (18.12.1 -> 18.12.2)
Subpackages: gwenview5-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1
- Update build requirements

==== hwdata ====
Version update (0.319 -> 0.320)

- Update to version 0.320 (bsc#1121410):
* Updated pci, usb and vendor ids.

==== ibus-libpinyin ====
Version update (1.10.92 -> 1.11.0)

- Update version to 1.11.0
* Fix keypad decimal
* Fix emoji candidates
* Support configurable opencc config
- Drop ibus-libpinyin-fix-build-fault.patch, merged by upstream.

==== incidenceeditor ====
Version update (18.12.1 -> 18.12.2)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== iw ====
Version update (4.14 -> 5.0)

- Update to version 5.0
* Bump compat level to 12
* Bump Standards-Version to 4.3.0
* d/gbp.conf: upstreambranch = upstream/latest

==== kaccounts-integration ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kaccounts-providers ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kaccounts-providers-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kactivities-stats ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kactivities5 ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* fix for macOS

==== kactivitymanagerd ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kactivitymanagerd-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Consti'fy
* create categories file
* Move kactivitymanagerd to libexec and remove manual daemon management
* Fix compile
* Use QStringLiteral and co

==== kaddressbook ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kaddressbook-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kalarmcal ====
Version update (18.12.1 -> 18.12.2)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kamera ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kamera-lang kio_kamera

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== karchive ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Save two KFilterDev::compressionTypeForMimeType calls

==== kate ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kate-lang kate-plugins

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kauth ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Remove support for passing gui QVariants to KAuth
helpers (bsc#1124863,CVE-2019-7443)

==== kbookmarks ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Build without D-Bus on Android

==== kcalc ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kcalc-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kcalcore ====
Version update (18.12.1 -> 18.12.2)

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kcalutils ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kcharselect ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kcharselect-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kcm_sddm ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kcm_sddm-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* Fix autologin session loading
* Fix mime type filter on background selection button (kde#402930)
* Fix loading of background image preview (kde#402930)
* Workaround QTBUG-47066 to fix crash on startup
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Fix some clazy warning
* Slightly tweak sizes and margins so everything fits and looks pretty
* Don't use hardcoded background color
* Move GHNS button to the normal location
* Use consistent text for the GHNS button
* Give the GHNS button an appropriate icon and more consistent text
(kde#400424)
* sddm-kcm: don't hardcode session file location.
* Give SDDM knsrc file a name (kde#399526)
* Make it compile with KDEFrameworkCompilerSettings module

==== kcmutils ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* [kcmutils] Add ellipsis to search labels in KPluginSelector

==== kcodecs ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* nsSJISProber::HandleData: Don't crash if aLen is 0
* KEncodingProber: Delete copy constructor and assignment operator

==== kcolorchooser ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kcolorchooser-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kcompletion ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* delete copy constructor and assignment operator of some internal classes
* Remove unused Q_D

==== kconfig ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* [API dox] Include kconfig_compiler/README.dox for QCH generation
* kconfig_compiler: delete the assignment operator and copy constructor
* KEmailSettings: Delete copy constructor and assignment operator
* KonfUpdate: delete copy constructor and assignment operator

==== kconfigwidgets ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Build without KAuth and D-Bus on Android
* fix environment setup of klanguagename test
* Add KLanguageName

==== kcontacts ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kcoreaddons ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* delete copy constructor and assignment operator of some public classes
* delete copy constructor and assignment operator of some internal classes
* Remove check for Qt version 5.10

==== kcrash ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Comment why changing the ptracer is required
* [KCrash] Establish socket to allow change of ptracer
* Fix out-of-bounds assert while running unittests with argv==nullptr.

==== kdav ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kdav-lang libKPimKDAV5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kdbusaddons ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kde-cli-tools5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kde-cli-tools5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* [KRun] Don?t follow redirection to speed up and avoid incorrect behavior
* Load Plasma QtQuick settings in KCMShell (kde#403314)
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* [kde-cli-tools] Add search ellipsis to label, make label more consistent
with HIG
* Remove KDE3 reference in kdeeject (kde#357986)
* Fix logic error in kioclient noninteractive argument handling
* Keep kioclient alive whilst we're showing error messages
* Fix KIOClient non-interactive mode handling renamed prompts
* KLineEdit::setClearButtonShown() is deprecated, port away.
* Use KDEFrameworkCompilerSettings
- Refresh kdesu-add-some-i18n-love.patch

==== kde-gtk-config5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* Use better, less technical, and more consistent strings for name, comment,
and GHNS button
* Sort icon and cursor themes case-insensitively (kde#368600)
* Fix spelling errors
* Add .arcconfig file

==== kde-user-manager ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kde-user-manager-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Consti'fy
* Fix some clazy warning
* Use new syntax
* Autogenerate debug file + add categories file
* Add NO_POLICY_SCOPE
* Use KDEFrameworkCompilerSettings

==== kdeclarative ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* [KCM Controls GridView] Add remove animation
* KDeclarative: Delete copy constructor and assignment operator

==== kded ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kded-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kdelibs4 ====
Subpackages: kdelibs4-branding-upstream kdelibs4-core libkde4 libkdecore4
libksuseinstall1

- Remove requirements on upower: it is long deprecated and there
is no longer a Qt4 based desktop to use it (boo#1124573)

==== kdelibs4support ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* autotests: disable failing KTabWidget test, not worth debugging
* autotests: tab reordering is done with LMB these days, not MMB
* Fix some country flags to use all the pixmap
* Remove Qt version check

==== kdenetwork4-filesharing ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kdenetwork4-filesharing-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kdepim-addons ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kdepim-addons-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Fix Bug 403174 - KAddressBook looses contact birthdays when merging two or
more contacts (kde#403174)

==== kdepim-apps-libs ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kdepim-apps-libs-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kdepim-runtime ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kdepim-runtime-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kdesu ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* handle wrong password when using sudo which asks for another password
(kde#389049)
* KDEsuClient: Delete copy constructor and assignment operator
* delete copy constructor and assignment operator of some internal classes

==== kdialog ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kdialog-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kdnssd-framework ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kdoctools ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kemoticons ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Remove unused variable + port to new connect api

==== kernel-source ====
Version update (4.20.6 -> 4.20.7)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms kernel-vanilla-base

- Linux 4.20.7 (bnc#1012628).
- drm/msm/gpu: fix building without debugfs (bnc#1012628).
- ipv6: sr: clear IP6CB(skb) on SRH ip4ip6 encapsulation
(bnc#1012628).
- ipvlan, l3mdev: fix broken l3s mode wrt local routes
(bnc#1012628).
- l2tp: copy 4 more bytes to linear part if necessary
(bnc#1012628).
- l2tp: fix reading optional fields of L2TPv3 (bnc#1012628).
- net: ip_gre: always reports o_key to userspace (bnc#1012628).
- net: ip_gre: use erspan key field for tunnel lookup
(bnc#1012628).
- net/ipv6: don't return positive numbers when nothing was dumped
(bnc#1012628).
- net/mlx4_core: Add masking for a few queries on HCA caps
(bnc#1012628).
- netrom: switch to sock timer API (bnc#1012628).
- net/rose: fix NULL ax25_cb kernel panic (bnc#1012628).
- net: set default network namespace in init_dummy_netdev()
(bnc#1012628).
- ravb: expand rx descriptor data to accommodate hw checksum
(bnc#1012628).
- sctp: improve the events for sctp stream reset (bnc#1012628).
- tun: move the call to tun_set_real_num_queues (bnc#1012628).
- ucc_geth: Reset BQL queue when stopping device (bnc#1012628).
- vhost: fix OOB in get_rx_bufs() (bnc#1012628).
- net: ip6_gre: always reports o_key to userspace (bnc#1012628).
- sctp: improve the events for sctp stream adding (bnc#1012628).
- net/mlx5e: Allow MAC invalidation while spoofchk is ON
(bnc#1012628).
- ip6mr: Fix notifiers call on mroute_clean_tables()
(bnc#1012628).
- Revert "net/mlx5e: E-Switch, Initialize eswitch only if eswitch
manager" (bnc#1012628).
- sctp: set chunk transport correctly when it's a new asoc
(bnc#1012628).
- sctp: set flow sport from saddr only when it's 0 (bnc#1012628).
- net: tls: Fix deadlock in free_resources tx (bnc#1012628).
- net: tls: Save iv in tls_rec for async crypto requests
(bnc#1012628).
- virtio_net: Don't enable NAPI when interface is down
(bnc#1012628).
- virtio_net: Don't call free_old_xmit_skbs for xdp_frames
(bnc#1012628).
- virtio_net: Fix not restoring real_num_rx_queues (bnc#1012628).
- virtio_net: Fix out of bounds access of sq (bnc#1012628).
- virtio_net: Don't process redirected XDP frames when XDP is
disabled (bnc#1012628).
- virtio_net: Use xdp_return_frame to free xdp_frames on
destroying vqs (bnc#1012628).
- virtio_net: Differentiate sk_buff and xdp_frame on freeing
(bnc#1012628).
- ipv6: Consider sk_bound_dev_if when binding a socket to an
address (bnc#1012628).
- CIFS: Do not count -ENODATA as failure for query directory
(bnc#1012628).
- CIFS: Fix possible oops and memory leaks in async IO
(bnc#1012628).
- CIFS: Fix trace command logging for SMB2 reads and writes
(bnc#1012628).
- CIFS: fix use-after-free of the lease keys (bnc#1012628).
- CIFS: Do not consider -ENODATA as stat failure for reads
(bnc#1012628).
- fs/dcache: Fix incorrect nr_dentry_unused accounting in
shrink_dcache_sb() (bnc#1012628).
- iommu/vt-d: Fix memory leak in intel_iommu_put_resv_regions()
(bnc#1012628).
- selftests/seccomp: Enhance per-arch ptrace syscall skip tests
(bnc#1012628).
- NFS: Fix up return value on fatal errors in
nfs_page_async_flush() (bnc#1012628).
- ARM: cns3xxx: Fix writing to wrong PCI config registers after
alignment (bnc#1012628).
- arm64: kaslr: ensure randomized quantities are clean also when
kaslr is off (bnc#1012628).
- arm64: Do not issue IPIs for user executable ptes (bnc#1012628).
- arm64: hyp-stub: Forbid kprobing of the hyp-stub (bnc#1012628).
- arm64: hibernate: Clean the __hyp_text to PoC after resume
(bnc#1012628).
- gpio: altera-a10sr: Set proper output level for direction_output
(bnc#1012628).
- gpiolib: fix line event timestamps for nested irqs
(bnc#1012628).
- gpio: pcf857x: Fix interrupts on multiple instances
(bnc#1012628).
- gpio: sprd: Fix the incorrect data register (bnc#1012628).
- gpio: sprd: Fix incorrect irq type setting for the async EIC
(bnc#1012628).
- gfs2: Revert "Fix loop in gfs2_rbm_find" (bnc#1012628).
- mmc: bcm2835: Fix DMA channel leak on probe error (bnc#1012628).
- mmc: mediatek: fix incorrect register setting of
hs400_cmd_int_delay (bnc#1012628).
- ALSA: usb-audio: Add Opus #3 to quirks for native DSD support
(bnc#1012628).
- ALSA: hda/realtek - Fixed hp_pin no value (bnc#1012628).
- ALSA: pcm: Fix tight loop of OSS capture stream (bnc#1012628).
- IB/uverbs: Fix OOPs upon device disassociation (bnc#1012628).
- IB/uverbs: Fix OOPs in uverbs_user_mmap_disassociate
(bnc#1012628).
- IB/hfi1: Remove overly conservative VM_EXEC flag check
(bnc#1012628).
- IB/hfi1: Add limit test for RC/UC send via loopback
(bnc#1012628).
- platform/x86: asus-nb-wmi: Map 0x35 to KEY_SCREENLOCK
(bnc#1012628).
- platform/x86: asus-nb-wmi: Drop mapping of 0x33 and 0x34 scan
codes (bnc#1012628).
- Btrfs: fix deadlock when allocating tree block during leaf/node
split (bnc#1012628).
- btrfs: On error always free subvol_name in btrfs_mount
(bnc#1012628).
- kernel/exit.c: release ptraced tasks before zap_pid_ns_processes
(bnc#1012628).
- mm/hugetlb.c: teach follow_hugetlb_page() to handle FOLL_NOWAIT
(bnc#1012628).
- oom, oom_reaper: do not enqueue same task twice (bnc#1012628).
- mm,memory_hotplug: fix scan_movable_pages() for gigantic
hugepages (bnc#1012628).
- mm, oom: fix use-after-free in oom_kill_process (bnc#1012628).
- mm: hwpoison: use do_send_sig_info() instead of force_sig()
(bnc#1012628).
- mm: migrate: don't rely on __PageMovable() of newpage after
unlocking it (bnc#1012628).
- of: overlay: add tests to validate kfrees from overlay removal
(bnc#1012628).
- of: overlay: add missing of_node_get() in __of_attach_node_sysfs
(bnc#1012628).
- of: overlay: use prop add changeset entry for property in new
nodes (bnc#1012628).
- of: overlay: do not duplicate properties from overlay for new
nodes (bnc#1012628).
- md/raid5: fix 'out of memory' during raid cache recovery
(bnc#1012628).
- cifs: Always resolve hostname before reconnecting (bnc#1012628).
- Refresh
patches.suse/btrfs-8447-serialize-subvolume-mounts-with-potentially-mi.patch.
- commit 730812f

==== kfilemetadata5 ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kfilemetadata5-lang

- Add fix-build-with-cmake-3.5.patch to fix build with cmake 3.5.2
on Leap 42.3
- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* harmonize testing data
* exiv2extractor: add support for bmp, gif, webp, tga
* Fix failing test of exiv gps data
* Test empty and zero gps data
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Use more https in links
* add support for more mimetypes to taglibwriter

==== kgamma5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kgamma5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Use directly KDEFrameworkCompilerSettings

==== kglobalaccel ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kguiaddons ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== khelpcenter5 ====
Version update (18.12.1 -> 18.12.2)
Subpackages: khelpcenter5-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kholidays ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* holidays/plan2/holiday_ua_uk - updated for 2019

==== khotkeys5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: khotkeys5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Remove Qt include prefix
* Fix some minor EBN issues
* Use nullptr
* not necessary to remove theses flags
* Use more flags
* Remove old kdebug feature
* Add version as for other module

==== khtml ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Fix ui.rc files to use non-deprecated <gui> root
* Add JSON metadata to khtmlpart plugin binary
* Use more https in links
* Avoid warnings for "this use of "defined" may not be portable"
* Use more nullptr
* Port away from deprecated KFilterDev::device()
* Port away from deprecated KWindowSystem::windowInfo()
* Port to non-deprecated variant of KRun::runUrl
* Remove defunct call of K_EXPORT_PLUGIN
* Port away from deprecated kservice_desktop_to_json
* Port away from deprecated KTextEdit::setClickMessage
* Port away from deprecated KLineEdit::isClearButtonShown/setClearButtonShown
* Port deprecated QStyleOptionFrameV3 -> QStyleOptionFrame

==== ki18n ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* delete copy constructor and assignment operator of some internal classes

==== kiconthemes ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Build without D-Bus on Android
* KIconEffect: Delete copy constructor and assignment operator
* KIconTheme: Delete copy constructor and assignment operator
* delete copy constructor and assignment operator of some internal classes
* Use QStringLiteral

==== kidentitymanagement ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Fix show error as utf8

==== kidletime ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix clazy warning
* delete copy constructor and assignment operator of some internal classes

==== kimageformats ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kimageformats-eps

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Too many changes to list here
- Dropped patches, now upstream:
* 0001-Fix-various-OOB-reads-and-writes-in-kimg_tga-and-kim.patch

==== kimap ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kimap-lang libKF5IMAP5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kinfocenter5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kinfocenter5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* Fix USB view (kde#402949)
* Consti'fy
* remove some clazy warning
* Update logic for disabling the PCI module.
* Copy to Clipboard in English
* We depend against kf5 5.50
* Fix mem leak found by asan
* Copy to clipboard: match item order of copied text with GUI (kde#400732)

==== kinit ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kinit-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* KLauncher: handle processes exiting without error (kde#389678)
* delete copy constructor and assignment operator of some internal classes

==== kio ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kio-core kio-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Improve keyboard controls of the checksum widget
* Add helper function to disable redirections (useful for kde-open)
* Correct tag
* Revert "Refactor SlaveInterface::calcSpeed" (kde#402665)
* Revert "Fix elapsed time check"
* NetRC: Delete copy constructor and assignment operator
* KPasswdServerClient: Delete copy constructor and assignment operator
* KSSLSettings: Delete copy constructor and assignment operator
* delete copy constructor and assignment operator of some internal classes
* Fix elapsed time check
* Don't set CMake policy CMP0028 to old. We don't have targets with :: unless
they are imported...
* [kio] Add ellipsis to search label in Cookies section
* [KNewFileMenu] Don't emit fileCreated when creating a directory
* Use (and suggest using) the nicer K_PLUGIN_CLASS_WITH_JSON
* avoid blocking kio_http_cache_cleaner and ensure exit with session
(kde#367575)
* Fix failing knewfilemenu test and underlying reason for its failure
- Dropped patches, now upstream:
* 0002-Revert-Refactor-SlaveInterface-calcSpeed.patch

==== kio-extras5 ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kio_audiocd ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kio_audiocd-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kirigami2 ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* raise only colored buttons (kde#403807)
* fix height
* same margins sizing policy as the other list items
* === operators
* support for the concept of expandible items
* don't clear when replacing all the pages
* horizontal padding is double than vertical
* take padding into account to compute size hints
* [kirigami] Do not use light font styles for headings (2/3)
* Unbreak the AboutPage layout on smaller devices
* stopatBounds for breadcrumb flickable

==== kitemmodels ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kitemviews ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* [kitemviews] Change the search in Desktop Behavior/Activities to more in
line with other search labels
* delete copy constructor and assignment operator of some internal classes

==== kitinerary ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kjobwidgets ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kjs ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Use even more nullptr
* Set SKIP_AUTOMOC for some generated files, to deal with CMP0071
* Use more nullptr

==== kjsembed ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kldap ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kldap-lang libKF5Ldap5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kleopatra ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kleopatra-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Remove double margin
* Remove double margin

==== kmag ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kmag-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kmail ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Fix Bug 403313 - Encoding problem on kmail2 5.10.1 when creating composer
from command line (kde#403313)

==== kmail-account-wizard ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kmail-account-wizard-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kmailtransport ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kmbox ====
Version update (18.12.1 -> 18.12.2)

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kmenuedit5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kmenuedit5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* Use debug categories
* Remove KShortcut
* Ignore files
* Fix warning + use nullptr + override + make it compiles with strict
* Add override + nullptr
* Add parent
* initialize QApplication first
* Remove Qt include prefix

==== kmime ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kmime-lang libKF5Mime5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Allow to detect attachment when mail use alternative
* Add more autotest

==== kmousetool ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kmousetool-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== knewstuff ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Delete copy constructor and assignment operator
* delete copy constructor and assignment operator of some internal classes
* Fix semantics for ghns_exclude (kde#402888)

==== knotes ====
Version update (18.12.1 -> 18.12.2)
Subpackages: knotes-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== knotifications ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix memory leak when passing icon data to Java
* Remove the AndroidX support library dependency
* Add Android notification channel support
* Make notifications work on Android with API level < 23
* Move the Android API level checks to runtime
* Remove unused forward declaration
* Rebuild AAR when Java sources change
* Build the Java side with Gradle, as AAR instead of JAR
* Don't rely on the Plasma workspace integration on Android
* Search for notfication event configuration in qrc resources

==== knotifyconfig ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* delete copy constructor and assignment operator of some internal classes

==== kompare ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kompare-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== konsole ====
Version update (18.12.1 -> 18.12.2)
Subpackages: konsole-part konsole-part-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Revert "Fix crash in extendSelection" (kde#403117)

==== kontact ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kontact-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kontactinterface ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kopete ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kopete-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== korganizer ====
Version update (18.12.1 -> 18.12.2)
Subpackages: korganizer-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kpackage ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kpackage-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Remove unused found member
* Make translations work

==== kparts ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Remove explicit include of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH

==== kpeople5 ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kpeople5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* delete copy constructor and assignment operator of some internal classes

==== kpimtextedit ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kpkpass ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKPimPkPass5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kplotting ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kpty ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* KPty: Delete copy constructor and assignment operator
* Fix struct/class mismatch

==== kross ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kross-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kruler ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kruler-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== krunner ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH

==== kscreen5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kscreen5-lang kscreen5-plasmoid

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Don't lose the widget layout after Default is pressed
* Use the nicer K_PLUGIN_CLASS_WITH_JSON
* Show unconnected displays at the right side of the main screen
* Rename config loading function
* [kded] Cleanup KScreenDaemon class
* [kded] Replace configReady functon with lambda
* Make use of libkscreen hash API
* Follow the preferred mode if we're asked to (i.e. if under QXL)
* Fix warning
* Show the preferred resolution on the combo box
* Don't apply configs in a loop
* Use KDEFrameworkCompilerSettings

==== kscreenlocker ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* [KCM] Use a better icon
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* [Greeter] Ignore unwritable configuration files (kde#403255)
* Fix fallback to built-in ui
* Disable kcrash in greeter in same way as in KWin
* Use override instead of Q_DECL_OVERRIDE
* Remove Qt include prefix
* Use KDEFrameworkCompilerSettings

==== kservice ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kservice-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Build without D-Bus on Android
* delete copy constructor and assignment operator of some internal classes
* Suggest people to use K_PLUGIN_CLASS_WITH_JSON

==== ksmtp ====
Version update (18.12.1 -> 18.12.2)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== ksshaskpass5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: ksshaskpass5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* USe KDEFrameworkCompilerSettings

==== ksysguard5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: ksysguard5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Fix some clazy warning
* Add missing explicit
* Remove unused code
* USe override. Add missing explicit
* Use int (remove warning)
* Fix minor typos
* port to QStringLiteral
* fix indentation
* Provide option to hide menu bar for Ksysguard

==== ktexteditor ====
Version update (5.54.0 -> 5.55.0)
Subpackages: ktexteditor-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* skip cppstyle indentation test for !t 5.12.0 which has a broken regex
implementation in JS
* KateSpellCheckDialog: Remove action "Spellcheck Selection"
* Update JavaScript library underscore.js to version 1.9.1
* Fix bug 403422: Allow changing the marker size again (kde#403422)
* Consistently use override, not Q_DECL_OVERRIDE
* SearchBar: Add Cancel button to stop long running tasks
* Remove explicit use of ECM_KDE_MODULE_DIR, is part of ECM_MODULE_PATH
* Review KateGotoBar
* ViewInternal: Fix 'Go to matching bracket' in override mode
* Delete copy constructor and assignment operator from public vim/ classes
* delete copy constructor and assignment operator of some internal classes
* Use HTTPS, if available, in links visible to users
* Review KateStatusBar
* ViewConfig: Add option to paste at cursor position by mouse (kde#363492)
* Use the nicer K_PLUGIN_CLASS_WITH_JSON
* Remove Qt version check

==== ktextwidgets ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== ktnef ====
Version update (18.12.1 -> 18.12.2)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kunitconversion ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== kwallet ====
Version update (5.54.0 -> 5.55.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* delete copy constructor and assignment operator of some internal classes

==== kwalletmanager5 ====
Version update (18.12.1 -> 18.12.2)
Subpackages: kwalletmanager5-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== kwayland ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* [server] Generate correct touch ids
* [autotests] Stabilize testWindowmanagement
* Make XdgTest spec compliant
* Add option to use wl_display_add_socket_auto
* [server] Send initial org_kde_plasma_virtual_desktop_management.rows
* Add rows info to the plasma virtual desktop protocol
* [client] Wrap wl_shell_surface_set_{class,title}
* Guard resource deletion in OuptutConfiguration::sendApplied

==== kwayland-integration ====
Version update (5.14.5 -> 5.15.0)

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Remove qt include prefix
* Add DEFAULT_SEVERITY keyword
* Use KDEFrameworkCompilerSettings

==== kwidgetsaddons ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix zero as nullptr constant warning
* [KWidgetsAddons] Do not use light font styles for headings (3/3)
* KRatingPainter: Delete copy constructor and assignment operator
* delete copy constructor and assignment operator of some internal classes
* Remove Qt version check

==== kwin5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: kwin5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* [effects/screenedge] Use correct blend function (kde#403570)
* Fix --no-global-shortcuts option
* [effects/startupfeedback] Fix shader
* Save the correct value of noborder property (kde#403948)
* [kcmkwin/compositing] Fix effect video previews
* [wayland] Send VirtualDesktop::done after editing a property
* Keep _NET_DESKTOP_NAMES in sync
* Fix flickering with Qt 5.12
* Fix "context objects" in VirtualDesktopManager::setVirtualDesktopManagement
* Set desktop name "atomically" when using the plasma virtual desktop protocol
* Generate desktop ids without curly braces
* Make sure that new virtual desktops can be activated by using plasma
virtual desktop protocol
* Fix VirtualDesktopManager::createVirtualDesktop (kde#403312)
* Delete names of removed desktops from kwinrc
* [scenes/opengl] Destroy the lanczos filter when the backend is still alive
(kde#403370)
* [build] Search for kirigami as a runtime dependency
* Compile the virtual backend with older Mesa (kde#403326)
* Fix DesktopGrid drag on X11
- Remove patches, now upstream:
* 0001-Fix-flickering-with-Qt-5.12.patch
* 0001-Compile-the-virtual-backend-with-older-Mesa.patch

==== kwindowsystem ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* autotests: fix it, since nobody else did, grmbl

==== kxmlgui ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Build without D-Bus on Android
* delete copy constructor and assignment operator of some internal classes
* Make KCheckAccelerators less invasive for apps that don't directly link to
KXmlGui

==== kxmlrpcclient5 ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== libKF5ModemManagerQt ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix QVariantMapList operator >> implementation

==== libKF5NetworkManagerQt ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== libgravatar ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkcddb ====
Version update (18.12.1 -> 18.12.2)

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkcompactdisc ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkdcraw ====
Version update (18.12.1 -> 18.12.2)

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkdecoration2 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: libkdecorations2-5 libkdecorations2-5-lang libkdecorations2private6

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle

==== libkdepim ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Add an option to skip the AkonadiSearchPIM dependency, to simplify Windows
build

==== libkexiv2 ====
Version update (18.12.1 -> 18.12.2)

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkgapi ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkipi ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkleo ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkomparediff2 ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libksane ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5Sane5 libksane-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libkscreen2 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* Guard failing to load backend (kde#403568)
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Consti'fy
* Fix some clazy warning
* USe KF5_MIN_VERSION
* Notify also if modes have changed
* Define ownership of edid in output and do not leak it
* Add output and connected outputs config API
* Move categories here
* Rename kscreen.categories to libkscreen.categories
* Autogenerate debug categories + create categories file
* Avoid creation of needless temporary containers
* Remove unused QPointer includes
* Don't leak Edid
* Fix qstring-insensitive-allocation clazy warning
* Remove unused member variable
* Support QXL hotplug_mode_update
* Use KDEFrameworkCompilerSettings

==== libksieve ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libksieve-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== libksysguard5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: libksysguard5-helper libksysguard5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Fix potential mem leak (found by asan)
* Use new syntax
* Fix minor typos
* Add ifdef for webengine (kde#399637)
* Port scripting to Qt WebEngine
- Remove patches, now upstream:
* 0001-Port-scripting-to-Qt-WebEngine.patch

==== libostree ====
Version update (2018.9 -> 2019.1)
Subpackages: libostree-1-1

- Update to version 2019.1:
+ This is the first libostree release of 2019; no big changes,
just a collection of smaller features and bugfixes.
+ On the features side, a good example is:
lib/repo: Search a list of paths in gpgkeypath for gpg keys.
+ Another feature is grub2: add support for devicetree.
+ lib/kargs: allow empty-list arguments i.e it ensures libostree
supports "empty list" kernel arguments.
+ There's also some ongoing work to have libostree be a "backend"
for OCI/Docker container storage; checkout: honor opaque
checkouts.
+ If built with --disable-http2, allow enabling via http2=1 will
allow people to more easily play with HTTP2 if it's disabled by
default.

==== libqt5-qtbase ====
Subpackages: libQt5Concurrent5 libQt5Core5 libQt5DBus5 libQt5Gui5
libQt5Network5 libQt5OpenGL5 libQt5PrintSupport5 libQt5Sql5 libQt5Sql5-mysql
libQt5Sql5-sqlite libQt5Test5 libQt5Widgets5 libQt5Xml5
libqt5-qtbase-platformtheme-gtk3

- Add 0001-Fix-compile-issue-with-gcc-9.patch to fix building with
the latest libstdc++ (boo#1121561)
- Remove workaround patch as fixed in KWin meanwhile:
* 0001-Revert-xcb-Initialize-OpenGL-integration-only-when-r.patch
- Add 0001-Revert-xcb-Initialize-OpenGL-integration-only-when-r.patch:
* Revert upstream commit 60cecc86f8 to work around display
flickering issues with some display drivers
(https://bugreports.qt.io/browse/QTBUG-73122, boo#1120090)

==== libqt5-qtspeech ====

- Split speechd plugin into subpackage to not pull in libspeechd forcibly
- Use System/Libraries as group for libQt5TextToSpeech5
- Use %license
- Use %requires_eq due to private API use

==== libvirt ====
Subpackages: libvirt-bash-completion libvirt-client libvirt-daemon
libvirt-daemon-driver-interface libvirt-daemon-driver-libxl
libvirt-daemon-driver-lxc libvirt-daemon-driver-network
libvirt-daemon-driver-nodedev libvirt-daemon-driver-nwfilter
libvirt-daemon-driver-qemu libvirt-daemon-driver-secret
libvirt-daemon-driver-storage libvirt-daemon-driver-storage-core
libvirt-daemon-driver-storage-disk libvirt-daemon-driver-storage-gluster
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- qemu: fix issues related to restricted permissions on /dev/sev
b6440119-qemu-conf-sev.patch, a404ac34-qemu-cgroup-sev.patch,
6fd4c8f8-qemu-domain-sev.patch, 17f6a257-security-dac-sev.patch,
a2d3dea9-qemu-caps-dac-override-sev.patch
bsc#1124842

==== libwacom ====
Version update (0.30 -> 0.32)
Subpackages: libwacom-data libwacom2

- Run through spec-cleaner
- Update to 0.32
Support for the following devices has been added:
* Lenovo Yoga 730, X380, 300e
* Dell XPS 15 9575
* HP Spectre x360
* Toshiba Portege X20W-D
* DTU-1141B
* Graphire4 6x8
* ISDv4 50fd, 4807
Other change:
* tools: provide a man page for libwacom-list-local-devices

==== libxkbcommon ====
Version update (0.8.2 -> 0.8.3)
Subpackages: libxkbcommon-x11-0 libxkbcommon0

- Update to new upstream release 0.8.3
* New APIs: XKB_KEY_XF86MonBrightnessCycle,
XKB_KEY_XF86RotationLockToggle.

==== mailcommon ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Fix bug found by David.

==== mailimporter ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== mariadb-connector-c ====
Version update (3.0.6 -> 3.0.8)

- New upstream version 3.0.8
* mingw fix: use lowercase names for include files
* CONC-375: Fixed handshake errors when mixing TLSv1.3 cipher
suites with cipher suites from other TLS protocols
* CONC-312: Added new caching_sha2_password authentication plugin
for authentication with MySQL 8.0
- refresh mariadb-connector-c-2.3.1_unresolved_symbols.patch
- pack caching_sha2_password.so plugin
- New upstream version 3.0.7 [bsc#1116686]
* Build fixes when building with ASAN/TSAN
* CONC-370: Fixed memory leak in configuration file parsing.
* CONC-371: Incorrect fractional part conversion when converting
datetime string to MYSQL_TIME
* CONC-283: Fixed pkg-config configuration
* CONC-364: Not all sockets created in pvio_socket_connect
function are closed
* multiple fixes in named pipe implementation
* CONC-349: Added new parameter STMT_ATTR_STATE to retrieve
statement status via api function mysql_stmt_attr_get
- refresh private_library.patch and absolute_path_fix.patch
- pack libmariadb.pc

==== messagelib ====
Version update (18.12.1 -> 18.12.2)
Subpackages: messagelib-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Fix Bug 403460 - Expand BCC list of emails button is oriented in
non-intuitive direction (kde#403460)
* Disable code for the moment
* Don't show "Attachment:" when there is a mail embedded
* Avoid to wrap word
* It was fixed in kmime
* Fix show attachment as reported by David.

==== milou5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: milou5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* [Plasmoid] Clean up layout
* Use KDEFrameworkCompilerSettings

==== mobipocket ====
Version update (18.12.1 -> 18.12.2)

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo
terminfo-base terminfo-screen

- Fix configure scripts as well as pkg-config configurations
that is correct paths in pkg-config and use pkg-config to
configure the configure scripts as well
- Add ncurses patch 20190209
+ add check in tic to provide warnings for mismatched number of
parameters in the documented user-capability extensions.
- Add ncurses patch 20190202
+ modify rpm test-package ".spec" file to work around naming conflict
with Redhat's package for ncurses6.
+ modify no-leaks code in test/picsmap to avoid non-standard tdestroy.
+ amend change to configure script which altered the top-level makefile
to avoid attempting to install the terminfo database when it was not
configured, to allow for installing the ".pc" files which are also
in the misc directory (report by Steve Wills).
- Add ncurses patch 20190126
+ change some "%define" statements in test-packages for RPMs to
"%global" to work around changes in rpm 4.14 from recent Redhat.
+ fixes for O_INPUT_FIELD extension (patch by Leon Winter).
+ eliminate fixed buffer-size when reading $TERMCAP variable.
+ correct logic in read_entry.c which prevented $TERMCAP variable from
being interpreted as a fallback to terminfo entry (prompted by
Savannah #54556, cf: 20110924).
- Add ncurses patch 20190121
+ add a check in test/configure to work around non-ncurses termcap.h
file in Slackware.
+ corrected flag for "seq" method of db 1.8.5 interface, needed by toe
on some of the BSDs.
+ updated "string-hacks" feature.
+ minor improvements to manpage typography.
+ corrected conditionally-compiled limit on color pairs (report by
"Hudd").
+ add -x option to test/pair_content, test/color_content for testing
init_extended_pair, extended_pair_content, init_extended_color,
extended_color_content
+ add -p option to test/pair_content, test/color_content to show the
return values from the tested functions.
+ improve manual page curs_color.3x discussion of error returns and
extensions.
+ add O_INPUT_FIELD extension to form library (patch by Leon Winter).
+ override/suppress --enable-db-install if --disable-database configure
option was given.
+ change a too-large terminal entry in tic from a fatal error to a
warning (prompted by discussion with Gabriele Balducci).

==== okular ====
Version update (18.12.1 -> 18.12.2)
Subpackages: okular-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* Fix MimeType in org.kde.mobile.okular_comicbook.desktop
- Do without em dashes in summaries.
- Split Postscript display functionality in a separate subpackage
(bsc#1117336, boo#1122797)
- List files for plugins, generators, and appstream metadata
in spec explicitly instead of wildcards

==== open-vm-tools ====
Subpackages: libvmtools0 open-vm-tools-desktop

- Link VGAuthService to libxmlsec1 rather than libxml-security-c in SLE
products where available. (bsc#1122435)
- Add patches to correct and/or improve handling of certain quiesced snapshot
failures (bsc#1124397).
+ no_manifest_on_aborted_snapshot.patch
Don't send a backup manifest when aborting a Linux quiesced snapshot.
+ vmtoolsd_bailout_on_rpc_errors.patch
Bail out vmtoolsd early when there are RPC errors.
+ send_vmbackup_event_generic_manifest.patch
Always send VMBACKUP_EVENT_GENERIC_MANIFEST during quiesced snapshots.
+ include_log_h_for_g_info.patch
Include vmware/tools/log.h to define g_info.
- Update vmtoolsd.service to support cloud-init customization by default
by adding "DefaultDependencies=no" and "Before=cloud-init-local.service"
to the [Unit] section of vmtoolsd.service (bsc#1121964) .
- Copyright year updated in spec file.

==== openpgm ====

- Backport patches from upstream to avoid adding a non-existing
foo/lib/pgm-5.2/include directory to pkg-config's CFLAGS which
breaks applications using strict compiler flags, and to make the
build reproducible regardless of the reported system/architecture
Added:
- libpgm-5.2.122-pkg-config-do-not-add-I-to-non-existing-directory.patch
- libpgm-5.2.122-reproducible-architecture.patch

==== orca ====
Version update (3.30.1 -> 3.30.2)
Subpackages: orca-lang

- Update to version 3.30.2:
+ Braille: Ensure we don't pan beyond the length of the line
being displayed.
+ Updated translations.

==== osc ====
Version update (0.164.1 -> 0.164.2)

- 0.164.2
- deleterequest for entire projects needs the --all option as additional
protection
- rewrite packagequery to support python3
- rewrite oscerr module to support python3
- rewrite archqeury and debquery to support python3
- Export vc env vars when running a source service

==== oxygen5 ====
Version update (5.14.5 -> 5.15.0)

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* enable animations for standalone created buttons
* fix typo in last commit
* Don't drag windows in empty areas from touch/pen events

==== oxygen5-icon-theme ====
Version update (5.54.0 -> 5.55.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== pcsc-lite ====
Subpackages: libpcsclite1

- Trim filler wording from description.

==== perl-DateTime-Format-Strptime ====
Version update (1.75 -> 1.76)

- updated to 1.76
see /usr/share/doc/packages/perl-DateTime-Format-Strptime/Changes
1.76 2019-02-07
[BACKWARDS INCOMPATIBILITIES]
* The ability to set the pattern, time_zone, and locale via accessor methods
has been removed. This was deprecated over three years ago in version
1.60. It also turns out that the setting was actually broken for a long time
but no one seemed to notice, so I think it's afe to remove this feature.

==== perl-SOAP-Lite ====

- Conditionally require optional build test Test::MockObject
- Added required dependencies for building and testing
- Cleaned spec file with spec-cleaner
- Fix env-script-interpreter in bin/{SOAPsh.pl,stubmaker.pl} and
examples/XMLRPC/{xmlrpc.cgi,xmlrpc.daemon}
* Added patch perl-SOAP-Lite-1.27-usr-bin-env.patch

==== perl-Task-Weaken ====

- Reduce manual sections and regenerate
- Added required dependencies for building and testing
- Cleaned with spec-cleaner

==== perl-Test-Simple ====
Version update (1.302160 -> 1.302162)

- updated to 1.302162
see /usr/share/doc/packages/perl-Test-Simple/Changes
1.302162 2019-02-05 19:55:14-08:00 America/Los_Angeles
- Typo fixes in documentation
1.302161 2019-01-29 09:34:27-08:00 America/Los_Angeles (TRIAL RELEASE)
- Remove SHM Optimization

==== perl-XML-LibXML ====
Version update (2.0133 -> 2.0134)

- updated to 2.0134
see /usr/share/doc/packages/perl-XML-LibXML/Changes
2.0134 2019-02-10
- Fix overzealous POD escaping in the docs' synposes
- https://github.com/shlomif/perl-XML-LibXML/issues/26
- Thanks to @davorg.

==== php7 ====
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pgsql php7-shmop php7-snmp
php7-sockets php7-sqlite php7-sysvsem php7-sysvshm php7-tidy php7-tokenizer
php7-wddx php7-xmlreader php7-xmlwriter php7-xsl php7-zlib

- set pcre.jit=0 until https://bugs.php.net/bug.php?id=77260
is solved [bsc#1124446]
- spec file cleanup
* add BuildRequires gpg2
* remove outdated README.SUSE-pear - Squirrelmail uses PDO instead
of DB now by default
* remove outdated php7-depdb-path.patch - Horde packages no longer
build so need to be fixed anyway
- update php7.rpmlintrc to suppress warnings that aren't fixable and
drown out other warnings
- provide the version of PEAR, rather than the PHP version in php-pear
- configure cache_dir, metadata_dir and sig_bin through PHP_PEAR_*
exports
- remove install-pear-nozlib.phar (the bundled and tested version from
the PHP sources is fresh enough for our purposes)
- merge back php7-pear-Archive_Tar in php7-pear
- rename cache_dir to pear and create it

==== pimcommon ====
Version update (18.12.1 -> 18.12.2)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== pkcs11-helper ====
Version update (1.22 -> 1.25.1)
Subpackages: libpkcs11-helper1

- Update to version 1.25.1:
* core: build with threading disabled, do not attempt to
initialize provider with fork mode is not safe. Too many
providers do not follow the PKCS#11 spec.
* openssl: rework support 1.1.

==== plasma-browser-integration ====
Version update (5.14.5 -> 5.15.0)
Subpackages: plasma-browser-integration-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* Install message handler after QApplication (kde#400906)
* Make media session property setter more resilient (kde#401636)
* Bump manifest version
* Include Breeze scrollbar CSS inline
* Also catch new Audio() elements (kde#398261)
* Connect to contextMenu clicked callback only once
* Update about KDE text
* Recreate interrupted download when it is resumed (kde#401038)
* Send all active downloads on load
* Fix removing KDE Connect device entry
* Sort keys in json encoder
* Bump manifest version
* Wait for duration to be known before registering player
* Bump manifest version
* Make it compiles with KDEFrameworkCompilerSettings

==== plasma-framework ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Use more https in links (& update a few urls)
* [Wallpaper templates] Add missing Comment= entry to desktop file
* Remove explicit use of ECM_KDE_MODULE_DIR, part of ECM_MODULE_PATH
* [Plasma Theme] Use new connect syntax
* Share Plasma::Theme instances between multiple ColorScope
* Make the clock svg's shadows more logically correct and visually appropriate
* [frameworks] Do not use light font styles for headings (1/3) (kde#402730)
* [Dialog] Don't alter mainItem's visibility
* Reset parentItem when mainItem changes
* Remove Qt version check

==== plasma-nm5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* [build] Search for kirigami as a runtime dependency
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Too many changes to list here
- Introduces wireguard support
- Refresh patches:
* 0001-Revert-Show-correct-current-download-and-upload-spee.patch
* 0001-Revert-Use-NetworkManager-DeviceStatistics-instead-o.patch

==== plasma5-addons ====
Version update (5.14.5 -> 5.15.0)
Subpackages: plasma5-addons-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* [KdePlasma-Addons/POTD/EOPD] Fixed RegEx string to accommodate both
HTTP/HTTPS protocols
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* date runner: match timezones by whether it's contained (kde#403271)
* Fix copyrights in binary clock files
* Allow dictionary runner to search multiple times
* [KdePlasma-Addons/POTD/NOAA] Fixed RegEx string of landing page
* [KdePlasma-Addons/POTD/NOAA] Fixed the web address and fetched the picture
from new address
* Use the nicer K_PLUGIN_CLASS_WITH_JSON
* [weather] Use capitalized strings for display of pressure tendency
* [comic dataengine] Do not cache identifier only requests
* [comic] Update comic strip on current identifier only
* [comic] Fix max cache limit
* [comic] Request current identifier on data change
* [comicupdater] Fix last day check
* Added "Transparent with light text" theme for Desktop Notes (kde#386833)
* Fix minor typosand EBN issues

==== plasma5-desktop ====
Version update (5.14.5 -> 5.15.0)
Subpackages: plasma5-desktop-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* [Activities KCM] Properly vertically center the buttons
* Revert "[Activities KCM] vertically center the buttons"
* [kcms/cursortheme] Correctly load m_originalPreferredSize (kde#403775)
* [kcms/mouse] Load current server settings in kcminit (kde#395401)
* [kcms/keys] Fix double margin
* [kcms/launch] Avoid infinite loop in button handling (kde#403950)
* [Look and Feel KCM] Write schemeName last (kde#403774)
* [Task Manager] Sort manually by default
* Fix new file creation leading to dupe items on a fresh view (kde#401023)
* Use https urls in doc
* Use https URLS
* Check icon positions after move (kde#402574)
* Defer initial positions apply until listing is complete (kde#354802)
* [KRDB] Also try wildcard tooltip (kde#355540)
* [KRDB] Write correct tooltip colors into gtkrc in kcminit
* [kcms/cursortheme] Fix size combo (kde#403019)
* [kcms/cursortheme] Set theme before loading size
* Don't put some KCMs in a single-item top-level category
* Set libkworkspace minimum version
* [build] Search for kirigami as a runtime dependency
* [Date & Time KCM] Fix clock display with fractional scale factor
(kde#396936)
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Too many changes to list here

==== plasma5-integration ====
Version update (5.14.5 -> 5.15.0)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* fix logic of lnf loading
* Fix Qt version check in deco support
* Disable KDE ServerDecoration on Qt > 5.12
* Install Platform theme plugin into bin/platformthemes for unit tests
* Add support for settings portal
* Remove unused check

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.15.0
- Update to 5.14.90

==== plasma5-pa ====
Version update (5.14.5 -> 5.15.0)
Subpackages: plasma5-pa-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* [build] Search for kirigami as a runtime dependency
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Use the nicer K_PLUGIN_CLASS_WITH_JSON
* Revert 604f35edd4a14d630d4583f61eb8109f21b6ed3a
* Make widget configuration translatable
* Kirigami Pages are required for kcms
* Show "muted" icon in panel and disable shortcuts for Dummy Output

==== plasma5-workspace ====
Version update (5.14.5 -> 5.15.0)
Subpackages: gmenudbusmenuproxy plasma5-session plasma5-session-wayland
plasma5-workspace-lang plasma5-workspace-libs xembedsniproxy

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* weather dataengine] noaa: another forecast string found in use
* [kio_applications] Fix last dir item being shown twice
* Revert string change on stable branch
* [image wallpaper] Show wallpaper title/filename on grid view delegates
* With software rendering, use outlines instead of shadows on login & lock
screen (kde#398317)
* Update Breeze Look and Feel theme previews
* [plasmawindowed] Pick up KQuickAddons::QtQuickSettings
* weather dataengine] noaa: support more "Slight Chance *" forecast strings
* [weather dataengine] Remove duplicated condition/forecast strings
* StatusItemNotifier: fix overlays by name with icons by name
* [weather dataengine] noaa: add another forecast string found in use
* [weather dataengine] bbc: use night icons for forecast "Tonight"
* Reload virtual desktop name on change
* Useful error output when shell loading is aborted due to kactivitymanagerd
not being activatable
* [applets/appmenu] Show placeholder when configuring and empty (kde#403232)
* [applets/appmenu] Set iconSource properly
* Handle ShutdowntypeDefault in KSMserver legacy code (kde#403466)
* [Analog Clock] Port config window to QQC2 and use Kirigami FormLayout
* [wallpapers/image] Port wallpaper plugins (mostly) to QQC2 (kde#400549)
* [build] Search for kirigami as a runtime dependency
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Too many changes to list here
- mkfontdir and xset not required anymore
- Remove patches, now upstream:
* 0001-Set-XDG_SESSION_TYPE-wayland-in-startplasmacomposito.patch

==== polkit-kde-agent-5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Use KPasswordLineEdit
* Connect slots explicitly instead of using auto-connections
* Fully remove `Application Name` from Details panel
* Improve replacement text when action description is not provided

==== postfix ====
Subpackages: postfix-doc

- rework config.postfix
* disable commenting of smtpd_sasl_path/smtpd_sasl_type
no need to comment, cause it is set to default anyway
and 'uncommenting' would place it at end of file then
which is not wanted

==== powerdevil5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: powerdevil5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* [dimdisplay] Waits a bit display to wake-up
* [dimdisplay] Do not change screen brightness on invalid values
* KCModule general page: Change conditional to what was probably intended
* Avoid creation of needless temporary containers
* Add missing emit keyword
* Add some QStringLiteral
* qt5.11 uses gcc 4.8 as minimum version

==== prison-qt5 ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix clazy warning

==== purpose ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Use the nicer K_PLUGIN_CLASS_WITH_JSON

==== python-certifi ====
Version update (2018.4.16 -> 2018.11.29)

- Update to 2018.11.29
* Deprecated old_where() has been removed
* Removed certificates
+ Visa eCommerce Root
+ Certplus Root CA G1
+ Certplus Root CA G2
+ OpenTrust Root CA G1
+ OpenTrust Root CA G2
+ OpenTrust Root CA G3

==== python-pycurl ====
Subpackages: python2-pycurl python3-pycurl

- Set LANG to en_US.UTF8 to fix the tests

==== python-qt5 ====
Version update (5.11.3 -> 5.12)
Subpackages: python-qt5-utils python3-qt5

- update to final 5.12 version
* Support for Qt 5.12
* Details at
https://www.riverbankcomputing.com/static/Downloads/PyQt5/ChangeLog
- fix-sip-detection.patch is obsolete
- update to 5.12 development snapshot

==== python-sip ====
Version update (4.19.13 -> 4.19.14)
Subpackages: python-sip-common python3-sip

- Switch to a working location for the tarball
- Update to 4.19.14:
* The reference count displayed by sip.dump() now has the same
caveat as sys.getrefcount().
* Added SIP_NULLPTR to the C API.
* Added support for size_t.
* Added sipLong_AsSizeT() to the C API.
* Added the '=' format characters to sipBuildResult() and
sipParseResult().

==== python-wxWidgets-3_0 ====
Subpackages: python-wxWidgets-3_0-lang

- Equalize the different macro styles
- Fix generation of -lang package file list
- cleanup using spec-cleaner

==== read-only-root-fs ====
Version update (1.0+git20180606.046b099 -> 1.0+git20190206.586e9f1)

- Update description to reflect new behaviour
- Fix creation of overlay directories
- Fix file list
- Update to version 1.0+git20190206.586e9f1:
* Remove migration code, only handle the initial setup here
* Drop use of fstab.sys
* Use a dracut config file instead of a module

==== rpm ====
Subpackages: rpm-build rpm-devel

- backport getncpus macro and related changes from upstream
* make make_build macro use verbose output
* add _smp_build_ncpus macro
* add _lto_cflags macro
* new patch: getncpus.diff

==== rubygem-addressable ====
Version update (2.5.2 -> 2.6.0)

- updated to version 2.6.0
* added `tld=` method to allow assignment to the public suffix
* most `heuristic_parse` patterns are now case-insensitive
* `heuristic_parse` handles more `file://` URI variations
* fixes bug in `heuristic_parse` when uri starts with digit
* fixes bug in `request_uri=` with query strings
* fixes template issues with `nil` and `?` operator
* `frozen_string_literal` pragmas added
* minor performance improvements in regexps
* fixes to eliminate warnings

==== schily ====
Subpackages: cdda2wav cdrecord libcdrdeflt1_0 libdeflt1_0 libedc_ecc1_0
libedc_ecc_dec1_0 libfile1_0 libfind3_0 libparanoia1_0 librmt1_0 librscg1_0
libscg1_0 libscgcmd1_0 libschily2_0 mkisofs readcd spax star

- Update to new upstream release 2019.01.22
* star: fixes for a hang and pipe reading issues
* star: The debug printing for the FIFO has been enhanced to
print more information from the FIFO control structure to
debug problems like the ones mentioned above.
* star now ignores SIGPIPE.
- Update to new upstream release 2018.12.06
* sccs-prs now prints the SCCS v6 initial path using the new
keyword :Gp:.
* sccs-prs now prints the SCCS v6 unified random using the new
keyword :Gr:.
* sccs: libcomobj: A parser for the SCCS v6 flags has been added.
* sccs: libcomobj: A parser for SCCS v6 global meta data has
been added.
- Package sccs.

==== shotwell ====
Version update (0.30.1 -> 0.30.2)
Subpackages: shotwell-lang

- Update to version 0.30.2:
+ Fix maximize on Wayland when double-clicking on title-bar.
+ Do not hide the cursor when showing the slideshow settings
dialog.
+ Fix compatibility with recent vala compilers.
+ Fix crash when dismissing file modifications on close.
+ Fix issues with google and flickr not being able to log in.
+ Replace picasaweb publishing with Google Photos publishing.
+ Comply with Flick API TOS.
+ Updated translations.
- Drop upstream fixed patches:
+ shotwell-Fix_double-click_maximize.patch.
+ shotwell-slideshow_Suspend_hiding_cursor.patch.
+ shotwell-vala-fixes.patch.
+ shotwell-Fix_crash_when_dismissing_modifications.patch.
+ shotwell-authenticator_Fix_google_and_flickr_auth.patch.
- Update calls passed to meson to align with upstreams changes.

==== solid ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Build without D-Bus on Android
* delete copy constructor and assignment operator of some internal classes

==== sonatype-oss-parent ====

- Clean-up the pom file installation to correspond to the standard
xmvn directories

==== sonnet ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Ignore files
* Avoid using trimmed method
* Don't call this code if we have only space
* GuessLanguage: Delete copy constructor and assignment operator
* delete copy constructor and assignment operator of some internal classes

==== spectacle ====
Version update (18.12.1 -> 18.12.2)
Subpackages: spectacle-lang

- Update to 18.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.12.2.php
- Changes since 18.12.1:
* No code changes since 18.12.1

==== spice ====

- Fix OOB memory access in internal tracking of slot_ids and
group_ids. (CVE-2019-3813 bsc#1122706)
* 0001-memslot-Fix-off-by-one-error-in-group-slot-boundary-.patch
- Remove celt051 Requires directive

==== syndication ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* No code changes since 5.54.0

==== syntax-highlighting ====
Version update (5.54.0 -> 5.55.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* Fix end of folding region in rules with lookAhead=true
* AsciiDoc: Fix highlighting of include directive
* Add AsciiDoc support
* Fixed Bug Which Caused Infinite Loop While Highlighting Kconfig Files
* check for endless context switches
* Ruby: fix RegExp after ": " and fix/improve detection of HEREDOC
(kde#361875, kde#358273)
* delete copy constructor and assignment operator of some internal classes
* Haskell: Make = a special symbol

==== systemsettings5 ====
Version update (5.14.5 -> 5.15.0)
Subpackages: systemsettings5-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- Changes since 5.14.90:
* Use same intro page system settings icon as in the desktop file
* Use correct sidebar back button press color
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Changes since 5.14.5:
* bump KF5 dependency to required 5.54 as agreed at start of Plasma 5.15 cycle
* Consti'fy
* Use app specific config after QApplication constructor
* remove some clazy warning
* Show tooltips for subcategories
* Remove the background gradient from icon view (kde#342938)
* Port away from deprecated setClearButtonShown() and setupBindings()
* Fix minor typos and EBN issues
* Fix crash on ExternalApp modules
* support for multilevel kcms
* Use KDEFrameworkCompilerSettings

==== tagsoup ====

- Not only install the pom, but also generate maven metadata so
so that the artifact can be used

==== threadweaver ====
Version update (5.54.0 -> 5.55.0)

- Update to 5.55.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.55.0.php
- Changes since 5.54.0:
* delete copy constructor and assignment operator of some internal classes

==== tiff ====
Subpackages: libtiff5 libtiff5-32bit

- security update
* CVE-2019-7663 [bsc#1125113]
+ tiff-CVE-2019-7663.patch
- security update
* CVE-2019-6128 [bsc#1121626]
+ tiff-CVE-2019-6128.patch
- extend tiff-CVE-2018-19210.patch and rename it to
tiff-CVE-2018-17000,19210.patch [bsc#1108606c#11]
* solves CVE-2018-19210 [bsc#1115717] and CVE-2018-17000 [bsc#1108606]
- amend tiff-CVE-2018-12900.patch: fix wrong error message
[bsc#1099257]

==== transactional-update ====
Version update (2.12 -> 2.13)
Subpackages: transactional-update-zypp-config

- Update to version 2.13
- Fix a serious data loss problem (deleting all files in /etc
overlays) in case /var/lib/overlay/etc is not part of any
snapshot any more.
- Avoid error message in case a system has no /etc/fstab.sys

==== virt-manager ====
Version update (2.0.0 -> 2.1.0)
Subpackages: virt-install virt-manager-common

- Upstream bug fixes (bsc#1027942)
f7508d02-addhardware-Fix-setting-optimal-default-net-model.patch
1018ab44-inspection-handle-failures-in-application-listing.patch
ae8a4f3d-engine-Fix-first-run-startup-error.patch
- Update to virt-manager 2.1.0 (fate#326786)
virt-manager-2.1.0.tar.bz2
virtman-fix-env-script-interpreter.patch
* Bash autocompletion support (Lin Ma, Cole Robinson)
* UI and command line ?vsock support (Slavomir Kaslev)
* virt-xml: Add ?os-variant option (Andrea Bolognani)
* virt-install: use libosinfo cpu, mem, disk size defaults (Fabiano Fidencio)
* virt-install: Better usage of libosinfo -unknown distro IDs (Fabiano
Fidencio)
* virt-install: More usage of libosinfo for ISO ?location detection
* virt-install: Add ?location LOCATION,kernel=X,initrd=Y for pointing to
kernel/initrd in media that virt-install/libosinfo fails to detect
- Drop
25b88733-urldetect-Dont-overload-suse_content-variable.patch
9308bae3-util-Fix-typo-vpcu-vcpu.patch
b8aff280-virtinst-quickfix-ubuntu-net-preseed-insert-cdrom-error.patch
c30b3bc6-increase-timeout-for-vm-to-start.patch
virtinst-use-latest-opensuse-version-when-unknown-media.patch

==== virt-sandbox ====
Version update (0.6.0 -> 0.8.0)
Subpackages: libvirt-sandbox-1_0-5

- Updated to version 0.8.0:
* Deleted the virt-sandbox-service tool as it is a failed
experiment
* Require libvirt-glib >= 0.2.2
* Add af_packet kmod nedeed by dhcp clients
* Add ext4 kmod needed by common filesystems
* Add fscrypto kmod needed as a dep of other mods
* Show dhcp client output in debug mode
* Add /dev/fd symlink for /proc/self/fd
* Sync and cleanly unmount filesystems during shutdown
* Fix handling of strace debug option
* Avoid exiting too early on shutdown so we see all debug
* messages and cleanly sync/unmount
* Allow setting custom env variables
* Ensure static versions of zlib and lzma are checked for
* Guest host image format from file extension if not given
* Allow switching to a specific user ID
* Improve docs on command line arg passing
* Fix bogus lib listed in pkgconfig file
* Fix misc goject introspection annotations
* Improve error message for unsupported libvirt URIs
* Search in $PATH for user specified binary
* Use squash security mode for non-root QEMU sandbox mounts
* Search for libtirpc standalone XDR library
* Avoid triggering some new compiler warnings
- Removed now useless patches:
* 15396686-avoid-setting-XDR_LIBS-to-none-required.patch
* 35d13f92-python3.patch
* 559b54d-load-ext4.patch
* b9031e08-search-for-standalone-xdr-library.patch
* dhcp-fix.patch
* f24d003b-sync-unmount-shutdown.patch
* no-libexec.patch

==== xdg-desktop-portal ====
Version update (1.0.3 -> 1.2.0)
Subpackages: xdg-desktop-portal-lang

- Update to version 1.2.0:
+ notification:
- Use icon validator from flatpak.
- Don't leave temp files around.
+ email: Validate options better.
+ inhibit: Validate options better.
+ file chooser: Add support for setting the current filter.
+ Updated translations.
- Changes from version 1.1.1:
+ Validate icons in notifications.
+ Respect lockdown settings.
+ Write back permissions for notifications to indicate portal
use.
+ Set st_nlink in the documents portal.
+ Add infrastructure for validating options.
+ Validate email addresses.
+ Updated translations.
- Changes from version 1.1.0:
+ Add a location portal, this requires geoclue 2.5.2.
+ Add a settings portal, for desktop-wide settings like XSettings
or kdeglobals.
+ Allow locking down printing, save-to-disk and opening uris.
+ Monitor application changes in the open uri portal.
+ Add more tests.
+ Fix a crash when xdg-desktop-portal-gtk times out (boo#1118121,
gh#flatpak/xdg-desktop-portal#236).
- Add pkgconfig(fontconfig) and pkgconfig(flatpak) BuildRequires:
New dependencies.
- Add pkgconfig(libgeoclue-2.0) BuildRequires and pass
enable-geoclue to configure, build new optional location portal.

==== xdg-desktop-portal-gtk ====
Version update (1.0.2 -> 1.2.0)
Subpackages: xdg-desktop-portal-gtk-lang

- Update to version 1.2.0:
+ file chooser: Support setting current filter.
+ Updated translations.
- Changes from version 1.1.1:
+ lockdown: Implement the lockdown backend.
+ email: Be more careful when selecting a handler.
+ Updated translations.
- Changes from version 1.1.0:
+ Respect GNOME lockdown settings for printing, save-to-disk and
app choosing.
+ filechooser: Set proper default accept label.
+ appchooser: Implement UpdateChoices and update the dialog.
+ Updated translations.

==== xdg-desktop-portal-kde ====
Version update (5.14.5 -> 5.15.0)
Subpackages: xdg-desktop-portal-kde-lang

- Update to 5.15.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.15.0.php
- No code changes since 5.14.90
- Update to 5.14.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.90.php
- Too many changes to list here

==== xfce4-terminal ====
Subpackages: xfce4-terminal-lang

- Fix issue with xfce4-terminal-settings.desktop entries boo#1125146
- Dropped obsolete macros
- Added %license macro

==== yast2 ====
Version update (4.1.53 -> 4.1.54)
Subpackages: yast2-logs

- Firewall: added some help methods for moving interfaces between
zones in a safe way (fate#324662).
- 4.1.54

==== yast2-bootloader ====
Version update (4.1.14 -> 4.1.16)

- Improve the layout of "Boot Code Options" tab (bsc#1120793)
- 4.1.16
- Improved error message for broken by-path device names (bsc#1122008)
- 4.1.15

==== yast2-network ====
Version update (4.1.36 -> 4.1.37)

- bsc#1124002
- do not crash when cloning and trying to read a device protocol
or portname.
- 4.1.37

==== zypper ====
Version update (1.14.24 -> 1.14.25)
Subpackages: zypper-aptitude zypper-log

- Fix installing plain rpm files with `zypper in` (bsc#1124897)
- Show only required info in the summary in quiet mode (bsc#993025)
- version 1.14.25


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages