Mailinglist Archive: opensuse-factory (602 mails)

< Previous Next >
Re: [opensuse-factory] zypper dup hangs while installing TW 20190202
  • From: Maximilian Trummer <maximilian@xxxxxxxxxxx>
  • Date: Wed, 06 Feb 2019 21:11:13 +0100
  • Message-id: <5965984.GbHKVKhLWT@ryzen>
Am Dienstag, 5. Februar 2019, 22:31:35 CET schrieb Patrick Shanahan:
* Maximilian Trummer <maximilian@xxxxxxxxxxx> [02-05-19 13:27]:
While trying to dup to Tumbleweed 20190202, the installation process
suddenly got stuck at trying to install 'btrfsmaintenance' at 70%. This
is the last output in /var/log/zypper.log from 40 minutes ago, no updates
since then:

2019-02-05 18:45:07 <1> ryzen(18702) [zypp] RpmHeader.cc(readPackage):252
ReferenceCounted(@0x562041d902f0<=1){0x5620416d8b10}{btrfsmaintenance-0.4
.2-1.2} from
/var/cache/zypp/packages/openSUSE-20180820-0/noarch/btrfsmaintenance-0.4.
2-1.2.noarch.rpm 2019-02-05 18:45:07 <1> ryzen(18702) [zypp]
RpmDb.cc(doInstallPackage):1992
RpmDb::installPackage(/var/cache/zypp/packages/openSUSE-20180820-0/noarch
/btrfsmaintenance-0.4.2-1.2.noarch.rpm,0x0000000c) 2019-02-05 18:45:07 <1>
ryzen(18702) [zypp::exec++] ExternalProgram.cc(start_program):259
Executing 'rpm' '--root' '/' '--dbpath' '/var/lib/rpm' '-U' '--percent'
'--noglob' '--force' '--nodeps' '--'
'/var/cache/zypp/packages/openSUSE-20180820-0/noarch/btrfsmaintenance-0.4
.2-1.2.noarch.rpm' 2019-02-05 18:45:07 <1> ryzen(18702) [zypp::exec++]
ExternalProgram.cc(start_program):424 pid 2838 launched

I can *still* ssh into the machine, there is basically no system load,
also no btrfs scrub/cleanup maintenance stuff running which was my first
idea. What should I do in this situation? Is there a way to find out what
went wrong?
kill the zypper dup process, manually remove btrfsmaintenance, the restart
the dup process. after it completes do:
zypper -v in btrfsmaintenance
Today I tried to 'zypper dup' again (the meanwhile released 20190205) and it
worked flawlessly, so that's it I guess.

Now of course I'm glad that snapper saved me there, but I still don't know why
a package would just fail installing and halt the entire 'zypper dup'
process...
< Previous Next >