Mailinglist Archive: opensuse-factory (633 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20190110 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20190110

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
aria2
bluedevil5 (5.14.4 -> 5.14.5)
breeze (5.14.4 -> 5.14.5)
breeze-gtk (5.14.4 -> 5.14.5)
breeze4-style (5.14.4 -> 5.14.5)
cups-filters
discover (5.14.4 -> 5.14.5)
drkonqi5 (5.14.4 -> 5.14.5)
geoclue2 (2.5.1 -> 2.5.2)
gthumb
irssi (1.1.1 -> 1.1.2)
jhbuild (3.22.0~20160920 -> 3.28.0~20171102)
kactivitymanagerd (5.14.4 -> 5.14.5)
kcm_sddm (5.14.4 -> 5.14.5)
kde-cli-tools5 (5.14.4 -> 5.14.5)
kde-gtk-config5 (5.14.4 -> 5.14.5)
kde-user-manager (5.14.4 -> 5.14.5)
kgamma5 (5.14.4 -> 5.14.5)
khotkeys5 (5.14.4 -> 5.14.5)
kinfocenter5 (5.14.4 -> 5.14.5)
kmenuedit5 (5.14.4 -> 5.14.5)
krename
kscreen5 (5.14.4 -> 5.14.5)
kscreenlocker (5.14.4 -> 5.14.5)
ksshaskpass5 (5.14.4 -> 5.14.5)
ksysguard5 (5.14.4 -> 5.14.5)
kwayland-integration (5.14.4 -> 5.14.5)
kwin5 (5.14.4 -> 5.14.5)
libkdecoration2 (5.14.4 -> 5.14.5)
libkscreen2 (5.14.4 -> 5.14.5)
libksysguard5 (5.14.4 -> 5.14.5)
libmbim (1.16.2 -> 1.18.0)
libstorage-ng (4.1.74 -> 4.1.75)
milou5 (5.14.4 -> 5.14.5)
multipath-tools (0.7.9+85+suse.766b95e -> 0.7.9+111+suse.b4232b7)
oxygen5 (5.14.4 -> 5.14.5)
patterns-base
plasma-nm5 (5.14.4 -> 5.14.5)
plasma5-addons (5.14.4 -> 5.14.5)
plasma5-desktop (5.14.4 -> 5.14.5)
plasma5-integration (5.14.4 -> 5.14.5)
plasma5-openSUSE
plasma5-pa (5.14.4 -> 5.14.5)
plasma5-workspace (5.14.4 -> 5.14.5)
polkit-kde-agent-5 (5.14.4 -> 5.14.5)
powerdevil5 (5.14.4 -> 5.14.5)
powertop (2.9 -> 2.10)
python-sip
sddm
systemsettings5 (5.14.4 -> 5.14.5)
virt-manager
xfwm4
yast2 (4.1.47 -> 4.1.48)
yast2-firewall (4.1.3 -> 4.1.5)
yast2-multipath (4.1.0 -> 4.1.1)
yast2-network (4.1.27 -> 4.1.29)
yast2-python-bindings (4.0.5 -> 4.0.7)
yast2-users (4.1.4 -> 4.1.5)

=== Details ===

==== aria2 ====
Subpackages: aria2-lang libaria2-0

- Fix CVE-2019-3500 boo#1120488
* aria2-CVE-2019-3500.patch
- Move bash completion to better location

==== bluedevil5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: bluedevil5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== breeze ====
Version update (5.14.4 -> 5.14.5)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers libbreezecommon5-5

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== breeze-gtk ====
Version update (5.14.4 -> 5.14.5)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* Set the default cursor theme to breeze_cursors
- Remove patches, now upstream:
* 0001-Set-the-default-cursor-theme-to-breeze_cursors.patch

==== breeze4-style ====
Version update (5.14.4 -> 5.14.5)
Subpackages: libbreezecommon4-5

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== cups-filters ====

- Fix building with Poppler 0.72
Add 0001-Raise-minimum-poppler-version-from-0.18-to-0.19.patch
Add 0002-Adapt-code-for-SplashXPathScanner-state-handling-sin.patch
Add 0003-Support-some-more-methods-returning-const.patch
Add 0004-Support-GooString-c_str-introduced-by-poppler-0.72.patch

==== discover ====
Version update (5.14.4 -> 5.14.5)
Subpackages: discover-backend-flatpak discover-backend-fwupd
discover-backend-packagekit discover-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* Don't enable the install button in the app page until we know the state
* fwupd: simplify logic that initialises files to download
* fwupd: fix leak on faulty devices
* Don't inspect sources if the backend isn't confident about offering good
results (kde#401844)
* ux: Make sure we can reach the view from the appdelegate
* pk: Don't show the dependencies button if there aren't dependencies
(kde#400781)
* snap: show more useful information for each channel (kde#401907)
* Don't show a hover event if there's nothing to open (kde#401833)
* Don't automatically refresh if the user already asked apt to do so
(kde#401810)
* Source enabled checkbox value shouldn't change only because it was clicked
(kde#401663)
* fwupd: Don't get releases for unsupported devices
* fwupd: be more verbose when returning a faulty checksum because a file
can't be read
* fwupd: remove unused declaration
- Move flatpak-discover icon to the backend-flatpak subpackage

==== drkonqi5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: drkonqi5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== geoclue2 ====
Version update (2.5.1 -> 2.5.2)
Subpackages: system-user-srvGeoClue typelib-1_0-Geoclue-2_0

- Update to version 2.5.2:
+ Scan for WiFi networks, greatly improving accuracy of WiFi
source.
+ Allow multiple clients on the same D-Bus connection and add API
for it. This is mainly targetted for Flatpak location portal.
+ Add API for apps to explicitly delete their client objects.
Long running apps, like gnome-settings-daemon and Flatpak
location portal, should use that to ensure Geoclue knows when
these apps are not actually using it and hence it doesn't need
to keep running needlessly.
+ Restore accidently removed, build of modem sources.
+ Update location on connectivity actually changing.
+ Try not spamming Mozilla Location Service.
+ Fix unexpected exit when non-active clients are connected.
+ Fix a check for system apps.
+ Use absolute paths for sysconfdir.
+ Fix links in docs.
+ More debug log.
+ A bunch of internal and/or non-functional fixes & improvements.
- Drop geoclue2-Fix-duplicate-decl-specifier.patch: The entire code
was removed from geoclue.

==== gthumb ====
Subpackages: gthumb-lang

- Add fix_double_free_dlg-contact-sheet_c.patch:
fix for bsc#1113749 / CVE-2018-18718

==== irssi ====
Version update (1.1.1 -> 1.1.2)

- update to 1.1.2
- Fix the resetting of window hiddenlevel (#861)
- Fix clearing of hidelevel in layout (#951)
- Fix accessing unallocated text when checking entry position
(#930)
- Fix uninitialised memory on empty lines (#873, GL#31, #878,
[#877], #907, #914)
- Fix use-after-free on expiration of hidden lines (#948)
(CVE-2019-5882 boo#1121396)
- Fix use-after-frees. By Maya Rashish (#919)
- Fix out of bounds access in help display when window width
is small (#949)
- Fix paste_join_multiline (#971)
- Correctly check for errno when displaying SSL errors. By
Janik Rabe (#895)
- Fix wrong signal emission argument count (#965)
- Documentation (#920). Sync NEWS, scripts (#849)
- Fix Perl detection on MacOS. By Dominyk Tiller (#927)
- Misc fixes. By Jaroslav ?karvada (#982)

==== jhbuild ====
Version update (3.22.0~20160920 -> 3.28.0~20171102)
Subpackages: jhbuild-lang

- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
- Modernize spec-file by calling spec-cleaner
- Update to version 3.28.0~20171102:
+ gnome-world: Remove libepc.
+ core-3.28:
- gvfs now uses meson
- Build NetworkManager with --disable-ovs
- Use Meson to build at-spi2-atk
+ core-deps-3.28:
- Enable build of libosinfo tests
- Disable more fwupd backends
- WebKitGTK+ 2.19.1
+ 3.28: Move xtrans to -syspeds
+ world: Tepl now uses GtkSourceView 4
+ apps-3.28: gnome-recipes depends on gnome-online-accounts
- Pass --enable-gui to configure: now GUI can be enabled/disabled
and since it's disabled by default we must turn it on.
- Update Url to https://wiki.gnome.org/Projects/Jhbuild: current
Jhbuild's project web page.
- Add conditional use for translation-update-upstream as it's a
SLE-only requirement.
- Drop:
+ jhbuild-unset-config-site.patch: fixed upstream.
+ %desktop_database_* post(un) scriplets: the functionality is
covered by file triggers now.
+ %defattr in '%files lang ...' section as it's not needed.
- Adopt %make_intall macro use as best practice instead of raw
commands.

==== kactivitymanagerd ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kactivitymanagerd-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== kcm_sddm ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kcm_sddm-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== kde-cli-tools5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kde-cli-tools5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== kde-gtk-config5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== kde-user-manager ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kde-user-manager-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== kgamma5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kgamma5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== khotkeys5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: khotkeys5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== kinfocenter5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kinfocenter5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* Increase default window size so nothing gets cut off by default BUG: 364767
FIXED-IN: 5.12.8 (kde#364767)

==== kmenuedit5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kmenuedit5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== krename ====

- Trim filler words from description. Fix bumpy grammar in the
sentence with filename composition.

==== kscreen5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kscreen5-lang kscreen5-plasmoid

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* Redraw the slider if modes have changed

==== kscreenlocker ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* Force software rendering when greeter crashed
* Fix build with libc++
* Prevent paste in screen locker (kde#388049)
* Load QtQuickSettings for software rendering

==== ksshaskpass5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: ksshaskpass5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== ksysguard5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: ksysguard5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== kwayland-integration ====
Version update (5.14.4 -> 5.14.5)

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== kwin5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: kwin5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* [platforms/x11/standalone] Pass kxkbconfig to Xkb prior to reconfigure
(kde#402764)

==== libkdecoration2 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: libkdecorations2-5 libkdecorations2-5-lang libkdecorations2private6

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== libkscreen2 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* Notify also if modes have changed

==== libksysguard5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: libksysguard5-helper libksysguard5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== libmbim ====
Version update (1.16.2 -> 1.18.0)
Subpackages: libmbim-glib4 mbimcli-bash-completion

- Update to version 1.18.0
+ New Microsoft Basic Connect Extensions service, that includes
new commands to manage Protocol Configuration Operations (PCO)
as well as LTE attach status and settings.
+ libmbim-glib:
- Added support to fully print all message contents, including
all fields, when traces are enabled.
- Added support for QMI indications over MBIM.
- Added additional cause codes to MbimNwError.
- Fixed signal emission in device, so that it's done before
completing transaction task.
+ mbim-proxy: Fixed the management of subscribed events, so that
the lists are maintained per-device.
+ mbimcli:
- New '--ms-query-pco' action.
- New '--ms-query-lte-attach-configuration' action.
- New '--ms-query-lte-attach-status' action.
+ Several other minor improvements and fixes.

==== libstorage-ng ====
Version update (4.1.74 -> 4.1.75)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- Translated using Weblate (Czech)
- 4.1.75

==== milou5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: milou5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== multipath-tools ====
Version update (0.7.9+85+suse.766b95e -> 0.7.9+111+suse.b4232b7)
Subpackages: kpartx

- Update to version 0.7.9+111+suse.b4232b7:
- merged upstream cb4a979a (SUSE bug fixes merged upstream,
code-identical to previous release).
- Update to version 0.7.9+109+suse.203c1cf:
* multipathd: avoid crash in cli_list_path (bsc#1121134)
* libmultipath: fix compilation with older kernel headers
(bsc#1121066)
- merged upstream fb824725
* Improved NVMe support in both native and dm-mpath mode
added basic NVMe ANA support (bsc#1119898)
* Fix prio output in "multipathd show topology" (bsc#1119897)
* multipathd: fix daemon not really shutdown
(bsc##1110060, bsc#1110439)
- Update to version 0.7.9+90+suse.f81e290:
* libmultipath: Increase SERIAL_SIZE to 128 bytes
(bsc#1107179)

==== oxygen5 ====
Version update (5.14.4 -> 5.14.5)

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt
patterns-base-base patterns-base-basesystem patterns-base-console
patterns-base-documentation patterns-base-enhanced_base
patterns-base-enhanced_base_opt patterns-base-minimal_base
patterns-base-minimal_base_conflicts patterns-base-sw_management
patterns-base-transactional_base patterns-base-x11 patterns-base-x11_enhanced
patterns-base-x11_opt

- recommend grub2-*arm*efi variants for arm/arm64 (bsc#1120804)
- recommend shim for aarch64

==== plasma-nm5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* Fix a wrong check in previous patch
* Openconnect: do not reload dialog when group changes for Juniper protocol
(kde#395157)
* Revert "Openconnect: do not reload the auth dialog endlessly when group
changes"
* Notify that kcm changed only when validity has changed (kde#379756)

==== plasma5-addons ====
Version update (5.14.4 -> 5.14.5)
Subpackages: plasma5-addons-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* [comic dataengine] Do not cache identifier only requests
* [comic] Update comic strip on current identifier only
* [comic] Fix max cache limit
* [comic] Request current identifier on data change
* [comicupdater] Fix last day check

==== plasma5-desktop ====
Version update (5.14.4 -> 5.14.5)
Subpackages: plasma5-desktop-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* [Activities KCM] Disable delete button when there's only one activity BUG:
397887 FIXED-IN; 5.12.8 (kde#397887)
* [Activities KCM] vertically center the buttons
* Fix removing first item in languages list (kde#401473)
* Make accessibility warning dialog usable again and fix event handling
* Make accessibility warning dialog usable again
* Make sure m_labelMode is initialised
* Round label width
* [Folder View] implement a minimum width for icon view to ensure that labels
are never rendered useless (kde#379432)
* Fix group popup dialog (kde#401508)
- Remove patches, now upstream:
* 0001-Fix-group-popup-dialog.patch

==== plasma5-integration ====
Version update (5.14.4 -> 5.14.5)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.14.5

==== plasma5-pa ====
Version update (5.14.4 -> 5.14.5)
Subpackages: plasma5-pa-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== plasma5-workspace ====
Version update (5.14.4 -> 5.14.5)
Subpackages: gmenudbusmenuproxy plasma5-session plasma5-session-wayland
plasma5-workspace-lang plasma5-workspace-libs xembedsniproxy

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* [weather dataengine] envcan: fix typo in forecast string "Mainly sunny"
* [weather dataengine] envcan: support also "Partly cloudy" forecast
* [weather dataengine] bbc: adapt to changed strings for same day in forecast
* [weather dataengine] noaa: add more forecast strings found in use
* [weather dataengine] Remove duplicated condition/forecast strings
* [weather dataengine] envcan: support also "Mainly cloudy" forecast
* [weather dataengine] noaa: use https over http
* [weather dataengine] noaa: fix unknown icon for Flurries
* [kuiserver] Debug--
* [kuiserver] Avoid double warning on terminated jobs
* Don't exec() hint about deactivating URL grabber (kde#363771)
* Set error if a kjob host disappears from kuiserver with active jobs

==== polkit-kde-agent-5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== powerdevil5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: powerdevil5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- Changes since 5.14.4:
* [dimdisplay] Do not change screen brightness on invalid values

==== powertop ====
Version update (2.9 -> 2.10)
Subpackages: powertop-lang

- Update to version 2.10:
* new WakeUp tab which displays the devices wake up settings
* Enable support for Intel GLK
* Enable support for Intel CNL-U/Y
* For details see https://01.org/powertop/downloads/powertop-v2.10
- Remove powertop_libc++_fix.patch: in new release
- Remove powertop_cstate_fix.patch: in new release

==== python-sip ====
Subpackages: python-sip-common python3-sip

- Build a private Qt4 module as well, that's needed by the latest
python-qt4 (boo#1119636)
- Use upstream-recommended %{_rpmconfigdir}/macros.d directory
for the rpm macros.

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Do not ignore errors from useradd.
- Add the dirs created by systemd-tmpfiles as %ghost as well
- Use service macros and create rcsddm link for sddm.service
- Add patch to delete socket on shutdown:
* 0001-Destroy-the-QLocalServer-in-Auth-on-shutdown.patch
- Move creation of runtime directories and cleanup of files on boot
into sddm-tmpfiles.conf (boo#1116431)
- Remove 0001-Don-t-leak-VT-FDs-in-jumpToVt.patch as the FD leak
worked around a race condition as a side effect
- Add patch to not leak tty FDs for wayland sessions:
* 0001-Don-t-leak-VT-FDs-in-jumpToVt.patch

==== systemsettings5 ====
Version update (5.14.4 -> 5.14.5)
Subpackages: systemsettings5-lang

- Update to 5.14.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.5.php
- No code changes since 5.14.4

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- Increase the timeout for a vm to start before assuming something
is wrong. (bsc#1027942)
c30b3bc6-increase-timeout-for-vm-to-start.patch
- fate#326698: Add support for Xen's PVH guest type
virtinst-add-pvh-support.patch

==== xfwm4 ====
Subpackages: xfwm4-lang

- Remove old themes, moved to gtk2 repos of the themes

==== yast2 ====
Version update (4.1.47 -> 4.1.48)
Subpackages: yast2-logs

- Ignore the old packages when fetching the release notes
(bsc#1112866)
- 4.1.48

==== yast2-firewall ====
Version update (4.1.3 -> 4.1.5)

- Restart running firewalld service if data has been changed.
(bsc#1114673)
- 4.1.5
- AutoYast schema:
- Allowed the new 'forward_ports', 'rich_rules' and
'source_ports' elements in zone entries (bsc#1108199)
- 4.1.4

==== yast2-multipath ====
Version update (4.1.0 -> 4.1.1)

- CVE-2018-17955, use random file name (bsc#1117592)
- 4.1.1

==== yast2-network ====
Version update (4.1.27 -> 4.1.29)

- bnc#1111483
- write physical device into vlan's configuration
- 4.1.29

==== yast2-python-bindings ====
Version update (4.0.5 -> 4.0.7)

- Define yast._() as an alias to gettext(); (bsc#1121106).
- Provide textdomain() and gettext() functions for
internationization; (bsc#1121106).
- Added license file to spec.

==== yast2-users ====
Version update (4.1.4 -> 4.1.5)

- Fixed a syntax error in UsersPluginQuota.pm introduced
in the previous change (bsc#1118291).
- 4.1.5


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >