Mailinglist Archive: opensuse-factory (188 mails)

< Previous Next >
Re: [opensuse-factory] Snapshot 20181214 QT library incompatibilities
I suppose that's the main problem here:
Am Mittwoch, 19. Dezember 2018, 17:22:48 schrieb Ben Holmes:
Problem: libQt5Scxml5-5.11.2-1.1.x86_64 requires
libQt5Qml.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement
cannot be provided

libqt5-qtscxml hasn't been updated to 5.12.0 in Factory yet, the submission is
still pending:
https://build.opensuse.org/request/show/656567

And 5.11.2 fails to build against Qt 5.12...

Do you actually need that?

According to the QT 5.12 release change notes
(https://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.12.0/?h=v5.12.0)
, 5.12 should be binary compatible with 5.11.2. Unfortunately, the
libraries are showing as incompatible.

In general they are binary compatible, but that's not necessarily true for the
private API (that's why it's called private).

Is it safe to ignore the dependencies?

No.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References