Mailinglist Archive: opensuse-factory (188 mails)

< Previous Next >
[opensuse-factory] Snapshot 20181214 QT library incompatibilities
G'day Tumblers,

When updating to 20181214, I get the following errors:

Computing distribution upgrade...
6 Problems:
Problem: libQt5WebView5-5.11.2-1.1.x86_64 requires libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
Problem: libQt5Scxml5-5.11.2-1.1.x86_64 requires libQt5Qml.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
Problem: libQt5WebView5-5.11.2-1.1.x86_64 requires libQt5WebEngine.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
Problem: libqt5-qtwebengine-5.11.2-1.2.x86_64 requires libQt5Gui.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
Problem: libQtQuick5-5.11.2-1.1.x86_64 requires libQt5Test.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
Problem: libQtQuick5-5.11.2-1.1.x86_64 requires libQt5Widgets.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided
Problem: libQt5WebView5-5.11.2-1.1.x86_64 requires libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement cannot be provided

According to the QT 5.12 release change notes (https://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.12.0/?h=v5.12.0), 5.12 should be binary compatible with 5.11.2. Unfortunately, the libraries are showing as incompatible.

Is this happening for everyone, or is it just me?

Is it safe to ignore the dependencies?

-- Ben
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >