Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20181116 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20181116

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
NetworkManager-applet
aaa_base (84.87+git20180409.04c9dae -> 84.87+git20181113.08d4125)
alpine
analitza (18.08.2 -> 18.08.3)
attica-qt5 (5.51.0 -> 5.52.0)
baloo5 (5.51.0 -> 5.52.0)
blinken (18.08.2 -> 18.08.3)
bluez-qt (5.51.0 -> 5.52.0)
bovo (18.08.2 -> 18.08.3)
breeze5-icons (5.51.0 -> 5.52.0)
cervisia (18.08.2 -> 18.08.3)
dialog
ffmpeg-4 (4.0.2 -> 4.1)
ffmpegthumbs (18.08.2 -> 18.08.3)
frameworkintegration (5.51.0 -> 5.52.0)
gdb
glib2-branding-openSUSE
gpg2 (2.2.10 -> 2.2.11)
hylafax+
ibus-libpinyin
installation-images-Kubic (14.388 -> 14.391)
intel-vaapi-driver (2.1.0 -> 2.2.0)
juk (18.08.2 -> 18.08.3)
kactivities-stats (5.51.0 -> 5.52.0)
kactivities5 (5.51.0 -> 5.52.0)
kalgebra (18.08.2 -> 18.08.3)
kalzium (18.08.2 -> 18.08.3)
kanagram (18.08.2 -> 18.08.3)
kapptemplate (18.08.2 -> 18.08.3)
karchive (5.51.0 -> 5.52.0)
katomic (18.08.2 -> 18.08.3)
kauth (5.51.0 -> 5.52.0)
kblackbox (18.08.2 -> 18.08.3)
kblocks (18.08.2 -> 18.08.3)
kbookmarks (5.51.0 -> 5.52.0)
kbounce (18.08.2 -> 18.08.3)
kbreakout (18.08.2 -> 18.08.3)
kbruch (18.08.2 -> 18.08.3)
kcachegrind (18.08.2 -> 18.08.3)
kcmutils (5.51.0 -> 5.52.0)
kcodecs (5.51.0 -> 5.52.0)
kcompletion (5.51.0 -> 5.52.0)
kconfig (5.51.0 -> 5.52.0)
kconfigwidgets (5.51.0 -> 5.52.0)
kcoreaddons (5.51.0 -> 5.52.0)
kcrash (5.51.0 -> 5.52.0)
kcron (18.08.2 -> 18.08.3)
kdbusaddons (5.51.0 -> 5.52.0)
kde-print-manager (18.08.2 -> 18.08.3)
kdeclarative (5.51.0 -> 5.52.0)
kdeconnect-kde
kded (5.51.0 -> 5.52.0)
kdeedu-data (18.08.2 -> 18.08.3)
kdegraphics-thumbnailers (18.08.2 -> 18.08.3)
kdelibs4support (5.51.0 -> 5.52.0)
kdesu (5.51.0 -> 5.52.0)
kdf (18.08.2 -> 18.08.3)
kdiamond (18.08.2 -> 18.08.3)
kdnssd-framework (5.51.0 -> 5.52.0)
kdoctools (5.51.0 -> 5.52.0)
kemoticons (5.51.0 -> 5.52.0)
kernel-firmware (20181001 -> 20181026)
kfilemetadata5 (5.51.0 -> 5.52.0)
kgeography (18.08.2 -> 18.08.3)
kget (18.08.2 -> 18.08.3)
kglobalaccel (5.51.0 -> 5.52.0)
kgoldrunner (18.08.2 -> 18.08.3)
kguiaddons (5.51.0 -> 5.52.0)
khangman (18.08.2 -> 18.08.3)
kholidays (5.51.0 -> 5.52.0)
khtml (5.51.0 -> 5.52.0)
ki18n (5.51.0 -> 5.52.0)
kiconthemes (5.51.0 -> 5.52.0)
kidletime (5.51.0 -> 5.52.0)
kig (18.08.2 -> 18.08.3)
kimageformats (5.51.0 -> 5.52.0)
kimagemapeditor (18.08.2 -> 18.08.3)
kinit (5.51.0 -> 5.52.0)
kio (5.51.0 -> 5.52.0)
kirigami2 (5.51.0 -> 5.52.0)
kiriki (18.08.2 -> 18.08.3)
kitemmodels (5.51.0 -> 5.52.0)
kitemviews (5.51.0 -> 5.52.0)
kiten (18.08.2 -> 18.08.3)
kjobwidgets (5.51.0 -> 5.52.0)
kjs (5.51.0 -> 5.52.0)
kjsembed (5.51.0 -> 5.52.0)
kjumpingcube (18.08.2 -> 18.08.3)
klettres (18.08.2 -> 18.08.3)
klines (18.08.2 -> 18.08.3)
kmahjongg (18.08.2 -> 18.08.3)
kmines (18.08.2 -> 18.08.3)
kmouth (18.08.2 -> 18.08.3)
kmplot (18.08.2 -> 18.08.3)
knavalbattle (18.08.2 -> 18.08.3)
knetwalk (18.08.2 -> 18.08.3)
knewstuff (5.51.0 -> 5.52.0)
knotifications (5.51.0 -> 5.52.0)
knotifyconfig (5.51.0 -> 5.52.0)
kolf (18.08.2 -> 18.08.3)
kollision (18.08.2 -> 18.08.3)
kolourpaint (18.08.2 -> 18.08.3)
konquest (18.08.2 -> 18.08.3)
kpackage (5.51.0 -> 5.52.0)
kparts (5.51.0 -> 5.52.0)
kpat (18.08.2 -> 18.08.3)
kpeople5 (5.51.0 -> 5.52.0)
kplotting (5.51.0 -> 5.52.0)
kpty (5.51.0 -> 5.52.0)
kqtquickcharts (18.08.2 -> 18.08.3)
krdc (18.08.2 -> 18.08.3)
kreversi (18.08.2 -> 18.08.3)
krfb (18.08.2 -> 18.08.3)
kross (5.51.0 -> 5.52.0)
krunner (5.51.0 -> 5.52.0)
kservice (5.51.0 -> 5.52.0)
kshisen (18.08.2 -> 18.08.3)
ksirk (18.08.2 -> 18.08.3)
kspaceduel (18.08.2 -> 18.08.3)
ksquares (18.08.2 -> 18.08.3)
ksudoku (18.08.2 -> 18.08.3)
ksystemlog (18.08.2 -> 18.08.3)
kteatime (18.08.2 -> 18.08.3)
ktexteditor (5.51.0 -> 5.52.0)
ktextwidgets (5.51.0 -> 5.52.0)
ktimer (18.08.2 -> 18.08.3)
ktouch (18.08.2 -> 18.08.3)
ktuberling (18.08.2 -> 18.08.3)
kturtle (18.08.2 -> 18.08.3)
kubrick (18.08.2 -> 18.08.3)
kunitconversion (5.51.0 -> 5.52.0)
kwallet (5.51.0 -> 5.52.0)
kwayland (5.51.0 -> 5.52.0)
kwidgetsaddons (5.51.0 -> 5.52.0)
kwindowsystem (5.51.0 -> 5.52.0)
kwordquiz (18.08.2 -> 18.08.3)
kxmlgui (5.51.0 -> 5.52.0)
kxmlrpcclient5 (5.51.0 -> 5.52.0)
libKF5ModemManagerQt (5.51.0 -> 5.52.0)
libKF5NetworkManagerQt (5.51.0 -> 5.52.0)
libgit2 (0.27.5 -> 0.27.7)
libinput (1.12.2 -> 1.12.3)
libkdegames (18.08.2 -> 18.08.3)
libkeduvocdocument (18.08.2 -> 18.08.3)
libkmahjongg (18.08.2 -> 18.08.3)
libmspack (0.8 -> 0.9.1)
libreoffice
libvirt
lirc (0.9.4c -> 0.10.1)
lokalize (18.08.2 -> 18.08.3)
lskat (18.08.2 -> 18.08.3)
mbox-importer (18.08.2 -> 18.08.3)
nano (3.1 -> 3.2)
oxygen5-icon-theme (5.51.0 -> 5.52.0)
parley (18.08.2 -> 18.08.3)
pcre
perl-DBI (1.641 -> 1.642)
perl-DateTime-Locale (1.220000 -> 1.230000)
perl-Error (0.17026 -> 0.17027)
perl-Specio (0.42 -> 0.43)
perl-XML-XPath (1.42 -> 1.44)
perl-YAML (1.26 -> 1.27)
perl-libwww-perl (6.35 -> 6.36)
pim-data-exporter (18.08.2 -> 18.08.3)
pim-sieve-editor (18.08.2 -> 18.08.3)
plasma-framework (5.51.0 -> 5.52.0)
prison-qt5 (5.51.0 -> 5.52.0)
purpose (5.51.0 -> 5.52.0)
qqc2-desktop-style (5.51.0 -> 5.52.0)
rpcbind (0.2.4 -> 1.2.5)
ruby2.5 (2.5.1 -> 2.5.3)
signon-kwallet-extension (18.08.2 -> 18.08.3)
solid (5.51.0 -> 5.52.0)
sonnet (5.51.0 -> 5.52.0)
step (18.08.2 -> 18.08.3)
susefirewall2-to-firewalld (0.0.3 -> 0.0.4)
sweeper (18.08.2 -> 18.08.3)
syndication (5.51.0 -> 5.52.0)
syntax-highlighting (5.51.0 -> 5.52.0)
systemd (237 -> 239)
threadweaver (5.51.0 -> 5.52.0)
tracker (2.1.5 -> 2.1.6)
umbrello (18.08.2 -> 18.08.3)
upower (0.99.8 -> 0.99.9)
util-linux
util-linux-systemd
xen

=== Details ===

==== NetworkManager-applet ====
Subpackages: NetworkManager-applet-lang NetworkManager-connection-editor
libnma0 nma-data typelib-1_0-NMA-1_0

- Add nm-applet-revert-no-show-all.patch: libnma: fix wrongly
showing hidden GUI elements (bsc#1106705,
glgo#GNOME/network-manager-applet#20).

==== aaa_base ====
Version update (84.87+git20180409.04c9dae -> 84.87+git20181113.08d4125)
Subpackages: aaa_base-extras

- Update to version 84.87+git20181113.08d4125:
* Sync x-genesis-rom extensions with freedesktop DB
* test for /applications before adding data dir
(bsc#1095969)
* Clean up the no_proxy value: not all clients ignore spaces
(bsc#1089796)
* Add option --version to /sbin/service
- Update to version 84.87+git20181107.f39a8d1:
* Readline: Do not miss common mappings for vi
* Readline: Use overwrite-mode on Insert key
* Avoid `ls' command in alljava shell scriptlets
* bashrc: Change =~ test to globs. Fixes mkshrc.
* Update README (#55)

==== alpine ====
Subpackages: pico

- updated upstream URL

==== analitza ====
Version update (18.08.2 -> 18.08.3)
Subpackages: analitza-lang libAnalitza5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== attica-qt5 ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Attica5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== baloo5 ====
Version update (5.51.0 -> 5.52.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Too many changes to list here

==== blinken ====
Version update (18.08.2 -> 18.08.3)
Subpackages: blinken-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== bluez-qt ====
Version update (5.51.0 -> 5.52.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Add Media and MediaEndpoint API header generation
* Fix new syntax

==== bovo ====
Version update (18.08.2 -> 18.08.3)
Subpackages: bovo-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== breeze5-icons ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Change package manager icons to emblems
* Re-add monochrome link icon as action Some action icons were symlinks to
`emblem-symbolic-link`. When the new emblem style was applied to
`emblem-symbolic-link`, those actions then had the wrong style. The old style
has been re-added as an action icon and the symlinks have been changed to point
to `link.svg`.
* Improve emblem contrast, legibility and consistency (kde#399356,
kde#399357, kde#399968)
* Support "new" mimetype for .deb files BUG: 399421 FIXED-IN: 5.52
(kde#399421)

==== cervisia ====
Version update (18.08.2 -> 18.08.3)
Subpackages: cervisia-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== dialog ====
Subpackages: dialog-lang libdialog14

- Fix mangled Hindi translation (bsc#1115005).

==== ffmpeg-4 ====
Version update (4.0.2 -> 4.1)
Subpackages: libavcodec58 libavdevice58 libavfilter7 libavformat58
libavresample4 libavutil56 libpostproc55 libswresample3 libswscale5

- Update ffmpeg to 4.1
* Lots of filter updates as usual: deblock, tmix, aplify,
fftdnoiz, aderivative, aintegral, pal75bars, pal100bars,
adeclick, adeclip, lensfun (wrapper), colorconstancy, 1D LUT
filter (lut1d), cue, acue, transpose_npp, amultiply,
Block-Matching 3d (bm3d) denoising filter, acrossover filter,
audio denoiser as afftdn filter, sinc audio filter source,
chromahold, setparams, vibrance, xstack,
(a)graphmonitor filter yadif_cuda filter.
* AV1 parser
* Support for AV1 in MP4
* PCM VIDC decoder and encoder
* libtensorflow backend for DNN based filters like srcnn
* -- The following only enabled in third-party builds:
* ATRAC9 decoder
* AVS2 video decoder via libdavs2
* IMM4 video decoder
* Brooktree ProSumer video decoder
* MatchWare Screen Capture Codec decoder
* WinCam Motion Video decoder
* RemotelyAnywhere Screen Capture decoder
* AVS2 video encoder via libxavs2
* ILBC decoder
* SER demuxer
* Decoding S12M timecode in H264
* For complete changelog, see
https://git.ffmpeg.org/gitweb/ffmpeg.git/shortlog/n4.1
- Remove 0001-avcodec-libaom-fix-setting-amount-of-threads.patch
(fixed upstream (bsc#776cdd1), remove ffmpeg-CVE-2018-13305.patch,
remove 0001-avformat-flvenc-Check-audio-packet-size.patch,
remove cve-2017-17555.diff (fixed upstream).
- Remove 0001-avformat-fivenc-Check-audio-packet-size.patch (fixed upstream
(bsc#8591d16)
- Update ffmpeg to 4.0.3
* For complete changelog, see
https://git.ffmpeg.org/gitweb/ffmpeg.git/shortlog/n4.0.3
- Add ffmpeg-CVE-2018-13305.patch to add a missing check for
negative values of mqaunt variable (CVE-2018-13305,
bsc#1100345).

==== ffmpegthumbs ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Don't crash if initializeVideo fails
- Dropped patches, now upstream:
* 0001-Don-t-crash-if-initializeVideo-fails.patch

==== frameworkintegration ====
Version update (5.51.0 -> 5.52.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== gdb ====

- Fix crash when reading core [bsc #1109013]
* Add gdb-fix-crash-when-reading-core.patch
https://sourceware.org/ml/gdb-cvs/2018-11/msg00022.html

==== glib2-branding-openSUSE ====

- Update gnome_defaults: evince.desktop has been renamed to
org.gnome.Evince.desktop with GNOME 3.30.

==== gpg2 ====
Version update (2.2.10 -> 2.2.11)
Subpackages: gpg2-lang

- Code no longer uses libcurl, remove from buildrequires.
- Update to 2.2.11:
* gpgsm: Fix CRL loading when intermediate certicates are not yet trusted.
* gpgsm: Fix an error message about the digest algo.
* gpg: Fix a wrong warning due to new sign usage check introduced with 2.2.9.
* gpg: Print the "data source" even for an unsuccessful keyserver query.
* gpg: Do not store the TOFU trust model in the trustdb.
* scd: Fix cases of "Bad PIN" after using "forcesig".
* agent: Fix possible hang in the ssh handler.
* dirmngr: Tack the unmodified mail address to a WKD request.
* dirmngr: Tweak diagnostic about missing LDAP server file.
* dirmngr: In verbose mode print the OCSP responder id.
* dirmngr: Fix parsing of the LDAP port.
* wks: Add option --directory/-C to the server.
* wks: Add option --with-colons to the client.
* Fix EBADF when gpg et al. are called by broken CGI scripts.
* Fix some minor memory leaks and bugs.

==== hylafax+ ====
Subpackages: hylafax+-client libfaxutil5_6_1

- Do not use tabs in spec
- boo#1115532 JBIG-in-tiff conversion added
(Build Requirement tiff, libtiff)

==== ibus-libpinyin ====

- Add ibus-libpinyin-fix-build-fault.patch: fix build error for
edition 1.10 in openSUSE-Leap-15(boo#1115778).

==== installation-images-Kubic ====
Version update (14.388 -> 14.391)

- merge gh#openSUSE/installation-images#273
- fix patching systemd-udevd.service file
- udevd needs a mountpoint for / to start (bsc#937237)
- 14.391
- merge gh#openSUSE/installation-images#272
- suse-module-tools now have a dependency on binutils
- 14.390
- merge gh#openSUSE/installation-images#271
- don't run udevd in its own private fs namespace
- 14.389

==== intel-vaapi-driver ====
Version update (2.1.0 -> 2.2.0)

- Update to version 2.2.0
* Bump version to 2.2.0
* Add new PCI ID for KBL-Y
* Add meson support
* Fix for VC1 decoding issues
* Fix VP8 encoding issues
* Fix the over-run issue in HEVC encoding
* Fix the max MV length in MPEG-2 encoding
* Fix packed header mode
* Fix building issue on Android

==== juk ====
Version update (18.08.2 -> 18.08.3)
Subpackages: juk-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* systray: Make SHIFT+Mousewheel change the volume, not the song. (kde#250355)

==== kactivities-stats ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kactivities5 ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Autogenerate debug categories + add categories file

==== kalgebra ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kalgebra-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kalzium ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kalzium-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kanagram ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kanagram-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kapptemplate ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kapptemplate-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== karchive ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* autotests: force use of utf8 for filename encodings

==== katomic ====
Version update (18.08.2 -> 18.08.3)
Subpackages: katomic-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kauth ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* USe new syntax

==== kblackbox ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kblackbox-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kblocks ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kblocks-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kbookmarks ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused variable
* Use reserve() on qt containers when fill size is known

==== kbounce ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kbounce-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kbreakout ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kbreakout-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kbruch ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kbruch-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kcachegrind ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kcachegrind-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kcmutils ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* remove deleted method
* support for multi pages kcms

==== kcodecs ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Use new syntax

==== kcompletion ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kconfig ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused variable
* Fix logic error in NotifyFlag testing
* Set explicit arg type in QCOMPARE
* Fix compilation without D-Bus
* Add mechanism to notify other clients of config changes over DBus
* Expose getter method for KConfig::addConfigSources

==== kconfigwidgets ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Allow KHelpCenter to open the right pages of KDE help when KHelpClient is
invoked with an anchor
* Include own header first
* Have include guard match header file name
* Use more explicit constructors with internal classes
* Use normalized signature with Q_ARG
* More const ref arguments in internal API
* Use emit foo(), not emit(foo());

==== kcoreaddons ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* autotests: repair "detecting hardlink change" with stat/qfswatch
* Minor: Use nullptr
* Add to categories files. Use new syntax
* Use qEnvironmentVariableIntValue

==== kcrash ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes

==== kcron ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kcron-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdbusaddons ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Use new syntax

==== kde-print-manager ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kde-print-manager-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdeclarative ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* API dox QCH creation: fix "linking" to kconfig docs
* make push/pop part of ConfigModule API
* Use reserve()
* Use QVariant::toFoo() where possible

==== kdeconnect-kde ====
Subpackages: kdeconnect-kde-lang

- Add 0001-Fix-build-on-Leap-42.3.patch to make it build on Leap
42.3

==== kded ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kded-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove useless "No X-KDE-DBus-ServiceName found" message
* Move categories file here
* Use qEnvironmentVariableIntValue

==== kdeedu-data ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdegraphics-thumbnailers ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Avoid nullptr access (kde#399896)

==== kdelibs4support ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused check
* Use directly qEnvironmentVariableIntValue

==== kdesu ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kdf ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdf-lang kwikdisk

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdiamond ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdiamond-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdnssd-framework ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* fix Service(Type)Browser documentation

==== kdoctools ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Fix autotests with -DBUILD_QCH:BOOL=TRUE
* API dox: fix typo
* API dox: add minimal docs to KDocTools namespace, so doxygen covers it
* Create a QCH file with the API dox, optionally, using ECMAddQCH
* Wait for docbookl10nhelper to be built before building our own manpages
* Use specified Perl interpreter instead of relying on PATH

==== kemoticons ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kernel-firmware ====
Version update (20181001 -> 20181026)
Subpackages: ucode-amd

- Update to version 20181026:
* qed: Add 8.37.7.0 firmware image
* amdgpu: add raven dmcu firmware
* amdgpu: update raven firmware to 18.40
* amdgpu: update fiji firmware to 18.40
* amdgpu: update tonga firmware to 18.40
* amdgpu: update carrizo firmware to 18.40
* amdgpu: update polaris10 firmware to 18.40
* amdgpu: update vega10 firmware to 18.40
* linux-firmware: add firmware for mt7650e
* linux-firmware: add MC firmware for NXP DPAA2 SoCs
* linux-firmware: liquidio: fix GPL compliance issue
* linux-firmware: Update firmware file for Intel Bluetooth,8265
* linux-firmware: Update firmware patch for Intel Bluetooth 8260
* linux-firmware: Update firmware file for Intel Bluetooth,9260
* linux-firmware: Update firmware file for Intel Bluetooth,9560
* linux-firmware: add firmware for mt7610e
* Update Intel OPA hfi1 firmware
* ath10k: QCA9984 hw1.0: update board-2.bin
* ath10k: QCA9984 hw1.0: update firmware-5.bin to 10.4-3.6.0.1-00003
* ath10k: QCA988X hw2.0: update firmware-5.bin to 10.2.4-1.0-00041
* ath10k: QCA9888 hw2.0: update board-2.bin
* ath10k: QCA9888 hw2.0: update firmware-5.bin to 10.4-3.6-00140
* ath10k: QCA9887 hw1.0: update firmware-5.bin to 10.2.4-1.0-00041
* ath10k: QCA9377 hw1.0: add firmware-6.bin to WLAN.TF.2.1-00021-QCARMSWP-1
* ath10k: QCA6174 hw3.0: update firmware-6.bin to RM.4.4.1.c2-00057-QCARMSWP-1
* ath10k: QCA4019 hw1.0: update board-2.bin
* ath10k: QCA4019 hw1.0: update firmware-5.bin to 10.4-3.6-00140
* nfp: Add Agilio BPF firmware rev 2.0.6.124
* rtw88: Add firmware file for driver rtw88
* nfp: update Agilio SmartNIC flower firmware to rev AOTC-2.9.A.37
* iwlwifi: add -41.ucode firmwares for 9000 series
* iwlwifi: update firmwares for 9000 series
* iwlwifi: update firmwares for 7000, 8000 and 9000 series
* nfp: update Agilio SmartNIC firmware to rev 2.1.13

==== kfilemetadata5 ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kfilemetadata5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Too many changes to list here

==== kgeography ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kgeography-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kget ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kget-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kglobalaccel ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Fix keyboard layout change notifications (kde#350816, kde#269403)
* Add identifier
* Call reserve() on Qt containers if fill size is known before
- Dropped patches, now upstream:
* 0001-Fix-keyboard-layout-change-notifications.patch

==== kgoldrunner ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kgoldrunner-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kguiaddons ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Use more explicit constructors with internal classes
* Have more include guards match file the name
* Use more new style connect()
* Use Q_OBJECT with all QObject subclasses (helps debugging introspection)

==== khangman ====
Version update (18.08.2 -> 18.08.3)
Subpackages: khangman-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kholidays ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Add Bahrain Holiday File
* Make KHolidays work as static library too

==== khtml ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== ki18n ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kiconthemes ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Revert some port to function-object based connect
* Add a QIconEnginePlugin to allow QIcon deserialization (kde#399989)
* Port some foreach code to for(...:...)
* [KIconLoader] Replace heap-allocated QImageReader with stack-allocated one
* [KIconLoader] Adjust emblem border depending on icon size
* [KIconLoader] Correct documentation of emblem/overlay order
* Include own header first
* Use more function-pointer based connect
* Use QStringLiteral if a final QString is wanted
* Use Q_OBJECT with all QObject subclasses (helps debugging introspection)
* Center icons properly if size doesn't fit (kde#396990)
* Use new syntax
* Fixing a copy-paste error
- Dropped patches, now upstream:
* Fixing-a-copy-paste-error.patch

==== kidletime ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kig ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kig-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kimageformats ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Fix minor EBN issues

==== kimagemapeditor ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kimagemapeditor-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kinit ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kinit-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* install categories file

==== kio ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kio-core kio-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Too many changes to list here
- Dropped patches, now upstream:
* 0001-kio_help-Fix-crash-in-QCoreApplication-when-accessin.patch

==== kirigami2 ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Too many changes to list here

==== kiriki ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kiriki-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kitemmodels ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Add missing "emit"
* Fix minor EBN issues and typos
* USe new syntax

==== kitemviews ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Call reserve() on Qt containers if fill size is known before

==== kiten ====
Version update (18.08.2 -> 18.08.3)
Subpackages: fonts-KanjiStrokeOrders kiten-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kjobwidgets ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Revert some port to function-object based connect
* Use more function-pointer based connect

==== kjs ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kjsembed ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kjumpingcube ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kjumpingcube-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== klettres ====
Version update (18.08.2 -> 18.08.3)
Subpackages: klettres-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== klines ====
Version update (18.08.2 -> 18.08.3)
Subpackages: klines-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmahjongg ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmahjongg-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmines ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmines-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmouth ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmouth-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmplot ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmplot-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== knavalbattle ====
Version update (18.08.2 -> 18.08.3)
Subpackages: knavalbattle-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== knetwalk ====
Version update (18.08.2 -> 18.08.3)
Subpackages: knetwalk-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== knewstuff ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused variable
* Adapt autotest to new menu structure
* More useful error messages
* Use new connect syntax

==== knotifications ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Revert some port to function-object based connect
* Use more function-pointer based connect
* Avoid creation of temporary list
* Do not include Qt module header
* Use prefix ++ operator for loop value
* Do not return void values in void methods
* Add missing "emit"
* Move categories file here
* force-finish canberra notifications on close() (kde#398695)

==== knotifyconfig ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kolf ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kolf-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Comment out phonon dependency
- Remove Phonon dependency from BuildRequires

==== kollision ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kollision-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kolourpaint ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kolourpaint-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== konquest ====
Version update (18.08.2 -> 18.08.3)
Subpackages: konquest-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kpackage ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kpackage-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Capture package metadata before install start
* Use new categories
* Call reserve() on Qt containers if fill size is known before

==== kparts ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Unbreak build, remove accidentally added code
* Remove duplicated include
* Include own header first
* Use more explicit with internal classes
* Fix Cancel being not handled in deprecated BrowserRun::askEmbedOrSave
* Port to undeprecated variant of KRun::runUrl
* Port KIO::Job::ui() -> KJob::uiDelegate()
* Use normalized signature with Q_ARG
* Add missing "emit"

==== kpat ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kpat-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Make sure the card we're trying to automove is the top of the pile

==== kpeople5 ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kpeople5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kplotting ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kpty ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kqtquickcharts ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== krdc ====
Version update (18.08.2 -> 18.08.3)
Subpackages: krdc-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kreversi ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kreversi-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== krfb ====
Version update (18.08.2 -> 18.08.3)
Subpackages: krfb-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kross ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kross-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== krunner ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Use new syntax

==== kservice ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kservice-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Use more explicit constructors with internal classes
* Use Q_OBJECT with all QObject subclasses (helps debugging introspection)
* Do not use const reference for enum type argument in internal API
* Use const ref for non-trivial copy types in internal API
* Use QLatin1String method overload instead of creating a temporary QString
* Use QStringLiteral, not QLatin1String, if a final QString is wanted
* Use QLatin1String, not QString::fromLatin1, in string calculations
* Use qEnvironmentVariableIntValue

==== kshisen ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kshisen-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ksirk ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ksirk-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kspaceduel ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kspaceduel-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ksquares ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ksquares-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ksudoku ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ksudoku-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ksystemlog ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ksystemlog-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kteatime ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kteatime-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ktexteditor ====
Version update (5.51.0 -> 5.52.0)
Subpackages: ktexteditor-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused variables
* Fix minor EBN issues and typos
* Fix align of doxygen comments in templates
* Use normalized signatures with SIGNAL(), SLOT(), Q_ARG(), Q_RETURN_ARG()
* Remove duplicated includes
* Use more explicit constructors with internal classes
* Remove double underscore (__) from header include guards
* Minor: Cleanup some code

==== ktextwidgets ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Reorder + use Q_OBJECT when necessary

==== ktimer ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ktimer-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ktouch ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ktouch-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ktuberling ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ktuberling-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kturtle ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kturtle-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kubrick ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kubrick-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Add OARS to Kubrick

==== kunitconversion ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== kwallet ====
Version update (5.51.0 -> 5.52.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused variable

==== kwayland ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Fix build with Qt <5.10 (no support for QCOMPARE(uint, int)
* Add KWayland virtual desktop protocol
* Add unit test for subsurface input mask detection
* Guard data source being deleted before processing dataoffer receive event
(kde#400311)
* [server] Respect input region of sub-surfaces on pointer surface focus
* [test/xdgtest] Create/destroy popup on click
* [xdgshell] Add positioner constraint adjustment flag operators

==== kwidgetsaddons ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Have more include guards match file the name
* Include own header first
* Include own _p header as second
* API dox: fix typo
* Use more explicit constructors with internal classes
* API dox: fix "Since" note of KPageWidgetItem::isHeaderVisible
* Use more new style connect()
* Do not mix const & non-const iterators
* Use normalized signatures with Q_ARG()
* Do not return a value in a void function
* Use Q_OBJECT with all QObject subclasses (helps debugging introspection)
* Use QString::remove(foo) over QString::replace(foo, "")
* Use emit properly and for all signals
* More const ref arg passing
* Use QString(), not QStringLiteral("") (where isNull() not relevant)
* add a new property headerVisible
* Remove unused variables
* Call reserve() on Qt containers if fill size is known before

==== kwindowsystem ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* don't assign variable to itself
* Add categories file here
* Use qEnvironmentVariableIsEmpty
* Remove unused variable
* Do not compare iterators returned from two separate returned copies
* Call reserve() on Qt containers if fill size is known before

==== kwordquiz ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kwordquiz-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kxmlgui ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused variables
* Take 1..n KMainWindows in kRestoreMainWindows
* Remove "void" as function argument
* Have include guard match header file name
* Include own header first
* Use single char for concat with QByteArray, not a string
* Use more explicit constructors with internal classes
* Use QStringLiteral if a final QString is wanted
* Use value argument for QLatin1String type in internal API
* Use more const ref with arguments in internal API
* Add missing "emit"
* Do not return void values in void methods
* Use Q_OBJECT with all QObject subclasses (helps debugging introspection)
* KAboutApplicationDialog: fix typo in apidox
* Add categories file
* Remove unused variable

==== kxmlrpcclient5 ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== libKF5ModemManagerQt ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Create own categories file

==== libKF5NetworkManagerQt ====
Version update (5.51.0 -> 5.52.0)

- Add patches that remove some new settings on Leap 42.3 (that
would require a newer NetworkManager) to fix the build:
* 0001-Revert-Add-missing-ipv4-setting-options.patch
* 0001-Revert-Add-vxlan-setting.patch
- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused variable
* Add missing ipv4 setting options
* Add vxlan setting
* Create own categories file

==== libgit2 ====
Version update (0.27.5 -> 0.27.7)

- libgit2 0.27.7:
* Various improvements for handling repositories
* Various API correctness fixes
- includes changess from 0.27.6:
* Various security fixes for parsing integers from buffers,
and buffer handling bsc#1114729

==== libinput ====
Version update (1.12.2 -> 1.12.3)
Subpackages: libinput-udev libinput10

- Update to new upstream release 1.12.3
* A new quirk "AttrEventCodeDisable" was added

==== libkdegames ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdegames-carddecks-default libkdegames-lang libkf5kdegames6

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkeduvocdocument ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKEduVocDocument5 libkeduvocdocument-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkmahjongg ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5KMahjongglib5 libkmahjongg-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libmspack ====
Version update (0.8 -> 0.9.1)

- Update to version 0.9.1:
* Fix bug in decompressing data to get to the correct folder
offset when the folder is LZX compressed (0.8 regression).
* Build system cleanup
* Testsuite available
* Does not install testing tools and examples by default.
- Rename mspack-tools to mspack-examples to follow upstream change.

==== libreoffice ====
Subpackages: libreoffice-branding-upstream libreoffice-calc libreoffice-draw
libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3
libreoffice-icon-themes libreoffice-impress libreoffice-l10n-cs
libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el libreoffice-l10n-en
libreoffice-l10n-en_GB libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN
libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-qt5 libreoffice-writer libreofficekit

- bsc#1112112 - LO-L3: [PPTX] SmartArt: Basic rendering of several list types
* bsc1112112.patch
- bsc#1110348 LO-L3: [PPTX] Charts having weird/darker/ugly background versus
Office 365 and strange artefacts where overlapping
* bsc1110348.patch

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-gluster libvirt-daemon-driver-storage-iscsi
libvirt-daemon-driver-storage-iscsi-direct
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-lxc libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- libxl: add support for soft reset
14d03b27-libxl-rm-redundant-virObjectEventStateQueue.patch,
82452a5d-libxl-rm-goto-libxlDomainShutdownThread.patch,
da4b0fd9-libxl-support-soft-reset.patch
bsc#1081516

==== lirc ====
Version update (0.9.4c -> 0.10.1)

- Update to version 0.10.1
* mode2: Fix inconsistent loglevel/debug option (#307).
* build: install media/lirc.h (Debian BTS #872074).
* build: Fix make "always build all" error - c6eb8ec.
* plugins: devinput: Fix glob "no match" error - 14685b2.
version 0.10.0
* lib/curl_poll.h: Fix header guard build error on müsl libc.
* Build: Mute libtool when V=0, typo.
* Update driver version info.
version 0.10.0-rc3
* lircmd: Fix bogus, excessive logging using --uinput (#295).
* Build: VPATH fixes (#294).
* Build: kfreebsd debian builds fixes.
* python tests: Portability fixes for in python-pkg/test.
* Unit tests in test/ dir: Portability fixes and some docs.
version 0.10.0-rc2
* Fixed lirc-setup fail-on-start (#290).
* Make python unit tests work on Debian (#289).
* Fix mode2 config file parsing [292].
* Documentation update.
* Build fixes.
version 0.10.0rc1
* ftdi driver: Fix off-by-2 timings (#275). This is a breaking
change, see ftdi driver docs or source at doc/plugins/ftdi.html.
* doc: The lirc.hwdb parsable driver list is deprecated - use
the python database or the configs/*.yaml files instead.
* lircd: the deprecated --uinput option is dropped. Use
the lircd-uinput(8) daemon instead.
* lircd: The --release option is deprecated.
* lircd: Adding a --immediate-init option which initiates
the hardware directly on start and exits on errors.
* lircd, lircd-uinput: Change default release suffix due to linux
kernel changes (#263).
* plugins: The slinke (a. k. a. slink-e) driver is dropped.
* plugins: Add support for irdroid in the irtoy driver.
* plugins: Enhanced device enumeration, mode2 --list-devices
works for most drivers.
* plugins: devinput driver: Fix bad codelength (#263).
* New, shiny (i. e., unstable) python API. See the API docs,
module "python bindings". The API is also available as a pypi
package, typically at /usr/share/lirc/python-pkg
* lircd-uinput: Multiple config file parsing errors (#284).
* lib: Added enumeration support and server version level check
to driver API.
* irrecord: Add --driver-options for lircd symmetry (#277).
* lircd: Fix devices not connected at first attempt (#279).
* lib: Fix failure when parsing absolute paths config files (#281).
* lircd/irsend: Fix bug when sending/receiving concurrently for
some remotes (#278, 5 pages!)
* lircd:Fix missing systemd support due to upstream changes (#274).
* The configs/*conf files no more supports enumerating devices
using shell scripts.
* Build: Added new configure --enable-devinput option (#264).
* Build: Added new configure --enable-uinput option, ditched
the HAVE_UINPUT 0.9.4c kludge.
* Build: More quiet, enhanced V=0/V=1 support.
* Build: OSX patches(#273)
version 0.9.4d
* The debian packaging means that freebsd and hurd builds are
regularly tested, improving build stability.
* A multitude of build patches, mostly after building on Debian:
+ Cross-compilation FTBS fixed (#233)
+ Fix configuration of configure (#234)
+ Fix library specification in lirc.pc (#236)
+ use HAVE_UINPUT=1 to force building uinput code (#238).
+ lib: Only use local headers in lirc_private.h (#237).
+ Configure libudev (#242)
+ Various kfreebsd fixes
+ Include config.h in installed headers (#250).
+ Fix _XOPEN_SOURCE related FTBS on some platforms (#248)
* lib: Fix some lircrcd-related bugs (#254)
* systemd: Fix wrong path to irexec (#239)
* systemd: Add missing lircd-setup.service to distribution (#243)
* lircd: Fix --listen option parsing [#249]
* lircd: Fix segfault in SET_INPUTLOG without arguments (#252)
* lircd: Fix DRV_OPTION error message handling (#256).
* ircat: Fix option parsing bug + empty conditions (#251)
* xmode2: Fix handling of --driver option.
- Dropped
lirc-lib-curl_poll.h-Ensure-build-on-unconfiguredclients.patch
and lirc-configure-libudev.patch (merged upstream)
- Spec cleanup

==== lokalize ====
Version update (18.08.2 -> 18.08.3)
Subpackages: lokalize-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== lskat ====
Version update (18.08.2 -> 18.08.3)
Subpackages: lskat-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== mbox-importer ====
Version update (18.08.2 -> 18.08.3)
Subpackages: mbox-importer-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== nano ====
Version update (3.1 -> 3.2)
Subpackages: nano-lang

- GNU nano 3.2:
* binding changes and renames
* python 3 highlighting improvements
* don't define controldelete or controlshitfdelete in tiny version
* removed some old debugging code

==== oxygen5-icon-theme ====
Version update (5.51.0 -> 5.52.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== parley ====
Version update (18.08.2 -> 18.08.3)
Subpackages: parley-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== pcre ====
Subpackages: libpcre1 libpcre1-32bit libpcre16-0 libpcrecpp0 libpcreposix0
pcre-devel

- pcreposix patch taken from debian. Solves cyrus-imapd issue #1731, too.
pcre-8.42-pcreposix.patch

==== perl-DBI ====
Version update (1.641 -> 1.642)

- updated to 1.642
see /usr/share/doc/packages/perl-DBI/Changes
=head2 Changes in DBI 1.642 - 28th October 2018
Fix '.' in @INC for proxy test under parallel load
thanks to H.Merijn Brand.
Fix driver-related croak() in DBI->connect to report the original DSN
thanks to maxatome #67
Introduce a new statement DBI method $sth->last_insert_id()
thanks to pali #64
Allow to call $dbh->last_insert_id() method without arguments
thanks to pali #64
Added a new XS API function variant dbd_db_do6()
thanks to Pali #61
Fix misprints in doc of selectall_hashref
thanks to Perlover #69
Remove outdated links to DBI related training resources. RT#125999

==== perl-DateTime-Locale ====
Version update (1.220000 -> 1.230000)

- updated to 1.23
see /usr/share/doc/packages/perl-DateTime-Locale/Changes
1.23 2018-10-17
- Rebuilt all locale data with CLDR 34, released on 2018-10-15.

==== perl-Error ====
Version update (0.17026 -> 0.17027)

- updated to 0.17027
see /usr/share/doc/packages/perl-Error/Changes
0.17027 2018-10-28
- Documentation and examples enhancements.
-
https://bitbucket.org/shlomif/perl-error.pm/pull-requests/1/october-prc-some-minor-mostly-doc-changes/diff
- Thanks to https://metacpan.org/author/JMERELO .

==== perl-Specio ====
Version update (0.42 -> 0.43)

- updated to 0.43
see /usr/share/doc/packages/perl-Specio/Changes
0.43 2018-10-26
- Optimized compile-time operations to make Specio itself quicker to
load. Specio's load time is a non-trivial part of the load time of DateTime
(and presumably other things that use it). Based on
https://github.com/houseabsolute/DateTime.pm/issues/85. Reported by
versable.

==== perl-XML-XPath ====
Version update (1.42 -> 1.44)

- updated to 1.44
see /usr/share/doc/packages/perl-XML-XPath/Changes
1.44 2018-10-11 MANWAR
- Added new test for axis descendant.
1.43 2018-10-10 MANWAR
- Fix memory leak in XML::XPath::Parser (PR #6), Thanks @niner.

==== perl-YAML ====
Version update (1.26 -> 1.27)

- updated to 1.27
see /usr/share/doc/packages/perl-YAML/Changes
1.27 Sat Nov 3 14:01:26 CET 2018
- Remove a warning about uninitialized value for perl <= 5.10

==== perl-libwww-perl ====
Version update (6.35 -> 6.36)

- updated to 6.36
see /usr/share/doc/packages/perl-libwww-perl/Changes
6.36 2018-10-10 02:20:58Z
- fix broken link https://metacpan.org/pod/LWP::Simple by fixing pod
header (thanks for the report, traumschule!)

==== pim-data-exporter ====
Version update (18.08.2 -> 18.08.3)
Subpackages: pim-data-exporter-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== pim-sieve-editor ====
Version update (18.08.2 -> 18.08.3)
Subpackages: pim-sieve-editor-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Get result when we close tab

==== plasma-framework ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Remove unused variables
* revert icons scaling on mobile
* Fix minor EBN issues and typos
* Support mnemonic labels
* Remove PLASMA_NO_KIO option
* proper color group for icons
* center text when no icon
* smaller dots
* Reduce double and triple lookups to the frames hash
* No point in including an empty foreach when NDEBUG isn't defined
* Properly look for fallback themes

==== prison-qt5 ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Use new syntax

==== purpose ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Reuse resultMap instead of converting to map two times more
* Remove unused variable
* Set Dialog flag for JobDialog

==== qqc2-desktop-style ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* No code changes since 5.51.0

==== rpcbind ====
Version update (0.2.4 -> 1.2.5)

- update to current upstream version 1.2.5 (bsc#1113002)
* move procinfo from /sbin to /bin and create a symlink in /sbin
* remove obsolete svc-freeargs.patch (included in the sources now)

==== ruby2.5 ====
Version update (2.5.1 -> 2.5.3)
Subpackages: libruby2_5-2_5 ruby2.5-devel ruby2.5-stdlib

- update to 2.5.3
This release includes some bug fixes and some security fixes.
- CVE-2018-16396: Tainted flags are not propagated in Array#pack
and String#unpack with some directives
- CVE-2018-16395: OpenSSL::X509::Name equality check does not
work correctly
https://github.com/ruby/ruby/compare/v2_5_1...v2_5_3
- drop frozen-pop3.patch

==== signon-kwallet-extension ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== solid ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* [solid-hardware5] List icon in device details
* Add DEFAULT_SEVERITY
* [UDisks2] Power down drive on remove if supported (kde#270808)

==== sonnet ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Use reserve() on QStringList
* Fix breakage of language guessing
* Another 0 -> nullptr

==== step ====
Version update (18.08.2 -> 18.08.3)
Subpackages: step-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== susefirewall2-to-firewalld ====
Version update (0.0.3 -> 0.0.4)

- Version bump to 0.0.4
* Add input and forward zone to the known ones (bsc#1115001)
* Stop guessing firewall service from port/proto

==== sweeper ====
Version update (18.08.2 -> 18.08.3)
Subpackages: sweeper-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== syndication ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Add missing README.md file (needed by various scripts)

==== syntax-highlighting ====
Version update (5.51.0 -> 5.52.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* z/OS CLIST file syntax highlighting
* Creating new syntax highlighting file for Job Control Language (JCL)
* remove open mode from too new Qt version
* inc version + fixup required kate version to current framework version
* keyword rule: Spport for keywords inclusion from another language/file
* add test file + remove no longer existing instructions reference from xml
* Improve R documentation highlighting
* No spell checking for Metamath except in comments
* CMake: Add XCode related variables and properties introduced in 3.13
* CMake: Introduce new features of upcoming 3.13 release
* Use new syntax

==== systemd ====
Version update (237 -> 239)
Subpackages: libsystemd0 libsystemd0-32bit libudev-devel libudev1
libudev1-32bit systemd-32bit systemd-coredump systemd-logger systemd-sysvinit
udev

- Make systemd-mini-sysvinit provides systemd-sysvinit
Some packages (such as shepherd-bins) want to conflicts with
systemd-sysvinit: they should also conflict with
systemd-mini-sysvinit.
- Add 0001-logind-keep-backward-compatibility-with-UserTasksMax.patch
We have to keep support for UserTasksMax= for a while before
dropping it. This patch is supposed to do that and also to make
users aware of this change. It also hints how to configure that
differently.
- Import commit f39674d6d114d999c50672c7bea8cad21e1eaed9
7d1e04e85 units: use =yes rather than =true everywhere
185ce0d34 units: assign user-runtime-dir@.service to user-%i.slice
a051f5e41 units: make sure user-runtime-dir@.service is Type=oneshot
30c6842c3 units: set StopWhenUnneeded= for the user slice units too
e74de046e login: fix typo in log message
- Own %{_libexecdir}/modules-load.d (again)
This was incorrectly dropped during the split of the SUSE specific
configurations.
- Drop a Conflicts: in systemd-coredump
It not needed anymore since the mini variant of systemd-coredump is
not built anymore.
- Import commit b54f5d7a8b41898ce98f43cd1a6cc92c0071806d
5def29d24 coredump: only install coredump.conf when ENABLED_COREDUMP=true
9133e2d6e dhcp6: make sure we have enough space for the DHCP6 option header
(bsc#1113632 CVE-2018-15688)
ebc3fa418 dhcp6: split assert_return() to be more debuggable when hit
51eefb6ac chown-recursive: let's rework the recursive logic to use O_PATH
(bsc#1113666 CVE-2018-15687)
e1e1aa237 core: skip unit deserialization and move to the next one when
unit_deserialize() fails
1c726c87d core: when deserializing state always use read_line(?,
LONG_LINE_MAX, ?) (bsc#1113665 CVE-2018-15686)
4cd7d11ac core: don't create Requires for workdir if "missing ok"
(bsc#1113083)
- Make systemd-coredump sub-package optional
and don't build the mini variant.
- Drop duplicated %{?mini} suffix for systemd-{container,coredump} subpackages
"-mini" is already part of the name of the main package so there's
no need to append it again for those sub packages. It's only needed
when the name of a subpackage is completely redefined, IOW when '-n'
option is used with the %package directive.
- Dont ship /usr/sbin/resolvconf symlink for now
It conflicts with the bin shipped by openresolv and provides
limited compat only.
- Upgrade to v239 (commit 6d8584e7e8e5d13d2bab49b9e6f6d2ec39759978)

==== threadweaver ====
Version update (5.51.0 -> 5.52.0)

- Update to 5.52.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.52.0.php
- Changes since 5.51.0:
* Fix minor EBN issues and typos

==== tracker ====
Version update (2.1.5 -> 2.1.6)
Subpackages: libtracker-common-2_0 libtracker-control-2_0-0
libtracker-miner-2_0-0 libtracker-sparql-2_0-0 tracker-lang
typelib-1_0-Tracker-2_0 typelib-1_0-TrackerControl-2_0

- Add tracker-sqlte-3.25-rename-tables.patch: drop FTS table/view
before ontology update (glgo#GNOME/tracker#40, boo#1110090)
- Update to version 2.1.6:
+ Backported multiple meson build fixes.
+ Fixed meson build from released tarball.
+ Updated translations.

==== umbrello ====
Version update (18.08.2 -> 18.08.3)
Subpackages: umbrello-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fixup of commit af72e05 (kde#400501)
* Fixes broken docbook URLs when creating xhtml (kde#400657)
* Make it possible to run docbook export from build dir
* Fix 'Umbrello fails to start due to ASSERT failure in QVector<T>::at "index
out of range"' (kde#400501)

==== upower ====
Version update (0.99.8 -> 0.99.9)
Subpackages: libupower-glib3 typelib-1_0-UpowerGlib-1_0 upower-lang

- Update to version 0.99.9:
+ Fix lack of update after AC status changes, and broken keyboard
backlight, following the daemon lockdown added in 0.99.8.
+ Multiple API documentation fixes.
+ Out-of-tree build fixes.
- Drop patches fixed upstream:
+ upower-remove-privatenetwork.patch.
+ upower-fix-keyboard-backlight.patch.

==== util-linux ====
Subpackages: libblkid-devel libblkid1 libblkid1-32bit libfdisk1 libmount1
libmount1-32bit libsmartcols1 libuuid-devel libuuid1 libuuid1-32bit
util-linux-lang

- Fix runstatedir path (to /run) (boo#1113188#c1).
- Create empty /etc/issue.d for the new agetty feature.
- Drop obsolete downstream ppc utilities
chrp-addnote and mkzimage_cmdline (boo#1109284).
- Drop obsolete setctsid (boo#1109290).

==== util-linux-systemd ====

- Fix runstatedir path (to /run) (boo#1113188#c1).
- Create empty /etc/issue.d for the new agetty feature.
- Drop obsolete downstream ppc utilities
chrp-addnote and mkzimage_cmdline (boo#1109284).
- Drop obsolete setctsid (boo#1109290).

==== xen ====
Subpackages: xen-libs xen-tools xen-tools-domU

- make package build reproducible (boo#1047218, boo#1062303)
* Set SMBIOS_REL_DATE
* Update tmp_build.patch to use SHA instead of random build-id
* Add reproducible.patch to use --no-insert-timestamp


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages