Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20181112 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20181112

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
SDL2 (2.0.8 -> 2.0.9)
akonadi-calendar (18.08.2 -> 18.08.3)
akonadi-calendar-tools (18.08.2 -> 18.08.3)
akonadi-contact (18.08.2 -> 18.08.3)
akonadi-import-wizard (18.08.2 -> 18.08.3)
akonadi-mime (18.08.2 -> 18.08.3)
akonadi-notes (18.08.2 -> 18.08.3)
akonadi-search (18.08.2 -> 18.08.3)
akonadi-server (18.08.2 -> 18.08.3)
akregator (18.08.2 -> 18.08.3)
ark (18.08.2 -> 18.08.3)
baloo5-widgets (18.08.2 -> 18.08.3)
calendarsupport (18.08.2 -> 18.08.3)
cronie
device-mapper
dolphin (18.08.2 -> 18.08.3)
dragonplayer (18.08.2 -> 18.08.3)
ethtool (4.18 -> 4.19)
eventviews (18.08.2 -> 18.08.3)
evolution
freecell-solver (4.18.0 -> 5.0.0)
gegl (0.4.8 -> 0.4.12)
gimp (2.10.6 -> 2.10.8)
gnome-maps (3.30.2 -> 3.30.2.1)
grantleetheme (18.08.2 -> 18.08.3)
guile
gwenview5 (18.08.2 -> 18.08.3)
hdf5
hwinfo (21.61 -> 21.62)
incidenceeditor (18.08.2 -> 18.08.3)
kaccounts-integration (18.08.2 -> 18.08.3)
kaccounts-providers (18.08.2 -> 18.08.3)
kaddressbook (18.08.2 -> 18.08.3)
kalarmcal (18.08.2 -> 18.08.3)
kamera (18.08.2 -> 18.08.3)
kate (18.08.2 -> 18.08.3)
kcalc (18.08.2 -> 18.08.3)
kcalcore (18.08.2 -> 18.08.3)
kcalutils (18.08.2 -> 18.08.3)
kcharselect (18.08.2 -> 18.08.3)
kcolorchooser (18.08.2 -> 18.08.3)
kcontacts (18.08.2 -> 18.08.3)
kdav (18.08.2 -> 18.08.3)
kdenetwork4-filesharing (18.08.2 -> 18.08.3)
kdepim-addons (18.08.2 -> 18.08.3)
kdepim-apps-libs (18.08.2 -> 18.08.3)
kdepim-runtime (18.08.2 -> 18.08.3)
kdialog (18.08.2 -> 18.08.3)
kernel-source (4.18.15 -> 4.19.1)
kglobalaccel
khelpcenter5 (18.08.2 -> 18.08.3)
kidentitymanagement (18.08.2 -> 18.08.3)
kimap (18.08.2 -> 18.08.3)
kio-extras5 (18.08.2 -> 18.08.3)
kio_audiocd (18.08.2 -> 18.08.3)
kitinerary (18.08.2 -> 18.08.3)
kldap (18.08.2 -> 18.08.3)
kleopatra (18.08.2 -> 18.08.3)
kmag (18.08.2 -> 18.08.3)
kmail (18.08.2 -> 18.08.3)
kmail-account-wizard (18.08.2 -> 18.08.3)
kmailtransport (18.08.2 -> 18.08.3)
kmbox (18.08.2 -> 18.08.3)
kmime (18.08.2 -> 18.08.3)
kmousetool (18.08.2 -> 18.08.3)
knotes (18.08.2 -> 18.08.3)
kompare (18.08.2 -> 18.08.3)
konsole (18.08.2 -> 18.08.3)
kontact (18.08.2 -> 18.08.3)
kontactinterface (18.08.2 -> 18.08.3)
kopete (18.08.2 -> 18.08.3)
korganizer (18.08.2 -> 18.08.3)
kpimtextedit (18.08.2 -> 18.08.3)
kpkpass (18.08.2 -> 18.08.3)
kruler (18.08.2 -> 18.08.3)
ksmtp (18.08.2 -> 18.08.3)
ktnef (18.08.2 -> 18.08.3)
kvm_stat (4.17.10 -> 4.19.1)
kwalletmanager5 (18.08.2 -> 18.08.3)
libgravatar (18.08.2 -> 18.08.3)
libkcddb (18.08.2 -> 18.08.3)
libkcompactdisc (18.08.2 -> 18.08.3)
libkdcraw (18.08.2 -> 18.08.3)
libkdepim (18.08.2 -> 18.08.3)
libkexiv2 (18.08.2 -> 18.08.3)
libkgapi (18.08.2 -> 18.08.3)
libkipi (18.08.2 -> 18.08.3)
libkleo (18.08.2 -> 18.08.3)
libkomparediff2 (18.08.2 -> 18.08.3)
libksane (18.08.2 -> 18.08.3)
libksieve (18.08.2 -> 18.08.3)
libyui-qt-pkg (2.45.22 -> 2.45.24)
linux-glibc-devel (4.18 -> 4.19)
lvm2
mailcommon (18.08.2 -> 18.08.3)
mailimporter (18.08.2 -> 18.08.3)
mercurial (4.7.2 -> 4.8)
messagelib (18.08.2 -> 18.08.3)
mobipocket (18.08.2 -> 18.08.3)
ncurses
okular (18.08.2 -> 18.08.3)
open-vm-tools (10.3.0 -> 10.3.5)
openldap2
perl-Clone (0.39 -> 0.41)
perl-Cpanel-JSON-XS (4.06 -> 4.07)
perl-DBD-CSV (0.53 -> 0.54)
perl-DBD-ODBC (1.59 -> 1.60)
perl-IO-Socket-SSL
perl-Math-BigInt (1.999813 -> 1.999816)
perl-Math-BigInt-GMP (1.6005 -> 1.6006)
php7 (7.2.11 -> 7.2.12)
pimcommon (18.08.2 -> 18.08.3)
python-M2Crypto (0.30.1 -> 0.31.0)
python-boto3
python-botocore
python-pycurl
python-requests
rubygem-passenger (5.3.5 -> 5.3.7)
shadow
spectacle (18.08.2 -> 18.08.3)
subversion (1.10.3 -> 1.11.0)
vim (8.1.0479 -> 8.1.0503)
x11-tools
yast2-country (4.1.0 -> 4.1.1)

=== Details ===

==== SDL2 ====
Version update (2.0.8 -> 2.0.9)

- Update to version 2.0.9
* Added a new sensor API, initialized by passing
SDL_INIT_SENSOR to SDL_Init(), and defined in SDL_sensor.h
* Added an event SDL_SENSORUPDATE which is sent when a sensor
is updated
* Added SDL_GetDisplayOrientation() to return the current
display orientation
* Added an event SDL_DISPLAYEVENT which is sent when the
display orientation changes
* Added HIDAPI joystick drivers for more consistent support
for Xbox, PS4 and Nintendo Switch Pro controller support
across platforms. (Thanks to Valve for contributing the PS4
and Nintendo Switch Pro controller support)
* Added support for many other popular game controllers
* Added SDL_JoystickGetDevicePlayerIndex(),
SDL_JoystickGetPlayerIndex(), and
SDL_GameControllerGetPlayerIndex() to get the player index for
a controller. For XInput controllers this returns the XInput
index for the controller.
* Added SDL_GameControllerRumble() and SDL_JoystickRumble()
which allow simple rumble without using the haptics API
* Added SDL_GameControllerMappingForDeviceIndex() to get the
mapping for a controller before it's opened
* Added the hint SDL_HINT_MOUSE_DOUBLE_CLICK_TIME to control
the mouse double-click time
* Added the hint SDL_HINT_MOUSE_DOUBLE_CLICK_RADIUS to control
the mouse double-click radius, in pixels
* Added SDL_HasColorKey() to return whether a surface has a
colorkey active
* Added SDL_HasAVX512F() to return whether the CPU has
AVX-512F features
* Added SDL_IsTablet() to return whether the application is
running on a tablet
* Added SDL_THREAD_PRIORITY_TIME_CRITICAL for threads that
must run at the highest priority
* Added SDL_LinuxSetThreadPriority() to allow adjusting the
thread priority of native threads using RealtimeKit if
available.
- Dropped 7babfecee045.patch (merged upstream)

==== akonadi-calendar ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== akonadi-calendar-tools ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-calendar-tools-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== akonadi-contact ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== akonadi-import-wizard ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== akonadi-mime ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== akonadi-notes ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== akonadi-search ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== akonadi-server ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fix StorageJanitor SQL error in duplicate detection
* Fix KOrg category color customization crash (kde#398459)

==== akregator ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akregator-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ark ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ark-lang libkerfuffle18

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Disable Compress menu on remote URLs
* Show 'Extract' menu on archives without extension (kde#399806)

==== baloo5-widgets ====
Version update (18.08.2 -> 18.08.3)
Subpackages: baloo5-widgets-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== calendarsupport ====
Version update (18.08.2 -> 18.08.3)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== cronie ====
Subpackages: cron

- cronie-pam_config.diff: When crond is started with the -n
switch like it does with systemd, the manual explicitly
instructs to disable the pam_loginuid module.

==== device-mapper ====
Subpackages: libdevmapper-event1_03 libdevmapper1_03 libdevmapper1_03-32bit

- Prevent writing beyond metadata area (bsc#1114113)
+ bug-1114113_metadata-prevent-writing-beyond-metadata-area.patch

==== dolphin ====
Version update (18.08.2 -> 18.08.3)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Don't enable two-clicks renaming in single-click mode
* [KStandardItemListWidget] Pass icon state to overlay painter
* Update hidden state correctly (kde#399599)

==== dragonplayer ====
Version update (18.08.2 -> 18.08.3)
Subpackages: dragonplayer-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fix: user settings for gui not saved after program is closed (kde#376961)

==== ethtool ====
Version update (4.18 -> 4.19)

- Update to new upstream release 4.19
* Feature: support combinations of FEC modes
* Fix: unitialized variable in qsfp dump

==== eventviews ====
Version update (18.08.2 -> 18.08.3)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Eventviews: properly fall back to color-generator if ColorAttribute is
absent
* Eventviews: simplify/modernize resource color code
* Fix color inconsistency for unset categories. (kde#382185)
* Factor out coloring from AgendaItem::paintEvent.

==== evolution ====
Subpackages: evolution-lang evolution-plugin-bogofilter
evolution-plugin-pst-import evolution-plugin-spamassassin

- Restore pkgconfig(libnotify) as BuildRequires.
Fixes: boo#1115189

==== freecell-solver ====
Version update (4.18.0 -> 5.0.0)
Subpackages: freecell-solver-presets libfreecell-solver0

- Update to 5.0.0
* Add the gen-multiple-pysol-layouts executable to generate
several numbered deals as separate files.
* Rename the AsciiDoc documents
* userland headers can now only be used with #include
<freecell-solver/$headerName>
- Drop fix-rpmlint-errors.patch. Fixed upstream

==== gegl ====
Version update (0.4.8 -> 0.4.12)
Subpackages: gegl-0_4 gegl-0_4-lang libgegl-0_4-0

- Update to version 0.4.12:
+ GeglBuffer: Fix fix of scaled blitting, the fix from last
release introduced scaling artifacts for all formats that are
non-8bit.
- Changes from version 0.4.10:
+ GeglBuffer:
- Fix integer overflow issues for u32 blit scaling code paths.
- Reduced memory clearing overhead for temporary buffers during
blit.
- Round alpha component during u8 bilinear/box filtering.
- gegl_buffer_dup now matches source buffer abyss, shift and
tile-size more closely.
- Added GEGL_TILE_COPY command for backends, for more efficient
buffer duplication/copies.
- New GeglBufferIterator API.
- Move type-generic scaling algorithms to GeglBuffer folder,
move opencl integration bits out of buffer.
+ Operations:
- gif-load: new operation for decoding GIF images/animations,
with frame delay exposed as an out-property.
- exr-save: do not hard-code a version name space.
- long-shadow: add 'Fading (fixed length)' style with a new
user-defined 'Midpoint' parameter.
- maniuk06: use double precision, permitting to work on larger
images.
- watershed-transform: improved description.
- unsharp-mask: permit std-dev radius of up to 1500px (from
300).
- Updated all operations to use new iterator API.

==== gimp ====
Version update (2.10.6 -> 2.10.8)
Subpackages: gimp-lang gimp-plugin-aa gimp-plugins-python libgimp-2_0-0
libgimpui-2_0-0

- Update to vesion 2.10.8:
+Core:
- Use adaptive chunk size in GimpProjectio nwhen rendering the
projection asynchronously, rather than using a fixed chunk size.
This provides a better trade-off between throughput and
responsiveness dynamically, based on how fast the processing is.
+Tools:
- In all selection tools, show error on attempt to
subtract-from/intersect-with empty selection.
- Fix text along path not working with vertical text.
- Fix Text tool's frame position when undoing a move operation.
- Streamline Text tool's drawing blocking/unblocking logic.
- When moving a text layer using the text tool (through alt-drag),
don't change the layer's box mode to "fixed", which is unnecessary,
since the layer's size isn't affected.
- Transform and deformation operations now maintain color for fully
transparent pixels, making unerase and curves manipulation of alpha
channel more reliable.
- All transform tools now apply changes when you asve or export/overwrite
an image without pressing Enter first to confirm changes.
- Heal, Dodge/Burn, Smudge and Convovle tools now adjust the processed
buffer and mask_buffer regions according to the changes made to the
application region, as calculated by intersecting it with the
drawable and mask extents. This fixes wrong application position
when painting on a drawable whose origin is above/to the left of the
image's origin, and there's a selection active.
+Plug-ins:
- Port all plug-ins to the new iterator API in GEGL.
- Improve automatic detection of HEIC/HEIF files.
- Improve RawTherapee discovery by looking up registry key (should
become useful with RawTherapee 5.5 and more).
+Usability:
- Compatibility information in the Save dialog is now more understandable.
The minimum GIMP version for the XCD file is always written down when it
is GIMP 2.8 or over. The list of features warranting the minimum version
is now listed in an expander container rather than as tooltip, which
makes it more discoverable. The warning on compression is now displayed
as its own text under the checkbox and not as additional text to the
minimum GIMP version label.
+CLI:
- New self-explanatory --enable-win32-debug-console CLI option
+Translations:
- Updated translations: Danish, Dutch, Finnish, German, Hungarian,
Italian, Polish, Portugese (Brazil), Spanish, Swedish, Ukranian.

==== gnome-maps ====
Version update (3.30.2 -> 3.30.2.1)
Subpackages: gnome-maps-lang

- Update to version 3.30.2.1:
+ Fix version number in release tarball (3.30.2 was missing
update of meson.build).
+ Updated translations.

==== grantleetheme ====
Version update (18.08.2 -> 18.08.3)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== guile ====
Subpackages: guile-modules-2_0 libguile-2_0-22

- Apply guile-use-utf8.patch to fix use of the "ja_JP.sjis" locale.
[bsc#1110085]
- Apply guile-add-test-ja_JP.sjis.patch to add standalone test that
verifies the "ja_JP.sjis" locale works properly. Further details
at https://debbugs.gnu.org/cgi/bugreport.cgi?bug=33044#43.
[bsc#1110085]

==== gwenview5 ====
Version update (18.08.2 -> 18.08.3)
Subpackages: gwenview5-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== hdf5 ====
Subpackages: libhdf5-103 libhdf5_hl100

- Create main master package, fix dependencies.

==== hwinfo ====
Version update (21.61 -> 21.62)

- merge gh#openSUSE/hwinfo#73
- update pci and usb ids (fate#326431)
- add script to update pci and usb ids
- adjust hwinfo know about RISC-V
- update git2log script
- fix curl commands
- 21.62

==== incidenceeditor ====
Version update (18.08.2 -> 18.08.3)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fix keyboard editing of start/end times of VTODOs (kde#391769)

==== kaccounts-integration ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kaccounts-providers ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kaccounts-providers-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kaddressbook ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kaddressbook-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kalarmcal ====
Version update (18.08.2 -> 18.08.3)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kamera ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kamera-lang kio_kamera

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Set mime type for special text files
* Fix opening special text files
* Add Messages.sh
* Add QCoreApplication

==== kate ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kate-lang kate-plugins

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Open document before using it's checksum to load metainfos (kde#384087)

==== kcalc ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kcalc-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kcalcore ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kcalutils ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kcharselect ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kcharselect-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kcolorchooser ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kcolorchooser-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kcontacts ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdav ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdav-lang libKPimKDAV5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdenetwork4-filesharing ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdenetwork4-filesharing-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdepim-addons ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdepim-addons-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2
- Refreshed patches:
* 0001-Enable-the-expert-plugin-by-default.patch

==== kdepim-apps-libs ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdepim-apps-libs-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kdepim-runtime ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdepim-runtime-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fix Bug 399231 - Kmail uses a low resolution icon for the notification
(kde#399231)

==== kdialog ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kdialog-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kernel-source ====
Version update (4.18.15 -> 4.19.1)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- vt: fix broken display when running aptitude (bnc#1114836).
- commit 5bec309
- doc/README.SUSE: correct GIT url
No more gitorious, github we use.
- commit 31864f3
- Remove Cell/PS3 support from ppc64 kernel (boo#1114846)
- commit c336d64
- rpm/kernel-binary.spec.in: add macros.s into kernel-*-devel
Starting with 4.20-rc1, file arch/*/kernel/macros.s is needed to build out
of tree modules. Add it to kernel-${flavor}-devel packages if it exists.
- commit 09d14c8
- Linux 4.19.1 (bnc#1012628).
- net: bridge: remove ipv6 zero address check in mcast queries
(bnc#1012628).
- sparc64: Wire up compat getpeername and getsockname
(bnc#1012628).
- sparc64: Make corrupted user stacks more debuggable
(bnc#1012628).
- sparc64: Export __node_distance (bnc#1012628).
- sctp: check policy more carefully when getting pr status
(bnc#1012628).
- Revert "be2net: remove desc field from be_eq_obj" (bnc#1012628).
- r8169: fix broken Wake-on-LAN from S5 (poweroff) (bnc#1012628).
- net: Properly unlink GRO packets on overflow (bnc#1012628).
- net: drop skb on failure in ip_check_defrag() (bnc#1012628).
- mlxsw: core: Fix devlink unregister flow (bnc#1012628).
- mlxsw: spectrum_switchdev: Don't ignore deletions of learned
MACs (bnc#1012628).
- net/smc: fix smc_buf_unuse to use the lgr pointer (bnc#1012628).
- net/ipv6: Allow onlink routes to have a device mismatch if it
is the default route (bnc#1012628).
- openvswitch: Fix push/pop ethernet validation (bnc#1012628).
- bonding: fix length of actor system (bnc#1012628).
- vhost: Fix Spectre V1 vulnerability (bnc#1012628).
- rtnetlink: Disallow FDB configuration for non-Ethernet device
(bnc#1012628).
- Revert "net: simplify sock_poll_wait" (bnc#1012628).
- net: udp: fix handling of CHECKSUM_COMPLETE packets
(bnc#1012628).
- net: stmmac: Fix stmmac_mdio_reset() when building stmmac as
modules (bnc#1012628).
- net: sched: gred: pass the right attribute to
gred_change_table_def() (bnc#1012628).
- net/mlx5e: fix csum adjustments caused by RXFCS (bnc#1012628).
- ipv6/ndisc: Preserve IPv6 control buffer if protocol error
handlers are called (bnc#1012628).
- bridge: do not add port to router list when receives query
with source 0.0.0.0 (bnc#1012628).
- commit 57135d7
- rpm: use syncconfig instead of silentoldconfig where available
Since mainline commit 0085b4191f3e ("kconfig: remove silentoldconfig
target"), "make silentoldconfig" can be no longer used. Use "make
syncconfig" instead if available.
- commit a239c6e
- series.conf: more descriptive name for network driver section
We have two networking sections in series.conf: one for networking core and
one for network drivers. The latter is among other driver related sections
but it may not be obvious that it is not intended for core networking
patches. Change the label to "Network drivers" to make its purpose more
apparent.
- commit 7968e32
- config: enable SCSI_AACRAID on ppc64le and ppc64 (bsc#1114523)
- commit 5f3762b
- Refresh
patches.suse/netfilter-bridge-define-INT_MIN-INT_MAX-in-userspace.patch.
Update upstream status.
- commit 37417fa
- cdrom: fix improper type cast, which can leat to information
leak (CVE-2018-18710,bsc#1113751).
- commit 6216efb
- rpm/kernel-binary.spec.in: allow unsupported modules for -extra
(bsc#1111183). SLE-15 and later only.
- commit 0d585a8
- series.conf: move
patches.suse/netfilter-bridge-define-INT_MIN-INT_MAX-in-userspace.patch to
netfilter section
- commit 7656685
- netfilter: bridge: define INT_MIN & INT_MAX in userspace
(4.19 fixes).
- commit e7213f6
- Update to 4.19 final
- Refresh configs
- commit b4c35bb
- Linux 4.18.16 (bnc#1012628).
- ARC: build: Don't set CROSS_COMPILE in arch's Makefile
(bnc#1012628).
- ARC: build: Get rid of toolchain check (bnc#1012628).
- mremap: properly flush TLB before releasing the page
(bnc#1012628).
- Revert "vfs: fix freeze protection in mnt_want_write_file()
for overlayfs" (bnc#1012628).
- x86/boot: Fix kexec booting failure in the SEV bit detection
code (bnc#1012628).
- iommu/amd: Return devid as alias for ACPI HID devices
(bnc#1012628).
- powerpc/numa: Use associativity if VPHN hcall is successful
(bnc#1012628).
- powerpc/tm: Avoid possible userspace r1 corruption on reclaim
(bnc#1012628).
- powerpc/tm: Fix userspace r13 corruption (bnc#1012628).
- pinctrl/amd: poll InterruptEnable bits in amd_gpio_irq_set_type
(bnc#1012628).
- iommu/rockchip: Free irqs in shutdown handler (bnc#1012628).
- RISC-V: include linux/ftrace.h in asm-prototypes.h
(bnc#1012628).
- RDMA/bnxt_re: Fix system crash during RDMA resource
initialization (bnc#1012628).
- clocksource/drivers/fttmr010: Fix set_next_event handler
(bnc#1012628).
- net/mlx4: Use cpumask_available for eq->affinity_mask
(bnc#1012628).
- bpf: test_maps, only support ESTABLISHED socks (bnc#1012628).
- bpf: sockmap, fix transition through disconnect without close
(bnc#1012628).
- bpf: sockmap only allow ESTABLISHED sock state (bnc#1012628).
- scsi: sd: don't crash the host on invalid commands
(bnc#1012628).
- scsi: ipr: System hung while dlpar adding primary ipr adapter
back (bnc#1012628).
- drm: mali-dp: Call drm_crtc_vblank_reset on device init
(bnc#1012628).
- scsi: lpfc: Synchronize access to remoteport via rport
(bnc#1012628).
- RDMA/uverbs: Fix validity check for modify QP (bnc#1012628).
- PCI: dwc: Fix scheduling while atomic issues (bnc#1012628).
- qed: Do not add VLAN 0 tag to untagged frames in multi-function
mode (bnc#1012628).
- qed: Fix populating the invalid stag value in multi function
mode (bnc#1012628).
- net/smc: fix sizeof to int comparison (bnc#1012628).
- net/smc: fix non-blocking connect problem (bnc#1012628).
- ravb: do not write 1 to reserved bits (bnc#1012628).
- net: emac: fix fixed-link setup for the RTL8363SB switch
(bnc#1012628).
- selftests: pmtu: properly redirect stderr to /dev/null
(bnc#1012628).
- Input: atakbd - fix Atari CapsLock behaviour (bnc#1012628).
- Input: atakbd - fix Atari keymap (bnc#1012628).
- intel_th: pci: Add Ice Lake PCH support (bnc#1012628).
- scsi: ibmvscsis: Ensure partition name is properly NUL
terminated (bnc#1012628).
- scsi: ibmvscsis: Fix a stringop-overflow warning (bnc#1012628).
- clocksource/drivers/ti-32k: Add CLOCK_SOURCE_SUSPEND_NONSTOP
flag for non-am43 SoCs (bnc#1012628).
- cxgb4: fix abort_req_rss6 struct (bnc#1012628).
- batman-adv: fix hardif_neigh refcount on queue_work() failure
(bnc#1012628).
- batman-adv: fix backbone_gw refcount on queue_work() failure
(bnc#1012628).
- batman-adv: Prevent duplicated tvlv handler (bnc#1012628).
- batman-adv: Prevent duplicated global TT entry (bnc#1012628).
- batman-adv: Prevent duplicated softif_vlan entry (bnc#1012628).
- batman-adv: Prevent duplicated nc_node entry (bnc#1012628).
- batman-adv: Prevent duplicated gateway_node entry (bnc#1012628).
- batman-adv: Fix segfault when writing to sysfs elp_interval
(bnc#1012628).
- batman-adv: Fix segfault when writing to throughput_override
(bnc#1012628).
- batman-adv: Avoid probe ELP information leak (bnc#1012628).
- spi: gpio: Fix copy-and-paste error (bnc#1012628).
- media: af9035: prevent buffer overflow on write (bnc#1012628).
- soundwire: Fix acquiring bus lock twice during master release
(bnc#1012628).
- soundwire: Fix incorrect exit after configuring stream
(bnc#1012628).
- soundwire: Fix duplicate stream state assignment (bnc#1012628).
- commit bd19c86

==== kglobalaccel ====
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Add patch to fix keyboard layout changes (boo#1103682, kde#350816,
kde#269403):
* 0001-Fix-keyboard-layout-change-notifications.patch

==== khelpcenter5 ====
Version update (18.08.2 -> 18.08.3)
Subpackages: khelpcenter5-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kidentitymanagement ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kimap ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kimap-lang libKF5IMAP5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kio-extras5 ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* apply eexist workaround from listDir to stat as well (kde#399699)
* Avoid crash by not checking free space for smb://
- Dropped patches, now upstream:
* 0001-Avoid-crash-by-not-checking-free-space-for-smb.patch

==== kio_audiocd ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kio_audiocd-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kitinerary ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* GBool -> bool
* Relax leading space offset detection for international tickets
* Auto-detect leading space in compact/international DB tickets

==== kldap ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kldap-lang libKF5Ldap5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kleopatra ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kleopatra-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmag ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmag-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmail ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fix show html format
* Fix save format
* Fix Bug 395711 - Since last Update kmail didn't load external images
anymore (kde#395711)
* Fix icon in notification

==== kmail-account-wizard ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmail-account-wizard-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmailtransport ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmbox ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmime ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmime-lang libKF5Mime5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kmousetool ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kmousetool-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== knotes ====
Version update (18.08.2 -> 18.08.3)
Subpackages: knotes-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fix Bug 399999 - Notes tooltips do not use the correct encoding (kde#399999)

==== kompare ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kompare-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== konsole ====
Version update (18.08.2 -> 18.08.3)
Subpackages: konsole-part konsole-part-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kontact ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kontact-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kontactinterface ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kopete ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kopete-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== korganizer ====
Version update (18.08.2 -> 18.08.3)
Subpackages: korganizer-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* korgac: repair the dumpAlarms() DBus method
* korgac: hide "Dismiss all" button if there's only one reminder.

==== kpimtextedit ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kpkpass ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKPimPkPass5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kruler ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kruler-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ksmtp ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ktnef ====
Version update (18.08.2 -> 18.08.3)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== kvm_stat ====
Version update (4.17.10 -> 4.19.1)

- Add "Requires: python-curses" in kvm_stat.spec as this package
needs to be installed to make kvm_stat work. (bsc#1114465)

==== kwalletmanager5 ====
Version update (18.08.2 -> 18.08.3)
Subpackages: kwalletmanager5-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libgravatar ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkcddb ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkcompactdisc ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkdcraw ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkdepim ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkexiv2 ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkgapi ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkipi ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkleo ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libkomparediff2 ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libksane ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5Sane5 libksane-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== libksieve ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libksieve-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fix show messagebox
* Fix bug when we click on ok. When script has error we closed it => we lose
data

==== libyui-qt-pkg ====
Version update (2.45.22 -> 2.45.24)

- Require and link against libQt5Svg (bsc#1114654)
- 2.45.24
- Better error handling for missing icons (bsc#1114654):
Error message in the y2log plus displaying a small red square for
missing icons.
- 2.45.23

==== linux-glibc-devel ====
Version update (4.18 -> 4.19)

- fix netfilter builds with 4.19
* add netfilter-bridge-define-INT_MIN-INT_MAX-in-userspace.patch
- Update to kernel headers 4.19

==== lvm2 ====
Subpackages: liblvm2app2_2 liblvm2cmd2_02

- Prevent writing beyond metadata area (bsc#1114113)
+ bug-1114113_metadata-prevent-writing-beyond-metadata-area.patch

==== mailcommon ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== mailimporter ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== mercurial ====
Version update (4.7.2 -> 4.8)
Subpackages: mercurial-lang

- mercurial-4.8-python2-shebang.patch: fixes boo#1114895
- explicitly depend on Python 2.7+
- Mercurial 4.8
This is a regularly-scheduled quarterly feature release.
See release overview at https://www.mercurial-scm.org/wiki/Release4.8 and
complete changelog at
https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.8_.282018-11-02.29

==== messagelib ====
Version update (18.08.2 -> 18.08.3)
Subpackages: messagelib-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Fix Bug 377708 - KMail doesn't remember to render in HTML (kde#377708)
* Fix Bug 396398 - KMail 5.8.2 displays HTML formatting on top of message
(kde#396398)
* Check QtWebEngine version instead of Qt's (kde#397349)
- Dropped patches, now upstream:
* 0001-Check-QtWebEngine-version-instead-of-Qt-s.patch

==== mobipocket ====
Version update (18.08.2 -> 18.08.3)

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo
terminfo-base terminfo-screen

- Add Add ncurses patch 20181027
+ add OpenGL clients alacritty and kitty -TD
+ add Smulx for tmux, vte-2018 -Nicholas Marriott
- Add ncurses patch 20181020
+ ignore $TERMINFO as a default value in configure script if it came
from the infocmp -Q option.
+ allow value for --with-versioned-syms to be a relative pathname
+ add a couple of broken-linker symbols to the list of versioned
symbols to help with link-time optimization versus weak symbols.
+ apply shift/control/alt logic when decoding xterm's 1006 mode to
wheel-mouse events (Redhat #1610681).
- Add ncurses patch 20181013
+ amend change from 20180818, which undid a fix for the $INSTALL value
to make it an absolute path.

==== okular ====
Version update (18.08.2 -> 18.08.3)
Subpackages: okular-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* Add three autotests for part saving
* Fix saving to files that don't exist
* Resolve symlinks before saving so we don't "break" them
* Fix crash if processing a link closes the document

==== open-vm-tools ====
Version update (10.3.0 -> 10.3.5)
Subpackages: libvmtools0 open-vm-tools-desktop

- Update to 10.3.5 (build 10430147) (boo#1115118)
+ While running a quiesced snapshot of a Linux guest on the vSphere hosts
earlier than version 6.7, open-vm-tools logs warning messages.
+ CreateTemporaryFileInGuest/CreateTemporaryDirectoryInGuest returns a file
path that does not exist.
+ Excessive spikes of the Memory/Workload percentage metric, in a vRealize
Operations cluster.
+ open-vm-tools Service running as vmusr crashes on Linux systems which are
not running on the VMware platform.
- Drop unnecessary patch:
- false-negative-cloud-init.patch
- handle-linux-kernel-stat-overflow.patch
- optional-override-os-name.patch

==== openldap2 ====
Subpackages: libldap-2_4-2 libldap-2_4-2-32bit libldap-data openldap2-client
openldap2-devel

- Emergency fix: move tmpfiles_create post from the library package
to the main package's post script, which ships the tmpfiles.d
configuration. Fixes the post script of the library (-p
/sbin/ldconfig does not allow more statements in the script).
- Bug 1111388 openldap and /var/lib/ldap/DB_CONFIG* (transactional-update)

==== perl-Clone ====
Version update (0.39 -> 0.41)

- updated to 0.41
see /usr/share/doc/packages/perl-Clone/Changes
0.41 2018-10-25 10:20:03 garu
- Check the CowREFCNT of a COWed PV (ATOOMIC)
this should fix some issues people have been
having with 0.40 on DBD drives and DBIx::Class
- Make buildtools files not executable (Mohammad S Anwar)
0.40 2018-10-23 20:001:49 garu
- reuse COWed PV when cloning (fixes RT97535) (ATOOMIC)
- extra protection against potential infinite loop (ATOOMIC)
- improved tests

==== perl-Cpanel-JSON-XS ====
Version update (4.06 -> 4.07)

- updated to 4.07
see /usr/share/doc/packages/perl-Cpanel-JSON-XS/Changes
4.07 2018-11-02 (rurban)
- Silence Gconvert -Wunused-result.
gcvt returns a string, sprintf int, so suppress the retval

==== perl-DBD-CSV ====
Version update (0.53 -> 0.54)

- Update to 0.54

==== perl-DBD-ODBC ====
Version update (1.59 -> 1.60)

- updated to 1.60
see /usr/share/doc/packages/perl-DBD-ODBC/Changes
1.60 2018-10-31
[BUG FIXES]
Merged pull request 11 from audun which fixes some issues with the
AutoCommit flag
on commit and rollback.
[MISCELLANEOUS]
Merged pull request 10 from vadz which fixed typo (affecting license) in
README.md.

==== perl-IO-Socket-SSL ====

- prevent flaky test failures with openssl 1.1.1 on overloaded
systems(bsc#1108977)
* https://rt.cpan.org/Public/Bug/Display.html?id=126899
* add
IO-Socket-SSL-2.060-make-all-tests-which-use-fork-also-ignore-signal-PIP.patch

==== perl-Math-BigInt ====
Version update (1.999813 -> 1.999816)

- updated to 1.999816
see /usr/share/doc/packages/perl-Math-BigInt/CHANGES
1.999816 2018-10-26
* bnok() for Math::BigInt and Math::BigFloat now support the full Kronenburg
extension. The behaviour is identical to the behaviour of the Maple and
Mathematica function for negative integers n, k. Add tests. This closes CPAN
RT #95628.
* Fix POD errors. This closes CPAN RT #125141.
1.999815 2018-10-19
* Move bitwise operators signed and, signed or, and signed xor from
lib/Math/BigInt/CalcEmu.pm into lib/Math/BigInt/Lib.pm. The file
lib/Math/BigInt/CalcEmu.pm is no longer needed and thus removed.
1.999814 2018-10-01
* Add to_base() and from_base() to Math::BigInt and corresponding library
methods _to_base() and _from_base() to Math::BigInt::Lib. This was inspired
by CPAN RT #122681.
* Fix Makefile.PL to reflect that Test::More is only needed for testing, not
for building.
* In the documentation for each of the to_(bin|hex|oct|bytes) methods, add a
reference to the corresponding from_(bin|hex|oct|bytes) method.

==== perl-Math-BigInt-GMP ====
Version update (1.6005 -> 1.6006)

- updated to 1.6006
see /usr/share/doc/packages/perl-Math-BigInt-GMP/CHANGES
1.6006 2018-10-09
* Update MANIFEST.SKIP.
* Sync test files with Math-BigInt.
* Better Makefile.PL.

==== php7 ====
Version update (7.2.11 -> 7.2.12)
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pear-Archive_Tar php7-pgsql
php7-shmop php7-snmp php7-sockets php7-sqlite php7-sysvsem php7-sysvshm
php7-tidy php7-tokenizer php7-wddx php7-xmlreader php7-xmlwriter php7-xsl
php7-zlib

- update to 7.2.12: This is a bugfix release.
http://php.net/ChangeLog-7.php
- forward ported:
% php7-crypt-tests.patch
% php7-honor-re2c-flags.patch
% php7-odbc-cmp-int-cast.patch

==== pimcommon ====
Version update (18.08.2 -> 18.08.3)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== python-M2Crypto ====
Version update (0.30.1 -> 0.31.0)
Subpackages: python2-M2Crypto python3-M2Crypto

- Update to 0.31.0 released tarball:
* Compatibility with OpenSSL 1.1.1 (partly workaround, maybe
requires further investigation)
* Fixes for Windows builds
* Fixes of installs on AWS Lambda
* Fixes of Mac OS X related failures
* Fix Python 2.6 compatibility issues
- pre-release of 0.31.0 tarball
- add openssl-1_1_1-compat.patch to fix OpenSSL 1.1.1 compatibility.

==== python-boto3 ====

- Fix build for openSUSE Leap 42.3
+ urllib3 needs the ssl module, which in Leap 42.3 is delivered by python
and not python-base. Set explicit build dependency on python

==== python-botocore ====

- Fix build for openSUSE Leap 42.3
+ urllib3 needs the ssl module, which in Leap 42.3 is delivered by python
and not python-base. Set explicit build dependency on python

==== python-pycurl ====
Subpackages: python2-pycurl python3-pycurl

- Don't run tests that fail randomly or under load
* add disable_randomly_failing_tests.patch

==== python-requests ====
Subpackages: python2-requests python3-requests

- Ensure neutrality of descriptions.

==== rubygem-passenger ====
Version update (5.3.5 -> 5.3.7)
Subpackages: ruby2.5-rubygem-passenger rubygem-passenger-apache2

- updated to version 5.3.7 (boo#1115545)
* Fixes package installation issues on Ubuntu 18.04. These issues
were caused by an update released by Ubuntu on the nginx-common
package. Closes GH-2122, GH-2140.
* Fixes compilation problems and warnings with GCC 8.2. Tested on
Alpine Linux edge 2018-11-05. Closes GH-2139.
* Fixes compatibility with libcurl 7.62.0. Contributed by
Po-Chuan Hsieh (@sunpoet).
* Changes minimum supported macOS version to 10.11 El Capitan.
* Removes packages for Ubuntu 17.10 Artful.
- updated to version 5.3.6 (boo#1114735)
* Fixes smart spawning. A regression in 5.3.5 (due to a refactoring) made it
so that Passenger only used the direct spawning method. This issue was mostly
noticeable in the form of increased process spawning times between 5.3.4 and
5.3.5.
* Fixes Passenger Core and application processes staying on the Watchdog's
OOM score (unkillable). Closes GH-2105.
* Fixes "mach_vm_map failed" warnings on macOS >= High Sierra. These warnings
were harmless, but annoying. Closes GH-2101.
* Fixes `passenger-config compile-agent` compilation with optimizations. The
optimization flags were not properly passed to the compiler.
* Fixes a crash that could occur when HTTP clients send a chunked
transfer-encoding body containing a chunk larger than 429496729 bytes.
* Improves detection of the system Apache's include headers on macOS High
Sierra and later.
* Fixes RVM gemset detection on RVM 1.29.
* No longer supplies precompiled Ruby extensions for Ruby 1.9.3 and 2.0.0.
When running Ruby 1.9.3 and 2.0.0, Passenger will attempt to compile from
source instead.
- changed suse.patch to apply again
- changed fix_shebangs.patch to apply again

==== shadow ====

- Add empty /etc/sub{u,g}id files. useradd and usermod add entries for users
only when those files exist. Having those entries is a requirement to create
user namespaces, for instance, when running podman as a non-root user.

==== spectacle ====
Version update (18.08.2 -> 18.08.3)
Subpackages: spectacle-lang

- Update to 18.08.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.3.php
- Changes since 18.08.2:
* No code changes since 18.08.2

==== subversion ====
Version update (1.10.3 -> 1.11.0)
Subpackages: libsvn_auth_gnome_keyring-1-0 libsvn_auth_kwallet-1-0
subversion-bash-completion subversion-perl subversion-python subversion-server
subversion-tools

- Apache Subversion 1.11.0:
* Shelving is no longer based on patch files
* Shelves created on 1.10 are not compatible
* New feature: Checkpointing
* New viewspec output command
* Improvements to tree conflict resolutio
* 'patch' can now read non-pretty-printed svn:mergeinfo diffs
* Better error when http:// URL is not a Subversion repository
* Add 'schedule' and 'depth' items to 'svn info --show-item'
* Allow the client cert password to be saved
* Various bug fixes
* On-disk caching of plaintext passwords and passphrases is now
disabled by default, but users can explicitly allow this
behavior via runtime configuration
- drop upstreamed subversion-1.10.2-java10.patch

==== vim ====
Version update (8.1.0479 -> 8.1.0503)
Subpackages: gvim vim-data vim-data-common

- Updated to 8.1.0503, fixes the following problems
- small change in vim-changelog.sh
* Failure when setting 'varsofttabstop' to end in a comma.
* When "Terminal" highlight is reverted cursor doesn't show.
* Some file types are not recognized.
* term_start() does not check if directory is accessible.
* Can't build in MS-Windows.
* No menus specifically for the terminal window.
* Using freed memory in quickfix code.
* Crash when autocmd clears vimpgrep location list.
* If a terminal dump has CR it is considered corrupt.
* "Edit with existing Vim" list can get long.
* argv() and argc() only work on the current argument list.
* Functions do not check for a window ID in other tabs.
* :filter only supports some commands.
* No tests for indent files.
* :%diffput changes order of lines.
* /etc/gitconfig not recognized at a gitconfig file.
* :2vimgrep causes an ml_get error
* Cleaning up in src/tee may not always work.
* Cppcheck warns for using array index before bounds check.
* Internal diff fails when diffing a context diff.
* Missing change to diff test.

==== x11-tools ====

- remove hostname's '-f' option since it may fail or - even worse -
causes timeouts (boo#1113087)

==== yast2-country ====
Version update (4.1.0 -> 4.1.1)
Subpackages: yast2-country-data

- provide better API for getting keyboard map info (fate#325748)
- 4.1.1


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups