Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20181110 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20181110

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.8.12 -> 7.0.8.14)
NetworkManager (1.14.0 -> 1.14.4)
appstream-glib (0.7.9+0 -> 0.7.14+0)
autoyast2 (4.0.65 -> 4.0.66)
bijiben (3.30.1 -> 3.30.2)
bluedevil5 (5.14.2 -> 5.14.3)
breeze (5.14.2 -> 5.14.3)
breeze-gtk (5.14.2 -> 5.14.3)
breeze4-style (5.14.2 -> 5.14.3)
ceph (13.2.0.210+g0e990e900d -> 14.0.0.4389+g4c34d15e48)
crash
dconf (0.30.0 -> 0.30.1)
devhelp (3.30.0 -> 3.30.1)
discover (5.14.2 -> 5.14.3)
drbd-utils (9.5.0 -> 9.6.0)
drkonqi5 (5.14.2 -> 5.14.3)
ecj
evince (3.30.1 -> 3.30.2)
evolution (3.30.1 -> 3.30.2)
evolution-data-server (3.30.1 -> 3.30.2)
evolution-ews (3.30.1 -> 3.30.2)
freetype2
gedit (3.30.1 -> 3.30.2)
glib2
gnome-builder (3.30.1 -> 3.30.2)
gnome-clocks (3.30.0 -> 3.30.1)
gnome-control-center (3.30.1 -> 3.30.2)
gnome-desktop (3.30.1 -> 3.30.2)
gnome-disk-utility (3.30.1 -> 3.30.2)
gnome-maps (3.30.1 -> 3.30.2)
gnome-music (3.30.0 -> 3.30.2)
gnome-terminal (3.30.1 -> 3.30.2)
gnome-user-docs (3.30.1 -> 3.30.2)
groff
groff-full
hwinfo (21.58 -> 21.61)
kactivitymanagerd (5.14.2 -> 5.14.3)
kcm_sddm (5.14.2 -> 5.14.3)
kde-cli-tools5 (5.14.2 -> 5.14.3)
kde-gtk-config5 (5.14.2 -> 5.14.3)
kde-user-manager (5.14.2 -> 5.14.3)
kdeconnect-kde (1.3.2 -> 1.3.3)
kdepim-addons
kexec-tools (2.0.17 -> 2.0.18)
kgamma5 (5.14.2 -> 5.14.3)
khotkeys5 (5.14.2 -> 5.14.3)
kinfocenter5 (5.14.2 -> 5.14.3)
kmenuedit5 (5.14.2 -> 5.14.3)
kscreen5 (5.14.2 -> 5.14.3)
kscreenlocker (5.14.2 -> 5.14.3)
ksshaskpass5 (5.14.2 -> 5.14.3)
ksysguard5 (5.14.2 -> 5.14.3)
kunitconversion
kwayland-integration (5.14.2 -> 5.14.3)
kwin5 (5.14.2 -> 5.14.3)
libdazzle (3.30.1 -> 3.30.2)
libgcrypt (1.8.3 -> 1.8.4)
libgphoto2 (2.5.19 -> 2.5.20)
libisoburn (1.4.8 -> 1.5.0)
libkdecoration2 (5.14.2 -> 5.14.3)
libkscreen2 (5.14.2 -> 5.14.3)
libksysguard5 (5.14.2 -> 5.14.3)
libmtp (1.1.15 -> 1.1.16)
libnumbertext
libsolv (0.6.35 -> 0.7.1)
libsoup (2.64.1 -> 2.64.2)
libssh (0.8.4 -> 0.8.5)
libstorage-ng (4.1.53 -> 4.1.54)
libyui
libyui-ncurses
libzypp (17.8.0 -> 17.8.1)
milou5 (5.14.2 -> 5.14.3)
nautilus (3.30.2 -> 3.30.3)
openldap2
oxygen5 (5.14.2 -> 5.14.3)
patterns-devel-osc
perl-DateTime-TimeZone (2.19 -> 2.21)
perl-Template-Toolkit (2.27 -> 2.28)
plasma-browser-integration (5.14.2 -> 5.14.3)
plasma-nm5 (5.14.2 -> 5.14.3)
plasma5-addons (5.14.2 -> 5.14.3)
plasma5-desktop (5.14.2 -> 5.14.3)
plasma5-integration (5.14.2 -> 5.14.3)
plasma5-openSUSE
plasma5-pa (5.14.2 -> 5.14.3)
plasma5-workspace (5.14.2 -> 5.14.3)
plymouth (0.9.3+git20181016.a588b3f -> 0.9.4+git20181105.f898586)
polari (3.30.1 -> 3.30.2)
polkit-kde-agent-5 (5.14.2 -> 5.14.3)
powerdevil5 (5.14.2 -> 5.14.3)
python-boto (2.48.0 -> 2.49.0)
python-boto3 (1.8.1 -> 1.9.38)
python-botocore (1.11.1 -> 1.12.38)
python-cffi
python-libvirt-python (4.8.0 -> 4.9.0)
python-numpy (1.15.2 -> 1.15.3)
python-psutil (5.4.7 -> 5.4.8)
python-py (1.5.4 -> 1.7.0)
python-qt5
relaxngDatatype
rubygem-cfa (0.6.4 -> 0.7.0)
rubygem-concurrent-ruby (1.0.5 -> 1.1.1)
rubygem-i18n (1.1.0 -> 1.1.1)
rubygem-jbuilder (2.7.0 -> 2.8.0)
rubygem-libyui-rake (0.1.11 -> 0.1.13)
rubygem-loofah (2.2.2 -> 2.2.3)
rubygem-method_source (0.9.0 -> 0.9.1)
rubygem-rack (2.0.5 -> 2.0.6)
shared-mime-info (1.9 -> 1.10)
soundtouch (2.0.0 -> 2.1.0)
srt
syslinux
sysprof (3.30.1 -> 3.30.2)
systemsettings5 (5.14.2 -> 5.14.3)
units (2.17 -> 2.18)
virt-manager (1.5.1 -> 2.0.0)
virtualbox (5.2.18_k4.18.15_1 -> 5.2.20_k4.18.15_1)
vte (0.54.1 -> 0.54.2)
webkit2gtk3 (2.22.2 -> 2.22.3)
whois (5.3.2 -> 5.4.0)
wicked (0.6.50 -> 0.6.51)
xalan-j2
xdg-desktop-portal-kde (5.14.2 -> 5.14.3)
xorg-x11-server (1.20.2 -> 1.20.3)
yast2 (4.1.32 -> 4.1.33)
yast2-firewall (4.0.33 -> 4.0.34)
yast2-installation (4.1.24 -> 4.1.25)
yast2-iscsi-client (4.1.1 -> 4.1.2)
yast2-packager (4.1.11 -> 4.1.12)
yast2-security (4.1.0 -> 4.1.1)
yast2-storage-ng (4.1.29 -> 4.1.31)
yast2-theme (4.1.4 -> 4.1.5)
yast2-trans (84.87.20180514.157a0650d -> 84.87.20181104.0df6e15205)
yast2-update (4.1.4 -> 4.1.5)
yast2-users (4.0.7 -> 4.0.9)
zypper (1.14.14 -> 1.14.15)

=== Details ===

==== ImageMagick ====
Version update (7.0.8.12 -> 7.0.8.14)
Subpackages: ImageMagick-extra libMagick++-7_Q16HDRI4 libMagickCore-7_Q16HDRI6
libMagickWand-7_Q16HDRI6 perl-PerlMagick

- update to 7.0.8-14:
* Adding coder headers with magic.xml will no longer be supported.
* Adding coder aliases with coder.xml will no longer be supported.
* fixing oss-fuzz issues
- asan_build: build ASAN included
- debug_build: build more suitable for debugging

==== NetworkManager ====
Version update (1.14.0 -> 1.14.4)
Subpackages: NetworkManager-lang libnm0 typelib-1_0-NM-1_0

- Update to version 1.14.4:
+ Fix a crash in nmcli when a device is removed while being
disconnected.
+ Fix a crash in ifupdown (Debian) configuration plugin.
+ Fix a daemon crash when a generated connection doesn't
validate.
+ Fix a memory leak in dhclient DHCP plugin.
+ Fix line editing in nmcli password prompts.
+ Fix a RPATH in bluetooth and wwan plugin when built with Meson
(otherwise they wouldn't find libnm-wwan.so).
- Update to version 1.14.2:
+ Fix a bug that could cause NetworkManager to crash after
checking connectivity status.
+ Correctly apply a default (-1) metric from DHCP.
+ Multiple fixes for IWD Wi-Fi backend.
+ Multiple fixes for builds with Meson build system.
+ Fix a crash with OLPC XO-1 mesh Wi-Fi.
+ Fix handling "serial.parity" and "serial.send-delay" properties
in nmcli.
+ Improve auto-selecting device when activating a connection
profile and don't auto-select unmanaged devices when activating
multi-connect profile.
+ Avoid expiring the lifetime of IPv6 addresses from router
advertisements.

==== appstream-glib ====
Version update (0.7.9+0 -> 0.7.14+0)
Subpackages: appstream-glib-lang libappstream-builder8 libappstream-glib8

- Update to version 0.7.14+0:
+ Set the AppStream ID from the X-Flatpak desktop key
+ trivial: Compile the DEP-11 stuff in the RPM spec file example
+ Add as_app_to_xml()
+ Add as_content_rating_add_attribute()
- Update to version 0.7.13+0:
+ Add ID provides for desktop files with X-Flatpak-RenamedFrom
+ trivial: Include glib.h for G_STRINGIFY
+ Throw an error when a launchable desktop-id is invalid
+ Better debug output for appstream-compose
+ Change order of arguments in matrix-html to match status-html
+ Do not restrict the maximum number of releases allowed
per-component
- Changes from version 0.7.12:
+ Support localised text in agreement sections
- Changes from version 0.7.11:
+ Add AS_APP_QUIRK_DEVELOPER_VERIFIED
+ store: Provide async variants of load functions
+ Escape quotes in attributes
- Changes from version 0.7.10:
+ trivial: Sync translations and remove line numbers
+ trivial: Fix a small memory leak when adding keywords manually
+ Do not require a release transaction when validating in relaxed
mode
+ Add object type checks on the inputs of all functions
+ Add COMMITMENT file as part of GPL Common Cure Rights
Commitment
+ trivial: Fix GObjectIntrospection markup for adding metadata
+ Do not parse firmware files
+ its: Extract release descriptions and agreement sections for
translation

==== autoyast2 ====
Version update (4.0.65 -> 4.0.66)
Subpackages: autoyast2-installation

- Writing security settings in first AY installation stage.
So other modules (e.g. users) can rely on these settings now.
(bnc#1112769)
- 4.0.66

==== bijiben ====
Version update (3.30.1 -> 3.30.2)
Subpackages: bijiben-lang gnome-shell-search-provider-bijiben

- Update to version 3.30.2:
+ Increased notes view width and removed alignment.
+ Updated translations.

==== bluedevil5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: bluedevil5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== breeze ====
Version update (5.14.2 -> 5.14.3)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers libbreezecommon5-5

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* Link *-resize to the right icons
* [cursors] Also link for Breeze Snow
* [Cursors] link *-resize to *_corner cursor (kde#399194)

==== breeze-gtk ====
Version update (5.14.2 -> 5.14.3)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== breeze4-style ====
Version update (5.14.2 -> 5.14.3)
Subpackages: libbreezecommon4-5

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* Link *-resize to the right icons
* [cursors] Also link for Breeze Snow
* [Cursors] link *-resize to *_corner cursor (kde#399194)

==== ceph ====
Version update (13.2.0.210+g0e990e900d -> 14.0.0.4389+g4c34d15e48)
Subpackages: librados2 librbd1

- Bump ceph aarch64 memory constraint from 8 to 9G to address
an EOM build failure seen in IBS
- Update to v14.0.0-4389-g4c34d15e48:
+ based on upstream nautilus a0b5445bc8400b9b1f398a414001164b2d8dd290
+ First downstream nautilus build. Notable changes:
* The 'ceph-disk' OSD deployment/introspection/management tool is gone.
Use 'ceph-volume' instead.
* Builds with Python 3.7 (boo#1113946)
* The 'ceph osd rm' command has been deprecated. Users should use
'ceph osd destroy' or 'ceph osd purge' (but after first confirming it is
safe to do so via the 'ceph osd safe-to-destroy' command).
* The MDS now supports dropping its cache for the purposes of benchmarking:
"ceph tell mds.* cache drop <timeout>"
* The 'ceph pg <pgid> list_missing' command has been renamed to
'ceph pg <pgid> list_unfound' to better match its behaviour.
* The 'rbd-mirror' daemon can now retrieve remote peer cluster
configuration secrets from the monitor.
* The is fully obsolete and references to it in the docs
have been removed or clarified.
* The libcephfs bindings added the ceph_select_filesystem function
for use with multiple filesystems.
* The cephfs python bindings now include mount_root and filesystem_name
options in the mount() function.
* erasure-code: add experimental *Coupled LAYer (CLAY)* erasure codes
support.
* The 'cache drop' OSD command has been added to drop an OSD's caches:
"ceph tell osd.x cache drop"
* The 'cache status' OSD command has been added to get the cache stats of an
OSD: "ceph tell osd.x cache status"
- Update to 13.2.2-86-g62b49f06c4:
+ rebase on upstream 13.2.2 release
https://ceph.com/releases/13-2-2-mimic-released/
+ IMPORTANT NOTE: this release contains a regression in CephFS
which was not yet fixed at the time of this build. Do not use
this build on a production cluster!
For details, see http://tracker.ceph.com/issues/36346
- Update to 13.2.1-427-g6cd01d4dd2:
+ cmake: no libradosstriper headers if WITH_LIBRADOSSTRIPER=OFF
- Update to 13.2.1-426-gd2d4852e84:
+ based on upstream mimic 510d48e10be716cf61b9ddd51e8bc847288ae15a
+ bsc#1101262 - ceph's SPDK builds with march=native
+ migrate DeepSea QA bash scripting from DeepSea repo
- Update to 13.2.1-106-g9a1fcb1b6a:
+ based on upstream mimic 0323ca11569b183509129c180dcec427aecf2a0a
* including upstream 13.2.1 release - for details, see
https://ceph.com/releases/13-2-1-mimic-released/
+ ceph-disk: let extract_parted_partition_numbers return a list
(fixes a py3 issue)

==== crash ====

- Sync with SLE15 SP1 (SR#173916) to enable the kmp-rt for SLERT15 SP1 only
set %if 0%{?sle_version} >= 150100

==== dconf ====
Version update (0.30.0 -> 0.30.1)
Subpackages: gsettings-backend-dconf libdconf1

- Update to version 0.30.1:
+ Engine: Fix memory leak when subscribing to a path.

==== devhelp ====
Version update (3.30.0 -> 3.30.1)
Subpackages: devhelp-lang emacs-plugin-devhelp gedit-plugin-devhelp
vim-plugin-devhelp

- Update to version 3.30.1:
+ Build: requires Meson >= 0.47.0.
+ Updated translations.

==== discover ====
Version update (5.14.2 -> 5.14.3)
Subpackages: discover-backend-flatpak discover-backend-fwupd
discover-backend-packagekit discover-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* snap: improve transaction status (kde#396351)
* Use the locale to create the release date string (kde#400314)
* pk: readability
* flatpak: use the path to identify a local remote
* flatpak: fix freeze (kde#400212)
* flatpak: use pkgconfig targets instead of using variables
* flatpak: fix warning
* fwupd: improve fwupd lookup
* fwupd: Cancel job upon close
* fwupd: don't report passive errors about unsupported devices
* fwupd: fix error handling logic
* fwupd: --output
* fwupd: no need to pass a pointer reference to read errors
* fwupd: don't ignore fwupd_client_get_devices errors
* fwupd: don't ignore get releases errors
* fwupd: silence invalid file errors (kde#400181)

==== drbd-utils ====
Version update (9.5.0 -> 9.6.0)

- Update to new upstream release 9.6.0
* usage-count: also count notty users if possible.
* drbd-overview: remove it, we have drbdtop/drbdmon. saves all the Perl deps.
* drbdmon: update frequency limiting, debug log for drbdevents, use
altbuffer,...
* drbdsetup show: on 9 allow json output.
mainly used in our CI, don't expect a stable field names yet.
* drbdsetup satus: on 9 fix json output to not include NaN/Infinity
* allow higher resync rates: first customers hit a limit. this requires an
updated kernel module as well (e.g., 9.0.16)
* init: fix some 8-only leftovers (sh-b-pri), sanitize the retry logic
* doc: document various 9 features that got forgotten (e.g., quorum-lost)
* build: various small fixes that popped up while playing with meson
- Remove patch: skip_sh-b-pri_in_v9.patch fix in ace704aac

==== drkonqi5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: drkonqi5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== ecj ====

- Add two more maven artifact aliases:
* org.eclipse.jdt.core.compiler:ecj
* org.eclipse.jdt:ecj

==== evince ====
Version update (3.30.1 -> 3.30.2)
Subpackages: evince-lang evince-plugin-comicsdocument
evince-plugin-djvudocument evince-plugin-dvidocument evince-plugin-pdfdocument
evince-plugin-psdocument evince-plugin-tiffdocument evince-plugin-xpsdocument
libevdocument3-4 libevview3-3 nautilus-evince typelib-1_0-EvinceDocument-3_0
typelib-1_0-EvinceView-3_0

- Update to version 3.30.2:
+ UI:
- Fix appearance of editable GtkComboBox in PDF form.
- Handle unexpected page jump while dragging the scroll.
+ Build: Claim ownership of org.gnome.evince.
+ Updated translations.

==== evolution ====
Version update (3.30.1 -> 3.30.2)
Subpackages: evolution-lang evolution-plugin-bogofilter
evolution-plugin-pst-import evolution-plugin-spamassassin

- Update to version 3.30.2:
+ Print actions disabled in Calendar view.
+ Task Location shown as Summary in preview pane.
+ Make sure message_list_folder_changed() is called from the
main/UI thread.
+ [Flatpak] Use host system DConf to store user settings.
+ Free/Busy lookup for authenticated URLs not re-tried.
+ [Calendar] Fix issues with attendees editing of an existing
meeting.
+ A little code clean-up related to the previous commit.
+ [Event/Task editor] Force timezone part show only if really
needed.
+ Bugs fixed: glgo#GNOME/evolution#135, glgo#GNOME/evolution#136,
glgo#GNOME/evolution#139, glgo#GNOME/evolution#140,
glgo#GNOME/evolution#155, glgo#GNOME/evolution#159,
glgo#GNOME/evolution#162, glgo#GNOME/evolution#163,
glgo#GNOME/evolution#164, glgo#GNOME/evolution#166,
glgo#GNOME/evolution#176, glgo#GNOME/evolution#183,
glgo#GNOME/evolution!4.
+ Updated translations.

==== evolution-data-server ====
Version update (3.30.1 -> 3.30.2)
Subpackages: evolution-data-server-lang libcamel-1_2-62 libebackend-1_2-10
libebook-1_2-19 libebook-contacts-1_2-2 libecal-1_2-19 libedata-book-1_2-25
libedata-cal-1_2-29 libedataserver-1_2-23 libedataserverui-1_2-2

- Update to version 3.30.2:
+ Fix a memory leak in ebmb_start_view_thread_func().
+ [evolution-dbus-session] Proxy also D-Bus subtrees.
+ [CamelProvider] Do not localize empty strings in provider
configuration.
+ Make tests retry when factory doesn't know about added ESource
yet.
+ [On The Web calendar] Log also response body when requested.
+ Bugs fixed: glgo#GNOME/evolution-data-server#35,
glgo#GNOME/evolution-data-server#36,
glgo#GNOME/evolution-data-server#37,
glgo#GNOME/evolution-data-server#38,
glgo#GNOME/evolution-data-server#40,
glgo#GNOME/evolution-data-server#44,
glgo#GNOME/evolution-data-server#50.
+ Updated translations.

==== evolution-ews ====
Version update (3.30.1 -> 3.30.2)
Subpackages: evolution-ews-lang

- Update to version 3.30.2:
+ Enable only Notification reminders in the calendar.
+ Treat 'Unknown' ResponseType as Needs-Action.
+ Collection backend schedules two 'populate' requests after
going online.
+ Bugs fixed: glgo#GNOME/evolution-ews#18,
glgo#GNOME/evolution-ews#19, glgo#GNOME/evolution-ews#21,
glgo#GNOME/evolution-ews#23.
+ Updated translations.

==== freetype2 ====
Subpackages: freetype2-devel libfreetype6 libfreetype6-32bit

- Remove old ppc64 parts in spec file
- Refresh patches:
+ bugzilla-308961-cmex-workaround.patch
+ don-t-mark-libpng-as-required-library.patch
+ enable-long-family-names-by-default.patch
- Enable subpixel rendering with infinality config:
+ enable-subpixel-rendering.patch
+ enable-infinality-subpixel-hinting.patch

==== gedit ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gedit-lang python3-gedit

- Update to version 3.30.2:
+ Fix file chooser not opening in correct location after first
time.
+ Updated translations.

==== glib2 ====
Subpackages: glib2-lang glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Add patchset to fix gvariant parsing issues. (bsc#1111499).
0001-gvariant-Fix-checking-arithmetic-for-tuple-element-e.patch
0002-gvarianttype-Impose-a-recursion-limit-of-64-on-varia.patch
0003-gvariant-Check-array-offsets-against-serialised-data.patch
0004-gvariant-Check-tuple-offsets-against-serialised-data.patch
0005-gvariant-Limit-GVariant-strings-to-G_MAXSSIZE.patch
0006-gdbusmessage-Validate-type-of-message-header-signatu.patch
0007-gdbusmessage-Improve-documentation-for-g_dbus_messag.patch
0008-gdbusmessage-Clarify-error-returns-for-g_dbus_messag.patch
0009-gdbusmessage-Fix-a-typo-in-a-documentation-comment.patch
0010-gdbusmessage-Check-for-valid-GVariantType-when-parsi.patch
0011-gvariant-Clarify-internal-documentation-about-GVaria.patch
0012-tests-Tidy-up-GError-handling-in-gdbus-serialization.patch
0013-tests-Use-g_assert_null-in-gdbus-serialization-test.patch
0014-gutf8-Add-a-g_utf8_validate_len-function.patch
0015-glib-Port-various-callers-to-use-g_utf8_validate_len.patch

==== gnome-builder ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gnome-builder-doc gnome-builder-lang gnome-builder-plugin-jedi
gnome-builder-plugin-jhbuild gnome-builder-plugin-vala-pack

- Update to version 3.30.2:
+ Fixes for tracking GNOME's Night Light setting.
+ Fix running of Builder's unit tests without installing.
+ Fix relative paths from .git gitdir.
+ Fix gdb communication over chatty intermediate PTY.
+ Allow gtksourceview-3.0 applications to use Builder
style-schemes.
+ Icon fixes and improvements.
+ More UI components display keyboard shortcuts.
+ Saving files will now create the necessary directory structure.
+ Buffers will mark themselves as "modified on disk" when the
backing file is deleted.
+ Drop SSL/PKI overrides for Flatpak.
+ Git plugin now updates status when the checkout directory
changes.
+ Vim command-bar has improved results when listing
files/directories.
+ Project creation and cloning wizards now update paths in
response to changes.
+ ".in" filename suffix will be ignored when guessing syntax
language.
+ You can specify what Ninja path to use using $NINJA in build
preferences.
+ RLS is now restarted when Cargo.toml changes.
+ Fuzzy matching completion results has been improved for some
corner-cases.
+ Gtk-sharp3 template now builds correctly.
+ Editor is properly focused when re-selecting open buffer from
global search.
+ Various bug fixes to gstyle.
+ Meson toolchain editing improvements.
+ Updated translations.
- Drop environment.pickle to make package build reproducible

==== gnome-clocks ====
Version update (3.30.0 -> 3.30.1)
Subpackages: gnome-clocks-lang gnome-shell-search-provider-gnome-clocks

- Update to version 3.30.1:
+ Flatpak package improvements.

==== gnome-control-center ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-lang gnome-control-center-user-faces

- Update to version 3.30.2:
+ Display:
- Hide unsupported resolutions again.
- Improve snapping.
- Stop night light dialog being destroyed twice.
+ Online Accounts: Track the lifecycle of CcGoaPanel across async
calls.
+ Region: Fix double-free when closing the input chooser dialog.
+ Wi-Fi: Disable periodic scan only when Wi-Fi is disabled.
+ Updated translations.

==== gnome-desktop ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gnome-desktop-lang gnome-version libgnome-desktop-3-17
libgnome-desktop-3_0-common typelib-1_0-GnomeDesktop-3_0

- Update to version 3.30.2:
+ Updated translations.

==== gnome-disk-utility ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gnome-disk-utility-lang

- Update to version 3.30.2:
+ Updated translations.

==== gnome-maps ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gnome-maps-lang

- Update to version 3.30.2:
+ overpass, placeBubble: Avoid use-after-free.
+ Updated translations.

==== gnome-music ====
Version update (3.30.0 -> 3.30.2)
Subpackages: gnome-music-lang

- Update to version 3.30.2:
+ Delayed loading of remote cover art.
+ Fix keyboard shortcuts.
+ Flatpak fixes.
+ Bugs fixed: glgo#GNOME/gnome-music#226,
glgo#GNOME/gnome-music#238.
+ Updated translations.
- Update to version 3.30.1:
+ Dark mode fixes.
+ Add TheAudioDB support for coverart.
+ Fix issues with repeatmode handling.
+ Bugs fixed: glgo#GNOME/gnome-music!245,
glgo#GNOME/gnome-music!241, glgo#GNOME/gnome-music!247,
glgo#GNOME/gnome-music!246, glgo#GNOME/gnome-music!269,
glgo#GNOME/gnome-music!271, glgo#GNOME/gnome-music!274,
glgo#GNOME/gnome-music#220.
+ Updated translations.
- Add pkgconfig(grilo-plugins-0.3) BuildRequires: New dependency.

==== gnome-terminal ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gnome-shell-search-provider-gnome-terminal gnome-terminal-lang
nautilus-extension-terminal

- Update to version 3.30.2:
+ prefs: Hide the new terminal mode setting when disunified.
+ Updated translations.

==== gnome-user-docs ====
Version update (3.30.1 -> 3.30.2)
Subpackages: gnome-user-docs-lang

- Update to version 3.30.2:
+ Updates to GNOME Help.
+ Updated translations.

==== groff ====

- add groff-reproducible-mdate.patch and groff-use-SDE.patch to allow
to override build time to make package build reproducible (boo#1047218)

==== groff-full ====
Subpackages: gxditview

- add groff-reproducible-mdate.patch and groff-use-SDE.patch to allow
to override build time to make package build reproducible (boo#1047218)

==== hwinfo ====
Version update (21.58 -> 21.61)

- merge gh#openSUSE/hwinfo#72
- fix id of s-par storage controller (bsc#1107196)
- 21.61
- merge gh#openSUSE/hwinfo#71
- add network interfaces found on mdio bus (bsc#1018271)
- 21.60
- merge gh#openSUSE/hwinfo#70
- The location of the S-Par drivers virtual buses has changed
(bsc#1107196)
- The location of the S-Par drivers virtual buses has changed
- 21.59

==== kactivitymanagerd ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kactivitymanagerd-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kcm_sddm ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kcm_sddm-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kde-cli-tools5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kde-cli-tools5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kde-gtk-config5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kde-user-manager ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kde-user-manager-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kdeconnect-kde ====
Version update (1.3.2 -> 1.3.3)
Subpackages: kdeconnect-kde-lang

- Update to 1.3.3
* Instantiate QApplication object to fix crash on KDE Neon
(kde#400178)
* Fix build failure on musl based systems (kde#395161)

==== kdepim-addons ====
Subpackages: kdepim-addons-lang

- Add patch to enable by default some commonly used options in
kmail:
* 0001-Enable-the-expert-plugin-by-default.patch

==== kexec-tools ====
Version update (2.0.17 -> 2.0.18)

- Remove bogus Url RPM tag: The project does not have a home page.
- Bump to version 2.0.18
Changelog:
http://git.kernel.org/cgit/utils/kernel/kexec/kexec-tools.git/log/?id=refs/tags/v2.0.17..v2.0.18
- Drop patches from upstream git:
* kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32.patch
- Remove the confusing kdump binary (no longer in upstream).

==== kgamma5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kgamma5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== khotkeys5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: khotkeys5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kinfocenter5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kinfocenter5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kmenuedit5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kmenuedit5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kscreen5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kscreen5-lang kscreen5-plasmoid

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kscreenlocker ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== ksshaskpass5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: ksshaskpass5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== ksysguard5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: ksysguard5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kunitconversion ====
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Use noun phrase in summary.

==== kwayland-integration ====
Version update (5.14.2 -> 5.14.3)

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== kwin5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: kwin5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* Flush kwinrulesrc in RuleBook::save (kde#399778)
* [effects/desktopgrid] Don't display the close button from Present Windows
(kde#364710)
* [effects/presentwindows] Avoid potential freeze during fill-gaps
(kde#364709,kde#380865,kde#368811)
* [effects/thumbnailaside] Save shortcuts (kde#400351)
* [effects/desktopgrid] Specify screen projection matrix when drawing moving
window (kde#361371,kde#364509)
* [effects/invert] Don't block blur and background contrast effect
(kde#279076,kde#359583)

==== libdazzle ====
Version update (3.30.1 -> 3.30.2)
Subpackages: libdazzle-1_0-0 typelib-1_0-libdazzle-1_0

- Update to version 3.30.2:
+ Fix build dependency to properly check for gtk+ >= 3.24.
+ App-window now uses GtkEventControllerMotion to provide
improved tracking of the app window fullscreen toolbar.
+ Shortcut placement was tweaked in menu popover.
+ Fixes for shift+tab and ctrl+shift+d keyboard shortcuts.
+ Various build fixes for -Bsymbolic and assertions.

==== libgcrypt ====
Version update (1.8.3 -> 1.8.4)
Subpackages: libgcrypt20 libgcrypt20-32bit libgcrypt20-hmac

- libgcrypt 1.8.4:
* Fix infinite loop with specific application implementations
* Fix possible leak of a few bits of secret primes to pageable
memory
* Fix possible hang in the RNG (1.8.3)
* Always make use of getrandom if possible and then use
its /dev/urandom behaviour

==== libgphoto2 ====
Version update (2.5.19 -> 2.5.20)
Subpackages: libgphoto2-6 libgphoto2-6-lang

- updated to 2.5.20 release
- ptp2:
* Canon EOS: fixed regression for some EOS series in OLC decoding
* Apple iPhone: disabled PTP Manifest reading again, as IOS seems not to
follow the standard
* bugfixes
* new IDs added:
* Sony Alpha-RX10M4
* Canon EOS M50, 4000D
* Fuji XT-3
* synced new MTP ids from libmtp
- pentax:
* refreshed from pktriggercord
- translations:
* updated polish, ukrainian, swedish, danish

==== libisoburn ====
Version update (1.4.8 -> 1.5.0)
Subpackages: libisoburn1 xorriso

- Update to 1.5.0:
* Bug fix: Multi-session emulation was not recognized with
non-zero partition offset
* New bit10 of isoburn_drive_aquire() to accept all xattr
namespaces
* New -xattr mode "any" to process all xattr namespaces of local
filesystem
* New -as mkisofs option --xattr-any
* New -as mkisofs options -uid and -gid

==== libkdecoration2 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: libkdecorations2-5 libkdecorations2-5-lang libkdecorations2private6

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== libkscreen2 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== libksysguard5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: libksysguard5-helper libksysguard5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== libmtp ====
Version update (1.1.15 -> 1.1.16)
Subpackages: libmtp-udev libmtp9

- updated to 1.1.16 release
- lots of new USB ids
- some bugfixes
- adjust udev rules for new kernel versions (bsc#1110868)

==== libnumbertext ====
Subpackages: libnumbertext-1_0-0 libnumbertext-data

- Drop libnumbertext-boost.patch and rather rely on new gcc, safer
- Add patch libnumbertext-boost.patch to fix build with boost
and enable build on older distributions

==== libsolv ====
Version update (0.6.35 -> 0.7.1)
Subpackages: libsolv-devel libsolv-tools python3-solv ruby-solv

- fix nasty off-by-one error in repo_write
- also copy pattern categories from the rpm that defines the
pattern [fate#323785]
- bump version to 0.7.1
- new repowriter interface
- new selection_make_matchsolvable function
- dropped support of REPOKEY_TYPE_U32
- bindings: Selection.flags is now an attribute
- bump version to 0.7.0

==== libsoup ====
Version update (2.64.1 -> 2.64.2)
Subpackages: libsoup-2_4-1 libsoup-lang typelib-1_0-Soup-2_4

- Update to version 2.64.2:
+ TLD tests updated.
+ Updated translations.

==== libssh ====
Version update (0.8.4 -> 0.8.5)

- Update to version 0.8.5
* Added support to get known_hosts locations with ssh_options_get()
* Fixed preferred algorithm for known hosts negotiations
* Fixed KEX with some server implementations (e.g. Cisco)
* Fixed issues with MSVC
* Fixed keyboard-interactive auth in server mode
(regression from CVE-2018-10933)
* Fixed gssapi auth in server mode (regression from CVE-2018-10933)
* Fixed socket fd handling with proxy command
* Fixed a memory leak with OpenSSL

==== libstorage-ng ====
Version update (4.1.53 -> 4.1.54)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- Translated using Weblate (Chinese (China))
- 4.1.54
- merge gh#openSUSE/libstorage-ng#589
- Add method Luks#get_uuid

==== libyui ====

- Changed dir of COPYING file.

==== libyui-ncurses ====

- Changed dir of COPYING file.

==== libzypp ====
Version update (17.8.0 -> 17.8.1)

- Adapt to changed type names in libsolv-0.7
- Package needreboot file (fate#326451)
- Fix definitions of gettext macros (fixes #135)
- version 17.8.1 (2)

==== milou5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: milou5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== nautilus ====
Version update (3.30.2 -> 3.30.3)
Subpackages: gnome-shell-search-provider-nautilus libnautilus-extension1
nautilus-lang

- Update to version 3.30.3:
+ Fix crashes in search.
+ Fix crash in path bar usage.
+ Fix error dialog not showing when renaming.
+ Trigger location entry with the slash numpad key too.

==== openldap2 ====
Subpackages: libldap-2_4-2 libldap-2_4-2-32bit libldap-data openldap2-client
openldap2-devel

- Fixed broken memory handling in
0001-ITS-8866-slapo-unique-to-return-filter-used-in-diagn.patch
affecting error response of slapo-unique

==== oxygen5 ====
Version update (5.14.2 -> 5.14.3)

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== patterns-devel-osc ====

- Change icon for OSC devel pattern.

==== perl-DateTime-TimeZone ====
Version update (2.19 -> 2.21)

- update to 2.21:
* based on 2018f of the Olson database
* includes contemporary changes for Morocco (bsc#1113554)
* includes contemporary changes for Russia (Volograd), Fiji,
and Chile (bsc#1104700)

==== perl-Template-Toolkit ====
Version update (2.27 -> 2.28)

- updated to 2.28
see /usr/share/doc/packages/perl-Template-Toolkit/Changes
* Matthew Somerville stopped a list import from printing an ARRAY(...) string.
https://github.com/abw/Template2/issues/33
[#]-----------------------------------------------------------------------
[#] Unreleased
[#]------------------------------------------------------------------------
[#]-----------------------------------------------------------------------
[#] Version 2.28 - 11th October 2018
[#]------------------------------------------------------------------------
* Add and enable Travis CI to track GitHub Pull Requests
* Template is now using GitHub as the official Bug Tracker
* Nicolas R. fixed a circular reference in Template::Plugin::Filter
https://github.com/abw/Template2/issues/152
* Nicolas R. adjusted group regexes to not be greedy
https://github.com/abw/Template2/issues/94
* Nicolas R. added unit tests to cover regression from RT 91172
https://github.com/abw/Template2/issues/122
* Nicolas R. added support for template files having mtime=0
https://github.com/abw/Template2/issues/102
* Todd Rinaldo fixed rand calls with no args in Math plugin
https://github.com/abw/Template2/issues/155
* Todd Rinaldo corrected ttree 2.22 logic change
https://github.com/abw/Template2/issues/148
* Todd Rinaldo turned off automated testing for tests using optional modules
https://github.com/abw/Template2/issues/156
* Nicolas R. adjusted unit tests to not force Stash::XS
* Nicolas R. added a pre allocated buffer in Stash.xs to avoid malloc/free
https://github.com/abw/Template2/issues/82
* Nicolas R. optmized Template::Parser by avoiding a dummy sub
https://github.com/abw/Template2/issues/83
* Nicolas R. optimized Template:Directive by using index
https://github.com/abw/Template2/issues/84
* Nicolas R. adjust _dotop logic in Stash for perl 5.28 and earlier
https://github.com/abw/Template2/issues/81
* Todd Rinaldo documented VMethod method called 'item'
https://github.com/abw/Template2/issues/90
* Nicolas R. adjusted t/filter.t after recent switch to RFC3986
https://github.com/abw/Template2/issues/179
* Nicolas R. fixed warnings from t/cgi.t
https://github.com/abw/Template2/issues/178
* Ivan Krylov added STRICT option to ttree
https://github.com/abw/Template2/issues/81
* Kent Fredric fixed relative path handling in templates on Perl 5.26+
https://github.com/abw/Template2/issues/80
* Tom Delmas fixed some typo from documentation
https://github.com/abw/Template2/issues/76
* Matthew Somerville switched uri/url to use RFC3986
updated the documentation to match the history.
https://github.com/abw/Template2/issues/35
* Sebastien Deseille used remove_tree helper to remove directories
https://github.com/abw/Template2/issues/67
* Nick Hibma - Add Sortkeys to DUMPER_ARGS
https://github.com/abw/Template2/issues/64
* E. Choroba added a warn on duplicate block name
https://github.com/abw/Template2/issues/61
* Jason Lewis fixed some typo in ttree.pod
https://github.com/abw/Template2/issues/58

==== plasma-browser-integration ====
Version update (5.14.2 -> 5.14.3)
Subpackages: plasma-browser-integration-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== plasma-nm5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* Use appropriate icon in system tray settings BUG: 400587 FIXED-IN: 5.14.3
(kde#400587)

==== plasma5-addons ====
Version update (5.14.2 -> 5.14.3)
Subpackages: plasma5-addons-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* [comicprovider] Restart timer on redirect request

==== plasma5-desktop ====
Version update (5.14.2 -> 5.14.3)
Subpackages: plasma5-desktop-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* [Libinput KCMs] Remove tiny dots by using Kirigami.Separator correctly
* Swap Trash/Delete when Shift is used while the menu is open (kde#395155)

==== plasma5-integration ====
Version update (5.14.2 -> 5.14.3)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.14.3

==== plasma5-pa ====
Version update (5.14.2 -> 5.14.3)
Subpackages: plasma5-pa-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* Set appropriate icon for plasmoid (kde#400586)
* Fix connecting to PulseAudio with Qt 5.12 beta 3

==== plasma5-workspace ====
Version update (5.14.2 -> 5.14.3)
Subpackages: gmenudbusmenuproxy plasma5-session plasma5-session-wayland
plasma5-workspace-lang plasma5-workspace-libs xembedsniproxy

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- Changes since 5.14.2:
* Only use wl-shell for the ksmserver greeters on Qt < 5.12 (kde#399918)

==== plymouth ====
Version update (0.9.3+git20181016.a588b3f -> 0.9.4+git20181105.f898586)
Subpackages: libply-boot-client4 libply-splash-core4 libply-splash-graphics4
libply4 plymouth-dracut plymouth-plugin-label plymouth-plugin-label-ft
plymouth-plugin-script plymouth-plugin-two-step plymouth-scripts

- Update to version 0.9.4+git20181105.f898586
bump to 0.9.4
- Update to version 0.9.3+git20181031.025ce59:
drm: use preferred mode for outputs
drm: Refactor ply_renderer_connector_get_rotation
drm: Reset LUT/gamma table before the first drmModeSetCrtc call
libply: Move kernel commandline parsing functions to libply/ply-utils
throbber: Don't skip last frame when waiting for end.
- Drop plymouth-throbber-Don-t-skip-last-frame-when-waiting-for-end.patch
* Upstream has already accept Michal's modification.
- plymouth-throbber-Don-t-skip-last-frame-when-waiting-for-end.patch
* Make sure plymouthd stops throbber animation at the first
opportunity after receiving quit command, instead of looping
multiple times. (boo#1110199)

==== polari ====
Version update (3.30.1 -> 3.30.2)
Subpackages: polari-lang typelib-1_0-Polari-1_0

- Update to version 3.30.2:
+ Fix regression with predefined networks.
+ Updated translations.

==== polkit-kde-agent-5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: polkit-kde-agent-5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== powerdevil5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: powerdevil5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== python-boto ====
Version update (2.48.0 -> 2.49.0)

- update to version 2.49.0
* Import the latest CA Bundle from certifi (:issue:`3818`, :sha:`e4699cba`)
* Fix to support uploads to KMS-encrypted buckets. (:issue:`3800`,
:sha:`0a1d9040`)
* Support fetching GCS bucket encryption metadata. (:issue:`3799`,
:sha:`132b64d2`)
* Update layer1.py (:issue:`3765`, :sha:`53340159`)
* Fix tests/unit/glacier/test_writer.py to make work with pypy.
(:issue:`3762`, :sha:`8402c5d6`)

==== python-boto3 ====
Version update (1.8.1 -> 1.9.38)

- Version update to 1.9.38
* api-change:``eks``: [``botocore``] Update eks client to latest version
* enhancement:Configuration: [``botocore``] Added new configuration provider
methods allowing for more flexibility in how a botocore session loads a
particular configuration value.
* api-change:``serverlessrepo``: [``botocore``] Update serverlessrepo client
to latest version
- Update Requires in spec file from setup.py
- Version update to 1.9.37
* api-change:``rekognition``: [``botocore``] Update rekognition client to
latest version
* api-change:``clouddirectory``: [``botocore``] Update clouddirectory client
to latest version
- from version 1.9.36
* api-change:``servicecatalog``: [``botocore``] Update servicecatalog client
to latest version
* enhancement:Exceptions: [``botocore``] Add the ability to pickle botocore
exceptions (`834 <https://github.com/boto/botocore/issues/834>`__)
- from version 1.9.35
* api-change:``mediastore-data``: [``botocore``] Update mediastore-data
client to latest version
* api-change:``secretsmanager``: [``botocore``] Update secretsmanager client
to latest version
* api-change:``greengrass``: [``botocore``] Update greengrass client to
latest version
* api-change:``config``: [``botocore``] Update config client to latest version
- from version 1.9.34
* api-change:``chime``: [``botocore``] Update chime client to latest version
* api-change:``rds``: [``botocore``] Update rds client to latest version
* api-change:``dms``: [``botocore``] Update dms client to latest version
- from 1.9.33
* api-change:``sagemaker``: [``botocore``] Update sagemaker client to latest
version
* api-change:``alexaforbusiness``: [``botocore``] Update alexaforbusiness
client to latest version
* api-change:``ssm``: [``botocore``] Update ssm client to latest version
- from version 1.9.32
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
- from version 1.9.31
* api-change:``codestar``: [``botocore``] Update codestar client to latest
version
* api-change:``alexaforbusiness``: [``botocore``] Update alexaforbusiness
client to latest version
- from version 1.9.30
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
- from version 1.9.29
* api-change:``inspector``: [``botocore``] Update inspector client to latest
version
* api-change:``shield``: [``botocore``] Update shield client to latest version
- from version 1.9.28
* api-change:``workspaces``: [``botocore``] Update workspaces client to
latest version
* api-change:``ssm``: [``botocore``] Update ssm client to latest version
- from version 1.9.27
* api-change:``medialive``: [``botocore``] Update medialive client to latest
version
* api-change:``route53``: [``botocore``] Update route53 client to latest
version
* api-change:``appstream``: [``botocore``] Update appstream client to latest
version
- from version 1.9.26
* api-change:``events``: [``botocore``] Update events client to latest version
* api-change:``apigateway``: [``botocore``] Update apigateway client to
latest version
- from version 1.9.25
* api-change:``glue``: [``botocore``] Update glue client to latest version
* api-change:``lightsail``: [``botocore``] Update lightsail client to latest
version
* api-change:``resource-groups``: [``botocore``] Update resource-groups
client to latest version
- from version 1.9.24
* api-change:``rds``: [``botocore``] Update rds client to latest version
* api-change:``lambda``: [``botocore``] Update lambda client to latest version
* api-change:``servicecatalog``: [``botocore``] Update servicecatalog client
to latest version
- from version 1.9.23
* api-change:``cloudtrail``: [``botocore``] Update cloudtrail client to
latest version
- from version 1.9.22
* api-change:``athena``: [``botocore``] Update athena client to latest version
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
* api-change:``transcribe``: [``botocore``] Update transcribe client to
latest version
* api-change:``mediaconvert``: [``botocore``] Update mediaconvert client to
latest version
* api-change:``directconnect``: [``botocore``] Update directconnect client to
latest version
- from version 1.9.21
* api-change:``transcribe``: [``botocore``] Update transcribe client to
latest version
* api-change:``comprehend``: [``botocore``] Update comprehend client to
latest version
* api-change:``es``: [``botocore``] Update es client to latest version
- from version 1.9.20
* enhancement:TLS: [``botocore``] Added support for configuring a client
certificate and key when establishing TLS connections.
* api-change:``ssm``: [``botocore``] Update ssm client to latest version
* bugfix:InstanceMetadataFetcher: [``botocore``] Fix failure to retry
on empty credentials and invalid JSON returned from IMDS
`1049 <https://github.com/boto/botocore/issues/1049>`__
`1403 <https://github.com/boto/botocore/issues/1403>`__
- from version 1.9.19
* api-change:``iot``: [``botocore``] Update iot client to latest version
* api-change:``iot-jobs-data``: [``botocore``] Update iot-jobs-data client to
latest version
- from version 1.9.18
* api-change:``ds``: [``botocore``] Update ds client to latest version
- from version 1.9.17
* api-change:``ssm``: [``botocore``] Update ssm client to latest version
* api-change:``codebuild``: [``botocore``] Update codebuild client to latest
version
* enhancement:HTTP Session: [``botocore``] Added the ability to enable TCP
Keepalive
via the shared config file's ``tcp_keepalive`` option.
* api-change:``apigateway``: [``botocore``] Update apigateway client to
latest version
* api-change:``storagegateway``: [``botocore``] Update storagegateway client
to latest version
- from version 1.9.16
* api-change:``sagemaker``: [``botocore``] Update sagemaker client to latest
version
* api-change:``secretsmanager``: [``botocore``] Update secretsmanager client
to latest version
- from version 1.9.15
* api-change:``rekognition``: [``botocore``] Update rekognition client to
latest version
* api-change:``guardduty``: [``botocore``] Update guardduty client to latest
version
- from version 1.9.14
* api-change:``codestar``: [``botocore``] Update codestar client to latest
version
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
- from version 1.9.13
* api-change:``mq``: [``botocore``] Update mq client to latest version
* api-change:``apigateway``: [``botocore``] Update apigateway client to
latest version
* enhancement:Event: [``botocore``] Add the `before-send` event which allows
finalized
requests to be inspected before being sent across the wire and allows for
custom
responses to be returned.
* api-change:``codecommit``: [``botocore``] Update codecommit client to
latest version
- from version 1.9.12
* api-change:``sqs``: [``botocore``] Update sqs client to latest version
* api-change:``glue``: [``botocore``] Update glue client to latest version
* api-change:``opsworkscm``: [``botocore``] Update opsworkscm client to
latest version
* api-change:``rds``: [``botocore``] Update rds client to latest version
- from version 1.9.11
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
* api-change:``cloudfront``: [``botocore``] Update cloudfront client to
latest version
* api-change:``ds``: [``botocore``] Update ds client to latest version
- from version 1.9.10
* api-change:``connect``: [``botocore``] Update connect client to latest
version
* api-change:``rds``: [``botocore``] Update rds client to latest version
- from version 1.9.9
* api-change:``mediaconvert``: [``botocore``] Update mediaconvert client to
latest version
- from version 1.9.8
* api-change:``rds``: [``botocore``] Update rds client to latest version
* api-change:``ds``: [``botocore``] Update ds client to latest version
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
- from version 1.9.7
* api-change:``cloudwatch``: [``botocore``] Update cloudwatch client to
latest version
* api-change:``s3``: [``botocore``] Update s3 client to latest version
* api-change:``organizations``: [``botocore``] Update organizations client to
latest version
- from version 1.9.6
* bugfix:Serialization: [``botocore``] Fixes `#1557
<https://github.com/boto/botocore/issues/1557>`__. Fixed a regression
in serialization where request bodies would be improperly encoded.
* api-change:``es``: [``botocore``] Update es client to latest version
* api-change:``rekognition``: [``botocore``] Update rekognition client to
latest version
- from version 1.9.5
* api-change:``codebuild``: [``botocore``] Update codebuild client to latest
version
* api-change:``elastictranscoder``: [``botocore``] Update elastictranscoder
client to latest version
* api-change:``ecs``: [``botocore``] Update ecs client to latest version
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
* api-change:``cloudwatch``: [``botocore``] Update cloudwatch client to
latest version
* api-change:``secretsmanager``: [``botocore``] Update secretsmanager client
to latest version
* api-change:``elasticache``: [``botocore``] Update elasticache client to
latest version
- from version 1.9.4
* enhancement:s3: [``botocore``] Adds encoding and decoding handlers for
ListObjectsV2 `#1552 <https://github.com/boto/botocore/issues/1552>`__
* api-change:``polly``: [``botocore``] Update polly client to latest version
- from version 1.9.3
* api-change:``ses``: [``botocore``] Update ses client to latest version
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
* api-change:``fms``: [``botocore``] Update fms client to latest version
* api-change:``connect``: [``botocore``] Update connect client to latest
version
- from version 1.9.2
* api-change:``opsworkscm``: [``botocore``] Update opsworkscm client to
latest version
* api-change:``ssm``: [``botocore``] Update ssm client to latest version
- from version 1.9.1
* api-change:``redshift``: [``botocore``] Update redshift client to latest
version
* api-change:``cloudhsmv2``: [``botocore``] Update cloudhsmv2 client to
latest version
- from version 1.9.0
* api-change:``logs``: [``botocore``] Update logs client to latest version
* api-change:``config``: [``botocore``] Update config client to latest version
* feature:Events: [``botocore``] This migrates the event system to using
sevice
ids instead of either client name or endpoint prefix. This prevents issues
that might arise when a service changes their endpoint prefix, also fixes a
long-standing bug where you could not register an event to a particular
service
if it happened to share its endpoint prefix with another service (e.g.
``autoscaling`` and ``application-autoscaling`` both use the endpoint prefix
``autoscaling``). Please see the `upgrade notes
<https://botocore.amazonaws.com/
v1/documentation/api/latest/index.html#upgrade-notes>`_ to determine if you
are
impacted and how to proceed if you are.
* feature:Events: This migrates the event system to using sevice ids instead
of
either client name or endpoint prefix. This prevents issues that might
arise when
a service changes their endpoint prefix, also fixes a long-standing bug
where you
could not register an event to a particular service if it happened to share
its
endpoint prefix with another service (e.g. ``autoscaling`` and
``application-autoscaling``
both use the endpoint prefix ``autoscaling``). Please see the `upgrade notes

<https://boto3.amazonaws.com/v1/documentation/api/latest/guide/upgrading.html>`_
to determine if you are impacted and how to proceed if you are.
- from version 1.8.9
* api-change:``apigateway``: [``botocore``] Update apigateway client to
latest version
* api-change:``codecommit``: [``botocore``] Update codecommit client to
latest version
* api-change:``mediaconvert``: [``botocore``] Update mediaconvert client to
latest version
- from version 1.8.8
* api-change:``rds``: [``botocore``] Update rds client to latest version
* api-change:``s3``: [``botocore``] Update s3 client to latest version
* api-change:``appstream``: [``botocore``] Update appstream client to latest
version
* api-change:``dynamodb``: [``botocore``] Update dynamodb client to latest
version
* api-change:``elb``: [``botocore``] Update elb client to latest version
- from version 1.8.7
* api-change:``rds``: [``botocore``] Update rds client to latest version
* api-change:``rekognition``: [``botocore``] Update rekognition client to
latest version
- from version 1.8.6
* api-change:``waf-regional``: [``botocore``] Update waf-regional client to
latest version
* api-change:``waf``: [``botocore``] Update waf client to latest version
* api-change:``eks``: [``botocore``] Update eks client to latest version
- from version 1.8.5
* api-change:``codebuild``: [``botocore``] Update codebuild client to latest
version
* api-change:``sagemaker``: [``botocore``] Update sagemaker client to latest
version
* bugfix:signing: [``botocore``] Fix an issue where mixed endpoint casing
could cause a SigV4 signature mismatch.
- from version 1.8.4
* api-change:``glue``: [``botocore``] Update glue client to latest version
* api-change:``sagemaker-runtime``: [``botocore``] Update sagemaker-runtime
client to latest version
* api-change:``mediapackage``: [``botocore``] Update mediapackage client to
latest version
- from version 1.8.3
* api-change:``glue``: [``botocore``] Update glue client to latest version
* api-change:``xray``: [``botocore``] Update xray client to latest version
- from version 1.8.2
* api-change:``iot``: [``botocore``] Update iot client to latest version
* api-change:``signer``: [``botocore``] Update signer client to latest version
* api-change:``redshift``: [``botocore``] Update redshift client to latest
version
* api-change:``iotanalytics``: [``botocore``] Update iotanalytics client to
latest version
- Update Requires in spec file from setup.py

==== python-botocore ====
Version update (1.11.1 -> 1.12.38)

- Version update to 1.12.38
* api-change:``eks``: Update eks client to latest version
* enhancement:Configuration: Added new configuration provider methods
allowing for more flexibility in how a botocore session loads a
particular configuration value.
* api-change:``serverlessrepo``: Update serverlessrepo client to latest
version
- from version 1.12.37
* api-change:``rekognition``: Update rekognition client to latest version
* api-change:``clouddirectory``: Update clouddirectory client to latest
version
- from version 1.12.36
* api-change:``servicecatalog``: Update servicecatalog client to latest
version
* enhancement:Exceptions: Add the ability to pickle botocore exceptions
(`834 <https://github.com/boto/botocore/issues/834>`__)
- from version 1.12.35
* api-change:``mediastore-data``: Update mediastore-data client to latest
version
* api-change:``secretsmanager``: Update secretsmanager client to latest
version
* api-change:``greengrass``: Update greengrass client to latest version
* api-change:``config``: Update config client to latest version
- from version 1.12.34
* api-change:``chime``: Update chime client to latest version
* api-change:``rds``: Update rds client to latest version
* api-change:``dms``: Update dms client to latest version
- from version 1.12.33
* api-change:``sagemaker``: Update sagemaker client to latest version
* api-change:``alexaforbusiness``: Update alexaforbusiness client to latest
version
* api-change:``ssm``: Update ssm client to latest version
- from version 1.12.32
* api-change:``ec2``: Update ec2 client to latest version
- from version 1.12.31
* api-change:``codestar``: Update codestar client to latest version
* api-change:``alexaforbusiness``: Update alexaforbusiness client to latest
version
- from version 1.12.30
* api-change:``ec2``: Update ec2 client to latest version
- from version 1.12.29
* api-change:``inspector``: Update inspector client to latest version
* api-change:``shield``: Update shield client to latest version
- from version 1.12.28
* api-change:``workspaces``: Update workspaces client to latest version
* api-change:``ssm``: Update ssm client to latest version
- from version 1.12.27
* api-change:``medialive``: Update medialive client to latest version
* api-change:``route53``: Update route53 client to latest version
* api-change:``appstream``: Update appstream client to latest version
- from version 1.12.26
* api-change:``events``: Update events client to latest version
* api-change:``apigateway``: Update apigateway client to latest version
- from version 1.12.25
* api-change:``glue``: Update glue client to latest version
* api-change:``lightsail``: Update lightsail client to latest version
* api-change:``resource-groups``: Update resource-groups client to latest
version
- from version 1.12.24
* api-change:``rds``: Update rds client to latest version
* api-change:``lambda``: Update lambda client to latest version
* api-change:``servicecatalog``: Update servicecatalog client to latest
version
- from version 1.12.23
* api-change:``cloudtrail``: Update cloudtrail client to latest version
- from version 1.12.22
* api-change:``athena``: Update athena client to latest version
* api-change:``ec2``: Update ec2 client to latest version
* api-change:``transcribe``: Update transcribe client to latest version
* api-change:``mediaconvert``: Update mediaconvert client to latest version
* api-change:``directconnect``: Update directconnect client to latest version
- from version 1.12.21
* api-change:``transcribe``: Update transcribe client to latest version
* api-change:``comprehend``: Update comprehend client to latest version
* api-change:``es``: Update es client to latest version
- from version 1.12.20
* enhancement:TLS: Added support for configuring a client certificate
and key when establishing TLS connections.
* api-change:``ssm``: Update ssm client to latest version
* bugfix:InstanceMetadataFetcher: Fix failure to retry on empty credentials
and invalid JSON returned from IMDS `1049
<https://github.com/boto/botocore/issues/1049>`__
`1403 <https://github.com/boto/botocore/issues/1403>`__
- from version 1.12.19
* api-change:``iot``: Update iot client to latest version
* api-change:``iot-jobs-data``: Update iot-jobs-data client to latest version
- from version 1.12.18
* api-change:``ds``: Update ds client to latest version
- from version 1.12.17
* api-change:``ssm``: Update ssm client to latest version
* api-change:``codebuild``: Update codebuild client to latest version
* enhancement:HTTP Session: Added the ability to enable TCP Keepalive via the
shared config file's ``tcp_keepalive`` option.
* api-change:``apigateway``: Update apigateway client to latest version
* api-change:``storagegateway``: Update storagegateway client to latest
version
- from version 1.12.16
* api-change:``sagemaker``: Update sagemaker client to latest version
* api-change:``secretsmanager``: Update secretsmanager client to latest
version
- from version 1.12.15
* api-change:``rekognition``: Update rekognition client to latest version
* api-change:``guardduty``: Update guardduty client to latest version
- from version 1.12.14
* api-change:``codestar``: Update codestar client to latest version
* api-change:``ec2``: Update ec2 client to latest version
- from version 1.12.13
* api-change:``mq``: Update mq client to latest version
* api-change:``apigateway``: Update apigateway client to latest version
* enhancement:Event: Add the `before-send` event which allows finalized
requests
to be inspected before being sent across the wire and allows for custom
responses to be returned.
* api-change:``codecommit``: Update codecommit client to latest version
- from version 1.12.12
* api-change:``sqs``: Update sqs client to latest version
* api-change:``glue``: Update glue client to latest version
* api-change:``opsworkscm``: Update opsworkscm client to latest version
* api-change:``rds``: Update rds client to latest version
- from version 1.12.11
* api-change:``ec2``: Update ec2 client to latest version
* api-change:``cloudfront``: Update cloudfront client to latest version
* api-change:``ds``: Update ds client to latest version
- from version 1.12.10
* api-change:``connect``: Update connect client to latest version
* api-change:``rds``: Update rds client to latest version
- from version 1.12.9
* api-change:``mediaconvert``: Update mediaconvert client to latest version
- from version 1.12.8
* api-change:``rds``: Update rds client to latest version
* api-change:``ds``: Update ds client to latest version
* api-change:``ec2``: Update ec2 client to latest version
- from version 1.12.7
* api-change:``cloudwatch``: Update cloudwatch client to latest version
* api-change:``s3``: Update s3 client to latest version
* api-change:``organizations``: Update organizations client to latest version
- from version 1.12.6
* bugfix:Serialization: Fixes `#1557
<https://github.com/boto/botocore/issues/1557>`__.
Fixed a regression in serialization where request bodies would be
improperly encoded.
* api-change:``es``: Update es client to latest version
* api-change:``rekognition``: Update rekognition client to latest version
- from version 1.12.5
* api-change:``codebuild``: Update codebuild client to latest version
* api-change:``elastictranscoder``: Update elastictranscoder client to latest
version
* api-change:``ecs``: Update ecs client to latest version
* api-change:``ec2``: Update ec2 client to latest version
* api-change:``cloudwatch``: Update cloudwatch client to latest version
* api-change:``secretsmanager``: Update secretsmanager client to latest
version
* api-change:``elasticache``: Update elasticache client to latest version
- from version 1.12.4
* enhancement:s3: Adds encoding and decoding handlers for ListObjectsV2
`#1552 <https://github.com/boto/botocore/issues/1552>`__
* api-change:``polly``: Update polly client to latest version
- from version 1.12.3
* api-change:``ses``: Update ses client to latest version
* api-change:``ec2``: Update ec2 client to latest version
* api-change:``fms``: Update fms client to latest version
* api-change:``connect``: Update connect client to latest version
- from version 1.12.2
* api-change:``opsworkscm``: Update opsworkscm client to latest version
* api-change:``ssm``: Update ssm client to latest version
- from version 1.12.1
* api-change:``redshift``: Update redshift client to latest version
* api-change:``cloudhsmv2``: Update cloudhsmv2 client to latest version
- from version 1.12.0
* api-change:``logs``: Update logs client to latest version
* api-change:``config``: Update config client to latest version
* feature:Events: This migrates the event system to using sevice ids
instead of either client name or endpoint prefix. This prevents issues
that might arise when a service changes their endpoint prefix, also
fixes a long-standing bug where you could not register an event to a
particular service if it happened to share its endpoint prefix with
another service (e.g. ``autoscaling`` and ``application-autoscaling``
both use the endpoint prefix ``autoscaling``). Please see the `upgrade
notes
<https://botocore.amazonaws.com/v1/documentation/api/latest/index.html#upgrade-notes>`_
to determine if you are impacted and how to proceed if you are.
- from version 1.11.9
* api-change:``apigateway``: Update apigateway client to latest version
* api-change:``codecommit``: Update codecommit client to latest version
* api-change:``mediaconvert``: Update mediaconvert client to latest version
- from version 1.11.8
* api-change:``rds``: Update rds client to latest version
* api-change:``s3``: Update s3 client to latest version
* api-change:``appstream``: Update appstream client to latest version
* api-change:``dynamodb``: Update dynamodb client to latest version
* api-change:``elb``: Update elb client to latest version
- from version 1.11.7
* api-change:``rds``: Update rds client to latest version
* api-change:``rekognition``: Update rekognition client to latest version
- from version 1.11.6
* api-change:``waf-regional``: Update waf-regional client to latest version
* api-change:``waf``: Update waf client to latest version
* api-change:``eks``: Update eks client to latest version
- from version 1.11.5
* api-change:``codebuild``: Update codebuild client to latest version
* api-change:``sagemaker``: Update sagemaker client to latest version
* bugfix:signing: Fix an issue where mixed endpoint casing could cause a
SigV4 signature mismatch.
- from version 1.11.4
* api-change:``glue``: Update glue client to latest version
* api-change:``sagemaker-runtime``: Update sagemaker-runtime client to latest
version
* api-change:``mediapackage``: Update mediapackage client to latest version
- from version 1.11.3
* api-change:``glue``: Update glue client to latest version
* api-change:``xray``: Update xray client to latest version
- from version 1.11.2
* api-change:``iot``: Update iot client to latest version
* api-change:``signer``: Update signer client to latest version
* api-change:``redshift``: Update redshift client to latest version
* api-change:``iotanalytics``: Update iotanalytics client to latest version
- Refresh patches for new version
+ hide_py_pckgmgmt.patch
- Update BuildRequires in spec file from setup.py

==== python-cffi ====
Subpackages: python2-cffi python3-cffi

- Add 7a76a381534012af4790e815140d1538510b7d93.patch to fix
bsc#1111657 (we need use to proper void returning function not
to corrupt memory in tests).

==== python-libvirt-python ====
Version update (4.8.0 -> 4.9.0)

- Update to 4.9.0
- Add all new APIs and constants in libvirt 4.9.0
- FATE#326371

==== python-numpy ====
Version update (1.15.2 -> 1.15.3)
Subpackages: python2-numpy python3-numpy

- Update to version 1.15.3
Changes documented in release notes:
https://github.com/numpy/numpy/blob/master/doc/release/1.15.2-notes.rst

==== python-psutil ====
Version update (5.4.7 -> 5.4.8)

- update to version 5.4.8:
* Enhancements
+ 1197: [Linux] cpu_freq() is now implemented by parsing
/proc/cpuinfo in case /sys/devices/system/cpu/* filesystem is
not available.
+ 1310: [Linux] psutil.sensors_temperatures() now parses
/sys/class/thermal in case /sys/class/hwmon fs is not available
(e.g. Raspberry Pi). (patch by Alex Manuskin)
+ 1320: [Posix] better compilation support when using g++ instead
of gcc. (patch by Jaime Fullaondo)
* Bug fixes
+ 715: do not print exception on import time in case cpu_times()
fails.
+ 1004: [Linux] Process.io_counters() may raise ValueError.
+ 1277: [OSX] available and used memory (psutil.virtual_memory())
metrics are not accurate.
+ 1294: [Windows] psutil.Process().connections() may sometimes
fail with intermittent 0xC0000001. (patch by Sylvain Duchesne)
+ 1307: [Linux] disk_partitions() does not honour PROCFS_PATH.
+ 1320: [AIX] system CPU times (psutil.cpu_times()) were being
reported with ticks unit as opposed to seconds. (patch by Jaime
Fullaondo)
+ 1332: [OSX] psutil debug messages are erroneously printed all
the time. (patch by Ilya Yanok)
+ 1346: [SunOS] net_connections() returns an empty list. (patch by
Oleksii Shevchuk)

==== python-py ====
Version update (1.5.4 -> 1.7.0)
Subpackages: python2-py python3-py

- update to 1.7.0
* use ``shutil.get_terminal_size()`` in Python 3.3+ to determine the size of
the
terminal, which produces more accurate results than the previous method.
* introduce new ``PY_IGNORE_IMPORTMISMATCH`` environment variable
that suppresses ``ImportMismatchError`` exceptions when set to ``1``.
* add ``TerminalWriter.width_of_current_line`` (i18n version of
``TerminalWriter.chars_on_current_line``), a read-only property
that tracks how wide the current line is, attempting to take
into account international characters in the calculation.

==== python-qt5 ====
Subpackages: python-qt5-utils python3-qt5

- python-enum34 is also required at runtime.

==== relaxngDatatype ====

- Install the provided pom file in order to generate correctly
the mvn(...) dependencies

==== rubygem-cfa ====
Version update (0.6.4 -> 0.7.0)

- Improve even more error reporting now with specialized exceptions
that holds all details for better user reports
(needed for bsc#1113996)
- 0.7.0

==== rubygem-concurrent-ruby ====
Version update (1.0.5 -> 1.1.1)

- updated to version 1.1.1
* (#768) add support for 1.9.3 back
[#]# Release v1.1.0, edge v0.4.0 (31 OCt 2018) (yanked)
* (#768) yanked because of issues with removed 1.9.3 support
[#]# Release v1.1.0.pre2, edge v0.4.0.pre2 (18 Sep 2018)
concurrent-ruby:
* fixed documentation and README links
* fix Set for TruffleRuby and Rubinius
* use properly supported TruffleRuby APIs
concurrent-ruby-edge:
* add Promises.zip_futures_over_on
[#]# Release v1.1.0.pre1, edge v0.4.0.pre1 (15 Aug 2018)
concurrent-ruby:
* requires at least Ruby 2.0
*
[Promises](http://ruby-concurrency.github.io/concurrent-ruby/1.1.0/Concurrent/Promises.html)
are moved from `concurrent-ruby-edge` to `concurrent-ruby`
* Add support for TruffleRuby
* (#734) Fix Array/Hash/Set construction broken on TruffleRuby
* AtomicReference fixed
* CI stabilization
* remove sharp dependency edge -> core
* remove warnings
* documentation updates
* Exchanger is no longer documented as edge since it was already available in
`concurrent-ruby`
* (#644) Fix Map#each and #each_pair not returning enumerator outside of MRI
* (#659) Edge promises fail during error handling
* (#741) Raise on recursive Delay#value call
* (#727) #717 fix global IO executor on JRuby
* (#740) Drop support for CRuby 1.9, JRuby 1.7, Rubinius.
* (#737) Move AtomicMarkableReference out of Edge
* (#708) Prefer platform specific memory barriers
* (#735) Fix wrong expected exception in channel spec assertion
* (#729) Allow executor option in `Promise#then`
* (#725) fix timeout check to use timeout_interval
* (#719) update engine detection
* (#660) Add specs for Promise#zip/Promise.zip ordering
* (#654) Promise.zip execution changes
* (#666) Add thread safe set implementation
* (#651) #699 #to_s, #inspect should not output negative object IDs.
* (#685) Avoid RSpec warnings about raise_error
* (#680) Avoid RSpec monkey patching, persist spec results locally, use RSpec
v3.7.0
* (#665) Initialize the monitor for new subarrays on Rubinius
* (#661) Fix error handling in edge promises
concurrent-ruby-edge:
* (#659) Edge promises fail during error handling
* Edge files clearly separated in `lib-edge`
* added ReInclude

==== rubygem-i18n ====
Version update (1.1.0 -> 1.1.1)

- updated to version 1.1.1
* Expose translations with an option to perform initialization (if it hasn't
been done already) (#353 / #254)
* Removed un-used Kernel core extension #436
* Added project metadata for RubyGems #434

==== rubygem-jbuilder ====
Version update (2.7.0 -> 2.8.0)

- updated to version 2.8.0
* Replace deprecated fragment_cache_key for Rails 5.2 support

==== rubygem-libyui-rake ====
Version update (0.1.11 -> 0.1.13)

- Changed the SLE12-SP4 SR target to the :Update subproject
(bsc#1113887)
- 0.1.13
- Remove qrc from license check (boo#1112041)
- 0.1.12

==== rubygem-loofah ====
Version update (2.2.2 -> 2.2.3)

- updated to version 2.2.3
[#]## Security (bsc#1113969, CVE-2018-16468)
Address CVE-2018-16468: Unsanitized JavaScript may occur in sanitized output
when a crafted SVG element is republished.
This CVE's public notice is at
https://github.com/flavorjones/loofah/issues/154
[#]# Meta / 2018-10-27
The mailing list is now on Google Groups
[#146](https://github.com/flavorjones/loofah/issues/146):
* Mail: loofah-talk@xxxxxxxxxxxxxxxx
* Archive: https://groups.google.com/forum/#!forum/loofah-talk
This change was made because librelist no longer appears to be maintained.

==== rubygem-method_source ====
Version update (0.9.0 -> 0.9.1)

- updated to version 0.9.1
no changelog found

==== rubygem-rack ====
Version update (2.0.5 -> 2.0.6)

- update to 2.0.6
see installed HISTORY.md

==== shared-mime-info ====
Version update (1.9 -> 1.10)
Subpackages: shared-mime-info-lang

- Update to version 1.10
+ Add mime-type for MJPEG raw streams
+ Add MPEG-4 Ringtone mime-type
+ Add mime-type for HEIF images
+ Add application/vnd.sqlite3, application/x-sqlite2 IANA types
+ Add application/pkcs8-encrypted
+ Add application/vnd.yotube.yt
+ Add audio/usac
+ Add mime-types for raw floppy disk images
+ Add aliases for SAP and HFE floppy image mime-types
+ Use new application/vnd.comicbook-rar IANA type

==== soundtouch ====
Version update (2.0.0 -> 2.1.0)

- Update to version 2.1.0
* Disable anti-alias filter when switch
SOUNDTOUCH_PREVENT_CLICK_AT_RATE_CROSSOVER defined
* Added script for building SoundTouchDll dynamic-link-library for
GNU platforms
* Rewrote Beats-per-Minute analysis algorithm for more reliable
BPM detection
* Added BPM functions to SoundTouchDll API
* Migrated Visual Studio project files to MSVC 201x format
* Replaced function parameter value asserts with runtime exceptions
- Fixed bugs:
* CVE-2018-17098 (bsc#1108632) -- remote denial of service
* CVE-2018-17097 (bsc#1108631) -- remote denial of service (double free)
* CVE-2018-17096 (bsc#1108630) -- remote denial of service
in BPMDetect.cpp
* boo#1113134 -- out of date package
- Removed obsolete patch fix-buffer-overflow.patch

==== srt ====

- Add pkgconfig(zlib) BuildRequires: until openssl 1.1.1, zlib was
pulled in into our buildroot, avoiding srt having to care for it
explicitly. Since this is changed now, we have to worry for our
dependency on our own. The dep comes from:
CMakeLists.txt:set (SSL_REQUIRED_MODULES "openssl libcrypto zlib")

==== syslinux ====

- sysmacros.patch: include <sys/sysmacros.h> for major/minor

==== sysprof ====
Version update (3.30.1 -> 3.30.2)
Subpackages: sysprof-lang

- Update to version 3.30.2:
+ The profiler menu button more properly handles changes to the
toplevel window.
+ Fixes for i18n/l10n intialization.

==== systemsettings5 ====
Version update (5.14.2 -> 5.14.3)
Subpackages: systemsettings5-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== units ====
Version update (2.17 -> 2.18)

- units 2.18:
* The units_cur script now supports multiple currency sources
* Add hyperbolic functions: sinh, cosh, tanh, asinh, acosh, atanh
* Add log to arbitrary integer bases: log3, log4, log72, etc.
* Units can be redefined without a warning by adding '+' before
the unit name in definitions.units.
* Add 'quit' and 'exit' commands.
* Add support for CGS electromagnetic units (activated using the
- u option or the UNITS_SYSTEM environment variable)
* Add !prompt command to add a prefix to the "You have:" prompt
* Texts specified with !message appear in the log file

==== virt-manager ====
Version update (1.5.1 -> 2.0.0)
Subpackages: virt-install virt-manager-common

- Upstream bug fixes (bsc#1027942)
b8aff280-virtinst-quickfix-ubuntu-net-preseed-insert-cdrom-error.patch
25b88733-urldetect-Dont-overload-suse_content-variable.patch
9308bae3-util-Fix-typo-vpcu-vcpu.patch
- Update to virt-manager 2.0.0 (fate#326786)
virt-manager-2.0.0.tar.bz2
* Finish port to Python 3 (Radostin Stoyanov, Cole Robinson)
* Improved VM defaults for supported OS: q35 PCIe, usb3, CPU host-model
* Search based OS selection UI for new VMs (Daniel P. Berrangé, Cole Robinson)
* Track OS name for lifetime of domain in XML
* Host interface management UI has been completely removed
* Show domain IP on interface details page (Lin Ma, Cole Robinson)
* More efficient stats polling with AllDomainStats (Simon Kobyda, Cole
Robinson)
* TPM device model and backend UI (Marc-André Lureau, Stefan Berger)
* Show connection state in UI (Lin Ma)
* Show attached devices in UI (Lin Ma)
* UI option to plug/unplug VM nic link (Simon Kobyda)
* UI support for disk discard and detect_zeroes (Povilas Kanapickas, Lin Ma)
* Improved SUSE ?location URL/ISO detection (Charles Arnold)
* cli and UI support for SCSI persistent reservations (Lin Ma)
* cli: Add ?network mtu.size= option (Anya Harter)
* cli: Add ?disk driver.copy_on_read (Anya Harter)
* cli: Add ?disk geometry support (Anya Harter)
* cli: Add ?sound codec support (Anya Harter)
* cli: Add ?hostdev net/char/block for LXC (Lubomir Rintel)
* cli: Add ?memorybacking access_mode and source_type (Marc-André Lureau)
* cli: Add ?boot rebootTimout (Yossi Ovadia)
* cli: Add ?boot bootloader=
* cli: Add ?destroy-on-exit
- Drop patches contained in new tarball or not required
0004-virtinst-python3-use-binary-mode-for-kernel.patch
27d4b167-virtinst-update-location-for-opensuse.patch
5a7698c7-fix-select-network-vol.patch
d15b78ab-virtinst-read-CPU-model-from-domain-capabilities.patch
fd6a8154-virtinst-compare-host-and-domain-cpu-models.patch
5a7698c7-fix-select-network-vol.patch
virtcli-python2-to-python3-conversion.patch
virtinst-add-ppc64-arch-support.patch
virtinst-check-date-format.patch
virtinst-fix-sle-distro-parsing.patch
virtinst-handle-tumbleweed-treeinfo-file.patch
virtinst-nfs-install-sanitize.patch
virtinst-no-usb-tablet-for-xenpv.patch
virtinst-set-qemu-emulator.patch
virtinst-storage-ocfs2.patch
virtman-add-connect-default.patch
virtman-fix-missing-translations.patch
virtman-libvirtd-not-running.patch
virtman-packages.patch
virtmisc-python2-to-python3-conversion.patch

==== virtualbox ====
Version update (5.2.18_k4.18.15_1 -> 5.2.20_k4.18.15_1)
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- Fix / simplify python3-virtualbox packages files section. Do not
rely on --record-rpm for any version of python, since we can't
use it across the band.
- Made changes requested in comments for request 646211.
1. Sustituted /usr/lib/python3.7/site-packages/ => %python3_sitelib
2. Reverted change that eliminated use of %{_tmppath}/SITE_FILES for Python
3.6
3. As vboxapisetup.py in Python 3.7 no longer accepts the --record-rpm switch,
SITE_FILES does not exist, and the individual files must still be listed.
- Make necessary updates so that VirtualBox will build with Python 3.7 -
boo#1113894
Change kernel module code to build against the API changes in kernel 4.20 -
This change
adds file "fixes_for_4.20.patch".
- Require(pre) virtualbox by the -qt package: otherewise it might
happen that virtualbox-qt is installed before virtualbox, which
then results in files being assigned to group 'root' instead of
'vboxusers', as the group is only created later.
- Version bump to 5.2.20 (released October 16 2018 by Oracle)
This is a maintenance release. The following items were fixed and/or added:
VMM: fixed task switches triggered by INTn instruction (bug #17979)
Storage: fixed connecting to certain iSCSI targets (bug #17507)
Storage: fixed handling of flush requests when configured to be ignored when
the host I/O cache is used (bug #17573)
Drag and drop: implemented support for UNC paths (bug #17146)
Drag and drop: fixed resuming operation when restoring from a saved state
(bug #17649)
Drag and drop: fixed copying files with long file names (> 248 characters)
from guests to Windows hosts (bug #17447)
Drag and drop: fixed handling files with Unicode names on Windows guests (bug
#15501)
Drag and drop: fixed copying empty (0-byte) files to / from guests (bugs
#14863 + #17443)
Drag and drop: fixed copying over files from hosts to Linux guests (bug
#16025)
Networking: restore connectivity for guests bridged to host adapters that
were unavailable temporarily (Windows hosts, bug #17090)
Guest Control: fixed hang when using --wait-stdout and/or --wait-stderr (bug
#17386). Needs updating Guest Additions
Video recording: fixed starting video recording on VM power up (bug #17307)
Linux Additions: various build fixes for kernel modules on recent
distributions, and made sure modules end up in initramfs files
Linux Additions: build fixes for 4.19, thank you Larry Finger
Linux Additions: various small fixes for video driver
This version also addresses the following vulnerabilities: CVE-2018-0732,
CVE-2018-2909, CVE-2018-3287
CVE-2018-3288, CVE-2018-3289, CVE-2018-3290, CVE-2018-3291, CVE-2018-3292,
CVE-2018-3293,
CVE-2018-3294, CVE-2018-3295, CVE-2018-3296, CVE-2018-3297, and
CVE-2018-3298. bsc#1112097
- Fix autostart of VMs, which is no longer handled by the vboxes.service.
A new routine "start_vms" is added to the start section of vboxdrv.sh,
which is called by vboxdrv.service. Files "vboxes.service", "vboxes.sh",
and "virtualbox-sysconfig.vbox" are deleted.
These changes are to satisfy bsc#1107769.

==== vte ====
Version update (0.54.1 -> 0.54.2)
Subpackages: libvte-2_91-0 typelib-1_0-Vte-2.91 vte-lang

- Update to version 0.54.2:
+ ring: Fix thawing combining accents over a double-wide
character.
+ emulation:
- Implement SCOSC/SCORC.
- Make dispatch of SCORC symmetrical to SCOSC.
+ modes: Use parentheses in macro.
+ widget: Add missing exception specification.

==== webkit2gtk3 ====
Version update (2.22.2 -> 2.22.3)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Update to version 2.22.3:
+ Many improvements and fixes for video playback with media
source extensions (MSE), which improve the user experience
across the board, and in particular for playback of WebM
videos.
+ Fix a memory leak during media playback when using playbin3.
+ Fix portions of Web views not being rendered after resizing.
+ Fix Resource Timing reporting for <iframe> elements.
+ Fix the build with the remote Web Inspector disabled.
+ Fix the build on ARMv7 with NEON extensions.
+ Fix several crashes and rendering issues.

==== whois ====
Version update (5.3.2 -> 5.4.0)

- whois 5.4.0:
* Add support for the new libxcrypt 4.x.
This allows mkpasswd to support many modern password hash methods
* Renam the hash types (i.e. the arguments to -H) to use the
naming convention established by John the Ripper
* Make mkpasswd use entropy gathered by crypt_gensalt(3), when
available
* Add the .gp TLD server
* Update the list of new gTLDs

==== wicked ====
Version update (0.6.50 -> 0.6.51)
Subpackages: libwicked-0-6 wicked-service

- version 0.6.51
- wireless: fix eap peap auth mapping for wpa-supplicant (bsc#1026807)
- vxlan: fix to convert dst_port to network byte order

==== xalan-j2 ====

- Add maven pom files for xalan-j2 and the serializer

==== xdg-desktop-portal-kde ====
Version update (5.14.2 -> 5.14.3)
Subpackages: xdg-desktop-portal-kde-lang

- Add David Edmundson's key to plasma.keyring
- Update to 5.14.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.14.3.php
- No code changes since 5.14.2

==== xorg-x11-server ====
Version update (1.20.2 -> 1.20.3)
Subpackages: xorg-x11-server-sdk xorg-x11-server-wayland

- Update to version 1.20.3
* Disable -logfile and -modulepath when running with elevated
privileges (bsc#1112020)
* LogFilePrep: add a comment to the unsafe format string.
* xfree86: fix readlink call

==== yast2 ====
Version update (4.1.32 -> 4.1.33)
Subpackages: yast2-logs

- WorkflowManager: Allow system roles to live in
/usr/share/system-roles/*.xml (bsc#1108176)
- 4.1.33

==== yast2-firewall ====
Version update (4.0.33 -> 4.0.34)

- Enable and open the SSH port when only public key authentication
is available for the root user (fate#324690).
- 4.0.34

==== yast2-installation ====
Version update (4.1.24 -> 4.1.25)

- Writing security settings in first AY installation stage.
So other modules (e.g. users) can rely on these settings now.
(bnc#1112769)
- 4.1.25

==== yast2-iscsi-client ====
Version update (4.1.1 -> 4.1.2)

- removed onboot startup mode for LUNs on S/390 (bsc#1045139)
- 4.1.2
- enable rubocop
- Added license file to spec.

==== yast2-packager ====
Version update (4.1.11 -> 4.1.12)

- Break the yast2-packager -> yast2-storage-ng -> yast2-packager
build cycle (bsc#1114517)
- 4.1.12

==== yast2-security ====
Version update (4.1.0 -> 4.1.1)

- Writing security settings in first AY installation stage.
So other modules (e.g. users) can rely on these settings now.
(bnc#1112769)
- 4.1.1
- Added license file to spec.

==== yast2-storage-ng ====
Version update (4.1.29 -> 4.1.31)

- Internal code reorganization at Proposal::SpaceMaker
(preparations for fate#325885 and fate#323484).
- Crypttab entry allows to find a crypttab device by its UUID.
- Devicegraph#find_by_any_name is able to find a LUKS device by
using its name at crypttab file.
- Related to bsc#1094963.
- 4.1.31
- Improve the proposal to be able to work with existing MD RAIDs
(fate#326573).
- 4.1.30

==== yast2-theme ====
Version update (4.1.4 -> 4.1.5)
Subpackages: yast2-branding-openSUSE yast2-branding-openSUSE-Oxygen

- Update: removing {yast_themedir}/current link of older packages
at first of all in order to install links via cpio of the new
package (bsc#1114620)
- 4.1.5

==== yast2-trans ====
Version update (84.87.20180514.157a0650d -> 84.87.20181104.0df6e15205)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en yast2-trans-en_GB
yast2-trans-en_US yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi
yast2-trans-fr yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr
yast2-trans-hu yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv
yast2-trans-ka yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt
yast2-trans-mk yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa
yast2-trans-pl yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru
yast2-trans-si yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv
yast2-trans-ta yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi
yast2-trans-wa yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20181104.0df6e15205:
* Translated using Weblate (Czech)
* Translated using Weblate (Czech)
* Translated using Weblate (Slovak)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Slovak)
* Translated using Weblate (Slovak)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* New POT for text domain 'security'.
* New POT for text domain 'installation'.
* New POT for text domain 'autoinst'.
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Catalan)
- Update to version 84.87.20181102.a4ad329efb:
* Translated using Weblate (Slovak)
* Translated using Weblate (French)
- Update to version 84.87.20181102.b6a8653ae1:
* Translated using Weblate (French)
* Translated using Weblate (French)
* Translated using Weblate (French)
* Translated using Weblate (French)
* New POT for text domain 'packager'.
* Translated using Weblate (Albanian)
* Translated using Weblate (Czech)
* Translated using Weblate (Danish)
* Translated using Weblate (Danish)
* Translated using Weblate (Slovak)
* New POT for text domain 'storage'.
* New POT for text domain 'packager'.
* Translated using Weblate (Danish)
* Translated using Weblate (Spanish)
* Translated using Weblate (Danish)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Catalan)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Danish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Slovak)
* Translated using Weblate (Dutch)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (German)
* New POT for text domain 'rmt'.
* New POT for text domain 'packager'.
* New POT for text domain 'network'.
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (Dutch)
* Translated using Weblate (German)
- Update to version 84.87.20181031.be8bf36984:
* Added translation using Weblate (Chinese (Taiwan))
* Fixed broken interpolations
* Fixed keyboard shortcuts in the Remote Administration dialog
* Fixed or removed invalid translations
* Fixed translation issues
* New POT for text domain 'add-on'.
* New POT for text domain 'alternatives'.
* New POT for text domain 'auth-client'.
* New POT for text domain 'autoinst'.
* New POT for text domain 'base'.
* New POT for text domain 'base.xgettext'.
* New POT for text domain 'bootloader'.
* New POT for text domain 'caasp'.
* New POT for text domain 'cio'.
* New POT for text domain 'control'.
* New POT for text domain 'country'.
* New POT for text domain 'country.xgettext'.
* New POT for text domain 'dhcp-server'.
* New POT for text domain 'dhcp-server.xgettext'.
* New POT for text domain 'dns-server'.
* New POT for text domain 'dns-server.xgettext'.
* New POT for text domain 'docker'.
* New POT for text domain 'fcoe-client'.
* New POT for text domain 'firewall'.
* New POT for text domain 'firstboot'.
* New POT for text domain 'firstboot.xgettext'.
* New POT for text domain 'ftp-server'.
* New POT for text domain 'geo-cluster'.
* New POT for text domain 'geo-cluster.xgettext'.
* New POT for text domain 'http-server'.
* New POT for text domain 'http-server.xgettext'.
* New POT for text domain 'installation'.
* New POT for text domain 'instserver'.
* New POT for text domain 'iscsi-client'.
* New POT for text domain 'iscsi-lio-server'.
* New POT for text domain 'isns'.
* New POT for text domain 'journal'.
* New POT for text domain 'ncurses-pkg'.
* New POT for text domain 'network'.
* New POT for text domain 'nfs'.
* New POT for text domain 'ntp-client'.
* New POT for text domain 'packager'.
* New POT for text domain 'pkg-bindings'.
* New POT for text domain 'printer'.
* New POT for text domain 'proxy'.
* New POT for text domain 'qt'.
* New POT for text domain 'qt-pkg'.
* New POT for text domain 'registration'.
* New POT for text domain 'samba-client.xgettext'.
* New POT for text domain 'samba-server'.
* New POT for text domain 'samba-server.xgettext'.
* New POT for text domain 'services-manager'.
* New POT for text domain 'slp-server'.
* New POT for text domain 'snapper'.
* New POT for text domain 'squid'.
* New POT for text domain 'storage'.
* New POT for text domain 'support'.
* New POT for text domain 's390'.
* New POT for text domain 'tftp-server'.
* New POT for text domain 'update'.
* New POT for text domain 'update.xgettext'.
* New POT for text domain 'users'.
* New POT for text domain 'users.xgettext'.
* Removed invalid translation
* Translated using Weblate (Albanian)
* Translated using Weblate (Arabic)
* Translated using Weblate (Catalan)
* Translated using Weblate (Czech)
* Translated using Weblate (Danish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Finnish)
* Translated using Weblate (French)
* Translated using Weblate (Galician)
* Translated using Weblate (German)
* Translated using Weblate (Hungarian)
* Translated using Weblate (Chinese (China))
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Indonesian)
* Translated using Weblate (Italian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Korean)
* Translated using Weblate (Norwegian Nynorsk)
* Translated using Weblate (Polish)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Russian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Spanish)
* Translated using Weblate (Swedish)
* Translated using Weblate (Turkish)
* Updated check script

==== yast2-update ====
Version update (4.1.4 -> 4.1.5)

- Avoid to crash when crypttab contains entries where the LUKS is
given by UUID= format.
- Avoid to crash when an encryption device is not probed with the
name indicated in a fstab entry.
- Related to bsc#1094963.
- 4.1.5

==== yast2-users ====
Version update (4.0.7 -> 4.0.9)

- Add public keys handling support in an installed system
(related to fate#324690).
- 4.0.9
- Allow the root user to use a public key for authentication
(fate#324690).
- 4.0.8

==== zypper ====
Version update (1.14.14 -> 1.14.15)
Subpackages: zypper-aptitude zypper-log

- Add `needs-restarting` shell script and manpage (fate#326451)
- Add zypper needs-rebooting command (fate#326451)
- version 1.14.15


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages