Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20181103 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20181103

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
apache-commons-logging
autoyast2 (4.0.61 -> 4.0.65)
bcm20702a1-firmware
digikam
installation-images-Kubic (14.387 -> 14.388)
libstorage-ng (4.1.24 -> 4.1.53)
libyui-ncurses-pkg (2.48.8 -> 2.48.9)
libyui-qt (2.49.5 -> 2.49.7)
libyui-qt-pkg (2.45.20 -> 2.45.22)
oprofile
patterns-xfce (20171113 -> 20181030)
rubygem-autoprefixer-rails (9.1.4 -> 9.3.1)
rubygem-mail (2.7.0 -> 2.7.1)
rubygem-rspec (3.7.0 -> 3.8.0)
rubygem-rspec-core (3.7.1 -> 3.8.0)
rubygem-rspec-expectations (3.7.0 -> 3.8.2)
rubygem-rspec-mocks (3.7.0 -> 3.8.0)
rubygem-rspec-support (3.7.1 -> 3.8.0)
rubygem-yast-rake (0.2.26 -> 0.2.28)
snapper (0.6.1 -> 0.8.0)
squid (4.3 -> 4.4)
yast2 (4.1.6 -> 4.1.32)
yast2-add-on (4.1.5 -> 4.1.7)
yast2-bootloader (4.1.8 -> 4.1.11)
yast2-control-center (4.1.1 -> 4.1.2)
yast2-core (4.0.3 -> 4.1.0)
yast2-country (4.0.23 -> 4.1.0)
yast2-dhcp-server (4.1.2 -> 4.1.3)
yast2-firewall (4.0.26 -> 4.0.33)
yast2-fonts (4.0.0 -> 4.0.1)
yast2-installation (4.1.13 -> 4.1.24)
yast2-instserver (4.1.1 -> 4.1.2)
yast2-network (4.1.6 -> 4.1.15)
yast2-ntp-client (4.1.0 -> 4.1.3)
yast2-packager (4.1.4 -> 4.1.11)
yast2-pkg-bindings (4.0.13 -> 4.1.0)
yast2-ruby-bindings (4.0.6 -> 4.1.0)
yast2-samba-client (4.0.2 -> 4.0.3)
yast2-samba-server (4.1.0 -> 4.1.1)
yast2-services-manager (4.1.7 -> 4.1.8)
yast2-snapper (4.0.4 -> 4.0.5)
yast2-storage-ng (4.1.13 -> 4.1.29)
yast2-theme (4.1.1 -> 4.1.4)
yast2-update (4.1.1 -> 4.1.4)
yast2-users (4.0.5 -> 4.0.7)
yast2-x11 (4.0.0 -> 4.0.1)
yast2-ycp-ui-bindings (4.0.0 -> 4.1.0)

=== Details ===

==== apache-commons-logging ====

- Cleanup of maven pom files installation

==== autoyast2 ====
Version update (4.0.61 -> 4.0.65)
Subpackages: autoyast2-installation

- Saving y2logs after the installation has been finished.
(fate#325737)
- 4.0.65
- Adapt schema to support the new way of defining a software
RAID (fate#326573).
- 4.0.64
- Added license file to spec.
- AutoInstallRules: Do a cleanup of the profile being merged with
(bsc#1108933).
- 4.0.63
- AutoYaST configuration module: Enable edit action for firewall
module (fate#324662).
- 4.0.62

==== bcm20702a1-firmware ====

- Avoid bashisms in %post
- Fetch & install another variant firmware (0a5c:21e8) (bsc#1087996)

==== digikam ====
Subpackages: kipi-plugins kipi-plugins-lang

- Add Add-QtWebEngine-support.patch to allow building with
QtWebEngine instead of QtWebKit
- Use QtWebEngine on platforms where it is available
- Add some necessary build requirements to avoid relying on other
packages pulling them in
- Remove unused libqca-qt5-devel BuildRequires
- Add Lower-minimum-exiv2-version.patch to make it build on Leap
42.3
- Remove some build requirements that are not used anymore since a
long time
- Remove unnecessary ENABLE_OPENCV3 and ENABLE_MYSQLSUPPORT cmake
options, they are ON by default since 5.7.0
- Remove obsolete ENABLE_LCMS2 option, LCMS2 is mandatory since 5.0

==== installation-images-Kubic ====
Version update (14.387 -> 14.388)

- merge gh#openSUSE/installation-images#270
- Kubic has its own skelcd package now (bsc#1114455)
- 14.388
- Use skelcd-control-Kubic for Kubic flavour (boo#1114455)
- Handle aarch64 and ppc64/ppc64le repos

==== libstorage-ng ====
Version update (4.1.24 -> 4.1.53)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- Translated using Weblate (Japanese)
- 4.1.53
- Translated using Weblate (Italian)
- 4.1.52
- Translated using Weblate (Catalan)
- 4.1.51
- merge gh#openSUSE/libstorage-ng#588
- Regenerated potfiles
- 4.1.50
- merge gh#openSUSE/libstorage-ng#585
- Fixed broken autobuild environment
- Support for StrayBlkDevices in CompoundActions (bsc#1085134)
- Moved predicates to base class
- New unit test for Bcache compound actions
- Use new check from superclass
- Removed unnecessary include
- Support for Bcache in CompoundActions
- First (incomplete) CompoundAction formatter for Bcache
- Fixed broken English
- Use inherited methods
- Use actual output for translator examples
- Use multiple lines, not one neverending line
- First complete CompoundAction formatter for Bcache
- First unit test for MD-RAID compound actions
- Added CompoundActions formatter for MD-RAIDs
- More test cases for MD-RAID
- User sanity check
- Coding style cleanup
- Updated year in useless legalese
- Added missing sformat parameter
- Added missing parameter doc in translator comment
- Fixed translator comments
- Moved device list formatting out to separate common function
- Use better comparision function
- Use existing constants
- New CompoundActions
- merge gh#openSUSE/libstorage-ng#587
- extended documentation
- ported check from snapper
- minor improvements
- 4.1.49
- merge gh#openSUSE/libstorage-ng#586
- mark AUTHORS as %doc
- merge gh#openSUSE/libstorage-ng#584
- mark LICENSE file as license
- 4.1.48
- merge gh#openSUSE/libstorage-ng#583
- Use predicates to make the code much better readable
- Added missing return
- Use speaking function names for getters
- Moved methods to base class
- Use predicates and speaking getters to make the code much better
readable (bsc#1085134)
- 4.1.47
- merge gh#openSUSE/libstorage-ng#582
- make format of po files consistent with gettext
- 4.1.46
- merge gh#openSUSE/libstorage-ng#580
- add bcache attributes (fate#325346)
- [RFC] add bcache attributes (fate#325346)
- 4.1.45
- Translated using Weblate (Chinese (China))
- 4.1.44
- merge gh#openSUSE/libstorage-ng#581
- Added test case for weird UUID (bsc#1102572)
- Whitespace
- Fixed blkid output parser to honor escaped quotes (bsc#1102572)
- Fixed blkid output parser to honor escaped quotes
- 4.1.43
- Translated using Weblate (Dutch)
- 4.1.42
- Translated using Weblate (Indonesian)
- 4.1.41
- Translated using Weblate (Indonesian)
- merge gh#openSUSE/libstorage-ng#579
- Use for bcache cset as display name string "bcache cache"
(fate#325346)
- 4.1.40
- merge gh#openSUSE/libstorage-ng#578
- use predefined constants
- 4.1.39
- Translated using Weblate (Russian)
- 4.1.38
- merge gh#openSUSE/libstorage-ng#577
- implement searching for free name for bcache (fate#325346)
- 4.1.37
- Translated using Weblate (Dutch)
- 4.1.36
- merge gh#openSUSE/libstorage-ng#576
- Added Travis ccache documentation
- Added Travis ccache documentation and cache cleanup
- 4.1.35
- Translated using Weblate (Chinese (China))
- 4.1.34
- merge gh#openSUSE/libstorage-ng#575
- Use ccache in Travis builds
- Use ccache in Travis builds (up to 4x faster)
- 4.1.33
- merge gh#openSUSE/libstorage-ng#574
- Allow to set Md uuid for testing
- 4.1.32
- Translated using Weblate (Danish)
- 4.1.31
- merge gh#openSUSE/libstorage-ng#573
- extended documentation
- 4.1.30
- merge gh#openSUSE/libstorage-ng#572
- Allow bcache to have partitions (fate#325346)
- Allow bcache to have partitions
- 4.1.29
- merge gh#openSUSE/libstorage-ng#571
- do not translate snapshot description (bsc#1092757)
- updated pot und po files
- 4.1.28
- Translated using Weblate (German)
- 4.1.27
- Translated using Weblate (Portuguese (Brazil))
- 4.1.26
- merge gh#openSUSE/libstorage-ng#570
- merge gh#openSUSE/libstorage-ng#569
- fixed variable scope to fix temporary mounting (bsc#1099144)
- added unit test
- 4.1.25

==== libyui-ncurses-pkg ====
Version update (2.48.8 -> 2.48.9)

- Remove the RPM Groups view (FATE#326485).
- 2.48.9

==== libyui-qt ====
Version update (2.49.5 -> 2.49.7)

- Fix style disappearing from sidebar (boo#1111720)
- 2.49.7
- Enable HiDPI (bsc#1089886)
- 2.49.6

==== libyui-qt-pkg ====
Version update (2.45.20 -> 2.45.22)

- New way of handling emblems with theming support (boo#1109382)
- 2.45.22
- Remove the RPM Groups view (FATE#326485).
- 2.45.21

==== oprofile ====
Subpackages: libopagent1

- Handle empty event name gracefully on ppc.
New patch: oprofile-handle-empty-event-name-spec-gracefully-for-ppc.patch

==== patterns-xfce ====
Version update (20171113 -> 20181030)
Subpackages: patterns-xfce-xfce patterns-xfce-xfce_basis
patterns-xfce-xfce_laptop patterns-xfce-xfce_office

- changes in Recommends as per ML thread:
https://lists.opensuse.org/opensuse-factory/2018-10/msg00271.html
- added recommends menulibre
- mousepad replaces leafpad
- xreader replaces evince
- engrampa replaces file-roller
- parole replaces totem

==== rubygem-autoprefixer-rails ====
Version update (9.1.4 -> 9.3.1)

- updated to version 9.3.1
* Fix Grid prefixes with `repeat()` value (by Bogdan Dolin).
[#] Fixes in previous versions
[#]# 9.3 ?Labor omnia vincit?
* Add `place-self` support (by Bogdan Dolin).
* Fix Grid row/column span inheritance bug (by Bogdan Dolin).
[#]# 9.2.1
* Update Can I Use data.
[#]# 9.2 ?Ony est glavnaya krepost?
* Add `/* autoprefixer grid: on */` control comment (by Andrey Alexandrov).
* Add duplicate `grid-area` support (by Bogdan Dolin).
* Fix `grid-gap` support for rules with different specifity (by Bogdan Dolin).
* Disable Grid in `@supports` at-rule with non-supported Grid features.
* Improve Grid warnings (by Daniel Tonon).

==== rubygem-mail ====
Version update (2.7.0 -> 2.7.1)

- updated to version 2.7.1
Compatibility:
* Restore LF=>CRLF conversions for properly encoded non-binary emails. (rubys)
* Gracefully parse certain invalid Content-Type headers. (rafbm)
* Support `x-uue` transfer encoding as uuencoding. (jkraemer)
Features:
* Expose Mail::Field#unparsed_value to read the raw field value, before
parsing. (Tensho)
Performance:
* Speed up message encoding, especially with large attachments. (dalibor)
Bugs:
* Fix transfer encoding when message encoding is blank. (jakubonty, saks)
* Fix 7bit/base64 content transfer encoding mismatch. (ahorek)
* Fix UTF-8 attachment filename quoting. (ahorek)
* Fix `delete_all` using a readonly IMAP connection. (kimromi)

==== rubygem-rspec ====
Version update (3.7.0 -> 3.8.0)

- updated to version 3.8.0
no changelog found

==== rubygem-rspec-core ====
Version update (3.7.1 -> 3.8.0)

- updated to version 3.8.0
[Full Changelog](http://github.com/rspec/rspec-core/compare/v3.7.1...v3.8.0)
Enhancements:
* Improve shell escaping used by `RSpec::Core::RakeTask` and `--bisect` so
that it works on `Pathname` objects. (Andrew Vit, #2479)
* Nicely format errors encountered while loading files specified
by `--require` option. (Myron Marston, #2504)
* Significantly improve the performance of `--bisect` on platforms that
support forking by replacing the shell-based runner with one that uses
forking so that RSpec and the application environment can be booted only
once, instead of once per spec run. (Myron Marston, #2511)
* Provide a configuration API to pick which bisect runner is used for
`--bisect`. Pick a runner via `config.bisect_runner = :shell` or
`config.bisect_runner = :fork` in a file loaded by a `--require`
option passed at the command line or set in `.rspec`. (Myron Marston, #2511)
* Support the [XDG Base Directory
Specification](https://specifications.freedesktop.org/basedir-spec/latest/)
for the global options file. `~/.rspec` is still supported when no
options file is found in `$XDG_CONFIG_HOME/rspec/options` (Magnus Bergmark,
#2538)
* Extract `RSpec.world.prepare_example_filtering` that sets up the
example filtering for custom RSpec runners. (Oleg Pudeyev, #2552)
Bug Fixes:
* Prevent an `ArgumentError` when truncating backtraces with two identical
backtraces. (Systho, #2515, Benoit Tigeot, #2539)

==== rubygem-rspec-expectations ====
Version update (3.7.0 -> 3.8.2)

- updated to version 3.8.2
[Full
Changelog](http://github.com/rspec/rspec-expectations/compare/v3.8.1...v3.8.2)
Bug Fixes:
* Change `include` matcher to rely on a `respond_to?(:include?)` check rather
than a direct
Hash comparison before calling `to_hash` to convert to a hash. (Jordan
Owens, #1073)
* Prevent unexpected call stack jumps from causing an obscure error
(`IndexError`), and
replace that error with a proper informative message. (Jon Rowe, #1076)
- updated to version 3.8.1
[Full
Changelog](http://github.com/rspec/rspec-expectations/compare/v3.8.0...v3.8.1)
Bug Fixes:
* Fix regression in `include` matcher so stopped
`expect(hash.with_indifferent_access).to include(:symbol_key)`
from working. (Eito Katagiri, #1069)
- updated to version 3.8.0
[Full
Changelog](http://github.com/rspec/rspec-expectations/compare/v3.7.0...v3.8.0)
Enhancements:
* Improve failure message of `change(receiver, :message)` by including the
receiver as `SomeClass#some_message`. (Tomohiro Hashidate, #1005)
* Improve `change` matcher so that it can correctly detect changes in
deeply nested mutable objects (such as arrays-of-hashes-of-arrays).
The improved logic uses the before/after `hash` value to see if the
object has been mutated, rather than shallow duping the object.
(Myron Marston, #1034)
* Improve `include` matcher so that pseudo-hash objects (e.g. objects
that decorate a hash using a `SimpleDelegator` or similar) are treated
as a hash, as long as they implement `to_hash`. (Pablo Brasero, #1012)
* Add `max_formatted_output_length=` to configuration, allowing changing
the length at which we truncate large output strings.
(Sam Phippen #951, Benoit Tigeot #1056)
* Improve error message when passing a matcher that doesn't support block
expectations to a block based `expect`. (@nicktime, #1066)

==== rubygem-rspec-mocks ====
Version update (3.7.0 -> 3.8.0)

- updated to version 3.8.0
[Full Changelog](http://github.com/rspec/rspec-mocks/compare/v3.7.0...v3.8.0)
Bug Fixes:
* Issue error when encountering invalid "counted" negative message
expectations.
(Sergiy Yarinovskiy, #1212)
* Ensure `allow_any_instance_of` and `expect_any_instance_of` can be
temporarily
supressed. (Jon Rowe, #1228)
* Ensure `expect_any_instance_of(double).to_not have_received(:some_method)`
fails gracefully (as its not supported) rather than issuing a
`NoMethodError`.
(Maxim Krizhanovsky, #1231)

==== rubygem-rspec-support ====
Version update (3.7.1 -> 3.8.0)

- updated to version 3.8.0
[Full
Changelog](http://github.com/rspec/rspec-support/compare/v3.7.1...v3.8.0)
Bug Fixes:
* Order hash keys before diffing to improve diff accuracy when using mocked
calls.
(James Crisp, #334)

==== rubygem-yast-rake ====
Version update (0.2.26 -> 0.2.28)

- Changed the SLE12-SP4 SR target to the :Update subproject
(bsc#1113887)
- 0.2.28
- Added CASP-4.0 target (needed for fate#325834)
- 0.2.27
- Removed installation of file COPYING into the doc directory.
This file will be packed by the %license tag in the spec files.

==== snapper ====
Version update (0.6.1 -> 0.8.0)
Subpackages: libsnapper4 snapper-zypp-plugin

- extended space aware cleanup algorithm to ensure minimal
free space for btrfs (within known ranges) (fate#325774)
- version 0.8.0
- fixed querying default and active snapshot if compiled without
rollback support (gh#openSUSE/snapper#442)
- version 0.7.2
- disallow to delete special (for btrfs currently mounted and next
to be mounted) snapshots (fate#326479)
- version 0.7.1
- mark active and default btrfs subvolume in list output
(fate#326479)
- reorder columns in snapper list output (fate#326479)
- version 0.7.0

==== squid ====
Version update (4.3 -> 4.4)

- New upstream stable version 4.4:
+ Fix memory leak when parsing SNMP packet (bsc#1113669)
+ Fixed display of error page by quoting certificate fields
before displaying them (bsc#1113668)
+ Malformed %>ru URIs for CONNECT requests

==== yast2 ====
Version update (4.1.6 -> 4.1.32)

- view_anymsg: allow user to switch to yast2-journal if file does
not exist or is empty (bsc#948729)
- 4.1.32
- Added flag save_y2logs to control.xml file in order to save
YaST logs at the end of installation (fate#325737)
- 4.1.31
- Ensure that Installation.sourcedir exists (bsc#1097700)
- Use LSB compliant Installation.sourcedir
- 4.1.30
- CWMFirewallInterfaces: make some "current state" methods public
needed by yast2-rmt (fate#326634)
- 4.1.29
- Network (Firewall): Added modify_masquerade method to zones API
unifying the way changes are applied to single value attributes.
(bsc#1112547)
- 4.1.28
- adapted to extended output of snapper (fate#326479, bsc#1111831)
- 4.1.27
- Small CWM optimization by avoiding deep_copy on big data
(bsc#1112402).
- 4.1.26
- CWMFirewallInterfaces: Improved the user UX replacing the api
calls for checking supported services once the list supported
ones are already known by the firewalld instance (fate#324662)
- 4.1.25
- Splitting yast2 package into yast2 and yast2-logs. yast2-logs
contains only scripts for handling YaST logs (fate#325737).
- 4.1.24
- Added tags full_system_media_name and full_system_download_url
in control.xml which describe the location for the
"all-packages" medium. This information will be shown if the
registration has been scipped by the user. No hint will be shown
if these tags have not been defined. (fate#325834)
- 4.1.23
- Added new methods to firewalld_wrapper in order to switch
yast2-dhcp-server to new firewall module. (bsc#1108942)
- 4.1.22
- Log viewer: replace invalid UTF-8 characters from the displayed
log to avoid a crash (bsc#1110549)
- 4.1.21
- Network (Firewall):
- Added some methods needed for AutoYaST configuration
(fate#324662)
- Make the service status label stretchable so the updated status
is displayed correctly (bsc#1110407)
- 4.1.20
- bnc#964856
- fixed internal error - do not crash when updating device config
- 4.1.19
- Y2Firewall::Firewalld: Single attributes setter will not modify
the value of the attribute in case it is the same (bsc#1109812)
- 4.1.18
- Improve Y2Firewall::Firewalld::Interface#zone to return an
Zone object (fate#324662).
- 4.1.17
- bnc#964856
- removed obsolete parts of NetworkInterfaces API:
ifcfg_part, device_type, device_num, alias_num,
GetFreeDevices, GetFreeDevice, LocateNOT, ListDevicesExcept
- 4.1.16
- Network (Firewall)
- Added Y2Firewall::Firewalld::Interface class.
- Adapted interfaces helpers to work with the new class.
(fate#324662)
- 4.1.15
- Add a new popup widget (fate#324662).
- Add a helper class UIState to keep the UI states when using CWM.
- Y2Firewall::Firewalld: Added convenience method to obtain the
firewalld service object (fate#324662)
- 4.1.14
- Allow reading the installation.xml (skelcd-* package) from other
repository than the initial one (e.g. the self update), select
the highest version of the package (instead of the first found)
(bsc#1101016)
- 4.1.13
- Firewalld: Fixed the API cmd call for removing services from
zones when the firewall is in offline mode (bsc#1108628)
- 4.1.12
- CWM: avoid to always return :next when accepting a dialog.
- Needed for Expert Partitioner (fate#318196).
- 4.1.11
- Added the missing SuSEFirewallProposal.rb file to the Makefile
(bsc#1087867)
- 4.1.10
- Bring back the SuSEFirewallProposal fixing the class unit tests
until yast2-network drops the import of the module completely.
(bsc#1087867)
- 4.1.9
- Extended the firewall API supporting the use of single-value
attributes and also prepared it for introducing more complex
relations like 'forward-ports' and 'rich-rules' in the future.
(fate#324662)
- Improved the parser for zones and added a parser for services.
- Improved test mocking fixing a Polkit popup shown when running the
test (bsc#1087867)
- 4.1.8
- CWM: allow to define next handler for CWM#show.
- CWM: define default next handler in CWM::Dialog.
- Needed for Expert Partitioner (fate#318196).
- 4.1.7

==== yast2-add-on ====
Version update (4.1.5 -> 4.1.7)

- Fixed path to license file. . Build error in bsc#1108139.
- 4.1.7
- Fix and improve the repo name selection in the AddOn auto client
(bsc#1108139)
- 4.1.6

==== yast2-bootloader ====
Version update (4.1.8 -> 4.1.11)

- Do not crash if an unknown device is found in a cloned configuration
(bsc#1111236)
- 4.1.11
- Fixed path to license file. . Build error in bsc#1089829.
- 4.1.10
- Do not crash when required package is not installed (bsc#1089829)
- 4.1.9

==== yast2-control-center ====
Version update (4.1.1 -> 4.1.2)
Subpackages: yast2-control-center-qt

- Enable HiDPI (bsc#1089886)
- 4.1.2
- Switched license in spec file from SPDX2 to SPDX3 format.
- Changed dir of COPYING file.

==== yast2-core ====
Version update (4.0.3 -> 4.1.0)

- Added license file to spec.
- Use an exclusive lock when rotating the YaST logs to avoid race
conditions when several YaST processes run in paralell
(related to bsc#1094875)
- 4.1.0
- Reduced risk of race condition between getenv and setenv while
logging (bsc#1103076)
- 4.0.4
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-country ====
Version update (4.0.23 -> 4.1.0)
Subpackages: yast2-country-data

- Console: Use empty string instead of none for FONTMAP
(bsc#1013573)
- 4.1.0
- Set only system time if no hardware clock available (bsc#1103744)
- 4.0.24
- Changed dir of COPYING file.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-dhcp-server ====
Version update (4.1.2 -> 4.1.3)

- Added license file to spec.
- Adapting to new firewall API (bsc#1108942)
- 4.1.3

==== yast2-firewall ====
Version update (4.0.26 -> 4.0.33)

- Added missing interfaces helpers requirement (fate#324662)
- 4.0.33
- Fixed zone_options widget test mocking (fate#324662)
- 4.0.32
- Small improvements to the widget for modifying the assignation
of interfaces to zones (fate##324662):
- Permits to split the input field entry by any combination of
spaces or commas.
- Initialize the zone selector with the default zone.
- 4.0.31
- Alert the user about unsaved changes when leaving the zone
services configuration without applying changes (fate#324662)
- 4.0.30
- AutoYaST configuration: Added support to editing and resetting
the current configuration. Improved the writing process
(fate324662).
- 4.0.29
- AutoYast schema:
- Allowed the new 'description', 'short' and 'target' elements in
zone entries (bsc#1108199)
- 4.0.28
- Add a new user interface to manage firewalld configuration
(fate#324662).
- Supported featues:
- Manage the firewalld service.
- Browse interfaces and assign them to firewall zones.
- List zones and design one of them as the default.
- Assign services to zones.
- Open ports.
- 4.0.27
- Switched license in spec file from SPDX2 to SPDX3 format.
- Changed dir of COPYING file.

==== yast2-fonts ====
Version update (4.0.0 -> 4.0.1)

- Added %license tag in spec file.
Needed to build fix for bnc#1087957 again.
- 4.0.1

==== yast2-installation ====
Version update (4.1.13 -> 4.1.24)

- extra_urls: compare unexpanded urls, so two identical
repositories with variables are detected (bsc#1090193)
- 4.1.24
- Added save_y2logs client. (fate#325737)
- 4.1.23
- Remember the selected role (related to FATE#325834)
- 4.1.22
- Saving y2logs after the installation has been finished.
(fate#325737)
- 4.1.21
- Fixed path to license file. . Build error in fate#324713
- 4.1.20
- Skip the roles' dialog selection when there is only one available
(fate#324713)
- 4.1.19
- Fix syntax error (bsc#1109659)
- 4.1.18
- Updated docu for add_on_products.xml: Added tag "confirm_license"
to handle Add-On-products licenses which will be added while
installation. (bsc#1105758)
- 4.1.17
- Avoid to restore old backups when upgrade fails (bsc#1097297)
- 4.1.16
- Copy the selected packages from the self-update repository to an
additional add-on repository, allow updating the installation
workflow from the self-update repository (bsc#1101016)
- 4.1.15
- do not translate snapshot description (bsc#1092757)
- 4.1.14

==== yast2-instserver ====
Version update (4.1.1 -> 4.1.2)

- Fixed path to license file. . Build error in bsc#1110037.
- 4.1.2

==== yast2-network ====
Version update (4.1.6 -> 4.1.15)

- bnc#1111925
- always propose wpa_supplicant when configuring wlan
- bsc#1113080
- Fix detection of peap mode (jreidinger@xxxxxxxx)
- Propose most commonly used setup for WPA by default
- 4.1.15
- Fix detection of peap mode (bsc#1113080)
- 4.1.14
- Simplified the installation network proposal collecting all the
configured dhcp interfaces in a single entry (fate#326480)
- 4.1.13
- bsc#1110598
- fixed path to license file
- 4.1.12
- fate#323454
- wicked compatible parsing of NTP servers from dhcp leases
- 4.1.11
- Fixes to the networking AY schema (bsc#1108852)
- Added missed s390 device 'layer2' boolean element.
- 4.1.10
- bnc#1105230
- do not crash with internal error when 0.0.0.0 netmask is used
in the routing tab
- Activate s390 network devices before applying udev naming rules,
avoiding "Invalid key/value pair in
/etc/udev/rules.d/70-persistent-net.rules" (bsc#1095761)
(by mvidner@xxxxxxxx)
- 4.1.9
- bnc#1109312
- fixed internal error (replaced calls to LanItems::FreeDevices
which was removed)
- 4.1.8
- bnc#964856
- adapted to changes in NetworkInterfaces API
- GetFreeDevice and GetFreeDevices was dropped
- 4.1.7

==== yast2-ntp-client ====
Version update (4.1.0 -> 4.1.3)

- Fixed license path. Build error for bsc#1110598.
- 4.1.3
- AutoYaST: Do not show the progress when merging the configuration
before writing it (bsc#1110598)
- 4.1.2
- Save the service status according to the user preferences
(bsc#1075039)
- 4.1.1

==== yast2-packager ====
Version update (4.1.4 -> 4.1.11)

- Set during upgrade proper release version for newly added repos
(bsc#1090193)
- 4.1.11
- Allow specify alias for online repos (bsc#1017823)
- Do not depend on yast2-installation (bsc#876533)
- 4.1.10
- Fixed path to license file. Build error in bsc#1110913.
- 4.1.9
- Ignore a read failure when backing up /var/log/YaST2, YaST might
be updating the logs while the archive is being created
(bsc#1110913)
- 4.1.8
- Copy also the role packages from the self-update repository
(bsc#1101016)
- 4.1.7
- add_on_products.xml : Added tag "confirm_license" to handle
Add-On-products licenses which will be added while installation.
(bsc#1105758)
- 4.1.6
- Copy the selected packages from the self-update repository to an
additional add-on repository, allow updating the installation
workflow from the self-update repository (bsc#1101016)
- 4.1.5

==== yast2-pkg-bindings ====
Version update (4.0.13 -> 4.1.0)

- Fix probing repository with URL including variable (bsc#1090193)
- 4.1.0
- Drop no longer used methods:
-- SetArchitecture and SystemArchitecture as only user Product
Creator is dropped
-- AddLock, GetLocks, RemoveLock as it was needed only once for
specific architecture that is no longer supported
-- TargetRebuildInit as recreating rpm database is no longer used
during upgrade
-- TargetFileHasOwner as old workaround for upgrade no longer
needed
-- TargetBlockSize as it is not longer needed to count disk usage
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-ruby-bindings ====
Version update (4.0.6 -> 4.1.0)

- Fix encoding-related problems by assuming that file contents is
always UTF-8. (bsc#1111367)
- 4.1.0
- adapted testsuite to glibc translation change (bsc#1107953)
- 4.0.7
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-samba-client ====
Version update (4.0.2 -> 4.0.3)

- Added license file to spec.
- Fix reading the permitted group to create "user shares";
(bsc#1107574).
- 4.0.3
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-samba-server ====
Version update (4.1.0 -> 4.1.1)

- Added license file to spec.
- Fix configuration not saved after new service status management
(bsc#1106876)
- 4.1.1

==== yast2-services-manager ====
Version update (4.1.7 -> 4.1.8)

- Added license file to spec.
- Adapted to use the Y2Firewall::Firewalld::Zone object returned by
Y2Firewall::Firewalld::Interface#zone instead of a String.
- Adapted to use the new Y2Firewall::Firewalld::Interface objects
instead of a hash (fate#324662)
- 4.1.8

==== yast2-snapper ====
Version update (4.0.4 -> 4.0.5)

- Better module description for YaST control center (bsc#1085071)
- 4.0.5
- Added license file to spec.
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-storage-ng ====
Version update (4.1.13 -> 4.1.29)

- Format the new multi-line compound actions correctly (bsc#1085134)
- 4.1.29
- do not include 'Partition' in partition type names
- allow creation of partitions starting before 1 MiB in expert
partitioner
- Fixes and improvements to AutoYaST partitioning:
- Improve support to reuse a disk as a PV (bsc#1107298).
- Resize and then create new devices (bsc#1112545).
- Warn the user when trying to reuse a non-existent filesystem.
- Fix support of old format to specify several software RAIDs
(bsc#1112546).
- Proper support for Xen virtual partitions (bsc#1105350).
- Export enable_snapshots element properly (related to
bsc#1073544).
- Allow to format a whole disk and use it as a filesystem.
- Add support for partitioned software RAIDs (fate#326573).
- Allow to use a whole disk as a software RAID member (related
to fate#326573).
- 4.1.28
- Add support for selecting cache mode during bcache creation
(fate#325346)
- 4.1.27
- Improved UI responsiveness by caching the value of some internal
methods (bsc#1112402):
* StorageClassWrapper.downcasted_new
* StorageEnv#active?
* DiskDevice#types_for_is
- Improved compatibility with RSpec 3.8 by caching the objects
used to wrap libstorage-ng enum values.
- 4.1.26
- Improve filtering of possible backing devices for bcache and
limit deletion of bcache to only safe cases (fate#325346)
- 4.1.25
- Improved the warning messages about missing BIOS Boot partition,
both in the Partitioner and in AutoYaST (bsc#1087275).
- Improved other AutoYaST warning messages related to the
partitions needed for booting.
- 4.1.24
- Implement creating and deleting bcache devices (fate#325346)
- 4.1.23
- Fixed flickering testcase. Maybe produced by the fix of
bsc#1108831.
- 4.1.22
- Partitioner: make it possible to directly format a disk (with
no partitions).
- Partitioner: reorganized the user interface by grouping options
to ensure all the new possibilities (like formatting a whole
disk or creating partitions on an MD RAID) fit into text mode
80x24 (part of fate#318196 and of fate#326573).
- 4.1.21
- AutoYaST proposal: Do not crash if existing boot partition
cannot be used without formatting it. (bsc#1108831)
- 4.1.20
- Partitioner: ask for unmounting when deleting a device.
- Partitioner: ask for unmounting when resizing a device.
- Part of fate#318196
- 4.1.19
- AutoYaST: Allow to use whole disk as PV by indicating a partition
with number 0 (bsc#1107298).
- When trying to reuse a partition, AutoYaST will consider only
those partitions from the right disk (bsc#1106774).
- Do not crash when a partition content info cannot be
detected (bsc#1101979).
- 4.1.18
- Add read-only support for Bcache (fate#325346)
- 4.1.17
- Partitioner: allow to manage partitions in software MD RAIDs
(fate#318196, bsc#1094933 and bsc#1092417).
- 4.1.16
- Partitioner: do not offer partitions of other RAIDs as available
devices to create MD RAID arrays (fate#318196).
- 4.1.15
- Partitioner: allow to add full disks and multipath devices (with
no partition table) to MD RAID arrays (fate#318196).
- Partitioner: improved checks and workflow for "Create New
Partition Table"
- More informative message when a device is in use.
- 4.1.14

==== yast2-theme ====
Version update (4.1.1 -> 4.1.4)
Subpackages: yast2-branding-openSUSE yast2-branding-openSUSE-Oxygen

- Added license file to spec.
- Changed icons to Gnome spec (boo#1110241)
- Added hicolor/scalable/devices (boo#1109382)
- New files in devices directory have been named according
to the suggested schema (boo#1110236)
- Optipng'd all the pngs and scroted all new icons for
space saving
- 4.1.4
- Add KDE PIM icon (boo#1107103)
- 4.1.3
- Unify icon location for SLES and OpenSUSE (bsc#1104067).
- 4.1.2
- Switched license in spec file from SPDX2 to SPDX3 format.

==== yast2-update ====
Version update (4.1.1 -> 4.1.4)

- Added license file to spec.
- Fixed crash while writing backup (bsc#1108934)
- 4.1.4
- Avoid to restore old backups when upgrade fails (bsc#1097297)
- 4.1.3
- do not translate snapshot description (bsc#1092757)
- 4.1.2

==== yast2-users ====
Version update (4.0.5 -> 4.0.7)

- read ssh keys from root user only if the user exists (bsc#1112119,
bsc#1107456)
- 4.0.7
- Fixed conflicting shortcuts in plugin module (bsc#1095320).
- 4.0.6
- Switched license in spec file from SPDX2 to SPDX3 format.
- Changed dir of COPYING file.

==== yast2-x11 ====
Version update (4.0.0 -> 4.0.1)

- xkbctrl: sort hash keys (boo#1109534)
- 4.0.1
- Switched license in spec file from SPDX2 to SPDX3 format.
- Changed dir of COPYING file.

==== yast2-ycp-ui-bindings ====
Version update (4.0.0 -> 4.1.0)

- Added license file to spec.
- increase version to correspond to the libyui version increase
(related to bsc#991090)
- 4.1.0
- Switched license in spec file from SPDX2 to SPDX3 format.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages