Mailinglist Archive: opensuse-factory (199 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20181001 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20181001

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
ImageMagick (7.0.8.11 -> 7.0.8.12)
MozillaThunderbird
apache2 (2.4.34 -> 2.4.35)
apr-util
attica-qt5 (5.49.0 -> 5.50.0)
baloo5 (5.49.0 -> 5.50.0)
bluez-qt (5.49.0 -> 5.50.0)
boost
boost-base
breeze5-icons (5.49.0 -> 5.50.0)
ca-certificates
cronie
cvs (1.12.12 -> 1.12.13)
dolphin
elfutils (0.173 -> 0.174)
epiphany (3.30.0 -> 3.30.1)
firewalld (0.6.1 -> 0.6.2)
frameworkintegration (5.49.0 -> 5.50.0)
gettext-runtime
gnome-backgrounds (3.28.0 -> 3.30.0)
gnome-chess (3.28.1 -> 3.30.0)
gnome-games (3.28.0 -> 3.30.1)
gnome-mines (3.28.0 -> 3.30.1.1)
gnome-sudoku (3.28.0 -> 3.30.0)
installation-images-Kubic (14.380 -> 14.384)
iptables (1.6.2 -> 1.8.0.g85)
kactivities-stats (5.49.0 -> 5.50.0)
kactivities5 (5.49.0 -> 5.50.0)
karchive (5.49.0 -> 5.50.0)
kauth (5.49.0 -> 5.50.0)
kbookmarks (5.49.0 -> 5.50.0)
kcmutils (5.49.0 -> 5.50.0)
kcodecs (5.49.0 -> 5.50.0)
kcompletion (5.49.0 -> 5.50.0)
kconfig (5.49.0 -> 5.50.0)
kconfigwidgets (5.49.0 -> 5.50.0)
kcoreaddons (5.49.0 -> 5.50.0)
kcrash (5.49.0 -> 5.50.0)
kdbusaddons (5.49.0 -> 5.50.0)
kdeclarative (5.49.0 -> 5.50.0)
kdepim-runtime
kdesu (5.49.0 -> 5.50.0)
kdewebkit (5.49.0 -> 5.50.0)
kdnssd-framework (5.49.0 -> 5.50.0)
kdoctools (5.49.0 -> 5.50.0)
kemoticons (5.49.0 -> 5.50.0)
kernel-firmware (20180825 -> 20180913)
kexec-tools
kfilemetadata5 (5.49.0 -> 5.50.0)
kglobalaccel (5.49.0 -> 5.50.0)
kguiaddons (5.49.0 -> 5.50.0)
kholidays (5.49.0 -> 5.50.0)
khtml (5.49.0 -> 5.50.0)
ki18n (5.49.0 -> 5.50.0)
kiconthemes (5.49.0 -> 5.50.0)
kidletime (5.49.0 -> 5.50.0)
kimageformats (5.49.0 -> 5.50.0)
kinit (5.49.0 -> 5.50.0)
kio (5.49.0 -> 5.50.0)
kio-extras5
kirigami2 (5.49.0 -> 5.50.0)
kitemmodels (5.49.0 -> 5.50.0)
kitemviews (5.49.0 -> 5.50.0)
kjobwidgets (5.49.0 -> 5.50.0)
kjs (5.49.0 -> 5.50.0)
kjsembed (5.49.0 -> 5.50.0)
kmailtransport
knewstuff (5.49.0 -> 5.50.0)
knotifications (5.49.0 -> 5.50.0)
knotifyconfig (5.49.0 -> 5.50.0)
kpackage (5.49.0 -> 5.50.0)
kparts (5.49.0 -> 5.50.0)
kpeople5 (5.49.0 -> 5.50.0)
kplotting (5.49.0 -> 5.50.0)
kpty (5.49.0 -> 5.50.0)
kross (5.49.0 -> 5.50.0)
krunner (5.49.0 -> 5.50.0)
kservice (5.49.0 -> 5.50.0)
ktexteditor (5.49.0 -> 5.50.0)
ktextwidgets (5.49.0 -> 5.50.0)
kunitconversion (5.49.0 -> 5.50.0)
kwallet (5.49.0 -> 5.50.0)
kwayland (5.49.0 -> 5.50.0)
kwidgetsaddons (5.49.0 -> 5.50.0)
kwindowsystem (5.49.0 -> 5.50.0)
kxmlgui (5.49.0 -> 5.50.0)
kxmlrpcclient5 (5.49.0 -> 5.50.0)
libKF5ModemManagerQt (5.49.0 -> 5.50.0)
libKF5NetworkManagerQt (5.49.0 -> 5.50.0)
libjpeg-turbo
libkgapi
libmanette (0.2.0 -> 0.2.1)
libqt5-qtbase (5.11.1 -> 5.11.2)
libqt5-qtconnectivity (5.11.1 -> 5.11.2)
libqt5-qtdeclarative (5.11.1 -> 5.11.2)
libqt5-qtgraphicaleffects (5.11.1 -> 5.11.2)
libqt5-qtimageformats (5.11.1 -> 5.11.2)
libqt5-qtlocation (5.11.1 -> 5.11.2)
libqt5-qtmultimedia (5.11.1 -> 5.11.2)
libqt5-qtquickcontrols (5.11.1 -> 5.11.2)
libqt5-qtquickcontrols2 (5.11.1 -> 5.11.2)
libqt5-qtscript (5.11.1 -> 5.11.2)
libqt5-qtsensors (5.11.1 -> 5.11.2)
libqt5-qtserialport (5.11.1 -> 5.11.2)
libqt5-qtspeech (5.11.1 -> 5.11.2)
libqt5-qtsvg (5.11.1 -> 5.11.2)
libqt5-qttools (5.11.1 -> 5.11.2)
libqt5-qtwayland (5.11.1 -> 5.11.2)
libqt5-qtwebchannel (5.11.1 -> 5.11.2)
libqt5-qtwebengine (5.11.1 -> 5.11.2)
libqt5-qtwebsockets (5.11.1 -> 5.11.2)
libqt5-qtx11extras (5.11.1 -> 5.11.2)
libqt5-qtxmlpatterns (5.11.1 -> 5.11.2)
libserf
libssh (0.8.2 -> 0.8.3)
libvirt (4.6.0 -> 4.7.0)
mcelog (1.53 -> 1.60)
mozilla-nss (3.37.3 -> 3.38)
openssh
oxygen5-icon-theme (5.49.0 -> 5.50.0)
patterns-kde
pcre (8.41 -> 8.42)
perl-Apache-AuthCookie (3.25 -> 3.27)
perl-Archive-Zip (1.63 -> 1.64)
perl-Config-IniFiles (2.98 -> 3.000000)
perl-DBD-mysql (4.047 -> 4.048)
perl-Encode-JIS2K (0.02 -> 0.03)
perl-IO-Socket-SSL (2.059 -> 2.060)
perl-Image-ExifTool (11.01 -> 11.11)
perl-Net-DNS (1.17 -> 1.18)
perl-YAML-LibYAML (0.72 -> 0.74)
php7 (7.2.9 -> 7.2.10)
plasma-framework (5.49.0 -> 5.50.0)
prison-qt5 (5.49.0 -> 5.50.0)
psmisc
purpose (5.49.0 -> 5.50.0)
python-M2Crypto (0.29.0 -> 0.30.1)
rpm
rubygem-pg (0.20.0 -> 1.1.3)
scout (0.2.1+20180813.59519f8 -> 0.2.1+20180914.017a078)
sddm
serd
slang
solid (5.49.0 -> 5.50.0)
sonnet (5.49.0 -> 5.50.0)
spamassassin (3.4.1 -> 3.4.2)
spice (0.14.0 -> 0.14.1)
sratom
sudo (1.8.25 -> 1.8.25p1)
sushi (3.28.3 -> 3.30.0)
syndication (18.08.1 -> 5.50.0)
syntax-highlighting (5.49.0 -> 5.50.0)
threadweaver (5.49.0 -> 5.50.0)
tigervnc
valgrind
virglrenderer (0.6.0 -> 0.7.0)
wicked (0.6.48 -> 0.6.49)
wpa_supplicant
xf86-video-intel (2.99.917+git781.c8990575 -> 2.99.917+git8674.25c9a2fcc)
xorg-docs
zsh
zypper (1.14.8 -> 1.14.11)

=== Details ===

==== ImageMagick ====
Version update (7.0.8.11 -> 7.0.8.12)
Subpackages: ImageMagick-extra libMagick++-7_Q16HDRI4 libMagickCore-7_Q16HDRI6
libMagickWand-7_Q16HDRI6 perl-PerlMagick

- update to 7.0.8-12:
* Added support for arithmetic coding to the jpeg encoder:
- define jpeg:arithmetic-coding=true.
* Fixed numerous use of uninitialized values, integer overflow, memory
exceeded, and timeouts (credit to OSS Fuzz).

==== MozillaThunderbird ====
Subpackages: MozillaThunderbird-translations-common

- Update file list since minidump-analyzer is only available when
crashreporter is enabled

==== apache2 ====
Version update (2.4.34 -> 2.4.35)
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- updated to 2.4.35:
* http: Enforce consistently no response body with both 204 and 304
statuses.
* mod_status: Cumulate CPU time of exited child processes in the
"cu" and "cs" values. Add CPU time of the parent process to the
"c" and "s" values.
* mod_proxy: Improve the balancer member data shown in mod_status when
"ProxyStatus" is "On": add "busy" count and show byte counts in
auto mode always in units of kilobytes.
* mod_status: Add cumulated response duration time in milliseconds.
* mod_status: Complete the data shown for async MPMs in "auto" mode.
Added number of processes, number of stopping processes and number
of busy and idle workers.
* mod_ratelimit: Don't interfere with "chunked" encoding, fixing regression
introduced in 2.4.34. PR 62568.
* mod_proxy: Remove load order and link dependency between mod_lbmethod_*
modules and mod_proxy. PR 62557.
* Allow the argument to <IfFile>, <IfDefine>, <IfSection>, <IfDirective>,
and <IfModule> to be quoted. This is primarily for the benefit of
<IfFile>.
* mod_watchdog: Correct some log messages.
* mod_md: When the last domain name from an MD is moved to another one,
that now empty MD gets moved to the store archive. PR 62572.
* mod_ssl: Fix merging of SSLOCSPOverrideResponder.
* mod_proxy_balancer: Restore compatibility with APR 1.4.

==== apr-util ====
Subpackages: apr-util-devel libapr-util1

- Add missing zlib-devel build dependency which used to be pulled in
by libopenssl-devel

==== attica-qt5 ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Attica5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Add support for proposed tags addition in OCS 1.7
* Use QTEST_GUILESS_MAIN

==== baloo5 ====
Version update (5.49.0 -> 5.50.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Fixed a typo in the index size output (kde#397843)
* Remove src not dest url when a url is newly unindexable.
* [tags_kio] Simplify the filename path query matching by using a capture
group.
* Revert "Skip queueing newly unindexable files and remove them from the
index immediately."
* [tags_kio] Simplify file path lookup while loop.

==== bluez-qt ====
Version update (5.49.0 -> 5.50.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== boost ====

- Fix build on Leap < 15.0

==== boost-base ====
Subpackages: boost-license1_68_0 boost_1_68-jam libboost_date_time1_68_0
libboost_filesystem1_68_0 libboost_headers1_68_0-devel libboost_iostreams1_68_0
libboost_locale1_68_0 libboost_program_options1_68_0 libboost_regex1_68_0
libboost_signals1_68_0 libboost_system1_68_0 libboost_thread1_68_0

- Fix build on Leap < 15.0

==== breeze5-icons ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Add LabPlot project file icon
* ScalableTest, add "scalable" plasma-browser-integration (kde#393999)

==== ca-certificates ====

- Changed "openssl" requirement to "openssl(cli)"
* (bsc#1101470)

==== cronie ====
Subpackages: cron

- update to 1.5.2
* cronnext: New useful utility to find out time of the next job
run.
* crond: Avoid creating PID files when crond doesn't fork.
* crontab: Do not try to replace the crontab with a directory.
* crond: Log startup even when started in non-forking mode.
* Multiple small cleanups and fixes.
- update Source address
- remove cronie-1.4.7-disable_logging.patch and restore the
original cronie behaviour (a line starting with a dash in
normal user's crontab is handled as incorrect), there was enough
time for crontab migration. Manpage part of the patch was applied
upstream
- remove cronie-nofork-nopid.patch (applied upstream)
- pack cronnext utility
- call autoreconf

==== cvs ====
Version update (1.12.12 -> 1.12.13)

- Upgrade to 1.12.13
This version fixes two security vulnerabilities in the zlib
compression libraries (see CERT vulnerabilities advisories
[#238678] & #680620 for more info), several issues involving
potential data-loss on heavily loaded systems, some minor
potential crashes, hangs, and several minor annoyances in CVS
client and server behavior.
See also:
https://savannah.nongnu.org/forum/forum.php?forum_id=4046
http://cvs.savannah.gnu.org/viewvc/cvs/ccvs/NEWS?revision=1.341

==== dolphin ====
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Add Dont-assign-twice-the-same-key-to-the-action-New-Tab.patch to
avoid an "Ambiguous shortcuts" error on startup when running
dolphin on a different desktop than Plasma
(boo#1109372, kde#398324)

==== elfutils ====
Version update (0.173 -> 0.174)
Subpackages: elfutils-lang libasm1 libdw1 libebl-plugins libelf-devel libelf1

- Add disable-backtrace-dwarf-test.patch in order to work around:
https://sourceware.org/bugzilla/show_bug.cgi?id=23673.
- Update to version 0.174
libelf, libdw and all tools now handle extended shnum and
shstrndx correctly.
elfcompress: Don't rewrite input file if no section data needs
updating. Try harder to keep same file mode bits
(suid) on rewrite.
strip: Handle mixed (out of order) allocated/non-allocated
sections.
unstrip: Handle SHT_GROUP sections.
backends: RISCV and M68K now have backend implementations to
generate CFI based backtraces.

==== epiphany ====
Version update (3.30.0 -> 3.30.1)
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Update to version 3.30.1:
+ Enable media source extensions.
+ Don't show reader mode icon on internal pages (e.g.
about:incognito).
+ Add reader mode styling for <mark> elements.
+ Fix searches using a colon in the first word.
+ Fix frequent crashes, and also fix address bar with multiple
windows open.
+ Fix crash on homedepot.com.
+ Hide homepage button in app mode.
+ Ensure Firefox Sync preferences web view uses Epiphany data
directories.

==== firewalld ====
Version update (0.6.1 -> 0.6.2)
Subpackages: firewall-macros firewalld-lang python3-firewall

- Add upstream patch to mark more strings as translatable which is
required by firewall UI when creating rich rules (bsc#1096542)
* 0001-Fix-translating-labels-392.patch
- Add upstream patch to fix rich rules that uses ipset (bsc#1104990)
* 00002-firewalld-0.6.x-rich-rule-with-ipset-regression.patch
- Update to 0.6.2. Some of the changes are:
* update translations
* nftables: fix log-denied with values other than "all" or "off"
* fw_ipset: raise FirewallError if backend command fails
* ipset: only use "-exist" on restore
* fw_ipset: fix duplicate add of ipset entries
* *tables: For opened ports/protocols/etc match ct state new,untracked
(bsc#1105821)
* ipXtables: increase wait lock to 10s
* nftables: fix rich rules ports/protocols/source ports not considering ct
state
* ports: allow querying a single added by range
* fw_zone: do not change rich rule errors into warnings
* fw_zone: fix services with multiple destination IP versions (bsc#1105899)
* fw_zone: consider destination for protocols
* firewall/core/fw_nm: nm_get_zone_of_connection should return None or empty
string instead of False (boo#1106319)
* fw: If direct rules fail to apply add a "Direct" label to error msg
* fw: if startup fails on reload, reapply non-perm config that survives reload
* nftables: fix rich rule audit log
* ebtables: replace RETURN policy with explicit RETURN at end of chain
* direct backends: allow build_chain() to build multiple rules
* fw: if failure occurs during startup set state to FAILED
* fw: on restart set policy from same function
* ebtables: drop support for broute table
- Remove upstream patches
* 0001-nftables-fix-rich-rules-ports-protocols-source-ports.patch
* 0001-fw_zone-consider-destination-for-protocols.patch
* 0002-fw_zone-fix-services-with-multiple-destination-IP-ve.patch
* firewalld-fix-firewalld-config-crash.patch

==== frameworkintegration ====
Version update (5.49.0 -> 5.50.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* [KStyle] Use dialog-question for question icon

==== gettext-runtime ====
Subpackages: gettext-tools

- Add patch msgfmt-reset-msg-length-after-remove.patch
which does reset the length of message string after a line
has been removed (boo#1106843)

==== gnome-backgrounds ====
Version update (3.28.0 -> 3.30.0)
Subpackages: gnome-backgrounds-lang

- Update to version 3.30.0:
+ Updated translations.
- Remove lang package from recommended packages as it already
supplements main package (same effect, it's redundant).
- Update to version 3.29.90:
+ New defaults.
- Use autosetup macro.

==== gnome-chess ====
Version update (3.28.1 -> 3.30.0)
Subpackages: gnome-chess-lang

- Update to version 3.30.0:
+ Updated translations.
- Remove lang package from recommended packages as it already
supplements main package (same effect, it's redundant).
- Update to version 3.29.90:
+ Fix code to ensure chess engine dies if main process crashes.
+ Don't display claim draw dialog when opening game.
+ Fix wrong player sometimes winning when timer expires.
+ Fix various bugs with open/save dialogs and switch to native
dialogs.
- Update to version 3.29.1:
+ Display special message when en passant is performed.
+ Fix draw being offered improperly when viewing past history.

==== gnome-games ====
Version update (3.28.0 -> 3.30.1)
Subpackages: gnome-games-lang

- Update to version 3.30.1:
+ MAME plugin loading is now slightly faster.
+ Fix crash in PlayStation plugin.
+ Pressed buttons in controller preferences are now positioned
correctly.
+ Fix drawing failure in controller preferences.
+ Fix occasional tiny thumbnails in Developers and Platforms
views.
+ Fix GTK+ warnings when browsing collection.
+ Updated translations.
- Update to version 3.30.0:
+ Updated translations.
- Changes from version 3.29.92.1:
+ UI:
- Add navigation with gamepads.
- Add the shortcuts for the gamepad controls in the shortcuts
window.
- Add Developers view that allows browsing games by developer.
- Add Platforms view that allows browsing game by platform.
- Use theme colors for GamepadView.
- Use symbolic icon for loading notification close button.
+ Supported games:
- Add support for Flatpak-ed Steam games.
+ Flatpak:
- Use `flatpak-spawn` to run Steam games.
- Fix displaying icons for Steam games.
- Fix downloading covers for Steam games.
+ Cache covers on disk, significantly speeding up application UI.
+ Fixes:
- Fix building with Vala 0.42.x.
- Fix many runtime warnings.
- Blacklist Flatpak-ed Steam desktop file.
- Various code cleanups.
+ Update the authors and documenters lists.
+ Updated translations.
- Drop gnome-games-fix-build-vala42.patch (fixed upstream).
- Update to version 3.29.90:
+ UI:
- Don't display the list of gamepads if none is available.
- Add borders around all lists in preferences.
- Scale the default emblem to the thumbnail's size.
+ Ensure games in the collection are added only once.
+ Add many more information about games and make Grilo fetch some
of it, thought this information is mostly unused.
+ Fixes:
- Fix a reference leak leading to Libretro cores not being
uninitialized.
- Fix many potential crashers.
- Various code cleanups.
+ Updated translations.
- Update to version 3.29.4:
+ Build:
- Replace the Autotools by Meson.
- Replace intltool for gettext.
- Replace the update-gameinfo build target by the
update-gameinfo.sh script.
- Add a development profile, settable by passing the
`-Dprofile=development` parameter to Meson. This profile
makes it clear the application is a development version by
appending ` (Development)` to the application name, by
appending `Devel` to the application ID, by changing the
style of the header bar and by appending the commit tag or
`-devel` to the version number.
+ UI:
- Allow to set the keyboard to gamepad mapping from the
preferences Controllers page.
- Make searching for local covers less greedy and asynchronous,
speeding up the loading time of the collection.
- Move the application menu to the collection view's header
bar.
- Add the Help application menu entry, opening Games'
documentation on the GNOME wiki.
- Add the Shortcuts application menu entry displaying a
shortcuts window.
- Display small thumbnails if the window is narrow to display
more of games.
- Correctly update the selected media number on the media
selector.
- Drop the shadow in the collection view's scrolled window.
+ Libretro backend:
- Add support for .options keyfiles listing options to be set
on a Libretro core at initialization time.
- Add predefined options for DeSmuME and DeSmuME 2015.
+ Supported games:
- Add support for Virtual Boy games.
- Use a dedicated MIME type for Neo Geo Pocket Color instead of
the Neo Geo Pocket one.
- Use a phony TurboGrafx-CD MIME type to fetch information from
Grilo.
+ Allow to read cue sheets in other formats than UTF-8, avoiding
the application to crash when parsing a file in UTF-16 or other
encoding.
+ Update the authors lists.
+ Update the appdata to the latest specifications, OARS metadata
and update gitlab links.
+ Updated translations.
- Switch to meson buildsystem, add meson BuildRequires and
corresponding macros.
- Add gnome-games-fix-build-vala42.patch: Fix build with vala42.
- Add fdupes BuildRequires and macro, remove duplicates.
- Drop intltool and libtool BuildRequires: No longer needed.
- Update to version 3.29.1:
+ Allow axes to map to buttons in the gamepad mapping wizard.
+ Unregister the grilo-plugin sources that are irrelevant to
Games.
+ UI:
- Prevent display of multiple setting windows to the user.
- Use the standard size for media button's icon.
+ Bugs fixed: glgo#GNOME/gnome-games#2, glgo#GNOME/gnome-games#9,
glgo#GNOME/gnome-games#12, bgo#782290.
+ Updated Translations.

==== gnome-mines ====
Version update (3.28.0 -> 3.30.1.1)
Subpackages: gnome-mines-lang

- Update to version 3.30.1.1:
+ Fixed invisible flag.
- Update to version 3.30.1:
+ Install 256x256 icon.
+ Updated translations.
- Update to version 3.30.0:
+ Updated translations.
+ Help cleanup.
+ Flatpak dependency urls updated to gitlab.
- Remove lang package from recommended packages as it already
supplements main package (same effect, it's redundant).
- Update to version 3.29.3:
+ Updated translations.

==== gnome-sudoku ====
Version update (3.28.0 -> 3.30.0)
Subpackages: gnome-sudoku-lang

- Update to version 3.30.0:
+ Miscellaneous fixes to meson build system.
+ Miscellaneous fixes to user help.
+ Updated translations.
- Drop sudoku-fix-appdata-location.patch (fixed upstream).
- Remove lang package from recommended packages as it already
supplements main package.
- Update to version 3.29.2:
+ No visible changes for the user.
- Add:
+ meson BuildRequires and replace configure/make_build/make_\
install macros with meson/meson_build/meson_install
respectively, to follow upstream port to Meson build system.
+ sudoku-fix-appdata-location.patch.
- Drop update-desktop-files BuildRequires and suse_update_desktop_\
file macro: they are no longer needed.

==== installation-images-Kubic ====
Version update (14.380 -> 14.384)

- merge gh#openSUSE/installation-images#264
- aarch64: add gpio-thunderx.ko module (bsc#1106114)
- 14.384
- merge gh#openSUSE/installation-images#262
- adjust to iptables using update-alternatives (bsc#1108289)
- added 'clear' to instsys (bsc#1108005)
- 14.383
- merge gh#openSUSE/installation-images#261
- Make monitor miror mode during installation the default again
(bsc#1108905)
- merge gh#openSUSE/installation-images#260
- Add ptp_qoriq to module.config
- 14.382
- merge gh#openSUSE/installation-images#259
- add bcache-tools to installation initrd (fate#325346)
- add bcache-tools to installatio initrd (fate#325346)
- 14.381

==== iptables ====
Version update (1.6.2 -> 1.8.0.g85)
Subpackages: libiptc0 libxtables12 xtables-plugins

- Add missing update-alternatives dependency to Requires(post)
section. If this is missing the package fails to install properly
when it is used as build dependency.
- Update to new upstream release 1.8.0 and snapshot 1.8.0.g75
* The ipv6 "srh" match can now match previous/next/last sid
* CONNMARK target now supports bit-shifting for restore,set
and save-mark.
* DNAT now supports shifted portmap ranges.
* iptables now comes in two backends: legacy and nft.

==== kactivities-stats ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kactivities5 ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== karchive ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Actual gz file, the other was empty
* handle non-ASCII encodings of file names in tar archives (kde#266141)
* KCompressionDevice: don't call write after WriteError (kde#397545)
* autotests: adjust expected value for Windows...
* Add missing Q_OBJECT macros for QIODevice subclasses
* KCompressionDevice: propagate errors from QIODevice::close() (kde#397545)
* Fix bzip main page

==== kauth ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kbookmarks ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kcmutils ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Use custom QScrollArea with size hint not limited by font size (kde#389585)
- Dropped patches, now upstream:
* 0001-Use-custom-QScrollArea-with-size-hint-not-limited-by.patch
- Add upstream patch 0001-Manually-resize-KCMUtilDialog-to-sizeHint.patch:
* Workaround for QTBUG-3459 to prevent too small windows when
system settings modules are opened standalone (kde#389585)

==== kcodecs ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kcompletion ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kconfig ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Remove warning about old kiosk feature that no longer applies.
* Set system default shortcut Ctrl+0 for "Actual Size" action
* Fix cleanup of kconfigtest kdeglobals

==== kconfigwidgets ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kcoreaddons ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Don't remove space between two url when line start with " (kmail bug)
* Add kmail bug. Need to understand why it eats space
* Add more autotest
* KPluginLoader: use '/' even on Windows, libraryPaths() returns paths with
'/'
* autotests: add debug output for plugin dirs, to investigate Purpose CI on
Windows
* KPluginMetaData: convert empty string to empty stringlist.

==== kcrash ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kdbusaddons ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kdeclarative ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Revert "ensure we are always writing in the engine's root context"
* Attach property to "delegate" (kde#397367)
* add an implicit size
* [KCM GridDelegate] Use layer effect only on OpenGL backend

==== kdepim-runtime ====
Subpackages: kdepim-runtime-lang

- Unversion the syndication requirement now that it has been moved
to Frameworks

==== kdesu ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kdewebkit ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kdnssd-framework ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kdoctools ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* add acronym ASCII to general.entities
* add JSON to general.entities
* Let test.cmake find the files where they were installed
* Let meinproc5 be more verbose in 'install' auto test
* Let 'install' autotest build in verbose mode to see KDE CI build issues
* Fix KDE CI compile issue
* In kdoctools_install test use absolute pathes to find installed files
* Convert manual install test to an autotest

==== kemoticons ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kernel-firmware ====
Version update (20180825 -> 20180913)
Subpackages: ucode-amd

- Update to version 20180913:
* brcm: update firmware for bcm43362 sdio
* Mellanox: Add new mlxsw_spectrum firmware 13.1703.4
* rtl_bt: Add firmware and configuration files for the Bluetooth part of
RTL8822CU
* nvidia: switch GP10[2467] to newer scrubber/ACR firmware (from GP108)

==== kexec-tools ====

- kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32.patch
Upstream backport.
In response to a change in binutils, commit b21ebf2fb4c
(x86: Treat R_X86_64_PLT32 as R_X86_64_PC32) was applied to
the linux kernel during the 4.16 development cycle and has
since been backported to earlier stable kernel series. The
change results in the failure message in $SUBJECT when
rebooting via kexec.
Fix this by replicating the change in kexec.

==== kfilemetadata5 ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kfilemetadata5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* add missing include
* Add enum alias Property::Language for typo Property::Langauge

==== kglobalaccel ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kguiaddons ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kholidays ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Implement proper equinox and solstice calculation algorithm (kde#396750)
* src/CMakeLists.txt - install headers the frameworks-way

==== khtml ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== ki18n ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Assert if trying to use a KCatalog without a QCoreApplication
* Port ki18n from QtScript to QtQml
* Migrate build system to use find_package in autotests/ki18n_install
* API docs: fix *xi18n* calls in example code to use correct variants
* Check the build directory for po/ as well

==== kiconthemes ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Set breeze as fallback icon theme

==== kidletime ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kimageformats ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kinit ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kinit-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kio ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kio-core kio-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Too many changes to list here
- Drop 0001-Revert-Support-NTFS-hidden-files.patch, the problem
with the root folder being hidden has been fixed (or rather
workarounded) upstream

==== kio-extras5 ====
Subpackages: kio-extras5-lang libkioarchive5

- Add upstream patch 0001-sftp-bump-pending-request-count-from-1-to-128.patch
* Increase sftp file reading speed up to 20 times

==== kirigami2 ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Require the library in the -devel subpackage
- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Too many changes to list here
- Dropped patches, now upstream:
* fix-build-with-gcc48.patch

==== kitemmodels ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kitemviews ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Deprecate KFilterProxySearchLine

==== kjobwidgets ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kjs ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kjsembed ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kmailtransport ====
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Require sasl2-kdexoauth2 instead of sasl2-kdexoauth2-3, the
package has been renamed

==== knewstuff ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Cache providerId

==== knotifications ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Support libcanberra for audio notification

==== knotifyconfig ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kpackage ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kpackage-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* autotests: plasmoidpackagetest fails when run in parallel to others
* autotests: handle /home being a symlink on the FreeBSD CI

==== kparts ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kpeople5 ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kpeople5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kplotting ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kpty ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kross ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kross-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== krunner ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* autotests: ensure Plasma/Runner servicetype is found in CI

==== kservice ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kservice-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* autotests: debug output for CI failure, or for general debugging
* autotests: rename header and function to match new purpose
* autotests: also copy applications.menu and set XDG_CONFIG_DIRS so it's found
* KBuildSycoca: always process application desktop files.
* autotests: factorize XDG_DATA_DIRS setup in new header, use from 3rd test
* autotests: don't wait for signal if we already received it (e.g. Windows CI)
* autotests: fix failure on Windows, QStringLiteral isn't fromUtf8 there...
* autotests: use data/kservicetypes5 instead of share, so it works on Windows
too
* autotests: use local servicetype desktop files in kservicetest as well
* autotests: use local copies of kplugininfo.desktop and application.desktop

==== ktexteditor ====
Version update (5.49.0 -> 5.50.0)
Subpackages: ktexteditor-lang

- Trim bias from description.
- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Too many changes to list here
- Refreshed patches:
* 0001-Disable-KAuth-integration.patch

==== ktextwidgets ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kunitconversion ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kwallet ====
Version update (5.49.0 -> 5.50.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Move example from techbase to own repo

==== kwayland ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Sync set/send/update methods
* Add serial number and EISA ID to OutputDevice interface
* Fix unit test
* Output device color curves correction
* Fix memory management in WaylandOutputManagement
* Isolate every test within WaylandOutputManagement
* OutputManagement fractional scaling

==== kwidgetsaddons ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Create a first example of the use of KMessageBox
* Fix two bugs in KMessageWidget
* [KMessageBox] Call style for icon
* Add workaround for labels with word-wrapping

==== kwindowsystem ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== kxmlgui ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Make Konqi look good in HiDPI
* autotests: see if ru_RU works better than uk in CI.
* Add missing parenthese

==== kxmlrpcclient5 ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== libKF5ModemManagerQt ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== libKF5NetworkManagerQt ====
Version update (5.49.0 -> 5.50.0)

- Add 0001-Revert-Require-NetworkManager-1.4.0-and-newer.patch to
make it build on Leap 42.3 which only has NetworkManager 1.0.
- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Remove notes from API documentation about older NM versions
* Require NetworkManager 1.4.0 and newer
* manager: add support to R/W the GlobalDnsConfiguration property
* Actually allow to set the refresh rate for device statistics

==== libjpeg-turbo ====
Subpackages: libjpeg8 libjpeg8-32bit libturbojpeg0

- Define FLOATTEST=64bit on ppc
- ctest-depends.patch: Add missing testsuite depedencies

==== libkgapi ====
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang

- Use < instead of <= when obsoleting sasl2-kdexoauth2-3 to prevent
self-obsoletion
- Rename sasl2-kdexoauth2-3 to sasl2-kdexoauth2, it is not a shared
library but a plugin for sasl2, and it makes no sense to have
several versions installed at the same time
- Provide sasl2-kdexoauth2-3 for now to avoid dependency problems
and to replace the old package
- Move libkdexoauth2.so from libkgapi-devel to sasl2-kdexoauth2,
apparently it's required on runtime for gmail/xoauth
authentification to work (boo#1108577, kde#375410)

==== libmanette ====
Version update (0.2.0 -> 0.2.1)

- Update to version 0.2.1:
+ Defer the emission of input device events by putting them into
idle event sources.
+ Update the game controller database.

==== libqt5-qtbase ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5Concurrent5 libQt5Core5 libQt5DBus5 libQt5Gui5
libQt5Network5 libQt5OpenGL5 libQt5PrintSupport5 libQt5Sql5 libQt5Sql5-mysql
libQt5Sql5-sqlite libQt5Test5 libQt5Widgets5 libQt5Xml5
libqt5-qtbase-platformtheme-gtk3

- Add patch to avoid lag on startup with the modesetting driver on
intel (QTBUG-70760):
* 0001-xcb-Don-t-get-initial-screen-rotation.patch
- Update to 5.11.2
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtbase.git/plain/dist/changes-5.11.2/?h=v5.11.2
- Refresh patches:
* 0002-xcb-Use-the-screen-s-physical-DPI-as-logical-DPI-unl.patch
* tell-the-truth-about-private-api.patch
- Remove patches, now upstream:
* 0001-Fix-qmake-build-with-glibc-2.28.patch
- Add patch to fix build on 32-bit:
* Export-qt_open64-from-QtCore.patch

==== libqt5-qtconnectivity ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5Bluetooth5 libQt5Bluetooth5-imports libQt5Nfc5
libQt5Nfc5-imports libqt5-qtconnectivity-tools

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtconnectivity.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtdeclarative ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtdeclarative.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtgraphicaleffects ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtgraphicaleffects.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtimageformats ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtimageformats.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtlocation ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5Location5 libQt5Positioning5 libQt5PositioningQuick5

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtlocation.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtmultimedia ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtmultimedia.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtquickcontrols ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtquickcontrols.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtquickcontrols2 ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5QuickControls2-5 libQt5QuickTemplates2-5

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtquickcontrols2.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtscript ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtscript.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtsensors ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5Sensors5 libQt5Sensors5-imports

- Update to 5.11.2
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtsensors.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtserialport ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtserialport.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtspeech ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtspeech.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtsvg ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtsvg.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qttools ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5Designer5 libQt5Help5 libqt5-qdbus libqt5-qtpaths

- Update to 5.11.2
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qttools.git/plain/dist/changes-5.11.2/?h=v5.11.2
- Add requires_eq for clang to workaround QTBUG-70687 (boo#1109367)
- Use %license, remove %defattr

==== libqt5-qtwayland ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5WaylandClient5 libQt5WaylandCompositor5

- Update to 5.11.2
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qtwayland.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtwebchannel ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5WebChannel5 libQt5WebChannel5-imports

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebchannel.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtwebengine ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebengine.git/plain/dist/changes-5.11.2/?h=v5.11.2
- Remove patches, now upstream:
* fix-build-with-ffmpeg4.patch
- Use pkgconfig() notation for the libav* BuildRequires

==== libqt5-qtwebsockets ====
Version update (5.11.1 -> 5.11.2)
Subpackages: libQt5WebSockets5 libQt5WebSockets5-imports

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtwebsockets.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtx11extras ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtx11extras.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libqt5-qtxmlpatterns ====
Version update (5.11.1 -> 5.11.2)

- Update to 5.11.2
* New bugfix release
* For more details please see:
*
http://code.qt.io/cgit/qt/qtxmlpatterns.git/plain/dist/changes-5.11.2/?h=v5.11.2

==== libserf ====

- Use %license for license install

==== libssh ====
Version update (0.8.2 -> 0.8.3)

- Update to version 0.8.3
* Added support for rsa-sha2
* Added support to parse private keys in openssh container format
(other than ed25519)
* Added support for diffie-hellman-group18-sha512 and
diffie-hellman-group16-sha512
* Added ssh_get_fingerprint_hash()
* Added ssh_pki_export_privkey_base64()
* Added support for Match keyword in config file
* Improved performance and reduced memory footprint for sftp
* Fixed ecdsa publickey auth
* Fixed reading a closed channel
* Added support to announce posix-rename@xxxxxxxxxxx and
hardlink@xxxxxxxxxxx in the sftp server
- Removed patch: 0001-poll-Fix-size-types-in-ssh_event_free.patch

==== libvirt ====
Version update (4.6.0 -> 4.7.0)
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-gluster libvirt-daemon-driver-storage-iscsi
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc
libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- Fix RPM groups. Remove idempotent %if..%endif guards.
- Remove redundant %clean section.
- libxl: fix VM migration on busy hosts
60b4fd90-libxl-rm-vm-finish-phase.patch,
e39c66d3-libxl-fix-p2p-migration.patch,
47da84e0-libxl-fix-job-handling-migsrc.patch,
0149464a-libxl-fix-job-handling-migdst.patch,
5ea2abb3-libxl-join-mig-rcv-thread.patch
bsc#1108086
- Update to libvirt 4.7.0
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
9ed59012--revert-jansson1.patch,
54f2b5e3-revert-jansson2.patch,
b56950fd-revert-jansson3.patch,
6c3d66ac-revert-jansson4.patch,
8e373e6d-revert-jansson5.patch,
6f99de31-revert-jansson6.patch,
f204cf51-revert-jansson7.patch,
5a58b5ed-revert-jansson8.patch,
63f6e0e9-revert-jansson9.patch,
8687eba-revert-jansson10.patch,
e96e71d8-revert-jansson11.patch,
d99a8959-revert-jansson12.patch,
074a7e14-revert-jansson13.patch,
86db0db9-revert-jansson14.patch

==== mcelog ====
Version update (1.53 -> 1.60)

(by trenn@xxxxxxx)
- Update to version 1.60 (fate#326221):
* Turn back rb_color field into unsigned long
* trigger: add a sync argument for waiting trigger child process exit
* page: trigger: add pre/post sync trigger when doing soft memory offline
* fixed build errors for some lose code when merging code
* transfer the page address to pre/post-sync-trigger scripts
* mcelog: Fix "--ascii" parsing to cope with change in kernel output since
v4.10
* Remove now unused local variable
* Add scripts file to do MCA error code validation for a selected CPU model
* Add license file
* mcelog: Improve decoding for APEI reported errors

==== mozilla-nss ====
Version update (3.37.3 -> 3.38)
Subpackages: libfreebl3 libsoftokn3 mozilla-nss-certs mozilla-nss-tools

- update to NSS 3.38
* required by Firefox 62.0
New Functionality
* Added support for the TLS Record Size Limit Extension
* When creating a certificate request (CSR) using certutil -R, an
existing orphan private key can be reused. Parameter -k may be
used to specify the ID of an existing orphan key. The available
orphan key IDs can be displayed using command certutil -K.
* When using certutil -O to print the chain for a given certificate
nickname, the new parameter --simple-self-signed may be provided,
which can avoid ambiguous output in some scenarios.
New Functions
* SECITEM_MakeItem - Allocate and make an item with the requested contents
(secitem.h)
New Macros
* SSL_RECORD_SIZE_LIMIT - used to control the TLS Record Size Limit
Extension (in ssl.h)
Notable Changes
* Fixed CVE-2018-0495 (bmo#1464971)
* Various security fixes in the ASN.1 code
* NSS automatically enables caching for SQL database storage on
Linux, if it is located on a network filesystem that's known to
benefit from caching.
* When repeatedly importing the same certificate into an SQL database,
the existing nickname will be kept.

==== openssh ====
Subpackages: openssh-helpers

- seccomp_filter sandbox is not supported on ppc

==== oxygen5-icon-theme ====
Version update (5.49.0 -> 5.50.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Don't require fdupes on Windows.

==== patterns-kde ====
Subpackages: patterns-kde-kde patterns-kde-kde_edutainment
patterns-kde-kde_games patterns-kde-kde_ide patterns-kde-kde_imaging
patterns-kde-kde_internet patterns-kde-kde_multimedia patterns-kde-kde_office
patterns-kde-kde_pim patterns-kde-kde_plasma patterns-kde-kde_utilities
patterns-kde-kde_utilities_opt patterns-kde-kde_yast

- Apply qt devel icon (boo#1039994)
- Change icon for kde-pim (boo#1107103)

==== pcre ====
Version update (8.41 -> 8.42)
Subpackages: libpcre1 libpcre1-32bit libpcre16-0 libpcrecpp0 libpcreposix0
pcre-devel

- pcre 8.42:
* Fix outdated real_pcre definitions in pcre.h.in
* pcregrep was truncating components of file names to 128
characters when processing files with the -r option, and also
truncating path names to 512 characters. There is now a check on
the absolute length of full path file names, which may be up to
2047 characters long
* Using pcre_dfa_exec(), in UTF mode when UCP support was not
defined, there was the possibility of a false positive match when
caselessly matching a "not this character" item such as
[^\x{1234}] (with a code point greater than 127) because the
"other case" variable was not being initialized
* Although pcre_jit_exec checks whether the pattern is compiled
in a given mode, it was also expected that at least one mode is
available. This is fixed and pcre_jit_exec returns with
PCRE_ERROR_JIT_BADOPTION when the pattern is not optimized by JIT
at all.
* The line number and related variables such as match counts in
pcregrep were all int variables, causing overflow when files with
more than 2147483647 lines were processed (assuming 32-bit ints).
They have all been changed to unsigned long ints.
* If a backreference with a minimum repeat count of zero was first in
a pattern, apart from assertions, an incorrect first matching
character could be recorded. For example, for the pattern
/(?=(a))\1?b/, "b" was incorrectly set as the first character of
a match.
* Fix out-of-bounds read for partial matching of /./ against an
empty string when the newline type is CRLF.
* When matching using the the REG_STARTEND feature of the POSIX
API with a non-zero starting offset, unset capturing groups
with lower numbers than a group that did capture something were
not being correctly returned as "unset" (that is, with offset
values of -1).
* Matching the pattern /(*UTF)\C[^\v]+\x80/ against an 8-bit
string containing multi-code-unit characters caused bad
behaviour and possibly a crash. This issue was fixed for other
kinds of repeat in release 8.37 by change 38, but repeating
character classes were overlooked.
* A small fix to pcregrep to avoid compiler warnings for
- Wformat-overflow=2.
* Added --enable-jit=auto support to configure.ac.
* Fix misleading error message in configure.ac.

==== perl-Apache-AuthCookie ====
Version update (3.25 -> 3.27)

- updated to 3.27
see /usr/share/doc/packages/perl-Apache-AuthCookie/Changes
3.27 2017-07-28
- Fix POD spelling error [#118545].
3.26 2016-09-30
- remove unused module Apache::AuthCookie::Autobox from dist
- remove CGI.pm dependency. CGI.pm has been removed from perl core, which
was the primary reason we used it in the first place. Replaced with
dependency on lighter weight set of three modules:
* HTTP::Body
* WWW::Form::UrlEncoded
* Hash::MultiValue
Also recommended (but not required) is WWW::Form::UrlEncoded::XS
- Add optional support for charset encoding. If you have something like
PerlSetVar MyAuthNameEncoding UTF-8
Then AuthCookie with now automatically decode parameters using the given
encoding now. AuthCookie params() data will be decoded automatically if
this is on. See details in AuthCookie module documentation. In addition
r->user will be encoded (using byte semantics) using this encoding.
* **** IMPORTANT *****
If you turn this on, this could break your code. r->user() will now be
byte encoded using the given encoding. If you use usernames that contain
non-ascii characters you either need to use decoded_user(), or decode
r->user() yourself in your subclasses.
See the AuthCookie docs for more details.
- add optional support for decoding httpd.conf requires directives. This is
enabled with a RequiresEncoding setting:
PerlSetVar MyAuthNameRequiresEncoding UTF-8
Then decoded_requires($r) will return the decoded value of $r->requires
You only need this if you have non-ascii characters in your requires
directives such as:
Requires user programmør
- add decoded_user($r) method to get the value of r->user decoded using
character semantics instead of bytes. Due to the fact that r->user is a C
API method we cannot get character semantics on r->user directly. If no
Encoding directive is in effect, then this is the same as r->user.
- add encoding($r): string which returns the value of the Encoding directive
that is in effect for the current request.

==== perl-Archive-Zip ====
Version update (1.63 -> 1.64)

- updated to 1.64
see /usr/share/doc/packages/perl-Archive-Zip/Changes
1.64 Wed 12 Sep 2018
- Fix for year 2030
- Cleaned with spec-cleaner

==== perl-Config-IniFiles ====
Version update (2.98 -> 3.000000)

- updated to 3.000000
see /usr/share/doc/packages/perl-Config-IniFiles/Changes

==== perl-DBD-mysql ====
Version update (4.047 -> 4.048)

- updated to 4.048
* Fix corrupted META.json so cpan installations work as expected.
https://github.com/perl5-dbi/DBD-mysql/issues/263
- Cleaned with spec-cleaner

==== perl-Encode-JIS2K ====
Version update (0.02 -> 0.03)

- update to 0.03
Revision: 0.03 $ $Date: 2015/06/05 03:57:30 $
! Makefile.PL
fix RT#67531 & RT#104967
https://rt.cpan.org/Ticket/Display.html?id=67531
https://rt.cpan.org/Ticket/Display.html?id=104967
! lib/Encode/JIS2K/2022JP3.pm
fix RT#73401
https://rt.cpan.org/Ticket/Display.html?id=73401
- Dropped patch fixed upstream
* reproducible.patch
- Cleaned with spec-cleaner

==== perl-IO-Socket-SSL ====
Version update (2.059 -> 2.060)

- updated to 2.060
see /usr/share/doc/packages/perl-IO-Socket-SSL/Changes

==== perl-Image-ExifTool ====
Version update (11.01 -> 11.11)
Subpackages: exiftool perl-File-RandomAccess

- Update to version 11.11 (changes since 11.01):
* See /usr/share/doc/packages/perl-Image-ExifTool/Changes

==== perl-Net-DNS ====
Version update (1.17 -> 1.18)

- updated to 1.18
see /usr/share/doc/packages/perl-Net-DNS/Changes

==== perl-YAML-LibYAML ====
Version update (0.72 -> 0.74)

- update to 0.74
* Fix tests on older perls
* Support back to perl.5.8.1
- Cleaned with spec-cleaner

==== php7 ====
Version update (7.2.9 -> 7.2.10)
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pear-Archive_Tar php7-pgsql
php7-shmop php7-snmp php7-sockets php7-sqlite php7-sysvsem php7-sysvshm
php7-tidy php7-tokenizer php7-wddx php7-xmlreader php7-xmlwriter php7-xsl
php7-zip php7-zlib

- updated to 7.2.10: This is a security release which also contains
several minor bug fixes.
http://php.net/ChangeLog-7.php
- reenable php7-dba support of Berkeley DB [bsc#1108554]

==== plasma-framework ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Workaround bug with native rendering and opacity in TextField text
(kde#396813)
* [Icon Item] Watch KIconLoader icon change when using QIcon
* [Icon Item] Use ItemEnabledHasChanged
* Get rid of deprecated QWeakPointer usage
* Fix style sheet for 22-22-system-suspend (kde#397441)
* Improve Widgets' removal and configure text
* Copy PlasmaCore binary qmldir file structure into bin for unit tests

==== prison-qt5 ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== psmisc ====
Subpackages: psmisc-lang

- Add COPYING to file list as otherwise a required fix does not
reach anything

==== purpose ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* autotests: use QTemporaryDir instead of a hardcoded filename
* autotests: remove dependency on klauncher, in the hope to fix Windows CI
* autotests: actually disable copyjob debug output in CI
* Use a temp dir so that an existing /tmp/purposetest file doesn't break the
test.

==== python-M2Crypto ====
Version update (0.29.0 -> 0.30.1)
Subpackages: python2-M2Crypto python3-M2Crypto

- Update to 0.30.1:
* Various small typos (Windows builds, Fix SSL.Connection.__del__)
* The project is now Linux-distribution agnostic
* Replace all old-style classes with the new ones (it shouldn't
cause any problems, but feel free to file an issue, if it does)
* Do not by-pass a potential transfer decoding in m2urllib2
* Update M2Crypto.six with 1.11.0 and replace our local workarounds
with new functions.
* SSLv3 just removed.
* Don't support Python 2.6 on Windows anymore. Windows users don't
have python as a system package, so they are usually more likely
to upgrade anyway.

==== rpm ====
Subpackages: rpm-build rpm-devel

- Add upstream patch that prints dwz compression rate
new patch: dwz-compression.patch

==== rubygem-pg ====
Version update (0.20.0 -> 1.1.3)

- updated to version 1.1.3
- Revert opimization that was sometimes causing EBADF in
rb_wait_for_single_fd().
== v1.1.2 [2018-08-28] Michael Granger <ged@xxxxxxxxxxxxx>
- Don't generate aliases for JOHAB encoding.
This avoids linking to deprecated/private function rb_enc(db)_alias().
== v1.1.1 [2018-08-27] Michael Granger <ged@xxxxxxxxxxxxx>
- Reduce deprecation warnings to only one message per deprecation.
== v1.1.0 [2018-08-24] Michael Granger <ged@xxxxxxxxxxxxx>
Deprecated (disable warnings per PG_SKIP_DEPRECATION_WARNING=1):
- Forwarding conn.exec to conn.exec_params is deprecated.
- Forwarding conn.exec_params to conn.exec is deprecated.
- Forwarding conn.async_exec to conn.async_exec_params.
- Forwarding conn.send_query to conn.send_query_params is deprecated.
- Forwarding conn.async_exec_params to conn.async_exec is deprecated.
PG::Connection enhancements:
- Provide PG::Connection#sync_* and PG::Connection#async_* query methods for
explicit calling syncronous or asynchronous libpq API.
- Make PG::Connection#exec and siblings switchable between sync and async API
per PG::Connection.async_api= and change the default to async flavors.
- Add async flavors of exec_params, prepare, exec_prepared, describe_prepared
and describe_portal.
They are identical to their syncronous counterpart, but make use of
PostgreSQL's async API.
- Replace `rb_thread_fd_select()` by faster `rb_wait_for_single_fd()` in
`conn.block` and `conn.async_exec` .
- Add PG::Connection#discard_results .
- Raise an ArgumentError for strings containing zero bytes by #escape,
#escape_literal, #escape_identifier, #quote_ident and
PG::TextEncoder::Identifier. These methods previously truncated strings.
Result retrieval enhancements:
- Add PG::Result#tuple_values to retrieve all field values of a row as array.
- Add PG::Tuple, PG::Result#tuple and PG::Result#stream_each_tuple .
PG::Tuple offers a way to lazy cast result values.
- Estimate PG::Result size allocated by libpq and notify the garbage
collector about it when running on Ruby-2.4 or newer.
- Make the estimated PG::Result size available to
ObjectSpace.memsize_of(result) .
Type cast enhancements:
- Replace Ruby code by a faster C implementation of the SimpleDecoder's
timestamp decode functions. github #20
- Interpret years with up to 7 digists and BC dates by timestamp decoder.
- Add text timestamp decoders for UTC vs. local timezone variations.
- Add text timestamp encoders for UTC timezone.
- Add decoders for binary timestamps: PG::BinaryDecoder::Timestamp and
variations.
- Add PG::Coder#flags accessor to allow modifications of de- respectively
encoder behaviour.
- Add a flag to raise TypeError for invalid input values to
PG::TextDecoder::Array .
- Add a text decoder for inet/cidr written in C.
- Add a numeric decoder written in C.
- Ensure input text is zero terminated for text format in PG::Coder#decode .
Source code enhancements:
- Fix headers and permission bits of various repository files.
Bugfixes:
- Properly decode array with prepended dimensions. #272
For now dimension decorations are ignored, but a correct Array is returned.
- Array-Decoder: Avoid leaking memory when an Exception is raised while
parsing. Fixes #279
- Add more rpmlint filters to avoid warnings which are caused by this gem
- Removed license line from gem2rpm.yml as the license can be detected
automatically
- Drop rubygem-pg-0.17.1_shebang.patch as it's no longer needed
- updated to version 1.0.0
see installed History.rdoc
== v1.0.0 [2018-01-10] Michael Granger <ged@xxxxxxxxxxxxx>
Deprecated:
- Deprecate Ruby older than 2.2.
- Deprecate Connection#socket in favor of #socket_io.
Removed:
- Remove compatibility code for Ruby < 2.0 and PostgreSQL < 9.2.
- Remove partial compatibility with Rubinius.
Enhancements:
- Update error codes to PostgreSQL-10
- Update Windows binary gems to Ruby-2.5, PostgreSQL 10.1 and
OpenSSL 1.1.0g.
Bugfixes:
- Fix URI detection for connection strings. #265 (thanks to jjoos)
- MINGW: Workaround segfault due to GCC linker error in conjunction with MSVC.
This happens when linking to PostgreSQL-10.0-x64 from EnterpriseDB.
Documentation fixes:
- Add PostgreSQL version since when the given function is supported. #263
- Better documentation to `encoder` and `decoder` arguments of COPY related
methods.
== v0.21.0 [2017-06-12] Michael Granger <ged@xxxxxxxxxxxxx>
Enhancements:
- Move add_dll_directory to the Runtime namespace for newest versions
of RubyInstaller.
- Deprecate PGconn, PGresult, and PGError top-level constants; a warning
will be output the first time one of them is used. They will be
removed in the upcoming 1.0 release.
Documentation fixes:
- Update the docs for PG::Result#cmd_tuples
New Samples:
- Add an example of the nicer #copy_data way of doing `COPY`.

==== scout ====
Version update (0.2.1+20180813.59519f8 -> 0.2.1+20180914.017a078)
Subpackages: command-not-found

- Update to version 0.2.1+20180914.017a078:
* Avoid running command-not-found with python2 (boo#1108565)

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Fix wayland session start if fish is used as shell:
* 0001-Revert-Adds-sourcing-of-etc-profile-to-fish.patch
- Rewrite sddm-relaxed-auth.diff as sddm-relaxed-auth.patch:
* Set XAUTHLOCALHOSTNAME only where necessary
* Also set it for the Greeter session (boo#1091784)

==== serd ====

- Use -std=gnu99 to fix compilation of bogus C code

==== slang ====
Subpackages: libslang2 slang-slsh

- overflow.patch: fix overflow checks not to depend on undefined behaviour

==== solid ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* solid/udisks2: Add support for categorized logging
* [Windows Device] Show device label only if there is one
* Force reevaluation of Predicates if interfaces are removed

==== sonnet ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* hunspell: Restore build with hunspell <=v1.5.0
* Include hunspell headers as system includes
* Fix a typo
- Dropped patches, superseded by upstream changes:
* Fix_Leap_42_3_build.patch

==== spamassassin ====
Version update (3.4.1 -> 3.4.2)
Subpackages: perl-Mail-SpamAssassin

- update spamassassin to 3.4.2
* There are four new plugins (disabled by default)
HashBL - interface to The Email Blocklist (EBL)
ResourceLimits - assure your spamd child processes do not exceed
specified CPU or memory limit
FromNameSpoof - detection of the From:name field being used to
mislead
Phishing - finds uris used in phishing campaigns detected by
OpenPhish (https://openphish.com) or PhishTank
(https://phishtank.com) feeds
* For security reasons SSLv3 support has been removed from spamc(1).
* Four CVE security bug fixes are included in this release for
PDFInfo.pm and the SA core: CVE-2017-15705, CVE-2016-1238,
CVE-2018-11780 & CVE-2018-11781.
* In sa-update script, optional support for SHA-256 / SHA-512 in
addition to or instead of SHA1 has been added for better validation
of rules.
* GeoIP2 support has been added to RelayCountry and URILocalBL plugins
due to GeoIP legacy API deprecations.
* several new or enhanced configuration options
- update spampd to 2.51
* Replace IO::Socket::INET with IO::Socket::IP for IPv6 support
* Unix ports (ability to listen on UNIX sockets)
* Add X-Envelope-* headers before Received
* Add /usr/local/bin and /usr/local/sbin to PATH
* Add --setsid option to start server with setsid if running in
background
- Removed patches (are now in upstream):
* 0001-bug-7361-Allow-building-against-OpenSSL-1.1.0.patch
* 0001-Fix-bug-7367-Don-t-assume-cwd-.-is-in-INC-it-may-be-.patch
* DNS-resolver-recursion-desired-not-set.patch
* spamassassin-dont_use_SSLv3_methods.patch
* spampd-2.42_git_20170226.patch
* Unescaped_left_brace_in_regex_is_deprecated.patch
- Revert incompatibility-with-NET-DNS.patch (this patch attempts to
fix a problem that was already solved by bsc#1059210)
- bsc#1107765 - spamassassin: incompatibility with Net::DNS >= 1.01
- Add upstream patch:
incompatibility-with-NET-DNS.patch
- bsc#1069831 Running sa-update from spamassassin gives warning
about deprecated regex
o remove deprecated-regex.patch and apply upstream patch:
Unescaped_left_brace_in_regex_is_deprecated.patch
This patch also fixes the bug PerMsgStatus Warning
https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7196

==== spice ====
Version update (0.14.0 -> 0.14.1)

- Upstream disabled support for the celt051 audio codec by default,
do likewise in the spec
- Note updated 0.14.1 build dependencies in the spec:
* OpenSSL 1.0.0 or newer is now required
* glib 2.32 required
- add upstream signing key and verify source signature
- Update to v0.14.1 stable release
The announcement email describes this release as follows:
The main change in this release is the addition of a new protocol
extension in order to support streaming the remote display as a
video stream rather than going through the QXL protocol. Together
with spice-streaming-agent, and/or with more work on the qemu/
spice-server side, this should allow streaming of 3D accelerated
VMs in the future. At this point, this part of spice-server is
still a work in progress (multi-monitor support and various
features are missing).
* avoid performance issues on Windows 10 KVM guests (boo#1109044)
* add new org.spice-space.stream.0 channel used for passing an
encoded video stream from the guest to the client
* add support for TCP_CORK to reduce the amount of packets that
we send
* fix CVE-2018-10873 (maintainer note: we already carried fix)
* fix cursor related migration crash
* fix regression causing sound recording to be muted after client
disconnection/reconnection (introduced in 0.13.90)
* fix regression in corner cases where images could be sent
uncompressed when they used to be compressed with QUIC
* disable TLS 1.0 support
* CELT 0.5.1 support is now disabled by default. If celt051-devel
is installed at build-time, --enable-celt051/--disable-celt051
must be explicitly specified
* drop support for unsupported OpenSSL version. OpenSSL 1.0.0 or
newer is now required
* bumped minimum required glib version to 2.32
* endianness fixes
* (small) leak fixes
* usual round of code cleanups
* not directly related to this release, but the upstream git
repository is now hosted on gitlab.freedesktop.org
- Removed patches:
bb15d481-Fix-flexible-array-buffer-overflow.patch

==== sratom ====

- Use -std=gnu99 to fix compilation of bogus C code

==== sudo ====
Version update (1.8.25 -> 1.8.25p1)

- fix permissions for /var/lib/sudo and /var/lib/sudo/ts
[bsc#1097643]
- Update to 1.8.25p1
* Fixed a bug introduced in sudo 1.8.25 that caused a crash on
systems that have the poll() function but not the ppoll()
function

==== sushi ====
Version update (3.28.3 -> 3.30.0)
Subpackages: sushi-lang

- Update to version 3.30.0:
+ Fix miscellaneous warnings.
+ Rename service file to match owned bus name.
- Use autosetup and make_build macros.

==== syndication ====
Version update (18.08.1 -> 5.50.0)

- Fix RPM groups.
- Update to 5.50.0 (now part of KDE Frameworks 5)
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 18.08.1:
* Upgrade dependency
* Enable release of syndication
* Adapt to KF5 versioning
* Normalize line breaks to fix unit tests on Windows
* Sync maintainer field with Mainpage.dox
* Widgets are only needed for tests
* Update metainfo.yaml for the KF5 move
* Cleanup test dependencies
* Adjust file layout to be KF5-compliant

==== syntax-highlighting ====
Version update (5.49.0 -> 5.50.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* Too many changes to list here

==== threadweaver ====
Version update (5.49.0 -> 5.50.0)

- Update to 5.50.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.50.0.php
- Changes since 5.49.0:
* None

==== tigervnc ====

- Changed "openssl" requirement to "openssl(cli)"
* (bsc#1101470)

==== valgrind ====

- valgrind truncates powerpc timebase to 32-bits (bsc#1109589).
Fix-access-to-time-base-register-to-return-64-bits.patch
- valgrind.xen.patch: refresh

==== virglrenderer ====
Version update (0.6.0 -> 0.7.0)

- Update package to 0.7.0
- Brings the renderer up to GL4.3/GLES3.1 capability and most of GLES3.2
- Make EGL optional at configure time
- The following patches will be removed:
0001-737c3350-renderer-fix-memory-leak-in-vertex-elements-state-cr.patch
0002-1fdafd62-vrend-Increase-VREND_MAX_CTX-to-64.patch
They are included in 0.7.0

==== wicked ====
Version update (0.6.48 -> 0.6.49)
Subpackages: libwicked-0-6 wicked-service

- version 0.6.49
- dhcp6: fix to properly decline dynamic addresses
- extensions: do not use /etc/HOSTNAME artifact (bsc#972463)
- ethtool: call offload ioctl if requested by offload name,
e.g. tso has been splitted into several features and the
old STSO offload ioctl sets multiple features at once.
- ethtool: add missing pause support (bsc#1102871)
- dhcp6: refresh info using rfc4242 info-refresh-time
- dhcp6: add ia and ia addr list search utilities, improve
status utils and use timeval struct in ia acquired times
- dhcp6: restart on NotOnLink status request reply
- ifcfg: show unknown/invalid bootproto as error
- dhcp6: Fix server preference and weight option behaviour
- dhcp6: retrigger duplicate detection on all address updates
- man: add ifcfg-lo.5 manual page
- man: add missing documentation for DHCLIENT6_CLIENT_ID
- man: improved create-cid docs in wicked-config(5) (bsc#1084527)

==== wpa_supplicant ====
Subpackages: wpa_supplicant-gui

- Enabled PWD as EAP method. This allows for password-based authentication,
which is easier to setup than most of the other methods, and is used by the
Eduroam network (bsc#1109209).

==== xf86-video-intel ====
Version update (2.99.917+git781.c8990575 -> 2.99.917+git8674.25c9a2fcc)

- Update to 2.99.917+git8674.25c9a2fcc: includes many SNA bugfixes.

==== xorg-docs ====

- reproducable_build.patch (boo#1110020)

==== zsh ====

- Unbreak Leap 42.3 compilation

==== zypper ====
Version update (1.14.8 -> 1.14.11)
Subpackages: zypper-aptitude zypper-log

- Allow repo commands on transactional-server (bsc#1108999)
- BuildRequires: libzypp-devel >= 17.7.0 (dropped type application)
- Unite askUserToAccept*Key report callback (fixes #196)
- version 1.14.11
- Always set error status if any nr of unknown repositories are
passed to lr and ref (bsc#1093103)
- version 1.14.10
- Notify user about unsupported rpm V3 keys in an old rpm database
(bsc#1096217)
- man: Remove links to missing metadata section (fixes #140)
- Detect read only filesystem on system modifying operations
(fixes #199)
- Use %license (bsc#1082318)
- Handle repo aliases containing multiple ':' in the PackageArgs
parser (bsc #1041178)
- BuildRequires: libzypp-devel >= 17.6.3
- version 1.14.9


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages