Mailinglist Archive: opensuse-factory (226 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180914 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180914

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
akonadi-contact (18.08.0 -> 18.08.1)
akonadi-mime (18.08.0 -> 18.08.1)
akonadi-notes (18.08.0 -> 18.08.1)
akonadi-search (18.08.0 -> 18.08.1)
akonadi-server (18.08.0 -> 18.08.1)
ark (18.08.0 -> 18.08.1)
baloo5-widgets (18.08.0 -> 18.08.1)
bluedevil5 (5.13.4 -> 5.13.5)
breeze (5.13.4 -> 5.13.5)
breeze-gtk (5.13.4 -> 5.13.5)
breeze4-style (5.13.4 -> 5.13.5)
discover (5.13.4 -> 5.13.5)
dolphin (18.08.0 -> 18.08.1)
dragonplayer (18.08.0 -> 18.08.1)
drkonqi5 (5.13.4 -> 5.13.5)
firewalld
flatpak-builder (0.10.10 -> 1.0.0)
gnome-photos (3.28.0 -> 3.28.1)
grantleetheme (18.08.0 -> 18.08.1)
gsettings-desktop-schemas (3.28.0 -> 3.28.1)
gwenview5 (18.08.0 -> 18.08.1)
iproute2 (4.17 -> 4.18)
kaccounts-integration (18.08.0 -> 18.08.1)
kaccounts-providers (18.08.0 -> 18.08.1)
kactivitymanagerd (5.13.4 -> 5.13.5)
kamera (18.08.0 -> 18.08.1)
kate (18.08.0 -> 18.08.1)
kcalc (18.08.0 -> 18.08.1)
kcalcore (18.08.0 -> 18.08.1)
kcharselect (18.08.0 -> 18.08.1)
kcm_sddm (5.13.4 -> 5.13.5)
kcolorchooser (18.08.0 -> 18.08.1)
kcontacts (18.08.0 -> 18.08.1)
kdav (18.08.0 -> 18.08.1)
kde-cli-tools5 (5.13.4 -> 5.13.5)
kde-gtk-config5 (5.13.4 -> 5.13.5)
kde-user-manager (5.13.4 -> 5.13.5)
kdenetwork4-filesharing (18.08.0 -> 18.08.1)
kdialog (18.08.0 -> 18.08.1)
kgamma5 (5.13.4 -> 5.13.5)
khelpcenter5 (18.08.0 -> 18.08.1)
khotkeys5 (5.13.4 -> 5.13.5)
kinfocenter5 (5.13.4 -> 5.13.5)
kio-extras5 (18.08.0 -> 18.08.1)
kio_audiocd (18.08.0 -> 18.08.1)
kitinerary (18.08.0 -> 18.08.1)
kldap (18.08.0 -> 18.08.1)
kmag (18.08.0 -> 18.08.1)
kmailtransport (18.08.0 -> 18.08.1)
kmbox (18.08.0 -> 18.08.1)
kmenuedit5 (5.13.4 -> 5.13.5)
kmime (18.08.0 -> 18.08.1)
kmousetool (18.08.0 -> 18.08.1)
kompare (18.08.0 -> 18.08.1)
konsole (18.08.0 -> 18.08.1)
kontactinterface (18.08.0 -> 18.08.1)
kopete (18.08.0 -> 18.08.1)
kpimtextedit (18.08.0 -> 18.08.1)
kpkpass (18.08.0 -> 18.08.1)
kruler (18.08.0 -> 18.08.1)
kscreen5 (5.13.4 -> 5.13.5)
kscreenlocker (5.13.4 -> 5.13.5)
ksmtp (18.08.0 -> 18.08.1)
ksshaskpass5 (5.13.4 -> 5.13.5)
ksysguard5 (5.13.4 -> 5.13.5)
kwalletmanager5 (18.08.0 -> 18.08.1)
kwayland-integration (5.13.4 -> 5.13.5)
kwin5 (5.13.4 -> 5.13.5)
libkcddb (18.08.0 -> 18.08.1)
libkcompactdisc (18.08.0 -> 18.08.1)
libkdcraw (18.08.0 -> 18.08.1)
libkdecoration2 (5.13.4 -> 5.13.5)
libkdepim (18.08.0 -> 18.08.1)
libkexiv2 (18.08.0 -> 18.08.1)
libkgapi (18.08.0 -> 18.08.1)
libkipi (18.08.0 -> 18.08.1)
libkleo (18.08.0 -> 18.08.1)
libkomparediff2 (18.08.0 -> 18.08.1)
libksane (18.08.0 -> 18.08.1)
libkscreen2 (5.13.4 -> 5.13.5)
libksysguard5 (5.13.4 -> 5.13.5)
librsvg (2.42.6 -> 2.44.2)
libzypp (17.6.2 -> 17.7.0)
mailimporter (18.08.0 -> 18.08.1)
makedumpfile
milou5 (5.13.4 -> 5.13.5)
mobipocket (18.08.0 -> 18.08.1)
okular (18.08.0 -> 18.08.1)
openafs (1.8.1 -> 1.8.2)
oxygen5 (5.13.4 -> 5.13.5)
patterns-kde
plasma-nm5 (5.13.4 -> 5.13.5)
plasma5-addons (5.13.4 -> 5.13.5)
plasma5-desktop (5.13.4 -> 5.13.5)
plasma5-integration (5.13.4 -> 5.13.5)
plasma5-openSUSE (15.0~git20180504T125857~b35c1c4 ->
15.0~git20180827T140000~c0d552e)
plasma5-pa (5.13.4 -> 5.13.5)
plasma5-workspace (5.13.4 -> 5.13.5)
polkit-kde-agent-5 (5.13.4 -> 5.13.5)
powerdevil5 (5.13.4 -> 5.13.5)
python-boto3 (1.7.75 -> 1.8.1)
python-botocore (1.10.75 -> 1.11.1)
signon-plugin-oauth2
soundtouch
spectacle (18.08.0 -> 18.08.1)
sudo (1.8.24 -> 1.8.25)
syndication (18.08.0 -> 18.08.1)
systemsettings5 (5.13.4 -> 5.13.5)

=== Details ===

==== akonadi-contact ====
Version update (18.08.0 -> 18.08.1)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* don't install it
* Remvoe it

==== akonadi-mime ====
Version update (18.08.0 -> 18.08.1)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== akonadi-notes ====
Version update (18.08.0 -> 18.08.1)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== akonadi-search ====
Version update (18.08.0 -> 18.08.1)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Fix categories description

==== akonadi-server ====
Version update (18.08.0 -> 18.08.1)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Attempt to mitigate trx deadlocks with SELECT ... FOR UPDATE
* Fix crash when NotificationCollector does not have Connection (kde#397239)
* Akonadi: forget about jobtracker if akonadiconsole went away
* Akonadi protocol: an invalid response is still a response.
* Use nullptr to fix gcc7 warning
* JobTracker: publish all jobs in the session when first connecting
* Debug output: show which collection we're syncing.
* fsck output: print out collection ID as well, for items with no RID
* Disable remote logging for inside Akonadi Console process
* Split out search-related debug output into own category.
- Removed patches, now upstream:
* Fix-crash-when-NotificationCollector-does-not-have-Connection.patch

==== ark ====
Version update (18.08.0 -> 18.08.1)
Subpackages: ark-lang libkerfuffle18

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Fix bzip main page

==== baloo5-widgets ====
Version update (18.08.0 -> 18.08.1)
Subpackages: baloo5-widgets-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== bluedevil5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: bluedevil5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== breeze ====
Version update (5.13.4 -> 5.13.5)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== breeze-gtk ====
Version update (5.13.4 -> 5.13.5)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* Fix scrollbars in LibreOffice (kde#389709)
* [kconf_update] Add "gtk-primary-button-warps-slider=0" to generated GTK3
config (kde#379773)

==== breeze4-style ====
Version update (5.13.4 -> 5.13.5)

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== discover ====
Version update (5.13.4 -> 5.13.5)
Subpackages: discover-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* Don't try to trigger an empty transaction (kde#397759)
* PK: wait until we have fetched the packages that dont' come from appstream
(kde#397192)
* Fix navigation after search (kde#391931)
* Remove wrong assert

==== dolphin ====
Version update (18.08.0 -> 18.08.1)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Pretty-print "creationtime" role

==== dragonplayer ====
Version update (18.08.0 -> 18.08.1)
Subpackages: dragonplayer-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== drkonqi5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: drkonqi5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== firewalld ====
Subpackages: firewall-macros firewalld-lang python3-firewall

- Add firewalld-fix-firewalld-config-crash.patch: set
nm_get_zone_of_connection to return 'None' instead of 'False' for
automatically generated connections to avoid firewall-config
crashes. Patch provided by upstream (boo#1106319,
gh#firewalld/firewalld#370).

==== flatpak-builder ====
Version update (0.10.10 -> 1.0.0)

- Update to version 1.0.0:
+ Respect no-parallel-make with ninja.
+ Fixed regression in data: uris.
+ Warn about deprecated cmake property.
+ Make X-Flatpak-RenamedFrom a list.
+ Fix handling of mirror uris with no terminating slash.
+ Take arch into account for --skip-if-unchanged.
+ Fix --run when run inside a flatpak sandbox.
+ Ensure GIT commiter env var is set when applying git patches.
+ Keep x-* properties in the manifest when creating
manifest.json.
+ New property paths in patch source to apply multiple patches.
- Update to version 0.99.3:
+ Add X-Flatpak-RenamedFrom key to renamed desktop files.
+ Set FLATPAK_BUILDER_BUILDDIR when building module.
+ Handle large downloads better.
+ Make p2p code non-optional.
- Changes from version 0.99.2:
+ Fix --install not working due to asking for confirmation.
+ Fix builds with latest libsoup.
+ New option git-init for archives.
+ New option use-git-am for patches.
- Changes from version 0.99.1:
+ New libdir build option.
+ Support loading default options from sdk.
+ Add support for overriding c/cpp/ld/etc flags in a module.
+ Now uses libcurl to download things instead of soup, which
means we now support ftp urls.
+ Don't prune build caches when building with
- -{export,finish}-only.
+ rename-desktop-file now handles launchables in the appdata.
+ Archive sources support dest-filename.
+ Archive and file sources now support mirror-urls to list extra
urls in case of network problems.
- Add pkgconfig(libcurl) BuildRequires: New dependency.
- Add "BuildRequires pkgconfig(yaml-0.1)" in flatpak-builder.spec
to enable yaml manifest file support. This is needed to build
flatpaks when flatpak manifest files are written in yaml (instead
of json).

==== gnome-photos ====
Version update (3.28.0 -> 3.28.1)
Subpackages: gnome-photos-lang gnome-shell-search-provider-gnome-photos

- Update to version 3.28.1:
+ Bugs fixed: tests: Update for renamed application ID
(glgo#GNOME/gnome-photos#100).
+ Updated translations.
- Drop gnome-photos-export-unbreak-empty-trash-button.patch: Fixed
upstream.

==== grantleetheme ====
Version update (18.08.0 -> 18.08.1)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== gsettings-desktop-schemas ====
Version update (3.28.0 -> 3.28.1)
Subpackages: gsettings-desktop-schemas-lang

- Update to version 3.28.1:
+ Set default background image for screen lock to an existing
one.
+ Updated translations.

==== gwenview5 ====
Version update (18.08.0 -> 18.08.1)
Subpackages: gwenview5-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Fix Crop tool Aspect ratio sometimes randomly preselected
* Improve keyboard handling for focused buttons in Crop and Reduce Red Eye
tools
* Fix Advanced settings crop toolbar sometimes cut off
* Keep the width of the crop spinboxes fixed to avoid wiggling

==== iproute2 ====
Version update (4.17 -> 4.18)

- Update to new upstream release 4.18
* tc: more JSON output
* vxlan: fix ttl inherit behavior
* gre/gre6: allow clearing {,i,o}{key,seq,csum} flags
* bpf: don't offload perf array maps
* tipc: Add support to set and get MTU for UDP bearer
* tc: flower: add support for verbose logging
* rdma: print driver resource attributes
* devlink: introduce support for showing port flavours
* ip address: Add support for address metric
* ip route: print RTA_CACHEINFO if it exists
* ip route get: support for sport, dport and ipproto match
* ip route: Add support for a few routing protocols
* ip address: strengthen check on 'label' input
* ip: add rmnet initial support
* tc: fix batch force option
* ip address: Fix and make consistent label match handling
* ip: add support for seg6local End.BPF action
* lib/namespace: avoid double-mounting /sys
* tc: flush output after each command in batch mode
* ip link: don't stop batch processing
* various command output fixes
* documentation improvements
- rdma-sync-some-IP-headers-with-glibc.patch:
drop (present in 4.18)

==== kaccounts-integration ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kaccounts-providers ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kaccounts-providers-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kactivitymanagerd ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kactivitymanagerd-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* If a query failure is bad enough for an assert, use qCWarning...

==== kamera ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kamera-lang kio_kamera

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kate ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kate-lang kate-plugins

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Explicitly include <QWidgetAction>

==== kcalc ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kcalc-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kcalcore ====
Version update (18.08.0 -> 18.08.1)

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kcharselect ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kcharselect-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kcm_sddm ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kcm_sddm-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kcolorchooser ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kcolorchooser-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kcontacts ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kdav ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kdav-lang libKPimKDAV5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* need for static_cast to fix the test.
* Fix noMatchingMime test.

==== kde-cli-tools5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kde-cli-tools5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kde-gtk-config5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kde-user-manager ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kde-user-manager-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kdenetwork4-filesharing ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kdenetwork4-filesharing-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kdialog ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kdialog-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kgamma5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kgamma5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== khelpcenter5 ====
Version update (18.08.0 -> 18.08.1)
Subpackages: khelpcenter5-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== khotkeys5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: khotkeys5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kinfocenter5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kinfocenter5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kio-extras5 ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kio-extras5-lang libkioarchive5

- Disable WebEngine BuildReq and add %license
- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Add license text of GPL 2.0, LGPL 2.0 and LGPL 2.1
* Avoid a kio-mtp crash when trying to add a blocked device to the device
cache

==== kio_audiocd ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kio_audiocd-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kitinerary ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKPimItinerary5 libKPimItinerary5-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Run the generic IATA BCBP extractor also for Vueling
* Make the pdfdocumenttest pass without Poppler

==== kldap ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kldap-lang libKF5Ldap5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kmag ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kmag-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kmailtransport ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Fix error
* Fix Bug 398036 - Password for sending mails not used when specified via
password prompt (kde#398036)
* Disable password lineedit when we don't store password
* Make sure to remove password stored
* Only recommend XOAUTH2 method on Gmail

==== kmbox ====
Version update (18.08.0 -> 18.08.1)

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kmenuedit5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kmenuedit5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kmime ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kmime-lang libKF5Mime5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kmousetool ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kmousetool-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kompare ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kompare-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== konsole ====
Version update (18.08.0 -> 18.08.1)
Subpackages: konsole-part konsole-part-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Scope the glib hack to only < Qt5.11.2 versions

==== kontactinterface ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kopete ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kopete-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kpimtextedit ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kpkpass ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKPimPkPass5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kruler ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kruler-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kscreen5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kscreen5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kscreenlocker ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* Prevent paste in screen locker (kde#388049)
* Load QtQuickSettings for software rendering

==== ksmtp ====
Version update (18.08.0 -> 18.08.1)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== ksshaskpass5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: ksshaskpass5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== ksysguard5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: ksysguard5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kwalletmanager5 ====
Version update (18.08.0 -> 18.08.1)
Subpackages: kwalletmanager5-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== kwayland-integration ====
Version update (5.13.4 -> 5.13.5)

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== kwin5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: kwin5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* Avoid global static for effects
* [effects] Use more effectData() in BuiltInEffects
* [kcmkwin] Use QtQuick.Controls 2.0 for Label and TextField (kde#366451)
* Update kwindecoration docbook

==== libkcddb ====
Version update (18.08.0 -> 18.08.1)

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== libkcompactdisc ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== libkdcraw ====
Version update (18.08.0 -> 18.08.1)

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Fix build with libraw 0.19 (kde#397345)
- Removed patches, now upstream:
* fix-build-with-libraw-0.19.patch

==== libkdecoration2 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: libkdecorations2-5 libkdecorations2-5-lang libkdecorations2private6

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== libkdepim ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Remove None mode, it was unused.
* Followup fix: only set mWasLastShown if we're actually toggling.
* Fix inconsistent state of the button to show/hide progress information.

==== libkexiv2 ====
Version update (18.08.0 -> 18.08.1)

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== libkgapi ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2-3

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* gmail auth: return proper HTTP response to avoid qwebengine error
* Fix typos

==== libkipi ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== libkleo ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== libkomparediff2 ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== libksane ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKF5Sane5 libksane-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== libkscreen2 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== libksysguard5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: libksysguard5-helper libksysguard5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== librsvg ====
Version update (2.42.6 -> 2.44.2)
Subpackages: gdk-pixbuf-loader-rsvg librsvg-2-2 rsvg-thumbnailer
typelib-1_0-Rsvg-2_0

- Append Apache-2.0 and MIT licenses to main package's and
librsvg-2-2 subpackage's License tags to comply with Rust crates,
static linked against LibRSVG, licenses.
- Update to version 2.44.2:
+ Don't leak all the elements at the toplevel
(glgo#GNOME/librsvg#325).
+ Make masking work on big-endian (glgo#GNOME/librsvg#328).
+ Fix library ordering so -Wl,--as-needed works.
- Update to version 2.44.1:
+ Don't panic if trying to render a non-empty SVG with no
elements (glgo#GNOME/librsvg#324).
+ All the elements were being leaked at the toplevel
(glgo#GNOME/librsvg#325).
- Update to version 2.44.0:
+ Librsvg now has minimal logging for debugging by setting the
RSVG_LOG environment variable. See CONTRIBUTING.md for details.
+ Speed improvements for Gaussian blur, SRGB conversions, and
various filters.
+ Fix glgo#GNOME/librsvg#264: The letter-spacing property now
supports "normal" in addition to lengths.
+ Fix glgo#GNOME/librsvg#318: The font-weight property was being
parsed incorrectly.
+ Fix glgo#GNOME/librsvg#323: Don't use 100% "forever" with
malicious SVGs that cause an exponential number of elements to
be instanced through the <use> element. We limit the number of
<use> instances now.
+ Fix glgo#GNOME/librsvg#293: Don't panic when masking an empty
group.
+ Fix glgo#GNOME/librsvg#319: Parse single font-family correctly.
+ Cleanups for the internal representation of elliptical arcs in
paths.
- Update to version 2.43.4:
+ This is an early release to test the effects of threading in
librsvg.
+ The lighting and Gaussian blur filters are now parallelized
with Rayon; they will use all available cores.
- Update to version 2.43.3:
+ Tentative fix: Don't panic if rendering to a non-image Cairo
surface (glgo#GNOME/librsvg#309).
+ Couple of optimizations.
- Update to version 2.43.2:
+ All the filter effects have been ported to Rust.
+ We now require Rust 1.26.
+ We now include Rust debug information even in release builds,
to make it easier to obtain stack traces.
+ Fix glgo#GNOME/librsvg#310: Respect DPI in the font-size
property.
+ Fix: draw the circle/ellipse elements with the same orientation
as the SVG 1.1 test suite; this is relevant for
stroke-dasharray.
+ Refactoring of the drawing code and font sizes.
+ New filters in Rust: feConvolveMatrix, feColorMatrix,
feMorphology, feDisplacementMap, feGaussianBlur,
feDistantLight, feSpotLight, fePointLight, feTile.
+ Updated Rust dependencies.
- Update to version 2.43.1:
+ Test fonts should now work with --enable-installed-tests
(glgo#GNOME/librsvg#259).
+ Don't panic when trying to filter an empty group
(glgo#GNOME/librsvg#277).
+ Don't panic if we try to clip an empty group
(glgo#GNOME/librsvg#292).
+ Fix the feOffset filter's coordinate parsing.
+ Fix linearization of SRGB data in the feComposite filter.
+ Fix CSS cascading in filters.
+ Fix, don't render filters if they are in error.
+ Fixed a couple of memory leaks in the test suite.
+ Filters now support FillPaint and StrokePaint for input.
+ Filters now support the color-interpolation-filters property.
+ The feImage, feBlend, feComponentTransfer filters are now in
Rust.
+ The feOffset filter now supports fractional offsets.
+ The drawing context code is now in Rust.
+ All the style property parsers have been moved to
rust-cssparser.
- Update to version 2.43.0:
+ Fixes:
- feDistantLight and feSpotLight now work again
(glgo#GNOME/librsvg#241).
- feComposite is fixed not to overwrite the source image in
some cases; this fixes drop shadows generated from Inkscape
(glgo#GNOME/librsvg#282).
+ Rust implementation:
- Text, tspan and tref elements;
- Basic styling infrastructure;
- Internals of the drawing infrastructure and bounding-box
computation;
- Element creation from the parsing stage;
- Clipping and Masking.
+ The feComposite filter now operates in linear RGB space, for
better spec compliance (glgo#GNOME/librsvg#275).
+ Filters now compute their bounds to floating-point values,
instead of clipping them to integers.
+ Text rendering improvements.
- Update to version 2.42.7:
+ Fix a denial-of-service condition from exponential explosion of
rendered elements, through nested use of SVG "use" elements in
malicious SVGs. This is similar to the XML "billion laughs
attack" but for SVG instancing (glgo#GNOME/librsvg#323).

==== libzypp ====
Version update (17.6.2 -> 17.7.0)

- Drop type application due to poor metadata support (bsc#1100095,
bsc#1104415)
- version 17.7.0 (2)
- Automatically fetch repository signing key from gpgkey url
(bsc#1088037)
- lsof: use '-K i' if lsof supports it (bsc#1099847,bsc#1036304)
- version 17.6.4 (2)
- Check for not imported keys after multi key import from rpmdb
(bsc#1096217)
- version 17.6.3 (2)

==== mailimporter ====
Version update (18.08.0 -> 18.08.1)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== makedumpfile ====

- Fix %license destination for older distributions.
- Merge SLE12 changelog.
- Patches that were never actually applied to Factory:
* makedumpfile-x86_64-xen-vtop.patch (included in 1.6.2)
* makedumpfile-Fix-elf_info-file_size-if-segment-excluded.patch
(included in 1.6.2)
- makedumpfile-Fix-elf_info-file_size-if-segment-excluded.patch:
elf_info: Fix file_size if segment is excluded (bsc#1068925).
- makedumpfile-x86_64-xen-vtop.patch: Fix the use of Xen physical
and machine addresses (bsc#1014136, bsc#1068694).

==== milou5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: milou5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* Support both QString and QIcon for dragHelper pixmap

==== mobipocket ====
Version update (18.08.0 -> 18.08.1)

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== okular ====
Version update (18.08.0 -> 18.08.1)
Subpackages: okular-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Fix path traversal issue when extracting an .okular file (kde#398096,
boo#1107591, CVE-2018-1000801)
* Fix links being "lost" on save (kde#397373)
* Make sure sorting in the configure backends is always the same
* Fix problem of saving pdf switches from thumbnail view in sidebar to
contents view (kde#389668)

==== openafs ====
Version update (1.8.1 -> 1.8.2)
Subpackages: openafs-client openafs-kmp-default

- Quote "*.c", and avoid unnecessary pass through xargs.
- update to security-release 1.8.2
* fix CVE-2018-16947 (OPENAFS-SA-2018-001)
* fix CVE-2018-16948 (OPENAFS-SA-2018-002)
* fix CVE-2018-16949 (OPENAFS-SA-2018-003)
- add retpoline support
- update to version 1.8.1.1
- Remove use_timespec64_for_kernel_4.18.patch. It is now integrated.

==== oxygen5 ====
Version update (5.13.4 -> 5.13.5)

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== patterns-kde ====
Subpackages: patterns-kde-kde patterns-kde-kde_edutainment
patterns-kde-kde_games patterns-kde-kde_ide patterns-kde-kde_imaging
patterns-kde-kde_internet patterns-kde-kde_multimedia patterns-kde-kde_office
patterns-kde-kde_pim patterns-kde-kde_plasma patterns-kde-kde_utilities
patterns-kde-kde_utilities_opt patterns-kde-kde_yast

- Work around missing PIM icon (boo#1107103)
- Use new pattern-kde icons instead of -kde4

==== plasma-nm5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* Fix a text label in the password dialog
* Add additional checks for device existence (kde#396957)

==== plasma5-addons ====
Version update (5.13.4 -> 5.13.5)
Subpackages: plasma5-addons-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* [POTD] Actually update the image every day (kde#397914)

==== plasma5-desktop ====
Version update (5.13.4 -> 5.13.5)
Subpackages: plasma5-desktop-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* [plasma-changeicons] Call sync() after writing
* Revert "Fix bad model hygiene in Positioner::move()"
* Kicker: Reset re-used menu width to default one
* [Style KCM] Use "configure" icon (kde#397358)
* fontinst quits after KJob is done
(kde#379524,kde#379324,kde#349673,kde#361960,kde#392267)
* [Desktop Toolbox] Emit contextualActionsAboutToShow before opening
(kde#384862)
* Fix bad model hygiene in Positioner::move() (kde#396666)
- Remove patches, now upstream:
* fontinst-quits-after-KJob-is-done.patch

==== plasma5-integration ====
Version update (5.13.4 -> 5.13.5)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* Fix QFileDialog not remembering the last visited directory.
* File Dialog: fix testSelectUrl() again, i.e. selectUrl() should set the
directory too

==== plasma5-openSUSE ====
Version update (15.0~git20180504T125857~b35c1c4 ->
15.0~git20180827T140000~c0d552e)
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.13.5
- Update to version 15.0~git20180827T140000~c0d552e:
* Remove explicit list of enabled thumbnail plugins

==== plasma5-pa ====
Version update (5.13.4 -> 5.13.5)
Subpackages: plasma5-pa-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== plasma5-workspace ====
Version update (5.13.4 -> 5.13.5)
Subpackages: gmenudbusmenuproxy plasma5-session plasma5-session-wayland
plasma5-workspace-lang plasma5-workspace-libs xembedsniproxy

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* [MPRIS Data Engine] Avoid blocking calls in media shortcuts handling
(kde#397685)
* [Solid Device Engine] Don't update free space info for inaccessible storage
devices
* [Notifications Engine] Guard "this" (kde#397105)
* [Service Runner] Look up relative entryPaths
* [Desktop Scripting ConfigGroup] Add more nullptr checks
* Use 1 instead of true for gtk-shell-shows-menubar (kde#397087)

==== polkit-kde-agent-5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== powerdevil5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: powerdevil5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None

==== python-boto3 ====
Version update (1.7.75 -> 1.8.1)

- Version update to 1.8.1
* api-change:``glue``: [``botocore``] Update glue client to latest version
- from version 1.8.0
* api-change:``events``: [``botocore``] Update events client to latest version
* api-change:``cognito-idp``: [``botocore``] Update cognito-idp client to
latest version
* feature:urllib3: [``botocore``] The vendored version of requests and
urllib3 are no longer being used and botocore now has a direct dependency on
newer versions of upstream urllib3.
- from version 1.7.84
* api-change:``iot``: [``botocore``] Update iot client to latest version
* api-change:``rekognition``: [``botocore``] Update rekognition client to
latest version
* api-change:``lex-models``: [``botocore``] Update lex-models client to
latest version
* api-change:``iotanalytics``: [``botocore``] Update iotanalytics client to
latest version
* api-change:``medialive``: [``botocore``] Update medialive client to latest
version
- from version 1.7.83
* api-change:``snowball``: [``botocore``] Update snowball client to latest
version
- from version 1.7.82
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
* api-change:``dlm``: [``botocore``] Update dlm client to latest version
* api-change:``rds``: [``botocore``] Update rds client to latest version
* api-change:``elasticbeanstalk``: [``botocore``] Update elasticbeanstalk
client to latest version
- from version 1.7.81
* api-change:``mediaconvert``: [``botocore``] Update mediaconvert client to
latest version
* api-change:``dynamodb``: [``botocore``] Update dynamodb client to latest
version
- from version 1.7.80
* api-change:``dax``: [``botocore``] Update dax client to latest version
* api-change:``secretsmanager``: [``botocore``] Update secretsmanager client
to latest version
* api-change:``sagemaker``: [``botocore``] Update sagemaker client to latest
version
- from version 1.7.79
* api-change:``discovery``: [``botocore``] Update discovery client to latest
version
* api-change:``ssm``: [``botocore``] Update ssm client to latest version
* api-change:``ec2``: [``botocore``] Update ec2 client to latest version
* api-change:``redshift``: [``botocore``] Update redshift client to latest
version
* api-change:``mediaconvert``: [``botocore``] Update mediaconvert client to
latest version
- from version 1.7.78
* api-change:``devicefarm``: [``botocore``] Update devicefarm client to
latest version
- from version 1.7.77
* api-change:``es``: [``botocore``] Update es client to latest version
* api-change:``autoscaling``: [``botocore``] Update autoscaling client to
latest version
* api-change:``cloudfront``: [``botocore``] Update cloudfront client to
latest version
- from version 1.7.76
* api-change:``sagemaker``: [``botocore``] Update sagemaker client to latest
version
- Replace vendored version of six from botocore with upstream version
- Update Requires in spec file from setup.py

==== python-botocore ====
Version update (1.10.75 -> 1.11.1)

- Version update to 1.11.1 (bsc#1095041)
* api-change:``glue``: Update glue client to latest version
- from version 1.11.0
* api-change:``events``: Update events client to latest version
* api-change:``cognito-idp``: Update cognito-idp client to latest version
* feature:urllib3: The vendored version of requests and urllib3 are no longer
being used and botocore now has a direct dependency on newer versions of
upstream urllib3.
- from version 1.10.84
* api-change:``iot``: Update iot client to latest version
* api-change:``rekognition``: Update rekognition client to latest version
* api-change:``lex-models``: Update lex-models client to latest version
* api-change:``iotanalytics``: Update iotanalytics client to latest version
* api-change:``medialive``: Update medialive client to latest version
- from version 1.10.83
* api-change:``snowball``: Update snowball client to latest version
- from version 1.10.82
* api-change:``ec2``: Update ec2 client to latest version
* api-change:``dlm``: Update dlm client to latest version
* api-change:``rds``: Update rds client to latest version
* api-change:``elasticbeanstalk``: Update elasticbeanstalk client to latest
version
- from version 1.10.81
* api-change:``mediaconvert``: Update mediaconvert client to latest version
* api-change:``dynamodb``: Update dynamodb client to latest version
- from version 1.10.80
* api-change:``dax``: Update dax client to latest version
* api-change:``secretsmanager``: Update secretsmanager client to latest
version
* api-change:``sagemaker``: Update sagemaker client to latest version
- from version 1.10.79
* api-change:``discovery``: Update discovery client to latest version
* api-change:``ssm``: Update ssm client to latest version
* api-change:``ec2``: Update ec2 client to latest version
* api-change:``redshift``: Update redshift client to latest version
* api-change:``mediaconvert``: Update mediaconvert client to latest version
- from version 1.10.78
* api-change:``devicefarm``: Update devicefarm client to latest version
- from version 1.10.77
* api-change:``es``: Update es client to latest version
* api-change:``autoscaling``: Update autoscaling client to latest version
* api-change:``cloudfront``: Update cloudfront client to latest version
- from version 1.10.76
* api-change:``sagemaker``: Update sagemaker client to latest version
- Drop obsolete patches
+ skip_test_on15.patch
- Refresh patches for new version
+ hide_py_pckgmgmt.patch
- Update BuildRequires in spec file from setup.py
- Update sed expression to patch out vendored modules

==== signon-plugin-oauth2 ====

- Don't install examples and tests

==== soundtouch ====

- bsc #1103676: CVE-2018-1000223: soundtouch: Heap-based buffer overflow
added patch fix-buffer-overflow.patch

==== spectacle ====
Version update (18.08.0 -> 18.08.1)
Subpackages: spectacle-lang

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* Fix missing notification title found by -Wswitch-enum

==== sudo ====
Version update (1.8.24 -> 1.8.25)

- Update to 1.8.25
* I/O log timing file entries now use a monotonic timer and
include nanosecond precision
* when sudo runs a command in a pseudo-tty, the slave device is
now closed in the main process immediately after starting the
monitor process
* the testsudoers utility now supports querying an LDIF-format
policy

==== syndication ====
Version update (18.08.0 -> 18.08.1)

- Update to 18.08.1
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.1.php
- Changes since 18.08.0:
* None

==== systemsettings5 ====
Version update (5.13.4 -> 5.13.5)
Subpackages: systemsettings5-lang

- Update to 5.13.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.5.php
- Changes since 5.13.4:
* None


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups