Mailinglist Archive: opensuse-factory (383 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180827 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180827

Please do not reply to this email to report issues, rather file a bug
on bugzilla.opensuse.org. For more information on filing bugs please
see https://en.opensuse.org/openSUSE:Submitting_bug_reports

Packages changed:
SDL_gfx (2.0.25 -> 2.0.26)
abcde (2.8.1 -> 2.9.2)
akonadi-calendar (18.04.3 -> 18.08.0)
akonadi-calendar-tools (18.04.3 -> 18.08.0)
akonadi-contact (18.04.3 -> 18.08.0)
akonadi-import-wizard (18.04.3 -> 18.08.0)
akonadi-mime (18.04.3 -> 18.08.0)
akonadi-notes (18.04.3 -> 18.08.0)
akonadi-search (18.04.3 -> 18.08.0)
akonadi-server (18.04.3 -> 18.08.0)
akregator (18.04.3 -> 18.08.0)
analitza (18.04.3 -> 18.08.0)
apparmor
ark (18.04.3 -> 18.08.0)
attica-qt5 (5.48.0 -> 5.49.0)
autoconf
autoconf-el
baloo5 (5.48.0 -> 5.49.0)
baloo5-widgets (18.04.3 -> 18.08.0)
blinken (18.04.3 -> 18.08.0)
bluez-qt (5.48.0 -> 5.49.0)
bovo (18.04.3 -> 18.08.0)
breeze5-icons (5.48.0 -> 5.49.0)
build (20180629 -> 20180816)
calendarsupport (18.04.3 -> 18.08.0)
cervisia (18.04.3 -> 18.08.0)
dolphin (18.04.3 -> 18.08.0)
dragonplayer (18.04.3 -> 18.08.0)
duplicity (0.7.17 -> 0.7.18)
eventviews (18.04.3 -> 18.08.0)
evolution
ffmpegthumbs (18.04.3 -> 18.08.0)
flatpak (0.11.8.3 -> 0.99.3)
frameworkintegration (5.48.0 -> 5.49.0)
gcc7 (7.3.1+r262243 -> 7.3.1+r263609)
gcc8 (8.1.1+r262873 -> 8.2.1+r263610)
gdb
glib2 (2.56.1 -> 2.56.2)
grantleetheme (18.04.3 -> 18.08.0)
gtk4
gwenview5 (18.04.3 -> 18.08.0)
health-checker
hylafax+ (5.5.9 -> 5.6.0)
incidenceeditor (18.04.3 -> 18.08.0)
isl (0.19 -> 0.20)
juk (18.04.3 -> 18.08.0)
kaccounts-integration (18.04.3 -> 18.08.0)
kaccounts-providers (18.04.3 -> 18.08.0)
kactivities-stats (5.48.0 -> 5.49.0)
kactivities5 (5.48.0 -> 5.49.0)
kaddressbook (18.04.3 -> 18.08.0)
kalarmcal (18.04.3 -> 18.08.0)
kalgebra (18.04.3 -> 18.08.0)
kalzium (18.04.3 -> 18.08.0)
kamera (18.04.3 -> 18.08.0)
kanagram (18.04.3 -> 18.08.0)
kapptemplate (18.04.3 -> 18.08.0)
karchive (5.48.0 -> 5.49.0)
kate (18.04.3 -> 18.08.0)
katomic (18.04.3 -> 18.08.0)
kauth (5.48.0 -> 5.49.0)
kblackbox (18.04.3 -> 18.08.0)
kblocks (18.04.3 -> 18.08.0)
kbookmarks (5.48.0 -> 5.49.0)
kbounce (18.04.3 -> 18.08.0)
kbreakout (18.04.3 -> 18.08.0)
kbruch (18.04.3 -> 18.08.0)
kcachegrind (18.04.3 -> 18.08.0)
kcalc (18.04.3 -> 18.08.0)
kcalcore (18.04.3 -> 18.08.0)
kcalutils (18.04.3 -> 18.08.0)
kcharselect (18.04.3 -> 18.08.0)
kcmutils (5.48.0 -> 5.49.0)
kcodecs (5.48.0 -> 5.49.0)
kcolorchooser (18.04.3 -> 18.08.0)
kcompletion (5.48.0 -> 5.49.0)
kconfig (5.48.0 -> 5.49.0)
kconfigwidgets (5.48.0 -> 5.49.0)
kcontacts (18.04.3 -> 18.08.0)
kcoreaddons (5.48.0 -> 5.49.0)
kcrash (5.48.0 -> 5.49.0)
kcron (18.04.3 -> 18.08.0)
kdav (18.04.3 -> 18.08.0)
kdbusaddons (5.48.0 -> 5.49.0)
kde-print-manager (18.04.3 -> 18.08.0)
kdeclarative (5.48.0 -> 5.49.0)
kded (5.48.0 -> 5.49.0)
kdeedu-data (18.04.3 -> 18.08.0)
kdegraphics-thumbnailers (18.04.3 -> 18.08.0)
kdelibs4support (5.48.0 -> 5.49.0)
kdenetwork4-filesharing (18.04.3 -> 18.08.0)
kdepim-addons (18.04.3 -> 18.08.0)
kdepim-apps-libs (18.04.3 -> 18.08.0)
kdepim-runtime (18.04.3 -> 18.08.0)
kdesu (5.48.0 -> 5.49.0)
kdevelop5 (5.2.3 -> 5.2.4)
kdewebkit (5.48.0 -> 5.49.0)
kdf (18.04.3 -> 18.08.0)
kdialog (18.04.3 -> 18.08.0)
kdiamond (18.04.3 -> 18.08.0)
kdnssd-framework (5.48.0 -> 5.49.0)
kdoctools (5.48.0 -> 5.49.0)
kemoticons (5.48.0 -> 5.49.0)
kernel-source (4.18.0 -> 4.18.5)
kfilemetadata5 (5.48.0 -> 5.49.0)
kgeography (18.04.3 -> 18.08.0)
kget (18.04.3 -> 18.08.0)
kglobalaccel (5.48.0 -> 5.49.0)
kgoldrunner (18.04.3 -> 18.08.0)
kguiaddons (5.48.0 -> 5.49.0)
khangman (18.04.3 -> 18.08.0)
khelpcenter5 (18.04.3 -> 18.08.0)
kholidays (5.48.0 -> 5.49.0)
khtml (5.48.0 -> 5.49.0)
ki18n (5.48.0 -> 5.49.0)
kiconthemes (5.48.0 -> 5.49.0)
kidentitymanagement (18.04.3 -> 18.08.0)
kidletime (5.48.0 -> 5.49.0)
kig (18.04.3 -> 18.08.0)
kimageformats (5.48.0 -> 5.49.0)
kimagemapeditor (18.04.3 -> 18.08.0)
kimap (18.04.3 -> 18.08.0)
kinit (5.48.0 -> 5.49.0)
kio (5.48.0 -> 5.49.0)
kio-extras5 (18.04.3 -> 18.08.0)
kio_audiocd (18.04.3 -> 18.08.0)
kirigami2 (5.48.0 -> 5.49.0)
kiriki (18.04.3 -> 18.08.0)
kitemmodels (5.48.0 -> 5.49.0)
kitemviews (5.48.0 -> 5.49.0)
kiten (18.04.3 -> 18.08.0)
kjobwidgets (5.48.0 -> 5.49.0)
kjs (5.48.0 -> 5.49.0)
kjsembed (5.48.0 -> 5.49.0)
kjumpingcube (18.04.3 -> 18.08.0)
kldap (18.04.3 -> 18.08.0)
kleopatra (18.04.3 -> 18.08.0)
klettres (18.04.3 -> 18.08.0)
klines (18.04.3 -> 18.08.0)
kmag (18.04.3 -> 18.08.0)
kmahjongg (18.04.3 -> 18.08.0)
kmail (18.04.3 -> 18.08.0)
kmail-account-wizard (18.04.3 -> 18.08.0)
kmailtransport (18.04.3 -> 18.08.0)
kmbox (18.04.3 -> 18.08.0)
kmime (18.04.3 -> 18.08.0)
kmines (18.04.3 -> 18.08.0)
kmousetool (18.04.3 -> 18.08.0)
kmouth (18.04.3 -> 18.08.0)
kmplot (18.04.3 -> 18.08.0)
knavalbattle (18.04.3 -> 18.08.0)
knetwalk (18.04.3 -> 18.08.0)
knewstuff (5.48.0 -> 5.49.0)
knotes (18.04.3 -> 18.08.0)
knotifications (5.48.0 -> 5.49.0)
knotifyconfig (5.48.0 -> 5.49.0)
kolf (18.04.3 -> 18.08.0)
kollision (18.04.3 -> 18.08.0)
kolourpaint (18.04.3 -> 18.08.0)
kompare (18.04.3 -> 18.08.0)
konquest (18.04.3 -> 18.08.0)
konsole (18.04.3 -> 18.08.0)
kontact (18.04.3 -> 18.08.0)
kontactinterface (18.04.3 -> 18.08.0)
kopete (18.04.3 -> 18.08.0)
korganizer (18.04.3 -> 18.08.0)
kpackage (5.48.0 -> 5.49.0)
kparts (5.48.0 -> 5.49.0)
kpat (18.04.3 -> 18.08.0)
kpeople5 (5.48.0 -> 5.49.0)
kpimtextedit (18.04.3 -> 18.08.0)
kplotting (5.48.0 -> 5.49.0)
kpty (5.48.0 -> 5.49.0)
kqtquickcharts (18.04.3 -> 18.08.0)
krdc (18.04.3 -> 18.08.0)
kreversi (18.04.3 -> 18.08.0)
krfb (18.04.3 -> 18.08.0)
kross (5.48.0 -> 5.49.0)
kruler (18.04.3 -> 18.08.0)
krunner (5.48.0 -> 5.49.0)
kservice (5.48.0 -> 5.49.0)
kshisen (18.04.3 -> 18.08.0)
ksirk (18.04.3 -> 18.08.0)
ksmtp (18.04.3 -> 18.08.0)
kspaceduel (18.04.3 -> 18.08.0)
ksquares (18.04.3 -> 18.08.0)
ksudoku (18.04.3 -> 18.08.0)
ksystemlog (18.04.3 -> 18.08.0)
kteatime (18.04.3 -> 18.08.0)
ktexteditor (5.48.0 -> 5.49.0)
ktextwidgets (5.48.0 -> 5.49.0)
ktimer (18.04.3 -> 18.08.0)
ktnef (18.04.3 -> 18.08.0)
ktouch (18.04.3 -> 18.08.0)
ktuberling (18.04.3 -> 18.08.0)
kturtle (18.04.3 -> 18.08.0)
kubrick (18.04.3 -> 18.08.0)
kunitconversion (5.48.0 -> 5.49.0)
kwallet (5.48.0 -> 5.49.0)
kwalletmanager5 (18.04.3 -> 18.08.0)
kwayland (5.48.0 -> 5.49.0)
kwidgetsaddons (5.48.0 -> 5.49.0)
kwindowsystem (5.48.0 -> 5.49.0)
kwordquiz (18.04.3 -> 18.08.0)
kxmlgui (5.48.0 -> 5.49.0)
kxmlrpcclient5 (5.48.0 -> 5.49.0)
ldb (1.3.3 -> 1.3.5)
libKF5ModemManagerQt (5.48.0 -> 5.49.0)
libKF5NetworkManagerQt (5.48.0 -> 5.49.0)
libgravatar (18.04.3 -> 18.08.0)
libkcddb (18.04.3 -> 18.08.0)
libkcompactdisc (18.04.3 -> 18.08.0)
libkdcraw (18.04.3 -> 18.08.0)
libkdegames (18.04.3 -> 18.08.0)
libkdepim (18.04.3 -> 18.08.0)
libkeduvocdocument (18.04.3 -> 18.08.0)
libkexiv2 (18.04.3 -> 18.08.0)
libkgapi (18.04.3 -> 18.08.0)
libkipi (18.04.3 -> 18.08.0)
libkleo (18.04.3 -> 18.08.0)
libkmahjongg (18.04.3 -> 18.08.0)
libkomparediff2 (18.04.3 -> 18.08.0)
libksane (18.04.3 -> 18.08.0)
libksieve (18.04.3 -> 18.08.0)
libqmi (1.20.0 -> 1.20.2)
libsolv (0.6.34 -> 0.6.35)
libvirt
libxcb
libzypp (17.5.2 -> 17.6.2)
lokalize (18.04.3 -> 18.08.0)
lskat (18.04.3 -> 18.08.0)
mailcommon (18.04.3 -> 18.08.0)
mailimporter (18.04.3 -> 18.08.0)
mailman
mbox-importer (18.04.3 -> 18.08.0)
messagelib (18.04.3 -> 18.08.0)
mjpegtools
mlterm (3.8.4 -> 3.8.6)
mobipocket (18.04.3 -> 18.08.0)
okular (18.04.3 -> 18.08.0)
open-vm-tools (10.2.5 -> 10.3.0)
oxygen5-icon-theme (5.48.0 -> 5.49.0)
parley (18.04.3 -> 18.08.0)
perl-Archive-Zip (1.60 -> 1.63)
perl-DBD-ODBC (1.58 -> 1.59)
perl-DateTime (1.49 -> 1.50)
perl-IO-Socket-SSL (2.058 -> 2.059)
perl-Log-Dispatch (2.67 -> 2.68)
perl-Params-ValidationCompiler (0.27 -> 0.30)
perl-Quantum-Superpositions (2.02 -> 2.03)
perl-Test-Simple (1.302138 -> 1.302140)
perl-YAML-LibYAML (0.59 -> 0.72)
pim-data-exporter (18.04.3 -> 18.08.0)
pim-sieve-editor (18.04.3 -> 18.08.0)
pimcommon (18.04.3 -> 18.08.0)
plasma-framework (5.48.0 -> 5.49.0)
prison-qt5 (5.48.0 -> 5.49.0)
publicsuffix (20180719 -> 20180813)
purpose (5.48.0 -> 5.49.0)
python-libvirt-python (4.5.0 -> 4.6.0)
python-pygame (1.9.3 -> 1.9.4)
qqc2-desktop-style (5.48.0 -> 5.49.0)
rubygem-autoprefixer-rails (9.1.2 -> 9.1.3)
rubygem-public_suffix (3.0.2 -> 3.0.3)
rubygem-turbolinks (5.1.1 -> 5.2.0)
rubygem-turbolinks-source (5.1.0 -> 5.2.0)
samba (4.8.2+git.30.690aa93c189 -> 4.8.4+git.37.a7a861d7982)
schily
solid (5.48.0 -> 5.49.0)
sonnet (5.48.0 -> 5.49.0)
spectacle (18.04.3 -> 18.08.0)
step (18.04.3 -> 18.08.0)
stoken (0.81 -> 0.92)
sweeper (18.04.3 -> 18.08.0)
syndication (18.04.3 -> 18.08.0)
syntax-highlighting (5.48.0 -> 5.49.0)
telegram-purple
threadweaver (5.48.0 -> 5.49.0)
transactional-update (2.5 -> 2.6)
umbrello (18.04.3 -> 18.08.0)
wiggle (1.0 -> 1.1)
xmlsec1
xterm (332 -> 335)
zypper (1.14.6 -> 1.14.8)

=== Details ===

==== SDL_gfx ====
Version update (2.0.25 -> 2.0.26)

- Readd SDL_gfx-devel Provides/Obsoletes, still needed.
- Update to 2.0.26
* Included patch for CMake builds against SDL2
* Fixed bug in rotozoomSurfaceSizeTrig

==== abcde ====
Version update (2.8.1 -> 2.9.2)

- Replace summary line with an actual summary. Fix broken
sentence grammar in description.
- Added use-cddbmethod.patch needed as factory does not provide
perl(MusicBrainz::DiscID)
- Added fix-makefile-version-2.9.2.patch
- Added keyring for verification
- Update to 2.9.2:
* Fix up lookup code to deal with spaces etc. in directory names
* Cope with "stub" releases in Musicbrainz
* Always call glyrc with LC_ALL=C. Thanks to Andreas Vögele for the
report and the suggested fix.
* Add a link to the CDDB data format in the abcde man page.
* More fixups of track number padding. Thanks to John Straw for the
patch.
* Allow for embedding of album art downloaded by the getalbumart
function. Currently this is available for flac (using metaflac),
mp3 (using eyed3), m4a (using AtomicParsley) and
WavPack aka wv (using wvtag).
* Use md5 rather than md5sum under macOS.
* Support added for encoding with
Audio Interchange File Format (AIFF).
* Allow selection of either cddb or musicbrainz from the command line
* Allow for embedding with do_embedalbumart() for single track
encodes when OUTPUTFORMAT and ONETRACKOUTPUTFORMAT are different.
* Experimental support for embedding albumart with ogg files.
* Massive rework of CD lookup code so support multiple sources
better. Thanks to Gabriel Rosenkoetter for his initial idea in this
area, and to Tomasz Goli?ski on irc for initial inspiration on how
this should work better.
There are now 3 different options for CD lookup: cddb, musicbrainz and
cdtext. They can all be listed in a comma-separated list for
CDDBMETHOD and the code will now call all of them in the sequence
listed. All the results will be combined into one list at the end for
the user to select, just like would have previously worked for one
source only.
* Fix Musicbrainz ID calculation in makeids()
* Fix abcde.mkcue() when handling the --wholedisk option. Thanks to
Nino Burini for the patch.
* Add more comprehensive examples for filename munging in the example
config file.
* Add a more better fix for the year lookup problem in
abcde-musicbrainz-tool
* Redirect stderr on "which" calls to clear up error noise on some
systems.
* Add Irix support.
* Rework abcde-musicbrainz-tool to work with WebService::MusicBrainz
Also added a specific dependency on version 1.0.4 or newer, so
abcde-musicbrainz-tool will abort if the version found is too old.
Since tweaked to deal with multi-artist albums and tracks more
completely.
* Add resume support in do_getalbumart()
* Fix getopts setup for "P". Thanks to Alan W. Kerr for reporting this.
* Major set of code cleanups to fix up lots of warnings found with
shellcheck, and a few other style issues:
+ Lots of quoting fixes
+ Use $( instead of `
+ Stop using -o and -a syntax with if [ - use || or && instead
+ Wrap and shorten some very long lines
* Wrap some output messages so they fit on a standard width console
* Factor out repeated code and make page() more useful
* Add version check before resuming from an old ripping run
- Dropped abcde-quote.patch

==== akonadi-calendar ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix warning about TRANSLATION_DOMAIN
* Fix new warning (gcc 8 ) 'warning: catching polymorphic type'
* Use Q_REQUIRED_RESULT
* always show an incidence if we are the organizer (kde#352214)

==== akonadi-calendar-tools ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-calendar-tools-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== akonadi-contact ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Add missing category
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Don't use deprecated api
* Port to new connect api
* Reorder
* Port to new connect api + fix disconnect it

==== akonadi-import-wizard ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== akonadi-mime ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix warning about TRANSLATION_DOMAIN
* Use Q_REQUIRED_RESULT

==== akonadi-notes ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== akonadi-search ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Don't use deprecated api
* Make compile under MSVC

==== akonadi-server ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Don't fetch missing parts from the resource.
* Revert "ProtocolHelper: only unserialize payload we requested"
* Monitor: rebuild Item from ntf if it's mustRetrieve but IFS is empty
(kde#397131)
* ProtocolHelper: only unserialize payload we requested
* Fix warning due to deleteLater on null object
* Server: create new Collection in a single step
* Monitor: fix broken subscription to only Item or Collection ntfs
* Server: fix Item notifications being rejected on mimetype filters
(kde#396781)
* Monitor: invalidate pending notifications on change
* Notifications: retrieve Item when RID is missing
* DataStore: don't access mNotificationCollector directly
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here
- Build with gcc7 on Leap 42.3

==== akregator ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akregator-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Build with gcc7 on Leap 42.3, it doesn't compile with 4.8 anymore
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== analitza ====
Version update (18.04.3 -> 18.08.0)
Subpackages: analitza-lang libAnalitza5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Make the HelpTip widget a tooltip
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Don't have two tests with the same name
* Fix comparison in some 32bit machines (kde#393487)

==== apparmor ====
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser
apparmor-parser-lang apparmor-profiles apparmor-utils apparmor-utils-lang
pam_apparmor pam_apparmor-32bit perl-apparmor python3-apparmor

- add make-pyflakes-happy.diff to fix an unused variable (SR 629206)

==== ark ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ark-lang libkerfuffle18

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Don't show comment message widget after clearing the comment view
* libzip: use ZIP_FL_ENC_RAW for comments
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* clizip: fix list after adding files to encrypted archive
* Stop ignoring compression options when dropping files (kde#396579)
* Make CI happy (I hope:))
* More strict compile flags
* cliinterface: restore old working directory after extraction (kde#395939)
* libarchive: restore old working directory after extraction
* Add checks for expected working dir in the extraction tests
* cliinterface: make m_operationMode protected
* Revert "cliinterface: simplify cleanUpExtracting() usage"
* libarchive: cleanup blank lines
* libarchive: rename counter variables
* libarchive: move variables closer to usage
* cliinterface: simplify cleanUpExtracting() usage
* Do not duplicate work of KAboutData::setupCommandLine()
* flatpak: enable graphics acceleration
* flatpak: drop QT_QPA_PLATFORM=flatpak

==== attica-qt5 ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Attica5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Don't instantiate a QStringRef into a QString only to search in a
QStringList
* Define elements when they're declared

==== autoconf ====

- ac-header-major.patch: port AC_HEADER_MAJOR to glibc 2.25
- Use %license for COPYING

==== autoconf-el ====

- ac-header-major.patch: port AC_HEADER_MAJOR to glibc 2.25
- Use %license for COPYING

==== baloo5 ====
Version update (5.48.0 -> 5.49.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* [tags_kio] Clean up parser debug and comments.
* [tags_kio] Fix multiple filename copies.
* Revert "[tags_kio] Use UDS_URL instead of UDS_TARGET_URL."
* [tags_kio] Use UDS_URL instead of UDS_TARGET_URL.
* [tags_kio] Query target filepaths instead of appending paths to the file
UDS entry.
* Support special URLs for finding files of a certain type
* Avoid manipulation of lists with quadratic complexity
* Use non deprecated fastInsert in baloo

==== baloo5-widgets ====
Version update (18.04.3 -> 18.08.0)
Subpackages: baloo5-widgets-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Honor BUILD_TESTING
* Fix unnecessary soversion change
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix typos in comments
* Remove module prefixes from Qt includes
* Use more explicit
* Use consistently override
* Use nullptr
* Bump min Qt/KF versions to those of dolphin
* Remove last traces of naturalqueryparser
* Note known min versions of deps in CMake Config file
* Port ECMPackageConfigHelpers -> CMakePackageConfigHelpers
* Remove QT definitions duplicated from KDEFrameworkCompilerSettings or dead
* Use same minimum version for ECM and KF5
* Use version from KDE Applications release script
* cmake: set version in the project() call
* filemetadatadatedisplaytest: Build and pass with < Qt5.10
* Add choice of date formats
* Expose group information to Dolphin's Information panel, tooltips, etc
* Remove all Nepomuk references
* filemetadatawidgettest: Enforce en_US locale

==== blinken ====
Version update (18.04.3 -> 18.08.0)
Subpackages: blinken-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== bluez-qt ====
Version update (5.48.0 -> 5.49.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== bovo ====
Version update (18.04.3 -> 18.08.0)
Subpackages: bovo-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== breeze5-icons ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Add `drive-optical` icon (kde#396432)

==== build ====
Version update (20180629 -> 20180816)
Subpackages: build-mkbaselibs build-mkdrpms

- docker format: New podman/buildah build engine support
- Support for full names in changes files
- Set %url macro when seeing an Url:
- pacman CLI updates
- enable core dump generation in VM builds
- Disable kpti on guest kernel for performance and correctness
- support for e2fsprogs 1.43.1 with old kernels

==== calendarsupport ====
Version update (18.04.3 -> 18.08.0)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Warning--
* Use Q_REQUIRED_RESULT
* various - add support for multiple holiday regions
* calprinter.h - fix doPrint signature to use fully qualified slot args found
by clazy
* src/printing/calprintpluginbase.cpp - restore code removed by accident
clazy found a set by unused variable
* src/calendarutils.cpp - normalize a SLOT/SIGNAL
* utils - introduce CalendarSupport::tooltipString()
* autotests/modeltest.cpp - fix signed vs. unsigned comparison warning
* Fix warning

==== cervisia ====
Version update (18.04.3 -> 18.08.0)
Subpackages: cervisia-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== dolphin ====
Version update (18.04.3 -> 18.08.0)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Remove custom icon selection for trash
* Compare UDS entry times directly instead of going through KFileItem
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here
- Refreshed patches:
* 0001-Revert-Disallow-executing-Dolphin-as-root-on-Linux.patch

==== dragonplayer ====
Version update (18.04.3 -> 18.08.0)
Subpackages: dragonplayer-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== duplicity ====
Version update (0.7.17 -> 0.7.18)

- Update to 0.7.18:
* Fixed bug #1756550 Online html man page is showing a 0 byte file
* Partial fix of bug #1734144 with patch from Joris van Eijden
- Note: this is really just a partial fix for now, since it only covers
the case where the local size does not yet match the remote size. A
case where -1 is the returned length is not fixed.
- Number of retries is now same as globals.num_retries.
- Added standoff delay of 0.5 sec per attempt.
* Fixed bug #1764432 with patch from Robke Geenen
- Just join the parts together.
* Fixed bug #1717935 with suggestion from strainu
- Use urllib.quote_plus() to properly quote pathnames passed via URL
* Fixed bug #1780617 Test fail when GnuPG >= 2.2.8
- Relevant change in GnuPG 2.2.8: https://dev.gnupg.org/T3981
- Added '--ignore-mdc-error' to all gpg calls made.
* Fixed bug #1785520 with patch from Chris Hunt
- Fix for B2 version 1.3.4 just released
* Fix a 2to3 error in ssh_paramiko_backend.py
- Update duplicity-remove_shebang.patch

==== eventviews ====
Version update (18.04.3 -> 18.08.0)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* various - support multiple holiday regions
* src/agenda/agenda.cpp - const ref range-loop (found by clazy)
* timelabels.cpp - Don't call QList::first() on temporary (found by clazy)
* todo/todoviewquickaddline - rename returnPressed() slot (for clazy)
* src/agenda/calendardecoration.h - de-const some signals (found by clazy)
* src/agenda/agenda.cpp - Q_EMIT showNewEventPopupSignal (found by clazy)
minor coding style and spelling fixes.
* src/eventview.h - eventDurationHint is not a SLOT (found by clazy)
* src/agenda/agendaview.cpp - removed unused variable found by clazy and some
coding style
* todo/incidencetreemodel.h - minor includes clean
* todo/todoview.cpp - add some KUIT
* various - tidy-up includes and some coding style
* eventview.cpp - fix fallthrough compiler warning
* support firstDayOfWeek setting (to override the locale) in monthview CCBUG:
358106

==== evolution ====
Subpackages: evolution-lang evolution-plugin-bogofilter
evolution-plugin-pst-import evolution-plugin-spamassassin

- Add evolution-3.28.5-dont-expand-archive-folder.patch
(bgo#795567).

==== ffmpegthumbs ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Add filmstrip embed configuration
* Add arcconfig

==== flatpak ====
Version update (0.11.8.3 -> 0.99.3)
Subpackages: libflatpak0 typelib-1_0-Flatpak-1_0

- Update to version 0.99.3:
+ Fixed case where system install would sometimes fail due to the
system-helper idle exiting.
+ Support installing flatpakref files in FlatpakTransaction,
including a new signal add-new-remote for when remotes might be
added.
+ Added some new FlatpakError codes.
+ We now support .flatpakrepo files with no gpg signatures.
+ Fix crash in system-helper when updating appstream.
+ New command create-usb which can be used to prepare an repo for
offline updates.
+ Fix some non-handled cases of the CLI not working when
/var/lib/flatpak doesn't exist.
+ Fix crash when running with a gid that is not in /etc/groups.
+ Add new permission-* commands to interact with the permissions
store from the portals.
+ Include appdata in OCI bundle.

==== frameworkintegration ====
Version update (5.48.0 -> 5.49.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== gcc7 ====
Version update (7.3.1+r262243 -> 7.3.1+r263609)

- Update to gcc-7-branch head (r263609).
* Includes fix for build with ISL 0.20.

==== gcc8 ====
Version update (8.1.1+r262873 -> 8.2.1+r263610)
Subpackages: cpp8 gcc8-c++ gcc8-fortran gcc8-info gcc8-locale gcc8-objc
libasan5 libatomic1 libgcc_s1 libgcc_s1-32bit libgfortran5 libgomp1 libitm1
liblsan0 libmpx2 libmpxwrappers2 libobjc4 libquadmath0 libstdc++6
libstdc++6-32bit libstdc++6-devel-gcc8 libtsan0 libubsan1

- Update to gcc-8-branch head (r263610).
* Includes GCC 8.2 release.
* Includes fix for build with ISL 0.20.

==== gdb ====

- Apply patch from fedora to build with python3.7:
* gdb-fix-python37-breakage.patch

==== glib2 ====
Version update (2.56.1 -> 2.56.2)
Subpackages: glib2-lang glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Update to version 2.56.2:
+ Support version 2 of the NetworkMonitor portal interface.
+ Bugs fixed: bgo#740791, bgo#755721, bgo#773435, bgo#793727,
bgo#794380, bgo#794801, bgo#795138, bgo#795234, bgo#795406,
bgo#795429, bgo#795711, bgo#795735, bgo#795802,
glgo#GNOME/glib2#1240, glgo#GNOME/glib2#1401,
glgo#GNOME/glib2#1452, glgo#GNOME/glib2#1458.
+ Updated translations.
- Drop glib2-codegen-headers.patch: Fixed upstream.
- Refresh patches with quilt.

==== grantleetheme ====
Version update (18.04.3 -> 18.08.0)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Add missing override

==== gtk4 ====

- Fix package name to be uniform immodules -> immodule bsc#1104264

==== gwenview5 ====
Version update (18.04.3 -> 18.08.0)
Subpackages: gwenview5-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix video controls volume slider not vertically centered sometimes
(kde#390929)
* Disable setImageData for dragging of unmodified images
* Make sure, a newly saved image is selected in ContextManager
* Keep crop handles inside selection rectangle
* Remove crosshair cursor from crop tool
* Fix crosshair cursor not showing in red eye reduction tool (kde#321933)
* Propagate unused mouse press events in edit tools
* Reactivate size slider in Red Eye Reduction tool
* Propagate unused mouse wheel events in edit tools
* Fix image smoothing sometimes not getting applied (kde#396736)
- Build with gcc7 on Leap 42.3, it doesn't compile with 4.8 anymore
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== health-checker ====
Subpackages: health-checker-plugins-caasp

- Use noun phrase in summary.

==== hylafax+ ====
Version update (5.5.9 -> 5.6.0)
Subpackages: hylafax+-client

- Trim "enterprise" nonsense marketing.
- version 5.6.0
* notification.diff removed (part of 5.6.0 now)
* some adjustments to assist AIX 6.1 builds (29 Jun 2018)
* initial support for systemd in faxsetup (29 Jun 2018)
* fix RFC2047 encoding by notify (27 Jun, 3 Jul 2018)
* add jobcontrol PageSize feature (27 Jun 2018)
* fix various compiler warnings (27 Jun 2018)
* fix build on musl-based distribution (27 Jun 2018)
* don't wait forever after +FRH:3 (18 Jun 2018)
* add -A and -B options to tagtest (22 Feb 2018)
* make tagtest use the TSI and CallerID data, if available (21 Feb 2018)
* make tagtest use the date from the TIFF tags, if available,
instead of "now" (20 Feb 2018)
* pass Content-Type name and Content-Disposition filename
information to faxmail MIMEHandlers (15 Jan 2018)
* fix faxmail transition between a message and external types (15 Jan 2018)
* fix warning for major and minor macros move to sysmacros.h (19 Dec 2017)
* avoid pagehandling from introducing some unnecessary EOM signals (15 Dec
2017)
* improve proxy connection error handling and logging (5 Dec 2017)
* fix for reproducible builds (11 Sep 2017)
* fix quote escaping in client apps (5 Sep 2017)
* treat callingnumber as null (25, 31 Aug 2017)
* add initial ModemGroup limits feature (24 Aug 2017)
* add CLEANFAXDATA and BADFAXLINES TIFF tags for ECM receptions (10 Aug 2017)
* pass the user's uid onto the session log file for sent faxes (25 Jul 2017)
* improve job waits to minimize triggers (30 May 2017)
* increase FIFO read size and add logging information (25 May 2017)
* add ProxyTaglineFormat and ProxyTSI features (13 Mar 2017)

==== incidenceeditor ====
Version update (18.04.3 -> 18.08.0)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix label to avoid %lt; tag misformation
* Don't hardcode link colors.
* fix warning
* Use Q_REQUIRED_RESULT
* Implement TODO: show error message on invalid date/time
* Don't use deprecated api

==== isl ====
Version update (0.19 -> 0.20)

- Update to 0.20
* keep track of domain in 0D isl_multi_pw_aff and
isl_multi_union_pw_aff
* add isl_aff_eval and isl_pw_aff_eval
* add fixed-size rectangular box hull

==== juk ====
Version update (18.04.3 -> 18.08.0)
Subpackages: juk-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Bring back inline tag editing. (kde#395948)
* use KDE_INSTALL_METAINFODIR
* Remove slight bias in random track selection.
* Inhibit power management when playing audio.
* Do not duplicate work of KAboutData::setupCommandLine()
* Fix one warning because of deprecated API call

==== kaccounts-integration ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kaccounts-integration-lang libkaccounts1

- Add libaccounts-glib-devel requirement to the devel package, the
cmake files look for it
- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix FindAccountsFileDir.cmake
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use JSON kded service data (kde#378965)

==== kaccounts-providers ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kaccounts-providers-lang

- Remove unnecessary BuildRequires that are actually dependencies
of kaccounts-integration-devel
- Remove unused Qt5Widgets BuildRequires
- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix Twitter tooltip

==== kactivities-stats ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kactivities5 ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kaddressbook ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kaddressbook-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix filter checkcombobox
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix restore to default
* Increase version
* Warning--
* Fix manager leak
* Use a better icon for the Kontact plugin
* mainwidget: Add space after "Search..."

==== kalarmcal ====
Version update (18.04.3 -> 18.08.0)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Use QTEST_GUILESS_MAIN
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Does not depend on kdelibs4support anymore
* test: Fix qCompare type
* Reenable tests
* Disable tests for KAlarmCal. These currently fail to build on the CI system
due to a linking failure, and due to KAlarmCal being a dependency of other
software in turn makes Extragear and Applications CI unmaintainable.
* Clarifications, formatting
* Fix saving local times to calendar
* Ignore X-KDE-KALARM-REPEAT if a main alarm exists
* Partial test class for KAEvent
* Remove KDE4Support
* Minor fixes

==== kalgebra ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kalgebra-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* kirigami: fix delegate look
* kirigami: fix qtquick warning
* kirigami: fix Tables when From and To are the same
* kirigami: fix qml error
* kirigami: keep the global drawer open as we do in discover on the desktop
* kirigami: don't make it as if items were clickable
* kirigami: let Kirigami.ApplicationWindow decide which header to use
* kirigami: Fix completion
* Small code polish around the console html generation code
* Fix consolehtml loading
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix crash
* Fix popup menu position
* Fix signal/slot
* Add separator
* Name the desktop file the same as the appdata file
* Include an appdata file for kalgebra mobile

==== kalzium ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kalzium-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kamera ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kamera-lang kio_kamera

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Proofread kcontrol/kamera docbook for 18.04
* Fix dangly pointer if gp_context_new fails (kde#386533)

==== kanagram ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kanagram-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kapptemplate ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kapptemplate-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== karchive ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kate ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kate-lang kate-plugins

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Honor BUILD_TESTING
- Use %license
- License is actually GPL-3.0-or-later
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here
- Refreshed patches:
* 0001-Defuse-root-block.patch
- Drop custom lang package definition

==== katomic ====
Version update (18.04.3 -> 18.08.0)
Subpackages: katomic-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kauth ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Avoid warnings for PolkitQt5-1 headers
* Honor BUILD_TESTING

==== kblackbox ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kblackbox-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kblocks ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kblocks-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kbookmarks ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Use noun phrase in summary; use complete sentences in description.
- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kbounce ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kbounce-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kbreakout ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kbreakout-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kbruch ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kbruch-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kcachegrind ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kcachegrind-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kcalc ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kcalc-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Remove unneeded QT definitions
* Build with strict compile flags

==== kcalcore ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Warning--
* Warning--
* Remove unused debug

==== kcalutils ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Fix Bug 394344: If the Location is a URL then it should be clickable in the
incidence viewer (kde#394344)
* Warning--
* various - adjust reference data to try to fix testincidenceformatter again
* Add override

==== kcharselect ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kcharselect-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use QT_USE_QSTRINGBUILDER instead of outdated QT definitions
* Add simple appdata file for KCharSelect

==== kcmutils ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Use noun phrase in summary.
- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kcodecs ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kcolorchooser ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kcolorchooser-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kcompletion ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kconfig ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kconfigwidgets ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kcontacts ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Cache country <-> ISO code mapping in both directions
* Load the address formatting rules only once
* Fix country detection from QLocale
* Don't rely on address formatting data from kdelibs4support
* Put the countrytransl.map file into a Qt resource
* Use Q_REQUIRED_RESULT
* Fix countryToISO() returning the local country for unknown country names
* Remove unused D-Bus dependency

==== kcoreaddons ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Fix overflow in rounding code (kde#397008)
* API dox: remove not-to-be-there ":"s behind "@note"
* API dox: talk about nullptr, not 0
* KFormat: Replace unicode literal with unicode codepoint to fix MSVC build
* KFormat: Add unit tests for mili/micro SI prefixes
* KFormat: fix typo in SI prefix name enum
* KFormat: correct @since tag for new KFormat::formatValue
* KFormat: Allow usage of quantities beyond bytes and seconds
* Correct KFormat::formatBytes examples
* Honor BUILD_TESTING

==== kcrash ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kcron ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kcron-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kdav ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdav-lang libKPimKDAV5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Assign colors correctly also when the alpha channel is set. (kde#395216)
* Cache value
* Fix signed/unsigned int
* Warning--

==== kdbusaddons ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Don't block forever in ensureKdeinitRunning
* Honor BUILD_TESTING

==== kde-print-manager ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kde-print-manager-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* use nullptr
* Use nullptr. use override
* Use nullptr/override
* Remove usage of dead QT_USE_FAST_CONCATENATION
* Do not duplicate work of KAboutData::setupCommandLine()
* Simplify accessing a job object
* Possibly fix a crash by updating a row before moving it (kde#326289)
* fix typo

==== kdeclarative ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* ensure we are always writing in the engine's root context
* better readability
* Improve API docs a bit
* Honor BUILD_TESTING

==== kded ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kded-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kdeedu-data ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kdegraphics-thumbnailers ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use NO_POLICY_SCOPE with KDECompilerSettings
* Use QT_USE_QSTRINGBUILDER, drop outdated QT definitions
* Set cmake required min only one, bump to 3.0

==== kdelibs4support ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Fix qtplugins in KStandardDirs

==== kdenetwork4-filesharing ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdenetwork4-filesharing-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Support desktop:/ protocol (kde#394316)

==== kdepim-addons ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdepim-addons-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Add missing categories
* Empty email is an invalid email
* Fix Bug 396685 - Edit Location not possible with dark theme (kde#396685)
* Don't set the icon theme too early
* Split rendertest data in tests that need Akonadi and those that don't
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== kdepim-apps-libs ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdepim-apps-libs-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Indent

==== kdepim-runtime ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdepim-runtime-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here
- Dropped patches, now upstream:
* 0001-Always-add-domain-delimiter-if-Domain-checkbox-is-se.patch

==== kdesu ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kdevelop5 ====
Version update (5.2.3 -> 5.2.4)
Subpackages: kdevelop5-lang kdevplatform kdevplatform-lang libkdevplatform52

- New upstream release 5.2.4
* Fix resizing of variable tooltip
* Fix various problems with filters in the output view
(kde#343124)
* Fix a crash which could happen when using the class browser in
debug builds with Qt >= 5.11
* Only show cppcheck menu for cpp files
- Move all plugins from kdevplatform to the main package following
upstream more closely, the kdevplatform package now only contains
files coming from the "kdevplatform" directory in the source
(kdevelop5 is the only application using kdevplatform anyway)

==== kdewebkit ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kdf ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdf-lang kwikdisk

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Not necessary to generate moc file
* Remove extra ;
* Warning--
* Do not duplicate work of KAboutData::setupCommandLine()
* Add simple appdata file for KDiskFree

==== kdialog ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdialog-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Do not duplicate work of KAboutData::setupCommandLine()
* Warning--

==== kdiamond ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdiamond-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kdnssd-framework ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kdoctools ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kemoticons ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kernel-source ====
Version update (4.18.0 -> 4.18.5)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Linux 4.18.5 (bnc#1012628).
- reiserfs: fix broken xattr handling (heap corruption, bad
retval) (bnc#1012628).
- i2c: imx: Fix race condition in dma read (bnc#1012628).
- i2c: core: ACPI: Properly set status byte to 0 for multi-byte
writes (bnc#1012628).
- PCI: pciehp: Fix unprotected list iteration in IRQ handler
(bnc#1012628).
- PCI: pciehp: Fix use-after-free on unplug (bnc#1012628).
- PCI: Skip MPS logic for Virtual Functions (VFs) (bnc#1012628).
- PCI: aardvark: Size bridges before resources allocation
(bnc#1012628).
- PCI: hotplug: Don't leak pci_slot on registration failure
(bnc#1012628).
- PCI / ACPI / PM: Resume all bridges on suspend-to-RAM
(bnc#1012628).
- PCI: Restore resized BAR state on resume (bnc#1012628).
- parisc: Remove ordered stores from syscall.S (bnc#1012628).
- parisc: Remove unnecessary barriers from spinlock.h
(bnc#1012628).
- drm/amdgpu/pm: Fix potential Spectre v1 (bnc#1012628).
- drm/i915/kvmgt: Fix potential Spectre v1 (bnc#1012628).
- ext4: fix spectre gadget in ext4_mb_regular_allocator()
(bnc#1012628).
- powerpc64s: Show ori31 availability in spectre_v1 sysfs file
not v2 (bnc#1012628).
- x86/mm/init: Remove freed kernel image areas from alias mapping
(bnc#1012628).
- x86/mm/init: Add helper for freeing kernel image pages
(bnc#1012628).
- x86/mm/init: Pass unconverted symbol addresses to
free_init_pages() (bnc#1012628).
- mm: Allow non-direct-map arguments to free_reserved_area()
(bnc#1012628).
- pty: fix O_CLOEXEC for TIOCGPTPEER (bnc#1012628).
- EDAC: Add missing MEM_LRDDR4 entry in edac_mem_types[]
(bnc#1012628).
- commit d918293
- x86/speculation/l1tf: Suggest what to do on systems with too
much RAM (bsc#1105536).
- x86/speculation/l1tf: Fix off-by-one error when warning that
system has too much RAM (bsc#1105536).
- x86/speculation/l1tf: Fix overflow in l1tf_pfn_limit() on 32bit
(OBS failures reported on IRC).
- commit f3b24ad
- Update config files.
- Delete
patches.suse/revert-mm-relax-deferred-struct-page-requirements.patch.
We actually do not this non-upstream revert. We only need the config
change. That is: leave DEFERRED_STRUCT_PAGE_INIT=n for i386 as it was
before 4.16.
- commit 161b8ee
- Linux 4.18.4 (bnc#1012628).
- l2tp: use sk_dst_check() to avoid race on sk->sk_dst_cache
(bnc#1012628).
- net_sched: fix NULL pointer dereference when delete tcindex
filter (bnc#1012628).
- net_sched: Fix missing res info when create new tc_index filter
(bnc#1012628).
- r8169: don't use MSI-X on RTL8168g (bnc#1012628).
- ALSA: hda - Sleep for 10ms after entering D3 on Conexant codecs
(bnc#1012628).
- ALSA: hda - Turn CX8200 into D3 as well upon reboot
(bnc#1012628).
- ALSA: vx222: Fix invalid endian conversions (bnc#1012628).
- ALSA: virmidi: Fix too long output trigger loop (bnc#1012628).
- ALSA: cs5535audio: Fix invalid endian conversion (bnc#1012628).
- ALSA: dice: fix wrong copy to rx parameters for Alesis iO26
(bnc#1012628).
- ALSA: hda: Correct Asrock B85M-ITX power_save blacklist entry
(bnc#1012628).
- ALSA: memalloc: Don't exceed over the requested size
(bnc#1012628).
- ALSA: vxpocket: Fix invalid endian conversions (bnc#1012628).
- ALSA: seq: Fix poll() error return (bnc#1012628).
- media: gl861: fix probe of dvb_usb_gl861 (bnc#1012628).
- USB: serial: sierra: fix potential deadlock at close
(bnc#1012628).
- USB: serial: pl2303: add a new device id for ATEN (bnc#1012628).
- USB: option: add support for DW5821e (bnc#1012628).
- ACPI / PM: save NVS memory for ASUS 1025C laptop (bnc#1012628).
- tty: serial: 8250: Revert NXP SC16C2552 workaround
(bnc#1012628).
- serial: 8250_exar: Read INT0 from slave device, too
(bnc#1012628).
- serial: 8250_dw: always set baud rate in dw8250_set_termios
(bnc#1012628).
- serial: 8250_dw: Add ACPI support for uart on Broadcom SoC
(bnc#1012628).
- uio: fix wrong return value from uio_mmap() (bnc#1012628).
- misc: sram: fix resource leaks in probe error path
(bnc#1012628).
- Revert "uio: use request_threaded_irq instead" (bnc#1012628).
- Bluetooth: avoid killing an already killed socket (bnc#1012628).
- isdn: Disable IIOCDBGVAR (bnc#1012628).
- net: sock_diag: Fix spectre v1 gadget in __sock_diag_cmd()
(bnc#1012628).
- r8169: don't use MSI-X on RTL8106e (bnc#1012628).
- ip_vti: fix a null pointer deferrence when create vti fallback
tunnel (bnc#1012628).
- net: ethernet: mvneta: Fix napi structure mixup on armada 3700
(bnc#1012628).
- net: mvneta: fix mvneta_config_rss on armada 3700 (bnc#1012628).
- cls_matchall: fix tcf_unbind_filter missing (bnc#1012628).
- commit a7b92e4
- Linux 4.18.3 (bnc#1012628).
- x86/speculation/l1tf: Exempt zeroed PTEs from inversion
(bnc#1012628).
- commit a14f6a3
- Linux 4.18.2 (bnc#1012628).
- x86/mm: Add TLB purge to free pmd/pte page interfaces
(bnc#1012628).
- ioremap: Update pgtable free interfaces with addr (bnc#1012628).
- Bluetooth: hidp: buffer overflow in hidp_process_report
(bnc#1012628).
- crypto: skcipher - fix crash flushing dcache in error path
(bnc#1012628).
- crypto: skcipher - fix aligning block size in skcipher_copy_iv()
(bnc#1012628).
- crypto: ablkcipher - fix crash flushing dcache in error path
(bnc#1012628).
- crypto: blkcipher - fix crash flushing dcache in error path
(bnc#1012628).
- crypto: vmac - separate tfm and request context (bnc#1012628).
- crypto: vmac - require a block cipher with 128-bit block size
(bnc#1012628).
- crypto: x86/sha256-mb - fix digest copy in
sha256_mb_mgr_get_comp_job_avx2() (bnc#1012628).
- crypto: ccp - Fix command completion detection race
(bnc#1012628).
- crypto: ccp - Check for NULL PSP pointer at module unload
(bnc#1012628).
- crypto: ccree - fix iv handling (bnc#1012628).
- crypto: ccree - fix finup (bnc#1012628).
- kbuild: verify that $DEPMOD is installed (bnc#1012628).
- x86/mm: Disable ioremap free page handling on x86-PAE
(bnc#1012628).
- xen/pv: Call get_cpu_address_sizes to set x86_virt/phys_bits
(bnc#1012628).
- x86/mm/pti: Clear Global bit more aggressively (bnc#1012628).
- x86/platform/UV: Mark memblock related init code and data
correctly (bnc#1012628).
- x86/hyper-v: Check for VP_INVAL in hyperv_flush_tlb_others()
(bnc#1012628).
- x86: i8259: Add missing include file (bnc#1012628).
- x86/l1tf: Fix build error seen if CONFIG_KVM_INTEL is disabled
(bnc#1012628).
- commit 51ef786
- Linux 4.18.1 (bnc#1012628).
- x86/init: fix build with CONFIG_SWAP=n (bnc#1012628).
- cpu/hotplug: Non-SMP machines do not make use of booted_once
(bnc#1012628).
- x86/smp: fix non-SMP broken build due to redefinition of
apic_id_is_primary_thread (bnc#1012628).
- commit 7e40689
- Linux 4.18.4 (bnc#1012628).
- l2tp: use sk_dst_check() to avoid race on sk->sk_dst_cache
(bnc#1012628).
- net_sched: fix NULL pointer dereference when delete tcindex
filter (bnc#1012628).
- net_sched: Fix missing res info when create new tc_index filter
(bnc#1012628).
- r8169: don't use MSI-X on RTL8168g (bnc#1012628).
- ALSA: hda - Sleep for 10ms after entering D3 on Conexant codecs
(bnc#1012628).
- ALSA: hda - Turn CX8200 into D3 as well upon reboot
(bnc#1012628).
- ALSA: vx222: Fix invalid endian conversions (bnc#1012628).
- ALSA: virmidi: Fix too long output trigger loop (bnc#1012628).
- ALSA: cs5535audio: Fix invalid endian conversion (bnc#1012628).
- ALSA: dice: fix wrong copy to rx parameters for Alesis iO26
(bnc#1012628).
- ALSA: hda: Correct Asrock B85M-ITX power_save blacklist entry
(bnc#1012628).
- ALSA: memalloc: Don't exceed over the requested size
(bnc#1012628).
- ALSA: vxpocket: Fix invalid endian conversions (bnc#1012628).
- ALSA: seq: Fix poll() error return (bnc#1012628).
- media: gl861: fix probe of dvb_usb_gl861 (bnc#1012628).
- USB: serial: sierra: fix potential deadlock at close
(bnc#1012628).
- USB: serial: pl2303: add a new device id for ATEN (bnc#1012628).
- USB: option: add support for DW5821e (bnc#1012628).
- ACPI / PM: save NVS memory for ASUS 1025C laptop (bnc#1012628).
- tty: serial: 8250: Revert NXP SC16C2552 workaround
(bnc#1012628).
- serial: 8250_exar: Read INT0 from slave device, too
(bnc#1012628).
- serial: 8250_dw: always set baud rate in dw8250_set_termios
(bnc#1012628).
- serial: 8250_dw: Add ACPI support for uart on Broadcom SoC
(bnc#1012628).
- uio: fix wrong return value from uio_mmap() (bnc#1012628).
- misc: sram: fix resource leaks in probe error path
(bnc#1012628).
- Revert "uio: use request_threaded_irq instead" (bnc#1012628).
- Bluetooth: avoid killing an already killed socket (bnc#1012628).
- isdn: Disable IIOCDBGVAR (bnc#1012628).
- net: sock_diag: Fix spectre v1 gadget in __sock_diag_cmd()
(bnc#1012628).
- r8169: don't use MSI-X on RTL8106e (bnc#1012628).
- ip_vti: fix a null pointer deferrence when create vti fallback
tunnel (bnc#1012628).
- net: ethernet: mvneta: Fix napi structure mixup on armada 3700
(bnc#1012628).
- net: mvneta: fix mvneta_config_rss on armada 3700 (bnc#1012628).
- cls_matchall: fix tcf_unbind_filter missing (bnc#1012628).
- commit 06f7c50
- ACPICA: Clear status of all events when entering sleep states
(boo#1104529).
- commit 5d7a9a7
- Delete
patches.suse/Revert-ACPICA-Events-Stop-unconditionally-clearing-A.patch.
- commit fb1dc2b
- Linux 4.18.3 (bnc#1012628).
- x86/speculation/l1tf: Exempt zeroed PTEs from inversion
(bnc#1012628).
- commit 3914d9b
- Linux 4.18.2 (bnc#1012628).
- x86/mm: Add TLB purge to free pmd/pte page interfaces
(bnc#1012628).
- ioremap: Update pgtable free interfaces with addr (bnc#1012628).
- Bluetooth: hidp: buffer overflow in hidp_process_report
(bnc#1012628).
- crypto: skcipher - fix crash flushing dcache in error path
(bnc#1012628).
- crypto: skcipher - fix aligning block size in skcipher_copy_iv()
(bnc#1012628).
- crypto: ablkcipher - fix crash flushing dcache in error path
(bnc#1012628).
- crypto: blkcipher - fix crash flushing dcache in error path
(bnc#1012628).
- crypto: vmac - separate tfm and request context (bnc#1012628).
- crypto: vmac - require a block cipher with 128-bit block size
(bnc#1012628).
- crypto: x86/sha256-mb - fix digest copy in
sha256_mb_mgr_get_comp_job_avx2() (bnc#1012628).
- crypto: ccp - Fix command completion detection race
(bnc#1012628).
- crypto: ccp - Check for NULL PSP pointer at module unload
(bnc#1012628).
- crypto: ccree - fix iv handling (bnc#1012628).
- crypto: ccree - fix finup (bnc#1012628).
- kbuild: verify that $DEPMOD is installed (bnc#1012628).
- x86/mm: Disable ioremap free page handling on x86-PAE
(bnc#1012628).
- xen/pv: Call get_cpu_address_sizes to set x86_virt/phys_bits
(bnc#1012628).
- x86/mm/pti: Clear Global bit more aggressively (bnc#1012628).
- x86/platform/UV: Mark memblock related init code and data
correctly (bnc#1012628).
- x86/hyper-v: Check for VP_INVAL in hyperv_flush_tlb_others()
(bnc#1012628).
- x86: i8259: Add missing include file (bnc#1012628).
- x86/l1tf: Fix build error seen if CONFIG_KVM_INTEL is disabled
(bnc#1012628).
- commit 403355b
- rpm/constraints.in: raise memory constraints
Build statistics show that most architectures already need more than 2 GB.
Require 4 GB except s390x where the memory usage is much lower and we might
have trouble finding any compliant worker.
- commit 494fb32
- Revert "ACPICA: Events: Stop unconditionally clearing ACPI
IRQs during suspend/resume" (boo#1104529, bko#196249).
- commit 5dac824
- Linux 4.18.1 (bnc#1012628).
- x86/init: fix build with CONFIG_SWAP=n (bnc#1012628).
- cpu/hotplug: Non-SMP machines do not make use of booted_once
(bnc#1012628).
- x86/smp: fix non-SMP broken build due to redefinition of
apic_id_is_primary_thread (bnc#1012628).
- commit 2f1304f

==== kfilemetadata5 ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kfilemetadata5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* API dox: add @file to functions-only header to have doxygen cover those

==== kgeography ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kgeography-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kget ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kget-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* [mirrorsettings] Delay accepting the QDialog
* [metalinkcreator] Setup the country and language models
* [metalinkcreator] Properly connect buttons to the file dialog
* [metalinkcreator] Only enable "finish" when all required data is entered
* [metalinkcreator] Use the real KGet version for the "generator" field
* [metalinkcreator] Properly set Save mode for save dialog with KIO 5.33+
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kglobalaccel ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kgoldrunner ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kgoldrunner-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kguiaddons ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== khangman ====
Version update (18.04.3 -> 18.08.0)
Subpackages: khangman-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== khelpcenter5 ====
Version update (18.04.3 -> 18.08.0)
Subpackages: khelpcenter5-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* [Khelpcenter] Use HiDPI icons
* Proofread online help docbook
* Set desktop file name in KAboutData

==== kholidays ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Holidays5 libKF5Holidays5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Install the sunrise/sunset computation header
* Added leap year day as (cultural) holiday for Norway
* Minor formatting changes (e.g. newlines)
* Added ?name? entry for Norwegian holiday files
* Added descriptions for Norwegian holiday files
* more Japanese holiday updates from phanect
* Update holiday_jp_ja and holiday_jp-en_us (kde#365241)

==== khtml ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== ki18n ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Reuse function that already does the same
* Fix the catalog handling and locale detection on Android
* Readability, skip no-op statements
* Fix KCatalog::translate when translation is same as original text
* a file has been renamed
* Let ki18n macro file name follow style of other find_package related files
* Fix the configure check for _nl_msg_cat_cntr
* Don't generate files in the source directory
* libintl: Determine if _nl_msg_cat_cntr exists before use (kde#365917)
* Fix the binary-factory builds.

==== kiconthemes ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kidentitymanagement ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* USe Q_REQUIRED_RESULT
* Don't use deprecated api

==== kidletime ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kig ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kig-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Warning--
* Fix bug 394676
* Golden ratio point

==== kimageformats ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kimagemapeditor ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kimagemapeditor-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kimap ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kimap-lang libKF5IMAP5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix merging
* USe Q_REQUIRED_RESULT
* Fix minor typos
* LOGIN: remove deprecated encryption options
* Add proper error message when STARTTLS is not supported
* LoginJob: add Q_FALLTHROUGH

==== kinit ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kinit-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kio ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kio-core kio-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
- Too many changes to list here

==== kio-extras5 ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Remove an space and a new line
* fix sftp links with new uds implementation
* Don't generate thumbnail for desktop files (kde#220330)
* [activity plugin] Use the imperative mood to match all other Dolphin plugins
* Rename KActivities linking plugin
* Constrain libsmbclient bug workaround to affected versions only
* Use a more intuitive, user-friendly name for Samba share access (kde#141257)

==== kio_audiocd ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kio_audiocd-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* generate and use a local cdda_interface headerfile copy

==== kirigami2 ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* support dynamically adding and removing title (kde#396417)
* introduce actionsVisible (kde#396413)
* Fix documentation typo
* adapt margins when scrollbar appears/disappear
* better management of the size (kde#396983)
* Optimise setting up the palette
* AbstractApplciationItem shouldn't have its own size, only implicit
* new signals pagePushed/pageRemoved
* fix logic
* add ScenePosition element (kde#396877)
* No need to emit the intermediary palette for every state
* hide->show
* Collapsible Sidebar Mode
* kirigami_package_breeze_icons: don't treat lists as elements
* fix searc/replace regexp (kde#396294)
* animating a color produces a rater unpleasant effect (kde#389534)
* color focused item for keyboard navigation
* remove quit shortcut
* Remove long-time deprecated Encoding=UTF-8 from desktop format file
* fix toolbar size (kde#396521)
* fix handle sizing
* Honor BUILD_TESTING
* Show icons for actions that have an icon source rather than an icon name

==== kiriki ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kiriki-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Do not duplicate work of KAboutData::setupCommandLine()
* [kiriki] avoid memory leak

==== kitemmodels ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kitemviews ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kiten ====
Version update (18.04.3 -> 18.08.0)
Subpackages: fonts-KanjiStrokeOrders kiten-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix warning

==== kjobwidgets ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kjs ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kjsembed ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kjumpingcube ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kjumpingcube-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kldap ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kldap-lang libKF5Ldap5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix warning
* Use Q_REQUIRED_RESULT
* kldap: add support for TLS CA certificate handling

==== kleopatra ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kleopatra-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== klettres ====
Version update (18.04.3 -> 18.08.0)
Subpackages: klettres-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Drop unused kemoticons dependency
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix out of sync

==== klines ====
Version update (18.04.3 -> 18.08.0)
Subpackages: klines-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kmag ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmag-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kmahjongg ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmahjongg-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kmail ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix enable/disable print action
* Add warning when we can't print message
* Add "Add Followup Reminder..." entry in messagelib popupmenu too
* Port to setAutoSaveSettings so that saving happens before hiding.
(kde#396339)
* KMail: don't sync after save, don't reload after last sync
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== kmail-account-wizard ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmail-account-wizard-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use return value
* Avoid to detach element

==== kmailtransport ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* kioslave was remove long time ago
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* SMTP: port XOAUTH handler to the new KGAPI2::AccountManager
* SMTP: use the new KSmtp encryption enumerators
* Use 587 as default SMTP port, fallback to 25 if 587 fails in ServerTest
* Use SSL/TLS and STARTTLS as encryption option labels
* Handle XOAUTH token expiration reported by KSmtp
* Don't use deprecated api
* SMTP: Add support for XOAUTH2 method
* Implement auto-detection of XOAUTH2 method
* Add clear button
* Avoid to export private class
* Fix metainfo.yaml
* Port to new connect api
* Remove private slot

==== kmbox ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT

==== kmime ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmime-lang libKF5Mime5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Speed up LFtoCRLF by 20% by not scanning all of it for \r\n.
* Use Q_REQUIRED_RESULT

==== kmines ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmines-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kmousetool ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmousetool-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Do not duplicate work of KAboutData::setupCommandLine()

==== kmouth ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmouth-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Do not duplicate work of KAboutData::setupCommandLine()
* mutal people ? mute people

==== kmplot ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kmplot-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== knavalbattle ====
Version update (18.04.3 -> 18.08.0)
Subpackages: knavalbattle-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== knetwalk ====
Version update (18.04.3 -> 18.08.0)
Subpackages: knetwalk-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== knewstuff ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Remove long-time deprecated Encoding=UTF-8 from desktop format files
* Change default sort order in the download dialog to Rating
* Fix DownloadDialog window margins to meet general theme margins
* Restore accidentally removed qCDebug
* Use the right QSharedPointer API
* Handle empty preview lists

==== knotes ====
Version update (18.04.3 -> 18.08.0)
Subpackages: knotes-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Apply patch from Oleg Solovyov (kde#334138)
* Use a pretty icon in Kontact sidebar
* Use KDE_INSTALL_DATADIR
* Add missing override

==== knotifications ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== knotifyconfig ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kolf ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kolf-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kollision ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kollision-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kolourpaint ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kolourpaint-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* There's only http for kolourpaint.org
* Use QT_USE_QSTRINGBUILDER instead of outdated QT definitions
* [Kolourpaint] Use HiDPI icons
* Add .arcconfig file
* Proofread kolourpaint docbook for 18.04

==== kompare ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kompare-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== konquest ====
Version update (18.04.3 -> 18.08.0)
Subpackages: konquest-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== konsole ====
Version update (18.04.3 -> 18.08.0)
Subpackages: konsole-part konsole-part-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Don't pollute the environment inside Konsole with QT_NO_GLIB
* Vt102EmulationTest: Use QTEST_GUILESS_MAIN
* Revert "Change internal character type size to 32 bit"
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here
- Refreshed patches:
* fix-build-with-gcc48.patch

==== kontact ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kontact-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Add location hint for Parts' toolbars (kde#383916)
* We depend against qt5.9
* ?if you to hide? ? ?if you want to hide?
* Improve size panel icon rendering
* kcmkontact.cpp - skip disabled plugins when making the "start with
component" combobox.

==== kontactinterface ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT

==== kopete ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kopete-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Stop mentioning "Windows Live Messenger" in appdata
* Remove the Yahoo protocol (kde#395287)
* Fix minor typo
* Add simple appdata file for Kopete

==== korganizer ====
Version update (18.04.3 -> 18.08.0)
Subpackages: korganizer-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== kpackage ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kpackage-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kparts ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* API dox: talk about nullptr, not 0

==== kpat ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kpat-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Freecell: Don't allow moving out of foundation
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Make keyboard action labels translatable
* Apply Jonathan's suggested change, let's see if it still builds on BSD
* Fix linking on FreeBSD
* Use Freecell Solver for FreeCell and Simple Simon
* Refactor the Solver class
* Getting rid of macros and dead code:
* General Code clean-up

==== kpeople5 ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kpeople5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kpimtextedit ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* RichtextEditor: don't rehighlight() directly, once is enough.
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Make sure to use value

==== kplotting ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kpty ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kqtquickcharts ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== krdc ====
Version update (18.04.3 -> 18.08.0)
Subpackages: krdc-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix deadlock when user cancels ssh password dialog
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Add option of connecting to the vnc server through a ssh tunnel
* Enable override warnings (on gcc)
* Small typo fix
* Make gcc happy
* No need for such a big margin on top now that image is gone
* Remove needless space-eating header
* clang-tidy: modernize-use-nullptr
* clang-tidy: modernize-use-override run
* CMake: Fix AUTOMOC warnings

==== kreversi ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kreversi-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== krfb ====
Version update (18.04.3 -> 18.08.0)
Subpackages: krfb-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix IPv6 connectivity
- Build with gcc7 on Leap 42.3

==== kross ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kross-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== kruler ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kruler-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Remove unneeded QT definitions
* fix compile without deprecated method
* Make sure that it compiles with strict compile flags

==== krunner ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kservice ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kservice-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Use more nullptr
* API dox: talk about nullptr, not 0
* Require out-of-source build
* Add subseq operator to match sub-sequences

==== kshisen ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kshisen-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== ksirk ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ksirk-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* remove the locolor icons

==== ksmtp ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Login: remove the deprected encryption options
* Add proper error message when STARTTLS is not supported
* Handle XOAUTH token expiration better
* Use QOverload
* Fix missing implemenation of LoginJob::usedAuthMethod()
* Fix variable
* Remove dependency on KMime, in master branch.
* Rename XOAUTH to XOAUTH2
* Increase SMTP session timeout to 1 minute

==== kspaceduel ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kspaceduel-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== ksquares ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ksquares-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== ksudoku ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ksudoku-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Improve two messages (kde#357999)
* Improve Hint and Solve action visibility and enabled state (kde#357996)
* Implement wish 319522: Option to restart current game (kde#319522)
* Remove TODO file
* Remove AUTHORS file
* Remove obsolete INSTALL and VERSION files
* Remove file TODOPORT

==== ksystemlog ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ksystemlog-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Do not duplicate work of KAboutData::setupCommandLine()

==== kteatime ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kteatime-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix no tea is ready notification after second run (kde#397151)
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Fix broken context menu after adding custom tea (kde#396448)
* Warning--
* Remove usage of dead QT_USE_FAST_CONCATENATION

==== ktexteditor ====
Version update (5.48.0 -> 5.49.0)
Subpackages: ktexteditor-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* proper fix for the raw string indenting auto-quoting
* fix indenter to cope with new syntax file in syntaxhighlighting framework
* adjust test to new state in syntax-highlighting repository
* Show "Search wrapped" message in center of view for better visibility
* fix warning, just use isNull()
* Extend Scripting API
* fix segfault on rare cases where empty vector occurs for word count happens
e.g. sometimes for vimode_emulatedcommandbar test
* enforce clear of scrollbar preview on document clear BUG: 374630
(kde#374630)

==== ktextwidgets ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* API docs: partial revert of earlier commit, didn't really work.
* KFindDialog: give the lineedit focus when showing a reused dialog
* APIdox: prefer the more intuitive solution of keeping the dialog open
* KFind: reset count when changing the pattern (e.g. in the find dialog).
* Apidox: modernize and improve KFind and KFindDialog documentation
* Honor BUILD_TESTING

==== ktimer ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ktimer-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Make sure to compile without deprecated method
* Make compile with strict compile flags
* Do not duplicate work of KAboutData::setupCommandLine()

==== ktnef ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* USe Q_REQUIRED_RESULT
* Fix metainfo.yaml

==== ktouch ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ktouch-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== ktuberling ====
Version update (18.04.3 -> 18.08.0)
Subpackages: ktuberling-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Do not duplicate work of KAboutData::setupCommandLine()
* Add OARS tags to the appdata

==== kturtle ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kturtle-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Add explicit/nullptr
* Use nullptr/explicit
* Remove double margin here too
* Remove double margin

==== kubrick ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kubrick-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== kunitconversion ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kwallet ====
Version update (5.48.0 -> 5.49.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kwalletmanager5 ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kwalletmanager5-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Do not duplicate work of KAboutData::setupCommandLine()
* Add simple appdata file for KWalletManager

==== kwayland ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Cleanup RemoteAccess buffers on aboutToBeUnbound instead of object
destruction
* Support cursor hints on locked pointer
* Reduce unnecessary long wait times on failing signal spies
* Fix selection and seat auto tests
* Populate shell version documentation
* Fix compiler warning about virtual overloads in XdgShell
* Replace remaining V5 compat global includes
* Add XDG WM Base support to our XDGShell API
* Make XDGShellV5 co-compilable with XDGWMBase

==== kwidgetsaddons ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Fix KTimeComboBox input mask for AM/PM times (kde#361764)
* Honor BUILD_TESTING

==== kwindowsystem ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== kwordquiz ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kwordquiz-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Clean up
* Fix warning

==== kxmlgui ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Fix KMainWindow saving incorrect widget settings (kde#395988)
* Honor BUILD_TESTING

==== kxmlrpcclient5 ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== ldb ====
Version update (1.3.3 -> 1.3.5)
Subpackages: libldb1 libldb1-32bit

- Add fix_ldb_mod_op_test.patch: Fix missing NULL terminator in
ldb_mod_op_test testsuite
- Update to 1.3.5
+ Security fix for CVE-2018-1140 (NULL pointer de-reference,
bug #13374).
- 1.3.4
+ Fix memory leaks and missing error checks (bug #13459, #13471,
[#13475]).
+ Fix fallback to full scan (performance regression) on
one-level search (bug #13448).
+ Fix read corruption (missing results) during writes,
particularly during a Samba subtree rename (bug #13452).

==== libKF5ModemManagerQt ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== libKF5NetworkManagerQt ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== libgravatar ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Don't export symbol
* increase version
* Byebye libravatar
* libravatar will be shutdown in september
* Remove old comment
* Add info about shutdown

==== libkcddb ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix tests
* Fix compile warnings
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== libkcompactdisc ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== libkdcraw ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== libkdegames ====
Version update (18.04.3 -> 18.08.0)
Subpackages: kdegames-carddecks-default libkdegames-lang libkf5kdegames6

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== libkdepim ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Fix show default text when we clear lineedit
* Make clear button works
* Don't use deprecated api
* Warning--
* Warning--
* Add missing override
* Fix metainfo.yaml

==== libkeduvocdocument ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKEduVocDocument5 libkeduvocdocument-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Honnor BUILD_TESTING

==== libkexiv2 ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== libkgapi ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix build against Qt < 5.10
* Replace KGAPIRaw logging category with file logging
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== libkipi ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== libkleo ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== libkmahjongg ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5KMahjongglib5 libkmahjongg-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== libkomparediff2 ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== libksane ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5Sane5 libksane-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Add workaround for broken bytes_per_line values in line-art mode
* Make finding Sane required on all platforms except Windows
* wrong place to fix clang warning
* clang static anayzer report this variable is never used in this function
* fix clang static analyzer report about uninitialized argument value

==== libksieve ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libksieve-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Empty email is an invalid email
* Clear values when we reset to default
* Add comment
* Add missing QLatin1Char('/')
* First step for simplifying code
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== libqmi ====
Version update (1.20.0 -> 1.20.2)
Subpackages: libqmi-glib5 libqmi-tools

- Update to version 1.20.2:
+ qmicli:
- Exit on --wds-start-network parse errors.
- Fix reading current technology in
- -wds-get-data-bearer-technology.
- Remove implicity casts to GDestroyNotify in
g_clear_pointer().
+ qmi-firmware-update:
- Fix --ignore-version-errors.
- Fix byte counts in error message.
+ libqmi-glib:
- dms: factory settings related operations since 1.0
- Avoid closing same file descriptor twice.
- Don't leak the inner MbimDevice if MBIM_QMUX_ENABLED.
- Add no-dependency-on filter to rpmlintrc, filter out false
warning about missing deps in devel package.

==== libsolv ====
Version update (0.6.34 -> 0.6.35)
Subpackages: libsolv-devel libsolv-tools python-solv

- refactor arch handling
- add support for zstd and zchunk compression
- convert repo2solv.sh script into a binary tool
- bump version to 0.6.35

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-gluster libvirt-daemon-driver-storage-iscsi
libvirt-daemon-driver-storage-logical libvirt-daemon-driver-storage-mpath
libvirt-daemon-driver-storage-rbd libvirt-daemon-driver-storage-scsi
libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc
libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- Revert switch to jansson
boo#1104820
- Dropped:
temp-build-fix.patch
- Added:
9ed59012--revert-jansson1.patch,
54f2b5e3-revert-jansson2.patch,
b56950fd-revert-jansson3.patch,
6c3d66ac-revert-jansson4.patch,
8e373e6d-revert-jansson5.patch,
6f99de31-revert-jansson6.patch,
f204cf51-revert-jansson7.patch,
5a58b5ed-revert-jansson8.patch,
63f6e0e9-revert-jansson9.patch,
8687eba-revert-jansson10.patch,
e96e71d8-revert-jansson11.patch,
d99a8959-revert-jansson12.patch,
074a7e14-revert-jansson13.patch,
86db0db9-revert-jansson14.patch
- spec: don't restart libvirt-guests when updating libvirt-client
bsc#1104662

==== libxcb ====
Subpackages: libxcb-composite0 libxcb-damage0 libxcb-devel libxcb-dpms0
libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-randr0
libxcb-record0 libxcb-render0 libxcb-render0-32bit libxcb-res0
libxcb-screensaver0 libxcb-shape0 libxcb-shm0 libxcb-shm0-32bit libxcb-sync1
libxcb-xf86dri0 libxcb-xfixes0 libxcb-xinerama0 libxcb-xinput0 libxcb-xkb1
libxcb-xtest0 libxcb-xv0 libxcb-xvmc0 libxcb1 libxcb1-32bit

- u_don-t-flag-extra-reply-in-xcb_take_socket.patch
* Update to version proposed upstream.
- u_don-t-flag-extra-reply-in-xcb_take_socket.patch
* Fix IO errors with KWin in combination with NVIDIA driver.
(bnc#1101560)

==== libzypp ====
Version update (17.5.2 -> 17.6.2)

- fixup! Add filesize check for downloads with known size (bsc#408814)
Fix detetction of metalink downloads and prevent aborting if
a metalink file is larger than the expected data file.
- version 17.6.2 (2)
- Adapt to changes in libgpgme11-11.1.0 breaking the signature
verification (bsc#1100427)
- Use %license (bsc#1082318)
- BuildRequires: libsolv-devel >= 0.6.35 (for bsc#1100095)
- changes: add CVE numbers
- version 17.6.1 (2)
- RepoInfo::provideKey: add report telling where we look for missing
keys.
- Support listing gpgkey URLs in repo files (bsc#1088037)
- Add new report to request user approval for importing a package key
- Handle http error 502 Bad Gateway in curl backend (bsc #1070851)
(fixes openSUSE/zypper#177)
- Add filesize check for downloads with known size (bsc#408814)
- Removed superfluous space in translation (bsc#1102019)
- version 17.6.0 (2)

==== lokalize ====
Version update (18.04.3 -> 18.08.0)
Subpackages: lokalize-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Add .arcconfig file
* Do not duplicate work of KAboutData::setupCommandLine()
* Make ?Incomplete? column sortable
* Show number of incomplete (fuzzy + untranslated) strings in project view
* Port KDE_{ISUN,}LIKELY to QT_{UN,}LIKELY
* Cleanup debugging (categories)

==== lskat ====
Version update (18.04.3 -> 18.08.0)
Subpackages: lskat-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== mailcommon ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use nullptr
* Use Q_REQUIRED_RESULT
* Use Q_REQUIRED_RESULT
* Minor
* Don't use deprecated api
* Don't export symbole

==== mailimporter ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Use override
* Fix metainfo.yaml

==== mailman ====

- Add reproducible.patch to use fixed build date in mailman-config
to make package build reproducible (boo#1047218)

==== mbox-importer ====
Version update (18.04.3 -> 18.08.0)
Subpackages: mbox-importer-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Add missing override

==== messagelib ====
Version update (18.04.3 -> 18.08.0)
Subpackages: messagelib-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* It seems that we need to register it
* Make sure that we load "disable emoticon" for header too
* Save "disable emoticon" when we change this value
* Don't show "Show detail" when we print mail
* We need to add isPrinting variable (otherwise it will not work)
* Fix link color/style text when we print mail
* Fix indent
* Fix rendering text. We can have Utf8 text
* Fix printing support in signedmessage.
* avoid crash by initializing pointer
* Significant performance increase for specific use conditions
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== mjpegtools ====
Subpackages: liblavfile-2_0-0 liblavjpeg-2_0-0 liblavplay-2_0-0 liblavrec-2_0-0
libmjpegutils-2_0-0 libmpeg2encpp-2_0-0 libmplex2-2_0-0

- Inject pkg-config --cflags SDL_gfx into CFLAGS: the build system
does not use pkg-config yet to find the right parameters for
SDL_gfx, so we cheat like that.

==== mlterm ====
Version update (3.8.4 -> 3.8.6)
Subpackages: mlterm-canna mlterm-ibus mlterm-scim mlterm-wnn

- updated to 3.8.6
* Support preserveAspectRatio option of OSC 1337.
* Support DECRQCRA, CSI 15 t, CSI 16 t, CSI 19 t and OSC 5;Ps;? ST.
* Support framebuffer on FreeBSD(98).
* Add vte 0.52.0 API symbols to libvte compatible library.
* Add --rv / "rv_color" option.
* Add servman.exe which manages the list of servers on win32.
* Add "PrivKey" entry to the ssh connection dialog on win32 and Android.
* Add "SCP" entry to the context menu on Android.
* Drop --servlist / "server_list" option.
* Improve performance of redrawing screen when type_engine=cairo.
* Show box style cursor when the cursor is on a picture or an emoji.
* Modify DECRC to save/restore last-column flag used to control wrapping
behavior
rather than manipulating DECAWM (See https://github.com/mattiase/wraptest
and
https://invisible-island.net/xterm/xterm.log.html#xterm_328)
* Change the default value of ssh_private(public)_key option from
/sdcard/.ssh/id_rsa(.pub) to /sdcard/.mlterm/id_rsa(.pub) on Android.
* Bug fixes:
Fix compiling error if ./configure is executed with --with-gui=fb,xlib
option.
Fix disappearing title bar on 'lxde' window manager.
Fix a bug which disabled to replace system palettes by colors of a wall
picture
(if "use_ansi_colors" option is disabled and visual depth is 4) since 3.8.4.
Fix the response strings of OSC 20 and OSC 21.
Use the background color specified by SGR instead of the default one to draw
pictures and emojis.
* Support libvterm (https://launchpad.net/libvterm) compatible library
partially.
* Support DRCS-Sixel.
(See drcssixel/DRCS-SIXEL-v2 and
https://qiita.com/arakiken/items/626b02cd857d20c12fbc)
* Support SDL2.
(Build mlterm with --with-gui=sdl2 option.) (see doc/en/README.sdl2)
* Support ligature of "Fira Code" font in -otl option.
* Add --halfwidth / "unicode_half_width_areas" option.
* Add --emoji / "emoji_path" option which makes mlterm to use a specified
emoji font
(NotoColorEmoji.ttf etc) instead of image files in ~/.mlterm/emoji.
* Add vte 0.50.0 API symbols to libvte compatible library.
* Treat not only U+1F1000-1F6FF but also U+1F900-1F9FF characters as emoji.
* Drop "show_picture" and "add_frame" from OSC 5379.
* Bug fixes:
Fix corrupt screen in showing inline pictures if "use_ot_layout" option is
true.
- mlterm-portability.patch renamed to mlterm-cast.patch

==== mobipocket ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* None

==== okular ====
Version update (18.04.3 -> 18.08.0)
Subpackages: okular-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Fix properties dialog path not being correct on Save As
* Increase version
* Improve picture scaling issues in epub generator
* Fix crash on shutdown when having edited text forms (kde#396807)
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== open-vm-tools ====
Version update (10.2.5 -> 10.3.0)
Subpackages: libvmtools0 open-vm-tools-desktop

- After updating the project to include openSUSE_Leap_15.0 and SLE_15, the
builds for these two projects fail because of unresolved dependencies.
Some Factory configuration settings were being used for them. Need to adjust
the spec file to not use Factory configuration settings for
openSUSE_Leap_15.0 and SLE_15.
- Remove vgauthd.service from the %pre and %post section in the spec file.
This allows vmtoolsd.service to enable vgauthd if needed which creates
the vmtoolsd.service.requires/vgauthd.service symlink. (bsc#1103868)
- Add Requires: libxmlsec1-openssl1 to the spec file. This is needed when
using xmlsec1 rather than xml-ssecurity-c.
- Update to 10.3.0 (build 8931395)
+ Starting with 10.3.0, open-vm-tools builds with xmlsec1 by default (instead
of building with xml-security). To revert to the old behavior and build
with xml-security, use the option '--enable-xmlsecurity' for the
./configure command.
+ Add BuildRequires: libxml2-devel
+ Add BuildRequires: pkgconfig(xmlsec1) for all openSUSE builds
+ Use --enable-xmlsecurity when building for SLE
- Drop unnecessary patches
- 100-libtirpc.patch

==== oxygen5-icon-theme ====
Version update (5.48.0 -> 5.49.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* None

==== parley ====
Version update (18.04.3 -> 18.08.0)
Subpackages: parley-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Remove duplicate code

==== perl-Archive-Zip ====
Version update (1.60 -> 1.63)

- updated to 1.63
see /usr/share/doc/packages/perl-Archive-Zip/Changes
1.63 Wed 21 Aug 2018
- Restore missing META.yml deps (needed updated MB)
- Symlink traversal test fix [github/haarg]
- Added missing prereq Encode as suggested by CPANTS [github/manwar]
- updated to 1.62
see /usr/share/doc/packages/perl-Archive-Zip/Changes

==== perl-DBD-ODBC ====
Version update (1.58 -> 1.59)

- updated to 1.59
see /usr/share/doc/packages/perl-DBD-ODBC/Changes
1.59 2018-08-10
[BUG FIXES]
git issue 8. Setting odbc_utf8_on didn't work properly. Thanks to David
Wheeler for
reporting and helping to debug.

==== perl-DateTime ====
Version update (1.49 -> 1.50)

- updated to 1.50
see /usr/share/doc/packages/perl-DateTime/Changes
1.50 2018-08-01
- The %F strftime pattern incorrectly zero-padded numbers less than four
digits. According to POSIX::strftime, this should output the year as-is
without padding. Reported by Andy Lester. GH #83.

==== perl-IO-Socket-SSL ====
Version update (2.058 -> 2.059)

- updated to 2.059
see /usr/share/doc/packages/perl-IO-Socket-SSL/Changes
2.058 2018/08/15
- fix memleak when CRL are used.
Thanks to Franz Skale for report and patch
https://rt.cpan.org/Ticket/Display.html?id=125867
- fix memleak when using stop_SSL and threads, reported by Paul Evans
https://rt.cpan.org/Ticket/Display.html?id=125867#txn-1797132

==== perl-Log-Dispatch ====
Version update (2.67 -> 2.68)

- updated to 2.68
see /usr/share/doc/packages/perl-Log-Dispatch/Changes
2.68 2018-08-21
- Speedups to the internals to avoid re-validating the same sets of parameters
repeatedly. Based on a PR #54 from Sergey Leschenko.

==== perl-Params-ValidationCompiler ====
Version update (0.27 -> 0.30)

- updated to 0.30
see /usr/share/doc/packages/perl-Params-ValidationCompiler/Changes
0.30 2018-07-31
- Tweaked the POD formatting so that the table of contents generated by
MetaCPAN is more useful.
0.29 2018-07-31
- Make Class::XSAccessor a recommended dep, not a required one.
0.28 2018-07-31
- Added a new option for named params, "return_object". This causes the
validation sub to return an object with methods for each param rather than a
hashref. This is a great way to avoid typos in hash keys. This idea (and
some of the implementation) was shamelessly stolen from Toby Inkster's
Type::Params module.

==== perl-Quantum-Superpositions ====
Version update (2.02 -> 2.03)

- updated to 2.03
see /usr/share/doc/packages/perl-Quantum-Superpositions/Changes
2.0.2 Sun Jul 8 15:28:31 CDT 2018
- POD, thanks for Florian Schlichting

==== perl-Test-Simple ====
Version update (1.302138 -> 1.302140)

- updated to 1.302140
see /usr/share/doc/packages/perl-Test-Simple/Changes
1.302140 2018-08-13 08:00:25-07:00 America/Los_Angeles
- No Changes since last release
1.302139 2018-07-17 12:38:37-07:00 America/Los_Angeles (TRIAL RELEASE)
- Mask warning from the recent IPC fix generated when threaded Test tools are
loaded at run-time

==== perl-YAML-LibYAML ====
Version update (0.59 -> 0.72)

- update to 0.72
- update download source on metacpan
- upstream changelog:
* Update to libyaml 0.2.1 (tinita) It's forbidden now to escape single
* quotes inside double quotes
* When disabling $LoadBlessed, return scalars not refs (tinita)
* Save anchors also for blessed scalars (tinita)
* Fix format specifier/argument mismatch PR#79 @a3f++
* Travis CI: Test on Perl 5.26 PR#80 @a3f++
* Fix a C90-compatibility issue PR#81 @stphnlyd++
* Security fix Add $LoadBlessed option to turn on/off loading objects
* PR#73 PR#74 TINITA++
* Fix regex roundtrip (fixes issue#69) PR#70 (TINITA++)
* Fix loading of many regexes (fixes issue#64) PR#71 (TINITA++)
* Support standard tags !!str, !!map and !!seq instead of dying. PR#67
* (TINITA++)
* Support JSON::PP::Boolean and boolean.pm via $YAML::XS::Boolean. PR#66
* (TINITA++) Thanks also to Björn Höhrmann for SvPV_nolen()
* Apply PR#55 (@vti++)
* Dump() was modifying original data, adding a PV to numbers
* Added a test for this (TINITA++)
* Prevent warning about unused variables (see issue#59)
* Clarify documentation about exported functions
* use lib FindBin::Bin in tests, preparing for perl 5.26 where '.' gets
* removed from @INC. Fixes issue#54 TINITA++
* Use the latest libyaml sources.
* Lazy load B::Deparse for faster startup time. Applied PR/53 by
* @perlpunk++ (submitted by @carnil++ from a Debian issue as GitHub
* issue#52)
* Apply PR/48 by @perlpunk++
* Fixes memory leaks
* Apply PR/42 @perlpunk++ (fix for detecting filehandles)
* Apply PR/37 @perlpunk++ (includes PR/36 @lameventanas++)
* Apply PR/33. @andygrundman++. Solaris fixes.

==== pim-data-exporter ====
Version update (18.04.3 -> 18.08.0)
Subpackages: pim-data-exporter-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Blogilo is unmaintained now

==== pim-sieve-editor ====
Version update (18.04.3 -> 18.08.0)
Subpackages: pim-sieve-editor-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* We depend against qt5.9

==== pimcommon ====
Version update (18.04.3 -> 18.08.0)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Increase version
* Don't use deprecated api
* Fix shouldLoadSaveAutocorrection.
* Move PimCommon::SieveSyntaxHighlighterUtil to KSieveUi
* It's already initialized in header
* Fix support when we expand contact
* Make it async.
* Move code in aclmodifyjob. Next step, change it as async
* Add missing override
* Fix metainfo.yaml

==== plasma-framework ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Plasma5 plasma-framework-components plasma-framework-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* if an applet is invalid, it has immediately UiReadyConstraint
* [Plasma PluginLoader] Cache plugins during startup
* Fix fading node when one textured is atlassed.
* [Containment] Don't load containment actions with
plasma/containment_actions KIOSK restriction
* Honor BUILD_TESTING

==== prison-qt5 ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Prison5 prison-qt5-imports

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Fix Mixed to Upper mode latching in Aztec code generation

==== publicsuffix ====
Version update (20180719 -> 20180813)

- Update to version 20180813:
* Update .ID list (#703)
* Updated .bn ccTLD. Removed wildcard. (#702)
* Remove stackspace.space from PSL (#691)
* Remove XPERIA (#697)

==== purpose ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Make sure debugging for kf5.kio.core.copyjob is disabled for the test
* Don't clean up the configuration too early
* Add bluetooth plugin
* [Telegram] Don't wait for Telegram to be closed
* Prepare to use Arc's status colours in the revision drop-down list
* Honor BUILD_TESTING

==== python-libvirt-python ====
Version update (4.5.0 -> 4.6.0)

- Update to 4.6.0
- Add all new APIs and constants in libvirt 4.6.0
- spec: remove %defattr

==== python-pygame ====
Version update (1.9.3 -> 1.9.4)

- Update to 1.9.4
* python 3.7 support.
* beta pypy support.
* pygame.draw fixes
* pygame.math is not experimental anymore. Speedups and bugfixes.
* Debian, Mac homebrew, mac virtualenv, manylinux and other platform fixes.
* documentation fixes, jedi support for type ahead in editors like VSCode and
VIM.
* Surface.blits for blitting many surfaces at once more quickly.

==== qqc2-desktop-style ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Improve sizing of menus (kde#396841)
* Remove double comparison
* Port away from string-based connects
* check for valid icon

==== rubygem-autoprefixer-rails ====
Version update (9.1.2 -> 9.1.3)

- updated to version 9.1.3
* Sort properties in `rake autoprefixer` alphabetically.
* Fix old Firefox gradient prefix.

==== rubygem-public_suffix ====
Version update (3.0.2 -> 3.0.3)

- updated to version 3.0.3
CHANGED: Updated definitions.

==== rubygem-turbolinks ====
Version update (5.1.1 -> 5.2.0)

- updated to version 5.2.0
* Introduces deferred snapshot caching to improve navigation performance and
allow Stimulus disconnect() callbacks to prepare the page to be cached (#390)
* Modernizes the test suite (#404)
* Fixes missing event.data.newBody on turbolinks:before-render events when
rendering error pages (#406)
* Adds a CHANGELOG.md file which points to the GitHub Releases index
* Corrects several errors in documentation examples
* Updates RubyGems installation instructions

==== rubygem-turbolinks-source ====
Version update (5.1.0 -> 5.2.0)

- updated to version 5.2.0
no changelog found

==== samba ====
Version update (4.8.2+git.30.690aa93c189 -> 4.8.4+git.37.a7a861d7982)
Subpackages: libdcerpc-binding0 libdcerpc-binding0-32bit libdcerpc0
libdcerpc0-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0
libndr-nbt0-32bit libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit
libnetapi0 libnetapi0-32bit libsamba-credentials0 libsamba-credentials0-32bit
libsamba-errors0 libsamba-errors0-32bit libsamba-hostconfig0
libsamba-hostconfig0-32bit libsamba-passdb0 libsamba-passdb0-32bit
libsamba-util0 libsamba-util0-32bit libsamdb0 libsamdb0-32bit libsmbclient0
libsmbconf0 libsmbconf0-32bit libsmbldap2 libsmbldap2-32bit libtevent-util0
libtevent-util0-32bit libwbclient0 libwbclient0-32bit samba-client
samba-client-32bit samba-doc samba-libs samba-libs-32bit samba-winbind
samba-winbind-32bit

- Update to samba-4.8.4+git.37.a7a861d7982;
+ CVE-2018-1139: Weak authentication protocol allowed;
(bsc#1095048); (bsc#13360);
+ CVE-2018-1140: Denial of Service Attack on DNS and LDAP server;
(bsc#1095056); (bso#13466); (bso#13374);
+ CVE-2018-10858: Insufficient input validation on client directory
listing in libsmbclient; (bsc#1103411); (bso#13453);
+ CVE-2018-10918: Denial of Service Attack on AD DC DRSUAPI server;
(bsc#1103414); (bso#13552);
+ CVE-2018-10919: Confidential attribute disclosure from the AD
LDAP server; (bsc#1095057); (bso#13434);
+ s3:winbind: winbind normalize names' doesn't work for users;
(bso#12851);
+ winbind: Fix UPN handling in canonicalize_username(); (bso#13369);
+ s3: smbd: Fix SMB2-FLUSH against directories; (bso#13428);
+ samdb: Fix building Samba with gcc 8.1; (bso#13437);
+ s3:utils: Do not segfault on error in DoDNSUpdate(); (bso#13440);
+ smbd: Flush dfree memcache on service reload; (bso#13446);
+ ldb: Save a copy of the index result before calling the
+ lib/util: No Backtrace given by Samba's AD DC by default;
(bso#13454).
+ s3: smbd: printing: Re-implement delete-on-close semantics for
print files missing since 3.5.x; (bso#13457).
+ python: Fix talloc frame use in make_simple_acl(); (bso#13474).
+ krb5_wrap: Fix keep_old_entries logic for older Kerberos
libraries;(bso#13478).
+ krb5_plugin: Add winbind localauth plugin for MIT Kerberos;
(bso#13480).

==== schily ====
Subpackages: libdeflt1_0 libfind2_0 librmt1_0 libschily1_0 spax star

- Run make config before build instead of in the middle,
to have reproducible builds (boo#1102408)
- Remove schily-2018-05-25_star_bufferoverflow.patch
(the bug is long gone, the patch has no effect)
- add patches from the star package
* schily-2018-05-25_star_configuration.patch
* schily-2018-05-25_star_no_fsync.patch
* schily-2018-05-25_star_lock.patch
* schily-2018-05-25_star_detect_gzip_failures.patch
* schily-2018-05-25_star_bufferoverflow.patch
* schily-2018-05-25_star_use_ssh_by_default.patch
* schily-2018-05-25_star_mk.patch
* schily-2018-05-25_star_selinux.patch
- add missing BuildRequires for star:
* autoconf (because of selinux patch)
* libacl-devel
* libattr-devel
* libselinux-devel
* libtool
- install README-FIRST (as schily-rmt) documentation
- add noreplace for %_sysconfdir/default/rmt and
%_sysconfdir/default/star
- move srmt from sbindir to bindir
- do not ship star_sym and suntar
- Update to new upstream release 2018.05.25
* star: user name, group name, path and linkpath are now
automatically added to the POSIX.1-2001 extended header in
case that they include non-ASCII characters (outside the
7-bit range).
- Remove gccwarns.diff (fixed upstream), gcc48wa.diff (we no
longer have gcc-4.8)
- Update to new upstream release 2018.05.17
* smake: Now using TYPE_MAXVAL(time_t) in gnewtime() instead of
the method from 1996, to work around a problem with gcc-8.1
and clang-6.0.
* mkisofs: The link count computation did incorrectly count all
directory entries for large (multi extent) files. This
resulted in a link count that was "real number" + (sizeof
file / 2GB)
* mkisofs: File meta data for UDF directories that refer to a
Rock Ridge relocated directory had been emitted as all
zeroes.
* star: nanosecond timestamp support
* libfind: nanosecond timestamp support
* star: Added a new archive format "epax". This is the same as
"pax", but it always includes a POSIX.1-2001 extended header
with timestamps with nanosecond resolution.
- Update to new upstream release 2018.05.02
* bsh: fixed a NULL deref when the file content was "#!"
* bsh: Avoid a coredump from expressions like
"$2222222222222222222" that cause an integer overflow while
converting the number.
* mkisofs: fixed crash during Joliet info creation
* Better support for Address Sanitizer
* (s)patch: CVE-2018-1000156 was fixed
* star: star -diff is now able to compare nanoseconds in
timestamps.
- Drop mkisofs-j-crash.diff (fixed upstream)
- Add gccwarns.diff to address some undefined behavior.
- Add update-alternatives handling for (s)rmt and (s)mt
- Add spax and star subpackages
- Add iconv-name.diff; rename cp10000 to macintosh to workaround
glibc [boo#1089126]
- Add mkisofs-j-crash.diff
- Move to schily-2018.03.16 source tarball
* mkisofs and smake moved their config files to /usr/share/lib.
* smake: when an implicit target is made, the result is now
searched in the list of obj-directories.
- Drop fix_chrp_boot.patch (applied upstream)
- Use cdrecord.spec as a base for schily.spec. The subsequent
changelog entries are from cdrecord.changes.
- fix_chrp_boot.patch: chrp-boot option doesn't take any parameters
but seems to require one that it doesn't use. Fix it uses no
parameters. (bnc#1084893)
- Always install to /usr/lib/siconv since otherwise mkisofs doesn't
find charsets. Needs to be fixed properly later. (bnc#1084892)
- Update to new upstream release 3.02~a09
* Cdda2wav now works around a Linux glibc bug that causes stderr
to be illegally buffered.
* `cdda2wav -vall` no longer clobbers out-fd= to become stdin
when compiled in 64 bit mode.
- Fix build on older distros (e.g. SLE11) -- no caps support in RPM
- Remove build dependency on mmv (not present on SLE, and its usage
is easily replaced with a small shell script).
- Fix build on older distros (makedepend)
- Update to new upstream release 3.02~a07
* mkisofs: deduplication for files)
- Update to new upstream release 3.02~a06
* libscg: fixed a copy/paste problem in the Linux transport that
could cause libscg to assume a timeout when no timeout occurred.
* libscg: add a new generic option interface.
* libscg: New option "ignore-resid" to work around a Linux kernel
problem.
* mkisofs: better warning messages for rotten directories when in
multi-session mode.
- Update to new upstream release 3.02~a05
* mkisofs now tries to be more immune against rotten iso images
when in multi session mode.
* mkisofs no longer tries to access a string past the null byte
when dealing with Joliet.
* mkisofs fixed a bug related to sorting with multi extent files
(greater than 4 GB).
- Update to new upstream release 3.02~a04
* Support for DVD-Audio was added to mkisofs.
* Several bug fixes in mkisofs and mkisofs/diag/* programs to make
them more robust against rotten ISO images.
- Update to new upstream release 3.02~a03
* isoinfo no longer eats up all memory when an ISO image
with a directory loop is specified.
- Update to new upstream release 3.02~a02
* Many smaller "isoinfo" enhancements including support for
relocated directories.
- Update to new upstream release 3.02~a01
* libparanoia: work around a bug that resulted from uninitalized
statistics data for C2 checks.
* cdda2wav now supports sound output on Linux again.
- Update to new upstream release 3.01
* Final version
- Update to new upstream release 3.01~a31
* Added compile support for Win-10 using non-automake-aware make
implementations. Add some workarounds for MinGW32 compilation.
- Update to new upstream release 3.01~a30
* Added a workaround (with autoconf) for a Cygwin bug with
[#]pragma weak.
- Update to new upstream release 3.01~a29
* (Several changes for better Haiku compatibility.)
* Some code fixes include results from automated tests.
- Update to new upstream release 3.01~a28
* Build system changes only: manpages are installed just once
- Update to new upstream release 3.01~a27
* dlopen emulation for certain platforms
- Update to new upstream release 3.01~a26
* Add the HELIOS UNICODE mapping code. This needs to be done at
UCS-2 level for Joliet and UDF (instead of UTF-8) and only for
Rock Ridge (in case of a UTF-8 based target locale) using UTF-8
based translations.
* Make the Apple extensions work again with "mkisofs -find"
- run permission handling code unconditionally. bnc#899718
- Update to new upstream release 3.01~a25
* Precursory work for localization
- Run spec-beautifier for spec files
- Reenable missing capability support [bnc#899718]
- Update package metadata: new upstream URLs
- Remove untracked old changes file
- Update to new upstream release 3.01~a24
* isoinfo now allows the user to extract all files from an ISO
image based on the built-in find(1) command. This works even for
milti-extent files (files > 4 GB).
* Some enhancements for the libschily *at() function emulations
have been added.
- Update to new upstream release 3.01~a23
* Cdrecord now prints timediffs also in hours:minutes:seconds.
* Cdda2wav no longer includes "c2check" in the "proof" paranoia
option to avoid a firmware bug in a TSSTcorp drive.
* Mkisofs has slightly-reduced CPU time requirements.
* A problem in isoinfo has been fixed; it did not always print
timestamps in `-find -ls` mode.
- Update to new upstream release 3.01~a22
* mkisofs includes a new option, -legacy, that allows it to
reenable the short options -H/-L/-P; these have been disabled in
2006 for compatibility with scripts that have not been updated
during the past 10 years.
* libsiconv now only tries to open a file when the argument
includes a slash in its name.
* libschily::printf() now includes support for %n$ argument
reordering for the first 30 arguments.
- Drop ppc64le.patch (merged upstream)
- Update to new upstream release 3.01~a21
* This release adds some workarounds for compiling with MinGW. New
functions xcomerr(), xcomerrno(), fxcomerr(), and fxcomerrno() in
libschily. A bug in libschily/format.c that caused %.*s to be
printed incorrectly has been fixed. Some bugs in the mkisofs man
page have been fixed.
- enable ppc64le architecture (ppc64le.patch)
- Update to new upstream release 3.01~a20
* libparanoia and cdda2wav have been enhanced to give much better
results with slightly bad media and new hardware.
- Enable symbol versions
- Update to new upstream release 3.01~a19
* This release added different fine-grained privilege handling that
keeps root privileges in cases where cdrtools have been called by
a privileged program.
* Libfind now supports "event port" type files.
* Emulations for *at() functions have been added to libschily.
- Mark the mkisofs program (combined work) as GPL-2.0 due to
some GPL2-only sources (mkisofs/inode.c).
- Add gcc48wa.diff to work around broken gcc-4.8 behavior
- Update to new upstream release 3.01a18
* This release fixes a copy+paste bug in the Linux support code for
fine-grained privileges.
* Libfind no longer leaks filedescriptors with -empty.
- Update to new upstream release 3.01a17
* Automatic support has been added for ARMv5 and ARMv6.
- Update to 3.01a16
* libparanoia: memset() call in i_silence_match() now uses the
correct size instead of sizeof (avec)
* libparanoia: Use dynamic arrays instead of alloca()/malloc()
if available
- Update BuildRequires, add License: fields, use %optflags, update
descriptions and wrap at 70 cols
- Remove unused static libraries and dissolve devel subpackage
(now provided by libschily-devel, libscg-devel)
- Update to new upstream release 3.01~a15
* This release warns about lack of fine-grained permissions
- Temporarily deactivate extra permissions for factory submission
while permissions package is not updated
- Add cdda2wav.{easy,paranoid,secure}. permissions.d entries need
to be in the same package as the file they are describing, or we
get errors during post-build verification.
- Use tildeversion; according to author, 3.01a14 sorts before 3.01
- Resync caps list from permissions.d files to .spec file
- actually fscaps are also managed by "permissions", leave the
%set_permissions calls in.
- reenabled the sample permission snippets for testing.
- Do not run set_permissions when fscaps are in use
- commented out the setuid root equivalent capabilities, cap_sys_admin
and cap_dac_override. (bnc#550021)
- commented out unnecessary and also dangerous cap_net_bind_service
(bnc#550021)
- add correct permission handling also for readcd and cdda2wav
- Linux fscaps support in the RPM package (bnc#550021)
- Commented out permissions.d files and
ran spec cleaner.
- Update to 3.01a14
* new autoconf tests for sys/capability.h and cap_*() functions
from Linux -lcap
* trying to support suid-root-less installation of cdrecord on Linux.
NOTE: You need "file caps" support built into your Linux installation.
* include/schily/stat.h now contains macros to set the nanoseconds
in timestamps in a OS independent way
* mkisofs now identifies itdelf by default (inside the APPID string)
as being UDF capable.
* mkisofs now supports additional file types with UDF: named pipes,
sockets, character devices, block devices
* mkisofs now supports all three UNIX times with microsecond granularity
in UDF
* mkisofs now sets correct user/group/permission for symlinks in UDF
* mkisofs now supports setuid, setgid, sticky bits in UDF
- Dissolve Obsoletes cycle between cdrkit (source package "wodim")
and cdrtools. Conflict tags have been submitted to cdrkit.
- Update to 3.01a12
* mkisofs: mkisofs now reserves more space for the file names
to avoid a path buffer overrun
* mkisofs: fixed a bug that caused to put more than one UDF
direcory entry for a file in case that the file is a ISO-0660
multi-segment file.
* mkisofs: fixed a bug that caused the wrong start sector address
to be used for UDF in case that the file is a ISO-9660
multi-segment file and the -sort option was used.
* libschily: libschily::fexecv() now allows to use the parameter
"ac" with the value -1 to indicate that the arg count is to be
determined by the NULL pointer at the end of the arg list
* new include files include/schily/err_*.h are used to
encapsulate #error CPP statements that would otherwise always
prevent compilation with K&R compilers
* mkisofs: new option -ignore-error alows to continue on some
errors
* mkisofs: Avoid a 32 bit integer overflow while computing sector
addresses for Rock Ridge CE entries
- Update to 3.01a08
* introduce a dependency for man page subdirectories to allow
syncing parallel make calls.
* libschily: getperm.c now correctly supports umask +w
* libscg & cdrecord: struct scsi_inquiry is now using a union
around the vendor ID strings in order to avoid incorrect buffer
overflow warnings from GCC-4.x
* mkisofs: while introducing the new option -modification-date,
we did accidently remove the code to set up the creation date
in te PVD. Now creation date again contains correct data.
- Update to version 3.01a07 Fixed non position independant build of
cdrecord with "COPTX=-fPIE" and "LDOPTX=-pie -Wl,-pie"
- Disabled parallel build.
- Update to 3.01a06.
- Update to 3.01a05 via source service.
- Fixed provides, obsoletes and requires to stop cdrtools from
requiring packages from wodim.
- Updated to 3.00
- Spec file updates:
* Changed the Name: entry to cdrtools and added cdrecord as a subpackage.
* Changes based on rpmdevtools templates and spec-cleaner run.
* Updates in Summary: and %description sections.
* Removed meta package schily-cdrtools and used the main package for
cdrkit-cdrtools-compat removal.
* Added Conflicts: for cdda2wav and mkisofs (with icedax and genisoimage
respectively).
* Use smp_flags with make.
* Updates in %install section. Most important:
[#] Remove installed documentation and install it manually in the %files
sections.
[#] Install additional programs.
[#] Don't run fdupes in /etc/permissions.d/ (some may want to have different
contents in each file).
* Updates in %files sections.
* Removed the %changelog entries from the spec file.
- A lot of cleanup fixes in the spec file, e.g. corrected paths,
added debuginfo. Thanks to K?i?tof ?elechovski for the patches.
- Small fixes to satisfy rpmlint.
- Updated to 3.01a01
- Updated to final 3.00
- fix requires(pre) -> requires(post)
- Reinstalled Prerequisites as Requires(pre)
- Updated to 2.01.01a77
- Updated to 2.01.01a74
- Updated to 2.01.01a72
- disable the permissions override
- Updated to 2.01.01a70
- Updated to 2.01.01a69
- Updated to 2.01.01a68
- removed /etc/permissions.d/ entries for readcd, rscsi and cdda2wav again
- removed conflicting Provides: from schily-cdrtools package
- Updated to a67
- added /etc/permissions.d/ entries for readcd, rscsi and cdda2wav as well
- Once again permissions.d/ files, fixed spec file.
- Fixed wrong naming of permissions.d/ files.
- import from henneodernich home repo
- removed up %post illegal operation and instead drop in permission.d snippets
4711 in easy mode, 0711 in secure and paranoid modes.
added rpmlintrc to allow this temporarily
- removed unused obsoletes
- conflict with cdrkit-cdrtools-compat instead of obsoletes
- alsa-devel buildrequires

==== solid ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== sonnet ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Sonnet: setLanguage should schedule a rehighlight if highlight is enabled
* Use the current hunspell API
- Add Fix_Leap_42_3_build.patch to use the old hunspell api in leap 42.3.

==== spectacle ====
Version update (18.04.3 -> 18.08.0)
Subpackages: spectacle-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Rework rectangle/arrow key handling to avoid "stuck edges" and 0x0px
rectangle
* Add license header to TextLabel.qml
* Fix rendering of on-screen help texts for fractional scaling
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== step ====
Version update (18.04.3 -> 18.08.0)
Subpackages: step-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Warning--

==== stoken ====
Version update (0.81 -> 0.92)

- Version update to 0.92:
* Fix build with new libtomcrypt
* support nette 3.x series
* See CHANGES for details

==== sweeper ====
Version update (18.04.3 -> 18.08.0)
Subpackages: sweeper-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Remove outdated Qt definitions
* Require at least Qt 5.4.0
* Make sure that it builds with strict compile flags
* Use same kf5 version
* Warning--
* Increase version for next Applications release

==== syndication ====
Version update (18.04.3 -> 18.08.0)

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* None
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Use Q_REQUIRED_RESULT
* Remove the unused OutputRetriever
* Replace KRandom with QUuid to ensure uniqueness
* Remove Syndication::FileRetriever

==== syntax-highlighting ====
Version update (5.48.0 -> 5.49.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* CoffeeScript: fix templates in embedded JavaScript code & add escapes
* Exclude this in Definition::includedDefinitions()
* Fix compiler warning -Wimplicit-fallthrough
* Use in-class member initialization where possible
* add functions to access keywords
* Add Definition::::formats()
* Add QVector<Definition> Definition::includedDefinitions() const
* Add Theme::TextStyle Format::textStyle() const;
* CSS: fix test reference of the previous commit
* C++: fix standard floating-point literals
* CSS: update syntax and fix some errors
* C++: update for c++20 and fix some syntax errors
* CoffeeScript & JavaScript: fix member objects. Add .ts extension in JS
(kde#394365,kde#366797)
* Lua: fix multi-line string (kde#395515)
* RPM Spec: add MIME type
* Python: fix escapes in quoted-comments (kde#386685)
* haskell.xml: don't highlight Prelude data constructors differently from
others
* haskell.xml: remove types from "prelude function" section
* haskell.xml: highlight promoted data constructors
* haskell.xml: add keywords family, forall, pattern
* Honor BUILD_TESTING

==== telegram-purple ====
Subpackages: libpurple-plugin-telegram libpurple-plugin-telegram-lang
pidgin-plugin-telegram

- Update grammar in summaries.
- Add telegram-purple-1.3.1-disable-werror.patch: Disable -Werror.

==== threadweaver ====
Version update (5.48.0 -> 5.49.0)

- Update to 5.49.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.49.0.php
- Changes since 5.48.0:
* Honor BUILD_TESTING

==== transactional-update ====
Version update (2.5 -> 2.6)

- Update to version 2.6
- Add --interactive and --non-interactive options to change the default
interactivity for zypper calls. For previously non-interactive calls (e.g.
dup) these options makes it possible to pick the correct solution in case
of conflicts or make sure that a script will never be stuck at an input
prompt.
- Add kured reboot support
- Tries to clean up temporary files and mount points if transactional-update
quits unexpectedly
- Remove trancactional-update-helper (replaced by zypper options)
- Create /var/lib/zypp if not available (boo#1104452)
- Robustify parsing zypper output (boo#1105992)
- Various small fixes
- Changed permissions of systemd script again

==== umbrello ====
Version update (18.04.3 -> 18.08.0)
Subpackages: umbrello-lang

- Update to 18.08.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.08.0.php
- Changes since 18.07.80:
* Never implemented context menu entry for adding actor, usecase, component,
artifact and activity from a widget
* Never implemented context menu entry for adding a subsystem port removed
* Never implemented context menu entry for adding a subsystem removed
* Remove context menu entry for adding port on component diagrams
* Fix position of adding note entry to context menu entries
* Position and presence of adding plain text unified using context menu for
diagrams and widgets
* Fix 'Set input focus on first input field in the general properties dialog
page' (kde#396844)
- Update to 18.07.80
* New feature release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.07.80.php
- Changes since 18.04.3:
* Too many changes to list here

==== wiggle ====
Version update (1.0 -> 1.1)

- Update to 1.1:
* Fix endian checks as per austin group definitions of endian.h
* Minor man page fixes

==== xmlsec1 ====
Subpackages: libxmlsec1-1 libxmlsec1-nss1

- Add rplintrc to avoid bogus errors:
* xmlsec1-rpmlintrc
- Fixed (bsc#1104876). Added: Requires: %{libname} = %{version} to each module
in the spec file. This will ensure that when one of the modules is installed
the corresponding version of libxmlsec1-1 will also be installed/upgraded.

==== xterm ====
Version update (332 -> 335)
Subpackages: xterm-bin

- Patch #335 - 2018/08/14
* add colorInnerBorder resource to make a change from patch
[#334] configurable (reports by H Merijn Brand, Gabriele
Balducci).
- Patch #334 - 2018/08/12
* modify Imakefile to reflect the fact that NetBSD no longer
has a working termcap emulation.
* add resource-setting validShells which can be used to augment
the system's /etc/shell (prompted by discussion with Paul
Lampert).
* stifle some useless warnings from lintian in test-packages.
* add the ncurses extension ?RGB? to the responses for the
termcap-query feature.
* improved getopts-handling in sample scripts.
* fix some warnings from gcc8 and clang --analyze.
* update note about incorrect documentation for DECRQSS to
include VT525 (report by Markus Schmidt).
* correct check for default-values in rectangular parsing; a
zero counts as a missing or default parameter
(report/testcase by Markus Schmidt).
* correct some ranges in the ambiguous[] table in wcwidth
(adapted from patch by KUGA Tsutomu).
* fix a special case with faint video attribute incorrectly
combined with default color.
* add private control XTREPORTSGR for reporting
video-attributes and color on a rectangle, and script
report-sgr.pl to demonstrate it.
* modify some of the markup in ctlseqs.ms to work around
groff's reassignment of ASCII punctuation characters as
documented in groff_char(7).
* treat ECMA-48 SGR 6 the same as SGR 5.
* add private controls XTPUSHSGR and XTPOPSGR for
saving/restoring the current video-attributes on a stack
(adapted from patch by Dan Thompson).
* modify DECRPM response for logging enable to indicate its
state even when enabling/disabling it is not allowed.
* implement DECSNLS
* implement DECRSPS
* improve fill-color for double-buffer configuration, which was
sharing a graphic context with the cursor.
* fix a couple of cases where double-sized VT100 characters
were not clipped, seen in Joe Smith's VT100 torture test.
* color the inner border using the same borderColor as the
outer border, rather than filling with the VT100's default
background.
* change encoding of ?THANKS? to UTF-8.
* modify handling of DECELR to recognize MotionNotify events
again, amending a check for allowMouseOps which limited that
to button-events in patch #328 (Olaf Rogalsky).
* fix some screen-painting problems with left/right margins
when using insert-line or delete-line (report/testcase by
Martin Hostettler). also fix similar case with
index/reverse-index.
* several minor performance improvements using macros, e.g.,
inline checks for character width.
* add DECSCPP and DECSLPP to DECRQSS.
* implement DECSCPP.
* implement DECCIR and DECTABSR presentation reports.
* modify checksum computation for DECRQCRA to treat
uninitialized cells as blanks rather than nulls.
* drop custom-entity from HTML-dump, use UTF-8 for &nbsp;
(Debian #902381).
* modify display of non-BMP characters when using bitmap fonts
to show a null/empty box rather than the replacement
character which was used in cleanup changes for patch #233
(report by Christian Weisgerber).
* when setting up clipping rectangle for Xft, allow for the
case where xterm is only displaying a combining character,
where the base was already written (report by Joshua
Crowgey).
* allow reset Xft's state if switching font-sizes when
double-buffering is used.
* fix repainting, e.g., on resize, when double-buffering is
used with Xft (patch by Daniel Colascione).
* correct some interchanged pairs of symbols in
unicode/keysym.map (Brad Town).
* improve configure macros CF_GCC_WARNINGS, CF_GNU_SOURCE,
CF_POSIX_C_SOURCE, CF_TRY_XOPEN_SOURCE, CF_XOPEN_SOURCE,
CF_X_ATHENA_CPPFLAGS.
* modify logFile resource to interpret ?-? as the standard
output (adapted patch by Colum Paget).
* improve documentation of Tek4014 menu options; fix a case
where the Tek4014 window was not displayed before switching
modes.
* re-correct parameter for pid used for DECCKSR, DECRQCSR (see
xterm #315).
* hard/soft reset now resets the cursor-blinking state that may
have been set via escape sequences; the cursor-blinking
menu-entry feature is unmodified (report by Matthieu Herrb).
* update config.guess, config.sub
- Patch #333 - 2018/05/03
* ensure that i18n is enabled if input-method is enabled.
* modify logic for pre-edit to update spot-location while the
cursor is invisible (Kakoune #1940).
* change default icon to newer one, "mini.xterm".
* install a complete set of icons, to simplify post-install
customization.
* add resource disallowedPasteControls to extend filtering of
control characters from pastes.
* add print-on-error action-hook, and document action-hooks for
dump-html, dump-svg.
* provide action-hook for print-immediate, which was available
only as a menu-item (report by Rastislav Barlik).
* continue to improve notes in ctlseqs.ms which mention where
various controls originated.
* add case to accept ECMA-48's bogus SD, but document the issue
in ctlseqs.ms.
* add control sequence for loading XPM-icon file, using the
analogous control sequence from shelltool/dtterm.
* add -report-icons option, to report on XPM-icon and title-bar
updates.
* correct a discrepancy between locator-reports for VT220 vs
VT330.
* add window-ops control sequences to complement existing ones
for reporting window-position and text-area size with reports
for text-area position and window-size.
* display vt52 graphics mode characters.
* correct case-statement for window-ops 10, overlooked since
some window managers equate vertical-maximize and
horizontal-maximize window hints with full-screen maximize.
- Copy updated config.sub config.guess files into vttest sources

==== zypper ====
Version update (1.14.6 -> 1.14.8)
Subpackages: zypper-aptitude zypper-log

- Support listing gpgkey URLs in repo files (bsc#1088037)
- Check for root privileges in zypper verify and si (bsc#1058515)
- XML <install-summary> attribute `packages-to-change` added
(bsc#1102429)
- Add expert (allow-*) options to all installer commands
(bsc#428822)
- Sort search results by multiple columns (bsc#1066215)
- man: Strengthen that `--config FILE' affects zypper.conf,
not zypp.conf (bsc#1100028)
- BuildRequires: libzypp-devel >= 17.6.0
- version 1.14.8
- Set error status if repositories passed to lr and ref are not
known (BSC #1093103)
- Do not override table style in search (fixes #171)
- Fix out of bound read in MbsIterator (fixes #167)
- Add --supplements switch to search and info (fixes #184)
- Add setter functions for zypp cache related config values to
ZConfig (fixes #180)
- BuildRequires: libzypp-devel >= 17.3.2
- version 1.14.7


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups