Mailinglist Archive: opensuse-factory (244 mails)

< Previous Next >
Re: [opensuse-factory] Tumbleweed snapshot 20180722: xserver 1.20 breaks optimus
  • From: Peter Suetterlin <pit@xxxxxxxxxxx>
  • Date: Tue, 24 Jul 2018 15:12:16 +0100
  • Message-id: <20180724141216.GB10279@woodstock.pitnet>
Andrei Borzenkov wrote:
On Tue, Jul 24, 2018 at 3:53 PM, Peter Suetterlin <pit@xxxxxxxxxxx> wrote:
Dominique Leuenberger wrote:

Packages changed:

xorg-x11-server (1.19.6 -> 1.20.0)

As reported in boo#1099974 already three weeks ago, 1.20 breaks
bumblebee/optirun on kmodesetting driver. As the intel driver isn't really
useable either this really is a showstopper for many laptops.

Please provide exact steps to install bumblebee (repositories,
versions, what was done after installation of packages, how bumblebee
was configured). I may try to reproduce it using Live ISO.

I'm using bumblebee repo,
http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_Tumbleweed

From that I have installed
VirtualGL bbswitch bbswitch-kmp-default bumblebee dkms nvidia-bumblebee primus
(I also have the 32bit packages installed, as I mostly use it for games that
still often come as 32bit).
The install will download the latest nvidia driver and compile it. So you
need kernel build environment.

AFAIR the only change I made to the default setup was setting "Bridge=primus"
in /etc/bumblebee/bumblebee.conf. But it is almost two years since I set it
up, I might have forgotten something....
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups