Mailinglist Archive: opensuse-factory (244 mails)

< Previous Next >
Re: [opensuse-factory] rubygem-mysql2 update breaks rails 4.2
On Thu, 2018-07-19 at 08:58 +0200, Maximilian Meister wrote:
good morning,

i just noticed that velum [0] has gotten unresolvable because of a
rubygem-mysql2 minor version bump (from 0.4 to 0.5)

as i could find out in a github issue [1], rails 4.2.x probably won't
update the requirement to mysql 0.5.x anymore. the only way to avoid
patching rails in this regard would be to stick with 0.4.x (i think)

what would be the best thing to do here?

can we add a rubygem-mysql2_0_4 package?

That is an option, indeed (or reverting rubygem-mysql2 back to 0.4.x as
a quick fix - if nothing depends on 0.5 yet)

@Manuel: you did this upgrade for Tumbleweed: what's your view/opinion?

Dominique
< Previous Next >
References