Mailinglist Archive: opensuse-factory (244 mails)

< Previous Next >
[opensuse-factory] Vagrant and Ruby 2.5 in openSUSE
I am unable to install some plugins for vagrant, e.g. vagrant-virtlib and
vagrant-kvm. Vagrant will try to compile these plugin first and install the
result as a Ruby gem. An number of devel packages are required for a
successful compilation. One of those is ruby-devel.

The reason for failing to compile, I think, is because Vagrant is shipped with
an embedded Ruby. This embedded version is 2.4 and openSUSE ships Ruby 2.5 and
hence no proper devel package for Ruby 2.4 is installed. I have tried to
manually install Ruby 2.4 using rvm. Although I could tell I had Ruby 2.4
running by looking at the output of 'ruby --version', not all necessary Ruby
files had been installed it seemed as the gem generation was still failing
with the same error.

My question is how do I resolve the above issue of having an embedded Ruby 2.4
within vagrant and not having the devel packages for that embedded version?

Regards.
Gerben


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups