Mailinglist Archive: opensuse-factory (368 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180622 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180622

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
attica-qt5 (5.46.0 -> 5.47.0)
baloo5 (5.46.0 -> 5.47.0)
bijiben (3.28.1 -> 3.28.3)
bluez (5.49 -> 5.50)
bluez-qt (5.46.0 -> 5.47.0)
breeze5-icons (5.46.0 -> 5.47.0)
cairo
chrome-gnome-shell
elfutils (0.171 -> 0.172)
evolution (3.28.2 -> 3.28.3)
evolution-data-server (3.28.2 -> 3.28.3)
evolution-ews (3.28.2 -> 3.28.3)
frameworkintegration (5.46.0 -> 5.47.0)
gnome-calculator (3.28.1 -> 3.28.2)
gnome-logs (3.28.2 -> 3.28.3)
gpg2 (2.2.7 -> 2.2.8)
graphene (1.8.0 -> 1.8.2)
gspell (1.8.0 -> 1.8.1)
gstreamer-plugins-base
gtk3
gtksourceview (3.24.7 -> 3.24.8)
harfbuzz (1.7.6 -> 1.8.1)
jsonrpc-glib (3.28.0 -> 3.28.1)
kactivities-stats (5.46.0 -> 5.47.0)
kactivities5 (5.46.0 -> 5.47.0)
karchive (5.46.0 -> 5.47.0)
kate
kauth (5.46.0 -> 5.47.0)
kbookmarks (5.46.0 -> 5.47.0)
kcmutils (5.46.0 -> 5.47.0)
kcodecs (5.46.0 -> 5.47.0)
kcompletion (5.46.0 -> 5.47.0)
kconfig (5.46.0 -> 5.47.0)
kconfigwidgets (5.46.0 -> 5.47.0)
kcoreaddons (5.46.0 -> 5.47.0)
kcrash (5.46.0 -> 5.47.0)
kdbusaddons (5.46.0 -> 5.47.0)
kdeclarative (5.46.0 -> 5.47.0)
kded (5.46.0 -> 5.47.0)
kdelibs4support (5.46.0 -> 5.47.0)
kdesu (5.46.0 -> 5.47.0)
kdewebkit (5.46.0 -> 5.47.0)
kdnssd-framework (5.46.0 -> 5.47.0)
kdoctools (5.46.0 -> 5.47.0)
kemoticons (5.46.0 -> 5.47.0)
kfilemetadata5 (5.46.0 -> 5.47.0)
kglobalaccel (5.46.0 -> 5.47.0)
kguiaddons (5.46.0 -> 5.47.0)
kholidays (5.46.0 -> 5.47.0)
khtml (5.46.0 -> 5.47.0)
ki18n (5.46.0 -> 5.47.0)
kiconthemes (5.46.0 -> 5.47.0)
kidletime (5.46.0 -> 5.47.0)
kimageformats (5.46.0 -> 5.47.0)
kinit (5.46.0 -> 5.47.0)
kio (5.46.0 -> 5.47.0)
kirigami2 (5.46.0 -> 5.47.0)
kitemmodels (5.46.0 -> 5.47.0)
kitemviews (5.46.0 -> 5.47.0)
kjobwidgets (5.46.0 -> 5.47.0)
kjs (5.46.0 -> 5.47.0)
kjsembed (5.46.0 -> 5.47.0)
kmod
knewstuff (5.46.0 -> 5.47.0)
knotifications (5.46.0 -> 5.47.0)
knotifyconfig (5.46.0 -> 5.47.0)
kpackage (5.46.0 -> 5.47.0)
kparts (5.46.0 -> 5.47.0)
kpeople5 (5.46.0 -> 5.47.0)
kplotting (5.46.0 -> 5.47.0)
kpty (5.46.0 -> 5.47.0)
kross (5.46.0 -> 5.47.0)
krunner (5.46.0 -> 5.47.0)
kservice (5.46.0 -> 5.47.0)
ktexteditor (5.46.0 -> 5.47.0)
ktextwidgets (5.46.0 -> 5.47.0)
kunitconversion (5.46.0 -> 5.47.0)
kwallet (5.46.0 -> 5.47.0)
kwayland (5.46.0 -> 5.47.0)
kwidgetsaddons (5.46.0 -> 5.47.0)
kwindowsystem (5.46.0 -> 5.47.0)
kxmlgui (5.46.0 -> 5.47.0)
kxmlrpcclient5 (5.46.0 -> 5.47.0)
libKF5ModemManagerQt (5.46.0 -> 5.47.0)
libKF5NetworkManagerQt (5.46.0 -> 5.47.0)
libdazzle (3.28.2 -> 3.28.3)
libgcrypt (1.8.2 -> 1.8.3)
libgpod
libgweather (3.28.1 -> 3.28.2)
libimobiledevice (1.2.0+git20170122.45fda81 -> 1.2.0+git20180427.26373b3)
libjpeg-turbo
liblouis (3.5.0 -> 3.6.0)
libqt5-qtbase
logrotate
messagelib
obs-service-source_validator (0.16 -> 0.17)
osinfo-db (20180531 -> 20180612)
ovmf (2018+git1525854636.13e3f8c03339 -> 2018+git1528497654.eb5943134630)
oxygen5-icon-theme (5.46.0 -> 5.47.0)
patterns-kde
perl-Net-Netmask (1.9022 -> 1.9101)
pesign-obs-integration
plasma-framework (5.46.0 -> 5.47.0)
plasma5-pk-updates
prison-qt5 (5.46.0 -> 5.47.0)
procps (3.3.14 -> 3.3.15)
purpose (5.46.0 -> 5.47.0)
python-cryptography (2.2.1 -> 2.2.2)
solid (5.46.0 -> 5.47.0)
sonnet (5.46.0 -> 5.47.0)
syntax-highlighting (5.46.0 -> 5.47.0)
threadweaver (5.46.0 -> 5.47.0)
totem (3.26.0 -> 3.26.1)
totem-pl-parser (3.26.0+20180301.0091a56 -> 3.26.1+20180614.d22b155)
virt-manager
yast2-tftp-server (4.0.2 -> 4.1.0)
yast2-vpn (3.1.5 -> 4.0.0)
ypbind (2.4 -> 2.5)
zstd
zypper (1.14.5 -> 1.14.6)

=== Details ===

==== attica-qt5 ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Attica5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Add override
* Use override

==== baloo5 ====
Version update (5.46.0 -> 5.47.0)
Subpackages: baloo5-file baloo5-file-lang baloo5-imports baloo5-imports-lang
baloo5-kioslaves baloo5-kioslaves-lang baloo5-tools baloo5-tools-lang
libKF5Baloo5 libKF5BalooEngine5 libKF5BalooEngine5-lang

- Recommend corresponding lang packages
- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Terminate query execution early if subterm returns empty result set
* Avoid crash when reading corrupt data from document terms db (kde#392878)
* Use override
* handle string lists as input
* fix some issues reported by clazy
* Ignore more types of source files (kde#394002, kde#390932)

==== bijiben ====
Version update (3.28.1 -> 3.28.3)
Subpackages: bijiben-lang gnome-shell-search-provider-bijiben

- Update to version 3.28.3:
+ Updated translations.
- Update to version 3.28.2:
+ Fix memory leaks and circular references in many objects.
+ Updated translations.
- Drop upstreamed patches:
+ bijiben-memory-leak-fixes.patch.
+ bijiben-webkit-editor_Use-g_auto.patch.
+ bijiben-settings-dialog-Fix-settings.patch.

==== bluez ====
Version update (5.49 -> 5.50)
Subpackages: bluez-cups libbluetooth3

- update to version 5.50:
- Fix issue with GATT and reading long values.
- Fix issue with GATT and reading multiple includes.
- Fix issue with GATT and service changes when offline.
- Fix issue with handling secondary service discovery.
- Fix issue with handling persistency of CCC values.
- Fix issue with handling Mesh session on disconnection.
- Fix issue with handling Mesh proxy PDU SAR message length.
- Fix issue with handling Mesh default heartbeat TTL value.
- Add support for Mesh node-reset operation handling.
- Add support for GATT authorization request handling.
- Add support for GATT minimum key size requirements.
- Add support for GATT server and included services.
- Add support for handling additional advertising data.
- Add support for handling separate discoverable state.
- Add support for enabling HFP version 1.7 features.
- Add support for dedicated Bluetooth logging daemon.
- remove 0001-Don-t-refresh-adv_manager-for-non-LE-devices.patch,
fixed upstream

==== bluez-qt ====
Version update (5.46.0 -> 5.47.0)
Subpackages: bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Add missing override
* Use override

==== breeze5-icons ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* fix handle-right
* updated handles and overflow-menu
* add varlesh to the authors list, thanks for your work

==== cairo ====
Subpackages: libcairo-gobject2 libcairo2 libcairo2-32bit

- Add cairo-CVE-2017-9814.patch: Replace malloc with _cairo_malloc
and check cmap size before allocating (boo#1049092,
CVE-2017-9814, fdo#101547).

==== chrome-gnome-shell ====

- BuildRequires p7zip-full, now that 7z was split out.

==== elfutils ====
Version update (0.171 -> 0.172)
Subpackages: elfutils-lang libasm1 libdw1 libebl-plugins libelf-devel libelf1

- Update to versio 0.172
No functional changes compared to 0.171.
Various bug fixes in libdw and eu-readelf dealing with bad DWARF5 data.
Thanks to running the afl fuzzer on eu-readelf and various testcases.
- disable-tests-with-ptrace.patch: Rediff

==== evolution ====
Version update (3.28.2 -> 3.28.3)
Subpackages: evolution-lang evolution-plugin-bogofilter
evolution-plugin-pst-import evolution-plugin-spamassassin

- Update to version 3.28.3:
+ Address some of the clang warnings.
+ Fix a 'variable hides parameter' warning.
+ [alarm-notify] Do not use markup around organizer name in
libnotify text.
+ Address some of the compiler and static analyzers warnings.
+ Crash when making links clickable in composer.
+ Shift+Click on switcher button to open a new window.
+ Fix a possible memory leak in mail_display_uri_requested_cb().
+ [composer-autosave] Use-after-free during snapshot save to
file ][.
+ Update bug URL and switch to https:// in the DOAP file.
+ Fix few memory leaks around camel_data_wrapper_get_mime_type().
+ [ENameSelectorEntry] Plain text drag & drop between entries
misbehaves.
+ Mail Accounts in Preferences not always properly sorted.
+ Drop dependency on libcryptui.
+ Bugs fixed: bgo#795977, bgo#796114, bgo#796294, bgo#776162,
glgo#GNOME/evolution#19.
+ Updated translations.
- Drop upstream fixed/applied patches:
+ evolution-alarm-notify-do-not-use-markup.patch.
+ evolution-autoArchive-archives-Junk-and-Deleted-too.patch.
- Drop pkgconfig(cryptui-0.0) BuildRequires: No longer needed, nor
used following upstream changes.

==== evolution-data-server ====
Version update (3.28.2 -> 3.28.3)
Subpackages: evolution-data-server-lang libcamel-1_2-61 libebackend-1_2-10
libebook-1_2-19 libebook-contacts-1_2-2 libecal-1_2-19 libedata-book-1_2-25
libedata-cal-1_2-28 libedataserver-1_2-23 libedataserverui-1_2-2

- Update to version 3.28.3:
+ Address some of the clang warnings.
+ Correct some public headers in libedataserverui.
+ Address some of the compiler and static analyzers warnings.
+ [module-secret-monitor] Correct runtime warning from
secret_service_search_sync().
+ Check for ICAL_STATUS_DELETED status enum value.
+ Correct find_program() for python with multiple names.
+ Silently skip empty lines when reading autoconfig-variables.
+ Update bug URL and switch to https:// in the DOAP file.
+ Google's "Daily Limit Exceeded" error not always propagated
into UI.
+ [CalDAV] Race condition on connection object.
+ Correct false runtime warning from camel_folder_info_build().
+ Bugs fixed: bgo#795997, bgo#796206, bgo#796115, bgo#796116,
bgo#796281, bgo#763029, bgo#792610,
glgo#GNOME/evolution-data-server#2,
glgo#GNOME/evolution-data-server#4.
+ Updated translations.
- Drop upstream fixed/applied patches:
+ eds-fix-fails-to-parse-Google-OAuth2.patch.
+ eds-correct-some-public-headers.patch.

==== evolution-ews ====
Version update (3.28.2 -> 3.28.3)
Subpackages: evolution-ews-lang

- Update to version 3.28.3:
+ Address some of the compiler and static analyzers warnings.
+ Update bug URL and switch to https:// in the DOAP file.
+ Bugs fixed: bgo#796297.

==== frameworkintegration ====
Version update (5.46.0 -> 5.47.0)
Subpackages: frameworkintegration-plugin libKF5Style5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Remove check
* Use override

==== gnome-calculator ====
Version update (3.28.1 -> 3.28.2)
Subpackages: gnome-calculator-lang gnome-shell-search-provider-gnome-calculator

- Update to version 3.28.2:
+ Fix currencies not loading (glgo#GNOME/gnome-calculator#66).
+ Updated translations.

==== gnome-logs ====
Version update (3.28.2 -> 3.28.3)
Subpackages: gnome-logs-lang

- Update to version 3.28.3:
+ Distribute meson files in tarball.
+ Updated translations.

==== gpg2 ====
Version update (2.2.7 -> 2.2.8)
Subpackages: gpg2-lang

- Update to version 2.2.8:
* gpg: Decryption of messages not using the MDC mode will now lead to a
hard failure even if a legacy cipher algorithm was used. The option
- -ignore-mdc-error can be used to turn this failure into a warning. Take
care: Never use that option unconditionally or without a prior warning.
* gpg: The MDC encryption mode is now always used regardless of the
cipher algorithm or any preferences. For testing --rfc2440 can be
used to create a message without an MDC.
* gpg: Sanitize the diagnostic output of the original file name in
verbose mode (bsc#1096745, CVE-2018-12020)
* gpg: Detect suspicious multiple plaintext packets in a more reliable way.
* gpg: Fix the duplicate key signature detection code.
* gpg: The options --no-mdc-warn, --force-mdc, --no-force-mdc,
- -disable-mdc and --no-disable-mdc have no more effect.
* agent: Add DBUS_SESSION_BUS_ADDRESS and a few other envvars to the
list of startup environment variables.
- Refresh gnupg-2.0.18-files-are-digests.patch
to gnupg-2.2.8-files-are-digests.patch

==== graphene ====
Version update (1.8.0 -> 1.8.2)

- Update to version 1.8.2:
+ The main change is that we've now disabled SIMD optimisations
on 32 bit Intel architectures; there aren't many of those left,
and in general compilers have been less than stellar when
supporting SIMD types on them. This is especially problematic
when it comes to using Graphene types inside other allocated
structures, where SIMD alignment rules break system allocators
on platforms like Windows. To avoid introducing weird bugs, if
you're on 32 bit IA, you're only going to have access to the
scalar SIMD implementation.

==== gspell ====
Version update (1.8.0 -> 1.8.1)
Subpackages: gspell-lang libgspell-1-2 typelib-1_0-Gspell-1

- Update to version 1.8.1:
+ Fix new compilation warning (-Wcast-function-type).
+ Updated translations.

==== gstreamer-plugins-base ====
Subpackages: gstreamer-plugins-base-lang libgstallocators-1_0-0 libgstapp-1_0-0
libgstaudio-1_0-0 libgstfft-1_0-0 libgstgl-1_0-0 libgstpbutils-1_0-0
libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0
libgsttag-1_0-0 libgstvideo-1_0-0 typelib-1_0-GstAudio-1_0
typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0 typelib-1_0-GstVideo-1_0

- Conditionalize pkgconfig(graphene-1.0) BuildRequires: fix build
for Leap 42.3.

==== gtk3 ====
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut
gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-immodule-xim gtk3-lang
gtk3-tools libgtk-3-0 typelib-1_0-Gtk-3_0

- Add gtk3-filechooserbutton-Fix-reserved-pointers.patch: Stop gcc
from complaining about unnecessary parenthesis, fix gnucash build
failures.

==== gtksourceview ====
Version update (3.24.7 -> 3.24.8)
Subpackages: gtksourceview-lang libgtksourceview-3_0-1 typelib-1_0-GtkSource-3_0

- Update to version 3.24.8:
+ MS Windows: lib shutdown on DLL_PROCESS_DETACH,
not DLL_THREAD_DETACH.
+ Syntax highlighting: sync all *.lang files from GtkSourceView4.
+ Updated translations.

==== harfbuzz ====
Version update (1.7.6 -> 1.8.1)
Subpackages: libharfbuzz-icu0 libharfbuzz0 libharfbuzz0-32bit

- Update to version 1.8.1:
+ Add correctness bug in hb_set_t operations, introduced in
1.7.7.
- Changes from version 1.8.0:
+ Update to Unicode 11.0.0.
- Changes from version 1.7.7:
+ All HarfBuzz objects are significantly smaller in size now.
+ Sinhala: Position repha on top of post-consonant, not base.
+ Significant libharfbuzz-subset changes. API subject to change.
+ New API in libharfbuzz: hb_blob_create_from_file() and
hb_face_count().
- Add missing post(un) ldconfig scriptlets for libharfbuzz-subset
shared library.

==== jsonrpc-glib ====
Version update (3.28.0 -> 3.28.1)

- Update to version 3.28.1:
+ Fixes for invalid type propagation.
+ Fixes for gobject introspection.
+ Improved busy tracking in streams.
+ Ensure JsonrpcClient::failed is emitted in panic.

==== kactivities-stats ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Warning--

==== kactivities5 ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kactivities5-imports libKF5Activities5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Revert "Warning--"
* Warning--

==== karchive ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Bring back kzip.cpp to where it belongs
* handle zip files embedded within zip files (kde#73821)

==== kate ====
Subpackages: kate-lang kate-plugins

- Add 0002-Fix-QuickOpen-with-Qt-5.11.patch for kde#395039
to make quick-open work again after Qt 5.11.0 update.

==== kauth ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Auth5 libKF5Auth5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Warning--

==== kbookmarks ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Warning--

==== kcmutils ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* [KCModuleQml] Ignore disabled controls when tabbing

==== kcodecs ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kcompletion ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Completion5 libKF5Completion5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Don't use deprecated method

==== kconfig ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kconf_update5 libKF5ConfigCore5 libKF5ConfigCore5-lang
libKF5ConfigGui5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* KConfigCompiler_Test: Update test_signal.h.ref to follow the generated file
* kcfg.xsd - do not require a kcfgfile element

==== kconfigwidgets ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Fix the "Default" color scheme to match Breeze again

==== kcoreaddons ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kcoreaddons-lang libKF5CoreAddons5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kcrash ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kdbusaddons ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kdbusaddons-tools libKF5DBusAddons5 libKF5DBusAddons5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kdeclarative ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kdeclarative-components libKF5CalendarEvents5 libKF5Declarative5
libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Revert "GHNS button"
* Set kcm context property on the correct context
* GHNS button
* [Plotter] Don't render if m_node is null (kde#394283)
* assign the contentItem

==== kded ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kded-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kdelibs4support ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override

==== kdesu ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Su5 libKF5Su5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override

==== kdewebkit ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Add override

==== kdnssd-framework ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kdoctools ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kdoctools-lang libKF5DocTools5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Update the list of Ukrainian entities
* add entity OSD to general.entites > > 10 hits in trunk
l10n-kf5/documentation Differential Revision: https://phabricator.kde.org/D13024
* Add entities CIFS, NFS, Samba, SMB to general.entities
* Add Falkon, Kirigami, macOS, Solid, USB, Wayland, X11, SDDM to general
entities

==== kemoticons ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kfilemetadata5 ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kfilemetadata5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override
* check that ffmpeg is at least version 3.1 that introduce the API we require
* split tests for better readability
* search for album artist and albumartist tags in taglibextractor
* popplerextractor: don't try to guess the title if there isn't one.
- Dropped patches, superseded by upstream changes:
- ffmpeg-buildrequires.patch

==== kglobalaccel ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kglobalaccel5 libKF5GlobalAccel5 libKF5GlobalAccel5-lang
libKF5GlobalAccelPrivate5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Make sure ungrab keyboard request is processed before emitting shortcut
(kde#394689)
* Use override
- Dropped patches, now upstream:
* 0001-Make-sure-ungrab-keyboard-request-is-processed-befor.patch

==== kguiaddons ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kholidays ====
Version update (5.46.0 -> 5.47.0)

- Rename the lang package to libKF5Holidays5-lang and recommend it
by libKF5Holidays5 so that it actually gets installed, kholidays
just contains a "DESIGN" document and is not pulled in by
anything
- Provide/Obsolete kholidays-lang in case somebody installed it
manually
- Use %{lname} instead of libKF5Holidays5 everywhere
- Remove outdated minimum versions
- Mark license files as %license instead of %doc
- Run spec-cleaner
- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Fix warning
* holiday_es_es - Fix day of the "Comunidad de Madrid" Patch by juanmanuelm

==== khtml ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override

==== ki18n ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5I18n5 libKF5I18n5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Override

==== kiconthemes ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Check if group < LastGroup, as KIconEffect doesn't handle UserGroup anyway

==== kidletime ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Add categories file
* Generate logging categories
* Add missing override
* Use override

==== kimageformats ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Remove duplicated mime types from json files
* Use override

==== kinit ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kinit-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kio ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kio-core kio-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Check if destination exists also when pasting binary data (kde#394318)
* Auth support: Return the actual length of socket buffer
* Auth support: Unify API for file descriptor sharing
* Auth support: Create socket file in user's runtime directory
* Auth support: Delete socket file after use
* Auth support: Move task of cleaning up socket file to FdReceiver
* Auth support: In linux don't use abstract socket to share file
descriptor
* [kcoredirlister] Remove as many url.toString() as possible
* KFileItemActions: fallback to default mimetype when selecting only files
(kde#393710)
* Introduce KFileItemListProperties::isFile()
* KPropertiesDialogPlugin can now specify multiple supported protocols
using X-KDE-Protocols
* Preserve fragment when redirecting from http to https
* [KUrlNavigator] Emit tabRequested when path in path selector menu is
middle-clicked
* Performance: use the new uds implementation
* Don't redirect smb:/ to smb:// and then to smb:///
* Allow accepting by double-click in save dialog (kde#267749)
* Enable preview by default in the filepicker dialog
* Hide file preview when icon is too small
* i18n: use plural form again for plugin message
* Use a regular dialog rather than a list dialog when trashing or deleting
a single file
* Make the warning text for deletion operations emphasize its permanency
and irreversibility
* Revert "Show view mode buttons in the open/save dialog's toolbar"

==== kirigami2 ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Add fix-build-with-gcc48.patch to make it compile with gcc 4.8 on
Leap 42.3
- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Show action.main more prominently on the ToolBarApplicationHeader
* Allow Kirigami build without KWin tablet mode dependency
* correct swipefilter on RTL
* correct resizing of contentItem
* fix --reverse behavior
* share contextobject to always access i18n
* make sure tooltip is hidden
* make sure to not assign invalid variants to the tracked proeprties
* fix a couple of warnings
* handle not a MouseArea, dropped() signal
* no hover effects on mobile
* proper icons overflow-menu-left and right
* remove useless debug
* not hoverenabled
* Drag handle to reorder items in a ListView
* Add Settings class to API documentation
* Use Mnemonics on the toolbar buttons
* Use override
* Added missing files in QMake's .pri
* [API dox] Fix Kirigami.InlineMessageType -> Kirigami.MessageType
* fix applicationheaders in applicationitem
* fix build on macos/ios
* Fix warnings
* Remove wrong warning
* Don't allow showing/hiding the drawer when there's no handle (kde#393776)

==== kitemmodels ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Properly sanitize input
* Warning--
* Use override

==== kitemviews ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kjobwidgets ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kjs ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5JS5 libKF5JSApi5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kjsembed ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override

==== kmod ====
Subpackages: kmod-compat libkmod2

- allow 'modprobe -c' print the status of "allow_unsupported_modules" option.
+ 0012-modprobe-print-unsupported-status.patch

==== knewstuff ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5NewStuff5 libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== knotifications ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Fix crashes in NotifyByAudio when closing applications

==== knotifyconfig ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Warning--
* Use override

==== kpackage ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kpackage-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* kpackage_install_*package: fix missing dep between .desktop and .json
* make sure paths in rcc are never derived from absolute paths

==== kparts ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Parts5 libKF5Parts5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override

==== kpeople5 ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kpeople5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kplotting ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kpty ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Pty5 libKF5Pty5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Add override
* Use override

==== kross ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kross-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* USe override

==== krunner ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Process DBus replies in the ::match thread (kde#394272)

==== kservice ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kservice-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override

==== ktexteditor ====
Version update (5.46.0 -> 5.47.0)
Subpackages: ktexteditor-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Warning--
* Use override
* Don't use title case for the "show word count" checkbox
* Make the word/char count a global preference

==== ktextwidgets ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kunitconversion ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5UnitConversion5 libKF5UnitConversion5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kwallet ====
Version update (5.46.0 -> 5.47.0)
Subpackages: kwallet-tools kwallet-tools-lang kwalletd5 kwalletd5-lang
libKF5Wallet5 libkwalletbackend5-5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kwayland ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* [autotests] Fix surface destroy test
* Use override
* Increase org_kde_plasma_shell interface version
* Add "SkipSwitcher" to API
* Set @since version number for XDGOutput
* Add XDG Output Protocol

==== kwidgetsaddons ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Warning--
* Use override
* [KCharSelect] Fix table cell size with Qt 5.11
* [API dox] Remove usage of \overload, resulting in broken docs
* [API dox] Tell doxygen "e.g." does not end the sentence, use ".\ "
* [API dox] Remove unneeded HTML escaping
* Don't automatically set the default icons for each style
* Make KMessageWidget match Kirigami inlineMessage's style (kde#385299,
kde#381255)

==== kwindowsystem ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kxmlgui ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== kxmlrpcclient5 ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== libKF5ModemManagerQt ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override

==== libKF5NetworkManagerQt ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Add missing override
* Use override
* Make information about unhandled property just debug messages
* WirelessSetting: implement assignedMacAddress property

==== libdazzle ====
Version update (3.28.2 -> 3.28.3)
Subpackages: libdazzle-1_0-0 typelib-1_0-libdazzle-1_0

- Update to version 3.28.3:
+ Animation uses g_signal_connect_object() to simplify lifecycle
tracking.
+ CPU graph model now re-uses FDs and parse buffers.
+ Realtime graphs now try harder to detect when the widget is
obscured to reduce overhead in that situation.
+ GCancellable chaining tries harder to release state struct.

==== libgcrypt ====
Version update (1.8.2 -> 1.8.3)
Subpackages: libgcrypt20 libgcrypt20-32bit libgcrypt20-hmac

- Update to version 1.8.3:
- Use blinding for ECDSA signing to mitigate a novel side-channel
attack. (CVE-2018-0495 bsc#1097410)
- Fix incorrect counter overflow handling for GCM when using an IV
size other than 96 bit.
- Fix incorrect output of AES-keywrap mode for in-place encryption
on some platforms.
- Fix the gcry_mpi_ec_curve_point point validation function.
- Fix rare assertion failure in gcry_prime_check.
- Applied spec-cleaner

==== libgpod ====
Subpackages: libgpod-lang libgpod-tools libgpod4

- Change bcond_without mono to bcond_with mono, no longer build
mono support/sub-package by default.

==== libgweather ====
Version update (3.28.1 -> 3.28.2)
Subpackages: gweather-data libgweather-3-15 libgweather-lang
typelib-1_0-GWeather-3_0

- Update to version 3.28.2:
+ Fix crash in gnome-shell.
+ Updated translations.
- Cleanup spec, drop la files rm, no longer needed when building
with meson.

==== libimobiledevice ====
Version update (1.2.0+git20170122.45fda81 -> 1.2.0+git20180427.26373b3)

- update version 1.2.0+git20180427.26373b3
* Propagate lower level errors to callers instead of returning unknown
* Added IDEVICE_DEVICE_PAIRED event constant matching the corresponding
* Define htobe16 if not defined
* Fix parameter check of instproxy_check_capabilities_match()
* Avoid double free with OpenSSL 1.1.0
* Don't use ERR_remove_thread_state() with OpenSSL 1.1.0
* #ifdef out code which is a no-op with OpenSSL 1.1.0
* cython: Fix build error after error constant rename
* gnutls: check for interrupted gnutls_handshake()
* idevicescreenshot: Detect screenshot image format to determine file
extension
* Add basic mobileactivation service implementation
* mobileactivation: Add new functions required for drmHandshake / session
mode device activation
* lockdown: Don't explicitly validate pairing unless we're dealing with an
older device
* mobileactivation: Don't convert activation record if it is already passed
as PLIST_DATA
* mobileactivation: Allow passing activation response headers as required for
iOS 11.2+
* lockdown: Plug small memory leak
* idevicesyslog: Wait for passcode entry on device when required
* idevicediagnostics: Add HDMI to the list of valid options for diagnostics
command
* idevicediagnostics: Add ioregentry command to query device IORegistry by
entry
* userpref: [GnuTLS] Fix 3.6.0 SHA1 compatibility
* userpref: [GnuTLS] Use valid serial for >= 3.6.0
* build: Fix autogen.sh with srcdir != builddir

==== libjpeg-turbo ====
Subpackages: libjpeg8 libjpeg8-32bit libturbojpeg0

- security update:
* CVE-2018-1152 [bsc#1098155]
+ libjpeg-turbo-CVE-2018-1152.patch
- security update:
* CVE-2018-11813 [bsc#1096209]
+ libjpeg-turbo-CVE-2018-11813.patch
* remove redundant libjpeg-turbo-CVE-2017-15232.patch
[bsc#1062937#c17]

==== liblouis ====
Version update (3.5.0 -> 3.6.0)
Subpackages: liblouis-data python3-louis

- Word wrapped changes file
- Update to 3.6.0:
+ New features:
- Add metadata fields name and display-name to tables
+ Bug fixes:
- Fix a bunch of buffer overflow errors in table parsing
(CVE-2018-11410 bsc#1094685, CVE-2018-11440 bsc#1095189)
- Fix input-output mapping of context rules
- Fix back tracking with all caps words
- Fix context rules with lookback
- Fix a memory leak in default table resolver
- Fix an array out of bounds error which caused a crash on
i386
- Fix numerous stack-based buffer overflow in table parsing
(CVE-2018-11683 bsc#1095827, CVE-2018-11684 bsc#1095826,
CVE-2018-11685 bsc#1095825).
+ Braille table improvements.
- Applied spec-cleaner.
- Removed CVE-2018-11410.patch: Included upstream.
- Added CVE-2018-12085.patch: Fixed a stack-based buffer overflow
in the function parseChars() in compileTranslationTable.c
(CVE-2018-12085 bsc#1097103).

==== libqt5-qtbase ====
Subpackages: libQt5Concurrent5 libQt5Core5 libQt5DBus5 libQt5Gui5
libQt5Network5 libQt5OpenGL5 libQt5PrintSupport5 libQt5Sql5 libQt5Sql5-mysql
libQt5Sql5-sqlite libQt5Test5 libQt5Widgets5 libQt5Xml5
libqt5-qtbase-platformtheme-gtk3

- Add patch allow fallback from the xcb platform to others (QTBUG-68859):
* 0001-Hack-together-a-way-to-get-fallback-from-xcb-working.patch
- Use "xcb;wayland" as default platform plugin list
- Add patch to fix running Qt applications via ssh (boo#1096806,
boo#1097227):
* xcb-fix-regression-with-remote-X11-clients.patch
- Add patch to fix yet another sqlite named placeholder issue:
* 0001-sqlite-Allow-for-duplicated-placeholders-with-just-o.patch

==== logrotate ====

- Add "Environment=HOME=/root" to logrotate.service file in order
to allow mariadb to rotate its logs when the database has a root
password defined [bsc#1093617]
- Added patch:
* logrotate-3.13.0-systemd_add_home_env.patch

==== messagelib ====
Subpackages: messagelib-lang

- Add upstream patch 0001-Fix-dnd-attachment-with-qt5.11.patch:
* Fixes drag-and-drop of attachments between message windows

==== obs-service-source_validator ====
Version update (0.16 -> 0.17)

- Update to version 0.17:
* make path for helpers variable
* fix for #bsc985980

==== osinfo-db ====
Version update (20180531 -> 20180612)

- bsc#1098054 - osinfo-query and virt-install do not detect
caasp3.0
add-caasp-support.patch
- Update database to version 20180612
osinfo-db-20180612.tar.xz

==== ovmf ====
Version update (2018+git1525854636.13e3f8c03339 ->
2018+git1528497654.eb5943134630)
Subpackages: qemu-ovmf-x86_64

- Update to 2018+git1528497654.eb5943134630
+ CryptoPkg PeiCryptLib: Enable SHA384/512 support
+ MdePkg/UefiRuntimeLib: Do not allow to be linked by DXE driver
+ CryptoPkg: Remove deprecated function usage in
X509GetCommonName()
+ PlatformBootManagerLib: add missing report status code call
+ OvmfPkg: raise DXEFV size to 11 MB
+ SignedCapsulePkg/PlatformFlashAccessLib: Add progress API
+ MdeModulePkg: Add DisplayUpdateProgressLib class
+ PcAtChipsetPkg/PcRtc: Add two new PCD for RTC Index/Target
registers
+ OvmfPkg/Virtio10Dxe: convert to PciCapLib
+ OvmfPkg/PciHotPlugInitDxe: convert to PciCapLib
+ ArmVirtPkg: resolve PciCapLib, PciCapPciSegmentLib,
PciCapPciIoLib
+ OvmfPkg: resolve PciCapLib, PciCapPciSegmentLib, PciCapPciIoLib
+ OvmfPkg: introduce PciCapPciIoLib
+ OvmfPkg: introduce PciCapPciSegmentLib
+ OvmfPkg: introduce PciCapLib
+ BaseTools/tools_def: add "-fno-unwind-tables" to
GCC_AARCH64_CC_FLAGS
+ OvmfPkg/PlatformBootManagerLib: process TPM PPI request
+ OvmfPkg: add Tcg2PhysicalPresenceLibQemu
+ OvmfPkg/IndustryStandard: add QemuTpm.h header
+ OvmfPkg: add Tcg2PhysicalPresenceLibNull when !TPM2_ENABLE
+ MdePkg/SmmPeriodicSmiLib: Get Periodic SMI Context More Robustly
+ OvmfPkg/PlatformBootManagerLib: connect Virtio RNG devices again
+ ArmVirtPkg/PlatformBootManagerLib: connect Virtio RNG devices
again
+ OvmfPkg/QemuVideoDxe: Enable DISPLAY_OTHER pci class for qemu
stdvga
+ OvmfPkg/QemuVideoDxe: Add SubClass field to QEMU_VIDEO_CARD
+ OvmfPkg/PlatformBootManagerLib: connect consoles unconditionally
+ BaseTools: Fix generating array's size is incorrect in AutoGen.c
+ BaseTools: incorrect calculation for 16M

==== oxygen5-icon-theme ====
Version update (5.46.0 -> 5.47.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None

==== patterns-kde ====
Subpackages: patterns-kde-kde patterns-kde-kde_edutainment
patterns-kde-kde_games patterns-kde-kde_ide patterns-kde-kde_imaging
patterns-kde-kde_internet patterns-kde-kde_multimedia patterns-kde-kde_office
patterns-kde-kde_plasma patterns-kde-kde_utilities
patterns-kde-kde_utilities_opt patterns-kde-kde_yast

- Remove moonlight-plugin and aria2 suggests

==== perl-Net-Netmask ====
Version update (1.9022 -> 1.9101)

- updated to 1.9101
see /usr/share/doc/packages/perl-Net-Netmask/Changes

==== pesign-obs-integration ====

- debhelper: restrict wildcard package unpacking
- debhelper: fix conffiles corner case
- Remove the unstable source url
- Update the debian scripts
- Switch to tarball release

==== plasma-framework ====
Version update (5.46.0 -> 5.47.0)
Subpackages: plasma-framework-components plasma-framework-lang
plasma-framework-private

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override
* Templates: consistent naming, fix translation catalog names & more
* [Breeze Plasma Theme] Fix kleopatra icon to use color stylesheet
(kde#394400)
* [Dialog] Handle dialog being minimized gracefully (kde#381242)

==== plasma5-pk-updates ====
Subpackages: plasma5-pk-updates-lang

- Add patch to hide the "Install updates" button on Tumbleweed as
the zypp PK backend can't handle it correctly:
* 0001-Hide-option-to-install-updates-on-Tumbleweed.patch

==== prison-qt5 ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* None
- Enable support for QtQuick2
* Split the functionality in additional -imports subpackage

==== procps ====
Version update (3.3.14 -> 3.3.15)

- Reference patch procps-ng-3.3.15-typo.patch this patch add a
missed parenthesis for a nroff macro that is \*We become \*(We
in line 2186 of top/top.1
- Update to procps-ng-3.3.15 (bsc#1092100)
* library: Increment to 8:0:1
No removals, no new functions
Changes: slab and pid structures
* library: Just check for SIGLOST and don't delete it issue #93
* library: Fix integer overflow and LPE in file2strvec CVE-2018-1124
* library: Use size_t for alloc functions CVE-2018-1126
* library: Increase comm size to 64
* pgrep: Fix stack-based buffer overflow CVE-2018-1125
* pgrep: Remove >15 warning as comm can be longer issue #92
* ps: Fix buffer overflow in output buffer, causing DOS CVE-2018-1123
* ps: Increase command name selection field to 64
* top: Don't use cwd for location of config CVE-2018-1122
- Increase so major number

==== purpose ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Extend X-Purpose-Constraints documentation
* Improve Telegram integration
* Treat inner arrays as OR constraints rather than AND
* Make it possible to constrain plugins by a desktop file presence
* Make it possible to filter plugins by executable
* Fix i18n
* Fix i18n issues in Phabricator Plugin
* Highlight the selected device in the KDE Connect plugin
* Fix Phabricator icon
* fix i18n issues in framworks/purpose/plugins
* Use override
* Add Telegram plugin
* kdeconnect: Notify when the process fails to start

==== python-cryptography ====
Version update (2.2.1 -> 2.2.2)
Subpackages: python2-cryptography python3-cryptography

- update to 2.2.2
* fix build on some systems with openssl 1.1.0h

==== solid ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Use override
* [FStab Handling] Clean up process running by using lambdas

==== sonnet ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Warning--
* Use override

==== syntax-highlighting ====
Version update (5.46.0 -> 5.47.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Perl6: Add support for extensions .pl6, .p6, or .pm6 (kde#392468)
* Add unit test for C++ Octal number misdetection
* DoxygenLua: fix closing comment blocks (kde#394184)
* add pgf to the latex-ish file formats (same format as tikz)
* Use override
* Add postgresql keywords
* Highlighting for OpenSCAD
* debchangelog: add Cosmic Cuttlefish
* cmake: Fix DetectChar warning about escaped backslash #2
* cmake: Fix DetectChar warning about escaped backslash
* Pony: fix identifier and keyword
* Lua: updated for Lua5.3

==== threadweaver ====
Version update (5.46.0 -> 5.47.0)

- Update to 5.47.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.47.0.php
- Changes since 5.46.0:
* Warning--

==== totem ====
Version update (3.26.0 -> 3.26.1)
Subpackages: nautilus-totem totem-lang totem-plugins

- Update to version 3.26.1:
+ Fix crash when properties tab is closed too fast.
+ Thumbnail OPUS and M4B audio files.
+ Fix thumbnailing on platforms with V4L M2M hardware decoders.
+ Fix playing back MJPEG files.
+ Fix Python Console menu not appearing.
+ Build fixes:
- Remove dependency on Debian-specific pycompile utility.
- Fix build with gtk-doc 1.26.
- Drop upstream fixed/applied patches:
+ totem-remove-pycopile.patch
+ totem-fix-properties-crash.patch
+ totem-add-opus-ogg.patch
+ totem-fix-gtk-doc.patch
+ totem-nb-translations.patch
+ totem-thumbnailer-blacklist-fixes.patch
+ totem-fix-libtotem_gir-dependency.patch

==== totem-pl-parser ====
Version update (3.26.0+20180301.0091a56 -> 3.26.1+20180614.d22b155)
Subpackages: libtotem-plparser-mini18 libtotem-plparser18 totem-pl-parser-lang
typelib-1_0-TotemPlParser-1_0

- Update to version 3.26.1+20180614.d22b155:
+ docs: Add headers to the ignore list
+ core: Fix compile-time warnings in XML parser
+ Update translations.
- Update service to point to new gitlab home.

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- bsc#1096819 - virt-install - Couldn't find hvm kernel for SUSE
tree
virtinst-python2-to-python3-conversion.patch
- bsc#1098054 - osinfo-query and virt-install do not detect
caasp3.0
virtinst-add-caasp-support.patch

==== yast2-tftp-server ====
Version update (4.0.2 -> 4.1.0)

- Use yast2-journal to read logs from journal (bsc#1008493)
- 4.1.0

==== yast2-vpn ====
Version update (3.1.5 -> 4.0.0)

- bnc#1087957 - version bump
- 4.0.0
- Fix a minor error in translation string on main dialog.
(bsc#1038440)
Bump version to 3.1.6.

==== ypbind ====
Version update (2.4 -> 2.5)

- Update to version 2.5
- enhance yp.conf manual page

==== zstd ====

- fix pzstd tests
- add pzstd-global-gtest.patch
- enable pzstd (parallel zstd)
- add pzstd.1.patch, taken from Fedora package (git 21908004)

==== zypper ====
Version update (1.14.5 -> 1.14.6)
Subpackages: zypper-aptitude zypper-log

- Fix broken display of detailed query results
- Fix broken search for items with a dash (bsc#907538, bsc#1043166,
bsc#1070770)
- fix translation error (fixes #178)
- Disable repository operations when searching installed packages
(bsc#1084525)
- Prevent nested calls to exit() if aborted by a signal (bsc#1092413)
- ansi.h: Prevent ESC sequence strings from going out of scope
(bsc#1092413)
- version 1.14.6


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages