Mailinglist Archive: opensuse-factory (368 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180613 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180613

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
Mesa (18.1.0 -> 18.1.1)
Mesa-drivers (18.1.0 -> 18.1.1)
NetworkManager-applet (1.8.10 -> 1.8.12)
akonadi-calendar (18.04.1 -> 18.04.2)
akonadi-calendar-tools (18.04.1 -> 18.04.2)
akonadi-contact (18.04.1 -> 18.04.2)
akonadi-import-wizard (18.04.1 -> 18.04.2)
akonadi-mime (18.04.1 -> 18.04.2)
akonadi-notes (18.04.1 -> 18.04.2)
akonadi-search (18.04.1 -> 18.04.2)
akonadi-server (18.04.1 -> 18.04.2)
akregator (18.04.1 -> 18.04.2)
appstream-glib (0.7.8+3 -> 0.7.9+0)
ark (18.04.1 -> 18.04.2)
baloo5-widgets (18.04.1 -> 18.04.2)
bash
binutils
bluedevil5 (5.12.5 -> 5.13.0)
breeze (5.12.5 -> 5.13.0)
breeze-gtk (5.12.5 -> 5.13.0)
breeze4-style (5.12.5 -> 5.13.0)
calendarsupport (18.04.1 -> 18.04.2)
ceph (13.0.2.1874+ge31585919b -> 13.2.0.39+geb7f429568)
discover (5.12.5 -> 5.13.0)
dolphin (18.04.1 -> 18.04.2)
dragonplayer (18.04.1 -> 18.04.2)
drkonqi5 (5.12.5 -> 5.13.0)
elfutils (0.170 -> 0.171)
eventviews (18.04.1 -> 18.04.2)
gcc (7 -> 8)
gcc8 (8.0.1+r259636 -> 8.1.1+r260570)
geocode-glib (3.25.4.1 -> 3.26.0)
ghostscript
gnome-documents (3.28.0 -> 3.28.1)
grantleetheme (18.04.1 -> 18.04.2)
gsl
gupnp
gvfs
gwenview5 (18.04.1 -> 18.04.2)
incidenceeditor (18.04.1 -> 18.04.2)
installation-images-Kubic (14.374 -> 14.375)
kaccounts-integration (18.04.1 -> 18.04.2)
kaccounts-providers (18.04.1 -> 18.04.2)
kactivitymanagerd (5.12.5 -> 5.13.0)
kaddressbook (18.04.1 -> 18.04.2)
kalarmcal (18.04.1 -> 18.04.2)
kamera (18.04.1 -> 18.04.2)
kate (18.04.1 -> 18.04.2)
kcalc (18.04.1 -> 18.04.2)
kcalcore (18.04.1 -> 18.04.2)
kcalutils (18.04.1 -> 18.04.2)
kcharselect (18.04.1 -> 18.04.2)
kcm_sddm (5.12.5 -> 5.13.0)
kcolorchooser (18.04.1 -> 18.04.2)
kcontacts (18.04.1 -> 18.04.2)
kdav (18.04.1 -> 18.04.2)
kde-cli-tools5 (5.12.5 -> 5.13.0)
kde-gtk-config5 (5.12.5 -> 5.13.0)
kde-user-manager (5.12.5 -> 5.13.0)
kdenetwork4-filesharing (18.04.1 -> 18.04.2)
kdepim-addons (18.04.1 -> 18.04.2)
kdepim-apps-libs (18.04.1 -> 18.04.2)
kdepim-runtime (18.04.1 -> 18.04.2)
kdialog (18.04.1 -> 18.04.2)
kernel-firmware (20180525 -> 20180606)
kgamma5 (5.12.5 -> 5.13.0)
kgpg (18.04.1 -> 18.04.2)
khelpcenter5 (18.04.1 -> 18.04.2)
khotkeys5 (5.12.5 -> 5.13.0)
kidentitymanagement (18.04.1 -> 18.04.2)
kimap (18.04.1 -> 18.04.2)
kinfocenter5 (5.12.5 -> 5.13.0)
kio-extras5 (18.04.1 -> 18.04.2)
kio_audiocd (18.04.1 -> 18.04.2)
kldap (18.04.1 -> 18.04.2)
kleopatra (18.04.1 -> 18.04.2)
kmag (18.04.1 -> 18.04.2)
kmail (18.04.1 -> 18.04.2)
kmail-account-wizard (18.04.1 -> 18.04.2)
kmailtransport (18.04.1 -> 18.04.2)
kmbox (18.04.1 -> 18.04.2)
kmenuedit5 (5.12.5 -> 5.13.0)
kmime (18.04.1 -> 18.04.2)
kmousetool (18.04.1 -> 18.04.2)
knotes (18.04.1 -> 18.04.2)
kompare (18.04.1 -> 18.04.2)
konsole (18.04.1 -> 18.04.2)
kontact (18.04.1 -> 18.04.2)
kontactinterface (18.04.1 -> 18.04.2)
kopete (18.04.1 -> 18.04.2)
korganizer (18.04.1 -> 18.04.2)
kpimtextedit (18.04.1 -> 18.04.2)
kruler (18.04.1 -> 18.04.2)
kscreen5 (5.12.5 -> 5.13.0)
kscreenlocker (5.12.5 -> 5.13.0)
ksmtp (18.04.1 -> 18.04.2)
ksshaskpass5 (5.12.5 -> 5.13.0)
ksysguard5 (5.12.5 -> 5.13.0)
ktnef (18.04.1 -> 18.04.2)
kwalletmanager5 (18.04.1 -> 18.04.2)
kwayland-integration (5.12.5 -> 5.13.0)
kwin5 (5.12.5 -> 5.13.0)
libepubgen (0.1.0 -> 0.1.1)
libgravatar (18.04.1 -> 18.04.2)
libkcddb (18.04.1 -> 18.04.2)
libkcompactdisc (18.04.1 -> 18.04.2)
libkdcraw (18.04.1 -> 18.04.2)
libkdecoration2 (5.12.5 -> 5.13.0)
libkdepim (18.04.1 -> 18.04.2)
libkexiv2 (18.04.1 -> 18.04.2)
libkgapi (18.04.1 -> 18.04.2)
libkipi (18.04.1 -> 18.04.2)
libkleo (18.04.1 -> 18.04.2)
libkomparediff2 (18.04.1 -> 18.04.2)
libksane (18.04.1 -> 18.04.2)
libkscreen2 (5.12.5 -> 5.13.0)
libksieve (18.04.1 -> 18.04.2)
libksysguard5 (5.12.5 -> 5.13.0)
libqt5-qtlocation
libqt5-qtwebengine
libvorbis
mailcommon (18.04.1 -> 18.04.2)
mailimporter (18.04.1 -> 18.04.2)
mc (4.8.20 -> 4.8.21)
messagelib (18.04.1 -> 18.04.2)
milou5 (5.12.5 -> 5.13.0)
mobipocket (18.04.1 -> 18.04.2)
nagios
okular (18.04.1 -> 18.04.2)
oxygen5 (5.12.5 -> 5.13.0)
patterns-base
patterns-kde
perl-Image-ExifTool (10.80 -> 11.00)
pimcommon (18.04.1 -> 18.04.2)
plasma-nm5 (5.12.5 -> 5.13.0)
plasma5-addons (5.12.5 -> 5.13.0)
plasma5-desktop (5.12.5 -> 5.13.0)
plasma5-integration (5.12.5 -> 5.13.0)
plasma5-openSUSE
plasma5-pa (5.12.5 -> 5.13.0)
plasma5-workspace (5.12.5 -> 5.13.0)
polkit-kde-agent-5 (5.12.5 -> 5.13.0)
powerdevil5 (5.12.5 -> 5.13.0)
read-only-root-fs (1.0+git20180418.4373cf9 -> 1.0+git20180606.046b099)
rpcbind
shim-leap
spectacle (18.04.1 -> 18.04.2)
squid
syndication (18.04.1 -> 18.04.2)
systemsettings5 (5.12.5 -> 5.13.0)
taglib
tiff
transactional-update (2.3 -> 2.4)
upower
v4l-utils (1.14.1 -> 1.14.2)
webkit2gtk3 (2.20.2 -> 2.20.3)
xen
xmms2
yast2-ftp-server (4.0.5 -> 4.1.1)

=== Details ===

==== Mesa ====
Version update (18.1.0 -> 18.1.1)
Subpackages: Mesa-dri-devel Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 libgbm1
libwayland-egl1

- Update to 18.1.1
- drop U_dri3-Stricter-SBC-wraparound-handling.patch
* Radv fixed one extension and several features on a per-generation basis.
* Vulkan got fixes for a potential free of uninitialized memory
* Tegra got modifier fixes.
* nv30 fixed displayable formats.
* i965 now works correctly for GLK 2x6 systems.

==== Mesa-drivers ====
Version update (18.1.0 -> 18.1.1)
Subpackages: Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libva libvdpau_nouveau
libvdpau_r300 libvdpau_r600 libvdpau_radeonsi libvulkan_intel libvulkan_radeon
libxatracker2

- Update to 18.1.1
- drop U_dri3-Stricter-SBC-wraparound-handling.patch
* Radv fixed one extension and several features on a per-generation basis.
* Vulkan got fixes for a potential free of uninitialized memory
* Tegra got modifier fixes.
* nv30 fixed displayable formats.
* i965 now works correctly for GLK 2x6 systems.

==== NetworkManager-applet ====
Version update (1.8.10 -> 1.8.12)
Subpackages: NetworkManager-applet-lang NetworkManager-connection-editor
libnma0 nma-data typelib-1_0-NMA-1_0

- Update to version 1.8.12:
+ Allow creation of PPPoE connection without a parent interface.
+ Add an option to set a connection as Metered.
+ Make the form layout consistent with GNOME UI style.
+ Convert editor into a GtkApplication with an app menu.
+ Fix a potential crash in the certificate picker with no
modules.
+ Fix build warnings with GCC 8.
+ Support building against Ayatana AppIndicator.
+ Updated translations.
- Drop upstream fixed patches:
+ 0001-shared-compat-fix-memory-handling-of-nm_setting_vpn_.patch
+ 0002-shared-compat-fix-memory-handling-of-nm_setting_vpn_.patch
- Following changes in NetworkManager:
+ Pass libnm_gtk=false and without-libnm-gtk to meson/configure.
+ Drop no longer needed pkgconfig(NetworkManager),
pkgconfig(libnm-glib), pkgconfig(libnm-glib-vpn) and
pkgconfig(libnm-util) BuildRequires.
+ Drop no longer built subpackages: libnm-gtk%%{sover},
typelib-1_0-NMGtk-1_0 and libnm-gtk-devel.
+ No longer handle libnm-gtk%%{sover} in post(un).
+ Drop currently disabled
nm-applet-probe-radius-server-cert.patch: Obsolete since patch
is no longer present in NetworkManager, following this, drop
define with_cacert_patch and conditionals.

==== akonadi-calendar ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-calendar-lang akonadi-plugin-calendar
libKF5AkonadiCalendar5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== akonadi-calendar-tools ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-calendar-tools-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== akonadi-contact ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-contact-lang akonadi-plugin-contacts libKF5AkonadiContact5
libKF5ContactEditor5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== akonadi-import-wizard ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== akonadi-mime ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-mime-lang akonadi-plugin-mime libKF5AkonadiMime5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== akonadi-notes ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== akonadi-search ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== akonadi-server ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== akregator ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akregator-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== appstream-glib ====
Version update (0.7.8+3 -> 0.7.9+0)
Subpackages: appstream-glib-lang libappstream-builder8 libappstream-glib8

- Update to version 0.7.9+0:
+ New Features:
- Add ability to store signature filename and checksum.
- Convert local icons found in metainfo files.
+ Bugs fixed:
- Follow the Debian tilde usage when ordering versions.
- Remove the refcounted string interning feature.
- Use the launchable to find the desktop filename.
- Drop gnome-common BuildRequires: this package has no use since
build system port to Meson.
- Update check section to work with meson.

==== ark ====
Version update (18.04.1 -> 18.04.2)
Subpackages: ark-lang libkerfuffle18

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== baloo5-widgets ====
Version update (18.04.1 -> 18.04.2)
Subpackages: baloo5-widgets-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== bash ====
Subpackages: bash-doc bash-lang

- In patch bash-4.4.dif avoud setgroups(2) but use initgroups(3) (boo#1095670)
- Add patch 20, 21, 22 and 23 to bash-4.4-patches.tar.bz2
* 20: In circumstances involving long-running scripts that create
and reap many processes, it is possible for the hash table bash
uses to store exit statuses from asynchronous processes to
develop loops. This patch fixes the loop causes and adds code
to detect any future loops.
* 21: A SIGINT received inside a SIGINT trap handler can possibly
cause the shell to loop.
* 22: There are cases where a failing readline command (e.g.,
delete-char at the end of a line) can cause a multi-character
key sequence to `back up' and attempt to re-read some of the
characters in the sequence.
* 23: When sourcing a file from an interactive shell, setting the
SIGINT handler to the default and typing ^C will cause the
shell to exit.
- remove bash-4.4-wait-sigint-handler.patch (upstreamed)

==== binutils ====
Subpackages: binutils-devel

- riscv-relax-versioned-hidden.patch: RISC-V: Fix symbol address problem
with versioned symbols (PR ld/22756)
- Restore riscv64-elf cross prefix via symlinks

==== bluedevil5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: bluedevil5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Consistently use X-KDE-ServiceTypes instead of ServiceTypes
* Add Qt5::Network
* Use nullptr
* Use override
* Use non-deprecated KDEInstallDirs variables
* Add newline at end of file
* Do not use Qt module include
* Merge applet package's /code subdir into /ui subdir
* Remove unneeded moc include
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Require KDE Frameworks 5.42 and Qt 5.9
* Bump min cmake version to 3.0, move cmake_minimum_required to begin
* Add explicit includes to fix build with Qt 5.11
* Revert "Update version number for 5.12.1"
* DeviceMonitor: Remove saving/restoring blocked state

==== breeze ====
Version update (5.12.5 -> 5.13.0)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* Check for option->styleObject before accessing it (kde#395028)
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Draw mouse-over rect over the full toolbutton even if it has a menu
* Plasma 5.13 "Kokkini" Wallpaper
* Fix build with Qt 4
* [kstyle] create shadow tiles more explicitly
* [kstyle] use Q_FALLTHROUGH in breezesplitterproxy
* [kdecoration] delete unused m_buttons field
* [colors] add corresponding CMakeLists.txt
* modernize: delete redundant return statements
* modernize: delete redundant void args
* modernize: use nullptr
* delete COPYING-ICONS
* [cursors] Add arrow cursor symlinks
* - Moved shadowSize from anonymous namespace to static member function -
calculate proper shadow size for Mdi windows - fix mdi windows shadow
renderning.
* Remove long-time deprecated Encoding=UTF-8 from desktop format file
* fix double spacing bug
* Fixed kde4 compilation. Fixed warning about blurhelper initialization.
* Added optional transparency/blur to menu frames
* Revert "Added option to set transparency and blur behind menu frames such
as right click context menu, toolbar menu, etc."
* align checkable widgets in menu items
* Added option to set transparency and blur behind menu frames such as right
click context menu, toolbar menu, etc. Transparency and blur is disabled by
default. Submitted on behalf of Alex Nemeth
* Revert "reserve space for checkable widgets in menu items"
* reserve space for checkable widgets in menu items
* Add the marking gcc likes to silence -Wimplicit-fallthrough= warning
* fixed KDE4 compîlation (missing header)
* ensure the rounded rectangle of scrollbard stays round
* Fixed qt4 compilation.
* even slimmer scrollbars

==== breeze-gtk ====
Version update (5.12.5 -> 5.13.0)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Clean up top corners of dark headerbar
* Adjust dark headerbar to look like a toolbar
* Convert headerbar styling to toolbar appearance and adjust titlebutton
rendering accordingly
* Restructure CSS to prepare for color scheme compatibility
* Use 1px padding on titlebuttons

==== breeze4-style ====
Version update (5.12.5 -> 5.13.0)

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* Check for option->styleObject before accessing it (kde#395028)
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Draw mouse-over rect over the full toolbutton even if it has a menu
* Plasma 5.13 "Kokkini" Wallpaper
* Fix build with Qt 4
* [kstyle] create shadow tiles more explicitly
* [kstyle] use Q_FALLTHROUGH in breezesplitterproxy
* [kdecoration] delete unused m_buttons field
* [colors] add corresponding CMakeLists.txt
* modernize: delete redundant return statements
* modernize: delete redundant void args
* modernize: use nullptr
* delete COPYING-ICONS
* [cursors] Add arrow cursor symlinks
* - Moved shadowSize from anonymous namespace to static member function -
calculate proper shadow size for Mdi windows - fix mdi windows shadow
renderning.
* Remove long-time deprecated Encoding=UTF-8 from desktop format file
* fix double spacing bug
* Fixed kde4 compilation. Fixed warning about blurhelper initialization.
* Added optional transparency/blur to menu frames
* Revert "Added option to set transparency and blur behind menu frames such
as right click context menu, toolbar menu, etc."
* align checkable widgets in menu items
* Added option to set transparency and blur behind menu frames such as right
click context menu, toolbar menu, etc. Transparency and blur is disabled by
default. Submitted on behalf of Alex Nemeth
* Revert "reserve space for checkable widgets in menu items"
* reserve space for checkable widgets in menu items
* Add the marking gcc likes to silence -Wimplicit-fallthrough= warning
* fixed KDE4 compîlation (missing header)
* ensure the rounded rectangle of scrollbard stays round
* Fixed qt4 compilation.
* even slimmer scrollbars

==== calendarsupport ====
Version update (18.04.1 -> 18.04.2)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== ceph ====
Version update (13.0.2.1874+ge31585919b -> 13.2.0.39+geb7f429568)
Subpackages: librados2 librbd1

- Update to v13.2.0-39-geb7f429568:
+ based on upstream mimic f38fff5d093da678f6736c7a008511873c8d0fda
- Update to 13.1.1-173-g127c33d64e:
+ based on upstream mimic dda69eea663bcabc5ad99f5ca8370f43575f475d
* fix GCC8 builds (bsc#1084645)
* fix python3 module loading (bsc#1086613)
* ceph-brag no longer packaged upstream

==== discover ====
Version update (5.12.5 -> 5.13.0)
Subpackages: discover-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Too many changes to list here
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Too many changes to list here
- Refresh 0001-Warning-for-FlatHub.patch

==== dolphin ====
Version update (18.04.1 -> 18.04.2)
Subpackages: dolphin-part dolphin-part-lang libdolphinvcs5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Fix crash in PlacesItem::setUrl() (kde#394507)
* Add missing i18n call (kde#394194)

==== dragonplayer ====
Version update (18.04.1 -> 18.04.2)
Subpackages: dragonplayer-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== drkonqi5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: drkonqi5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Warning--
* Fix oversights of the last DBusInterfaceLauncher commit
* DrKonqi: Enable DBus-Interface for debugging with KDevelop
* Use static_cast of parent where type is known
* Fix README to show the right config section
* Add explicit includes to fix build with Qt 5.11
* Add explicit includes to fix build with Qt 5.11
* Remove parentheses
* Use non-deprecated KDEInstallDirs variable
* Remove no longer needed version checks
* Remove module namespace from Qt includes
* Remove include of unused cmake macros
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Bump min cmake version to 3.0, move cmake_minimum_required to top
* Remove duplicate definition
* Use debug categories
* Initialize pointer
* Build with strict definition.

==== elfutils ====
Version update (0.170 -> 0.171)
Subpackages: elfutils-lang libasm1 libdw1 libebl-plugins libelf-devel libelf1

- Update to version 0.171
DWARF5 and split dwarf, including GNU DebugFission, are supported now.
Data can be read from the new DWARF sections .debug_addr, .debug_line_str,
.debug_loclists, .debug_str_offsets and .debug_rnglists. Plus the new
DWARF5 and GNU DebugFission encodings of the existing .debug sections.
Also in split DWARF .dwo (DWARF object) files. This support is mostly
handled by existing functions (dwarf_getlocation*, dwarf_getsrclines,
dwarf_ranges, dwarf_form*, etc.) now returning the data from the new
sections and data formats. But some new functions have been added
to more easily get information about skeleton and split compile units
(dwarf_get_units and dwarf_cu_info), handle new attribute data
(dwarf_getabbrevattr_data) and to keep references to Dwarf_Dies
that might come from different sections or files (dwarf_die_addr_die).
Not yet supported are .dwp (Dwarf Package) and .sup (Dwarf Supplementary)
files, the .debug_names index, the .debug_cu_index and .debug_tu_index
sections. Only a single .debug_info (and .debug_types) section are
currently handled.
readelf: Handle all new DWARF5 sections.
- -debug-dump=info+ will show split unit DIEs when found.
- -dwarf-skeleton can be used when inspecting a .dwo file.
Recognizes GNU locviews with --debug-dump=loc.
libdw: New functions dwarf_die_addr_die, dwarf_get_units,
dwarf_getabbrevattr_data and dwarf_cu_info.
libdw will now try to resolve the alt file on first use of
an alt attribute FORM when not set yet with dwarf_set_alt.
dwarf_aggregate_size() now works with multi-dimensional arrays.
libdwfl: Use process_vm_readv when available instead of ptrace.
backends: Add a RISC-V backend.
There were various improvements to build on Windows.
The sha1 and md5 implementations have been removed, they weren't used.
- Remove patches: elfutils-0.170-Wpackednotaligned.patch,
elfutils-0.170-stripnothing.patch, gcc8-disable-test.patch
- make package with V=1 to print verbose command line
- Add gcc8-disable-test.patch in order to fix boo#1084637: temporarily
disable a test-case.

==== eventviews ====
Version update (18.04.1 -> 18.04.2)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== gcc ====
Version update (7 -> 8)
Subpackages: cpp gcc-c++ gcc-fortran gcc-info gcc-objc libstdc++-devel

- Fix gcc-PIE spec to properly honor -no-pie at link time.
- Switch gcc to default 8.

==== gcc8 ====
Version update (8.0.1+r259636 -> 8.1.1+r260570)
Subpackages: libatomic1 libgcc_s1 libgcc_s1-32bit libgomp1 libitm1 liblsan0
libmpx2 libmpxwrappers2 libobjc4 libquadmath0 libstdc++6 libstdc++6-32bit
libtsan0

- Update to gcc-8-branch head (r260570).
* Adds fix for qtscript miscompile.
* Avoids bogus strict-overflow warnings. [bnc#1094222]
- Add riscv64-elf cross target.
Suffix has become necessary to distinguish from openSUSE target.
- libffi-riscv.patch: Backport of RISC-V support for libffi
- Update to GCC 8.1 release.
- Update to gcc-8-branch head (r259752).
* GCC 8.1 second release candidate.

==== geocode-glib ====
Version update (3.25.4.1 -> 3.26.0)
Subpackages: libgeocode-glib0 typelib-1_0-GeocodeGlib-1_0

- Update to version 3.26.0:
+ Remove full build path from public headers so as to make the
build more easily reproduceable.
- Drop geocode-glib-make-reproducible.patch: Fixed upstream.
- Drop hicolor-icon-theme BuildRequires: No longer needed.

==== ghostscript ====
Subpackages: ghostscript-x11

- CVE-2018-10194.patch fixes stack-based buffer overflow
in gdevpdts.c (bsc#1090099), see
https://bugs.ghostscript.com/show_bug.cgi?id=699255 and

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=39b1e54b2968620723bf32e96764c88797714879

==== gnome-documents ====
Version update (3.28.0 -> 3.28.1)
Subpackages: gnome-documents-lang gnome-documents_books-common
gnome-shell-search-provider-documents

- Update to version 3.28.1:
+ Avoid premature queries during startup.
+ Updated translations.

==== grantleetheme ====
Version update (18.04.1 -> 18.04.2)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== gsl ====
Subpackages: libgsl23 libgslcblas0

- temporarily disable unit tests on i586 (boo#1092530)

==== gupnp ====

- Drop NetworkManager recommends from libgupn-1_0-4: There is no
reason to pollute a system with NM just because something pulls
in libgupnp (boo#1082090).

==== gvfs ====
Subpackages: gvfs-backend-afc gvfs-backend-samba gvfs-backends gvfs-fuse
gvfs-lang

- Add gvfs-smb-Use-O_RDWR-to-fix-fstat-when-writing.patch: Fix
failures copying files on smb mounts (bgo#795805 boo#1096476).

==== gwenview5 ====
Version update (18.04.1 -> 18.04.2)
Subpackages: gwenview5-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Fix share menu not showing the first time it is used
* Watch for installation of kipi-plugins only when needed
* Update thumbnail de-/select hover button on selection change (kde#394406)
* Update paste action on current directory and selection changes (kde#276255)
* Cleanup code for finishing undo/redo of image operations
* Enable redo for undone image operations
* Disable View mode shortcuts outside of View mode

==== incidenceeditor ====
Version update (18.04.1 -> 18.04.2)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== installation-images-Kubic ====
Version update (14.374 -> 14.375)

- merge gh#openSUSE/installation-images#251
- include all kernel input modules (bsc#1095289)
- 14.375

==== kaccounts-integration ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kaccounts-providers ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kaccounts-providers-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kactivitymanagerd ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kactivitymanagerd-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Warning--
* Link against kcrash
* Migrate to ecm_qt_declare_logging_category
* Use category logging
* Allowing KAMD to run without a database backend
* Removed the separate thread for resource score cache processing
* allow to have more than one default activity

==== kaddressbook ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kaddressbook-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kalarmcal ====
Version update (18.04.1 -> 18.04.2)
Subpackages: akonadi-plugin-kalarmcal kalarmcal-lang libKF5AlarmCalendar5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kamera ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kamera-lang kio_kamera

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kate ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kate-lang kate-plugins

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kcalc ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kcalc-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kcalcore ====
Version update (18.04.1 -> 18.04.2)

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kcalutils ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Fix Bug 394410 - Copy link for the participants should be a url not a uid
in the incidence viewer (kde#394410)

==== kcharselect ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kcharselect-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kcm_sddm ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kcm_sddm-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Use installedTheme
* Warning--

==== kcolorchooser ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kcolorchooser-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kcontacts ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kdav ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kdav-lang libKPimKDAV5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kde-cli-tools5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kde-cli-tools5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Fix filetypestest
* Fix build in kcmshell5, accidentially landed the wrong revision
* Use platform detection from KWorkSpace in KCMShell
* Use non-deprecated KDEInstallDirs variables
* [kbroadcastnotification] Set app data from created KAboutData instance
* Do not repeat work done by KAboutData.setupCommandLine()
* Port away from deprecated NETWinInfo constructor variant
* Port away from deprecated KWindowSystem::windowInfo()
* Port away from deprecated KRun::runUrl() variant
* Port away from deprecated KIO::Job::ui()
* Port away from deprecated KLineEdit::setClickMessage()
* Use explicit
* Use nullptr
* Use override
* Group all cmake macro includes, move settings ones to top
* Remove module prefixes from Qt includes
* Remove now always fulfilled check of Qt version
* Remove unused cpp macro
* Call KLocalizedString::setApplicationDomain after Q*App creation
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Use add_test signature where target command gets resolved to binary path
* Bump min cmake version to 3.0, move cmake_minimum_required to begin
* Update an include to now used class
* [KCMShell] Don't assume KCModuleProxy is our child widget
- Refresh kdesu-add-some-i18n-love.patch
- Remove patches, now upstream:
* 0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
* 0002-Use-platform-detection-from-KWorkSpace-in-KCMShell.patch
* 0003-Fix-build-in-kcmshell5-accidentially-landed-the-wron.patch

==== kde-gtk-config5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Make sure there are less unnecessary changed() emissions (kde#388126)
* Use new connect syntax

==== kde-user-manager ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kde-user-manager-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Split replaceAccount from addAccountToCache (kde#336994)
* Warning--
* Fix merge conflict
* Enable anti-aliasing for user avatars

==== kdenetwork4-filesharing ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kdenetwork4-filesharing-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kdepim-addons ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kdepim-addons-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kdepim-apps-libs ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kdepim-apps-libs-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kdepim-runtime ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kdepim-runtime-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* resources/ews: Fix saving passwords to KWallet (kde#393002)

==== kdialog ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kdialog-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kernel-firmware ====
Version update (20180525 -> 20180606)
Subpackages: ucode-amd

- Update to version 20180606:
* brcm: update firmware for bcm4356 pcie
* brcm: update firmware for bcm4354 sdio
* brcm: update firmware for bcm43362 sdio
* brcm: update firmware for bcm43340 sdio
* brcm: update firmware for bcm43430 sdio
* Update Cypress license termination clause
* amdgpu: update vega10 VCE firmware to version 55.3
* linux-firmware: Update firmware patch for Intel Bluetooth 7265 (D0)
* linux-firmware:Update firmware patch for Intel Bluetooth 7265 (D1)
* qcom: add venus firmware files for v5.2
* linux-firmware: liquidio: update vswitch firmware to v1.7.2
- Use the upstream version of AMD ucode for family 17h
(CVE-2017-5715, bsc#1095735)

==== kgamma5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kgamma5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* Only enable on XCB (kde#394548)
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Warning--
* Fix install target for kgamma
* Let KDECompilerSettings change the policies in the project
* Remove duplicated include
* Use explicit
* Use nullptr
* Use override
* Move add_definitions(-DTRANSLATION_DOMAIN) into dir level of Messages.sh
* Remove unused cmake macro include
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Remove unneeded moc includes
* Require KDE Frameworks 5.42 and Qt 5.9
* Bump min cmake version to 3.0, remove duplicated cmake_minimum_required

==== kgpg ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kgpg-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* fix KEY_CONSIDERED lines always resulting in TS_MSG_SEQUENCE errors
* Resolve decryption failure when message has no version header
* Resolve decryption failure when message has no version header
* avoid needless string copy

==== khelpcenter5 ====
Version update (18.04.1 -> 18.04.2)
Subpackages: khelpcenter5-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== khotkeys5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: khotkeys5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* None

==== kidentitymanagement ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kimap ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kimap-lang libKF5IMAP5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Fix STARTTLS support detection
* Fix TLS vs STARTTLS handling (kde#394769)

==== kinfocenter5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kinfocenter5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* kcm_opengl: Fix retrieval of DRI information
* kcm_opengl: Fix EGL info retrieval.
* Fix displaying OpenGL info on wayland: do not require OpenGL 3.2
* Update kinfocenter docbook to 5.12
* [Device Viewer] Add battery percentage bar
* [Device Viewer] Add missing Solid battery types
* Remove unused X-Plasma-RemoteLocation entries
* Remove not necessary QtCore and co
* Remove long-time deprecated Encoding=UTF-8 from desktop format files
* Show high-resolution and vector logos properly in HighDPI mode (kde#388633)
* Don't use const'ref for int element
* Remove unused definition
- Remove patches, now upstream:
* kcm_opengl-Fix-retrieval-of-DRI-information.patch

==== kio-extras5 ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Scale up folder icon before creating preview overlays

==== kio_audiocd ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kio_audiocd-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kldap ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kldap-lang libKF5Ldap5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kleopatra ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kleopatra-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kmag ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kmag-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kmail ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Bug 232911 - "Reply Without Quote" does not open message composer anymore
(kde#232911)
* Fix show two icon when we use kontact.
* Fix warning about shortcut

==== kmail-account-wizard ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kmail-account-wizard-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kmailtransport ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kmbox ====
Version update (18.04.1 -> 18.04.2)

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kmenuedit5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kmenuedit5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* None

==== kmime ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kmime-lang libKF5Mime5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kmousetool ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kmousetool-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== knotes ====
Version update (18.04.1 -> 18.04.2)
Subpackages: knotes-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kompare ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kompare-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== konsole ====
Version update (18.04.1 -> 18.04.2)
Subpackages: konsole-part konsole-part-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Backspace without CTRL should send '^?' (kde#394276)

==== kontact ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kontact-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Fix Bug 394767 - Error message at start with Qt 5.11 (kde#394767)
- Dropped patches, now upstream:
* fix-error-window-kontact.patch

==== kontactinterface ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kopete ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kopete-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* cmake: remove extra "plugins"
* Fix installation of notifyrc file
* Remove the WLM protocol

==== korganizer ====
Version update (18.04.1 -> 18.04.2)
Subpackages: korganizer-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* koviewmanager.cpp - use the fallback when selecting the date for Day View
BUG: 394416 FIXED-IN: 5.8.2 (kde#394416)

==== kpimtextedit ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kruler ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kruler-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kscreen5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kscreen5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Too many changes to list here

==== kscreenlocker ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Use the default Plasma wallpaper on the lock screen
* expose the wallpaper config to the lockscreen
* Add script to unlock a broken session via ConsoleKit.
* Update path to fakekcheckpass with latest ECM's bin/ collection
* Help KSldTest to find its helper binaries with latest ECM's bin/ collection
* Use explicit
* Use override
* Use nullptr
* Remove module namespace from Qt includes
* Port away from deprecated KAuthorized::authorizeKAction()
* Drop ECMPackageConfigHelpers for CMakePackageConfigHelpers
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Use add_test signature where target command gets resolved to binary path
* Add missing project() in toplevel CMakeLists.txt
* Bump min cmake version to 3.0, move cmake_minimum_required to top
* Build test/autotest if BUILD_TESTING is defined

==== ksmtp ====
Version update (18.04.1 -> 18.04.2)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Fix TLS vs STARTTLS handling (kde#394770)

==== ksshaskpass5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: ksshaskpass5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Remove manual call to cmake_policy(SET CMP0063 NEW)
* Fix QString from latin 1 error
* Make it compiles with strict definition

==== ksysguard5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: ksysguard5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Fix warning
* Make some strings easier to translate
* Explicitly include <QDoubleValidator> to fix build with Qt 5.11
* Remove extra ';'
* Fix some warnings
* Use more non-deprecated KDEInstallDirs variables
* Remove another module namespace from a Qt include
* Remove linking with no longer set var KDE4_KDEFAKES_LIBS
* Remove Qt includes with modula namespace
* Use non-deprecated KDEInstallDirs variables
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Bump min cmake version to 3.0, move cmake_minimum_required to top
* Correction with the & problem in tabs (kde#382512)
* Use nullptr
* Reserve vector
* Start to make it compile with strict compile flags
- Refresh 0001-Use-run-for-ksysguardd-s-pid-file.patch

==== ktnef ====
Version update (18.04.1 -> 18.04.2)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kwalletmanager5 ====
Version update (18.04.1 -> 18.04.2)
Subpackages: kwalletmanager5-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== kwayland-integration ====
Version update (5.12.5 -> 5.13.0)

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* None

==== kwin5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: kwin5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* Don't scale resolution dependent cursor size twice
* Reparse rules config prior to update (kde#393788)
* Do not save kwinrulesrc on every window opening/closing (kde#393911)
* Update seat's timestamp after waking up screen through double tap
(kde#392754)
* Use XdgShell Unstable V6 in nested wayland platform
* Ensure the QToolTip on the deocration does not steal key events (kde#393253)
* Do not unset cursor image when cursor enters a surface
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Too many changes to list here

==== libepubgen ====
Version update (0.1.0 -> 0.1.1)

- Version update to 0.1.1:
* Avoid <div> inside <p> or <span>.
* Avoid writin vertical-align attribute without a value.
* Fix generation of invalid XHTML when there is a link starting at the
beginning of a footnote.
* Handle relative width for images.
* Fixed layout: write chapter names to improve navigation.
* Support writing mode.
* Start a new HTML file at every page span in addition to the splits
induced by the chosen split method. This is to ensure that specified
writing mode works correctly, as it is HTML <body> attribute.
* Improve tests.
* Add a basic support for ruby.
* Configure: disable treating of compiler warnings as errors by
default.
* Various minor fixes and code cleanups.

==== libgravatar ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkcddb ====
Version update (18.04.1 -> 18.04.2)

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkcompactdisc ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkdcraw ====
Version update (18.04.1 -> 18.04.2)

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkdecoration2 ====
Version update (5.12.5 -> 5.13.0)

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- %lang_package -n %{lname}
- Run spec-cleaner
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Use non-deprecated KDEInstallDirs variables
* Use override
* Group cmake macro includes as done in other plasma repos
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Use add_test signature where target command gets resolved to binary path
* Drop ECMPackageConfigHelpers for CMakePackageConfigHelpers
* Require KDE Frameworks 5.42 and Qt 5.9
* Bump min cmake version to 3.0, move cmake_minimum_required to begin
* Make the messages translatable
* Build test/autotest if BUILD_TESTING is defined
* Tooltips (kde#383040)

==== libkdepim ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkexiv2 ====
Version update (18.04.1 -> 18.04.2)

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkgapi ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkipi ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5Kipi32_0_0 libkipi-data

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkleo ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkomparediff2 ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libksane ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5Sane5 libksane-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== libkscreen2 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* XRandR: Fix 'may fall through' warning
* Fix kscreen-doctor description
* [kscreen-doctor] document output scaling in --help
* allow setting rotation from kscreen-doctor
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Add option for creation of API dox documentation in QCH format
* Remove outdated & broken option for API dox creation
* Use generated export header
* Update D-Bus xml file to use "Out*" for signal type Qt annotations
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Use non-deprecated KDEInstallDirs variables
* Remove module namespace from Qt includes
* Drop ECMPackageConfigHelpers for CMakePackageConfigHelpers
* Bump min cmake version to 3.0
* Build test/autotest if BUILD_TESTING is defined

==== libksieve ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libksieve-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Don't add an item with same name
* Allow to select multi emails
* Use KSieveUi::AbstractSelectEmailLineEdit
* Parse script here too. Otherwise it's always active even if we disable code
* Don't create two connect/slot

==== libksysguard5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: libksysguard5-helper libksysguard5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* [ProcessModel] Center more column headings (kde#394467)
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Fix whitespace
* Use non-deprecated KDEInstallDirs variables
* Remove Qt includes with module namespace
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Use QT_MIN_VERSION & KF5_MIN_VERSION variables
* Have a single grouping of cmake macro includes, as done elsewhere
* Port to non-deprecated NETWinInfo constructor
* "Port" QStyleOptionViewItemV4 -> QStyleOptionViewItem
* Drop ECMPackageConfigHelpers for CMakePackageConfigHelpers
* Fix compiler warning
* Fix log name
* Split debug categories in several categories + autogenerate it + install
categories file
* Some QChar items I missed, and it turns out QStringLiteral can't be used
there, so just fromUtf8 it
* Complete porting of the code away from ASCII and Byte Array casting as
started by the previous commit.
* Remove 'remove_definitions(-DQT_NO_CAST_FROM_ASCII
-DQT_NO_CAST_FROM_BYTEARRAY'
* Const'ref
* Use QStringLiteral (why this test is not build here ? )
* Const'ref
* Clean up, const'ify
* Remove qt include namespace.
* Fix i18n formating
* Make it compile
* Make it compile with strict compile flags.

==== libqt5-qtlocation ====
Subpackages: libQt5Location5 libQt5Positioning5 libQt5PositioningQuick5

- Mention libQt5PositioningQuick in baselibs.conf

==== libqt5-qtwebengine ====

- Add a patch to fix build with opengles2 (means on ARM):
* fix-build-with-opengles2.patch
- Add yet another upstream chromium patch to fix build with GCC 8.1:
* fix-build-with-gcc-8-for-real.patch
- Add upstream Chromium patch to fix build with GCC 8.1:
* fix-build-with-gcc-8.patch
- Add upstream Chromium patch to fix build with ffmpeg 4:
* fix-build-with-ffmpeg4.patch
- Refresh patches:
* disable-gpu-when-using-nouveau-boo-1005323.diff
* harmony-fix.diff

==== libvorbis ====
Subpackages: libvorbis0 libvorbis0-32bit libvorbisenc2 libvorbisfile3
libvorbisfile3-32bit

- Replace vorbis-CVE-2017-14160.patch with the upstream fix
(commit 018ca26dece6), refresh vorbis-CVE-2018-10393.patch
- Fix the validation of channels in mapping0_forward()
(CVE-2018-10392, bsc#1091070):
vorbis-CVE-2018-10392.patch

==== mailcommon ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== mailimporter ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== mc ====
Version update (4.8.20 -> 4.8.21)
Subpackages: mc-lang

- update to 4.8.21
* * Core
* Cancel Chmod/Chown/Advanced chown operation for large group of files when
operation is not permitted (#3850)
* Mouse support in the "Advanced chown" dialog window (#3148)
* File highlighting by extension is case insensitive by default (#1620)
* Safe file overwrite (#3913)
* * VFS
* Support zstd compression format (#3906)
* * Editor
* Syntax:
- Rust support (#3884)
- JavaScript modules support (#3890)
- Improve Markdown support (#3893)
* * Viewer
* * Diff viewer
* * Misc
* Add JavaScript module support to filehighlight.ini
(MidnightCommander/mc#132)
* Add Excel xlsx file format support to mc.ext.in (MidnightCommander/mc#135)
* i18n of argument type names in --help blocks (#3879)
* Code cleanup: (#3857, #3914)
* * Fixes
* Fail to link to ncurses built as two libraries: ncurses+tinfo (#3880)
* Garbage in displaying of summary of file sizes for selected files (#3883)
* "Compute totals" unnecessarily done for moves (#3149, #3908)
* mc.ext: allow Java class files to be viewed even if JAD isn't on PATH
(MidnightCommander/mc#134)
* mcedit: broken extended key mode (#3897)
* mcedit doesn't save all opened files (#3898)
* extfs: sftps: -31 SFTP Protocol Error when transferring file (#3406)
* extfs: rpm: truncated script content in the viewer (#3865)
* extfs: rpm helper misses CONFLICTS field (#3789)

==== messagelib ====
Version update (18.04.1 -> 18.04.2)
Subpackages: messagelib-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Ensure we always reset the external reference override (kde#394554)
* QtWebEngine 5.11 can intercept more messages include local and data ones
- Dropped patches, now upstream:
* always-reset-external-reference-override.patch

==== milou5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: milou5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* [SourcesModel] Check changed file name before reloading configuration
* Remove duplicated (X-KDE-)ServiceTypes entry
* Fix typos in comments
* Do not ue Qt module includes
* Merge applet package's /code subdir into /ui subdir
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Use non-deprecated KDEInstallDirs variables
* No const signals
* Bump minimal cmake version to 3.0
* Use more explicit
* Use nullptr
* Use override
* Remove unnecessary dependency on QtScript

==== mobipocket ====
Version update (18.04.1 -> 18.04.2)

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== nagios ====
Subpackages: nagios-www

- fix setting default values in nagios-exec-start-pre

==== okular ====
Version update (18.04.1 -> 18.04.2)
Subpackages: okular-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* Force release of free memory
* Use a target in FindDiscount (modern cmake) rather than variables

==== oxygen5 ====
Version update (5.12.5 -> 5.13.0)

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* changed demo button icon

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt
patterns-base-base patterns-base-basesystem patterns-base-console
patterns-base-enhanced_base patterns-base-enhanced_base_opt
patterns-base-minimal_base patterns-base-minimal_base_conflicts
patterns-base-sw_management patterns-base-transactional_base patterns-base-x11
patterns-base-x11_opt patterns-base-x86

- Only recommend rollback-helper if sle_version is defined: The
helper makes sense on Leap and SLE, where one can register with
SCC, but not for Tumbleweed.

==== patterns-kde ====
Subpackages: patterns-kde-kde patterns-kde-kde_edutainment
patterns-kde-kde_games patterns-kde-kde_ide patterns-kde-kde_imaging
patterns-kde-kde_internet patterns-kde-kde_multimedia patterns-kde-kde_office
patterns-kde-kde_plasma patterns-kde-kde_utilities
patterns-kde-kde_utilities_opt patterns-kde-kde_yast

- Don't recommend the imaging pattern, it pulls in only GIMP anyway
- Use VLC instead of Dragon Player

==== perl-Image-ExifTool ====
Version update (10.80 -> 11.00)
Subpackages: exiftool perl-File-RandomAccess

- Update to 11.00:
* Added read support for WTV and DVR-MS videos
* Added print conversions for some ASF date/time tags
* Added a new SonyModelID
* Decode a new PanasonicRaw tag
* Decode some new Sony RX100 VI tags
* Made Padding and OffsetSchema tags "unsafe" so they
aren't copied by default

==== pimcommon ====
Version update (18.04.1 -> 18.04.2)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== plasma-nm5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* Assign notification area category
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Remove unused code
* Simplify connection item delegate
* Use QtQuick's built-in HSV color features for cycling download color
* Coding style and minor improvements
* Unquote remote when importing OpenVPN connections (kde#393657)
* Use ScrollView from QtQuickControls in the main connection view (kde#393794)
* Check for device not being null
* Require NM 1.0.0 and newer
* use the bundled variant of installpackage
* Adjust spacing between text and plotter line in Speed tab of nm applet

==== plasma5-addons ====
Version update (5.12.5 -> 5.13.0)
Subpackages: plasma5-addons-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* [Timer applet] Fix double speed countdown & commands run multiple times
(kde#381173)
* [timer applet] Fix internal function calls
* [timer applet] Unify QtQuick imports
* Fix always empty memory bar
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Too many changes to list here

==== plasma5-desktop ====
Version update (5.12.5 -> 5.13.0)
Subpackages: plasma5-desktop-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Too many changes to list here
- Remove patches, now upstream:
* 0001-Fix-submenus-not-updating-when-switching-between-cat.patch
* 0002-Fix-submodel-population.patch
- Add Requires: kirigami2 to express the dependency directly
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Too many changes to list here
- Remove patches, now upstream:
* 0001-Place-toolbox-in-the-top-right-corner-of-the-screen.patch
- Add patches from Plasma/5.13 branch:
* 0002-Fix-submodel-population.patch

==== plasma5-integration ====
Version update (5.12.5 -> 5.13.0)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* Don't manipulate foreign windows
* KDEPlatformFileDialog: Fix initial directory selection for remote files
(kde#374913)
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Save the dialog view settings when closing the dialog without hitting the
cancel button
* KDEPlatformFileDialog: Fix initial directory selection for remote files
(kde#374913)
* Remove not necessary QtCore and co
* Fix typo in comment
* Remove duplicated include
* Use explicit
* Use nullptr
* Use override
* Remove unneeded moc includes
* Remove unused cmake macro includes (and include oithers in usual order)
* Remove duplicated feature_summary() call
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Require KDE Frameworks 5.42 and Qt 5.9
* Use add_test signature where target command gets resolved to binary path
* Bump min cmake version to 3.0
* Use KFileWidget::setSupportedSchemes when available

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.13.0
- Update to 5.12.90
- Refresh sddmtheme.diff

==== plasma5-pa ====
Version update (5.12.5 -> 5.13.0)
Subpackages: plasma5-pa-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Don't use plasma theme icons for application icons
* Show OSD when default output changes
* Fix issues in models to pass ModelTest
* use the new install_package form
* Simplify display when there's only a single input device and a single
output device
* Add "move to device" functionality to hamburger menu
* KCM: Show only available device profiles
* Fix output device context menu
* Applet: Use new device icons
* Move availability property from Port to Profile

==== plasma5-workspace ====
Version update (5.12.5 -> 5.13.0)
Subpackages: plasma5-session plasma5-session-wayland plasma5-workspace-lang
plasma5-workspace-libs

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* [Slideshow Wallpaper] Ignore hidden files and folders (kde#394882)
* [Global Menu Applet] Open menu on press
* Weigh matching services by relating data used in query to their menuids
* Add mappings for VirtualBox
* Remove legacy Wine hack-around from rules rc. (kde#393787)
* Calendar widget: fix resize
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Too many changes to list here
- Add patch to add default desktop icons:
* 0001-Revert-No-icons-on-the-desktop-by-default.patch
- Remove patches, now upstream:
* 0001-Add-a-button-to-clear-the-notification-history.patch
* 0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
* 0002-Add-platform-detection-to-KWorkspace-library-to-adju.patch
* 0003-No-longer-export-QT_QPA_PLATFORM-env-variable-to-the.patch
- Remove runtime dep on update-desktop-files

==== polkit-kde-agent-5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Add .arcconfig
* Polish `Details` panel; added "Not Applicable" to fill otherwise blank
spaces
* Add a window icon for authentication dialog under Wayland.
* Fix app initialization order
* Use non-deprecated KDEInstallDirs variables
* Remove unused cmake macro includes
* Use explicit
* Use nullptr
* Use override
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Require KDE Frameworks 5.42 and Qt 5.9
* Bump min cmake version to 3.0, move cmake_minimum_required to top

==== powerdevil5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: powerdevil5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* Revert "Revert "Get rid of KDELibs4Support""
* org.freedesktop.PowerManagement.Inhibit should only prevent suspend
* Use platform detection from KWorkspace in Powerdevil
* Remove outdated condition for calling feature_summary()
* Use non-deprecated KDEInstallDirs variables
* Update D-Bus xml file to use "Out*" for signal type Qt annotations
* End source files with newline
* Fix typos in comments
* Use override
* Use nullptr
* Use explicit
* Remove Qt module include
* Remove module prefixes from Qt includes
* Remove unneeded moc includes
* Remove duplicated add_definitions(-DQT_NO_KEYWORDS)
* Remove unneeded cmake macro include
* Use KF5_MIN_VERSION also for ECM, now that it's part of KF
* Require KDE Frameworks 5.42 and Qt 5.9
* Bump min cmake version to 3.0, move cmake_minimum_required to begin
* Properly define an optional feature, i.e. ddcutils
- Remove patches, now upstream:
* 0001-Use-platform-detection-from-KWorkspace-in-Powerdevil.patch

==== read-only-root-fs ====
Version update (1.0+git20180418.4373cf9 -> 1.0+git20180606.046b099)

- Update to version 1.0+git20180606.046b099:
* Fix missing shebang
* Make scripts executeable
* Enable create-dirs-from-rpmdb.service by default

==== rpcbind ====

- Drop all commented out patches (4 years now):
* 0008-First-part-of-init_transport-refactoring.patch
* 0009-init_transport-move-the-registration-code-into-a-sep.patch
* 0010-Fix-the-behavior-when-specifying-the-h-option.patch
* 0011-Clean-up-the-way-we-handle-the-h-option-in-init_tran.patch
* 0014-When-using-systemd-redirect-syslog-calls-to-the-syst.patch
* 0030-systemd-fix-rmtcall.patch
- Say goodbye to omc files fate#301838
- Format with spec-cleaner

==== shim-leap ====

- Update shim to 14-lp150.8.5.1
+ Replace shim-bsc1092000-fallback-always-try-first-option.patch
with shim-bsc1092000-fallback-menu.patch to show a countdown
menu before reset (bsc#1092000)

==== spectacle ====
Version update (18.04.1 -> 18.04.2)
Subpackages: spectacle-lang

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== squid ====

- a3f6783.patch: Fixes certificate handling with intermediates
chains

==== syndication ====
Version update (18.04.1 -> 18.04.2)

- Update to 18.04.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-18.04.2.php
- Changes since 18.04.1:
* None

==== systemsettings5 ====
Version update (5.12.5 -> 5.13.0)
Subpackages: systemsettings5-lang

- Update to 5.13.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.13.0.php
- Changes since 5.12.90:
* None
- Update to 5.12.90
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.90.php
- Changes since 5.12.5:
* WArning--
* Fix sidebar view regression of not prompting about unsaved changes
(kde#392160)
* Enlarge default window size. Use (adjusted) calculation in `SizeHint` to
determine minimum window width. (kde#389617)
* Fix build with Qt 5.11 (missing QStyle)
* QML applets need to manage padding by themselves
* Add QtQuickSettings
* Add hidden system setting group
* Update systemsettings docbook to 5.12
* Use platform detection in SystemSettings
* Make the item heights rounded to avoid font rendering issues
* Add explicit includes to fix build with Qt 5.11
* Use nullptr
* Use override
* Port from deprecated KRun::run() to KRun::runService()
* Remove module prefix from Qt includes
* Use non-deprecated KDEInstallDirs variables
* Remove '(' and ')'
* Use nullptr
* Increase version
* Use debug categories
* Make it compiles with strict definition
* Use nullptr
- Refresh install_administration_category.diff
- Remove patches, now upstream:
* 0001-Use-platform-detection-in-SystemSettings.patch

==== taglib ====
Subpackages: libtag1 libtag_c0

- Added taglib-CVE-2018-11439.patch: Fix an out-of-bounds read when loading
invalid ogg flac files (CVE-2018-11439, bsc#1096180).
- Applied spec-cleaner to specfile

==== tiff ====
Subpackages: libtiff5 libtiff5-32bit

- security update
* CVE-2018-8905 [bsc#1086408]
+ tiff-CVE-2018-8905.patch
- security update
* CVE-2017-11613 [bsc#1082332]
+ tiff-CVE-2017-11613.patch
- security update
* CVE-2018-7456 [bsc#1082825]
+ tiff-CVE-2018-7456.patch

==== transactional-update ====
Version update (2.3 -> 2.4)

- Update to version 2.4
- Bug fix release

==== upower ====
Subpackages: libupower-glib3 typelib-1_0-UpowerGlib-1_0 upower-lang

- Add upower-fix-crash-logind-doesnt-return-error.patch: Fix crash
if logind doesn't return an error.
- Add upower-fix-memory-leak.patch: Fix memory leak if logind
returns an error.

==== v4l-utils ====
Version update (1.14.1 -> 1.14.2)
Subpackages: libv4l libv4l1-0 libv4l2-0 libv4lconvert0

- Update to version 1.14.2:
* keytable: abi no longer set LIRC_CAN_REC_SCANCODE for raw
devices
* ir-ctl: abi no longer set LIRC_CAN_SEND_SCANCODE for raw
devices

==== webkit2gtk3 ====
Version update (2.20.2 -> 2.20.3)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Update to version 2.20.3:
+ Fix installation directory of API documentation.
+ Disable Gigacage if mmap fails to allocate in Linux.
+ Add user agent quirk for paypal website.
+ Properly detect compiler flags, needed libs, and fallbacks for
usage of 64-bit atomic operations.
+ Fix a network process crash when trying to get cookies of
about:blank page.
+ Fix UI process crash when closing the window under Wayland.
+ Fix several crashes and rendering issues.
+ Security fixes: CVE-2018-4190, CVE-2018-4199, CVE-2018-4218,
CVE-2018-4222, CVE-2018-4232, CVE-2018-4233, CVE-2018-4246,
CVE-2018-11646.
- Drop webkit2gtk3-boo1095611-null-page-url.patch: Fixed upstream.
- Add webkit2gtk3-boo1095611-null-page-url.patch: don't crash if
the page URL is null (CVE-2018-11646).

==== xen ====
Subpackages: xen-doc-html xen-libs xen-tools xen-tools-domU

- bsc#1092543 - GCC 8: xen build fails
gcc8-fix-warning-on-i586.patch

==== xmms2 ====
Subpackages: libxmmsclient-glib1 libxmmsclient6 xmms2-plugin-base

- Drop gnome-vfs2-devel BuildRequires: No longer needed, nor used.
- Run spec-cleaner, modernize spec.

==== yast2-ftp-server ====
Version update (4.0.5 -> 4.1.1)

- Do not modify value when Browse dialog is canceled (bsc#1041829)
- 4.1.1
- Drop SSLv2 and SSLv3 as it is dropped for security reason for
vsftpd (bsc#921303)
- 4.1.0


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >