Mailinglist Archive: opensuse-factory (368 mails)

< Previous Next >
[opensuse-factory] tumbleweed [20180606] - zypper dup issue with libQt5Positioning5
  • From: Andrew Colvin <andrew@xxxxxxxxxxxxx>
  • Date: Sat, 09 Jun 2018 06:29:31 +0100
  • Message-id: <6536867.0f2HA9ivx6@host>
Had to revert back to previous snaphot due to the following QT5 update
libqt5-qtbase (5.10.0 -> 5.11.0)
libqt5-qtconnectivity (5.10.0 -> 5.11.0)
libqt5-qtdeclarative (5.10.0 -> 5.11.0)
libqt5-qtgraphicaleffects (5.10.0 -> 5.11.0)
libqt5-qtimageformats (5.10.0 -> 5.11.0)
libqt5-qtlocation (5.10.0 -> 5.11.0)
libqt5-qtmultimedia (5.10.0 -> 5.11.0)
libqt5-qtquickcontrols (5.10.0 -> 5.11.0)
libqt5-qtquickcontrols2 (5.10.0 -> 5.11.0)
libqt5-qtscript (5.10.0 -> 5.11.0)
libqt5-qtsensors (5.10.0 -> 5.11.0)
libqt5-qtserialport (5.10.0 -> 5.11.0)
libqt5-qtspeech (5.10.0 -> 5.11.0)
libqt5-qtsvg (5.10.0 -> 5.11.0)
libqt5-qttools (5.10.0 -> 5.11.0)
libqt5-qttranslations (5.10.0 -> 5.11.0)
libqt5-qtvirtualkeyboard (5.10.0 -> 5.11.0)
libqt5-qtwayland (5.10.0 -> 5.11.0)
libqt5-qtwebchannel (5.10.0 -> 5.11.0)
libqt5-qtwebengine (5.10.1 -> 5.11.0)
libqt5-qtwebsockets (5.10.0 -> 5.11.0)
libqt5-qtx11extras (5.10.0 -> 5.11.0)
libqt5-qtxmlpatterns (5.10.0 -> 5.11.0)

The following zypper dup error occurs when I try "tumbleweed update" and a
later
zypper dup

Problem: libQt5Positioning5-32bit-5.11.0-1.1.x86_64 requires
libQt5PositioningQuick.so.5,
but this requirement cannot be provided
Problem: libQt5Positioning5-5.10.0-2.2.x86_64 requires libQt5Core.so.
5(Qt_5.10.0_PRIVATE_API)(64bit), but this requirement cannot be provided



Problem: libQt5Positioning5-32bit-5.11.0-1.1.x86_64 requires
libQt5PositioningQuick.so.5,
but this requirement cannot be provided

Each option results in later resolver issues. Anyone else seeing this?

BTW the factory dashboard https://build.opensuse.org/package/view_file/
openSUSE:Factory:Staging/dashboard/installcheck also shows installation
issues:
can't install libqt5-qtwebengine-devel-32bit-5.11.0-1.1.x86_64:
package libqt5-qtwebengine-devel-32bit-5.11.0-1.1.x86_64 requires
libqt5-qtwebengine-32bit = 5.11.0, but none of the providers can be
installed package libqt5-qtwebengine-32bit-5.11.0-1.1.x86_64 requires
libQt5Positioning.so.5, but none of the providers can be installed
package libqt5-qtwebengine-32bit-5.11.0-1.1.x86_64 requires
libQt5Positioning.so.5(Qt_5), but none of the providers can be installed
nothing provides libQt5PositioningQuick.so.5 needed by
libQt5Positioning5-32bit-5.11.0-1.1.x86_64 nothing provides
libQt5PositioningQuick.so.5(Qt_5.11.0_PRIVATE_API) needed by
libQt5Positioning5-32bit-5.11.0-1.1.x86_64
--snip--
can't install libqt5-qtlocation-devel-32bit-5.11.0-1.1.x86_64:
package libqt5-qtlocation-devel-32bit-5.11.0-1.1.x86_64 requires
libQt5Positioning5-32bit = 5.11.0, but none of the providers can be
installed nothing provides libQt5PositioningQuick.so.5 needed by
libQt5Positioning5-32bit-5.11.0-1.1.x86_64 nothing provides
libQt5PositioningQuick.so.5(Qt_5.11.0_PRIVATE_API) needed by
libQt5Positioning5-32bit-5.11.0-1.1.x86_64
--snip--
can't install libQt5WebKit5-devel-32bit-5.212~alpha2-4.6.x86_64:
package libQt5WebKit5-devel-32bit-5.212~alpha2-4.6.x86_64 requires
libQt5WebKit5-32bit = 5.212~alpha2, but none of the providers can be
installed package libQt5WebKit5-32bit-5.212~alpha2-4.6.x86_64 requires
libQt5Positioning.so.5, but none of the providers can be installed
package libQt5WebKit5-32bit-5.212~alpha2-4.6.x86_64 requires
libQt5Positioning.so.5(Qt_5), but none of the providers can be installed
nothing provides libQt5PositioningQuick.so.5 needed by
libQt5Positioning5-32bit-5.11.0-1.1.x86_64 nothing provides
libQt5PositioningQuick.so.5(Qt_5.11.0_PRIVATE_API) needed by
libQt5Positioning5-32bit-5.11.0-1.1.x86_64


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >