Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
[opensuse-factory] Using Python 3 in VirtualBox
Hi,

I have finished converting VirtualBox from Python 2.7 to 3.6, and I am currently testing it. No problems with the new package have been found, once it built without error.

Most of the changes were contained within the VB files; however, the system macro py_compile found in /usr/lib/rpm/macros is hardwired to use the "python" command, which causes it to try to use Python 2.7. My hack is to add a new version of that macro using python3 to the VB spec file. It works, but I am wondering if the system version should use __python, or some other macro. Is this situation worthy of a bug report?

As far as I can tell, all supported versions of openSUSE contain Python 3.6. Should I push this change to Factory as soon as the testing is complete? What about Leap 15.0 and Leap 42.3 updates?

Thanks,

Larry
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages