Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
[opensuse-factory] Re: snapshot 20180525: perl version bump broke texlive-biber-bin dependency
  • From: Achim Gratz <Stromeko@xxxxxxxx>
  • Date: Tue, 29 May 2018 16:14:12 +0200
  • Message-id: <87bmcyim6j.fsf@Rainer.invalid>
Andreas Schwab writes:
Is the `equal` runtime requirement for perl necessary? The build requirement
is `greater or equal`:

%if %{with buildbiber}
BuildRequires: perl-base >= 5.26.1

I think the direct perl dependency should be removed, since the
appropriate perl module dependencies are already present
(eg. perl(Biber)).

Biber needs specific versions of bundled core modules that weren't
present in earlier Perl versions, so unless the above specification can
deal with core module versioning it would seem to be necessary to
explicitly spell out which Perl version is needed.


Regards,
Achim.
--
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

SD adaptation for Waldorf microQ V2.22R2:
http://Synth.Stromeko.net/Downloads.html#WaldorfSDada

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >