Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
Re: [opensuse-factory] Package 'xmonad' is not available in your repositories.
Michal Suchánek writes:

Package 'xmonad' is not available in your repositories. Cannot
reinstall, upgrade, or downgrade.

Is there some more information somewhere?

some 1600 Haskell packages were removed from TW recently, and xmonad was
one of them. I'll try to add xmonad into Factory again at some point,
but I can't say for sure when I'll be able to. It's not going to be
"real soon" -- I know that much.

For the time being, TW contains only a handful of Haskell package that
allow users to set up a *development environment*, i.e. we will have
ghc, cabal-install, and stack in very recent versions. Beyond that,
you'll have to compile other packages yourself.

Having said that, a wealth of Haskell packages is available via OBS:

devel:languages:haskell:lts:11 (ghc-8.2.2)
devel:languages:haskell:lts:next (ghc-8.4.2)

You can safely register any of those projects with your local zypper and
continue to use those binaries.

Best regards
Peter
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References