Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
Re: [opensuse-factory] snapshot 20180525: perl version bump broke texlive-biber-bin dependency
Hello list,

the update of perl to version 5.26.2 broke the texlive subpackage
`texlive-biber-bin`.

In texlive.spec, the required perl version is fixed to the one it was compiled
with (I think):

%package biber-bin
...
Requires: perl = %{perl_version}

Due to the texlive build currently failing, the package in the repository is
still at 5.26.1, zypper thus complains

Problem: nothing provides perl = 5.26.1 needed by
texlive-biber-bin-2018.20180414.svn46862-52.2.noarch
Solution 1: do not install texlive-biber-2018.151.2.11svn47196-38.1.noarch
Solution 2: break texlive-biber-bin-2018.20180414.svn46862-52.2.noarch by
ignoring some of its dependencies

Is the `equal` runtime requirement for perl necessary? The build requirement
is `greater or equal`:

%if %{with buildbiber}
BuildRequires: perl-base >= 5.26.1

Cheers
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups