Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
[opensuse-factory] Leap 15.0 Build 241.1 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=15.0&build=241.1&groupid=50
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Distribution&query_format=advanced&resolution=---&version=Leap%2015.0

When you reply to discuss some issues, make sure to change the subject.
Please use the test plan at
https://docs.google.com/spreadsheets/d/1AGKijKpKiJCB616-bHVoNQuhWHpQLHPWCb3m1p6gXPc/edit#gid=168760829
to record your testing efforts and use bugzilla to report bugs.

Packages changed:
bluedevil5 (5.12.4 -> 5.12.5)
breeze (5.12.4 -> 5.12.5)
breeze-gtk (5.12.4 -> 5.12.5)
breeze4-style (5.12.4 -> 5.12.5)
discover (5.12.4 -> 5.12.5)
drkonqi5 (5.12.4 -> 5.12.5)
gnome-bluetooth
gnome-dictionary
gnome-disk-utility
kactivitymanagerd (5.12.4 -> 5.12.5)
kcm_sddm (5.12.4 -> 5.12.5)
kde-cli-tools5 (5.12.4 -> 5.12.5)
kde-gtk-config5 (5.12.4 -> 5.12.5)
kde-user-manager (5.12.4 -> 5.12.5)
kgamma5 (5.12.4 -> 5.12.5)
khotkeys5 (5.12.4 -> 5.12.5)
kinfocenter5 (5.12.4 -> 5.12.5)
kio
kmenuedit5 (5.12.4 -> 5.12.5)
kscreen5 (5.12.4 -> 5.12.5)
kscreenlocker (5.12.4 -> 5.12.5)
ksshaskpass5 (5.12.4 -> 5.12.5)
ksysguard5 (5.12.4 -> 5.12.5)
kwayland-integration (5.12.4 -> 5.12.5)
kwin5 (5.12.4 -> 5.12.5)
libkdecoration2 (5.12.4 -> 5.12.5)
libkscreen2 (5.12.4 -> 5.12.5)
libksysguard5 (5.12.4 -> 5.12.5)
milou5 (5.12.4 -> 5.12.5)
openssh
oxygen5 (5.12.4 -> 5.12.5)
pam
phonon (4.10.0 -> 4.10.1)
phonon4qt5 (4.10.0 -> 4.10.1)
plasma-framework
plasma-nm5 (5.12.4 -> 5.12.5)
plasma5-addons (5.12.4 -> 5.12.5)
plasma5-desktop (5.12.4 -> 5.12.5)
plasma5-integration (5.12.4 -> 5.12.5)
plasma5-openSUSE (15.0~git20180421T093411~6c02346 ->
15.0~git20180504T125857~b35c1c4)
plasma5-pa (5.12.4 -> 5.12.5)
plasma5-workspace (5.12.4 -> 5.12.5)
polkit-kde-agent-5 (5.12.4 -> 5.12.5)
postgresql
postgresql10
powerdevil5 (5.12.4 -> 5.12.5)
solid
systemd-presets-branding-openSUSE
systemsettings5 (5.12.4 -> 5.12.5)
translation-update
util-linux
util-linux-systemd

=== Details ===

==== bluedevil5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: bluedevil5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== breeze ====
Version update (5.12.4 -> 5.12.5)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== breeze-gtk ====
Version update (5.12.4 -> 5.12.5)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== breeze4-style ====
Version update (5.12.4 -> 5.12.5)

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== discover ====
Version update (5.12.4 -> 5.12.5)
Subpackages: discover-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* Improve display of Progress element (kde#393323)
* More elegant syntax for qrc files in cmake
* Make sure we update the checkability of all delegates when one changes
* PK: Improve information on resources that extend others
* Report 0% update progress when not progressing
* Infer cancellability of the StandardBackendUpdater (kde#390319)
* Forward action enabled state into the button
* Don't change the resources while updating (kde#391262)
* Remove unused variable
* Fix typo
* Fix notifier button placement
* Fix warning on Qt 5.11
* Remove wrongly commented code
* Report when root categories change
* Readability
* Properly concatenate strings
* Fix crash when installing flatpak files
* Remove unneeded dependency
* Don't crash when cancelling flatpak jobs (kde#391941)
* Remove unused imports
* --debug
* Make sure we don't crash automatically (kde#392082)
* Fix sorting when the actual comparison matches
* Fix warning in Qt 5.11

==== drkonqi5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: drkonqi5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== gnome-bluetooth ====
Subpackages: gnome-bluetooth-lang libgnome-bluetooth13
typelib-1_0-GnomeBluetooth-1_0

- Fix Leap specific build failure (BuildRequires needs
translation-update-upstream) (boo#1086036).
- Set gettext domain explicitly in translation-update-upstream,
as it does not support complex meson.build expressions
(bsc#1087076#c21).
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
- Update to version 3.26.1:
+ Fix installation of Bluetooth icons.
+ Fix Bluetooth icon names for bluetooth-sendto in various
translations.
- Update to version 3.26.0:
+ Fix "file received" notifications not being translated.
+ Updated translations.
- Update package summaries. Avoid running fdupes across hardlink
boundaries.
- Update to version 3.25.91:
+ Port to meson build system, and remove autotools build system.
+ Use Unicode in translatable strings.
+ Update Settings UI for updated gnome-control-center UI.
+ Align the explanatory text with the listbox.
+ Fix crash when exiting panel during pairing.
- Add meson BuildRequires and switch autotools macros configure,
make and makeinstall to meson, meson_build and meson_install
following upstream switch to Meson build system.
- Drop %glib2_gsettings_schema_*, desktop_database_* and
%icon_theme_cache_* post/postun macros: the functionality is now
covered by file triggers.
- Add gtk-doc BuildRequires: new dependency, as we no longer
receive the docs pre-built in the tarball.
- Drop intltool BuildRequires: no longer needed.
- Update to version 3.20.1:
+ Unknown device types now show as "Unknown" rather than "All
types".
+ Fix an invisible spinner when pairing.
+ Fix PIN font size.
- Drop gnome-bluetooth-plugins-geoclue Obsoletes: Not been around
since version 3.11.3, no current openSUSE release carry this.
- Drop libgnomebt-devel Obsoletes/Provides and libgnomebt1
Provides: Not been around since 2009.
- Drop obexd-client Requires: obex was merged into bluez a long
time ago, and we already pull it.
- Drop no longer needed Provides/Obsoletes: bluez-gnome and
nautilus-sendto-plugin-bluetooth.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
- Stop passing V=1 to make, we do debugging locally.
- Update to version 3.20.0:
+ Add support for joysticks.
+ Fix small memory leaks.
+ Fix a runtime warning when the vendor is unknown.
+ Fix PIN label size.
- Update to GNOME 3.20 -- Fate#318572.
- Remove 61-gnome-bluetooth-rfkill.rules (no longer needed).
- Update to version 3.18.3:
+ Trust devices paired from the remote device.
- Update to version 3.18.2:
+ Added API to export adapter status.
+ Updated translations.
- Update to version 3.18.1:
+ Fix a number of style regressions in PIN dialogues.
+ Updated translations.
- Nothing in gnome-bluetooth now needs gnome-control-center so
remove the recommendation as non-GNOME solutions based on
gnome-bluetooth exist.
- Update to version 3.18.0:
+ Updated translations.
- Update to version 3.17.92:
+ Updated translations.
- Update to version 3.17.90:
+ This version of the library adds Obex support to the settings
widget. When the settings panel will be opened, other devices
will be able to send files to the computer.
+ Remove outdated end-user documentation.
+ Settings:
- Better empty and disabled state views.
- Handle service authorisation requests for HID devices (mice,
joypads).
- Fix phone icon if extra icons aren't installed.
- Add default PIN for Logitech Ultrathin Touch mouse and
Microsoft Sculpt Comfort mice.
+ Send-to:
- Show better error message when sending a file fails.
- Disallow sending files to iDevices, they don't support Obex.
- Add pkgconfig(libcanberra-gtk3) and pkgconfig(libnotify)
BuildRequires: New dependencies.
- Update to version 3.16.1:
+ Fix Bluetooth 2.1 keyboards not being pairable.
- Update to version 3.16.0:
+ Updated translations.
- Update to version 3.15.4:
+ Fix some memory leaks in BluetoothAgent.
+ Deprecation warning fixes.
+ Use widget templates to create the UI.
- Update to version 3.14.0:
+ Updated translations.
- Update to version 3.13.90:
+ Fix properties dialog bugs.
+ Fix incorrect use of "Setup" as an adjective.
+ Use header bar buttons in bluetooth-sendto.
- Require the udev library for build to allow the move
of udev.pc back to udev
- Update to version 3.12.0:
+ Fix crasher with GTK+ dialogue changes.
+ Updated translations.
- Update to version 3.11.91:
+ Add missing libudev private requires.
+ Require GTK+ 3.11.2.
+ Fix crasher with latest GTK+.
+ Remove GtkStock usage.
+ Updated translations.
- Update to version 3.11.3:
+ Obsolete the separate wizard, instead a widget to create a
Bluetooth Settings panel is provided and will be used by
gnome-control-center.
+ Removed APIs:
- settings/wizard plugins API.
- killswitch (now handled by gnome-settings-daemon's Rfkill
plugin).
- applet gir library.
+ Better icons for headphones, headsets, Apple, Google and
Samsung phones.
- No longer package 61-gnome-bluetooth-rfkill.rules: it lives now
officially andf formally in gnome-settings-daemon.
- Drop gnome-bluetooth-plugins-geoclue subpackage and obsolete it
from the main package: gnome-bluetooth no longer suppoers
plugins.
- No longer pass --disable-scrollkeeper and
- -enable-nautilus-sendto to configure: those parameters haven't
been valid for a few releases.
- Rename libgnome-bluetooth12 subpackage to libgnome-bluetooth13,
following upstreams soname change.
- Update to version 3.10.0:
+ Fix the Bluetooth status icon not appearing in gnome-shell.
+ Fix crashes when the "Connect" switch is used.
+ Add pairing support for the Microsoft Wedge Touch Mouse.
- Update to version 3.9.91:
+ Wizard:
- Remove extraneous tabs.
+ Fix some issues freeing memory.
+ Updated translations.
- Update to version 3.9.3:
+ Fix possible assertion with newer kernels on some hardware.
+ Port to BlueZ 5.
+ API documentation fixes.
+ Send-To:
- Fix "Retry" button.
- Set the From label as soon as we create the window.
- Clear the progress bar text when there's an error.
- Remove duplicate header label.
- Show when all the transfers have completed.
+ Wizard:
- Fix buttons when "retry" is clicked.
- Only enable "PIN options" button if device is selected.
- Hide PIN options dialogue if the selected device changes.
- Rename libgnome-bluetooth11 subpackage to libgnome-bluetooth12,
following upstreams soname change.
- Update to version 3.8.0:
+ Updated translations.
- Update to version 3.7.92:
+ Fix introspection generation for Vala.
+ Updated translations.
- Update to version 3.7.4:
+ Remove fallback applet as GNOME fallback is obsolete.
+ Remove ObexFTP browsing support.
+ Fix help links in GNOME 3.6+.
+ Sendto: Remove nautilus-sendto plugin.
- Drop and obsolete nautilus-sendto-plugin-bluetooth.
- Drop pkgconfig(libnotify) BuildRequires: no longer needed.
- Remove traces of BUILD_FROM_VCS.
- Move udev rules.d files to the right location:
+ Add pkgconfig(udev) BuildRequires.
+ Define _udevdir based on udevdir variable in udev.pc
+ Fix install section to make use of _udevdir.
- Update to version 3.6.1:
+ Library:
- Fix crasher using BlueZ's development version.
- Fix Connect/Disconnect functions not working.
- Add internal helper to talk to /dev/rfkill.
+ Wizard:
- Add another OUI for Apple trackpad.
- Fix crasher doing substring matching.
- Add a white button press (meaning Return) for iCades.
- own udev directories to avoid udev buildrequire
- Update to version 3.6.0:
+ Updated translations.
- Update to version 3.5.92:
+ Fix warning in BluetoothAgent
+ Add pairing support for iCade variants (mobile, core and jr.)
+ Use yelp-tools instead of gnome-doc-utils
+ Support LXDE with the fallback applet too
+ Updated translations.
- Replace gnome-doc-utils-devel BuildRequires with yelp-tools,
following upstream.
- Drop lxde-support.patch: fixed upstream.
- Update to version 3.5.5:
+ Allow building with nautilus-sendto 3.6
+ Namespace killswitch API properly
+ Loads of API documentation fixes
- Update to version 3.5.4:
+ Library: Fix stuck "Finishing" page for some devices.
+ Applet: Fix warning and empty device name in some cases.
+ Wizard: Use shorter label for the finishing pages.
- Rename libgnome-bluetooth10 subpackage to libgnome-bluetooth11,
following upstreams soname bump.
- Update to version 3.4.2:
+ Library:
- Support for BlueZ 5.0 API
- Fix memory leak when registering the pairing agent
+ Applet:
- Fix assertion in gnome-shell when a device requires
authorisation
+ Wizard:
- Fix Simple Pairing never succeeding
- Fix stuck "Finishing page" for some devices
- Drop gnome-bluetooth-fix-pairing.patch and
gnome-bluetooth-fix-stuck-finish-page.patch: fixed upstream.
- Drop xz BuildRequires as it now comes for free in the build
system.
- Added gnome-bluetooth-fix-pairing.patch and
gnome-bluetooth-fix-stuck-finish-page.patch to enable pairing of
devices again (bnc#769536, bgo#679190, rh#819203).
- Update to version 3.4.1:
+ Library:
- Fix potential crashes when registering pairing agents with no
adapter present
- Fix warning when bluetooth-sendto exits
- Better API documentation
- Fix warnings related to BluetoothStatusClass
+ Send-To:
- Document the --name option
- Make the "Retry" button always visible
- Fix warnings when saving the last used address
+ Wizard:
- Fix setup of devices that don't require pairing
+ Updated translations.
- Update 61-gnome-bluetooth-rfkill.rules due to the removal of
udev-acl in udev >= 182.
- Update to version 3.4.0:
+ Updated translations.
- Update to version 3.3.92:
+ Applet:
- String fixes
+ Library:
- Remove generated file from version control
+ Wizard:
- Add support for pairing the iCade
- Improve support for keyboard PINs
- Add OUI for Apple Magic Trackpad
- Add OUI for Sony BD Remote Control
- Update to version 3.3.4:
+ Applet:
- Fix newly paired devices not appearing in menus
- Update fallback menu to match GNOME Shell's
+ Library:
- Make the Connect/Disconnect helper function work
- Do not use dbus-glib-1 when building introspection data
- Remove header from chooser widget, breaks API
+ Wizard:
- Fix assertion when exiting
- Remove "Device Setup Failed" label from the sidebar
- A number of UI tweaks
+ Plus build fixes, and the removal of the unmaintained Moblin UI
- Drop gnome-bluetooth-no-dbus-glib.patch: fixed upstream.
- Rename libgnome-bluetooth9 subpackage to libgnome-bluetooth10,
following upstream soversion change.
- Change gnome-control-center Requires to Recommends, to avoid a
build loop.
- Add gnome-control-center Requires for bluetooth setup to work
(bnc#732689)
- Update to version 3.3.3:
+ Library:
- GVariant fixes
- Build improvements
+ Applet:
- Fix a packing issue
+ Wizard:
- Improvements in the handling of PIN codes
- Fix a segfault
- Fix an UI issue with the "Close" button
- Add xz BuildRequires because we can't build a package for a
xz-compressed tarball without explicitly specifying that... See
bnc#697467 for more details.
- Remove gtk2-devel Requires from devel subpackage: it will
automatically be added the pkgconfig() way.
- Rewrite summary and description of devel subpackage.
- Change group of libgnome-bluetooth9 and
typelib-1_0-GnomeBluetooth-1_0 from System/GUI/GNOME to
System/Libraries.
- Add gnome-bluetooth-no-dbus-glib.patch: finish removing dbus-glib
usage in the build system.
- Remove pkgconfig(dbus-glib-1) BuildRequires: it is gone since
version 3.3.2.
- Split typelib file into typelib-1_0-GnomeBluetooth-1_0
subpackage.
- Add typelib-1_0-GnomeBluetooth-1_0 Requires to devel subpackage.
- Remove all .la files: gnome-bluetooth-applet.la on its own has
reference to the other la files, so keeping some of them breaks
more than it serves.
- Update to version 3.3.2:
+ Library:
- Clean up public API
- Port to GDBus
- Small UI fixes to the chooser
+ Properties:
- Move to gnome-control-center
+ Wizard:
- Remove special-case Wiimote handling (now in Bluez)
- Remove multi-adapter support
+ Updated translations.
- Drop gnome-bluetooth-fix-crash.patch: fixed upstream another way.
- Rename libgnome-bluetooth8 to libgnome-bluetooth9, following
soversion bump.
- Update to version 3.2.1:
+ Fix warnings about BluetoothStatusClass
+ Fix small memory leaks
+ Updated translations.
- Add gnome-bluetooth-fix-crash.patch: fix various crashes in
libgnome-bluetooth, that help a bit getting bluetooth working in
GNOME. Part of bnc#722722.
- Update to version 3.2.0:
+ Updated translations.
- Update to version 3.1.92:
+ Properties:
- Use links to link to other panels
- Fix rounded toolbar buttons
+ Applet:
- Fix "browse" menu item
+ Updated translations.
- Update to version 3.1.4:
+ Properties: Fix crash when device has no UUIDs
+ Applet: Change preferences menu items to match the gnome-shell
UI
+ Updated translations.
- Drop gnome-bluetooth-libgnome-control-center.patch: fixed
upstream.
- Remove now unneeded gnome-common BuildRequires and call to
gnome-autogen.sh.
- Add gnome-bluetooth-libgnome-control-center.patch: the new
gnome-control-center doesn't install libgnome-control-center
development files, so work around this.
- Add gnome-common BuildRequires and call to gnome-autogen.sh,
needed for the patch.
- Remove now unneeded pkgconfig(libgnome-control-center)
BuildRequires.
- Update to version 3.1.3:
+ Properties:
- Show extra configuration widgets in the properties
- Add Send/Browse buttons
- Small UI changes
+ Applet:
- Fix crasher when "Browsing device" using the menu item
- Fix "Send To..." overquoting the Bluetooth address
+ Wizard:
- Handle Wiimote pairing through newer bluez
- Fix a lot of keys not working in the custom PIN entry
- Fix display of Secure Simple Pairing passkeys
- Add old Apple wireless mouse to the PIN database
- Update to version 3.0.1:
+ Applet:
- Fix crasher when using "browse"
- Fix startup not working in fallback mode
+ Wizard:
- Add support for more Wiimotes
- Fix custom PIN entry not working as expected
- Fix display of SSP passkeys
+ Library:
- Fix possible warnings in debug mode
- Update to version 3.0.0:
+ Properties:
- Show link to touchpad settings for touchpads
- Hide labels when no devices are selected
+ Updated translations.
- Update to version 2.91.92:
+ Properties:
- Use dim labels
- Fix translation problems
- Use the inline-toolbar style
+ Geoclue plugin:
- Use GSettings instead of GConf
+ Wizard:
- Add Magic Trackpad quirk
- Update to version 2.91.91:
+ Properties:
- Put in the control-center's Hardware category
- Redesign for GNOME 3
+ Applet:
- Only start the applet in the fallback session
+ Library:
- Fix a possible warning in the button chooser
+ Sendto:
- Re-enable sento plugin for GNOME 3.0
- Make double-click select a device
- Add desktop file for nice name in the shell
- Fix packing in dialogue
+ Wizard:
- Add desktop file for nice name in the shell
- Changes fromv version 2.91.5:
+ Properties:
- Make dialogue parenting work for errors
+ Library:
- Use BluetoothClient to track default adapter
- Don't free request_key and passkey in agent reply functions.
- Set log domain to differentiate library messages from the
lib's ones
+ Applet:
- Fix crash in bluetooth_applet_create_device_from_iter()
- Fix crash when creating an agent
- Fix crash when unref'ing a DBusGMethodInvocation
- Fix crash when there's no default adapter
+ Moblin:
- Fix compilation of the Moblin front-end
- Changes from version 2.91.2:
+ Update command to launch Bluetooth panel
+ Fix i18n in the panel
+ Make test-plugins test command more useful
+ Fix adapter not going powered when coming back from hard-block
+ Allow setup of devices that don't support pairing
+ Make sure the icon is shown/hidden when killswitch state
changes.
+ Make sure all the unblocked adapters get powered on startup
+ Fix visible menu item disappearing after suspend
+ Make --dump-devices work again in the applet, and
fix its output for some services
+ Refactor applet as a library, for use in gnome-shell
+ Build fixes
- Changes from version 2.90.0:
+ Port to GSettings, GTK+ 3.x and GtkApplication
+ Use GBinding instead of copy/paste Seahorse code
+ Plenty of killswitch bug fixes
+ Applet:
- Fix browsing a device when already mounted
- Use symbolic icons
+ Properties:
- Port to gnome-control-center 3.x API
- Add a specific page when Bluetooth is hard-blocked
+ Moblin/MeeGo:
- Use bluetoothd backed power switch
- Some re-designs for meego
- Change obexed Requires to obexd-client.
- Drop gnome-bluetooth-fix-introspection-build.patch: fixed
upstream.
- Remove no longer needed libunique-devel BuildRequires.
- Add pkgconfig() BuildRequires now needed: dbus-glib-1, gtk+-3.0,
libgnome-control-center.
- Move to pkgconfig()-style BuildRequires:
+ Old ones: nautilus-sendto-devel
+ New ones: nautilus-sendto.
- Add support for source service checkout, with %BUILD_FROM_VCS:
+ Add gnome-common and gtk-doc BuildRequires.
+ Add call to ./autogen.sh.
+ Enforce gtk-doc html generation by passing --enable-gtk-doc to
configure.
- Add 61-gnome-bluetooth-rfkill.rules: add ACL to rfkill device.
This will be replaced by urfkill in the future, but in the
meantime, people need to be able to switch off devices. Fix
bnc#632256.
- Call relevant macros in %post/%postun:
+ %desktop_database_post/postun because the package ships at
least one desktop file.
+ %icon_theme_cache_post/postun because the package ships themed
icons.
- Pass %{?no_lang_C} to %find_lang so that english documentation
can be packaged with the program, and not in the lang subpackage.
- Change Requires of lang subpackage to Recommends, since the
english documentation is not there anymore.
- Add gnome-bluetooth-fix-introspection-build.patch, which
obsoletes gnome-bluetooth-fix-parallel-build.patch: this updated
patch will really fix the build with recent
gobject-introspection.
- Update to version 2.32.0:
+ Updated translations.
- Move gir files to devel subpackage.
- Remove gir-repository BuildRequires: this was only needed for the
DBusGLib gir, which is now part of gobject-introspection.
- Add gnome-bluetooth-fix-parallel-build.patch: this updates the
build system for introspection, to work correctly. This requires
the gnome-common BuildRequires and the call to gnome-autogen.sh.
- Update to version 2.31.90:
+ More killswitch fixes
+ Fix crasher when Bluetooth nautilus-sendto plugin is loaded
- Do not add a GenericName to bluetooth-applet.desktop: it's an
autostart file, so it's not needed.
- Do not add/change GenericName and Name for
bluetooth-properties.desktop: it only appears in the control
center now, and we don't need to change those keys in this case
(the changes made sense for the applications menu).
- Add Supplements to automatically install plugins-geoclue if
gnome-bluetooth and geoclue are installed.
- Update to version 2.31.6:
+ Allow setting up devices that do not use pairing
+ Port to GSettings instead of GConf
+ Properties:
- Add specific page when the only adapter is hard blocked
through a physical killswitch
- Remove --disable-schemas-install from configure call
(gconf-specific) and update packaging to handle GSettings schemas
instead of gconf schemas.
- Rename libgnome-bluetooth7 to libgnome-bluetooth8 after bump in
library soname.
- Require bluez and obexd, fixes bnc#622946.
- Revert previous change about adding HardwareSettings category to
bluetooth-properties.desktop, post-11.3.
- Add HardwareSettings category to bluetooth-properties.desktop to
make it appear at the right place. This is needed because
update-desktop-files won't keep the X-GNOME-* categories in 11.3.
- Fix calls to suse_update_desktop_file: the arguments were not in
the right order.
- Update to version 2.30.0:
+ Add PIN code for Navman GPS
+ Updated translations.
- Update to version 2.29.91:
+ Mention gnome-user-share in the documentation
+ Applet:
- Link to the sound preferences for audio devices
- Remove hard-coded use of nautilus
+ Library:
- Use spinner from GTK+
- Install introspection data properly
- API documentation fixes
- Fix some parts of the UI not being translated at run-time
+ Wizard:
- Fix run-time warning when pairing a new device
+ Moblin applet;
- Add summary page support
- Fix a number of memory leaks and possible crashers
+ Sendto:
- Fix crash when obex-client isn't already running
- Make Cancel button actually work
- Implement "retry" when sending fails
- Fix progress bar when sending multiple files
- Drop upstream merged gnome-bluetooth-introspection-install.patch.
- Remove unused BuildRequires hal-devel
- Update to version 2.29.3:
+ Build and install nautilus-sendto plugin by default
+ Preferences:
- Add a button to access "Personal File Sharing" preferences
+ Library:
- Clean up combo box selection widget
- Make it possible to set the selected device in the chooser
- Make the button chooser select the device when popping up a
dialogue
+ Sendto:
- Wrap errors instead of clipping them
+ Wizard:
- Make it possible to re-pair devices
- Changes from version 2.29.2:
+ Add Moblin front-end for gnome-bluetooth
+ Add experimental nautilus-sendto plugin
+ Applet:
- Fix applet showing the wrong connection information
- Use separate icon for the status icon, for monochromatic
themes
- Add discoverable menu item
- Fix a number of rfkill related bugs
+ Library:
- Make it possible use another widget for device filtering
- Don't overwrite UUIDs when discovering known devices
- Add BluetoothChooserCombo widget
- Fix usage under non-UTF-8 locales
- Add nautilus-sendto-devel BuildRequires and create
nautilus-sendto-plugin-bluetooth subpackage.
- Enable introspection: add gir-repository and
gobject-introspection-devel BuildRequires, pass
- -enable-introspection to configure.
- Add gnome-bluetooth-introspection-install.patch to fix
installation of introspection data.
- added LXDE support to /etc/xdg/autostart/bluetooth-applet.desktop
- Update to version 2.28.1:
+ Applet:
- Fix most devices showing up as connected when they aren't
- Make sure the pairing agent is only bound to the default
adapter
+ All:
- String fixes
- API documentation updates
- Filtering fixes in the BluetoothChooser
- Update to version 2.28.0:
+ Applet:
- Applet fails to connect to disconnected audio devices
- Fix crash when getting a pairing request from a known rfcomm
device
+ Wizard:
- Fix pairing of devices that require a PIN entry
- Update to version 2.27.90:
+ Fix crasher when exiting and the NetworkManager plugin was
installed.
+ Fix wizard not loading because of a bug in the UI definition.
+ Fix keyboard not working.
- Update to version 2.27.9:
+ All:
- Port to using new rfkill API in Linux kernel 2.6.31
+ Applet:
- Hide unwanted menu items when Bluetooth isn't available
- Fix connecting to Sony Ericsson phones
- Fix a crash when disconnecting an audio device
- Fix devices showing up as connected when they were not
+ Properties:
- Close the preferences dialogue when pressing 'Esc'
+ Wizard:
- Mention "enter" when pairing a keyboard
- String fixes
+ Library:
- Track whether devices are connecting, as opposed to already
connected
- Remove Obsoletes for libgnome-bluetooth2 and libgnome-bluetooth6.
- Update to version 2.27.8:
+ All:
- A number of UI strings changes
+ Applet:
- Make "Connect" in the menu for devices appear correctly after
pairing
- Filter for paired ObexFTP devices in the browse menu item
+ Preferences:
- Add link to help
+ Wizard:
- Fix crash when selecting a device where the name hasn't been
resolved yet
+ Library:
- Add introspection support
- Export device and adapter models for easy enumeration
- Fix broken filtering for device category
- Fix possible crasher in spinner widget
- Ellipsise names in the chooser widget
- A number of API documentation fixes
- Rename libgnome-bluetooth6 to libgnome-bluetooth7 because of
soname change.
- Have libgnome-bluetooth7 Obsoletes libgnome-bluetooth6.
- Update to version 2.27.7.1:
+ When deleting a device, pass it through the plugins
to delete any other associations
+ Add a test program
+ Add Geoclue GPS setup plugin
+ Fix pairing some fixed PIN devices, and misc fixes
- Create subpackage plugins-geoclue
- Update to version 2.27.6:
+ Applet:
- Use a better tooltip for the applet
- Add "Send File" and "Browse files" menu item for devices that
support it
- Add menu items to call the preferences for mice and keyboards
- Fix assertions when removing a device, and pairing it again
without the applet being restarted
- Don't show "Connect" for devices without input or audio
capabilities
- Support notification-daemon without any support for actions,
as used in Ubuntu
- Pass the device name to bluetooth-sendto
- Rework UI of all the pairing helper dialogues
+ Preferences:
- Fix the adapter page not showing up when restarting
bluetoothd
- Add --dump debug option, to dump a list of all known devices
and their properties
+ Send-to:
- Fix warning when sending an empty file
- Remove use of red labels on errors
- Remove obex-data-server support, and require obexd
- Try harder to get a device name
+ Wizard:
- Fix handling for devices that use random passkeys, but can't
handle 6 digits (such as Sony CMT-DH5BT)
- Add Simple Pairing support
- Try harder to connect to devices after pairing them, fixes
the Microsoft Wireless Notebook Presenter Mouse 8000 not
working straight after pairing
- Allow skipping name resolution when we would be using a fixed
passkey
- Don't allow stepping back in the middle of pairing
- Add more instructions on the front page
- Many many UI changes
+ Library:
- Allow getting arbitrary data from the backend for
BluetoothChooser users
- Only export the supported symbols in the library
- Add plugin support, so third-party applications can be setup,
for a particular device, from the preferences or the wizard
- Replace the search button with a "Searching" label and spinner
- Rename libgnome-bluetooth2 to libgnome-bluetooth6, and have it
Obsoletes libgnome-bluetooth2 <= 2.27.5.
- Update to version 2.27.5:
+ Fix some killswitch related bugs
+ Work with older versions of Pango
+ Fix pairing with Blackberry and Samsung phones
+ Use the services status to check the connection status, makes
connecting/disconnecting devices much faster
+ Add a quit menu to the applet, when in debug mode
+ Fix passkey special-casing when a OUI is used
- Change BuildRequires from unique-devel to libunique-devel
- Update to version 2.27.4:
+ Fix display of labels on the passkey page, and of the passkey
on the passkey options dialogue
+ More use of GtkBuilder in the wizard
+ First pass at user-targetted documentation
+ Fix a few memory leaks
+ Fix crash when running properties installed
- Changes from version 2.27.3:
+ Fix schema installation
+ Make sure the applet works even without the schema being
installed properly
+ Fix display of devices with underscores in their name in the
applet
+ Fix some devices with no real audio support (AVCRP phones for
example) showing up in the applet
- Add gnome-doc-utils-devel BuildRequires.
- Pass --disable-scrollkeeper to configure.
- Package documentation too.
- Use fdupes.
- Update to version 2.27.2:
+ General:
- Use our own "paired" icon, to avoid confusion in some themes
- Remove "Trust" from the UI, it's an implementation detail
- Group input and audio device-types under the same heading in
the chooser
+ Applet:
- Use new "disabled" icons
- Add a status label for the killswitch menu item
- Add the ability to connect/disconnect from devices directly
from the applet's menu
+ Properties:
- Only show the default adapter, and simplify the UI
- Show a way to turn off the killswitch when there's no
Bluetooth adapters in the machine
+ Wizard:
- Don't show "Enter passkey" when we know the passkey of the
device already
- Remove special-casing of mice, and PS3 BD remote from the
code and into the database
- Move passkey options button back into the content area, from
the action area
- Simplify passkey options dialogue
- Connect to input and audio devices when setup finishes
- Mark all the newly paired devices as trusted
- Fix the wizard not allowing to get past the search page when
the device selected didn't have a name at first
- Port quirks database to XML
- Add quirk for the Bluemax Bluetooth GPS Receiver GPS-009
- Add quirk for the Nintendo Wiimote
- Add quirk for iBT-GPS, and another GPS
+ Sendto:
- Fix obex-data-server support
- Added support for translation-update-upstream (FATE#301344).
- Add Obsoletes/Provides for libgnomebt-devel.
- Make gnome-bluetooth Obsoletes/Provides bluez-gnome since it's a
drop-in replacement for bluez-gnome.
- Don't set the name in bluetooth-applet.desktop to the preexisting
value.
- Update to version 2.27.1:
+ This is basically a new package, forked from bluez-gnome

==== gnome-dictionary ====
Subpackages: gnome-dictionary-lang

- Set gettext domain explicitly in translation-update-upstream,
as it does not support complex meson.build expressions
(bsc#1091307).
- Update to version 3.26.1+20180313.ac6d4c0:
+ Remove po/Makevars.
+ Flatpak: use meson from flatpak build definition.
+ Fix translations of the Name key.
+ Drop build-api wrapper for Continuous.
+ Updated translations.
- Switch to git-checkout via source services.
- Drop obsolete gnome-utils Conflicts and update-desktop-files
BuildRequires and stop passing glib2_gsettings_schema_requires
and suse_update_desktop_file macros.
- Use autosetup macro and pass explicit use_ipv6=true and
build_man=true to meson, ensure we build the features we want.
- Update URL to correct home.
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).
- Modernize spec-file by calling spec-cleaner
- Update to version 3.26.1:
+ Menu for dictionary selection has too small size (bgo#777584).
+ Can't add dictionary sources (bgo#762589).
+ Updated translations.
- Update to version 3.26.0:
+ Update the gnome-dictionary man page and install it
(bgo#786319).
+ Ensure that desktop files and AppData metadata is valid.
+ Updated translations.
- Update to version 3.25.90:
+ The GDict library is now private for GNOME Dictionary, and it
is not installed any more.
+ The "Description" key for dictionary sources has been
deprecated, and replaced with the "Comment" one, to allow for
localisation with Gettext.
+ GNOME Dictionary does not depend on intltool for builds.
+ GNOME Dictionary switched to the Meson build system from
Autotools.
+ Use natural_width for database popover (bgo#777584).
+ Fix typos in manual (bgo#766412).
+ Fix displaying the program name in the about dialog
(bgo#784343).
+ Updated translations.
- Add meson BuildRequires and switch autotools macros configure,
make and makeinstall to meson, meson_build and meson_install
following upstream switch to Meson build system.
- Drop intltool BuildRequires: no longer needed.
- Drop libgdata-1_0-10, typelib-1_0-GDict-1_0 and libgdict-data
subpackage: the library is no longer public.
- Obsolete libgdict-data, as the files that were in this package
have been merged into the main package.
- Update to version 3.24.0:
+ Move more UI into the XML template.
+ Fix the DatabaseChooserButton construction.
+ Remove unused app menu item.
+ Store the appropriate window size.
+ Bump up the dependency on GLib and GTK+.
+ Use Unicode in translatable strings.
+ Add Ctrl+Q keyboard accelerator quit shortcut.
+ Updated translations.
- Switch back to released tarball:
+ Drop _service handling.
+ Drop gnome-common BuildRequires and autogen.sh call.
- Update to version 3.20.1+20170312.f3d61d5:
+ Add Flatpak manifest
+ Include the right header in GdictClientContext
+ Use gtk_show_uri_on_window() with newer GTK+
+ Use gtk_menu_popup_at_widget() with newer GTK+
+ Update translation.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.
- Switch to source service and use latest upstream git. Following
this: Add gnome-common BuildRequires and autogen call.
- Add gtk-doc BuildRequires: and pass --enable-gtk to configure,
needed now that we use a git checkout.
- Add gobject-introspection-devel BuildRequires: New dependency.
- Split out new typelib sub package typelib-1_0-Gdict-1.0.
- Update to version 3.20.0:
+ Updated translations.
- Update to version 3.19.91:
+ Updated translations.
- Update to version 3.19.90:
+ Application: Add a missing tag to the AppData file.
+ Updated translations.
- Update to version 3.19.0:
+ Update the AppData file to spec version 0.7+.
+ Drop deprecated API from DefBox.
+ Bump required Gtk+ version.
+ Updated translations.
- Update to version 3.18.1:
+ Library:
- Create new GdictDatabaseChooserButton widget.
- Symbolic icons.
+ Application:
- Fix spelling in "Creating XDG config directory" message.
- Use GTK's automagic menu loading.
- Symbolic icons.
- Replace action area with header bar.
- Replace deprecated GtkTable with GtkGrid.
+ Updated translations.
- Rename libgdict-1_0-9 subpackage to libgdict-1_0-10, following
upstreams soname bump.
- Update to version 3.18.0:
+ Updated translations.
- Update to version 3.17.90:
+ Library:
- Split lookup-start and lookup-end signals.
- Improve GdictDatabaseChooser widget.
- Add library initialize function.
+ Updated translations.
- Rename libgdict-1_0-8 subpackage to libgdict-1_0-9, following
upstreams soname bump.
- Add libgdict-1_0-8 Obsoletes. We already obsolete libgdict-1_0-6.
- Update to version 3.17.4:
+ Updated translations.
- Update to version 3.17.3:
+ Remove Select All menu entry.
+ Remove Edit submenu.
+ Remove Close menu entry.
+ Make entries under File top-level menu entries.
+ Remove obsolete gdict_window_defbox_selection_changed.
+ Updated translations.
- Own %{_datadir}/appdata for openSUSE:42.
- Update to version 3.17.2:
+ Fix bgo#749131: Do not translate stack pages titles.
+ Remove Copy menu entry.
+ Updated translations.
- Update to version 3.17.1:
+ Pass the application pointer to the window constructor.
+ Drop homegrown app singleton.
+ Use widget templates to build GdictPrefDialog.
+ Rename the GdictPrefDialog UI definition.
+ Rename the menus UI definition file.
+ Use widget templates for GdictSourceDialog.
+ Updated translations.
- Update to version 3.16.2:
+ Updated translations.
- Update to version 3.16.1:
+ Application:
- Remove compilation warnings.
- Improve menu items sensitivity.
+ Library: Add GdictDefbox::selection-changed signal.
+ Updated translations.
- Update to version 3.16.0:
+ Documentation: Fix paste keyboard shortcut.
+ Updated translations.
- Update to version 3.15.92:
+ Implement GApplication::activate signal.
+ Updated translations.
- Update to version 3.15.91:
+ Application:
- Rename the AppData file to match the desktop name.
- Drop slash for the 'Find' action.
+ Build system fixes.
+ Bugs fixed: bgo#745022.
+ Updated translations.
- Rename libgdict-1_0-6 subpackage to libgdict-1_0-8, following
upstreams soname bump.
- Split out a new libgdict-data package, required by
libgdata-1_0-8, in order to not have conflicts in the future.
- Obsolete libgdict-1_0-6 from the new -data package. Not exactly
correct, but aids on upgrades. gnome-dictionary is the only
consumer of this library.
- Update to version 3.15.90:
+ Application:
- Convert to new-style commandline option handling.
- Make DBus-activatable.
- bgo#528956: duplicated dictionary sources.
+ Library:
- Fix emission of lookup-start.
- Add GObject introspection support.
+ Updated translations.
- Added support for translation-update-upstream.
- Update to version 3.14.2:
+ Application: Use g_timeout_add_seconds() for multi-second
timeouts.
+ Updated translations.
- Update to version 3.14.1:
+ bgo#737626: expand sidebar.
+ Updated translations.
- Update to version 3.14.0:
+ Updated translations.
- Update to version 3.13.92:
+ Code fixes.
+ User documentation fixes.
+ Updated translations.
- Update to version 3.10.0:
+ Sidebar: Do not select unrealized menu items.
+ Fix bugzilla product in .desktop file.
+ Fix Ctrl+A and Ctrl+C in the search field.
+ Build system fixes.
+ Bugs fixed: bgo#706556.
+ Updated translations.
- Update to version 3.9.0:
+ Updated translations.
- Update to version 3.8.0:
+ Re-written help in Mallard.
+ Updated translations.
- No longer pass --disable-scrollkeeper to configure: after the
rewrite of the help in Mallard it is no longer used/known.
- Add fdupes BuildRequires and call fdupes in install section to
link equal files, saving some space.
- Update to version 3.6.0:
+ Updated translations.
- Replace pkgconfig(gnome-doc-utils) BuildRequires with yelp-tools:
even though not specified in NEWS, this release switched to the
new documentation infrastructure.
- Update to version 3.5.2:
+ Drop usage of deprecated methods
+ Use the new GMenu API
+ Updated translations.
- Update to version 3.4.0:
+ Use XDG configuration directories to store the dictionary data.
+ Updated translations.
- Initial package, version 3.3.2:
+ First release after the split from gnome-utils.

==== gnome-disk-utility ====
Subpackages: gnome-disk-utility-lang

- Set gettext domain explicitly in translation-update-upstream,
as it does not support complex meson.build expressions
(bsc#1087076#c21).
- Unconditionally enable translation-update-upstream: on
Tumbleweed, this results in a NOP and for Leap in SLE paid
translations being used (boo#1086036).

==== kactivitymanagerd ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kactivitymanagerd-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kcm_sddm ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kcm_sddm-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* Also read sddm.conf.d config directories
* Use XCursorTheme on wayland as well
* Read theme.conf of themes
- It's whitelisted (bsc#1065563), no need to keep this around

==== kde-cli-tools5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kde-cli-tools5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kde-gtk-config5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kde-user-manager ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kde-user-manager-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kgamma5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kgamma5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== khotkeys5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: khotkeys5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kinfocenter5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kinfocenter5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* kcm_opengl: Fix EGL info retrieval.

==== kio ====
Subpackages: kio-core kio-lang

- Add 0001-Revert-Support-NTFS-hidden-files.patch to revert the new
support for NTFS hidden files, it caused the mount point itself
to be hidden (boo#1091780, kde#392913)

==== kmenuedit5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kmenuedit5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kscreen5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kscreen5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kscreenlocker ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== ksshaskpass5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: ksshaskpass5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== ksysguard5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: ksysguard5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kwayland-integration ====
Version update (5.12.4 -> 5.12.5)

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== kwin5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: kwin5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* Convert JS files to UTF-8 (from ISO-8859-15)
* [KScreen Effect] Fix fade to black (kde#388384)
* Reparse the input configuration when we are notified that it changed
* Don't try to filter null key combinations (kde#390110)
* drm backend: choose correct EGL config with mesa-18
* Ensure _NET_CURRENT_DESKTOP is set on startup (kde#391034)

==== libkdecoration2 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: libkdecorations2-5 libkdecorations2private5

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== libkscreen2 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: libKF5Screen7 libkscreen2-plugin

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== libksysguard5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: libksysguard5-helper libksysguard5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* [ProcessModel] Return invalid QVariant() for when window is not known

==== milou5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: milou5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== openssh ====
Subpackages: openssh-helpers

- Use TIRPC on suse_version >= 1500: sunrpc is deprecated and
should be replaced by TIRPC.
- additional rebased patches (bsc#1080779)
* auditing support
* LDAP integration
* various distribution tweaks from SLE12
(X forwarding over IPv6, sftp forced permissions
and verbose batch mode)

==== oxygen5 ====
Version update (5.12.4 -> 5.12.5)

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None

==== pam ====
Subpackages: pam-32bit

- pam_umask.8 needed to be patched as well.
[bsc#1089884, pam-fix-config-order-in-manpage.patch]
- Changed order of configuration files to reflect actual code.
[bsc#1089884, pam-fix-config-order-in-manpage.patch]

==== phonon ====
Version update (4.10.0 -> 4.10.1)

- Update to 4.10.1:
* CMake files are now compatible with Qt 5.11. Note that the
relevant CMake code is shared with the backends, and thus also
fixes the compatibility issue there.

==== phonon4qt5 ====
Version update (4.10.0 -> 4.10.1)

- Update to 4.10.1:
* CMake files are now compatible with Qt 5.11. Note that the
relevant CMake code is shared with the backends, and thus also
fixes the compatibility issue there.

==== plasma-framework ====
Subpackages: plasma-framework-components plasma-framework-lang
plasma-framework-private

- Remove outdated calendar.svgz from the Air and Oxygen themes to
fix showing event markers in the calendar (boo#1091832)
- Add Air-Oxygen-themes-Bump-version.patch to raise the version of
these 2 themes, otherwise Plasma would reuse existing caches
rendering the above fix ineffective
- Add patches to fix window thumbnails on Nvidia:
* 0001-Revert-windowthumbnail-Use-gamma-correct-scaling.patch
* 0002-Revert-windowthumbnail-Use-mipmap-texture-filtering.patch
- Add Dont-alter-memory-management-to-hide-an-item.patch to fix a
possible Plasma crash when changing the desktop layout
(kde#391642)

==== plasma-nm5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp

- Unconditionally provide the -vpnc subpackage again for now, vpnc
is still in Tumbleweed and has been revived for Leap 15.0
- Activate proper Requires and Supplements for the -openswan,
- l2tp, and -iodine subpackages, the corresponding NetworkManager
packages are in Factory (and Leap) meanwhile
- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* None
- Fix plasma-nm5-openconnect supplements
- Don't provide the -vpnc subpackage anymore on TW and Leap 15

==== plasma5-addons ====
Version update (5.12.4 -> 5.12.5)
Subpackages: plasma5-addons-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* Fix run-time warnings on quick-share
* [mediaframe applet] Enable wrapping of fill mode description in config UI
(kde#393232)
* [quickshare applet] Fix sizing of complete color config page
* [quickshare applet] Fix layout of elements in config page
* [mediaframe applet] Fix defunct adding of new files/folder per DnD
* [mediaframe applet] Fix broken selection of fill mode
* [notes applet] Remove unused/unneeded import of private.notifications
* [potd dataengine] Fix Wikimedia Picture of the Day provider
* [Media Frame] Fix config pages to fit themselves into dialog
* [weather applet] Fix wind direction arrows to adapt to color theme
* [potd wallpaper] Add missing Messages.sh, use wallpaper catalog name
* [potd wallpaper] Config UI: fix spacing between UI elements
* [potd dataengine] Do not leak pimpl object of PotdProvider class

==== plasma5-desktop ====
Version update (5.12.4 -> 5.12.5)
Subpackages: plasma5-desktop-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* [Desktop Theme KCM] Workaround bug in FileDialog
* FunnelModel: fix invalid model API usage.
* [Window List] Show pin icon only when in panel (kde#391145)
* Make automounting work even if StorageAccess is ignored (kde#389479)
* [Folder View] Set shortcut on plasmoid.action (kde#392730)
* [Folder View] Use KStandardAction for rename, delete, and trash
* [Folder View] Simplify clearing of lists
* [Folder View] Update "Empty Trash" enabled state for files inside Trash and
links to Trash (kde#392738)
* [System Model] Support actions
* Do clamping in the model and add missing lower bound check (kde#390888)
- Remove patches, now upstream:
* Make-automounting-work-even-if-StorageAccess-is-ignored.patch

==== plasma5-integration ====
Version update (5.12.4 -> 5.12.5)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* KDEPlatformFileDialog: Fix initial directory selection for remote files
(kde#374913)
- Remove patches, now upstream:
* Fix-initial-directory-selection-for-remote-files.patch
- Use %license

==== plasma5-openSUSE ====
Version update (15.0~git20180421T093411~6c02346 ->
15.0~git20180504T125857~b35c1c4)
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to version 15.0~git20180504T125857~b35c1c4:
* Bump theme versions to cause cache refresh
- Update to version 15.0~git20180503T153654~628130a:
* Remove outdated and incompatible calendar.svg (boo#1091832)
- Update to 5.12.5

==== plasma5-pa ====
Version update (5.12.4 -> 5.12.5)
Subpackages: plasma5-pa-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* AbstractModel: Check if index is valid in setData

==== plasma5-workspace ====
Version update (5.12.4 -> 5.12.5)
Subpackages: plasma5-session plasma5-session-wayland plasma5-workspace-lang
plasma5-workspace-libs

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* [ksmserver] Use QUrl::fromUserInput to construct sound url (kde#392725)
* [Image Wallpaper] Fix auto transform for blurred fill (kde#393498)
* sddm-theme: Focus the password field if enter pressed in the username field
* [Notifications] Always scroll to the top when opening (kde#391646)
* [ContextMenu Containment Action] Fix checking for KIOSK (kde#393329)
* [Power Management Engine] Fix kiosk restriction for lockscreen (kde#393331)
* [weather dataengine] envcan: fix forecast terms to match "ice pellets"
* [weather dataengine] bbc: handle and ignore condition "Not Available"
* [weather dataengine] bbc: handle and skip visbility "--"
* [OSD] Enforce plain text
* [weather] BBCUKMET: add missing "thundery showers"
* [weather] BBCUKMET: add missing "light rain showers"/"heavy rain showers"
* [weather dataengine] Fix BBC provider to adapt to change RSS feed
(kde#392510)
* KDE logout screen background color fix (kde#382264)
* fix: Klipper notifications visually broken since plasma 5.12 (kde#390375)
* [notifications applet] Fix two qml warnings about assigning [undefined]
- Remove patches, now upstream:
* Fix-weather-engine-BBC-provider.patch

==== polkit-kde-agent-5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* Add a window icon for authentication dialog under Wayland.
* Remove traces of polkit-kde-authorization tool
- Use %license

==== postgresql ====
Subpackages: postgresql-server

- Require update-alternatives by postgresql: one of the main
scripts in use is install-alternatives, which calls u-a.
- Put POSTGRES_LANG into LC_ALL instead of LANG to retain the
previous behaviour of that variable (boo#1077027).

==== postgresql10 ====
Subpackages: libpq5 postgresql10-server

- bsc#1091412: server prerequires server-noarch to make sure that
the postgresql user and group exist.

==== powerdevil5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: powerdevil5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* Ignore "migration" key for determining whether the config is empty
(kde#391782)
- Remove patches, now upstream:
* 0001-Ignore-migration-key-for-determining-whether-the-con.patch

==== solid ====
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-imports solid-tools

- Add Update-mount-point-after-mount-operations.patch to fix
spurious errors when trying to open an unmounted disk/device in
file manager (kde#370975)

==== systemd-presets-branding-openSUSE ====

- Enable appstream-sync-cache.service on all distros that install
the service (boo#1090346).

==== systemsettings5 ====
Version update (5.12.4 -> 5.12.5)
Subpackages: systemsettings5-lang

- Update to 5.12.5
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.5.php
- Changes since 5.12.4:
* Polish sidebar header appearance (kde#392340)
* Use font.weight instead of font.bold

==== translation-update ====
Subpackages: translation-update-cs translation-update-da translation-update-de
translation-update-en_GB translation-update-en_US translation-update-es
translation-update-fi translation-update-fr translation-update-hu
translation-update-it translation-update-ja translation-update-nb
translation-update-nl translation-update-pl translation-update-pt
translation-update-pt_BR translation-update-ru translation-update-sv
translation-update-zh_CN translation-update-zh_TW

- Refresh from
translation-update-from-translation-update-upstream-20180427.tar.bz2:
* Update for translation-update-upstream fixes (bsc#1087076).
* Correct files from meson/ninja based builds.
* Creates many new sub-packages.
- translation-update-spec-generate-lang-list.sh:
Include more incorrect Language values.

==== util-linux ====
Subpackages: libblkid1 libblkid1-32bit libfdisk1 libmount1 libsmartcols1
libuuid1 libuuid1-32bit util-linux-lang

- Backport three upstream patches:
* Fix crash loop in lscpu
(bsc#1072947, util-linux-lscpu-loop.patch).
* Fix possible segfault of umount -a
(util-linux-libmount-umount-a-segfault.patch).
* Fix mount -a on NFS bind mounts (bsc#1080740,
util-linux-libmount-mount-a-nfs-bind-mount.patch).

==== util-linux-systemd ====

- Backport three upstream patches:
* Fix crash loop in lscpu
(bsc#1072947, util-linux-lscpu-loop.patch).
* Fix possible segfault of umount -a
(util-linux-libmount-umount-a-segfault.patch).
* Fix mount -a on NFS bind mounts (bsc#1080740,
util-linux-libmount-mount-a-nfs-bind-mount.patch).


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages