Mailinglist Archive: opensuse-factory (930 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180406 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180406

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
ImageMagick (7.0.7.25 -> 7.0.7.28)
MozillaFirefox-branding-openSUSE
NetworkManager-applet
NetworkManager-pptp (1.2.4 -> 1.2.6)
alsa-tools
ark
boost
boost-base
build (20180209 -> 20180329)
createrepo_c
cups-filters (1.20.0 -> 1.20.1)
docbook-xsl
ethtool
fprintd (0.7.0 -> 0.8.0)
fwupd
gegl
glibmm2_4 (2.52.1 -> 2.56.0)
gnome-screenshot (3.26.0 -> 3.26.0+20180327.60e7720)
grub2
hwdata (0.310 -> 0.311)
jasper (1.900.14 -> 2.0.14)
kcm_tablet (2.9.82 -> 3.0.0)
kernel-firmware (20180320 -> 20180402)
kernel-source (4.15.13 -> 4.16.0)
korganizer
lapack (3.5.0 -> 3.8.0)
less
libmygpo-qt (1.0.9 -> 1.1.0)
libofx (0.9.10 -> 0.9.12)
libreoffice (6.0.3.1 -> 6.0.3.2)
libsecret (0.18.5 -> 0.18.6)
libsmbios (2.3.3 -> 2.4.1)
libzip
logrotate
mercurial (4.5.2 -> 4.5.3)
patterns-base
patterns-desktop
patterns-gnome (20170319 -> 20180321)
patterns-kde
patterns-media
perl-DBD-SQLite (1.56 -> 1.58)
php7 (7.2.3 -> 7.2.4)
plasma5-workspace
psqlODBC (10.01.0000 -> 10.02.0000)
python3 (3.6.4 -> 3.6.5)
python3-base (3.6.4 -> 3.6.5)
remmina (1.2.0~rcgit.27 -> 1.2.0~rcgit.28)
rsync
screen
skanlite (2.0.1 -> 2.1.0.1)
skopeo (0.1.26 -> 0.1.28)
sqlite3 (3.22.0 -> 3.23.0)
vala (0.40.1 -> 0.40.2)
vim
virt-manager
vsftpd
wireshark (2.4.5 -> 2.4.6)
xmlgraphics-fop
yast2-auth-client (3.3.18 -> 4.0.0)
yast2-tftp-server (4.0.1 -> 4.0.2)

=== Details ===

==== ImageMagick ====
Version update (7.0.7.25 -> 7.0.7.28)
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI5 libMagickWand-7_Q16HDRI5 perl-PerlMagick

- Remove BuildRequires on dcraw, it is not needed at buildtime.
- do not run tests on i586 at all
- update to 7.0.7-28:
* Fixed numerous use of uninitialized values, integer overflow, memory
exceeded, and timeouts
- tesuite still fails, however:
https://github.com/ImageMagick/ImageMagick/issues/1058
- added ImageMagick-write.t-pict.patch
- added ImageMagick-tests.tap-attributes.patch
- update to 7.0.7-27:
* Fixed numerous use of uninitialized values, integer overflow,
memory exceeded, and timeouts.
- remove ImageMagick-remove-test.tap-attributes.patch as the perl
testsuite fails in bunch of tests anyway. Waiting for results of
the upstream bug (https://github.com/ImageMagick/ImageMagick/issues/1019)
- added ImageMagick-remove-test.tap-attributes.patch, removes
failing test on i586
https://github.com/ImageMagick/ImageMagick/issues/1019
- update to 7.0.7-26
* Fixed numerous use of uninitialized values, integer overflow, memory
exceeded, and timeouts (credit to OSS Fuzz).

==== MozillaFirefox-branding-openSUSE ====

- recognize Leap 15.0 (boo#1087713)

==== NetworkManager-applet ====
Subpackages: NetworkManager-applet-lang NetworkManager-connection-editor
libnm-gtk0 libnma0 nma-data typelib-1_0-NMA-1_0

- Re enable appindicator in autotools BuildRequires
- Add feature-app-indicator-desktop-file.patch to launch the startup
application with appindicator support and add a delay to ensure
that the desktop's systray service is running beforehand.

==== NetworkManager-pptp ====
Version update (1.2.4 -> 1.2.6)
Subpackages: NetworkManager-pptp-gnome NetworkManager-pptp-lang

- Update to version 1.2.6:
+ Fix passing "user" and set "remotename" (bgo#794695)
+ Use gresources for UI file
+ Updated translations.
- Update URL tag to https://wiki.gnome.org/Projects/NetworkManager:
currently the Network Manager project's web page.
- Drop icon_theme_cache_* post/postun scriptlets: its fucntionality
has been moved to RPM file triggers (4.13, suse_version 1330).
- Add gio-2.0, gio-unix-2.0 and glib-2.0 pkgconfig modules
BuildRequires to avoid implicit dependencies.

==== alsa-tools ====

- Update to alsa-tools 1.1.6:
* hwmixvolume: use python2 directly
* Change FSF address (Franklin Street)
* hdspconf, hdspmixer: validate the .desktop files
* hdajackretask: add .desktop and icon files
* hdspmixer: move .desktop and icon files to desktop, use modern destination
for icons
* hdspconf: move .desktop and icon files to desktop, use modern destination
for icons
* echomixer: add .desktop and icon files
* envy24control: add .desktop and icon files
* hwmixvolume: add .desktop and icon files
* Makefile: fix version file creation
* hdajacksensetest: add gitcompile to EXTRA_DIST
- Rename README.SuSE to README.SUSE
- Drop superfluous conditional builds; gtk and fltk are always available
- Remove obsoleted patch
alsa-tools-desktop-fix.dif

==== ark ====
Subpackages: ark-lang libkerfuffle17

- Drop 0001-Swap-priorities-around-between-unar-and-unrar.patch
again, unar's "unrar" wrapper has been split out and doesn't
replace unrar anymore.
There are good reasons not to prefer unar over unrar, it
currently only supports a subset of RAR archives, and this also
breaks creating of RAR archives with Ark if unar is installed.
People who do want to install the new unrar_wrapper instead of
the real unrar can still disable the rar plugin in Ark's settings
to be able to open RAR archives with unar.

==== boost ====

- Use %license instead of %doc [bsc#1082318]

==== boost-base ====
Subpackages: boost-license1_66_0 boost_1_66-jam libboost_date_time1_66_0
libboost_filesystem1_66_0 libboost_headers1_66_0-devel libboost_iostreams1_66_0
libboost_locale1_66_0 libboost_regex1_66_0 libboost_signals1_66_0
libboost_system1_66_0 libboost_thread1_66_0

- Use %license instead of %doc [bsc#1082318]

==== build ====
Version update (20180209 -> 20180329)
Subpackages: build-mkbaselibs build-mkdrpms

- KIWI: Support OBS-Profiles kiwi annotation
kiwi profile filtering
- Switch to a little perl http server to get rid of the python2 dependency
- Avoid Ubuntu 18.04 uncompress failure messages
- Don't rely on AppImage's auto-detection for architecture
- build-recipe-livebuild: count ONIE images as build results

==== createrepo_c ====
Subpackages: libcreaterepo_c0 python3-createrepo_c

- fix spelling of old weakdeps feature switch (bsc#1088328)

==== cups-filters ====
Version update (1.20.0 -> 1.20.1)

- Version upgrade to 1.20.1
to provide upstream bugfixes also for SLE15 / Leap15
and be also already prepared for SLE12 (fate#323676).
This is a bug fix release fixing several issues
on the Braille support and other bugs, in particular
(for details see the NEWS file):
* libcupsfilters: Silenced warning when using CUPS < 2.x
by eliminating the use of a recently introduced
CUPS library function, see
https://bugs.linuxfoundation.org/show_bug.cgi?id=1421
* cups-browsed: Fixed crash when CUPS reports a print queue
without "device-uri" attribute when cups-browsed polls a
list of local CUPS queues, see
https://github.com/OpenPrinting/cups-filters/issues/16
- fix_upstream_bug_1421.patch is no longer needed because
it is now fixed in the upstream sources
(see the "libcupsfilters ... bug ... 1421" entry above).

==== docbook-xsl ====
Subpackages: docbook-xsl-stylesheets docbook5-xsl-stylesheets

- Spec file:
Missing 'g' in sed replacements of @VERSION@ of catalog files.
This is needed to avoid the string "@VERSION@" in our installed
catalog files. This leads to catalog resolution errors.
- Applied spec-cleaner

==== ethtool ====

- Use %license instead of %doc [bsc#1082318]

==== fprintd ====
Version update (0.7.0 -> 0.8.0)
Subpackages: fprintd-lang fprintd-pam fprintd-pam-32bit

- Update to version 0.8.0
* Lockdown the daemon to minimise potential security issues
* Don't wake up readers when there's no enrolled fingerprints

==== fwupd ====
Subpackages: fwupd-lang libfwupd2

- Update hasbang in installed files from /usr/bin/env python3 to
/usr/bin/python3.
- Update url
- Small packaging cleanup with spec-cleaner

==== gegl ====
Subpackages: gegl-0_3 gegl-0_3-lang libgegl-0_3-0

- Add cairo and glib-2.0 BuildRequires to avoid implicit
dependencies.

==== glibmm2_4 ====
Version update (2.52.1 -> 2.56.0)
Subpackages: glibmm2_4-devel libgiomm-2_4-1 libglibmm-2_4-1

- Update to version 2.56.0:
+ Glib:
- Threads::Private: Fix gobj() (bgo#791711).
- TimeoutSource: Use monotonic time consistently (bgo#792524).
- Add RefPtr::get(). (bgo#495762).
+ Gio:
- TlsClientConnection: Deprecate set/get/property_use_ssl3().
- DataInputStream: Deprecate read_until().
- Application: Add property_resource_base_path_string(). This
is a replacement for property_resource_base_path() which
can't be fixed without breaking ABI (bgo#787496).
- Application: Add three set_option_context_*() methods.
- DesktopAppInfo: Add get_locale_string().
+ Documentation: Slightly elaborate Glib::Variant<Variant> docs
(bgo#778219).
+ tests:
- glibmm_variant: Don't use C++14 features when a C++11
compiler is used (bgo#787648).
- glibmm_interface_move test: Avoid unused function warnings.
+ gmmproc:
- _WRAP_METHOD:
. Accept optional list of exceptions in errthrow
(bgo#787979).
. Suppress the @return section in generated documentation if
return type is void (bgo#787978).
- Add _MEMBER_SET_STR macro, setter for strings (bgo#793778).
- Drop gcc8.patch: Fixed upstream.

==== gnome-screenshot ====
Version update (3.26.0 -> 3.26.0+20180327.60e7720)
Subpackages: gnome-screenshot-lang

- Update to version 3.26.0+20180327.60e7720:
+ Updated translations.
- Update to version 3.26.0+20180313.a35622c:
+ Remove po/Makevars.
+ Fix a grammar mistake in the man page.
+ Drop build-api wrapper.
+ Honor the mandir option.
+ Updated translations.
- Switch to git checkout via source services.
- Drop update-desktop-files BuildRequires and no longer call
suse_update_desktop_file macro, not needed anymore.
- Use autosetup macro.
- Drop obsolete gnome-utils Conflicts, not needed anymore.

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Fix Nvidia GPU in legacy I/O slot 2 disappears during system
startup (bsc#1082914)
* 0001-Fix-PCIe-LER-when-GRUB2-accesses-non-enabled-MMIO-da.patch
- Fix packed-not-aligned error on GCC 8 (bsc#1084632)
* 0001-Fix-packed-not-aligned-error-on-GCC-8.patch

==== hwdata ====
Version update (0.310 -> 0.311)

- Update to version 0.311:
* Updated pci, usb and vendor ids.

==== jasper ====
Version update (1.900.14 -> 2.0.14)

- Added patch:
* jasper-CVE-2018-9055.patch
+ fix CVE-2018-9055, bsc#1087020: jasper: denial of service via
a reachable assertion in the function jpc_firstone in
libjasper/jpc/jpc_math.c.
- Upgrade to 2.0.14
* Soname and package name change libjasper1 to libjasper4
* Security fixes:
+ CVE-2016-9557 jasper: Signed integer overflow in jas_image.c
- Removed patches:
* jasper-1.900.1-uninitialized.patch
+ not needed any more
* jasper-CVE-2016-10251.patch
* jasper-CVE-2016-8654.patch
* jasper-CVE-2016-9262.patch
* jasper-CVE-2016-9395.patch
* jasper-CVE-2016-9560.patch
* jasper-CVE-2016-9583.patch
* jasper-CVE-2016-9591.patch
* jasper-CVE-2016-9600.patch
* jasper-CVE-2017-1000050.patch
* jasper-CVE-2017-5498.patch
* jasper-CVE-2017-6850.patch
+ Fixed upstream
- Added patches:
* 0001-jpc_cs-reject-all-but-JPC_COX_INS-and-JPC_COX_RFT.patch
+ fix assertion failure JPC_NOMINALGAIN() which can be caused
by a crafted JP2 file.
* 0001-Added-a-fix-from-nrusch-to-allow-JasPer-to-be-build-.patch
+ allow JasPer to be build with CMake 2.x as well as CMake 3.x.

==== kcm_tablet ====
Version update (2.9.82 -> 3.0.0)
Subpackages: kcm_tablet-lang

- Update to version 3.0.0
* Implemented hotplugging on Xlib (by Fabian Vogt). Hotplugging
should now work on Debian/Ubuntu based distributions, and all
other distributions that don't build libXCB with Xinput
enabled.
* Screen mapping configuration now uses output names instead of
screen indices. This invalidates existing screen mapping
configurations.
* Tablet Finder should no longer skip button detection.
* First steps in fixing rotation handling in multi-screen setup.
However, for now if you want your screen rotation to be
tracked, it has to be set as primary screen. Qt bug:
https://bugreports.qt.io/browse/QTBUG-65598
* Minor calibration dialog fixes. Calibration still might be off
with Cintiq devices. Fixing those would require some feedback:

https://userbase.kde.org/Wacomtablet#Calibration_issues_.26_manual_calibration
* New device definitions:
+ Lenovo Yoga 520 (by Felipe Abrahao)
+ Wacom Intuos Pro L (PTH-860) (by Melvin Vermeeren)
+ Wacom Bamboo One M (CTL-671) (by Alexander)
- Drop Implement-hotplugging-on-Xlib.patch, merged upstream
- Mark license file as %license

==== kernel-firmware ====
Version update (20180320 -> 20180402)
Subpackages: ucode-amd

- Update to version 20180402:
* amdgpu: update vce firmware for Polaris
* linux-firmware: Add firmware file for Intel Bluetooth,9560
* linux-firmware: Add firmware file for Intel Bluetooth,9260
* linux-firmware: Update firmware file for Intel Bluetooth,8265
* linux-firmware: Update firmware patch for Intel Bluetooth 8260
* nfp: update Agilio SmartNIC firmware to rev 2.0.7
* cxgb4: update firmware to revision 1.18.9.0
* linux-firmware: intel: Update Geminilake audio firmware
* linux-firmware: intel: Update Kabylake audio firmware
* linux-firmware: intel: Update Broxton audio firmware
* linux-firmware: intel: Update Skylake audio firmware

==== kernel-source ====
Version update (4.15.13 -> 4.16.0)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Revert "tools: fix cross-compile var clobbering" (build fix).
- commit 590ff92
- Update to 4.16-final.
- commit 1b10c5b
- Linux 4.15.15 (bnc#1012628).
- team: Fix double free in error path (bnc#1012628).
- skbuff: Fix not waking applications when errors are enqueued
(bnc#1012628).
- qede: Fix qedr link update (bnc#1012628).
- net: systemport: Rewrite __bcm_sysport_tx_reclaim()
(bnc#1012628).
- net: Only honor ifindex in IP_PKTINFO if non-0 (bnc#1012628).
- netlink: avoid a double skb free in genlmsg_mcast()
(bnc#1012628).
- net/iucv: Free memory obtained by kzalloc (bnc#1012628).
- net: fec: Fix unbalanced PM runtime calls (bnc#1012628).
- net: ethernet: ti: cpsw: add check for in-band mode setting
with RGMII PHY interface (bnc#1012628).
- commit 4904fc3
- net: ethernet: arc: Fix a potential memory leak if an optional
regulator is deferred (bnc#1012628).
- l2tp: do not accept arbitrary sockets (bnc#1012628).
- ipv6: fix access to non-linear packet in
ndisc_fill_redirect_hdr_option() (bnc#1012628).
- dccp: check sk for closed state in dccp_sendmsg() (bnc#1012628).
- dpaa_eth: remove duplicate increment of the tx_errors counter
(bnc#1012628).
- dpaa_eth: increment the RX dropped counter when needed
(bnc#1012628).
- dpaa_eth: remove duplicate initialization (bnc#1012628).
- dpaa_eth: fix error in dpaa_remove() (bnc#1012628).
- soc/fsl/qbman: fix issue in qman_delete_cgr_safe()
(bnc#1012628).
- s390/qeth: on channel error, reject further cmd requests
(bnc#1012628).
- s390/qeth: lock read device while queueing next buffer
(bnc#1012628).
- s390/qeth: when thread completes, wake up all waiters
(bnc#1012628).
- s390/qeth: free netdevice when removing a card (bnc#1012628).
- net: Fix hlist corruptions in inet_evict_bucket() (bnc#1012628).
- net: use skb_to_full_sk() in skb_update_prio() (bnc#1012628).
- ieee802154: 6lowpan: fix possible NULL deref in
lowpan_device_event() (bnc#1012628).
- sch_netem: fix skb leak in netem_enqueue() (bnc#1012628).
- kcm: lock lower socket in kcm_attach (bnc#1012628).
- test_rhashtable: add test case for rhltable with duplicate
objects (bnc#1012628).
- rhashtable: Fix rhlist duplicates insertion (bnc#1012628).
- ppp: avoid loop in xmit recursion detection code (bnc#1012628).
- net sched actions: return explicit error when tunnel_key mode
is not specified (bnc#1012628).
- ipv6: Reflect MTU changes on PMTU of exceptions for MTU-less
routes (bnc#1012628).
- net: phy: Tell caller result of phy_change() (bnc#1012628).
- mlxsw: spectrum_buffers: Set a minimum quota for CPU port
traffic (bnc#1012628).
- ipv6: sr: fix scheduling in RCU when creating seg6 lwtunnel
state (bnc#1012628).
- ipv6: sr: fix NULL pointer dereference when setting encap
source address (bnc#1012628).
- ipv6: old_dport should be a __be16 in __ip6_datagram_connect()
(bnc#1012628).
- net: ipv6: keep sk status consistent after datagram connect
failure (bnc#1012628).
- macvlan: filter out unsupported feature flags (bnc#1012628).
- devlink: Remove redundant free on error path (bnc#1012628).
- net: phy: relax error checking when creating sysfs link
netdev->phydev (bnc#1012628).
- sysfs: symlink: export sysfs_create_link_nowarn() (bnc#1012628).
- qed: Fix non TCP packets should be dropped on iWARP ll2
connection (bnc#1012628).
- tcp: purge write queue upon aborting the connection
(bnc#1012628).
- qed: Fix MPA unalign flow in case header is split across two
packets (bnc#1012628).
- openvswitch: meter: fix the incorrect calculation of max delta_t
(bnc#1012628).
- net: dsa: Fix dsa_is_user_port() test inversion (bnc#1012628).
- commit 0e7b541
- Linux 4.15.14 (bnc#1012628).
- MIPS: ralink: Remove ralink_halt() (bnc#1012628).
- MIPS: ralink: Fix booting on MT7621 (bnc#1012628).
- MIPS: lantiq: Fix Danube USB clock (bnc#1012628).
- MIPS: lantiq: Enable AHB Bus for USB (bnc#1012628).
- MIPS: lantiq: ase: Enable MFD_SYSCON (bnc#1012628).
- iio: chemical: ccs811: Corrected firmware boot/application
mode transition (bnc#1012628).
- iio: st_pressure: st_accel: pass correct platform data to init
(bnc#1012628).
- iio: adc: meson-saradc: unlock on error in meson_sar_adc_lock()
(bnc#1012628).
- ALSA: usb-audio: Fix parsing descriptor of UAC2 processing unit
(bnc#1012628).
- ALSA: aloop: Sync stale timer before release (bnc#1012628).
- ALSA: aloop: Fix access to not-yet-ready substream via cable
(bnc#1012628).
- ALSA: hda - Force polling mode on CFL for fixing codec
communication (bnc#1012628).
- ALSA: hda/realtek - Fix speaker no sound after system resume
(bnc#1012628).
- ALSA: hda/realtek - Fix Dell headset Mic can't record
(bnc#1012628).
- ALSA: hda/realtek - Always immediately update mute LED with
pin VREF (bnc#1012628).
- mmc: core: Fix tracepoint print of blk_addr and blksz
(bnc#1012628).
- mmc: core: Disable HPI for certain Micron (Numonyx) eMMC cards
(bnc#1012628).
- mmc: block: fix updating ext_csd caches on ioctl call
(bnc#1012628).
- mmc: dw_mmc: Fix the DTO/CTO timeout overflow calculation for
32-bit systems (bnc#1012628).
- mmc: dw_mmc: exynos: fix the suspend/resume issue for exynos5433
(bnc#1012628).
- mmc: dw_mmc: fix falling from idmac to PIO mode when
dw_mci_reset occurs (bnc#1012628).
- PCI: Add function 1 DMA alias quirk for Highpoint RocketRAID
644L (bnc#1012628).
- ahci: Add PCI-id for the Highpoint Rocketraid 644L card
(bnc#1012628).
- lockdep: fix fs_reclaim warning (bnc#1012628).
- clk: bcm2835: Fix ana->maskX definitions (bnc#1012628).
- clk: bcm2835: Protect sections updating shared registers
(bnc#1012628).
- clk: sunxi-ng: a31: Fix CLK_OUT_* clock ops (bnc#1012628).
- RDMA/mlx5: Fix crash while accessing garbage pointer and freed
memory (bnc#1012628).
- Drivers: hv: vmbus: Fix ring buffer signaling (bnc#1012628).
- pinctrl: samsung: Validate alias coming from DT (bnc#1012628).
- Bluetooth: btusb: Remove Yoga 920 from the
btusb_needs_reset_resume_table (bnc#1012628).
- Bluetooth: btusb: Add Dell OptiPlex 3060 to
btusb_needs_reset_resume_table (bnc#1012628).
- libata: fix length validation of ATAPI-relayed SCSI commands
(bnc#1012628).
- libata: remove WARN() for DMA or PIO command without data
(bnc#1012628).
- libata: don't try to pass through NCQ commands to non-NCQ
devices (bnc#1012628).
- libata: Apply NOLPM quirk to Crucial MX100 512GB SSDs
(bnc#1012628).
- libata: disable LPM for Crucial BX100 SSD 500GB drive
(bnc#1012628).
- libata: Enable queued TRIM for Samsung SSD 860 (bnc#1012628).
- libata: Apply NOLPM quirk to Crucial M500 480 and 960GB SSDs
(bnc#1012628).
- libata: Make Crucial BX100 500GB LPM quirk apply to all firmware
versions (bnc#1012628).
- libata: Modify quirks for MX100 to limit NCQ_TRIM quirk to
MU01 version (bnc#1012628).
- sched, cgroup: Don't reject lower cpu.max on ancestors
(bnc#1012628).
- cgroup: fix rule checking for threaded mode switching
(bnc#1012628).
- nfsd: remove blocked locks on client teardown (bnc#1012628).
- media: tegra-cec: reset rx_buf_cnt when start bit detected
(bnc#1012628).
- hugetlbfs: check for pgoff value overflow (bnc#1012628).
- h8300: remove extraneous __BIG_ENDIAN definition (bnc#1012628).
- mm/vmalloc: add interfaces to free unmapped page table
(bnc#1012628).
- x86/mm: implement free pmd/pte page interfaces (bnc#1012628).
- mm/khugepaged.c: convert VM_BUG_ON() to collapse fail
(bnc#1012628).
- mm/thp: do not wait for lock_page() in deferred_split_scan()
(bnc#1012628).
- mm/shmem: do not wait for lock_page() in
shmem_unused_huge_shrink() (bnc#1012628).
- Revert "mm: page_alloc: skip over regions of invalid pfns
where possible" (bnc#1012628).
- drm/vmwgfx: Fix black screen and device errors when running
without fbdev (bnc#1012628).
- drm/vmwgfx: Fix a destoy-while-held mutex problem (bnc#1012628).
- drm/radeon: Don't turn off DP sink when disconnected
(bnc#1012628).
- drm/amd/display: We shouldn't set format_default on plane as
atomic driver (bnc#1012628).
- drm/amd/display: Add one to EDID's audio channel count when
passing to DC (bnc#1012628).
- drm: Reject getfb for multi-plane framebuffers (bnc#1012628).
- drm: udl: Properly check framebuffer mmap offsets (bnc#1012628).
- mm/vmscan: wake up flushers for legacy cgroups too
(bnc#1012628).
- module: propagate error in modules_open() (bnc#1012628).
- acpi, numa: fix pxm to online numa node associations
(bnc#1012628).
- ACPI / watchdog: Fix off-by-one error at resource assignment
(bnc#1012628).
- libnvdimm, {btt, blk}: do integrity setup before add_disk()
(bnc#1012628).
- brcmfmac: fix P2P_DEVICE ethernet address generation
(bnc#1012628).
- rtlwifi: rtl8723be: Fix loss of signal (bnc#1012628).
- tracing: probeevent: Fix to support minus offset from symbol
(bnc#1012628).
- mtdchar: fix usage of mtd_ooblayout_ecc() (bnc#1012628).
- mtd: nand: fsl_ifc: Fix nand waitfunc return value
(bnc#1012628).
- mtd: nand: fsl_ifc: Fix eccstat array overflow for IFC ver >=
2.0.0 (bnc#1012628).
- mtd: nand: fsl_ifc: Read ECCSTAT0 and ECCSTAT1 registers for
IFC 2.0 (bnc#1012628).
- can: peak/pcie_fd: fix echo_skb is occupied! bug (bnc#1012628).
- can: peak/pcie_fd: remove useless code when interface starts
(bnc#1012628).
- can: ifi: Repair the error handling (bnc#1012628).
- can: ifi: Check core revision upon probe (bnc#1012628).
- can: cc770: Fix stalls on rt-linux, remove redundant IRQ ack
(bnc#1012628).
- can: cc770: Fix queue stall & dropped RTR reply (bnc#1012628).
- can: cc770: Fix use after free in cc770_tx_interrupt()
(bnc#1012628).
- tty: vt: fix up tabstops properly (bnc#1012628).
- selftests/x86/ptrace_syscall: Fix for yet more glibc
interference (bnc#1012628).
- x86/vsyscall/64: Use proper accessor to update P4D entry
(bnc#1012628).
- x86/efi: Free efi_pgd with free_pages() (bnc#1012628).
- posix-timers: Protect posix clock array access against
speculation (bnc#1012628).
- kvm/x86: fix icebp instruction handling (bnc#1012628).
- x86/build/64: Force the linker to use 2MB page size
(bnc#1012628).
- x86/boot/64: Verify alignment of the LOAD segment (bnc#1012628).
- hwmon: (k10temp) Only apply temperature offset if result is
positive (bnc#1012628).
- hwmon: (k10temp) Add temperature offset for Ryzen 1900X
(bnc#1012628).
- perf/x86/intel/uncore: Fix Skylake UPI event format
(bnc#1012628).
- perf stat: Fix CVS output format for non-supported counters
(bnc#1012628).
- perf/core: Fix ctx_event_type in ctx_resched() (bnc#1012628).
- trace/bpf: remove helper bpf_perf_prog_read_value from
tracepoint type programs (bnc#1012628).
- perf/x86/intel: Don't accidentally clear high bits in
bdw_limit_period() (bnc#1012628).
- perf/x86/intel/uncore: Fix multi-domain PCI CHA enumeration
bug on Skylake servers (bnc#1012628).
- iio: ABI: Fix name of timestamp sysfs file (bnc#1012628).
- iio: imu: st_lsm6dsx: fix endianness in
st_lsm6dsx_read_oneshot() (bnc#1012628).
- iio: imu: st_lsm6dsx: introduce conf_lock mutex (bnc#1012628).
- staging: android: ion: Zero CMA allocated memory (bnc#1012628).
- kbuild: disable clang's default use of -fmerge-all-constants
(bnc#1012628).
- bpf: skip unnecessary capability check (bnc#1012628).
- bpf, x64: increase number of passes (bnc#1012628).
- commit def7e44
- staging: ncpfs: memory corruption in ncp_read_kernel()
(bsc#1086162, CVE-2018-8822).
- commit a967c04
- x86/entry/64: Don't use IST entry for #BP stack (bsc#1087088).
- commit 67a9975
- brcmsmac: allocate ucode with GFP_KERNEL (bsc#1085174).
- commit 580a38a
- Update vanilla config files.
- commit 9beaab6
- net: phy: mdio-bcm-unimac: fix potential NULL dereference in
unimac_mdio_probe() (bsc#1084829 CVE-2018-8043).
- commit 7b5f96b
- Update to 4.16-rc7.
- Eliminated 1 patch.
- commit 7a36f2f

==== korganizer ====
Subpackages: korganizer-lang

- Add fix-folder-properties.patch to fix "Folder Properties" not
appearing (kde#392395)

==== lapack ====
Version update (3.5.0 -> 3.8.0)
Subpackages: libblas3 liblapack3

- Update to version 3.8.0:
* Symmetric-indefinite Factorization: Aasen?s tridiagonalization
2 stage.
* LAPACKE interfaces.
- Static -pic libraries are no longer built.

==== less ====

- Use %license instead of %doc [bsc#1082318]

==== libmygpo-qt ====
Version update (1.0.9 -> 1.1.0)

- Update to 1.1.0:
* Deprecated Qt4 support
* Improvements in Qt5 support
* Fix in URL parsing, preventing Double Encoding of URLs

==== libofx ====
Version update (0.9.10 -> 0.9.12)
Subpackages: libofx-devel

- Update to version 0.9.12:
+ Fixing a buffer overflow (CVE-2017-2816).
- Add libofx-CVE-2017-14731.patch: Fix a buffer overflow on
unexpected tag names (CVE-2017-14731, boo#1060437).
- Update to version 0.9.11:
+ Add support for client uid, from kde#366326 bug.
- Rename libofx6 subpackage to libofx7, following the soname bump.
- Delete backup files that should not be in the tarball.

==== libreoffice ====
Version update (6.0.3.1 -> 6.0.3.2)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-draw
libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3
libreoffice-icon-themes libreoffice-impress libreoffice-kde4
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-hu
libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN
libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreofficekit

- Update to 6.0.3.2 fate#324870:
* Final 6.0.3 tag for release

==== libsecret ====
Version update (0.18.5 -> 0.18.6)
Subpackages: libsecret-1-0 libsecret-lang typelib-1_0-Secret-1

- Update to version 0.18.6:
+ Fix shared key derivation between libsecret and gnome-keyring
(bgo#778357).
+ Avoid run-time error when gnome-keyring is not responding
(bgo#787391).
+ Enable cross compilation (bgo#748111).
+ GI annotation fixes (bgo#785034).
+ Fix textual typos (bgo#782206).
+ Updated translations.
- Drop libsecret-secret-size.patch: fixed upstream.

==== libsmbios ====
Version update (2.3.3 -> 2.4.1)
Subpackages: python-smbios smbios-utils-python

- Update shared library packaging to meet guideline.
- Use find's -exec + strategy.
- Escape all % signs to %% where needed.
- Update to 2.4.1:
* Minor fixes submitted for help2man improvements and a signed
comparison.
* Fix a crash when used by fwupd [boo#1086732]
- Changes in 2.4.0:
* Convert all python2 -> python3.
* Drop libsmbios C++ library.
* Introduce support for WMI SMM API provided by Linux kernel
4.15+.
* Add proper support for SMBIOS 3.0 tables.
* Fix many many crashers.
* Clean up long standing coverity errors.

==== libzip ====
Subpackages: libzip-devel libzip5

- add pkgconfig.patch - fixes boo#1087756

==== logrotate ====

- Use %license instead of %doc [bsc#1082318]

==== mercurial ====
Version update (4.5.2 -> 4.5.3)
Subpackages: mercurial-lang

- Mercurial 4.5.3
This is a regularly-scheduled bugfix release.
* Bug Fixes
+ rebase: on abort, don't strip commits that didn't need to be rebased
(issue5822)
+ hgweb: garbage collect on every request
+ amend: abort if unresolved merge conflicts found (issue5805)

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt
patterns-base-base patterns-base-basesystem patterns-base-console
patterns-base-enhanced_base patterns-base-enhanced_base_opt
patterns-base-minimal_base patterns-base-minimal_base_conflicts
patterns-base-sw_management patterns-base-x11 patterns-base-x11_opt
patterns-base-x86

- Recommend bash-completion by the base system (not minimal_base):
most users will expect it to be present and until recently, it
was in a recommended chain of systemd (boo#1087710).

==== patterns-desktop ====
Subpackages: patterns-desktop-books patterns-desktop-imaging
patterns-desktop-imaging_opt patterns-desktop-laptop
patterns-desktop-multimedia patterns-desktop-multimedia_opt
patterns-desktop-technical_writing

- Do not recommend (non-free) AdobeICCProfiles for standard
installations (boo#1088291).

==== patterns-gnome ====
Version update (20170319 -> 20180321)
Subpackages: patterns-gnome-gnome patterns-gnome-gnome_basis
patterns-gnome-gnome_basis_opt patterns-gnome-gnome_games
patterns-gnome-gnome_ide patterns-gnome-gnome_imaging
patterns-gnome-gnome_internet patterns-gnome-gnome_multimedia
patterns-gnome-gnome_office patterns-gnome-gnome_utilities
patterns-gnome-gnome_yast patterns-gnome-sw_management_gnome

- Drop gnome-icon-theme recommendation from gnome_x11: this theme
has been long superseded by adwaita. While reworking the pattern
for the SLE12->15 migration, it snuck back in.
- Only recommend gnome-initial-setup on SLE/Leap: those have a
crippled variant of g-i-s only doing extended keyboard settings.
g-i-s in Tumbleweed is 'the real thing' and is meant for system
integrators, that can use it as initial system start to configure
the system.
- Drop dia and inkscape from defaults basically if you want to do
vector operations you can install the packages while most users
won't use these on default installation
- Drop the gnome-menus as it is dead as snail since 2013
- Reduce remmina/vino/vinagre to require only remmina/vingare
as SLE/openSUSE diff, vino is VNC server not needed by default
* kill gnome admin which is now empty
- Do not recommend amavisd-new - no need for virus scanner
- Drop google-droid-fonts, all core pkgs recommend required fonts
no need to mess with it in patterns
- No longer recommend aria2
- Drop gutenprint and hplip from patterns here, this is handled
by printing patterns
- Drop gnome-laptop pattern, move gnome-bluetooth recommend to
core
- Drop gnome-imaging-opt moving dia to gnome-imaging
- Remove suggest on sound-juicer - rippers can install it by hand
- Remove abiword/gnumeric/pinpoint - we already pull full
libreoffice, if someone wants to, they can pull it later on
- Switch from empathy to pidgin (also dropping the telepathy
connectors) as the empathy is kinda dying while pidgin rocks
on
- Bump version to $TODAY
- Remove libui-gtk-pkg as it is gone
- Remove various stray comments
- Drop gtk2-devel from devel as we should strive to kill it
- Drop gnome-doc-utils-devel as gnome-doc-utils is deprecated
- Drop monodevelop as we do not really emphasise mono these days
- Drop f-spot as it is gone
- Recommend also gstreamer-plugins-libav
- Drop yast-scanner and yast-tv as both modules were removed
- Split gnome pattern into gnome_x11 and gnome (wayland) patterns
to implement SLED system roles (FATE#324198).
- Add gnome-user-share as requires (bsc#1075321).
- Add deja-dup, gnome-characters and gnome-contacts are Recommends
to gnome pattern (SLE only) (bsc#1069699).
- Add brasero and file-roller as Recommends to gnome_basic pattern
(SLE only) (bsc#1069699, bsc#1065945).
- Fix requires in gnome_basic pattern, it MUST be gnome_basic, not
gnome-basic (bsc#1066771), pattern name MUST NOT contain -, only
_ is allowed.
- Fix requires in gnome pattern on SLE, should be gnome-basic not
gnome_basic.
- Stop requiring yast2-control-center-gnome in gnome pattern, use
x11_yast patterns as Recommends instead (bsc#1062733).
- Remove gstreamer as Recommends, it is pulled by package
dependencies.
- Stop provides/obsoletes openSUSE patterns when building on SLE.
- On SLE, gnome pattern requires gnome_basic and not just
gnome_basis (bsc#1065166).
- No longer requires cheese for g-c-c user panel, only recommends.
- Switch to pidgin on SLE (bsc#1065191).
- Recommends gnome-documents on SLE gnome pattern.
- No longer recommends tracker-gui, it no longer exists.
- Recommends NetworkManager-openvpn/pptp/openconnect-gnome on SLE
gnome pattern (bsc#1065148).
- Disable some implicit requires
(gnome-shell/gnome-settings-daemon/gnome-control-center) when gdm
is requires.
- Massive cleanup on gnome_basis pattern, dropping obsolete
package dependencies.
- Add gnome_basic pattern, installing a basic GNOME desktop and
application, with SLES as a use case.
- evince should be included on SLE (bsc#1063397)
- Do not requires x11_base pattern, it doesn't exist anymore and
gnome_basis as requirement is enough.
- base pattern now obsoletes and provides Default to make SLE-12
upgrades smoother (bsc#1062164)

==== patterns-kde ====
Subpackages: patterns-kde-devel_kde patterns-kde-devel_kde_frameworks
patterns-kde-devel_qt5 patterns-kde-kde patterns-kde-kde_edutainment
patterns-kde-kde_games patterns-kde-kde_ide patterns-kde-kde_imaging
patterns-kde-kde_internet patterns-kde-kde_multimedia patterns-kde-kde_office
patterns-kde-kde_plasma patterns-kde-kde_utilities
patterns-kde-kde_utilities_opt patterns-kde-kde_yast

- Replace plasma-nm5-vpnc with plasma-nm5-openconnect

==== patterns-media ====
Subpackages: patterns-media-rest_cd_core patterns-media-rest_dvd

- Require readonly_root_tools pattern by rest_dvd: add the pattern
to the installation DVD (boo#1088229).
- No longer require gnome_laptop by rest_cd_gnome: gnome_laptop has
been dropped, as it was empty.
- No longer require gnome_admin, gnome_imaging_opt, gnome_laptop,
gnome_multimedia_opt and gnome_office_opt by rest_DVD: those
patterns were eliminated.

==== perl-DBD-SQLite ====
Version update (1.56 -> 1.58)

- updated to 1.58
see /usr/share/doc/packages/perl-DBD-SQLite/Changes
1.58 2018-03-28
- Switched to a production version.
1.57_01 2018-03-21
- Made it an error to fetch attributes from a statement
handle whose database handle is inactive (ribasushi++)

==== php7 ====
Version update (7.2.3 -> 7.2.4)
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pear-Archive_Tar php7-pgsql
php7-shmop php7-snmp php7-sockets php7-sqlite php7-sysvsem php7-sysvshm
php7-tidy php7-tokenizer php7-wddx php7-xmlreader php7-xmlwriter php7-xsl
php7-zip php7-zlib

- updated to 7.2.4: This is a security release with also contains
several minor bug fixes.
http://php.net/ChangeLog-7.php#7.2.4
- php7-no-build-date.patch refreshed

==== plasma5-workspace ====
Subpackages: plasma5-session plasma5-session-wayland plasma5-workspace-devel
plasma5-workspace-lang plasma5-workspace-libs

- Add Fix-weather-engine-BBC-provider.patch to adapt the BBC
weather engine provider to changes in the RSS feed that broke it
(kde#392510)

==== psqlODBC ====
Version update (10.01.0000 -> 10.02.0000)

- Update to version 10.02.0000:
* It's safer to call setlocale(LC_CTYPE, "") than calling setlocale(LC_ALL,
"")
* Avoid replacing effective notice messages.
* Handle MALLOC/REALLOC errors while fetching tuples more effectively.
* Make SQLSetPos(SQL_DELETE/SQL_REFRESH) more effective. Because queries
calling currtid(2) like
select .. from .. where ctid=currtid2(.., ..) cause Seq Scan, their
execution may be very slow.
It is better to execute queries using subqueries like
select .. from .. where ctid=(select currtid2(.., ..)) because they cause Tid
Scan.
* Fix a crash bug in AddDeleted().

==== python3 ====
Version update (3.6.4 -> 3.6.5)
Subpackages: python3-curses python3-dbm python3-tk

- update to 3.6.5
* bugfix release
* see Misc/NEWS for details
- drop ctypes-pass-by-value.patch
- drop fix-localeconv-encoding-for-LC_NUMERIC.patch
- refresh python-3.6.0-multilib-new.patch

==== python3-base ====
Version update (3.6.4 -> 3.6.5)
Subpackages: libpython3_6m1_0

- update to 3.6.5
* bugfix release
* see Misc/NEWS for details
- drop ctypes-pass-by-value.patch
- drop fix-localeconv-encoding-for-LC_NUMERIC.patch
- refresh python-3.6.0-multilib-new.patch

==== remmina ====
Version update (1.2.0~rcgit.27 -> 1.2.0~rcgit.28)
Subpackages: remmina-lang remmina-plugin-rdp remmina-plugin-secret
remmina-plugin-vnc remmina-plugin-xdmcp

- Desktop and icon updates will only be executed on suse
versions prior to 1500.
- Activated telepathy plugin
- Enabled PIE
- Removed patch included in upstream
- Upgraded to 1.2.0.-rcgit.28
Implemented enhancements:
* window has no focus when open ssh sessions #1530
* Enhancement - Variables for pre- and post-commands #1485
* Register and support opening rdp files -
Mime improvements #1497 (antenore)
* Profile and group name niddles in the pre/post
commands #1492 (antenore)
* Add xdmcp protocol to Keywords #1491 (mfvescovi)
Fixed bugs:
* Remmina fails to connect to SSH server without
compression since 1.2.0-rcgit-27 (git rcgit-27) #1505
* Pasting something that was copied in another VM that
has since been closed causes crash #1484
* SSH password authentication failed Wrong state
during pending SSH call #1428
* Fix clipboard cleanup, fixes issue #1484 #1486 (giox069)
* telepathy: add dbus-glib-1 to link flags
* Minor improvements on secure plugin and SNAP welcome message #1545
* Fixes segmentation fault reported by #1499 #1503
Other improvements:
* Redesign - Removed icons where not needed #1535
* Delay and use gtk_window_present_with_time() #1533
* Update French translation #1524
* Fixes for fedora bugs - desktop file and AppStream metadata #1523
* Desktop data fixes #1522
* Updated Hungarian translation #1517
* Removed compression option as not compatible with all SSH servers #1506

==== rsync ====

- Use %license instead of %doc [bsc#1082318]

==== screen ====

- Use %license instead of %doc [bsc#1082318]

==== skanlite ====
Version update (2.0.1 -> 2.1.0.1)
Subpackages: skanlite-lang

- Update to version 2.1.0.1:
* Add translations that were missing in 2.1.0 (kde#392598)
- Update to version 2.1.0:
* Allow index to start from 0 (kde#360432)
* D-BUS support
* Bugfix: wrong folder selection dialog behavior (kde#377929)
* Fix DPI info in 16-bit PNG
* Fix handling of empty prefix
* Correct display of applied filename templates
* Default to PNG format if no format is provided (kde#374315)

==== skopeo ====
Version update (0.1.26 -> 0.1.28)

- Run spec-cleaner on skopeo.spec
- Enable ostree support on Tumbleweed, Leap 15 and SLE 15
- Enable support for containers/storage, which is especially useful to further
support Podman and cri-o.
- Update to skopeo v0.1.28:
* vendor: bump containers/image and containers/image
* Cleanup skopeo man page and README.md
* Use credentials from authfile for skopeo commands
* Update to a newer containers/storage master
* Add global --override-arch and --override-os options

==== sqlite3 ====
Version update (3.22.0 -> 3.23.0)
Subpackages: libsqlite3-0 libsqlite3-0-32bit sqlite3-devel sqlite3-doc

- update to 3.23.0:
* Add the sqlite3_serialize() and sqlite3_deserialize()
interfaces when the SQLITE_ENABLE_DESERIALIZE compile-time
option is used.
* Recognize TRUE and FALSE as constants. (For compatibility, if
there exist columns named "true" or "false", then the
identifiers refer to the columns rather than Boolean constants.)
* Support operators IS TRUE, IS FALSE, IS NOT TRUE, and IS NOT FALSE.
* Added the SQLITE_DBSTATUS_CACHE_SPILL option to
sqlite3_db_status() for reporting the number of cache spills
that have occurred.
* The "alternate-form-2" flag ("!") on the built-in printf
implementation now causes string substitutions to measure the
width and precision in characters instead of bytes.
* If the xColumn method in a virtual table implementation returns
an error message using sqlite3_result_error() then give that
error message preference over internally-generated messages.
* Added the -A command-line option to the CLI to make it easier to
manage SQLite Archive files.
* Add support for INSERT OR REPLACE, INSERT OR IGNORE, and UPDATE
OR REPLACE in the Zipfile virtual table.
* Enhance the sqlite3changeset_apply() interface so that it is
hardened against attacks from deliberately corrupted changeset
objects.
* Added the sqlite3_normalize() extension function.
* Query optimizer enhancements
* Various bug fixes
* Fix various issues reported by fuzzers, including:
+ CVE-2018-8740: NULL pointer dereference on CREATE TABLE as
(bsc#1085790)

==== vala ====
Version update (0.40.1 -> 0.40.2)
Subpackages: libvala-0_40-0

- Update to version 0.40.2:
+ Various bug fixes: gdbus: Fix missing declaration of _fd_list
for async methods (bgo#794566).
+ Bindings:
- glib-2.0: Use g_value_*et_schar instead of deprecated
g_value_*et_char
- gobject-2.0: Add ParamSpecGType.
- gtk+-*.0: Hide dedicated constructors of compact classes
bound as structs (bgo#794733).

==== vim ====
Subpackages: gvim vim-data vim-data-common

- Pre-convert gvim icons, otherwise building vim depends on
rsvg-convert -> librsvg -> cargo -> Rust -> LLVM
- Cleanup SVG icon, make lines pixel-grid aligned
- Correct RPM Group
- Use %license instead of %doc [bsc#1082318]

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- bsc#1086038 - VM guests cannot be properly installed with
virt-install
d15b78ab-virtinst-read-CPU-model-from-domain-capabilities.patch
fd6a8154-virtinst-compare-host-and-domain-cpu-models.patch
- Drop virtinst-dont-set-cpu-model-when-caps-mismatch.patch in
favor of upstream versions.

==== vsftpd ====

- Add firewalld service file (bsc#1083705)

==== wireshark ====
Version update (2.4.5 -> 2.4.6)
Subpackages: libwireshark9 libwiretap7 libwscodecs1 libwsutil8 wireshark-ui-qt

- Wireshark 2.4.6:
This release fixes minor vulnerabilities that could be used to
trigger dissector crashes or cause dissectors to go into large
infinite loops by making Wireshark read specially crafted
packages from the network or capture files (bsc#1088200):
* CVE-2018-9264: ADB dissector crash
* CVE-2018-9260: IEEE 802.15.4 dissector crash
* CVE-2018-9261: NBAP dissector crash
* CVE-2018-9262: VLAN dissector crash
* CVE-2018-9256: LWAPP dissector crash
* CVE-2018-9263: Kerberos dissector crash
* CVE-2018-9258: TCP dissector crash
* CVE-2018-9257: CQL infinite loop
* Memory leaks in multiple dissectors:
CVE-2018-9265, CVE-2018-9266, CVE-2018-9267, CVE-2018-9268,
CVE-2018-9269, CVE-2018-9270, CVE-2018-9271, CVE-2018-9272,
CVE-2018-9273, CVE-2018-9274
* Further bug fixes and updated protocol support as listed in:
https://www.wireshark.org/docs/relnotes/wireshark-2.4.6.html

==== xmlgraphics-fop ====

- Added patch:
* java8-compatibility.patch
+ Fix compatibility with java8 and lower when built with java9
or higher

==== yast2-auth-client ====
Version update (3.3.18 -> 4.0.0)

- bnc#1087957
- version bump
- 4.0.0

==== yast2-tftp-server ====
Version update (4.0.1 -> 4.0.2)

- do not report error when cloning without tftp installed
(bsc#1081688)
- 4.0.2


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >