Mailinglist Archive: opensuse-factory (705 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180330 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180330

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
Mesa
Mesa-drivers
MozillaThunderbird (52.6 -> 52.7)
baobab
biosdevname
bluedevil5 (5.12.3 -> 5.12.4)
bluez
branding-openSUSE (13.3 -> 15.0)
breeze (5.12.3 -> 5.12.4)
breeze-gtk (5.12.3 -> 5.12.4)
breeze4-style (5.12.3 -> 5.12.4)
devhelp
digikam (5.8.0 -> 5.9.0)
discover (5.12.3 -> 5.12.4)
drkonqi5 (5.12.3 -> 5.12.4)
elfutils
ffmpeg
fwupd (1.0.5 -> 1.0.6)
gdm-branding-openSUSE
geocode-glib
git (2.16.2 -> 2.16.3)
gnome-dictionary (3.26.1 -> 3.26.1+20180313.ac6d4c0)
gnome-keyring (3.28.0.1 -> 3.28.0.2)
gnutls
gptfdisk
grub2
gstreamer-plugins-bad
gstreamer-plugins-ugly (1.12.4 -> 1.12.5)
i4l-base
ibus-libpinyin
installation-images-Kubic (14.364 -> 14.366)
kactivitymanagerd (5.12.3 -> 5.12.4)
kcm_sddm (5.12.3 -> 5.12.4)
kde-cli-tools5 (5.12.3 -> 5.12.4)
kde-gtk-config5 (5.12.3 -> 5.12.4)
kde-user-manager (5.12.3 -> 5.12.4)
kded
kernel-firmware (20180312 -> 20180320)
kgamma5 (5.12.3 -> 5.12.4)
khotkeys5 (5.12.3 -> 5.12.4)
kinfocenter5 (5.12.3 -> 5.12.4)
kmenuedit5 (5.12.3 -> 5.12.4)
kscreen5 (5.12.3 -> 5.12.4)
kscreenlocker (5.12.3 -> 5.12.4)
ksshaskpass5 (5.12.3 -> 5.12.4)
ksysguard5 (5.12.3 -> 5.12.4)
kwayland-integration (5.12.3 -> 5.12.4)
kwin5 (5.12.3 -> 5.12.4)
libedit
libgweather (3.28.0 -> 3.28.1)
libidn
libkdecoration2 (5.12.3 -> 5.12.4)
libkscreen2 (5.12.3 -> 5.12.4)
libksysguard5 (5.12.3 -> 5.12.4)
libmetalink
libmtp (1.1.14 -> 1.1.15)
libnfnetlink
libogg (1.3.2 -> 1.3.3)
libqt5-qtbase
libqt5-qtwebengine
libreoffice (6.0.2.1 -> 6.0.3.1)
libsolv (0.6.33 -> 0.6.34)
libyajl
libzypp-plugin-appdata (1.0.1+git.20180321 -> 1.0.1+git.20180327)
lsof (4.90 -> 4.91)
makedumpfile
milou5 (5.12.3 -> 5.12.4)
mokutil
mozc
mtools
ncurses
obs-service-format_spec_file (20180215 -> 20180306)
okular
openssl (1.1.0g -> 1.1.0h)
openssl-1_1 (1.1.0g -> 1.1.0h)
orca (3.27.91 -> 3.28.0)
osinfo-db
oxygen5 (5.12.3 -> 5.12.4)
patch (2.7.5 -> 2.7.6)
patterns-base
patterns-kde
perl-Bootloader
perl-DateTime (1.46 -> 1.48)
perl-DateTime-TimeZone (2.17 -> 2.18)
perl-IPC-Run (0.96 -> 0.97)
php7
plasma-nm5 (5.12.3 -> 5.12.4)
plasma5-addons (5.12.3 -> 5.12.4)
plasma5-desktop (5.12.3 -> 5.12.4)
plasma5-integration (5.12.3 -> 5.12.4)
plasma5-openSUSE (15.0~git20180116T134836~c3ce1b2 ->
15.0~git20180328T172058~30e1414)
plasma5-pa (5.12.3 -> 5.12.4)
plasma5-workspace (5.12.3 -> 5.12.4)
pngquant
polkit-kde-agent-5 (5.12.3 -> 5.12.4)
powerdevil5 (5.12.3 -> 5.12.4)
python-gobject (3.28.1 -> 3.28.2)
python-kiwisolver
sddm
shotwell (0.28.0 -> 0.28.1)
spectacle
spirv-tools
squid (4.0.23 -> 4.0.24)
system-users
systemd
systemsettings5 (5.12.3 -> 5.12.4)
tigervnc
timezone (2018c -> 2018d)
timezone-java (2018c -> 2018d)
totem-pl-parser (3.26.0 -> 3.26.0+20180301.0091a56)
unrar_wrapper
upower
usbutils
util-linux
util-linux-systemd
vala (0.40.0 -> 0.40.1)
vim
virt-manager
xdg-desktop-portal-kde (5.12.3 -> 5.12.4)
xen (4.10.0_14 -> 4.10.0_16)
xfce4-panel-plugin-pulseaudio (0.3.5 -> 0.4.0)
xorg-x11-server
yakuake (3.0.4 -> 3.0.5)
yp-tools (4.2.2 -> 4.2.3)
zstd (1.3.3 -> 1.3.4)

=== Details ===

==== Mesa ====
Subpackages: Mesa-dri-devel Mesa-libEGL-devel Mesa-libEGL1 Mesa-libGL-devel
Mesa-libGL1 Mesa-libglapi0 libgbm1 libwayland-egl1

- Update to 18.0.0 final
* one-and-only change since 18.0.0-rc5: updated release notes
- Changes since 17.3
* The top highlights include:
+ Cannonlake support on i965 and anv
+ GL 4.3/GLES 3.1 support on r600/evergreen with hw fp64 support
+ Meson build system
* ANV Extensions:
+ VK_EXT_external_memory_dma_buf
* RADV Extensions:
+ VK_ANDROID_native_buffer
+ VK_KHR_external_fence
+ VK_KHR_external_fence_capabilities
+ VK_KHR_external_fence_fd
+ VK_KHR_get_surface_capabilities2
+ VK_EXT_discard_rectangles
+ VK_EXT_external_memory_dma_buf
+ VK_AMD_shader_info
* EGL:
+ Support for RGBA/RGBX 1010102 formats
+ EGL_EXT_pixel_format_float
+ Final planned release to ship wayland-egl. Now provided by wayland.
* GLX:
+ Darwin/Apple fixes
* Mesa core
+ Support 1 binary format for GL_ARB_get_program_binary on i965
+ drirc workarounds:
(*) Unreal 4 Editor
(*) Observer
(*) Steamroll
(*) Refunct
* drirc mesa_glthread whitelists:
+ Mount and Blade Warband
- i965:
* Disk shader cache when MESA_GLSL_CACHE_DISABLE is set to "false"
* GL_EXT_disjoint_timer_query on gen6+

==== Mesa-drivers ====
Subpackages: Mesa-dri Mesa-gallium Mesa-libva libvdpau_r300 libvdpau_r600
libvdpau_radeonsi libvulkan_radeon libxatracker2

- Update to 18.0.0 final
* one-and-only change since 18.0.0-rc5: updated release notes
- Changes since 17.3
* The top highlights include:
+ Cannonlake support on i965 and anv
+ GL 4.3/GLES 3.1 support on r600/evergreen with hw fp64 support
+ Meson build system
* ANV Extensions:
+ VK_EXT_external_memory_dma_buf
* RADV Extensions:
+ VK_ANDROID_native_buffer
+ VK_KHR_external_fence
+ VK_KHR_external_fence_capabilities
+ VK_KHR_external_fence_fd
+ VK_KHR_get_surface_capabilities2
+ VK_EXT_discard_rectangles
+ VK_EXT_external_memory_dma_buf
+ VK_AMD_shader_info
* EGL:
+ Support for RGBA/RGBX 1010102 formats
+ EGL_EXT_pixel_format_float
+ Final planned release to ship wayland-egl. Now provided by wayland.
* GLX:
+ Darwin/Apple fixes
* Mesa core
+ Support 1 binary format for GL_ARB_get_program_binary on i965
+ drirc workarounds:
(*) Unreal 4 Editor
(*) Observer
(*) Steamroll
(*) Refunct
* drirc mesa_glthread whitelists:
+ Mount and Blade Warband
- i965:
* Disk shader cache when MESA_GLSL_CACHE_DISABLE is set to "false"
* GL_EXT_disjoint_timer_query on gen6+

==== MozillaThunderbird ====
Version update (52.6 -> 52.7)
Subpackages: MozillaThunderbird-translations-common

- update to Thunderbird 52.7
* Searching message bodies of messages in local folders, including
filter and quick filter operations, did not find content in
message attachments
* Better error handling for Yahoo accounts
- The following security fixes are included as part of the mozilla
platform. In general, these flaws cannot be exploited through
email in the Thunderbird product because scripting is disabled
when reading mail, but are potentially risks in browser or
browser-like contexts (MFSA 2018-09, bsc#1085130, bsc#1085671):
* CVE-2018-5127 (bmo#1430557)
Buffer overflow manipulating SVG animatedPathSegList
* CVE-2018-5129 (bmo#1428947)
Out-of-bounds write with malformed IPC messages
* CVE-2018-5144 (bmo#1440926)
Integer overflow during Unicode conversion
* CVE-2018-5146 (bmo#1446062)
Out of bounds memory write in libvorbis
* CVE-2018-5125 (bmo1416529,bmo#1434580,bmo#1434384,bmo#1437450,
bmo#1437507,bmo#1426988,bmo#1438425,bmo#1324042,bmo#1437087,
bmo#1443865,bmo#1425520)
Memory safety bugs fixed in Firefox 59, Firefox ESR 52.7, and
Thunderbird 52.7
* CVE-2018-5145 (bmo#1261175,bmo#1348955)
Memory safety bugs fixed in Firefox ESR 52.7 and Thunderbird
52.7

==== baobab ====
Subpackages: baobab-lang

- Drop gnome-utils Conflicts, not needed for a long time.
- Drop update-desktop-files BuildRequires and no longer pass
suse_update_desktop_file macro.
- Add baobab-fix-linguas-build-issues.patch: build: Fix setting
GNOMELOCALEDIR (bgo#794381), and build: Use LINGUAS file for help
(bgo#794449).
- Update URL to new home in GNOME wiki.

==== biosdevname ====

- Use %license instead of %doc [bsc#1082318]

==== bluedevil5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: bluedevil5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== bluez ====
Subpackages: bluez-cups bluez-devel libbluetooth3

- add 0001-Don-t-refresh-adv_manager-for-non-LE-devices.patch
(boo#1086731)

==== branding-openSUSE ====
Version update (13.3 -> 15.0)
Subpackages: grub2-branding-openSUSE plymouth-branding-openSUSE
wallpaper-branding-openSUSE xfce4-splash-branding-openSUSE
yast2-qt-branding-openSUSE

- Update to version 15.0:
* Better version with shadow
* Fix wrong frame of animation
* Fix for editable QComboBox (boo#1084816)
* Fixed lock in plymouth

==== breeze ====
Version update (5.12.3 -> 5.12.4)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* - Moved shadowSize from anonymous namespace to static member function -
calculate proper shadow size for Mdi windows - fix mdi windows shadow
renderning.

==== breeze-gtk ====
Version update (5.12.3 -> 5.12.4)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== breeze4-style ====
Version update (5.12.3 -> 5.12.4)

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* - Moved shadowSize from anonymous namespace to static member function -
calculate proper shadow size for Mdi windows - fix mdi windows shadow
renderning.

==== devhelp ====
Subpackages: devhelp-lang emacs-plugin-devhelp gedit-plugin-devhelp
vim-plugin-devhelp

- Add Requires: devhelp for vim, emac and gedit plugins as these
plugins, which are supposed to pop up the devhelp window to
search for the selected word/phrase, don't work otherwise.

==== digikam ====
Version update (5.8.0 -> 5.9.0)
Subpackages: kipi-plugins kipi-plugins-lang

- Update to 5.9.0:
* https://www.digikam.org/news/2018-03-25-5.9.0_release_announcement/
- New features (from NEWS):
General : Libraw updated to last 0.18.8.
- 45 bugs fixed
- Drop upstream patches:
* fix-font-size-in-tooltips.patch
* digikam-5.8.0.fix-db-migration-0001.patch
* digikam-5.8.0.fix-db-migration-0002.patch
* digikam-5.8.0.fix-db-migration-0003.patch
* digikam-5.8.0.fix-db-migration-0004.patch
* update-internal-libraw-to-last-stable-0.18.7.patch
* update-internal-libraw-to-last-0.18.8.patch
- Drop fix-italian-docs-with-older-kdoctools.patch, Leap 42.2 is no
longer supported
- Don't try to delete libkvkontakte translations, they are no
longer installed (kde#369517)
- Also don't try to delete *.a files and locale/x-test, no longer
necessary

==== discover ====
Version update (5.12.3 -> 5.12.4)
Subpackages: discover-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* Simplify the tasks view (kde#391760)
* Remove unneeded includes
* Fix dbus path
* Include a test for cancelling flatpak installations
* Improve status of FlatpakTransaction
* Remove pointless i18n call
* KNS: Only indicate that it's fetching if already fetching reviews
* Include a test that makes sure we can list origins
* Solve some inconsistencies found when testing flatpak
* Introduce a flatpak test
* No need to pass the extra arguments on the Update Action (kde#391801)
* Add Qt5::Xml
* Simplify KNSTransaction creation (kde#390236)
* Fix test
* Add a test to make sure we don't add resources with the wrong URL
* kns: Fix logic for adding screenshots (kde#391190)
* Add debug information when the searched URI is wrong
- Add patch to show an informative warning when adding FlatHub:
* 0001-Warning-for-FlatHub.patch

==== drkonqi5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: drkonqi5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== elfutils ====
Subpackages: elfutils-lang libasm1 libdw1 libebl-plugins libelf-devel libelf1

- disable-tests-with-ptrace.patch: Rediff

==== ffmpeg ====
Subpackages: libavcodec-devel libavcodec57 libavdevice57 libavfilter6
libavformat57 libavresample-devel libavresample3 libavutil-devel libavutil55
libpostproc54 libswresample-devel libswresample2 libswscale-devel libswscale4

- Create a new package ffmpeg-private-devel which contains some
headers under /usr/include/ffmpeg/private that were not installed
by upstream. Those headers are needed by the libav package in order
to build avconv and other tools using the libav* libraries generated
by ffmpeg instead of its own. No other package should require
ffmpeg-private-devel.
- Build and install also the sidxindex tool

==== fwupd ====
Version update (1.0.5 -> 1.0.6)
Subpackages: fwupd-lang libfwupd2

- Update to version 1.0.6:
+ New Features:
- Add bash completion for fwupdmgr.
- Add support for newest Thunderbolt chips.
- Allow all functions that take device arguments to be
prompted.
- Allow devices to use the runtime version when in bootloader
mode.
- Allow overriding ESP mount point via conf file.
- Delete any old fwupdate capsules and efivars when launching
fwupd.
- Generate Vala bindings.
+ Bugfixes:
- Allow ctrl-d out of the prompt for devices.
- Allow to create package out of provided binary.
- Correct handling of unknown Thunderbolt devices.
- Correctly detect new remotes that are manually copied.
- Fix a crash related to when passing device to downgrade in
CLI.
- Fix running the self tests when no fwupd is installed.
- Fix Unifying signature writing and parsing for Texas
bootloader.
- Only send success and failure reports to the server.
- Use a CNAME to redirect to the correct CDN for metadata.
- Use a longer timeout when powering back the Thunderbolt
device.

==== gdm-branding-openSUSE ====

- Append InitialSetupEnable=False in custom.conf on Leap, disabling
the gnome-initial-setup gdm mode, making it consistent with the
behavior of SLE (bsc#1067976 boo#1086056).

==== geocode-glib ====
Subpackages: libgeocode-glib0 typelib-1_0-GeocodeGlib-1_0

- Add geocode-glib-make-reproducible.patch: lib: Remove full build
path from public headers. So as to make the build more easily
reproducible.

==== git ====
Version update (2.16.2 -> 2.16.3)
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- Use %license instead of %doc [bsc#1082318]
- git 2.16.3:
* "git status" after moving a path in the working tree (hence
making it appear "removed") and then adding with the -N option
(hence making that appear "added") detected it as a rename, but
did not report the old and new pathnames correctly.
* "git commit --fixup" did not allow "-m<message>" option to be
used at the same time; allow it to annotate resulting commit
with more text.
* When resetting the working tree files recursively, the working
tree of submodules are now also reset to match.
* Fix for a commented-out code to adjust it to a rather old API
change around object ID.
* When there are too many changed paths, "git diff" showed a
warning message but in the middle of a line.
* The http tracing code, often used to debug connection issues,
learned to redact potentially sensitive information from its
output so that it can be more safely sharable.
* Crash fix for a corner case where an error codepath tried to
unlock what it did not acquire lock on.
* The split-index mode had a few corner case bugs fixed.
* Assorted fixes to "git daemon".
* Completion of "git merge -s<strategy>" (in contrib/) did not
work well in non-C locale.
* Workaround for segfault with more recent versions of SVN.
* Recently introduced leaks in fsck have been plugged.
* Travis CI integration now builds the executable in 'script'
phase to follow the established practice, rather than during
'before_script' phase. This allows the CI categorize the
failures better ('failed' is project's fault, 'errored' is
build environment's).

==== gnome-dictionary ====
Version update (3.26.1 -> 3.26.1+20180313.ac6d4c0)
Subpackages: gnome-dictionary-lang

- Update to version 3.26.1+20180313.ac6d4c0:
+ Remove po/Makevars.
+ Flatpak: use meson from flatpak build definition.
+ Fix translations of the Name key.
+ Drop build-api wrapper for Continuous.
+ Updated translations.
- Switch to git-checkout via source services.
- Drop obsolete gnome-utils Conflicts and update-desktop-files
BuildRequires and stop passing glib2_gsettings_schema_requires
and suse_update_desktop_file macros.
- Use autosetup macro and pass explicit use_ipv6=true and
build_man=true to meson, ensure we build the features we want.
- Update URL to correct home.

==== gnome-keyring ====
Version update (3.28.0.1 -> 3.28.0.2)
Subpackages: gnome-keyring-32bit gnome-keyring-lang gnome-keyring-pam
gnome-keyring-pam-32bit libgck-modules-gnome-keyring

- Update to version 3.28.0.2:
+ Fix glitches in ssh-agent (bgo#794361, bgo#794368, bgo#794369,
bgo#794500, bgo#794631).

==== gnutls ====
Subpackages: libgnutls-dane0 libgnutls-devel libgnutls30 libgnutls30-32bit

- build without DANE support on SLE-15, as it doesn't have unbound
(bsc#1086428)
- add back refreshed gnutls-3.6.0-disable-flaky-dtls_resume-test.patch
the dtls-resume test still keeps randomly failing on PPC
- remove gnutls-3.6.0-disable-flaky-dtls_resume-test.patch
patch does not apply any more and apparently the build
suceeds even if the formerly flaky testcase is run (bsc#1086579)

==== gptfdisk ====

- Use %license instead of %doc [bsc#1082318]

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Fix incorrect netmask on ppc64 (bsc#1085419)
* grub2-Fix-incorrect-netmask-on-ppc64.patch

==== gstreamer-plugins-bad ====
Subpackages: gstreamer-plugins-bad-lang libgstadaptivedemux-1_0-0
libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
libgstwayland-1_0-0

- Move BuildRequires pkgconfig(dvdnav/dvdread) to BUILD_ORIG
section. It is only needed when building BUILD_ORIG package,
which is not the case for official builds for openSUSE Leap,
Tumbleweed or SLE.

==== gstreamer-plugins-ugly ====
Version update (1.12.4 -> 1.12.5)
Subpackages: gstreamer-plugins-ugly-lang

- Update to version 1.12.5:
+ Bugs fixed: bgo#792111.
- Drop gst-ugly-amrnwbdec-fixes.patch and
gst-x264enc-fix-build-x264-multiple-bit-depths.patch: Fixed
upstream.
- Add gst-x264enc-fix-build-x264-multiple-bit-depths.patch:
x264enc: fix build with newer x264 with support for multiple bit
depths (bgo#792111).

==== i4l-base ====
Subpackages: i4l-isdnlog libcapi20-3

- Own %{_sysconfdir}/xinetd.d: filesystem won't own this directory
much longer (boo#1084457).

==== ibus-libpinyin ====

- Drop ibus-libpinyin-build_lua_5.2.patch, merged by upstream.

==== installation-images-Kubic ====
Version update (14.364 -> 14.366)

- merge gh#openSUSE/installation-images#241
- s390x: add zpxe.rexx to dvd (bsc#813454)
- 14.366
- merge gh#openSUSE/installation-images#240
- add libstorage-ng translations (bsc#1081454)
- 14.365

==== kactivitymanagerd ====
Version update (5.12.3 -> 5.12.4)

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kcm_sddm ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kcm_sddm-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kde-cli-tools5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kde-cli-tools5-lang

- Add patches to support wayland sessions without QT_QPA_PLUGIN:
* 0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
* 0002-Use-platform-detection-from-KWorkSpace-in-KCMShell.patch
* 0003-Fix-build-in-kcmshell5-accidentially-landed-the-wron.patch
- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kde-gtk-config5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kde-user-manager ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kde-user-manager-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kded ====
Subpackages: kded-devel kded-lang

- Add patch to support Wayland sessions without QT_QPA_PLATFORM:
* 0001-Add-platform-detection-and-adjustment-to-kded.patch

==== kernel-firmware ====
Version update (20180312 -> 20180320)
Subpackages: ucode-amd

- Update to version 20180320:
* BCM-0bb4-0306: Update to Cypress license in WHENCE
* linux-firmware: intel: Update Kabylake audio firmware
- detect new style modalias too for AMD CPUs in ucode-amd
(bsc#1084687)

==== kgamma5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kgamma5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== khotkeys5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: khotkeys5-devel khotkeys5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kinfocenter5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kinfocenter5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* kcm_energyinfo: Allow changing of the timespan if no data available

==== kmenuedit5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kmenuedit5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* Fix pixelated icon scaling for HiDPI screens (kde#390737)

==== kscreen5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kscreen5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kscreenlocker ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== ksshaskpass5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: ksshaskpass5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== ksysguard5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: ksysguard5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kwayland-integration ====
Version update (5.12.3 -> 5.12.4)

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== kwin5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: kwin5-devel kwin5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* [colorcorrection] Apply current color temperature on screen hot plug
(kde#391623)
* [effects/coverswitch] Fix broken reflection on multi-monitor setup
(kde#378688)
* [AppMenu] Ignore show request when application menu isn't configured
(kde#392012)

==== libedit ====

- move Changelog back to runtime package as it might not
be only developer documentation
- Use %license instead of %doc [bsc#1082318]
- Move development docu into -devel subpackage

==== libgweather ====
Version update (3.28.0 -> 3.28.1)
Subpackages: gweather-data libgweather-3-15 libgweather-lang
typelib-1_0-GWeather-3_0

- Update to version 3.28.1:
+ Fix memory and D-Bus match rule leaks.
+ Updated translations.

==== libidn ====
Subpackages: libidn-devel libidn11

- Update summaries. Remove ineffective --with-pic.
- Add patch to fix bsc#1056450 CVE-2017-14062:
* libidn-CVE-2017-14062.patch

==== libkdecoration2 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== libkscreen2 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== libksysguard5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: libksysguard5-devel libksysguard5-helper libksysguard5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== libmetalink ====

- libmetalink-autotools.patch: update, export only
metalink_ symbols using -export-symbols-regex, there
is an upstream configure option --enable-gcc-visibility
but it is currently incomplete and cannot be used as is

==== libmtp ====
Version update (1.1.14 -> 1.1.15)
Subpackages: libmtp-devel libmtp-udev libmtp9

- updated to 1.1.15 release
- lots of new USB ids
- copy and move object implemented
- 64bit file bugfixes
- bugfixes

==== libnfnetlink ====

- Use %license instead of %doc [bsc#1082318]

==== libogg ====
Version update (1.3.2 -> 1.3.3)
Subpackages: libogg-devel libogg0 libogg0-32bit

- Use %license macro
- Update to version 1.3.3
* Fix an issue with corrupt continued packet handling.

==== libqt5-qtbase ====
Subpackages: libQt5Concurrent-devel libQt5Concurrent5 libQt5Core-devel
libQt5Core-private-headers-devel libQt5Core5 libQt5DBus-devel libQt5DBus5
libQt5Gui-devel libQt5Gui-private-headers-devel libQt5Gui5 libQt5Network-devel
libQt5Network5 libQt5OpenGL-devel libQt5OpenGL5 libQt5PlatformHeaders-devel
libQt5PrintSupport-devel libQt5PrintSupport5 libQt5Sql-devel libQt5Sql5
libQt5Sql5-mysql libQt5Sql5-postgresql libQt5Sql5-sqlite libQt5Sql5-unixODBC
libQt5Test-devel libQt5Test5 libQt5Widgets-devel libQt5Widgets5 libQt5Xml-devel
libQt5Xml5 libqt5-qtbase-common-devel libqt5-qtbase-devel
libqt5-qtbase-platformtheme-gtk3

- Add patch to fix build with GCC 8 (boo#1087073):
* 0001-Do-a-static_cast-in-bit-blasts-that-are-UB.patch

==== libqt5-qtwebengine ====

- Enable spell checking:
* Ported script snippet from Fedora package by Kevin Kofler
* Converts available Hunspell dictionaries locally during installation
- Changed specfile header to reflect code coming from K. Kofler

==== libreoffice ====
Version update (6.0.2.1 -> 6.0.3.1)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-draw
libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3
libreoffice-icon-themes libreoffice-impress libreoffice-kde4
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-hu
libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN
libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreofficekit

- Disable firebird engine on SLE for now
- Also drop boost_string_fixes.patch merged in upstream differently
- Version update to 6.0.3.1:
* Another bugfix release milestone
- Drop patch orcus-0.13.3.patch merged upstream
- Drop patch bnc955545.patch merged upstream
- Drop patch bnc1081079.patch merged upstream

==== libsolv ====
Version update (0.6.33 -> 0.6.34)
Subpackages: libsolv-devel libsolv-tools python-solv

- make sure product files come from /etc/products.d in fallback
search [bnc#1086602]
- bump version to 0.6.34

==== libyajl ====

- Use %license instead of %doc [bsc#1082318]
- Move other docu to -devel package where it better fits

==== libzypp-plugin-appdata ====
Version update (1.0.1+git.20180321 -> 1.0.1+git.20180327)

- Update to version 1.0.1+git.20180327:
* AsHelper: normalize the repo alias names
- Start zypper lr with ZYPP_PLUGIN_APPDATA_FORCE_COLLECT=1 post
installation (boo#1009745).
- Add relevant Requires(post) to ensure packages are installed in
the right order:
+ appstream-glib >= 0.3.6
+ python3-cmdln
+ python3-createrepo_c
+ libzypp >= 16.13.1
+ zypper

==== lsof ====
Version update (4.90 -> 4.91)

- Update to version 4.91
* This revision applies two fixes that correct the Linux PTY
endpoint processing bug [bsc#1082900]

==== makedumpfile ====

- Use %license instead of %doc [bsc#1082318]

==== milou5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: milou5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== mokutil ====

- Use %license instead of %doc [bsc#1082318]

==== mozc ====
Subpackages: fcitx-mozc ibus-mozc ibus-mozc-candidate-window mozc-gui-tools

- add excludearch for ppc/ppc64/s390/s390x as the code assumes
little endian all over the place (bsc#1086763)

==== mtools ====

- Do not BuildRequire metapackage xorg-x11-devel

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo terminfo-base

- Change baselibs.conf to avoid mixed version requirements (bsc#1082744)
- Add ncurses patch 6.1-20180317
+ fix a check in infotocap which may not have detected a problem when
it should have.
+ add a check in tic for the case where setf/setb are given using
different strings, but provide identical results to setaf/setab.
+ further improve fix for terminfo.5 (patch by Kir Kolyshkin).
+ reorder loop-limit checks in winsnstr() in case the string has no
terminating null and only the number of characters is used (patch
by Gyorgy Jeney).
- Avoid opaque libraries for Leap 15 and SLES 15
- No tests on Leap 15 and SLES 15

==== obs-service-format_spec_file ====
Version update (20180215 -> 20180306)

- Update to version 20180306:
+ do not patch URL nor Url

==== okular ====
Subpackages: okular-lang

- Add some build requirements to enable additional features:
* Qt5TextToSpeech for text-to-speech support
* purpose-devel for enabling the share menu
* libmarkdown-devel for displaying Markdown documents

==== openssl ====
Version update (1.1.0g -> 1.1.0h)
Subpackages: libopenssl-devel

- Update to 1.1.0h release

==== openssl-1_1 ====
Version update (1.1.0g -> 1.1.0h)
Subpackages: libopenssl-1_1-devel libopenssl1_1 libopenssl1_1-32bit

- Tolerate a Certificate using a non-supported group on server side
(boo#1084651)
* https://github.com/openssl/openssl/pull/5607
* add 0001-Tolerate-a-Certificate-using-a-non-supported-group-o.patch
- Update to 1.1.0h
OpenSSL Security Advisory [27 Mar 2018]
* Constructed ASN.1 types with a recursive definition could exceed
the stack (CVE-2018-0739) (bsc#1087102)
* rsaz_1024_mul_avx2 overflow bug on x86_64 (CVE-2017-3738)
(bsc#1071906)
- refresh patches:
* 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
* openssl-1.1.0-fips.patch
* openssl-pkgconfig.patch
* openssl-rsakeygen-minimum-distance.patch
* openssl-static-deps.patch

==== orca ====
Version update (3.27.91 -> 3.28.0)
Subpackages: orca-lang

- Update to version 3.28.0:
+ Web + Email:
- Ensure focus is grabbed on image links when navigating.
- Fix bug causing notifications to trigger browse mode.
+ LibreOffice: Improve heuristic to identify spellcheck dialog.
+ General: Ensure list name is presented for ancestor lists.
+ Updated translations.

==== osinfo-db ====

- bsc#1086715 - SLE15 patch for osinfo-db has wrong information
in it
add-sle15-support.patch

==== oxygen5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang
oxygen5-sounds oxygen5-style

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== patch ====
Version update (2.7.5 -> 2.7.6)

- Move COPYING from %doc to %license.
- Add AUTHORS and COPYING to %doc.
- fix-segfault-mangled-rename.patch: Fix segfault with mangled
rename patch (bsc#1080951, CVE-2018-6951, savannah#53132).
- patch 2.7.6:
* Files specified on the command line are no longer verified to
be inside the current working directory, so commands like
"patch -i foo.diff ../foo" will work again
* Fixes CVE-2016-10713 (Out-of-bounds access within
pch_write_line() in pch.c could possibly lead to DoS via a
crafted input file; bsc#1080918)
* Various fixes

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt
patterns-base-base patterns-base-basesystem patterns-base-console
patterns-base-enhanced_base patterns-base-enhanced_base_opt
patterns-base-minimal_base patterns-base-minimal_base_conflicts
patterns-base-sw_management patterns-base-x11 patterns-base-x11_opt
patterns-base-x86

- Add systemd-coredump to the list of recommended of miminal_base
Latest systemd package split off its coredump management facility
into a sub-package. Recommend this package so this functionnality is
still available by default on Factory but give the possibility to
block it by using a soft dep (Recommends:). This might be needed on
live images for example where space is rather low.

==== patterns-kde ====
Subpackages: patterns-kde-devel_kde patterns-kde-devel_kde_frameworks
patterns-kde-devel_qt5 patterns-kde-kde patterns-kde-kde_edutainment
patterns-kde-kde_games patterns-kde-kde_ide patterns-kde-kde_imaging
patterns-kde-kde_internet patterns-kde-kde_multimedia patterns-kde-kde_office
patterns-kde-kde_plasma patterns-kde-kde_utilities
patterns-kde-kde_utilities_opt patterns-kde-kde_yast

- Recommend kdevelop5 instead of kdevelop4 in the kde_ide pattern
(boo#1009986)
- Don't recommend unused kde-oxygen-fonts and google-droid-fonts

==== perl-Bootloader ====

- Use %license instead of %doc [bsc#1082318]

==== perl-DateTime ====
Version update (1.46 -> 1.48)

- updated to 1.48
see /usr/share/doc/packages/perl-DateTime/Changes
1.48 2018-03-26
- The last release would die if Sub::Util was not available, but this should
just be an optional requirement. Fixed by Paul Howarth. Fixes GH #77. PR
[#78].
- updated to 1.47
see /usr/share/doc/packages/perl-DateTime/Changes
1.47 2018-03-25
1.47 2018-02-18
- DateTime::Duration->multiply now only allows integer
multipliers. Implemented by Dan Stewart. PR #73.
- Added is_last_day_of_quarter() and is_last_day_of_year()
methods. Implemented by Dan Stewart. PR #72.
- When an exception was thrown while adding a duration the object could be
left in a broken state, with the duration partially applied. Subsequent
addition or subtraction would produce the wrong results. Reported by Pawel
Pabian. GH #74.

==== perl-DateTime-TimeZone ====
Version update (2.17 -> 2.18)

- updated to 2.18
see /usr/share/doc/packages/perl-DateTime-TimeZone/Changes
2.18 2018-03-23
- This release is based on version 2018d of the Olson database. This release
includes contemporary changes for Palestine and Casey Station.

==== perl-IPC-Run ====
Version update (0.96 -> 0.97)

- Fixed build on ppc and ppc64 architectures.
- Refreshed spec file with spec-clean.
- updated to 0.97
see /usr/share/doc/packages/perl-IPC-Run/Changes
0.97 Mon Mar 26 2018
- Update meta and POD to point to GitHub issues not RT.
- Update README with pod changes.
- Fix variable name in synopsis - [Github #47]
- Fix t/run.t to work on "perl in space" - [Github #100]

==== php7 ====
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-json php7-ldap php7-mbstring php7-mysql
php7-odbc php7-openssl php7-pdo php7-pear php7-pear-Archive_Tar php7-pgsql
php7-shmop php7-snmp php7-sockets php7-sqlite php7-sysvsem php7-sysvshm
php7-tidy php7-tokenizer php7-wddx php7-xmlreader php7-xmlwriter php7-xsl
php7-zip php7-zlib

- build firebird extension only for openSUSE (sle15 requirement)

==== plasma-nm5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== plasma5-addons ====
Version update (5.12.3 -> 5.12.4)
Subpackages: plasma5-addons-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* [konsoleprofiles applet] Do not try to set plasmoid.aspectRatioMode
* Fix default colour used by Swap monitor
* Drop unused X-Plasma-Requires-* entries from applet metadata
* Remove long-time deprecated Encoding=UTF-8 from desktop format files

==== plasma5-desktop ====
Version update (5.12.3 -> 5.12.4)
Subpackages: plasma5-desktop-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* [Folder View] Fix selecting text with Shift+Home/End (kde#392318)
* Make Select/Deselect All operate on the filtered rows.
* Remove long-time deprecated Encoding=UTF-8 from desktop format files
* [touchpad kded] Work around kded fail on X-KDE-OnlyShowOnQtPlatforms lists
* [Touchpad KCM] Sync values to UI on Defaults in Wayland session (kde#392029)
* [Workspace Options KCM] sync() after writing settings
* bad textarea width for rename file if filename too short (kde#386546)
* Fix scrollbar on empty search results (kde#391644)
* kimpanel: Fix the window positioning when plasma uses native-qt scaling.
* Load correct wallpaper plugin configuration in the dialog
* Don't skip certain recent documents in kicker and taskmanager
* Improve multi-desktop folderview behavior (kde#390676)
* Use QUrl in the ScreenMapper API
* use opacity instead of visible (kde#391432)

==== plasma5-integration ====
Version update (5.12.3 -> 5.12.4)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== plasma5-openSUSE ====
Version update (15.0~git20180116T134836~c3ce1b2 ->
15.0~git20180328T172058~30e1414)
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 20180328T172058~30e1414:
* Enable native file dialogs in digikam and showfoto
- Update to 5.12.4
- Update to 20180322T150725~d7ae3c4:
* Provide kcm-about-distrorc in the tarball
* Add a new distributor icon
* Add a new splash screen

==== plasma5-pa ====
Version update (5.12.3 -> 5.12.4)
Subpackages: plasma5-pa-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* call beginRemoveRows before removing the data

==== plasma5-workspace ====
Version update (5.12.3 -> 5.12.4)
Subpackages: plasma5-session plasma5-session-wayland plasma5-workspace-devel
plasma5-workspace-lang plasma5-workspace-libs

- Don't require plasma5-workspace in plasma5-workspace-devel,
it pulls in a lot of unnecessary requirements and can cause
build loops
- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* [notifications applet] Fix two qml warnings about assigning [undefined]
* Remove long-time deprecated Encoding=UTF-8 from desktop format files
* [Run Command] Pass "event" to runCurrentIndex
* Move to KRunner's second results item with a single keypress (kde#392197)
* Pass proper click coordinates to SNI ContextMenu calls
* libdbusmenu-qt: Remove nonexistant actions directly from the menu
* Set a transient parent for SNI context menus
* [DeviceNotifications Engine] Never show safely remove message when mounting
(kde#391180)
* Use dbus-run-session instead of dbus-launch --exit-with-session
* [System Tray] Fix hiding applets with HiddenStatus
* [Notifications] Remove NoAccessNetworkAccessManagerFactory
* Improve By Desktop sorting for task groups (kde#384747)
* Use separate config group for each wallpaper plugin
* Fix duplicated [Desktop Entry] sections in two menu directory files
- Remove patches, now upstream:
* 0001-Use-dbus-run-session-instead-of-dbus-launch-exit-wit.patch
- Add patches to not set QT_QPA_PLATFORM in a wayland session:
* 0001-Call-KLocalizedString-setApplicationDomain-after-Q-A.patch
* 0002-Add-platform-detection-to-KWorkspace-library-to-adju.patch
* 0003-No-longer-export-QT_QPA_PLATFORM-env-variable-to-the.patch
* 0001-Set-XDG_SESSION_TYPE-wayland-in-startplasmacomposito.patch
- Set GDK_BACKEND=x11 to work around GTK3 bugs:
* 0001-Set-GTK_BACKEND-x11-in-a-wayland-session.patch
- Add a suffix to the wayland session's name:
* 0001-Add-suffix-to-the-wayland-session-s-name.patch
- Apply upstream patches before downstream patches

==== pngquant ====

- Abolish %__ type macro indirections.

==== polkit-kde-agent-5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== powerdevil5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: powerdevil5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None
- Add patch to support wayland sessions without QT_QPA_PLATFORM:
* 0001-Use-platform-detection-from-KWorkspace-in-Powerdevil.patch

==== python-gobject ====
Version update (3.28.1 -> 3.28.2)
Subpackages: python2-gobject python2-gobject-Gdk python2-gobject-cairo
python3-gobject python3-gobject-Gdk python3-gobject-cairo

- Update to version 3.28.2:
+ Fix:
- __str__ return type of Gtk.TreePath with depth == 0
(glgo#GNOME/pygobject#143);
- A crash when setting a str property with a value containing
surrogates (glgo#GNOME/pygobject#169).
+ Tests: Fix a potential crash during tests.

==== python-kiwisolver ====

- Quantify speeds in description.

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Don't add a suffix for wayland sessions anymore, for symmetry with
gdm and lightdm:
* 0001-Remove-suffix-for-Wayland-session.patch

==== shotwell ====
Version update (0.28.0 -> 0.28.1)
Subpackages: shotwell-lang

- Update to version 0.28.1:
+ The paperbag. Unbreak all publishers.
+ Fix a missing symbol error.
+ Bugs fixed: bgo#794293.
+ Updated translations.

==== spectacle ====
Subpackages: spectacle-lang

- Add patch to fix taking screenshots on wayland without the wayland
platform plugin:
* 0001-Decide-to-use-the-wayland-backend-by-looking-at-XDG_.patch

==== spirv-tools ====

- add spirv-tools-devel for baselibs, for wine usage.

==== squid ====
Version update (4.0.23 -> 4.0.24)

- New upstream version 4.2.24
+ Bug 4505: SMP caches sometimes do not purge entries
+ TPROXY: Fix clientside_mark and client port logging
+ Native FTP: Fix "Cannot assign requested address" with TPROXY
+ SSL-Bump: Fix authentication with types other than Basic
+ ... and some documentation fixes
- install license correctly (bsc#1082318) and transition to SPDXv3

==== system-users ====
Subpackages: system-group-hardware system-group-wheel system-user-bin
system-user-daemon system-user-ftp system-user-games system-user-lp
system-user-mail system-user-man system-user-news system-user-nobody
system-user-upsd system-user-uucp system-user-wwwrun

- Add "render" group in system-group-hardware (bsc#1085847)
"uaccess" tag has been dropped from /dev/dri/renderD* and these devices
now have 0666 permsions by default is owned by the render group.

==== systemd ====
Subpackages: libsystemd0 libsystemd0-32bit libudev-devel libudev1
libudev1-32bit systemd-32bit systemd-logger systemd-sysvinit udev

- Drop systemd-bash-completion sub-package
Now we directly ship the completion scripts from the main package as
we already do for zsh. I couldn't see any advantages in this split.
- Be more accurate when specifiying the tools version we provide
- Make sure rpm won't expand %autopatch even if it's commented
- stat(1) as well as systemctl are not use in %post section of udev
So remove stat(1) from the list of dep and move systemctl to the
requirements of %postun since it's called from there.
- Import commit 14b3e00c3ccb8c1c82c8a2e99a9534750880a09e
e0a8285e2 pid1: when creating service directories, don't chown existing files
(#8181) (boo#1085971)
fb25886b1 Fix format-truncation compile failure by typecasting USB IDs
(#8250) (bsc#1084638)
5a6e9c92e sysusers: make sure to reset errno before calling fget*ent()
c2e1ee488 sysusers: also add support for NIS entries in /etc/shadow
51cb94fa1 sysusers: do not append entries after the NIS ones (bsc#1085062
bsc#1045092)
783f3d368 basic/macros: rename noreturn into _noreturn_ (#8456)
- Drop 0001-basic-macros-rename-noreturn-into-_noreturn_.patch
It's been merged in the git repo.
- Rename the tarball
So it's clear that it contains some additional patches on top of the
upstream version. Use the commit hash in the name so the exact
version can easily be identified.
Provide _service file which can be used to retrieve the tarball from
the git repo (with "osc service disabledrun").
- Split systemd-coredump sub-package off (bsc#1083849)
- Don't ship machines.target in systemd-container but in systemd main package
machines.target is supposed to be a standard target for
starting/stopping all containers. systemd-nspawn is the main user of
it but other container managers could also make use of it.
- Build a mini variant of systemd-container
So we don't have to manually track and remove all files that should
be shipped by systemd-container in the case of a bootstrap build.
- Run migrate-sysconfig-i18n.sh also during package installation (bsc#1086164)
This is needed when we upgrade from SLE11.

==== systemsettings5 ====
Version update (5.12.3 -> 5.12.4)
Subpackages: systemsettings5-devel systemsettings5-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None
- Support wayland sessions without QT_QPA_PLATFORM set:
* 0001-Use-platform-detection-in-SystemSettings.patch

==== tigervnc ====

- Enable xvnc.socket if upgraded from previous installation that
had VNC enabled in xinetd configuration. (bnc#1085974)
- Subpackage xorg-x11-Xvnc must also obsolete tightvnc.

==== timezone ====
Version update (2018c -> 2018d)

- timezone update 2018d (bsc#1086729):
* In 2018, Palestine starts DST on March 24, not March 31
* Casey Station in Antarctica changed from +11 to +08 on
2018-03-11 at 04:00
* corrections for historical transitions

==== timezone-java ====
Version update (2018c -> 2018d)

- timezone update 2018d (bsc#1086729):
* In 2018, Palestine starts DST on March 24, not March 31
* Casey Station in Antarctica changed from +11 to +08 on
2018-03-11 at 04:00
* corrections for historical transitions

==== totem-pl-parser ====
Version update (3.26.0 -> 3.26.0+20180301.0091a56)
Subpackages: libtotem-plparser-mini18 libtotem-plparser18 totem-pl-parser-lang
typelib-1_0-TotemPlParser-1_0

- Update to version 3.26.0+20180301.0091a56:
+ plparse: Don't consider MJPEG streams as JPEG images.
+ build: Remove libsoup dependency.
+ podcast: Add support for "medium" property.
+ videosite: Fix leak in totem_pl_parser_add_videosite.
+ Updated translations.
- Switch to git checkout via source service.
- Drop pkgconfig(libsoup-2.4) BuildRequires following upstreams
changes.
- Use autosetup macro.
- Pass explicit disable-gmime-i-know-what-im-doing=false,
enable-quvi=yes, enable-libarchive=yes and enable-libgcrypt=yes
to meson, make sure we build the features we want.

==== unrar_wrapper ====

- remove python3-devel BuildRequires that is not needed
- fix license

==== upower ====
Subpackages: libupower-glib3 typelib-1_0-UpowerGlib-1_0 upower-lang

- Add upower-fix-ios-crash.patch to fix repeating crashes on some
iOS devices like the Apple TV (fdo#105625).

==== usbutils ====

- Use usb ids from hwdata
- Modernise spec file with spec-cleaner
- Make building more verbose

==== util-linux ====
Subpackages: libblkid-devel libblkid1 libblkid1-32bit libfdisk1 libmount1
libmount1-32bit libsmartcols1 libuuid-devel libuuid1 libuuid1-32bit
util-linux-lang

- Use %license instead of %doc [bsc#1082318]

==== util-linux-systemd ====

- Use %license instead of %doc [bsc#1082318]

==== vala ====
Version update (0.40.0 -> 0.40.1)
Subpackages: libvala-0_40-0

- Update to version 0.40.1:
+ Various bug fixes:
- codegen:
. Don't add target fields for captured delegates without
target.
. Don't add length fields for captured fixed-length array
variables.
- valadoc: Bump VALA_0_xx defines and glib_minor to match 0.40
series.
+ Bindings:
- Add libgeoclue-2.0 bindings (bgo#794376).
- gobject-2.0: Cherry-pick some changes from 0.42.
- gdk-3.0,gtk+-3.0: Update to 3.22.29.
- gtk+-4.0: Update to 3.93.0+433517fd.
- gtk+-*.0: Fix iter parameter of
TextView.backward*/forward*/move_visually() (bgo#794345).
- gstreamer-1.0: Update to 1.13.91 and add gstreamer-webrtc-1.0
bindings.
- libgsf-1: Switch to GIR and update to 1.14.42.
- linux: Add various symbols.
- posix:
. Add various symbols.
. Include sys/sysmacros.h for major(), minor() and makedev()
(bgo#794651).
- webkit-1.0: Update to 2.4.11.
- webkit2gtk-4.0: Update to 2.20.0.
- Update GIR-based bindings.

==== vim ====
Subpackages: gvim vim-data vim-data-common

- instead of explicitly unsetting mouse, remove it from the defaults in the
first place (boo#1079185, vim-8.0.1568-defaults.patch)

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- Fallback to latest version of openSUSE when opensuse-unknown is
detected for the ISO (bsc#1085757)
virtinst-use-latest-opensuse-version-when-unknown-media.patch
- bsc#1086038 - VM guests cannot be properly installed with
virt-install
virtinst-dont-set-cpu-model-when-caps-mismatch.patch

==== xdg-desktop-portal-kde ====
Version update (5.12.3 -> 5.12.4)
Subpackages: xdg-desktop-portal-kde-lang

- Update to 5.12.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.4.php
- Changes since 5.12.3:
* None

==== xen ====
Version update (4.10.0_14 -> 4.10.0_16)
Subpackages: xen-doc-html xen-libs xen-tools xen-tools-domU

- Upstream patches from Jan (bsc#1027519) and fixes related to
Page Table Isolation (XPTI). See also bsc#1074562 XSA-254
5a856a2b-x86-xpti-hide-almost-all-of-Xen-image-mappings.patch
5a9eb7f1-x86-xpti-dont-map-stack-guard-pages.patch
5a9eb85c-x86-slightly-reduce-XPTI-overhead.patch
5a9eb890-x86-remove-CR-reads-from-exit-to-guest-path.patch
5aa2b6b9-cpufreq-ondemand-CPU-offlining-race.patch
5aaa9878-x86-vlapic-clear-TMR-bit-for-edge-triggered-intr.patch

==== xfce4-panel-plugin-pulseaudio ====
Version update (0.3.5 -> 0.4.0)
Subpackages: xfce4-panel-plugin-pulseaudio-lang

- update to version 0.4.0: Stable Release!
* Use correct player names and icons in media player preferences
* Translation Updates

==== xorg-x11-server ====
Subpackages: xorg-x11-server-sdk xorg-x11-server-wayland

- Update and re-enable n_xserver-optimus-autoconfig-hack.patch.
(bnc#1084411)

==== yakuake ====
Version update (3.0.4 -> 3.0.5)
Subpackages: yakuake-lang

- Update to 3.0.5
* Improved Wayland support.
* Yakuake's window title now always matches what's shown in its
title bar.
* Fixed button icons in the 'Appearance' settings page.
* Yakuake now installs a D-Bus service file. This allows calling
its D-Bus methods even when Yakuake is not running yet- it will
then be started implicitly.
* Fixed a crash due to a missing bounds check in the
'sessionAtTab' D-Bus method.
* Fixed a type marshalling issue with the 'addSession' D-Bus
method that caused a noisy warning when using it via qdbus.
* Yakuake now depends on KDE Frameworks 5.29 or higher.
- Drop 0001-Revert-Removed-usage-to-deprecated-interface.patch,
Leap 42.2 is no longer supported
- Use cmake() syntax for BuildRequires
- Mark license files as %license

==== yp-tools ====
Version update (4.2.2 -> 4.2.3)

- Update to version 4.2.3
- Re-add yptest [issues/#4]
- Lower compiler warnings [bsc#1084633]

==== zstd ====
Version update (1.3.3 -> 1.3.4)

- Update to 1.3.4
* perf: faster speed (especially decoding speed) on recent cpus
(haswell+)
* perf: much better performance associating --long with
multi-threading
* perf: better compression at levels 13-15
* cli : asynchronous compression by default, for faster
experience (use --single-thread for former behavior)
* cli : smoother status report in multi-threading mode
* cli : added command --fast=#, for faster compression modes
* cli : fix crash when not overwriting existing files
* api : `nbThreads` becomes `nbWorkers` : 1 triggers
asynchronous mode
* api : compression levels can be negative, for even more speed
* api : ZSTD_getFrameProgression() : get precise progress
status of ZSTDMT anytime
* api : ZSTDMT can accept new compression parameters during
compression
* api : implemented all advanced dictionary decompression prototypes
- build the static library (depency for btrfsprogs-static)
- Update to 1.3.3
* perf: improved zstd_opt strategy (levels 16-19)
* fix : bug #944 : multithreading with shared ditionary and
large data, reported by @gsliepen
* cli : fix : content size written in header by default
* cli : fix : improved LZ4 format support, by @felixhandte
* cli : new : hidden command -b -S, to benchmark multiple files
and generate one result per file
* api : change : when setting pledgedSrcSize, use
ZSTD_CONTENTSIZE_UNKNOWN macro value to mean "unknown"
* api : fix : support large skippable frames, by @terrelln
* api : fix : re-using context could result in suboptimal
block size in some corner case scenarios
* api : fix : streaming interface was adding a useless
3-bytes null block to small frames
- update to 1.3.2:
* new long range mode, using --long command
* new ability to generate and decode magicless frames
* changed maximum nb of threads reduced to 200, to avoid address
space exhaustion in 32-bits mode
* fix multi-threading compression works with custom allocators
* fix ZSTD_sizeof_CStream() was over-evaluating memory usage
* fix a rare compression bug when compression generates very large
distances and bunch of other conditions
(only possible at --ultra -22)
* fix 32-bits build can now decode large offsets (levels 21+)
* cli added LZ4 frame support by default
* cli improved --list output
* cli now can split input file for dictionary training, using
command -B#
* cli new clean operation artefact on Ctrl-C interruption
* do not change /dev/null permissions when using command -t with
root access
* cli fix write file size in header in multiple-files mode
* api: added macro ZSTD_COMPRESSBOUND() for static allocation
* api: new advanced decompression API
* api: sizeof_CCtx() used to over-estimate
* build: fix : no-multithread variant compiles without pool.c
dependency
* build: better compatibility with reproducible builds
* license: changed /examples license to BSD + GPLv2
* license: fix a few header files to reflect new license
- Update to v1.3.1
* License is now BSD + GPL-2.0
* See https://github.com/facebook/zstd/releases for the
complete changelog.
- Update to v1.1.4
See https://github.com/facebook/zstd/releases for details.
- Drop zstd-lib-no-rebuild.patch
- Fix group name for the shared library
- Update to version 1.1.1
* New : cli commands -M#, --memory=, --memlimit=,
- -memlimit-decompress= to limit allowed memory consumption
during decompression
* Improved : slightly better compression ratio at --ultra levels
* Improved : better memory usage when using streaming
compression API
* Added : API : ZSTD_initCStream_usingCDict(),
ZSTD_initDStream_usingDDict() (experimental section)
* Changed : zstd_errors.h is now installed within /include
(and replaces errors_public.h)
* Fixed : several sanitizer warnings
- Update descriptions
- initial package version 1.1.0
based on https://pbrady.fedorapeople.org/zstd.spec


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups