Mailinglist Archive: opensuse-factory (742 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180320 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180320

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
MozillaFirefox (58.0.2 -> 59.0.1)
akonadi-calendar (17.12.2 -> 17.12.3)
akonadi-calendar-tools (17.12.2 -> 17.12.3)
akonadi-contact (17.12.2 -> 17.12.3)
akonadi-import-wizard (17.12.2 -> 17.12.3)
akonadi-mime (17.12.2 -> 17.12.3)
akonadi-notes (17.12.2 -> 17.12.3)
akonadi-search (17.12.2 -> 17.12.3)
akonadi-server (17.12.2 -> 17.12.3)
akregator (17.12.2 -> 17.12.3)
ark (17.12.2 -> 17.12.3)
attica-qt5 (5.43.0 -> 5.44.0)
baloo5 (5.43.0 -> 5.44.0)
baloo5-widgets (17.12.2 -> 17.12.3)
bluez-qt (5.43.0 -> 5.44.0)
breeze5-icons (5.43.0 -> 5.44.0)
brltty (5.5 -> 5.6)
calendarsupport (17.12.2 -> 17.12.3)
cifs-utils
cmake (3.10.2 -> 3.10.3)
dolphin (17.12.2 -> 17.12.3)
dragonplayer (17.12.2 -> 17.12.3)
ebtables
eventviews (17.12.2 -> 17.12.3)
extra-cmake-modules (5.43.0 -> 5.44.0)
fetchmail
fonts-config
frameworkintegration (5.43.0 -> 5.44.0)
gnome-builder
gnome-mines (3.26.0 -> 3.28.0)
grantleetheme (17.12.2 -> 17.12.3)
graphite2 (1.3.10 -> 1.3.11)
gthumb (3.6.0 -> 3.6.1)
gwenview5 (17.12.2 -> 17.12.3)
iagno (3.26.1 -> 3.28.0)
incidenceeditor (17.12.2 -> 17.12.3)
inst-source-utils (2018.2.16 -> 2018.03.13)
iptables
kaccounts-integration (17.12.2 -> 17.12.3)
kaccounts-providers (17.12.2 -> 17.12.3)
kactivities-stats (5.43.0 -> 5.44.0)
kactivities5 (5.43.0 -> 5.44.0)
kaddressbook (17.12.2 -> 17.12.3)
kalarmcal (17.12.2 -> 17.12.3)
kamera (17.12.2 -> 17.12.3)
karchive (5.43.0 -> 5.44.0)
kate (17.12.2 -> 17.12.3)
kauth (5.43.0 -> 5.44.0)
kbookmarks (5.43.0 -> 5.44.0)
kcalc (17.12.2 -> 17.12.3)
kcalcore (17.12.2 -> 17.12.3)
kcalutils (17.12.2 -> 17.12.3)
kcharselect (17.12.2 -> 17.12.3)
kcmutils (5.43.0 -> 5.44.0)
kcodecs (5.43.0 -> 5.44.0)
kcolorchooser (17.12.2 -> 17.12.3)
kcompletion (5.43.0 -> 5.44.0)
kconfig (5.43.0 -> 5.44.0)
kconfigwidgets (5.43.0 -> 5.44.0)
kcontacts (17.12.2 -> 17.12.3)
kcoreaddons (5.43.0 -> 5.44.0)
kcrash (5.43.0 -> 5.44.0)
kdav (17.12.2 -> 17.12.3)
kdbusaddons (5.43.0 -> 5.44.0)
kdeclarative (5.43.0 -> 5.44.0)
kded (5.43.0 -> 5.44.0)
kdelibs4support (5.43.0 -> 5.44.0)
kdenetwork4-filesharing (17.12.2 -> 17.12.3)
kdepim-addons (17.12.2 -> 17.12.3)
kdepim-apps-libs (17.12.2 -> 17.12.3)
kdepim-runtime (17.12.2 -> 17.12.3)
kdesignerplugin (5.43.0 -> 5.44.0)
kdesu (5.43.0 -> 5.44.0)
kdewebkit (5.43.0 -> 5.44.0)
kdialog (17.12.2 -> 17.12.3)
kdnssd-framework (5.43.0 -> 5.44.0)
kdoctools (5.43.0 -> 5.44.0)
kdump
kemoticons (5.43.0 -> 5.44.0)
kfilemetadata5 (5.43.0 -> 5.44.0)
kget (17.12.2 -> 17.12.3)
kglobalaccel (5.43.0 -> 5.44.0)
kgpg (17.12.2 -> 17.12.3)
kguiaddons (5.43.0 -> 5.44.0)
khelpcenter5 (17.12.2 -> 17.12.3)
kholidays (5.43.0 -> 5.44.0)
khtml (5.43.0 -> 5.44.0)
ki18n (5.43.0 -> 5.44.0)
kiconthemes (5.43.0 -> 5.44.0)
kidentitymanagement (17.12.2 -> 17.12.3)
kidletime (5.43.0 -> 5.44.0)
kimageformats (5.43.0 -> 5.44.0)
kimap (17.12.2 -> 17.12.3)
kinit (5.43.0 -> 5.44.0)
kio (5.43.0 -> 5.44.0)
kio-extras5 (17.12.2 -> 17.12.3)
kio_audiocd (17.12.2 -> 17.12.3)
kirigami2 (5.43.0 -> 5.44.0)
kitemmodels (5.43.0 -> 5.44.0)
kitemviews (5.43.0 -> 5.44.0)
kjobwidgets (5.43.0 -> 5.44.0)
kjs (5.43.0 -> 5.44.0)
kjsembed (5.43.0 -> 5.44.0)
kldap (17.12.2 -> 17.12.3)
kleopatra (17.12.2 -> 17.12.3)
kmag (17.12.2 -> 17.12.3)
kmail (17.12.2 -> 17.12.3)
kmail-account-wizard (17.12.2 -> 17.12.3)
kmailtransport (17.12.2 -> 17.12.3)
kmbox (17.12.2 -> 17.12.3)
kmime (17.12.2 -> 17.12.3)
kmousetool (17.12.2 -> 17.12.3)
knewstuff (5.43.0 -> 5.44.0)
knotes (17.12.2 -> 17.12.3)
knotifications (5.43.0 -> 5.44.0)
knotifyconfig (5.43.0 -> 5.44.0)
kompare (17.12.2 -> 17.12.3)
konqueror (17.12.2 -> 17.12.3)
konsole (17.12.2 -> 17.12.3)
kontact (17.12.2 -> 17.12.3)
kontactinterface (17.12.2 -> 17.12.3)
korganizer (17.12.2 -> 17.12.3)
kpackage (5.43.0 -> 5.44.0)
kparts (5.43.0 -> 5.44.0)
kpeople5 (5.43.0 -> 5.44.0)
kpimtextedit (17.12.2 -> 17.12.3)
kplotting (5.43.0 -> 5.44.0)
kpty (5.43.0 -> 5.44.0)
kross (5.43.0 -> 5.44.0)
kruler (17.12.2 -> 17.12.3)
krunner (5.43.0 -> 5.44.0)
kservice (5.43.0 -> 5.44.0)
ksmtp (17.12.2 -> 17.12.3)
ktexteditor (5.43.0 -> 5.44.0)
ktextwidgets (5.43.0 -> 5.44.0)
ktnef (17.12.2 -> 17.12.3)
kunitconversion (5.43.0 -> 5.44.0)
kwallet (5.43.0 -> 5.44.0)
kwalletmanager5 (17.12.2 -> 17.12.3)
kwayland (5.43.0 -> 5.44.0)
kwidgetsaddons (5.43.0 -> 5.44.0)
kwin5
kwindowsystem (5.43.0 -> 5.44.0)
kxmlgui (5.43.0 -> 5.44.0)
kxmlrpcclient5 (5.43.0 -> 5.44.0)
libKF5ModemManagerQt (5.43.0 -> 5.44.0)
libKF5NetworkManagerQt (5.43.0 -> 5.44.0)
libffi
libgpg-error (1.27 -> 1.28)
libgravatar (17.12.2 -> 17.12.3)
libinput (1.10.2 -> 1.10.3)
libkcddb (17.12.2 -> 17.12.3)
libkcompactdisc (17.12.2 -> 17.12.3)
libkdcraw (17.12.2 -> 17.12.3)
libkdepim (17.12.2 -> 17.12.3)
libkexiv2 (17.12.2 -> 17.12.3)
libkgapi (17.12.2 -> 17.12.3)
libkipi (17.12.2 -> 17.12.3)
libkleo (17.12.2 -> 17.12.3)
libkomparediff2 (17.12.2 -> 17.12.3)
libksane (17.12.2 -> 17.12.3)
libksieve (17.12.2 -> 17.12.3)
libwmf
mailcommon (17.12.2 -> 17.12.3)
mailimporter (17.12.2 -> 17.12.3)
mailman (2.1.23 -> 2.1.26)
marble (17.12.2 -> 17.12.3)
mercurial
messagelib (17.12.2 -> 17.12.3)
mobipocket (17.12.2 -> 17.12.3)
netcfg (11.5 -> 11.6)
okular (17.12.2 -> 17.12.3)
openslp
oxygen5-icon-theme (5.43.0 -> 5.44.0)
pidgin-sipe (1.22.1 -> 1.23.2)
pimcommon (17.12.2 -> 17.12.3)
plasma-framework (5.43.0 -> 5.44.0)
plasma5-workspace
postfix (3.2.4 -> 3.3.0)
postgresql10 (10.2 -> 10.3)
powertop (2.8 -> 2.9)
prison-qt5 (5.43.0 -> 5.44.0)
purple-plugin-pack
purpose (5.43.0 -> 5.44.0)
qalculate (2.2.0 -> 2.2.1)
rdma-core (16.3 -> 16.4)
sddm
solid (5.43.0 -> 5.44.0)
sonnet (5.43.0 -> 5.44.0)
soxr (0.1.2 -> 0.1.3)
spectacle (17.12.2 -> 17.12.3)
syndication (17.12.2 -> 17.12.3)
syntax-highlighting (5.43.0 -> 5.44.0)
threadweaver (5.43.0 -> 5.44.0)
unar
xen (4.10.0_13 -> 4.10.0_14)

=== Details ===

==== MozillaFirefox ====
Version update (58.0.2 -> 59.0.1)
Subpackages: MozillaFirefox-translations-common

- update to Firefox 59.0.1 (bsc#1085671)
MFSA 2018-08
* CVE-2018-5146 (bmo#1446062)
Vorbis audio processing out of bounds write
* CVE-2018-5147 (bmo#1446365)
Out of bounds memory write in libtremor
(mozilla-bmo1446062.patch)
- Added patch:
* mozilla-bmo1005535.patch:
Enable skia_gpu on big endian platforms.
- update to Firefox 59.0
* Performance enhancements
* Drag-and-drop to rearrange Top Sites on the Firefox Home page
* added features for Firefox Screenshots
* Enhanced WebExtensions API
* Improved RTC capabilities
MFSA 2018-06 (bsc#1085130)
* CVE-2018-5127 (bmo#1430557)
Buffer overflow manipulating SVG animatedPathSegList
* CVE-2018-5128 (bmo#1431336)
Use-after-free manipulating editor selection ranges
* CVE-2018-5129 (bmo#1428947)
Out-of-bounds write with malformed IPC messages
* CVE-2018-5130 (bmo#1433005)
Mismatched RTP payload type can trigger memory corruption
* CVE-2018-5131 (bmo#1440775)
Fetch API improperly returns cached copies of no-store/no-cache resources
* CVE-2018-5132 (bmo#1408194)
WebExtension Find API can search privileged pages
* CVE-2018-5133 (bmo#1430511, bmo#1430974)
Value of the app.support.baseURL preference is not properly sanitized
* CVE-2018-5134 (bmo#1429379)
WebExtensions may use view-source: URLs to bypass content restrictions
* CVE-2018-5135 (bmo#1431371)
WebExtension browserAction can inject scripts into unintended contexts
* CVE-2018-5136 (bmo#1419166)
Same-origin policy violation with data: URL shared workers
* CVE-2018-5137 (bmo#1432870)
Script content can access legacy extension non-contentaccessible resources
* CVE-2018-5138 (bmo#1432624) (Android only)
Android Custom Tab address spoofing through long domain names
* CVE-2018-5140 (bmo#1424261)
Moz-icon images accessible to web content through moz-icon: protocol
* CVE-2018-5141 (bmo#1429093)
DOS attack through notifications Push API
* CVE-2018-5142 (bmo#1366357)
Media Capture and Streams API permissions display incorrect origin
with data: and blob: URLs
* CVE-2018-5143 (bmo#1422643)
Self-XSS pasting javascript: URL with embedded tab into addressbar
* CVE-2018-5126
Memory safety bugs fixed in Firefox 59
* CVE-2018-5125
Memory safety bugs fixed in Firefox 59 and Firefox ESR 52.7
- requires NSPR 4.18 and NSS 3.35
- requires rust >= 1.22.1
- removed obsolete patches:
mozilla-alsa-sandbox.patch
mozilla-enable-csd.patch
firefox-no-default-ualocale.patch
- removed l10n_changesets.txt since same information is now in
Firefox source tree (updated create-tar.sh now requires jq)

==== akonadi-calendar ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akonadi-calendar-lang libKF5AkonadiCalendar5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== akonadi-calendar-tools ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akonadi-calendar-tools-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== akonadi-contact ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akonadi-contact-lang libKF5AkonadiContact5 libKF5ContactEditor5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Remove duplicate category file
* Fix crash Bug 390965 - kaddressbook-5.7.2 without kdepim-addons crashes
adding/editing contacts (kde#390965)
* Remove debug
* Allow barcodes to be nullpointers

==== akonadi-import-wizard ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akonadi-import-wizard-lang libKPimImportWizard5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== akonadi-mime ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akonadi-mime-lang libKF5AkonadiMime5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== akonadi-notes ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akonadi-notes-lang libKF5AkonadiNotes5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== akonadi-search ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akonadi-search-lang libKF5AkonadiSearch

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== akonadi-server ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akonadi-server-lang akonadi-server-sqlite libKF5AkonadiAgentBase5
libKF5AkonadiCore5 libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Properly workaround xsltproc not handling spaces in filepaths on Windows
* Add warning in case an invalid mimetype is requested here.
* Restart DataStore's keep-alive query when opening connection

==== akregator ====
Version update (17.12.2 -> 17.12.3)
Subpackages: akregator-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Apply patch from mgannon (kde#381929)
* Don't call it twice

==== ark ====
Version update (17.12.2 -> 17.12.3)
Subpackages: ark-lang libkerfuffle17

- Add downstream patch 0001-Swap-priorities-around-between-unar-and-unrar.patch
* Ensure unar is preferred over the unrar executable when only
a wrapper is installed (boo#1083834)
- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Add expected failures for timestamp tests
* Fix build with Qt 5.11
* Mark canceled extractions as killed jobs (kde#382601)
* Stop crashing when all read-write plugins are disabled (kde#390690)

==== attica-qt5 ====
Version update (5.43.0 -> 5.44.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== baloo5 ====
Version update (5.43.0 -> 5.44.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* balooctl: Remove checkDb option (kde#380465)
* indexerconfig: Describe some functions
* indexerconfig: Expose canBeSearched function
* balooctl monitor: Wait for dbus interface
* fileindexerconfig: Introduce canBeSearched()

==== baloo5-widgets ====
Version update (17.12.2 -> 17.12.3)
Subpackages: baloo5-widgets-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== bluez-qt ====
Version update (5.43.0 -> 5.44.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== breeze5-icons ====
Version update (5.43.0 -> 5.44.0)

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Fix inconsistencies in index.theme, detected by scalabletest
* remove view-media-playlist from preferences icons
* add 24px media-album-cover icon
* add Babe QML support (22px)
* update handle- icons for kirigami
* add 64px media icons for elisa

==== brltty ====
Version update (5.5 -> 5.6)
Subpackages: brltty-driver-at-spi2 brltty-driver-brlapi
brltty-driver-speech-dispatcher brltty-driver-xwindow brltty-lang libbrlapi0_6
python3-brlapi xbrlapi

- Use correct license
- Update to version 5.6
* General updates:
+ BRLTTY has been relicensed to the LGPL (from the GPL).
+ Better cursor routing handling of status line updates and
vertical scrolling.
+ The Track Screen Scroll setting has been added.
+ The Word Wrap setting has been added.
+ Panning left when using a contraction table now word wraps.
+ Typing dismisses an alert message.
+ The test for when INFO does text maximization instead has
been fixed.
+ Overrides are now applied when the preferences haven't yet
been saved.
+ The Inceptor braille driver (from Innovision) has been added.
* The Baum braille driver:
+ On models with B9 and B10 by the joystick, both are
interpreted as Space.
+ Input packet handling for Pronto! V3 models has been fixed.
* The EuroBraille braille driver:
+ Improved autodetection when using Bluetooth.
+ The Esytime braille keyboard can be used over Bluetooth and
USB.
+ For Esytime models, B5 has been renamed to B8.
* The HIMS braille driver:
+ The Smart Beetle is now recognized when using Bluetooth.
* The HumanWare braille driver:
+ The BrailleNote Touch is recognized when using USB.
* BrlAPI changes:
+ The version is now 0.6.7 (it was 0.6.6).
+ The brlapi_getModelIdentifier() function has been added to
the API.
+ The default character set is now based on the user's locale.
+ Sessions would occasionally hang when connecting.
+ PolKit authentication is no longer attempted when it isn't
available.
+ Reading raw key codes no longer uses key ranges.
* Text tables:
+ The lt (Lithuanian) table has been updated.
+ The uk (Ukrainian) table has been added.
* Contraction tables:
+ The fr-abrege (French) table has been updated.
+ The lt (Lithuanian) table has been added.
+ Support has been added for LibLouis tables.
+ brltty-ctb's output is now UTF-8 (rather than ASCII).
* Key tables:
+ The ifPlatform and ifNotPlatform directives have been added.
* Systemd changes:
+ Path (rather than target) units are now used to manage BRLTTY
instances.
* Build features:
+ Add the reload target to the make files for Systemd and Udev.
+ A make file for install/uninstall of the AppStream rules has
been added.
+ Python 3.6 is supported.
- Use espeak-ng when available

==== calendarsupport ====
Version update (17.12.2 -> 17.12.3)
Subpackages: calendarsupport-lang libKF5CalendarSupport5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== cifs-utils ====

- Update BuildIgnore to break build cycle samba-client <-> cifs-utils

==== cmake ====
Version update (3.10.2 -> 3.10.3)

- Update to 3.10.3:
* GoogleTest: Rename TIMEOUT parameter to avoid clash
* Autogen: Fix for the empty source file crash in 3.10.2
* ccmake: fix status line buffer overflow on very wide terminals
- switch to https urls

==== dolphin ====
Version update (17.12.2 -> 17.12.3)
Subpackages: dolphin-part libdolphinvcs5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Fix resetting "View Modes" preferences to defaults

==== dragonplayer ====
Version update (17.12.2 -> 17.12.3)
Subpackages: dragonplayer-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== ebtables ====

- fix ExecStart/ExecStop path in ebtables.service [bnc#1085228]
- Fix ethertypes ownership, should be %exclude, not %ghost.
- Resolve conflict with iptables-nft and obtain ethertypes from new netcfg
minor version. FATE#320520

==== eventviews ====
Version update (17.12.2 -> 17.12.3)
Subpackages: eventviews-lang libKF5EventViews5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== extra-cmake-modules ====
Version update (5.43.0 -> 5.44.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Define __ANDROID_API__
* Fix readelf command name on x86
* Remove obsolete policy settings
* Extend search path for NDK dependencies
* Set ANDROID in the Android toolchain file
* Fix include path for x86 targets
* Android toolchain: add ANDROID_COMPILER_PREFIX variable.

==== fetchmail ====

- Fix fetchmailconf to compile with python{2,3} [bsc#1082694]
* fetchmail-fetchmailconf-python3-1of3.patch
* fetchmail-fetchmailconf-python3-2of3.patch
* fetchmail-fetchmailconf-python3-3of3.patch

==== fonts-config ====

- Do not create fonts.{dir,scale} in encodings directory

==== frameworkintegration ====
Version update (5.43.0 -> 5.44.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== gnome-builder ====
Subpackages: gnome-builder-doc gnome-builder-lang gnome-builder-plugin-jedi
gnome-builder-plugin-jhbuild gnome-builder-plugin-vala-pack

- Recommend flatpak: The application templates in Builder require
flatpak to operate correctly (boo#1085751).

==== gnome-mines ====
Version update (3.26.0 -> 3.28.0)
Subpackages: gnome-mines-lang

- Update to version 3.28.0:
+ Updated translations.
- Update to version 3.27.92.1:
+ Include meson build files in the tarball.
- Update to version 3.27.92:
+ Fixed icon install dir.
+ Install appdata to non-deprecated location.
+ Updated translations.
- Modernize spec-file by calling spec-cleaner
- Update to version 3.27.90:
+ Fixed icon redraw issues.
+ Added snap packaging.
+ Updated translations.
- Update Url tag to https://wiki.gnome.org/Mines: current Mines'
web page.
- Drop intltool BuildRequires following upstream migration to
Gettext.
- Drop %glib2_gsettings_schema_post, %desktop_database_post,
%icon_theme_cache_post post/postun scriptlets and
%glib2_gsettings_schema_requires macro: they are no longer needed
since RPM File Triggers.
- Add meson BuildRequires and replace configure, make and
make_install macros with meson, meson_build and meson_install,
reflecting upstream port to Meson build system.
- Add gee-0.8 and vapigen pkgconfig modules BuildRequires: new
dependencies.
- Update to version 3.27.2:
+ Updated translations.

==== grantleetheme ====
Version update (17.12.2 -> 17.12.3)
Subpackages: grantleetheme-lang libKF5GrantleeTheme5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== graphite2 ====
Version update (1.3.10 -> 1.3.11)
Subpackages: graphite2-devel libgraphite2-3 libgraphite2-3-32bit

- Use python3 everywhere
- Drop fonttools test dep as it pulls TON of py3 packages
- Update to 1.3.11:
- removed patches (upstreamed or not needed)
* gcc8.patch (code commeted out)
* graphite-nonvoid-return.patch (code commented out)
* graphite2-python3_tests.patch (upstreamed)
* graphite2-python3_tests_cornercases.patch (upstreamed
- refreshed patch
* link-gcc-shared.diff
- fixes security issue: CVE-2018-7999 [bsc#1084850]
+ graphite2-CVE-2018-7999.patch

==== gthumb ====
Version update (3.6.0 -> 3.6.1)
Subpackages: gthumb-lang

- Update to version 3.6.1:
+ Bug fixed: Fixed crash when browsing folders with images and
videos (bgo#760214).
+ Updated manual translations.
+ Updated translations.
- Add pkgconfig(json-glib-1.0) BuildRequires to avoid implicit
dependencies.
- Drop update-desktop-files BuildRequires and suse_update_desktop_\
file macro: they are no longer required.

==== gwenview5 ====
Version update (17.12.2 -> 17.12.3)
Subpackages: gwenview5-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Enlarge small SVGs too (kde#364822)
* Fix URL Navigator margins
* Hide fullscreen thumbnailbar when on-canvas image tools are in use
* Remove symbolic icons in favor of standard icons
* Fix thumbnail bar in View resetting to OFF when quitting in fullscreen
* Fix background color for image view toolbar (crop/red-eye)
* Update filename in fullscreen view on rename (kde#390332)
* Add icons for context and sidebar menu
* Improve thumbnail tooltip animation (kde#245091)
* Save config when opening the config dialog (kde#390331)

==== iagno ====
Version update (3.26.1 -> 3.28.0)
Subpackages: iagno-lang

- Update to version 3.28.0:
+ Updated translations.
- Update URL tag to https://wiki.gnome.org/Apps/Iagno: the current
Iagno's web page.
- Drop:
+ intltool BuildRequires as upstream ported to Gettext.
+ update-desktop-files BuildRequires and suse_update_desktop_file
macro: they are no longer required.

==== incidenceeditor ====
Version update (17.12.2 -> 17.12.3)
Subpackages: incidenceeditor-lang libKF5IncidenceEditor5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== inst-source-utils ====
Version update (2018.2.16 -> 2018.03.13)

- new susedata i18n structure
- move source to git

==== iptables ====
Subpackages: libiptc0 libxtables12 xtables-plugins

- Fix ethertypes ownership, should be %exclude, not %ghost.
- Resolve conflict with ebtables and obtain ethertypes from new netcfg minor
version. FATE#320520

==== kaccounts-integration ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kaccounts-integration-lang libkaccounts1

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kaccounts-providers ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kaccounts-providers-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kactivities-stats ====
Version update (5.43.0 -> 5.44.0)

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kactivities5 ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kaddressbook ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kaddressbook-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kalarmcal ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kalarmcal-lang libKF5AlarmCalendar5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kamera ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kamera-lang kio_kamera

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== karchive ====
Version update (5.43.0 -> 5.44.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kate ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kate-lang kate-plugins

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kauth ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kauth-devel libKF5Auth5 libKF5Auth5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kbookmarks ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kcalc ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kcalc-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kcalcore ====
Version update (17.12.2 -> 17.12.3)

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kcalutils ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kcalutils-lang libKF5CalendarUtils5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kcharselect ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kcharselect-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kcmutils ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kcmutils-devel libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kcodecs ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kcodecs-devel libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kcolorchooser ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kcolorchooser-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kcompletion ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kcompletion-devel libKF5Completion5 libKF5Completion5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kconfig ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5
libKF5ConfigCore5-lang libKF5ConfigGui5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Save some memory allocations by using the right API
* Export kconf_update with tooling

==== kconfigwidgets ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Improve KLanguageButton::insertLanguage when no name is passed
* Add icons for KStandardActions Deselect and Replace

==== kcontacts ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kcontacts-lang libKF5Contacts5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kcoreaddons ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kcoreaddons-devel kcoreaddons-lang libKF5CoreAddons5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Cleanup m_inotify_wd_to_entry before invalidating Entry pointers
(kde#390214)
* kcoreaddons_add_plugin: remove effectless OBJECT_DEPENDS on json file
* Help automoc to find metadata JSON files referenced in the code
* kcoreaddons_desktop_to_json: note the generated file in the build log
* Bump shared-mime-info to 1.3
* Use override keyword here
* Introduce K_PLUGIN_CLASS_WITH_JSON
* KUrlMimeData: port to QStringLiteral
* Increase timeout in the hope of fixing test failure on the CI

==== kcrash ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Add default value

==== kdav ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKPimKDAV5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kdbusaddons ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5
libKF5DBusAddons5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kdeclarative ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Fix the build failure on armhf/aarch64
* Kill QmlObjectIncubationController
* disconnect render() on window change (kde#388508, kde#374280, kde#365052,
kde#343576)

==== kded ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kded-devel kded-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kdelibs4support ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kdelibs4support-devel kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* autotests: detect executables as shared libraries too
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kdenetwork4-filesharing ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kdenetwork4-filesharing-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kdepim-addons ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kdepim-addons-lang

- Add Place-events-without-start-date-at-end-date.patch to avoid
an infinite loop that would cause Plasma to freeze when there was
an agenda item with no start date in the calendar
(boo#1084802, kde#367541)
- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Fix Bug 389820 - spamassassin (kde#389820)

==== kdepim-apps-libs ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kdepim-apps-libs-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kdepim-runtime ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kdepim-runtime-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Fix method name

==== kdesignerplugin ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kdesu ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kdesu-devel libKF5Su5 libKF5Su5-lang

- Add patch to allow kdesu to be used on wayland:
* 0001-Unset-QT_QPA_PLATFORM-to-get-xcb.patch
- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kdewebkit ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kdialog ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kdialog-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kdnssd-framework ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kdoctools ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kdoctools-devel kdoctools-lang libKF5DocTools5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kdump ====

- kdump-always-copy-timezone.patch: Always copy timezone data into
kdumprd (bsc#1081646).

==== kemoticons ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kfilemetadata5 ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kfilemetadata5-devel kfilemetadata5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kget ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kget-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Fix porting bug in UrlChecker::destUrl()
* Fix wrong path conversions in NewTransferDialogHandler::handleUrls()
* Fix importing several links at once
* Fix destDir handling in KGet::addTransfer() (kde#390612)
* Fix blurry icons in HiDPI

==== kglobalaccel ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccel5-lang libKF5GlobalAccelPrivate5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kgpg ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kgpg-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* ignore empty entries in key groups (kde#387408)

==== kguiaddons ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== khelpcenter5 ====
Version update (17.12.2 -> 17.12.3)
Subpackages: khelpcenter5-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kholidays ====
Version update (5.43.0 -> 5.44.0)

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* various - use camelcase headers, minor coding style
* Use override
* I'll take maintainership --Allen

==== khtml ====
Version update (5.43.0 -> 5.44.0)
Subpackages: khtml-devel libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== ki18n ====
Version update (5.43.0 -> 5.44.0)
Subpackages: ki18n-devel libKF5I18n5 libKF5I18n5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* API dox: add note about calling setApplicationDomain after QApp creation

==== kiconthemes ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kiconthemes-devel libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* [KIconLoader] Take into account devicePixelRatio for overlays

==== kidentitymanagement ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kidentitymanagement-lang libKF5IdentityManagement5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kidletime ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kimageformats ====
Version update (5.43.0 -> 5.44.0)

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* kcoreaddons_add_plugin: remove effectless OBJECT_DEPENDS on json file

==== kimap ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kimap-lang libKF5IMAP5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kinit ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kinit-devel kinit-lang

- Add patch to not move XAUTHORITY around if not required (boo#1084798):
* 0001-Only-move-XAUTHORITY-if-it-s-temporary.patch
- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kio ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kio-core kio-devel kio-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Too many changes to list here
- Dropped patches, now upstream:
* 0001-Dont-stat-etc-localtime-between-read-and-write.patch
* 0001-Fix-bug-382437-Regression-in-kdialog-causes-wrong-file-ext.patch

==== kio-extras5 ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kio-extras5-lang libkioarchive5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kio_audiocd ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kio_audiocd-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kirigami2 ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Too many changes to list here

==== kitemmodels ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kitemviews ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kitemviews-devel libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kjobwidgets ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kjs ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kjs-devel kjs-devel-lang libKF5JS5 libKF5JSApi5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kjsembed ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kjsembed-devel libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kldap ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kldap-lang libKF5Ldap5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kleopatra ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kleopatra-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kmag ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kmag-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kmail ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kmail-application-icons kmail-lang ktnef

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Rename categories file name + follow kdepim categories name
* Fix Bug 390620 Editing an Identity while New Message window is open causes
the Signature to be updated in the New Message window (kde#390620)

==== kmail-account-wizard ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kmail-account-wizard-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kmailtransport ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kmailtransport-lang libKF5MailTransport5
libKF5MailTransportAkonadi5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Fix autotest smtpjobtest.

==== kmbox ====
Version update (17.12.2 -> 17.12.3)

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kmime ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kmime-lang libKF5Mime5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kmousetool ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kmousetool-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== knewstuff ====
Version update (5.43.0 -> 5.44.0)
Subpackages: knewstuff-core-devel knewstuff-devel libKF5NewStuff5
libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Add explicit includes to fix build with Qt 5.11
* Add vokoscreen to KMoreTools and add it to the "screenrecorder" grouping

==== knotes ====
Version update (17.12.2 -> 17.12.3)
Subpackages: knotes-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== knotifications ====
Version update (5.43.0 -> 5.44.0)
Subpackages: knotifications-devel libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Use QWidget to see if the window is visible

==== knotifyconfig ====
Version update (5.43.0 -> 5.44.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kompare ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kompare-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== konqueror ====
Version update (17.12.2 -> 17.12.3)
Subpackages: konqueror-devel konqueror-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== konsole ====
Version update (17.12.2 -> 17.12.3)
Subpackages: konsole-part

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kontact ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kontact-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kontactinterface ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kontactinterface-lang libKF5KontactInterface5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== korganizer ====
Version update (17.12.2 -> 17.12.3)
Subpackages: korganizer-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kpackage ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kpackage-devel kpackage-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Help automoc to find metadata JSON files referenced in the code

==== kparts ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kparts-devel libKF5Parts5 libKF5Parts5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Clean up old, unreachable code
* Drop obsolete version checks

==== kpeople5 ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kpeople5-devel kpeople5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kpimtextedit ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kpimtextedit-lang libKF5PimTextEdit5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kplotting ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kpty ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kpty-devel libKF5Pty5 libKF5Pty5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kross ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kross-devel kross-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kruler ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kruler-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== krunner ====
Version update (5.43.0 -> 5.44.0)
Subpackages: krunner-devel libKF5Runner5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Update krunner plugin template

==== kservice ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kservice-devel kservice-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== ksmtp ====
Version update (17.12.2 -> 17.12.3)
Subpackages: ksmtp-lang libKPimSMTP5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== ktexteditor ====
Version update (5.43.0 -> 5.44.0)
Subpackages: ktexteditor-devel ktexteditor-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Initialize value
* Iterate over initializer_lists to avoid mem allocs
* Add icons for KTextEditor Document-Export, Bookmark-Remove and Formatting
Text Upppercase, Lowercase and Capitalize

==== ktextwidgets ====
Version update (5.43.0 -> 5.44.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== ktnef ====
Version update (17.12.2 -> 17.12.3)
Subpackages: ktnef-lang libKF5Tnef5

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kunitconversion ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5
libKF5UnitConversion5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kwallet ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 kwalletd5-lang libKF5Wallet5
libkwalletbackend5-5

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kwalletmanager5 ====
Version update (17.12.2 -> 17.12.3)
Subpackages: kwalletmanager5-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== kwayland ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kwayland-devel

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Implement releasing of client-freed output
* [server] Properly handle the situation when the DataSource for a drag gets
destroyed (kde#389221)
* [server] Don't crash when a subsurface gets commited whose parent surface
got destroyed (kde#389231)
- Dropped patches, now upstream:
* 0001-server-Don-t-crash-when-a-subsurface-gets-commited-w.patch

==== kwidgetsaddons ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kwin5 ====
Subpackages: kwin5-devel kwin5-lang

- Add patch to create Xauthority on wayland, to support connections
as different user (boo#1084737):
* 0001-Use-Xauthority-for-Xwayland.patch

==== kwindowsystem ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== kxmlgui ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kxmlgui-devel libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Explicity include <QAction> to fix build with Qt 5.11
* Fix build with Qt < 5.9
* Reset QLocale internals when we have a custom app language
* Do not allow to configure separator actions via context menu
* Don't show context menu menu if right-clicking outside (kde#373653)
* Improve KSwitchLanguageDialogPrivate::fillApplicationLanguages

==== kxmlrpcclient5 ====
Version update (5.43.0 -> 5.44.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Move categories file here

==== libKF5ModemManagerQt ====
Version update (5.43.0 -> 5.44.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== libKF5NetworkManagerQt ====
Version update (5.43.0 -> 5.44.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== libffi ====
Subpackages: libffi7 libffi7-32bit

- libffi-riscv.patch: add support for RISC-V

==== libgpg-error ====
Version update (1.27 -> 1.28)
Subpackages: libgpg-error-devel libgpg-error0 libgpg-error0-32bit

- update to 1.28:
* The formerly internal yat2m tool is now installed for a native build.
* The new files gpgrt.m4 and gpgrt-config are now installed. They can
be used instead of gpg-error.m4 and gpg-error-config.
* New logging functions similar to those used by GnuPG.
* New helper functions for platform abstraction.
* Interface changes

==== libgravatar ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5Gravatar5 libgravatar-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libinput ====
Version update (1.10.2 -> 1.10.3)
Subpackages: libinput-udev libinput10

- Update to bugfix release 1.10.3
* Fix a crasher triggered by a specific event sequence during
3-finger gestures (and on some touchpads 2-finger gestures).
* Fix the new pointer jitter detection. A bitmask got lost and
the software compared 32 bits instead of only the 3 it ought
to care about.

==== libkcddb ====
Version update (17.12.2 -> 17.12.3)

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libkcompactdisc ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5CompactDisc5 libkcompactdisc-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libkdcraw ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5KDcraw5 libkdcraw-devel

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libkdepim ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5Libkdepim5 libKF5LibkdepimAkonadi5 libkdepim-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libkexiv2 ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5KExiv2-15_0_0 libkexiv2-devel

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libkgapi ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libkipi ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5Kipi32_0_0 libkipi-data libkipi-devel

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libkleo ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5Libkleo5 libkleo-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libkomparediff2 ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libkomparediff2-5 libkomparediff2-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libksane ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5Sane5 libksane-devel libksane-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== libksieve ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libksieve-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Fix autotest

==== libwmf ====
Subpackages: libwmf-0_2-7 libwmf-tools

- libwmf-0.2.8.4-config.patch: update so -config --libs
do not inject bogus dependencies to other packages.
- build with disable-static too.

==== mailcommon ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5MailCommon5 mailcommon-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== mailimporter ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5MailImporter5 libKF5MailImporterAkonadi5 mailimporter-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== mailman ====
Version update (2.1.23 -> 2.1.26)

- Fix install prefix for some of the files
- Install license file
- Sort out with spec-cleaner
- Use direct paths in post scriptlets and properly state their deps
- Do not attempt user creation during build, fails anyway
- Use proper user creation code in scriptlets
- update to 2.1.26
* An XSS vulnerability in the user options CGI could allow a crafted
URL to execute arbitrary javascript in a user's browser. A
related issue could expose information on a user's options page
without requiring login. (CVE-2018-5950) bsc#1077358
* Google reCAPTCHA v2
* New bin/mailman-config command to display various information
about this Mailman version and how it was configured.
* bug fixes, i18n updates
* for further details see NEWS
- updato to 2.1.25
* The admindb held subscriptions listing now includes the date of the
most recent request from the address.
* bug fixes, i18n updates
* for further details see NEWS
- update to 2.1.24
* bug fixes, i18n updates
* for further details see NEWS
- Rename and refresh patch:
* mailman-2.1.2-list_lists.patch to mailman-2.1.26-list_lists.patch

==== marble ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libastro1 libmarblewidget-qt5-28 marble-devel

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== mercurial ====
Subpackages: mercurial-lang

- Modernize spec-file by calling spec-cleaner

==== messagelib ====
Version update (17.12.2 -> 17.12.3)
Subpackages: messagelib-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Reactivate code now
* Reactivate scroll to
* Remove some yellow style
* Activate it
* Fix add/remove yellow mark
* Workaround bug found by David.
* Patch from aleksejshilin

==== mobipocket ====
Version update (17.12.2 -> 17.12.3)

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== netcfg ====
Version update (11.5 -> 11.6)

- Include /etc/ethertypes to resolve a conflict between
security:netfilter/ebtables and security:netfilter/iptables-nft. This
ethertypes version comes from iptables, because it contains an additional
entry over the ebtables one. Increased minor version to allow a suitable
Requires statement in ebtables/iptables. FATE#320520
- Use %license (boo#1082318)

==== okular ====
Version update (17.12.2 -> 17.12.3)
Subpackages: okular-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* Add QVERIFY to QTest::qWaitForWindowExposed
* Fix crash due to dangling pointer in MouseAnnotation (kde#388228)
* Build++
* Add test that produces bug 388288 crash
* Make it compile
* Make Part::openUrl not discard OpenUrlArguments (kde#386600)
* Fix potential crash in document saving
* PDF: Fix potential crash
* XPS: Fix crash opening some files

==== openslp ====
Subpackages: openslp-devel openslp-server

- Use %license (boo#1082318)
- fix slpd using the peer address as local address for TCP
connections [bnc#1076035]
new patch: openslp.localaddr.diff
- use tcp connections for unicast requests [bnc#1080964]
new patch: openslp.tcpunicast.diff

==== oxygen5-icon-theme ====
Version update (5.43.0 -> 5.44.0)
Subpackages: oxygen5-icon-theme-large

- It's no longer necessary to add the media-mount icons, they are
included now
- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* add Artikulate icon BUG:317527 (kde#317527)
* add folder-games icon BUG: 318993 (kde#318993)
* fix incorrect 48px icon for calc.template BUG: 299504 (kde#299504)
* add media-playlist-repeat and shuffle icon BUG: 339666 (kde#339666)
* Oxygen: add tag icons like in breeze BUG: 332210 (kde#332210)
* link emblem-mount to media-mount BUG: 373654 (kde#373654)
* add network icons which are available in breeze-icons BUG:374673
(kde#374673)
* sync oxygen with breeze-icons add icons for audio plasmoid
* Add edit-select-none to Oxygen for Krusader BUG:388691 (kde#388691)
* Add rating-unrated icon BUG:339863 (kde#339863)

==== pidgin-sipe ====
Version update (1.22.1 -> 1.23.2)
Subpackages: libpurple-plugin-sipe libpurple-plugin-sipe-lang pidgin-plugin-sipe

- Update to 1.23.2:
+ fix some HTTP requests that were not sent
- Changes from version 1.23.1:
+ Fixed #337: Duplicate candidates in SDP
+ Fixed #336: Lync autodiscover does not follow user redirect
+ media: unconditionally ignore multichannel codecs
+ Updated translations.
- Changes from version 1.23.0:
+ Feature #100: Extend libpurple D-Bus interface
+ Feature #99: IPv6 addresses in SIP & SDP messages
+ don't load buddy photos from unknown sites by default
* custom web URIs pose a security risk as they may be abused
* users can override this behaviour in the account settings
* Office365 accounts should not be affected by this change
+ add support for GMime 3.0 API
+ raise BR glib-2.0 >= 2.18.0
+ raise BR purple >= 2.7.0
+ drop support for GMime 2.4
+ drop support for gstreamer-0.10

==== pimcommon ====
Version update (17.12.2 -> 17.12.3)
Subpackages: libKF5PimCommon5 libKF5PimCommonAkonadi5 pimcommon-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== plasma-framework ====
Version update (5.43.0 -> 5.44.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-lang plasma-framework-private

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* use the new value for largeSpacing in Kirigami
* Reduce visibility of PC3 TextField placeholder text
* Don't make Titles 20% transparent either
* [PackageUrlInterceptor] Don't rewrite "inline"
* API dox: remove duplicated deprecated comment
* API dox: Use @deprecated tag for deprecation comment
* Don't make Headings 20% transparent, to match Kirigami
* don't put the fullrep in the popup if not collapsed
* Remove dead code for finding QCA2, not used since Plasma5
* Help automoc to find metadata JSON files referenced in the code
* [AppletQuickItem] Preload applet expander only if not already expanded
* other preload microoptimizations
* drop the setting of c++0x
* Set IconItem default to smooth=true
* preload the expander (the dialog) too
* [AppletQuickItem] Fix setting default preload policy if no environment
variable is set
* fix RTL appearance for ComboBox
* try to preload certain applets in a smart way
* [Icon Item] Set filtering on FadingNode texture
* Initialize m_actualGroup to NormalColorGroup
* Make sure the FrameSvg and Svg instances have the right devicePixelRatio

==== plasma5-workspace ====
Subpackages: plasma5-session plasma5-session-wayland plasma5-workspace-devel
plasma5-workspace-lang plasma5-workspace-libs

- Add upstream patch to fix starting a wayland session from gdm and
lightdm: (boo#1085772):
* 0001-Use-dbus-run-session-instead-of-dbus-launch-exit-wit.patch

==== postfix ====
Version update (3.2.4 -> 3.3.0)
Subpackages: postfix-doc

- Refresh spec-file via spec-cleaner and manual optinizations.
* Add %license macro.
* Set license to IPL-1.0 OR EPL-2.0.
- Update to 3.3.0
*
http://cdn.postfix.johnriley.me/mirrors/postfix-release/official/postfix-3.3.0.RELEASE_NOTES
* Dual license: in addition to the historical IBM Public License
1.0, Postfix is now also distributed with the more recent Eclipse
Public License 2.0. Recipients can choose to take the software
under the license of their choice. Those who are more comfortable
with the IPL can continue with that license.
* The postconf command now warns about unknown parameter names
in a Postfix database configuration file. As with other unknown
parameter names, these warnings can help to find typos early.
* Container support: Postfix 3.3 will run in the foreground with
"postfix start-fg". This requires that Postfix multi-instance
support is disabled (the default). To collect Postfix syslog
information on the container's host, mount the host's /dev/log
socket into the container, for example with "docker run -v
/dev/log:/dev/log ...other options...", and specify a distinct
Postfix syslog_name setting in the container (for example with
"postconf syslog_name=the-name-here").
* Milter support: applications can now send RET and ENVID parameters
in SMFIR_CHGFROM (change envelope sender) requests.
* Postfix-generated From: headers with 'full name' information
are now formatted as "From: name <address>" by default. Specify
"header_from_format = obsolete" to get the earlier form "From:
address (name)".
* Interoperability: when Postfix IPv6 and IPv4 support are both
enabled, the Postfix SMTP client will now relax MX preferences
and attempt to schedule similar numbers of IPv4 and IPv6
addresses. This works around mail delivery problems when a
destination announces lots of primary MX addresses on IPv6, but
is reachable only over IPv4 (or vice versa). The new behavior
is controlled with the smtp_balance_mx_inet_protocols parameter.
* Compatibility safety net: with compatibility_level < 1, the
Postfix SMTP server now warns for mail that would be blocked
by the Postfix 2.10 smtpd_relay_restrictions feature, without
blocking that mail. There still is a steady trickle of sites
that upgrade from an earlier Postfix version.

==== postgresql10 ====
Version update (10.2 -> 10.3)
Subpackages: libecpg6 libpq5 postgresql10-contrib postgresql10-devel
postgresql10-docs postgresql10-server

- Update to 10.3
* https://www.postgresql.org/docs/current/static/release-10-3.html
A dump/restore is not required for those running 10.X.
However, if you run an installation in which not all users are
mutually trusting, or if you maintain an application or
extension that is intended for use in arbitrary situations, it
is strongly recommended that you read the documentation changes
described in the first changelog entry in the link above, and
take suitable steps to ensure that your installation or code is
secure.
Also, the changes described in the second changelog entry in
the link above may cause functions used in index expressions or
materialized views to fail during auto-analyze, or when
reloading from a dump. After upgrading, monitor the server logs
for such problems, and fix affected functions.
* CVE-2018-1058 bsc#1081925 Uncontrolled search path element in
pg_dump and other client applications

==== powertop ====
Version update (2.8 -> 2.9)
Subpackages: powertop-lang

- Remove powertop-no-date.patch: upstreamed
- Upgrade to version 2.9
Already mainline:
D powertop-2.8-potential-segfaults.patch
D powertop-no-date.patch
From mainline (after 2.9):
A powertop_cstate_fix.patch
A powertop_libc++_fix.patch

==== prison-qt5 ====
Version update (5.43.0 -> 5.44.0)

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Update links to dependencies, and mark Android as officially supported
* Make DMTX dependency optional
* Add QML support for Prison
* Set minimum size on 1D barcodes as well

==== purple-plugin-pack ====
Subpackages: libpurple-plugin-pack libpurple-plugin-pack-lang pidgin-plugin-pack

- Add a missing build dependency: python2.

==== purpose ====
Version update (5.43.0 -> 5.44.0)
Subpackages: libKF5Purpose5 libKF5PurposeWidgets5 purpose-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* forgot to commit it
* Generate debug categories and create file for it
* Fix tier, accommodate for KIO

==== qalculate ====
Version update (2.2.0 -> 2.2.1)
Subpackages: libqalculate-devel

- Use %license
- Clean .spec file
- Update to 2.2.1:
* Fix electric constant, magnetic constant, and characteristic impedance of
vacuum.
* Fix handling of Unicode symbols in expressions with quotation marks.
* Fix segfault in solve() function.
* sinc() function.
* Add vacuum_permeability and vacuum_permittivity as alternative names for
magnetic and electric constants.
* Add completion only names to enable completion of Greek letters from the
Roman letter names.
* Suppress gnuplot output in terminal.

==== rdma-core ====
Version update (16.3 -> 16.4)
Subpackages: libibverbs libibverbs1 libmlx4-1 libmlx5-1 librdmacm1

- Update to rdma-core v16.4 (bsc#1084456)
* Backport fixes:
* cxgb4: add new device pci ids.
* mlx5: Fix referencing uninitialized var in create_qp error flow
* Ensure all public headers compile in C++ mode
* providers/i40iw: Skip CQEs for destroyed QP
* ibacm: Support FDR and EDR rates

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Reorder patches for easier maintainability, needs refresh of:
* 0001-Move-Xauthority-to-a-different-location-and-truncate.patch
* 0001-Read-the-DISPLAYMANAGER_AUTOLOGIN-value-from-sysconf.patch
* sddm-relaxed-auth.diff
- Replace 0001-Revert-Rename-XDisplay-and-WaylandDisplay-config-sec.patch
with 0001-Support-both-X11-XDisplay-Wayland-and-WaylandDisplay.patch
- Add patches to fix setting EnableHiDPI in the configuration:
* 0001-greeter-Use-Qt-command-line-parser.patch
* 0001-Fix-platform-detection-for-EnableHiDPI.patch

==== solid ====
Version update (5.43.0 -> 5.44.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-devel solid-imports
solid-tools

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* fix a leak and incorrect nullptr check in DADictionary.
* [UDisks] Fix auto-mount regression (kde#389479)
* [UDisksDeviceBackend] Avoid multiple lookup
* Mac/IOKit backend: support for drives, discs and volumes
- Dropped patches, now upstream:
* Fix-auto-mount-regression.patch

==== sonnet ====
Version update (5.43.0 -> 5.44.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5
sonnet-devel

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Use Locale::name() instead of Locale::bcp47Name()
* Find libhunspell build by msvc

==== soxr ====
Version update (0.1.2 -> 0.1.3)

- Update to 0.1.3
- Upstream changes:
* SIMD enhancements: SSE, AVX, Neon.
* Improve support for clang, ARM, and cross-compilation.
* Provide env. var. override of runtime parameters.
* Build fix re cmake variables AVCODEC_INCLUDE_DIRS &
AVUTIL_INCLUDE_DIRS.
* Build options WITH_SINGLE_PRECISION, WITH_DOUBLE_PRECISION &
WITH_SIMD have been removed; replacement options are detailed
in INSTALL, `Resampling engines'.

==== spectacle ====
Version update (17.12.2 -> 17.12.3)
Subpackages: spectacle-lang

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== syndication ====
Version update (17.12.2 -> 17.12.3)

- Update to 17.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/announce-applications-17.12.3.php
- Changes since 17.12.2:
* None

==== syntax-highlighting ====
Version update (5.43.0 -> 5.44.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* Basic support for PHP and Python fenced code blocks in Markdown
* Support case-insensitive WordDetect
* Scheme highlighting: Remove hard-coded colors
* Add syntax highlighting for SELinux CIL Policies & File Contexts
* Adding ctp file extension to the PHP syntax highlighting
* Yacc/Bison: Fix the $ symbol and update syntax for Bison
* awk.xml: add gawk extension keywords (kde#389590)
* Add APKBUILD to be highlighted as a Bash file
* Revert "Add APKBUILD to be highlighted as a Bash file"
* Add APKBUILD to be highlighted as a Bash file

==== threadweaver ====
Version update (5.43.0 -> 5.44.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.44.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
* None

==== unar ====

- revert changes from the last submission and move unrar_wrapper
script to a separate package as it seems that openSUSE:Factory
is not ready to obsolete unrar by unar yet [bsc#1083834],
[fate#323896]

==== xen ====
Version update (4.10.0_13 -> 4.10.0_14)
Subpackages: xen-doc-html xen-libs xen-tools xen-tools-domU

- bsc#1072834 - Xen HVM: unchecked MSR access error: RDMSR from
0xc90 at rIP: 0xffffffff93061456 (native_read_msr+0x6/0x30)
5a956747-x86-HVM-dont-give-wrong-impression-of-WRMSR-success.patch
- Upstream patches from Jan (bsc#1027519)
5a79d7ed-libxc-packed-initrd-dont-fail-domain-creation.patch
5a7b1bdd-x86-reduce-Meltdown-band-aid-IPI-overhead.patch
5a843807-x86-spec_ctrl-fix-bugs-in-SPEC_CTRL_ENTRY_FROM_INTR_IST.patch
5a856a2b-x86-emul-fix-64bit-decoding-of-segment-overrides.patch
5a856a2b-x86-use-32bit-xors-for-clearing-GPRs.patch
5a8be788-x86-nmi-start-NMI-watchdog-on-CPU0-after-SMP.patch
5a95373b-x86-PV-avoid-leaking-other-guests-MSR_TSC_AUX.patch
5a95571f-memory-dont-implicitly-unpin-in-decrease-res.patch (Replaces
xsa252.patch)
5a95576c-gnttab-ARM-dont-corrupt-shared-GFN-array.patch (Replaces
xsa255-1.patch)
5a955800-gnttab-dont-free-status-pages-on-ver-change.patch (Replaces
xsa255-2.patch)
5a955854-x86-disallow-HVM-creation-without-LAPIC-emul.patch (Replaces
xsa256.patch)
- Drop
xsa252.patch
xsa255-1.patch
xsa255-2.patch
xsa256.patch


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups