Mailinglist Archive: opensuse-factory (742 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180308 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180308

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
ModemManager
NetworkManager
NetworkManager-applet
NetworkManager-openconnect
NetworkManager-pptp
NetworkManager-vpnc
PackageKit-Qt
atkmm1_6
avahi (0.6.32 -> 0.7)
binutils (2.29.1 -> 2.30)
brotli (1.0.2 -> 1.0.3)
clamav (0.99.3 -> 0.99.4)
empathy (3.12.14 -> 3.25.90)
evolution (3.26.5 -> 3.26.6)
evolution-data-server (3.26.5 -> 3.26.6)
evolution-ews (3.26.5 -> 3.26.6)
flatpak
freetype2
gconf2
gdk-pixbuf
gdm-branding-openSUSE
geocode-glib
gfbgraph
gfxboot (4.5.33 -> 4.5.35)
ghex
glade (3.20.3 -> 3.20.4)
gmime
gnome-color-manager
gnome-dictionary
gnome-documents
gnome-dvb-daemon
gnome-icon-theme
gnome-menus
gnome-menus-branding-openSUSE
gnome-online-miners
gnome-packagekit
gnome-power-manager
gnome-screenshot
gnome-software (3.26.6 -> 3.26.7)
gnome-themes-standard (3.22.3 -> 3.27.90)
gnome-user-docs
gnome-vfs2
gnome-video-effects
goffice
gperf
grilo
gsound
gssdp
gthumb
gtk3
gtkmm2
gtkmm3
gtksourceview
gtkspell
gtkspell3
gucharmap
gupnp
gupnp-dlna
gupnp-igd
gvfs (1.34.2 -> 1.34.2.1)
harfbuzz
hicolor-icon-theme
hicolor-icon-theme-branding-openSUSE
iceauth (1.0.7 -> 1.0.8)
intltool
ipset (6.35 -> 6.36)
iso-codes
json-glib
konqueror
libcanberra
libchamplain
libcroco
libcryptui
libdrm (2.4.90 -> 2.4.91)
libgdata
libgee (0.20.0 -> 0.20.1)
libgepub
libgit2-glib (0.26.2 -> 0.26.4)
libglade2
libgnome-keyring
libgnomekbd
libgnomesu
libgsf
libgtop
libgusb
libgxps
libidl
libiptcdata
libkipi
liblouis
libmediaart
libmodman
libnice
libostree
libpeas
libpst
libpwquality
librest
librsvg (2.42.2 -> 2.42.3)
libsigc++2
libsocialweb
libsocialweb-branding-openSUSE
libthai
libvirt (4.0.0 -> 4.1.0)
libwnck
libxcb (1.12 -> 1.13)
libxklavier
libxml++26
libzapojit
libzypp-plugin-appdata
lzip (1.19 -> 1.20)
meld
mjpegtools
mobile-broadband-provider-info
mono-core
mousetweaks
mpg123 (1.25.8 -> 1.25.10)
nautilus-sendto
ncurses
nemiver
notification-daemon
nss-mdns
pangomm1_4
pidgin
pitivi
pixman
polkit-gnome
pulseaudio
python-atspi
python-gtk
python-kiwi (9.13.1 -> 9.13.5)
sddm
seahorse-nautilus
sound-theme-freedesktop
speech-dispatcher
startup-notification
system-config-printer
telepathy-farstream
telepathy-gabble
telepathy-haze
telepathy-idle
telepathy-logger
telepathy-salut
totem
totem-pl-parser
tracker
tracker-miners
upower
util-macros (1.19.1 -> 1.19.2)
vinagre
vino
webkit2gtk3
xdg-desktop-portal (0.8 -> 0.10)
xdg-desktop-portal-gtk (0.7 -> 0.10)
xdg-desktop-portal-kde (5.12.2 -> 5.12.3)
xfce4-branding-openSUSE
xkbcomp (1.4.0 -> 1.4.1)

=== Details ===

==== ModemManager ====
Subpackages: ModemManager-bash-completion ModemManager-devel ModemManager-lang
libmm-glib0 typelib-1_0-ModemManager-1_0

- Modernize spec-file by calling spec-cleaner

==== NetworkManager ====
Subpackages: NetworkManager-devel NetworkManager-lang libnm-glib-vpn1
libnm-glib4 libnm-util2 libnm0 typelib-1_0-NM-1_0 typelib-1_0-NMClient-1_0
typelib-1_0-NetworkManager-1_0

- Add nm-fix-autoconnect.patch: Fix autoconnect with agent-owned
secrets (bgo#794014, boo#1079672).
- fix nfs dispatcher script (boo#1083831)
- Modernize spec-file by calling spec-cleaner

==== NetworkManager-applet ====
Subpackages: NetworkManager-applet-lang NetworkManager-connection-editor
libnm-gtk0 libnma0 nma-data typelib-1_0-NMGtk-1_0

- Modernize spec-file by calling spec-cleaner

==== NetworkManager-openconnect ====
Subpackages: NetworkManager-openconnect-gnome

- Modernize spec-file by calling spec-cleaner

==== NetworkManager-pptp ====
Subpackages: NetworkManager-pptp-gnome

- Modernize spec-file by calling spec-cleaner

==== NetworkManager-vpnc ====
Subpackages: NetworkManager-vpnc-gnome

- Modernize spec-file by calling spec-cleaner

==== PackageKit-Qt ====
Subpackages: PackageKit-Qt-devel libpackagekitqt5-0

- Use SPDX3.0 license tags and package COPYING as %license.

==== atkmm1_6 ====

- Modernize spec-file by calling spec-cleaner

==== avahi ====
Version update (0.6.32 -> 0.7)
Subpackages: avahi-compat-mDNSResponder-devel avahi-lang libavahi-client3
libavahi-client3-32bit libavahi-common3 libavahi-common3-32bit libavahi-core7
libavahi-devel libdns_sd

- Use SPDX3.0 license tags and package COPYING as %license.
- Update to version 0.7:
+ The Avahi 0.7 release brings two new features, binary TXT
records in XML service files and the ability to start the
gobject client in a custom context.
+ New Features:
- Add support for binary values in TXT records in XML service
files by specifying
value-format="text|binary-hex|binary-base64". If not
specified, defaults to the normal value of "text" (thus
backwards compatible).
- avahi-gobject: Allow starting the client in a custom
GMainContext by passing context to ga_client_start_in_context
instead of ga_client_start (avahi-gobject minor version has
been incremented).
+ Notable Changes:
- avahi-daemon: Remove all default rlimits from
avahi-daemon.conf, as two main problems happened with firstly
rlimit-nproc causing avahi to fail when started in a
container without user namespaces and secondly because memory
rlimits were causing avahi to crash in some cases. Leave it
up to the init system to impose any modified limits instead.
It is recommend to ship this change in distribution default
config files.
- avahi-common: Fix watch cleanup issue in watch_free
- avahi-discover (python): Updated for Python3 & GTK3
- avahi-autoipd:
. Clear previously set address before binding a new one.
. Fix dhclient hooks to check for avahi-autoipd before
running.
- build: Move default rundir from /var/run to /run as per
modern system setups.
+ Other Changes:
- build:
. Fix the printed value of "Building libavahi-client" in
./configure.
. autogen.sh improved to work when called from another
directory.
. Fix warnings when compiling against musl libc.
- avahi-compat-libdns_sd: Fix incorrect URL in warnings.
- service-type-database: Add new service Types: _ipps._tcp,
_xpra._tcp.
- avahi-dnsconfd: Update manpage with the correct action script
name.
- avahi-gobject:
. Use the correct shared library name in AvahiCore-0.6.gir
. Fix build failing under some locales.
- avahi-common/dbus-watch-glue.c: remove Unneeded semicolon.
- Update gentoo init scripts for newer openrc version.
+ Updated translations.
- Drop avahi-empty-share-dir.patch, avahi-gir-fixup.patch,
avahi-move-everything-to-run.patch and avahi-outdated-URL.patch:
Fixed upstream.
- Drop systemd_requires macro: on a machine managed by systemd, we
don't have to require it. If the machine/container is not managed
by systemd, we don't want to require it.
- Add pkgconfig(pygobject-3.0) BuildRequires: New dependency.

==== binutils ====
Version update (2.29.1 -> 2.30)
Subpackages: binutils-devel

- Add binutils-pr22868.diff to fix testsuite fails in LLVM.
- Update to binutils 2.30
* Add --debug-dump=links option to readelf and --dwarf=links option to objdump
which displays the contents of any .gnu_debuglink or .gnu_debugaltlink
sections.
Add a --debug-dump=follow-links option to readelf and a --dwarf=follow-links
option to objdump which causes indirect links into separate debug info files
to be followed when dumping other DWARF sections.
* Add support for loaction views in DWARF debug line information.
* Add -z separate-code to generate separate code PT_LOAD segment.
* Add "-z undefs" command line option as the inverse of the "-z defs" option.
* Add -z globalaudit command line option to force audit libraries to be run
for every dynamic object loaded by an executable - provided that the loader
supports this functionality.
* Tighten linker script grammar around file name specifiers to prevent the use
of SORT_BY_ALIGNMENT and SORT_BY_INIT_PRIORITY on filenames. These would
previously be accepted but had no effect.
* The EXCLUDE_FILE directive can now be placed within any SORT_* directive
within input section lists.
- binutils-2.30-branch.diff: 2.30 branch @4cd0043413
- riscv-wrap-relax.patch: Fix linker relaxation with --wrap
- Remove use-hashtype-both-by-default.diff, use
- -enable-default-hash-style=both instead
- Remove binutils-2.29-branch.diff, s390x-8fe09d7.diff
- Use riscv64-suse-linux as target for cross-riscv64-binutils

==== brotli ====
Version update (1.0.2 -> 1.0.3)
Subpackages: libbrotlicommon1 libbrotlienc1

- Update to new upstream release 1.0.3
* New "Large Window Brotli" feature
* New dictionary generator

==== clamav ====
Version update (0.99.3 -> 0.99.4)
Subpackages: libclamav7

- Update to security release 0.99.4 (bsc#1083915):
* CVE-2012-6706
* CVE-2017-6419
* CVE-2017-11423
* CVE-2018-1000085 (bsc#1082858)
* CVE-2018-0202
- Obsolete patches:
* clamav-CVE-2012-6706.patch
* clamav-gcc47.patch

==== empathy ====
Version update (3.12.14 -> 3.25.90)
Subpackages: empathy-lang telepathy-mission-control-plugin-goa

- Modernize spec-file by calling spec-cleaner

==== evolution ====
Version update (3.26.5 -> 3.26.6)
Subpackages: evolution-lang evolution-plugin-bogofilter
evolution-plugin-pst-import evolution-plugin-spamassassin

- Update to version 3.26.6:
+ itip-formatter: Meeting request attendee response address not
properly filled.
+ Bugs fixed: bgo#793582.

==== evolution-data-server ====
Version update (3.26.5 -> 3.26.6)
Subpackages: evolution-data-server-lang libcamel-1_2-60 libebackend-1_2-10
libebook-1_2-19 libebook-contacts-1_2-2 libecal-1_2-19 libedata-book-1_2-25
libedata-cal-1_2-28 libedataserver-1_2-22 libedataserverui-1_2-1

- Update to version 3.26.6:
+ Google calendar stopped reporting user email.
+ Bugs fixed: bgo#793466, bgo#793852, bgo#791475, bgo#793779.

==== evolution-ews ====
Version update (3.26.5 -> 3.26.6)
Subpackages: evolution-ews-lang

- Update to version 3.26.6:
+ Bugs fixed: bgo#793606.

==== flatpak ====
Subpackages: libflatpak0 typelib-1_0-Flatpak-1_0

- Do not build document portal anymore, rely on
xdg-desktop-portal/-gtk instead. Add corresponding dependency.
- Build with --with-system-bubblewrap and Add corresponding
build and runtime dependency.
- Remove --with-dwarf-header configure flag, it no longer exists.
- Modernize spec-file by calling spec-cleaner

==== freetype2 ====
Subpackages: freetype2-devel libfreetype6 libfreetype6-32bit

- Refresh spec-file via spec-cleaner.
- Add shell script freetype2.sh in separate package
freetype2-profile-tti35 in order to be able to set TrueType
interpreter version 35 (boo#1084085).

==== gconf2 ====
Subpackages: gconf-polkit gconf2-devel

- Modernize spec-file by calling spec-cleaner

==== gdk-pixbuf ====
Subpackages: gdk-pixbuf-devel gdk-pixbuf-lang gdk-pixbuf-query-loaders
gdk-pixbuf-query-loaders-32bit gdk-pixbuf-thumbnailer libgdk_pixbuf-2_0-0
libgdk_pixbuf-2_0-0-32bit typelib-1_0-GdkPixbuf-2_0

- Modernize spec-file by calling spec-cleaner

==== gdm-branding-openSUSE ====

- Modernize spec-file by calling spec-cleaner

==== geocode-glib ====
Subpackages: libgeocode-glib0 typelib-1_0-GeocodeGlib-1_0

- Modernize spec-file by calling spec-cleaner

==== gfbgraph ====
Subpackages: libgfbgraph-0_2-0 typelib-1_0-GFBGraph-0_2

- Fix SRPM group. Update summaries.
- Modernize spec-file by calling spec-cleaner

==== gfxboot ====
Version update (4.5.33 -> 4.5.35)

- Translated using Weblate (Danish)
- 4.5.35
- Translated using Weblate (French)
- Translated using Weblate (Dutch)
- 4.5.34

==== ghex ====
Subpackages: ghex-lang libgtkhex-3-0

- Modernize spec-file by calling spec-cleaner

==== glade ====
Version update (3.20.3 -> 3.20.4)
Subpackages: glade-lang libgladeui-2-6

- Update to version 3.20.4:
+ Fix bgo#772485: File Name property of GtkImage is copied to all
other GtkImage.
+ Fix bgo#793652: Crash when deleting a list.
+ Fix bgo#793757: Gtk-CRITICAL **: _gtk_window_add_popover:
assertion '_gtk_widget_get_parent (popover) == NULL' failed.
+ Add GDK_SUPER_MASK accelerator handling.

==== gmime ====

- Modernize spec-file by calling spec-cleaner

==== gnome-color-manager ====
Subpackages: gnome-color-manager-lang

- Modernize spec-file by calling spec-cleaner

==== gnome-dictionary ====
Subpackages: gnome-dictionary-lang

- Modernize spec-file by calling spec-cleaner

==== gnome-documents ====
Subpackages: gnome-documents-lang gnome-documents_books-common
gnome-shell-search-provider-documents

- Modernize spec-file by calling spec-cleaner
- Update Url tag to https://wiki.gnome.org/Apps/Documents: current
Documents' web page.
- Drop glib2_gsettings_schema_requires macro now that it is no
longer needed since RPM File Triggers.
- Adopt the use of %make_build macro rather than raw make command,
following the best practices.
- Add fdupes and its macro for replacement of duplicated files with
links under the data directory.

==== gnome-dvb-daemon ====
Subpackages: gnome-dvb-daemon-lang python-gnome-dvb-daemon
totem-plugin-gnome-dvb-daemon

- Modernize spec-file by calling spec-cleaner

==== gnome-icon-theme ====

- Modernize spec-file by calling spec-cleaner

==== gnome-menus ====
Subpackages: gnome-menus-lang

- Modernize spec-file by calling spec-cleaner

==== gnome-menus-branding-openSUSE ====

- Modernize spec file using spec-cleaner.

==== gnome-online-miners ====

- Modernize spec-file by calling spec-cleaner

==== gnome-packagekit ====
Subpackages: gnome-packagekit-lang

- Modernize spec-file by calling spec-cleaner

==== gnome-power-manager ====
Subpackages: gnome-power-manager-lang

- Modernize spec-file by calling spec-cleaner

==== gnome-screenshot ====
Subpackages: gnome-screenshot-lang

- Modernize spec-file by calling spec-cleaner
- Drop %glib2_gsettings_schema_* and %desktop_database_*
post/postun/requires macros: the functionality is covered by file
triggers now.
- Drop libxml2-tools BuildRequires since it's not being used or
needed anymore.

==== gnome-software ====
Version update (3.26.6 -> 3.26.7)
Subpackages: gnome-software-lang

- Update to version 3.26.7:
+ Use less space on low resolution displays.
+ Hide invalid apps we don't know how to install.
+ Rate limit distro upgrade notifications once per week.
+ Make category name sorting case insensitive.
+ Add back install buttons to codec install view.
+ Update flatpak remote metadata when refreshing.
+ Remove fedora-tagger-usage plugin.
+ Various correctness and warning fixes.
+ Various fixes to the external appstream plugin.
+ Various fixes to the snap plugin.
+ Updated translations.

==== gnome-themes-standard ====
Version update (3.22.3 -> 3.27.90)
Subpackages: gnome-themes-accessibility gnome-themes-accessibility-gtk2
gtk2-metatheme-adwaita gtk2-theming-engine-adwaita
gtk2-theming-engine-adwaita-32bit gtk3-metatheme-adwaita
metatheme-adwaita-common

- Modernize spec-file by calling spec-cleaner

==== gnome-user-docs ====
Subpackages: gnome-user-docs-lang

- Modernize spec-file by calling spec-cleaner

==== gnome-vfs2 ====
Subpackages: gnome-vfs2-devel gnome-vfs2-lang

- Modernize spec-file by calling spec-cleaner

==== gnome-video-effects ====

- Modernize spec-file by calling spec-cleaner

==== goffice ====
Subpackages: goffice-lang libgoffice-0_10-10

- Modernize spec-file by calling spec-cleaner

==== gperf ====

- testsuite-race.patch: fix race condition in testsuite

==== grilo ====
Subpackages: grilo-lang libgrilo-0_3-0 libgrlnet-0_3-0 libgrlpls-0_3-0
typelib-1_0-Grl-0_3

- Modernize spec-file by calling spec-cleaner

==== gsound ====
Subpackages: libgsound0 typelib-1_0-GSound-1_0

- Fix SRPM group. Ensure neutrality of descriptions.
- Package COPYING as %license instead of %doc.

==== gssdp ====

- Modernize spec-file by calling spec-cleaner

==== gthumb ====
Subpackages: gthumb-lang

- Modernize spec-file by calling spec-cleaner

==== gtk3 ====
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut
gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-immodule-xim gtk3-lang
gtk3-tools libgtk-3-0 typelib-1_0-Gtk-3_0

- Modernize spec-file by calling spec-cleaner
- Package COPYING as %license instead of %doc.
- Drop gtk3-path-local.patch: patch had been disabled since GTK
August 2016 with nobody missing the feature.

==== gtkmm2 ====

- Modernize spec-file by calling spec-cleaner

==== gtkmm3 ====

- Modernize spec-file by calling spec-cleaner

==== gtksourceview ====
Subpackages: gtksourceview-lang libgtksourceview-3_0-1 typelib-1_0-GtkSource-3_0

- Remove ineffective --with-pic. Fix RPM groups.
- Modernize spec-file by calling spec-cleaner

==== gtkspell ====
Subpackages: gtkspell-lang libgtkspell0

- Modernize spec-file by calling spec-cleaner

==== gtkspell3 ====
Subpackages: gtkspell3-lang libgtkspell3-3-0

- Modernize spec-file by calling spec-cleaner

==== gucharmap ====
Subpackages: gucharmap-lang libgucharmap_2_90-7

- Modernize spec-file by calling spec-cleaner
- Update Url to https://wiki.gnome.org/Apps/Gucharmap: current
Gucharmap's web page.
- Add pkgconfig(glib-2.0) BuildRequires: missing declaration of
dependency, it was already being used thanks to
pkgconfig(gio-2.0) BuildRequires that lives in the same devel
package that provides glib-2.0.
- Drop perl(Env) and libxml2-tools BuildRequires since they are not
being used or needed.
- Points fdupes to removal of duplicates under the data directory
rather than the whole build root.

==== gupnp ====

- Modernize spec-file by calling spec-cleaner

==== gupnp-dlna ====
Subpackages: libgupnp-dlna-2_0-3 libgupnp-dlna-backend-gstreamer

- Modernize spec-file by calling spec-cleaner

==== gupnp-igd ====

- Modernize spec-file by calling spec-cleaner

==== gvfs ====
Version update (1.34.2 -> 1.34.2.1)
Subpackages: gvfs-backend-afc gvfs-backend-samba gvfs-backends gvfs-fuse
gvfs-lang

- Update to version 1.34.2.1:
+ mtp: Prevent crashes if device is unplugged during mount
operation.

==== harfbuzz ====
Subpackages: harfbuzz-devel libharfbuzz-icu0 libharfbuzz0 libharfbuzz0-32bit

- Modernize spec-file by calling spec-cleaner

==== hicolor-icon-theme ====

- Modernize spec-file by calling spec-cleaner

==== hicolor-icon-theme-branding-openSUSE ====

- Modernize spec-file by calling spec-cleaner

==== iceauth ====
Version update (1.0.7 -> 1.0.8)

- Update to version 1.0.8
* autogen.sh: use quoted string variables
* autogen: add default patch prefix
* Add -u & -V options to synopsis in man page
* autogen.sh: use exec instead of waiting for configure to finish

==== intltool ====

- Modernize spec-file by calling spec-cleaner

==== ipset ====
Version update (6.35 -> 6.36)
Subpackages: libipset11

- Update to new upstream release 6.36
* Adding a IPv4 range x.x.x.x?255.255.255.255 could lead to
memory exhaustion, which has been fixed.
- Drop 0001-build-do-install-libipset-args.h.patch (merged)

==== iso-codes ====
Subpackages: iso-codes-lang

- Modernize spec-file by calling spec-cleaner

==== json-glib ====
Subpackages: json-glib-lang libjson-glib-1_0-0 typelib-1_0-Json-1_0

- Modernize spec-file by calling spec-cleaner

==== konqueror ====
Subpackages: konqueror-devel konqueror-lang

- Add add-kwallet-support-to-webengine.patch to allow storing user
names and passwords in kwallet when using the webenginepart

==== libcanberra ====
Subpackages: canberra-gtk-play libcanberra-devel libcanberra-gtk-module-common
libcanberra-gtk0 libcanberra-gtk0-32bit libcanberra-gtk2-module
libcanberra-gtk2-module-32bit libcanberra-gtk3-0 libcanberra-gtk3-module
libcanberra0 libcanberra0-32bit

- Fix SRPM group. Update summaries.
- Modernize spec-file by calling spec-cleaner

==== libchamplain ====
Subpackages: libchamplain-0_12-0 typelib-1_0-Champlain-0_12

- Modernize spec-file by calling spec-cleaner

==== libcroco ====

- Modernize spec-file by calling spec-cleaner

==== libcryptui ====
Subpackages: libcryptui-data libcryptui0 seahorse-daemon

- Update summaries.
- Modernize spec-file by calling spec-cleaner

==== libdrm ====
Version update (2.4.90 -> 2.4.91)
Subpackages: libdrm-devel libdrm2 libdrm_amdgpu1 libdrm_intel1 libdrm_nouveau2
libdrm_radeon1

- update to 2.4.91
+ amdgpu: Fix mistake in initial hole size calculation.
+ amdgpu: mostly revert "use the high VA range if possible v2"
+ amdgpu: add AMDGPU_VA_RANGE_HIGH
+ amdgpu: fix "add AMDGPU_VA_RANGE_HIGH"
+ freedreno: add interface to get buffer address
+ drm/fourcc: Fix fourcc_mod_code() definition
+ drm/tegra: Sanitize format modifiers

==== libgdata ====
Subpackages: libgdata-lang libgdata22 typelib-1_0-GData-0_0

- Modernize spec-file by calling spec-cleaner

==== libgee ====
Version update (0.20.0 -> 0.20.1)

- Modernize spec-file by calling spec-cleaner
- Update to version 0.20.1:
+ Minor bug fixes.
- Update Url tag to https://wiki.gnome.org/Projects/Libgee: the
current Libgee's web page.
- Remove idempotent %clean section: RPM already does this work.
- Update package summaries and descriptions making them either
shorter or more content-descriptive.

==== libgepub ====

- Modernize spec-file by calling spec-cleaner

==== libgit2-glib ====
Version update (0.26.2 -> 0.26.4)

- Update to version 0.26.4:
+ Make meson the official build system.
+ Misc bug fixes.
- Switch to meson buildsystem following upstreams port, add meson
BuildRequires and use meson macros as well as pass explicit
options to meson, build the features we want.
- Modernize spec-file by calling spec-cleaner

==== libglade2 ====

- Remove ineffective --with-pic.
- Modernize spec-file by calling spec-cleaner
- Switch to python3:
+ Add libglade2-python3.patch: convert libglade-convert to a
python3 program.
+ Export PYTHON=/usr/bin/python3 before calling configure.
+ Replace python-devel and python-xml BuildRequires with
python3-devel and python3-xml.
+ Add libtool BuildRequires and call to autoreconf: the currently
bootstrapped configure script can't cope with python3 version
comparison.

==== libgnome-keyring ====
Subpackages: libgnome-keyring-devel libgnome-keyring-lang libgnome-keyring0
typelib-1_0-GnomeKeyring-1_0

- Modernize spec-file by calling spec-cleaner

==== libgnomekbd ====
Subpackages: libgnomekbd-lang

- Modernize spec-file by calling spec-cleaner

==== libgnomesu ====
Subpackages: libgnomesu0

- Modernize spec-file by calling spec-cleaner

==== libgsf ====
Subpackages: gsf-office-thumbnailer libgsf-1-114 libgsf-devel libgsf-lang
typelib-1_0-Gsf-1

- Update summaries. Fix SRPM group.
- Modernize spec-file by calling spec-cleaner

==== libgtop ====
Subpackages: libgtop-2_0-11 libgtop-lang

- Modernize spec-file by calling spec-cleaner

==== libgusb ====

- Modernize spec-file by calling spec-cleaner

==== libgxps ====

- Modernize spec-file by calling spec-cleaner

==== libidl ====
Subpackages: libIDL-2-0 libidl-devel

- Fix SRPM groups. Update summaries. Remove ineffective --with-pic.
- Modernize spec-file by calling spec-cleaner

==== libiptcdata ====
Subpackages: libiptcdata-lang libiptcdata0

- Fix RPM groups. Trim description for secondary packages a bit.
- Modernize spec-file by calling spec-cleaner

==== libkipi ====
Subpackages: libKF5Kipi32_0_0 libkipi-data libkipi-devel

- Only require libkipi11 and apply dont-install-pics.diff in SLE12

==== liblouis ====
Subpackages: liblouis-data liblouis14 python3-louis

- Modernize spec-file by calling spec-cleaner

==== libmediaart ====
Subpackages: libmediaart-2_0-0 typelib-1_0-MediaArt-2_0

- Update summaries.
- Modernize spec-file by calling spec-cleaner

==== libmodman ====

- Fix SRPM group. Update summaries. Reorder file list to have
if/endif blocks per output file.
- Modernize spec-file by calling spec-cleaner

==== libnice ====
Subpackages: gstreamer-libnice libnice10

- Modernize spec-file by calling spec-cleaner

==== libostree ====
Subpackages: libostree-1-1

- Modernize spec-file by calling spec-cleaner

==== libpeas ====
Subpackages: libpeas-1_0-0 libpeas-gtk-1_0-0 libpeas-lang libpeas-loader-python
libpeas-loader-python3 typelib-1_0-Peas-1_0 typelib-1_0-PeasGtk-1_0

- Modernize spec-file by calling spec-cleaner

==== libpst ====

- Modernize spec-file by calling spec-cleaner

==== libpwquality ====
Subpackages: libpwquality-lang libpwquality1

- Modernize spec-file by calling spec-cleaner

==== librest ====
Subpackages: librest-0_7-0 typelib-1_0-Rest-0_7

- Modernize spec-file by calling spec-cleaner

==== librsvg ====
Version update (2.42.2 -> 2.42.3)
Subpackages: gdk-pixbuf-loader-rsvg librsvg-2-2 rsvg-thumbnailer
typelib-1_0-Rsvg-2_0

- Update to version 2.42.3:
+ glgo#GNOME/librsvg#205: The configure script now checks for
Rust 1.20.0. Previously this minimum requirement was not
well-defined.
+ glgo#GNOME/librsvg#204: New feature: If an SVG has an <a> link
element, we now generate the corresponding link when
outputting to a Cairo PDF surface. If you use rsvg-convert(1)
with PDF output, <a> links in the SVG will work in the PDF.
+ glgo#GNOME/librsvg#108: New feature: support font-size:larger
and font-size:smaller relative sizes.
+ New feature: rsvg-convert now supports SOURCE_DATE_EPOCH to
generate reproducible output for PDFs.
+ glgo#GNOME/librsvg#197: New requirement: We now require
Freetype2 2.9.0, which fixes font rendering bugs. The test
reference PNGs have been regenerated with this version.
+ glgo#GNOME/librsvg#91: Fix rendering of masks and clips when
the initial transformation has a translation component.
+ glgo#GNOME/librsvg#112: Fix: apply style attributes for all SVG
elements, not just for the toplevel one.
+ glgo#GNOME/librsvg#161: Fix the marker angle for the last
vertex of closed paths.
+ glgo#GNOME/librsvg#198: Fix: Make rsvg_pixbuf_from_file() and
its derived functions work again. Now we have tests for the
whole public API.
+ glgo#GNOME/librsvg#143: Minor optimizations for Gaussian blurs.
+ glgo#GNOME/librsvg#201: Minor speedups in the code to parse SVG
attributes.
+ glgo#GNOME/librsvg#178: Fix some tests that failed on 32-bit
machines.
+ In addtion to --enable-debug/--disable-debug to control the
Rust compilation, now you can use an environment variable
LIBRSVG_DEBUG=yes / LIBRSVG_DEBUG=no if you wish.
+ Code moved to Rust: SVG paint servers, SVG attribute parsing.
+ We now use a Cargo workspace internally, to move more things to
Rust.
- Add pkgconfig(freetype2) BuildRequires: New dependency.
- Modernize spec-file by calling spec-cleaner

==== libsigc++2 ====
Subpackages: libsigc++2-devel libsigc-2_0-0

- Modernize spec-file by calling spec-cleaner

==== libsocialweb ====
Subpackages: libsocialweb0

- Modernize spec-file by calling spec-cleaner

==== libsocialweb-branding-openSUSE ====

- Modernize spec-file by calling spec-cleaner

==== libthai ====
Subpackages: libthai-data libthai0 libthai0-32bit

- Fix SRPM group. Update descriptions.
- Modernize spec-file by calling spec-cleaner

==== libvirt ====
Version update (4.0.0 -> 4.1.0)
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-logical
libvirt-daemon-driver-storage-mpath libvirt-daemon-driver-storage-rbd
libvirt-daemon-driver-storage-scsi libvirt-daemon-driver-uml
libvirt-daemon-driver-vbox libvirt-daemon-lxc libvirt-daemon-qemu
libvirt-daemon-xen libvirt-libs

- Update to libvirt 4.1.0
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
72adaf2f-revert-qemu-monitor-error-report.patch,
71d56a39-nodedev-fix-parse-PCI-address.patch,
68eed56b-conf-smbios-oem-strings.patch,
76977061-qemu-smbios-oem-strings.patch,
0c710a37-libxl-resume-lock-on-mig-failure.patch,
759b4d1b-virlog-determine-the-hostname-on-startup-CVE-2018-67.patch,
c2dc6698-fix-deadlock-obtaining-hostname.patch,
c391e07e-libxl-clock-settings.patch,
ef71caea-libxl-memalign.patch,
suse-apparmor-signal.patch

==== libwnck ====
Subpackages: libwnck-3-0 typelib-1_0-Wnck-3_0

- Modernize spec-file by calling spec-cleaner

==== libxcb ====
Version update (1.12 -> 1.13)
Subpackages: libxcb-composite0 libxcb-damage0 libxcb-devel libxcb-dpms0
libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0 libxcb-randr0
libxcb-record0 libxcb-render0 libxcb-render0-32bit libxcb-res0
libxcb-screensaver0 libxcb-shape0 libxcb-shm0 libxcb-shm0-32bit libxcb-sync1
libxcb-xf86dri0 libxcb-xfixes0 libxcb-xinerama0 libxcb-xinput0 libxcb-xkb1
libxcb-xtest0 libxcb-xv0 libxcb-xvmc0 libxcb1 libxcb1-32bit

- Update to version 1.13
* As with xcb-proto, this release mainly enables multi-planar buffers in
DRI3 v1.2 via support for variable-sized lists of FDs, and enables
sending GenericEvents to other clients. Present v1.2 and RandR v1.6
did not require any specific library changes.
- supersedes U_add-support-for-eventstruct.patch,
u_build_python3.patch

==== libxklavier ====
Subpackages: libxklavier-devel libxklavier16 typelib-1_0-Xkl-1_0

- Fix RPM groups. Update summaries. Remove --with-pic.
- Modernize spec-file by calling spec-cleaner

==== libxml++26 ====

- Modernize spec-file by calling spec-cleaner

==== libzapojit ====
Subpackages: libzapojit-0_0-0 typelib-1_0-Zpj-0_0

- Modernize spec-file by calling spec-cleaner

==== libzypp-plugin-appdata ====

- Modernize spec-file by calling spec-cleaner

==== lzip ====
Version update (1.19 -> 1.20)

- Update to new upstream release 1.20
* The option "--loose-trailing" has been added.
* The test used by clzip to discriminate trailing data from a
corrupt header in multimember or concatenated files has been
improved to a Hamming distance of 3.
* The "-S" option now keeps input files unchanged.

==== meld ====
Subpackages: meld-lang

- Modernize spec-file by calling spec-cleaner

==== mjpegtools ====
Subpackages: liblavfile-2_0-0 liblavjpeg-2_0-0 liblavplay-2_0-0 liblavrec-2_0-0
libmjpegutils-2_0-0 libmpeg2encpp-2_0-0 libmplex2-2_0-0

- Add libmplex2-2_0-0 to baselibs.conf for gstreamer-plugins-bad-32bit
forgotten in the previous change
- Add libmpeg2encpp-2_0-0 to baselibs.conf for gstreamer-plugins-bad-32bit
which may be needed for wine's A/V support to function properly

==== mobile-broadband-provider-info ====

- Modernize spec-file by calling spec-cleaner

==== mono-core ====
Subpackages: libmono-2_0-1 libmono-2_0-devel libmonosgen-2_0-1
libmonosgen-2_0-devel mono-data mono-data-sqlite mono-extras mono-mvc mono-wcf
mono-web mono-winforms mono-winfxcore

- Fix armv6 build

==== mousetweaks ====
Subpackages: mousetweaks-lang

- Modernize spec-file by calling spec-cleaner

==== mpg123 ====
Version update (1.25.8 -> 1.25.10)
Subpackages: libmpg123-0 mpg123-openal mpg123-pulse

- Update to version 1.25.10
* libout123: Fix error messages beginning from OUT123_ARG_ERROR
(bug 261).
version 1.25.9
* mpg123: Fix --icy-interval handling to work with stream from
stdin. (curl | mpg123 --icy-interval=n -)
* libmpg123: Fix another invalid read and segfault on damaged
(fuzzed) files with part2_3_length == 0 (set maxband=1, pulled
from upcoming 1.26.0).

==== nautilus-sendto ====
Subpackages: nautilus-sendto-lang

- Modernize spec-file by calling spec-cleaner

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo terminfo-base

- Add ncurses patch 6.1-20180303
+ modify TurnOn/TurnOff macros in lib_vidattr.c and lib_vid_attr.c to
avoid expansion of "CUR" in trace.
+ improve a few lintian warnings in test-packages.
+ modify lib_setup to avoid calling pthread_self() without first
verifying that the address is valid, i.e., for weak symbols
(report/patch by Werner Fink).
+ modify generated terminfo.5 to not use "expand" and related width
on the last column of tables, making layout on wide terminals look
better (adapted from patch by Kir Kolyshkin).
+ add a category to report_offsets, e.g., "w" for wide-character, "t"
for threads to make the report more readable. Reorganized the
structures reported to make the categories more apparent.
+ simplify some ifdef's for extended-colors.
+ add NCURSES_GLOBALS and NCURSES_PRESCREEN to report_offsets, to show
how similar the different tinfo configurations are.
- Remove patch ncurses-6.1-weakpthreads.dif now upstream (bsc#1082772)
- Make expect build check less fragile on timing
- Switch back to shared libtinfo only but provide an auxiliary shared
library libtinfow to avoid a rebuild of third party programs (bsc#1082772)
+ Add sanity check if new 32bit API is included in libtinfo
- Add patch ncurses-6.1-weakpthreads.dif
+ Be aware that libtinfo/libtinfw is also used without libpthread
(boo#1058509)
- Use expect to run at least two test for normal and wide character
version of newdemo from test suite
- Add ncurses patch 6.1-20180224
+ modify _nc_resolve_uses2() to detect incompatible types when merging
a "use=" clause of extended capabilities. The problem was seen in a
defective terminfo integrated from simpleterm sources in 20171111,
compounded by repair in 20180121.
+ correct Ss/Ms interchange in st-0.7 entry (tmux #1264) -TD
+ fix remaining flash capabilities with trailing mandatory delays -TD
+ correct cut/paste in NEWS (report by Sven Joachim).
- Add ncurses patch 6.1-20180217
+ remove incorrect free() from 20170617 changes (report by David Macek).
+ correct type for "U8" in user_caps.5; it is a number not boolean.
+ add a null-pointer check in safe_sprintf.c (report by Steven Noonan).
+ improve fix for Debian #882620 by reusing limit2 variable (report
Julien Cristau, Sven Joachim).
- Add ncurses patch 6.1-20180210
+ modify misc/Makefile.in to install/uninstall explicit list in case
the build-directory happens to have no ".pc" files when an uninstall
is performed (report by Jeffrey Walton).
+ deprecate safe-sprintf, since the vsnprintf function, which does what
was needed, was standardized long ago.
+ add several development/experimental options to development packages.
+ minor reordering of options in configure script to make the threaded
and reentrant options distinct from the other extensions which are
normally enabled.
- Make reentrant libs opaque

==== nemiver ====
Subpackages: nemiver-lang

- Modernize spec-file by calling spec-cleaner

==== notification-daemon ====

- Modernize spec-file by calling spec-cleaner

==== nss-mdns ====
Subpackages: nss-mdns-32bit

- Modernize spec-file by calling spec-cleaner

==== pangomm1_4 ====

- Modernize spec-file by calling spec-cleaner

==== pidgin ====
Subpackages: libpurple libpurple-lang libpurple-plugin-sametime libpurple-tcl

- Add pidgin-2.10.11-purple-remote-python3.patch: port
purple-remote to python 3 (bsc#1084147).
- Export PYTHON=python3 in %build.
- Adjust scripts to invoke python3, not python2.
- Drop support for SLE 11 and openSUSE older than 42.x.
- Remove pidgin-gnome-keyring.patch: was only useful for SLE 11.
- Update pidgin-ncurses-6.0-accessors.patch to cope with ncurses
enabling opaque-panels. Pidgin should not access internal
structures of ncurses.

==== pitivi ====
Subpackages: pitivi-lang

- Modernize spec-file by calling spec-cleaner

==== pixman ====
Subpackages: libpixman-1-0 libpixman-1-0-32bit libpixman-1-0-devel

- Modernize spec-file by calling spec-cleaner

==== polkit-gnome ====

- Modernize spec-file by calling spec-cleaner

==== pulseaudio ====
Subpackages: libpulse-devel libpulse-mainloop-glib0 libpulse0
pulseaudio-bash-completion pulseaudio-lang pulseaudio-module-bluetooth
pulseaudio-module-gconf pulseaudio-module-jack pulseaudio-module-lirc
pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils

- Fix the wrongly suspended sinks due to the previous patch
(bsc#1084047):
refreshed 0001-alsa-fix-infinite-loop-with-Intel-HDMI-LPE.patch

==== python-atspi ====

- Modernize spec-file by calling spec-cleaner

==== python-gtk ====

- Modernize spec-file by calling spec-cleaner

==== python-kiwi ====
Version update (9.13.1 -> 9.13.5)

- Bump version: 9.13.4 ? 9.13.5
- Fixed btrfs search path in earlyboot script
If kiwi generates its own efi image for the boot process
it does not setup the btrfs relative path setup in the
earlyboot script embedded into the generated efi image.
This has a bad impact on the file search because the
btrfs setup done in kiwi puts root below the @ volume
which we then need to specify of the relative lookup
is not activated. Fixes bsc#1082155
- Bump version: 9.13.3 ? 9.13.4
- Use LABEL for the swap partition
If multipath and device maps are active the fstab entry should use
the LABEL reference. Systemd calls swapon and it only works properly
with multipath devices when LABEL reference is used or calling directly
on the /dev/dm-* device file.
- Bump version: 9.13.2 ? 9.13.3
- The order of the options for mkisofs matters
Setting -eltorito-platform after -b causes mkisofs to fail
- Resize partition table after image resize
The command 'kiwi image resize' allows to resize the size
of a disk image. Depending on the partition table type it
is also required to resize the partition table inside of
the image to let the file size change become effective
This Fixes #534
- APT: Support patternType in the bootstrap phase
With patternType="onlyRequired" (the default), run debootstrap with
--variant=minbase to install only essential packages. With
patternType="plusRecommended", let debootstrap also install important
packages. This is not exactly what the patternType keyword means with
other targets, but it allows to choose between an absolutely minimal
image and a small but usable system.
- Bump version: 9.13.1 ? 9.13.2
- Reactivate device mappings after repart. Fixes #645
This commit recreates removed device maps and triggers again
systemd generators in order to adapt again device units to the
new context. Fixes #645
- Refactor ovftool check
The way this was done mask errors from the call
with the check if the tool exists on the host.
This patch refactors this and makes clear where
we check for the tool to be installed and where
we actually call it
- Extend has_option_in_help to also check error data
- Check if isotool supports eltorito-platform option
Along with the change there is a small refactoring to
populate the iso tool search to the public api of the
Iso class
- Set eltorito-platform for efi
The default eltorito platform is set to "x86_64 PC", however
in an alternative bootloader spec for efi this would be the
wrong platform spec. This patch adds the correct platform
to the alt-boot setup for efi. References #643
- Fixup obs test status helper
Use osc results output to get better status information
- Fixed get_free_disk_bytes in dracut kiwi-lib
The method used any device from the lsblk output, but it can
happen that some device nodes with different name point to
the same physical device. The method would then calculate
the free space wrong. This patch takes the PARTUUID value
into account to make sure any partition device size is used
only once. This Fixes #648
- Use pytest instead of py.test
From pytest 3.0, it is recommended to use "pytest" as the main
command. The use of "py.test" is deprecated and is potentially removed
in the future.
- Update tox setup
Add python 3.6 target and activate it for the travis
and the local make targets
Use major python version for the check(flake) and doc
targets where the interpreter minor version is not
primarily important
This references #641
- Update yast setup documentation
Incorporate changes per review by Tom

==== sddm ====
Subpackages: sddm-branding-openSUSE

- Add patch to not quit on SIGHUP (boo#1080305):
* 0001-Don-t-quit-on-SIGHUP.patch

==== seahorse-nautilus ====

- Modernize spec-file by calling spec-cleaner

==== sound-theme-freedesktop ====

- Modernize spec-file by calling spec-cleaner

==== speech-dispatcher ====
Subpackages: libspeechd-devel libspeechd2 python3-speechd
speech-dispatcher-configure speech-dispatcher-module-espeak

- Use espeak-ng when available

==== startup-notification ====

- Modernize spec-file by calling spec-cleaner

==== system-config-printer ====
Subpackages: python3-cupshelpers system-config-printer-applet
system-config-printer-common system-config-printer-common-lang
system-config-printer-dbus-service udev-configure-printer

- Modernize spec-file by calling spec-cleaner

==== telepathy-farstream ====

- Update summaries, fix SRPM group.
- Modernize spec-file by calling spec-cleaner

==== telepathy-gabble ====

- Modernize spec-file by calling spec-cleaner

==== telepathy-haze ====

- Modernize spec-file by calling spec-cleaner

==== telepathy-idle ====

- Modernize spec-file by calling spec-cleaner

==== telepathy-logger ====
Subpackages: libtelepathy-logger3 typelib-1_0-TelepathyLogger-0_2

- Update summaries, fix RPM groups.
- Modernize spec-file by calling spec-cleaner

==== telepathy-salut ====

- Modernize spec-file by calling spec-cleaner

==== totem ====
Subpackages: nautilus-totem totem-lang totem-plugin-brasero totem-plugins

- Modernize spec-file by calling spec-cleaner

==== totem-pl-parser ====
Subpackages: libtotem-plparser-mini18 libtotem-plparser18 totem-pl-parser-lang
typelib-1_0-TotemPlParser-1_0

- Use SPDX3.0 license tags and package COPYING as %license.

==== tracker ====
Subpackages: libtracker-common-2_0 libtracker-control-2_0-0
libtracker-miner-2_0-0 libtracker-sparql-2_0-0 tracker-lang
typelib-1_0-Tracker-2_0 typelib-1_0-TrackerControl-2_0

- Modernize spec-file by calling spec-cleaner

==== tracker-miners ====
Subpackages: tracker-miner-files tracker-miners-lang

- Modernize spec-file by calling spec-cleaner

==== upower ====
Subpackages: libupower-glib3 typelib-1_0-UpowerGlib-1_0 upower-lang

- Use SPDX3.0 license tags and package COPYING as %license.

==== util-macros ====
Version update (1.19.1 -> 1.19.2)

- update to release 1.19.2
* Update check for manpage section numbers to not rely on Solaris version
* Rework CHANGELOG_CMD to touch/echo >&2 only as needed
* Rework INSTALL_CMD to touch/echo >&2 only as needed

==== vinagre ====
Subpackages: vinagre-lang

- Update License to GPL-3.0-or-later: various files are licensed
this way, moving the entire project up.
- Modernize spec-file by calling spec-cleaner

==== vino ====
Subpackages: vino-lang

- Use SPDX3.0 license tags and package COPYING as %license.

==== webkit2gtk3 ====
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Add webkit2gtk3-fix-wayland-crash.patch: fix crash when using
Wayland with QXL/virtio (bsc#1079512, webkit#182490).
- Add missing dependencies from the -devel package to the build
typelib-1_0-*: just like libraries, a consumer of the devel
package can assume the typelibs to be present:
+ typelib-1_0-WebKit2-%{_sonameverpkg}.
+ typelib-1_0-WebKit2WebExtension-%{_sonameverpkg}.

==== xdg-desktop-portal ====
Version update (0.8 -> 0.10)
Subpackages: xdg-desktop-portal-lang

- Remove BuildRequires(flatpak), it is not needed.
- Own /usr/share/dbus-1, /usr/share/dbus-1/{interfaces,services}
which were owned by flatpak package before.
- Use SPDX3.0 license tags and package COPYING as %license.
- Update to version 0.10:
+ xdg-document-portal moved here from flatpak.
+ Add a new screencast and remote desktop portal based on
PipeWire.
- Pass --disable-pipewire to configure: pipewire has not yet been
packaged for openSUSE.
- Add pgkconfig(fuse) BuildRequires: new dependency.
- Update to version 0.9:
+ Install pkg-config files into datadir.
+ Avoid a race in the portal APIs.
+ Change the email portal to take fds.
+ Updated translations.

==== xdg-desktop-portal-gtk ====
Version update (0.7 -> 0.10)
Subpackages: xdg-desktop-portal-gtk-lang

- Update to version 0.10:
+ Fix critical in file chooser.
+ Add options to screenshot portals.
+ Add screencast and remote portal implementations.
+ Updated translations.
- Modernize spec-file by calling spec-cleaner
- Update to version 0.9:
+ Improve the app picker ui.
+ Fix error reporting in the email portal.
+ Updated translations.

==== xdg-desktop-portal-kde ====
Version update (5.12.2 -> 5.12.3)
Subpackages: xdg-desktop-portal-kde-lang

- Update to 5.12.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.3.php
- Changes since 5.12.2:
* None

==== xfce4-branding-openSUSE ====
Subpackages: exo-branding-openSUSE libgarcon-branding-openSUSE
libxfce4ui-branding-openSUSE midori-branding-openSUSE openSUSE-xfce-icon-theme
thunar-volman-branding-openSUSE xfce4-notifyd-branding-openSUSE
xfce4-panel-branding-openSUSE xfce4-power-manager-branding-openSUSE
xfce4-session-branding-openSUSE xfce4-settings-branding-openSUSE
xfdesktop-branding-openSUSE xfwm4-branding-openSUSE

- fix spelling of "Adwaita" in index.theme (boo#1074269)
- use adwaita-icon-theme instead of gnome-icon-theme
as fallback icon theme
The reasons for this change are that Upstream gnome no
longer uses gnome-icon-theme, and to save space on te Thumbleweed
rescue CD, requested by DimStar
https://lists.opensuse.org/opensuse-xfce/2017-05/msg00000.html
- fix /etc/xfce_defaults.conf not declared as %conf
- use plugin-pulseaudio instead of plugin-mixer
- recommend pavucontrol and plugin-pulseaudio instead of xfe4-mixer
- replace application-menu with whiskermenu
- brand whiskermenu suse style
- require whiskermenu from panel-branding-openSUSE
- fix obsoletes of exo-branding-openSUSE
- fix exo-branding provides / obsoletes
- adapt to changes in exo package (exo-1 subdir patch removed)
- on >= 13.2 package-manager.desktop was renamed to
yast2-packager.desktop (boo#892936)
- bump version to 4.12
- lock screen on suspen/hibernate
- xfce4-panel-plugin-xfce4battery was renamed to
power-manager-plugin
- recommend xfce4-panel-plugin-xfce4battery which is in the panel
branding
- fix critical power action and hdd spindown settings
- adapt xfce4-power-manager branding to version 1.3.0
- fix typo
- rename source tarball removing the meaningless version
- adjust to GTK 3 variant of libxfce4ui
- remove support for openSUSE < 12.3
- add custom theme for xfce4-notifyd
- improve suse_version overlay system
- add xfce4-power-manager-branding-openSUSE with default actions
for button press events and critical battery levels
- add support for 13.2, drop support for < 12.2
- follow the exo package changes and rename exo-branding-openSUSE
to libexo-1-0-branding-openSUSE and move helpers.rc in an
API-versioned subdirectory
- support openSUSE 13.1
- fix an error in the openSUSE-Xfce index.theme file causing
theme inheritance to fail
- 12.3 specific xfce4-panel branding
- adapt to Terminal rename
- adapt to new name of the mixer plugin
- remove support for openSUSE 11.4
- disable automatic session saving by default and don't preselect
session saving in the logout dialog since it causes problems such
as bxo#5123
- added audio-input-microphone-muted icon to openSUSE Xfce icon
theme which is used by xfce4-mixer 4.10.0
- on >= 12.2 depend on libgio-2_0-0 which provides the
defaults.list symlink target
- on > 12.2 depend on desktop-file-utils which is now needed to
generate defaults.list
- updated comment in xfce_defaults.conf
- require desktop-data-openSUSE on openSUSE distros in
the openSUSE branding
- own more directories to fix build of derived packages
- remove submenus below Settings which are accessible through the
xfce4-settings-manager
- add xfce4-panel-plugin-mixer to the panel
- add support for Xfce-specific MIME default associations
- add back pager and reduce workspaces to two
- remove the launchers from the panel and switch from action
buttons to the actions menu
- mark the global menus as config files, they may be edited by an
administrator and should not be silently overwritten
- use actions menu rather than buttons in the panel
- fix xfcemail and xfce-nomail icons
- rename %{_datadir}/wallpapers/xfce/default.jpg to
%{_datadir}/wallpapers/xfce/default.wallpaper, the default
wallpaper formats may differ and xfdesktop doesn't care about
the filetype extension
- remove ristretto icons and use the new icons provided by
ristretto 0.6.0
- added depenency of libgarcon-branding-openSUSE on
libxfce4ui-tools snce the menu references xfce4-about.desktop
- remove dependency of libgarcon-branding-openSUSE on
libgarcon-data
- remove dependency of xfce4-panel-branding-openSUSE on exo-tools
- added xfce-schedule icon
- bump version to 4.10
- libgarcon-branding-openSUSE should have a reverse dependency on
libgarcon-data rather than libgarcon-1-0
- libxfce4ui-branding-openSUSE
- added keyboard shortcuts for starting browser and MUA with
XF86WWW and XF86Mail
- use startup notification for xfce4-appfinder shortcuts
- xfce4-settings-branding-openSUSE
- order the menus in xfce-settings-manager.menu
- xfwm4-branding-openSUSE
- enable tiling
- only build midori-branding-openSUSE for > 11.4 since Midori does
not support 11.4 any more
- only depend on wallpaper-branding-openSUSE for > 11.4
- make libgarcon-branding-openSUSE depend on libgarcon-data
- added openSUSE-xfce-icon-theme which provides icons missing from
gnome-icon-theme
- moved licenses into the tarballs
- xfce4-panel-branding-openSUSE
- use internal clock plugin again
- added new button images
%{_datadir}/pixmaps/xfce4-opensuse-light.png and
%{_datadir}/pixmaps/xfce4-opensuse-dark.png
- xfce4-session-branding-openSUSE
- dropped xfce4-settings-helper which ash been removed
- dropped xscreensaver which is now started via autostart
- xfwm4-branding-openSUSE
- increased doubleclick time to 400ms
- enabled composite by default
- enabled shadows
- libgarcon-branding-openSUSE
- reworked application menu and incorporated a customized
xfce-settings-manager-menu
- xfce4-settings-branding-openSUSE
- added customized
%{_sysconfdir}/xdg/menus/xfce-settings-manager.menu which also
includes non-Xfce settings
- switch from the GNOME icon theme to the openSUSE Xfce icon
theme
- xfdesktop-branding-openSUSE
- deliver symlink %{_datadir}/xfce4/backdrops/default.jpg
pointing to the default backdrop image from
wallpaper-branding-openSUSE which is now the compiled-in
default and removed
%{_sysconfdir}/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-desktop.xml
so that now all screens have the same default
- enabled thunar-volman-branding-openSUSE for 11.4
- bump version to 4.9.0
- remove xfce4-tips autostart file
- add build dependencies on upstream branding to avoid ambiguities
- added midori-branding-openSUSE
- added openSUSE package search to the list of search engines
- use opensuse.org as the default home page
- own %{_datadir}/desktop-directories/ for >= 12.1
- enable GNOME compatibility mode in order to start gnome-keyring
by default (bnc#754700)
- adapt to renamed packages
- make the default panel opaque with compositing enabled
(bnc#742766)
- license update: CC-BY-SA-3.0 and GPL-2.0+
Indicate the aggregation of GPL-2.0+ and the CC licensed wallpapers
- fix license to be in spdx.org format
- switch to final xfwm4 branding
- make xfce4-panel-branding-openSUSE depend on
xfce4-panel-plugin-datetime
- use DateTime rather than Clock panel plugin
- added thunar-volman-branding-openSUSE package for >= 12.1
- rename
/usr/share/desktop-directories/xfce-settings-system.directory to
/usr/share/desktop-directories/xfce-administration.directory
and add
/usr/share/desktop-directories/xfce-preferences.directory
- change /etc/xdg/menus/xfce-applications.menu to not show category
PackageManager under System
- renamed COPYING.xfce4-splash-openSUSE-11.4
- created xfce4-branding-openSUSE-4.8.0-11.4.tar.bz2 for < 12.1
- switch to Adwaita as the new default theme for >= 12.1
- use wallpaper from new wallpaper-branding package
- fix build failure by removing the splash on >= 12.1, also
do not install the copyright file
- require the splash out of branding-openSUSE for 12.1+ to
ease the update of artwork
- fixed "Administration" menu for >= 12.1 (bnc#719826)
- changed border/text-color of splash screen to match that of other
GTK splash screens
- included the final splashscreen
- explicitly include xfce-settings-manager.desktop in the Settings
menu since it is also in the X-XFCE category
- stay at 4.8.0
- determine versions of branded packages automatically
- tweaked xfce4-session splash screen look a bit
- bump libgarcon version
- added temporary splash screen for xfce4-settings based on 11.3
branding
- switch to Sonar theme
- added xfce4-branding-openSUSE
- replace exo- launches with launchers for the openSUSE default
applications since items hidden in the main menu cannot be used
as panel launchers
- exclude X-XFCE category from the Settings menu as it will be
shown inside the settings manager and exclude X-Xfce-Toplevel
category from submenus
- merged some keyboard shortcut changes from libxfce4ui 4.8.0
- removed unused panel launcher desktop files
- supplement libgarcon-1-0 rather than libgarcon
- added exo-branding-openSUSE subpackage
- fixed launchers
- added branding for libgarcon, libxfce4ui, xfce4-notifyd
- obsoleted xfce4-desktop branding which is now provided by
xfdesktop-branding
- split up in subpackages xfce4-panel-branding-openSUSE,
xfce4-session-branding-openSUSE,
xfce4-settings-branding-openSUSE, xfdesktop-branding-openSUSE,
libgarcon-branding-openSUSE, libxfce4ui-branding-openSUSE,
xfce4-notifyd-branding-openSUSE
- temporarily removed menu again as it is currently provided by
libgarcon
- migrated panel settings to new format
- cleaned up menu
- version bump to 4.8.0
- add gtk2-metatheme-gilouche to Requires [bnc#616275]
- version bump to 4.7.1
- version bump to 4.6.4
- version bump to 4.6.3
- require desktop-data instead of desktop-data-SuSE
- version bump to 4.6.1
- added branding for xfce4-panel
- updated to be compatible with Xfce 4.6.0 release

==== xkbcomp ====
Version update (1.4.0 -> 1.4.1)

- Update to version 1.4.1
* This release adds the path of the xkbcomp executable to the pkgconfig
data, allowing the X server to find the right binary regardless of
where its (the X servers) $prefix is pointed. Without this the X server
will guess that xkbcomp is configured for the same prefix; since the
default prefix is /usr/local, and your distribution certainly did not
install xkbcomp there, 'make check' and 'ninja dist' for the X server
build would fail because Xvfb would not start.
- supersedes U_xkbcomp_pkgconfig-add-bindir.patch
- refreshed xkbcomp.keyring; seems signing key changed, since this
time the package has been released by Adam Jackson (before: Daniel
Stone)? Hope I got this right ...


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages