Mailinglist Archive: opensuse-factory (588 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180307 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
ImageMagick ( ->
autoyast2 (4.0.36 -> 4.0.37)
dpdk (17.11.1_k4.15.7_1 -> 18.02_k4.15.7_1)
geany-plugins (1.31 -> 1.33)
libical (2.0.0 -> 3.0.3)
libreoffice ( ->
libstorage-ng (3.3.182 -> 3.3.185)
lightdm-gtk-greeter (2.0.3 -> 2.0.4)
perl-CGI-Application (4.50 -> 4.61)
perl-DBD-ODBC (1.56 -> 1.57)
perl-DBD-SQLite (1.54 -> 1.56)
spec-cleaner (1.0.4 -> 1.0.6)
tslib (1.13 -> 1.15)
vim (8.0.1525 -> 8.0.1568)
xfce4-notifyd (0.4.1 -> 0.4.2)
xfce4-settings (4.12.1 -> 4.12.2)
xfce4-terminal (0.8.6 -> 0.8.7)
yast2-packager (4.0.45 -> 4.0.46)

=== Details ===

==== ImageMagick ====
Version update ( ->
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI5 libMagickWand-7_Q16HDRI5 perl-PerlMagick

- update to 7.0.7-25
* Fixed numerous use of uninitialized values, integer overflow,
memory exceeded, and timeouts (credit to OSS Fuzz).

==== aaa_base ====
Subpackages: aaa_base-extras

- Use %license (boo#1082318)

==== autoyast2 ====
Version update (4.0.36 -> 4.0.37)
Subpackages: autoyast2-installation

- Fix in showing/accepting base licenses: Using
inst_product_license module instead of
ProductLicense.AskLicenseAgreement (bnc#1073324)
- 4.0.37

==== bash ====
Subpackages: bash-doc bash-lang libreadline7 readline-devel readline-doc

- Create readline-devel-static package to re-enable static libraries
again (boo#1082913)
- Use %license (boo#1082318)

==== bzip2 ====
Subpackages: libbz2-1 libbz2-1-32bit libbz2-devel

- Update autotools patchset:
D bzip2-1.0.6-autoconfiscated.patch
A bzip2-
- Use %license (boo#1082318)

==== corosync ====
Subpackages: libcmap4 libcorosync_common4

- some coverity fixes for corosync on upstream(bsc#1083895)
Added: 0015-coverity-fixes.patch

==== desktop-file-utils ====

- suse-update-mime-defaults requires coreutils and awk
add both to package requires

==== dpdk ====
Version update (17.11.1_k4.15.7_1 -> 18.02_k4.15.7_1)

- Removed 0002-kni-fix-build-on-SLE12-SP3.patch since no longer referenced in
.spec files
- Added 0002-dpdk-eal-ppc-rte_smp_mb.patch to fix an issue on ppc64le platforms
with v18.02
- Updated to version 18.02; some of the changes include:
* Added function to allow releasing internal EAL resources on exit
* Added igb, ixgbe and i40e ethernet driver to support RSS with flow API
* Updated i40e driver to support PPPoE/PPPoL2TP
* Added MAC loopback support for i40e
* Added support of run time determination of number of queues per i40e VF
* Updated mlx5 driver
* Updated mlx4 driver
* Added NVGRE and UDP tunnels support in Solarflare network PMD
* Added AVF (Adaptive Virtual Function) net PMD
* Added feature supports for live migration from vhost-net to vhost-user
* Updated the AESNI-MB PMD
* Updated the DPAA_SEC crypto driver to support rte_security
* Added Wireless Base Band Device (bbdev) abstraction
* Added New eventdev Ordered Packet Distribution Library (OPDL) PMD
* Added new pipeline use case for dpdk-test-eventdev application
* Updated Eventdev sample application to support event devices based on
* Added Rawdev, a generic device support library
* Added new multi-process communication channel
* Added GRO support for VxLAN-tunneled packets
* Increased default Rx and Tx ring size in sample applications
* Added new DPDK build system using the tools ?meson? and ?ninja?

==== file ====
Subpackages: file-devel file-magic libmagic1

- Use %license (boo#1082318)

==== filesystem ====

- Handle aaa_base moving the license files to /usr/share/licenses.

==== geany-plugins ====
Version update (1.31 -> 1.33)
Subpackages: geany-plugins-lang

- Update to version 1.33:
+ General:
- Rename plugin geanylatex to latex
- utils lib: added new function
+ Addons: Show color tip and start Color Chooser with double
click (gh#geany/geany-plugins#664)
+ GeanyLua:
- Add filetype to set in geany.newfile()
- Add function geany.reloadconf() (gh#geany/geany-plugins#653)
- Fix right-trim.lua (gh#geany/geany-plugins#670)
- Update glspi_keycmd.h to match latest Geany version
- Update to match latest Geany's Scintilla API
+ PrettyPrinter: Allow to pretty print a selection only
+ Spellcheck:
- Remember 'Check while typing' setting between sessions
(gh#geany/geany-plugins#667, gh#geany/geany-plugins#680)
- Support Enchant 2.0 and later (gh#geany/geany-plugins#674)
+ Treebrowser: Fallback to "text-x-generic" icon if info lookup
fails (gh#geany/geany-plugins#682)
+ VC: Remember the commit dialog size
+ Workbench:
- Add "Create file here..."/"Create directory here..."
- Renamed "folder" to "sub-directory"
+ Updated translations.
- Modernize spec-file by calling spec-cleaner.
- Update to version 1.32:
+ General:
- New plugin: Workbench (gh#geany/geany-plugins#460).
- Add a common utils library (gh#geany/geany-plugins#622).
+ Addons - Mark Word: Deselect when the selection changes
+ GeniusPaste - Enable HTTPS for
+ GitChangebar - Add the possibility to undo hunk at cursor
position (gh#geany/geany-plugins#531).
+ PrettyPrinter - Add saving and loading of preferences in/from a
file (gh#geany/geany-plugins#494, gh#geany/geany-plugins#581).
+ ProjectOrganizer:
- Close dir created with g_dir_open() in some special cases as
well as don't keep directories open when enumerating their
children (gh#geany/geany-plugins#605).
- Use stock icons instead of the ones provided by the plugin
+ Scope:
- Only allow selection of folders for "working dir"
- Add tooltips to toolbar buttons (gh#geany/geany-plugins#617).
+ XmlSnippets - Activate unit tests for the plugin.
+ Updated translations.
- Adopt the use of %make_build macro rather than raw make command,
following the best practices.
- Pass --docdir=%{_docdir}/%{name} to configure, fixing the
documentation location.
- Reflecting the above change, point fdupes to this new location.
- Add ldconfig post/postun scriptlets now that the package shipps a
shared library.

==== gmp ====
Subpackages: gmp-devel libgmp10 libgmp10-32bit libgmpxx4

- Use %license (boo#1082318)

==== gzip ====

- Use %license (boo#1082318)

==== kdepimlibs4 ====
Subpackages: libakonadi4 libkdepimlibs4

- Add patch to fix build with libical >= 3.0:
* libical-3.patch

==== keyutils ====
Subpackages: keyutils-devel libkeyutils1 libkeyutils1-32bit

- Use %license (boo#1082318)

==== libgudev ====
Subpackages: libgudev-1_0-0 libgudev-1_0-devel typelib-1_0-GUdev-1_0

- Modernize spec-file by calling spec-cleaner

==== libical ====
Version update (2.0.0 -> 3.0.3)

- Update to new upstream release 3.0.3
* Various changes to the API over 2.x.
* Fixed use-after-free issues and some memory leaks
* More accurate VTIMEZONE generation when using the system time
zone data (when USE_BUILTIN_TZDATA=False)
* icalvalue_new/set_date and icalvalue_new/set_datetime now
enforce DATE and DATE-TIME values respectively.
* draft-ietf-calext-extensions (RFC 7986) support added.
* Parameter values are now en/decoded per RFC 6868.
* Added support for VPATCH component.
- Disable building static libs, nothing seems to be using it.
- Remove 0001-build-ICU-must-appear-as-Requires-in-pkgconfig.patch,
libical-boo1015964-use-after-free.patch (all are upstream)

==== libmbim ====
Subpackages: libmbim-glib4 mbimcli-bash-completion

- Modernize spec-file by calling spec-cleaner

==== libndp ====

- Modernize spec-file by calling spec-cleaner

==== libpcap ====

- Fix SRPM group

==== libreoffice ====
Version update ( ->
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-draw
libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3
libreoffice-icon-themes libreoffice-impress libreoffice-kde4
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-hu
libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN
libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreofficekit

- Remove upstreamed patches
* bnc1061210.patch
* bnc954772.patch
- Version update to release:
* second bugfix release closing around 80 TDF issues
- LO-L3: Saving PPTX chart changes $12K to 12,345 format
* bnc1081079.patch
- LO-L3: Cutting object (Rectangle) in Navigator cuts the whole slide instead
* bnc955545.patch
- LO-L3: Wrong transition time
* bnc1039203.patch
- LO-L3: Slide with chart has some strange (too large?) elements (PPTX)
* bnc1060128.patch
- LO-L3: Table(s) from DOCX show wrong position/color/...?
* bnc1061210.patch
- LO-L3: Copy and Paste in Table ignores formatting completely
* bnc954772.patch

==== libstorage-ng ====
Version update (3.3.182 -> 3.3.185)
Subpackages: libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#485
- added unit test
- 3.3.185
- merge gh#openSUSE/libstorage-ng#484
- added unit test
- coding style
- 3.3.184
- merge gh#openSUSE/libstorage-ng#483
- added note
- improved logging
- try to delete directory before creating btrfs subvolume
- handle change of path in mount point
- added integration test
- handle missing attribute for pvs
- do not search for block device of missing pvs
- improved exception handling
- improved example
- fixed log message
- 3.3.183

==== libunistring ====
Subpackages: libunistring2 libunistring2-32bit

- Fix RPM groups and summaries.

==== libustr ====

- Use %license (boo#1082318)

==== libverto ====
Subpackages: libverto-devel libverto1 libverto1-32bit

- Use %license (boo#1082318)

==== libzio ====

- Use %license (boo#1082318)

==== lightdm-gtk-greeter ====
Version update (2.0.3 -> 2.0.4)
Subpackages: lightdm-gtk-greeter-lang

- Update to version 2.0.4:
* New cursor-theme-name and cursor-theme-size configuration keys
* Finish port from gnome-common
* Moved more deprecated function calls to greeterdeprecated.c/.h
* Fixed autologin-session (lp#1707186)
* Fixed accessibility with at-spi-bus on systemd and non-systemd
environments (lp#1366534, lp#1670933)
* Fixed infinite flicker with multiple monitors (lp#1410406,

==== mdadm ====

- mdadm: allow clustered raid10 to be created with default layout

==== orage ====
Subpackages: orage-doc orage-lang

- add 0001-fix-build-with-libical-version-3.patch (bxo#13997)
- should now work with libical > 2
- Explicitly request old libical

==== patterns-fonts ====
Subpackages: patterns-fonts-fonts patterns-fonts-fonts_opt

- drop intlfonts from fonts_opt, it only contains documentation, but
no font data.

==== pcre ====
Subpackages: libpcre1 libpcre1-32bit libpcre16-0 libpcrecpp0 libpcreposix0

- Use %license (boo#1082318)

==== perl-CGI-Application ====
Version update (4.50 -> 4.61)

- updated to 4.61
see /usr/share/doc/packages/perl-CGI-Application/Changes
- Release fix in 4.60_1
- Revert MANIFEST changes which seemed to have caused some issues
- Fix minor POD typo.
- updated to 4.60
see /usr/share/doc/packages/perl-CGI-Application/Changes
- Release, includes all changes from 4.50_50, 4.50_51
4.50_51 (developer release) 2015-07-16
- Create new CGI::PSGI object unconditionally in psgi_app()/Bug #88506
- Introduced Travis CI (Martin McGrath)
4.50_50 (developer release) Fri Jun 23, 2014
- Add PSGI Streaming methods (Mike Tonks)
- Added dependency, it is no longer a core module (Martin McGrath)
- Fixed rt #84403 - Security problem: missing "start" mode dumps ENV to
output page. (Martin McGrath)
- Ensure dump_html() returns valid HTML. (Martin McGrath)
- Changes to repository URL and bug tracker, added Martin McGrath as a
- Typo fixes (David Steinbrunner)

==== perl-DBD-ODBC ====
Version update (1.56 -> 1.57)

- updated to 1.57
see /usr/share/doc/packages/perl-DBD-ODBC/Changes

==== perl-DBD-SQLite ====
Version update (1.54 -> 1.56)

- updated to 1.56
see /usr/share/doc/packages/perl-DBD-SQLite/Changes
1.56 2018-02-28
- Switched to a production version.
1.55_07 2018-01-27
- This is a developer release to help testing DBIx::Class
- Upgraded SQLite to 3.22.0
- Disabled two STAT compile time options (tentatively),
which fixes RT-124227 anyway
1.55_06 2018-01-27
- This is a developer release to help testing DBIx::Class
- Downgraded SQLite to 3.19.3 because of a SQLite regression
(RT-124227, ribasushi++)
- Fixed some tests to adapt to a change in error format
introduced by the latest DBI
- Remove no warnings test from t/43_fts.t which failed under
some environments
1.55_05 2017-12-16
- Implemented ParamValues statement handle attribute (RT-123886)
1.55_04 2017-11-22
- Updated SQLite to 3.21.0
- Resolved #122581: statistics_info() doesn't work correctly
(John Deighan)
- Fixed typo (GH#26, ReneNyffenegger)
- Silenced some warnings (GH#25, Jacques Germishuys)
- Fixed no dot in @INC issue (GH#24, ribasushi)
- Fixed zero-length BLOB value is retrieved as undef
(GH#23, SATO Kentaro)
- Fixed VirtualTable::PerlData to use new ops added in SQLite 3.21.0
(GH#28, fschlich)
- noted on sqlite_extended_result_codes handle attribute
1.55_03 2017-02-14
- Updated SQLite to 3.17.0
1.55_02 2017-01-08
- Updated SQLite to 3.16.2
- Fixed statistics_info when only unique indexes were requested (Dave
Rolsky++). GitHub #21
1.55_01 2017-01-04
- Updated SQLite to 3.16.0

==== polkit ====
Subpackages: libpolkit0 polkit-devel typelib-1_0-Polkit-1_0

- Modernize spec-file by calling spec-cleaner

==== popt ====
Subpackages: libpopt0 libpopt0-32bit popt-devel

- Use %license (boo#1082318)

==== rpm ====
Subpackages: rpm-build rpm-devel

- remove no longer needed and now harmful extcond patch
dropped patch: extcond.diff

==== sed ====
Subpackages: sed-lang

- Use %license (boo#1082318)

==== slang ====
Subpackages: libslang2 slang-slsh

- BuildRequire default libpng on the system, builds and test
pass fine. (drops slang-libpng12-linker-flag.patch)

==== spec-cleaner ====
Version update (1.0.4 -> 1.0.6)

- Version update to 1.0.6 release:
* Fixes license conversions to spdx3.0
* Allows better parsing of pattern packages
* Various manpage suffixing fixes
* Added more things to exclude bracketing

==== texinfo ====
Subpackages: info makeinfo

- Use %license (boo#1082318)

==== tslib ====
Version update (1.13 -> 1.15)

- Update tslib.keyring with latest key
- Update to version 1.15:
* This release includes libts version 0.9.0 and the following changes:
- New ts_get_eventpath() API to learn the opened device file path
- ts_test_mt shows the number of supported concurrent touch contacts
- New filter module "invert"
- ts_uinput: fallback to fb0 and new option --nofb
* Bugfixes
- Changes for version 1.14:
* This release includes libts version 0.8.1 and the following changes:
- The following modules are now disabled in the default configuration run:
`module_raw arctic2`
`module_raw corgi`
`module_raw collie`
`module_raw dmc`
`module_raw h3600`
`module_raw mk712`
`module_raw ucb1x00`
Users of those modules must enable them, like `./configure --enable-arctic2`
- Automatic touchscreen device detection for Linux (if not defined by the
- New filter plugin "lowpass"
- SPDX license identifiers in all C source files
* Bugfixes

==== vim ====
Version update (8.0.1525 -> 8.0.1568)
Subpackages: gvim vim-data vim-data-common

- Updated to revision 1568, fixes the following problems
* No test using a screen dump yet.
* Screen dump test fails on MS-Windows.
* Dead code found.
* Assert_equalfile() does not close file descriptors. (Coverity)
* Dump test fails when using a shadow directory.
* Cannot use 24 bit colors in MS-Windows console.
* Compiler warnings without termguicolors feature.
* Libterm doesn't support requesting fg and bg color.
* C syntax test fails when using gvim
* C syntax test still fails when using gvim.
* Quotestar test is flaky when using the GUI.
* Xxd does not skip NUL lines when using ebcdic.
* Popupmenu is too far left when completion is long. (Linwei)
* No test for the popup menu positioning.
* Popup menu positioning fails with longer string.
* synpat_T is taking too much memory.
* Terminal screen dump does not include cursor position.
* With 'termguicolors' Normal color doesn't work correctly.
* When using 'termguicolors' SpellBad doesn't show.
* Screen dumps not included in distribution.
* Using feedkeys() in a terminal window may trigger mappings.
(Charles Sheridan)
* Undo in the options window makes it empty.
* Screen dump test script not included in distribution.
* Various small problems in test files.
* Various small problems in source files.
* On Mac 'maxmemtot' is set to a weird value.
* May leak file descriptors when executing job.
* Cannot see what digraph is used to insert a character.
* Custom plugins loaded with --clean.
* Build error for some combination of features.
* May not parse the t_RS response correctly, resulting in wrong characters
in the input stream.
* printf() does not work with only one argument. (Daniel Hahler)
* No right-click menu in a terminal.
* Build failure without GUI.
* Build failure without GUI on MS-Windows.
* Crash with rust syntax highligting. (Edd Barrett)
* The terminal debugger can't set a breakpoint with the mouse.
* Timeout of getwinposx() can be too short. (lilydjwg)
* Too many #ifdefs.
* Can't build Mac version without GUI.
* Too many #ifdefs.
* Cannot build Win32 GUI without IME. (John Marriott)
* Can't build on older Mac, header file is missing.
- Recommend vim-data so that colors can work by default

==== xfce4-notifyd ====
Version update (0.4.1 -> 0.4.2)
Subpackages: xfce4-notifyd-lang

- update to version 0.4.2 (01 March 2018):
This is a bugfix release.
Bugs fixed:
* Fix support for hyperlinks in notifications (bxo#14073)
* Fix crash because of double-free (bxo#14060)
* Improve wrapping and ellipsizing of notification bubble
* Ensure goes into the tarball
* Suppress warnings about unused and uninitialized variables
* Fix crash when there are no known apps
* panel-plugin: Fix showing placeholder when there are no logs
from today
* Updated translations

==== xfce4-settings ====
Version update (4.12.1 -> 4.12.2)
Subpackages: xfce4-settings-lang

- update to version 4.12.2:
- Fix: Leave monitors where they were if possible (bxo#14096)
- Fix: syncdaemon not starting with certain locales
- Fix: division by 0 crash from gdk_screen_height_mm()
- New: Default monospace font option in the Appearance dialog
- New: Improved support for embedded DisplayPort connectors
- New: Show location of the mouse pointer on keypress
- Translation updates

==== xfce4-terminal ====
Version update (0.8.6 -> 0.8.7)
Subpackages: xfce4-terminal-lang

- update to version 0.8.7:
* Update man page: add a note about config file changes being
picked up
* Update 'Read-Only' checkbox state when switching between tabs
* Use Ctrl+click to directly open color editor in Preferences (bxo#13715)
* Add a setting to control drop-down window vertical position (bxo#13722)
* Allow per-terminal configuration of 'scroll on output' mode
* Add "Copy as HTML" to Edit and context menus (VTE 0.50 required)
* Add support for utmp file updates (build using --with-utempter
parameter) (bxo#13710)
* Fix negative geometry offsets handling (bxo#13753)
* Focus the terminal after closing Set Title popover (bxo#13754)
* Request confirmation when closing window or tab which has a
running process (bxo#13781)
* Add an option to open new tab to the right of the current tab (bxo#13821)
* Fix VTE critical message when a terminal has no pty
* Allow to restart a process after it exited or was killed
(for -H/--hold) (bxo#13820)
* Expose default terminal directory setting to Preferences: if
set, will be used by new terminals; current directory will be
used otherwise. MiscDefaultWorkingDir renamed to DefaultWorkingDir.
* Make use of VTE 0.52 new vte_terminal_get_scroll_on_output() API
* Add new tab to the currently active window, not to the last open (bxo#13891)
* Move slim tabs setting to the Appearance tab
* Add Audible and Visual bells configuration to Preferences (bxo#13874)
* Disable move tab actions when MiscCycleTabs is false and the tab
is in the leftmost or rightmost position (bxo#13892)
* Try to retrieve current working directory from VTE (bxo#13902)
* Fix BSD build by adding missing include
* Bump required GTK+ version to 3.20.8 to resolve the problem with
Set Title dialog that is using GtkPopover (bxo#13996)
* Do not escape URL as libxfce4ui now does it (bxo#12715)
* Expose "middle mouse click to open URLs" setting to Preferences
* Fix handling empty $DISPLAY env var which may happen under
Wayland (bxo#14092)
* Update regex definitions from gnome-terminal: Disallow terminating
semicolon in URLs, Allow balanced pairs of square brackets in URLs
* Remove man page translation files as Transifex doesn't take care
of them (bxo#12938)
* Add option to control text blinking (VTE 0.51.3) (bxo#14127)
* Add "Bold is bright" option; remove "Allow bold text" option
(VTE 0.51.3)
* Add cell spacing options (VTE 0.51.3) (bxo#14127)
* Allow underscores that are part of tab titles to be shown in the
tabs menu
* Don't copy working directory to $PWD for vte >= 0.51.90
* Resolve deprecations of GDK functions
* Translation updates
- remove obsoleted 0001-Revert-Fix-handling-email-addresses.patch

==== yast2-packager ====
Version update (4.0.45 -> 4.0.46)

- Confirm base license: parameter for disabling back button.
Needed for showing base product license while AutoYaST
installation (bnc#1073324).
- 4.0.46

To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages