Mailinglist Archive: opensuse-factory (742 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180305 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180305

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
PackageKit
apparmor
gdm
glade (3.20.2 -> 3.20.3)
gtk2
hylafax+
ibus-libpinyin (1.9.1 -> 1.9.3)
libnotify (0.7.7 -> 0.7.7+20170717.43aac61)
libpinyin (2.1.0 -> 2.1.91)
mozjs52
pcsc-lite
python-cffi (1.11.4 -> 1.11.5)
python-requests
telepathy-glib
xfce4-panel-plugin-pulseaudio (0.3.4 -> 0.3.5)

=== Details ===

==== PackageKit ====
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module PackageKit-lang libpackagekit-glib2-18
typelib-1_0-PackageKitGlib-1_0

- Modernize spec-file by calling spec-cleaner

==== apparmor ====
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser
apparmor-parser-lang apparmor-profiles apparmor-utils apparmor-utils-lang
pam_apparmor pam_apparmor-32bit perl-apparmor python3-apparmor

- Change of path of rpm in lessopen.sh (boo#1082956)
- add disable-cache-on-ro-fs.diff - disable write cache if filesystem is
read-only and don't bail out (bsc#1069906, bsc#1074429)
- add parser-write-cache-warn-only.diff to make cache write failures a
warning instead of an error (boo#1069906, boo#1074429)
- reduce dependeny on libnotify-tools (used by aa-notify -p) to "Suggests"
to avoid pulling in several Gnome packages on servers (boo#1067477)

==== gdm ====
Subpackages: gdm-lang gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Add gdm-Revert-session-don-t-call-gdm_session_defaults_chang.patch:
fix showing right active session of user in login dialog
(bsc#1082958 bgo#793609).
- Remove gdm-default-wm-sle12.patch: default session in SLE15
becomes 'GNOME', don't need this patch anymore.

==== glade ====
Version update (3.20.2 -> 3.20.3)
Subpackages: glade-lang libgladeui-2-6

- Update to version 3.20.3.
+ Fix bgo#793036: "GtkCellRenderer Properties not loaded from
glade file".
+ Add GtkStackSidebar to the toolbox.
+ Fix bgo#774994: "In treeview columns editor contextual menu
does nothing".
+ GladeDesignView: set selected layout state.

==== gtk2 ====
Subpackages: gtk2-data gtk2-devel gtk2-immodule-amharic gtk2-immodule-inuktitut
gtk2-immodule-thai gtk2-immodule-vietnamese gtk2-immodule-xim gtk2-lang
gtk2-tools gtk2-tools-32bit libgtk-2_0-0 libgtk-2_0-0-32bit typelib-1_0-Gtk-2_0

- Use SPDX3.0 license tags and package COPYING as %license

==== hylafax+ ====
Subpackages: hylafax+-client libfaxutil5_5_9

- Remove uucp user creation for pre-1500: aaa_base provides
this user/group already.

==== ibus-libpinyin ====
Version update (1.9.1 -> 1.9.3)

- Update version to 1.9.3
* Translate input method name in ibus menu
* Remove phrases.txt
- Update to 1.9.2
* fixes pinyin and bopomofo config

==== libnotify ====
Version update (0.7.7 -> 0.7.7+20170717.43aac61)
Subpackages: libnotify-tools libnotify4 typelib-1_0-Notify-0_7

- Update to version 0.7.7+20170717.43aac61:
+ Conditionall call g_type_init() after a version check.
+ build: Update the list of headers in srcdir.
+ notify-send: Call setlocale in main function.
- Switch to git-checkout via source service, following this, add
gtk-doc and gnome-common BuildRequires ans pass autogen.sh to
bootstrap tarball and pass --enable-gtk-doc to configure.
- Clean up spec, use autosetup and make_build macros.
- Add libnotify-rpmlintrc, silence rpmlint warning about
shlib-policy-missing-lib.
- Rectify RPM groups
- Spec cleanup.

==== libpinyin ====
Version update (2.1.0 -> 2.1.91)
Subpackages: libpinyin-data libpinyin13 libzhuyin13

- Update version to 2.1.91
* Fix zhuyin parsers
* Use model15.

==== mozjs52 ====

- Actually remove bundled zlib and use system zlib. Avoids potential
problems when trying to use system zlib while mozjs52-devel is
installed (two zlib.h instances with conflicting definitions).
Likewise fix for boo#1082720.
- Drop unused zip BuildRequires.

==== pcsc-lite ====
Subpackages: libpcsclite1

- Use python3 (bsc#1082129, pcsc-lite-python3.patch).

==== python-cffi ====
Version update (1.11.4 -> 1.11.5)
Subpackages: python2-cffi python3-cffi

- update to version 1.11.5:
* Issue #357: fix ffi.emit_python_code() which generated a buggy
Python file if you are using a struct with an anonymous union
field or vice-versa.
* Windows: ffi.dlopen() should now handle unicode filenames.
* ABI mode: implemented ffi.dlclose() for the in-line case (it used
to be present only in the out-of-line case).
* Fixed a corner case for setup.py install --record=xx --root=yy
with an out-of-line ABI module. Also fixed Issue #345.
* More hacks on Windows for running CFFI?s own setup.py.
* Issue #358: in embedding, to protect against (the rare case of)
Python initialization from several threads in parallel, we have to
use a spin-lock. On CPython 3 it is worse because it might
spin-lock for a long time (execution of Py_InitializeEx()). Sadly,
recent changes to CPython make that solution needed on CPython 2
too.
* CPython 3 on Windows: we no longer compile with Py_LIMITED_API by
default because such modules cannot be used with virtualenv. Issue
[#350] mentions a workaround if you still want that and are not
concerned about virtualenv: pass a
define_macros=[("Py_LIMITED_API", None)] to the
ffibuilder.set_source() call.

==== python-requests ====

- Recommends only for SUSE
- In no SUSE evironments some tests related with certificates can
fail. Skip the tests if this case.

==== telepathy-glib ====
Subpackages: libtelepathy-glib0 typelib-1_0-TelepathyGlib-0_12

- Use SPDX3.0 license tags and package COPYING as %license.

==== xfce4-panel-plugin-pulseaudio ====
Version update (0.3.4 -> 0.3.5)
Subpackages: xfce4-panel-plugin-pulseaudio-lang

- update to version 0.3.5:
* New Feature: Move streams on default output device change (bxo#14157)
- Prior to this update, when a new output device was selected, any
existing streams had to be moved using pavucontrol. This change
automatically moves any active output streams to the newly
selected device.
* New Feature: Management of known MPRIS2 players (bxo#13903)
- Known players can now be cleared or selectively hidden from the menu.
* Bug Fixes:
- Wait for the pulseaudio volume sink to be connected to get the
current volume state at startup (bxo#14071, bxo#13677)
- MPRIS2: stale data retained after Metadata signal (bxo#14068)
* Translation Updates


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages