Mailinglist Archive: opensuse-factory (1193 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180225 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180225

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
ImageMagick (7.0.7.22 -> 7.0.7.23)
Mesa
Mesa-drivers
PackageKit (1.1.7 -> 1.1.8)
bijiben
curl
dracut
ffmpeg
fftw3
fluidsynth
gfxboot (4.5.29 -> 4.5.33)
gnome-themes-standard
gobject-introspection
graphene (1.6.0 -> 1.6.2)
gtk3 (3.22.26 -> 3.22.28)
issue-generator
kalzium
kdump
kexec-tools
ksshaskpass5 (5.12.1 -> 5.12.2)
libao (1.2.0 -> 1.2.2+git20180114.d522165)
libinput (1.9.4 -> 1.10.0)
libvirt
mariadb (10.2.12 -> 10.2.13)
multipath-tools (0.7.3+38+suse.a16beed5280a -> 0.7.3+52+suse.08a969b7fce0)
os-prober
pam-config (0.94 -> 0.95)
parted
polkit-kde-agent-5 (5.12.1 -> 5.12.2)
protobuf
publicsuffix (20180125 -> 20180218)
python-M2Crypto (0.28.2 -> 0.29.0)
python-base
python-cffi (1.11.2 -> 1.11.4)
python3
python3-base
samba
system-config-printer
tiff
vim (8.0.1442 -> 8.0.1525)
xorg-x11-server
xournal
yp-tools

=== Details ===

==== ImageMagick ====
Version update (7.0.7.22 -> 7.0.7.23)
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-7_Q16HDRI4
libMagickCore-7_Q16HDRI5 libMagickWand-7_Q16HDRI5 perl-PerlMagick

- upstream fixes the test by changing the signature
- ImageMagick-820e636.patch
+ ImageMagick-write.t-PICT-signature.patch
- update to 7.0.7.23
* Fixed numerous use of uninitialized values, integer overflow,
memory exceeded, and timeouts (credit to OSS Fuzz).
* Add list-length policy to limit the maximum image sequence length.
- added patches
+ ImageMagick-montage.t-directory-exception.patch
+ ImageMagick-820e636.patch
- Add explicit buildrequires on: pkgconfig(libwebpmux),
pkgconfig(cairo), pkgconfig(fontconfig), pkgconfig(libpng),
pkgconfig(x11), pkgconfig(xext), pkgconfig(zlib). all
of them direct build dependencies but not included in
the spec file

==== Mesa ====
Subpackages: Mesa-dri-devel Mesa-libEGL-devel Mesa-libEGL1 Mesa-libGL-devel
Mesa-libGL1 Mesa-libglapi0 libgbm1 libwayland-egl1

- removed no longer needed ncurses-devel BuildRequires (boo#1082315)
- redone u_add_llvm_codegen_dependencies.patch and renamed to
u_configure.ac-Link-to-libLLVMCodegen-to-fix-cyclic-li.patch
(boo#1082307)
- removed u_mesa-8.0.1-fix-16bpp.patch and
u_mesa-8.0-llvmpipe-shmget.patch, which we no longer apply since
about 5 years (boo#1082305)
- recreated u_mesa-python3-only.patch and renamed to
u_r600-egd_tables.py-added-support-for-python-3.patch; also
removed first hunk (boo#1082303)
- removed n_Define-GLAPIVAR-separate-from-GLAPI.patch
* bits moved to libGLw's n_Use-newly-introduced-GLAPIVAR-for-variables.patch
(boo#1082297)
- Mesa-gallium only exists if %{with_opencl}
- Add support for riscv64

==== Mesa-drivers ====
Subpackages: Mesa-dri Mesa-gallium Mesa-libva libvdpau_r300 libvdpau_r600
libvdpau_radeonsi libvulkan_radeon libxatracker2

- removed no longer needed ncurses-devel BuildRequires (boo#1082315)
- redone u_add_llvm_codegen_dependencies.patch and renamed to
u_configure.ac-Link-to-libLLVMCodegen-to-fix-cyclic-li.patch
(boo#1082307)
- removed u_mesa-8.0.1-fix-16bpp.patch and
u_mesa-8.0-llvmpipe-shmget.patch, which we no longer apply since
about 5 years (boo#1082305)
- recreated u_mesa-python3-only.patch and renamed to
u_r600-egd_tables.py-added-support-for-python-3.patch; also
removed first hunk (boo#1082303)
- removed n_Define-GLAPIVAR-separate-from-GLAPI.patch
* bits moved to libGLw's n_Use-newly-introduced-GLAPIVAR-for-variables.patch
(boo#1082297)
- Mesa-gallium only exists if %{with_opencl}
- Add support for riscv64

==== PackageKit ====
Version update (1.1.7 -> 1.1.8)
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module PackageKit-lang libpackagekit-glib2-18
typelib-1_0-PackageKitGlib-1_0

- Update to version 1.1.8:
+ Notes: The Slackware backend was renamed from "katja" to
"slack".
+ Libraries:
- Add getters for PkEulaRequired.
- Add new pk_results_set_role() API.
+ New Features: Save transaction role to the offline update
results file.
+ Bugfixes:
- Various fixes to docs.
- Bring introspection and vapigen m4 macros into the source.
- command-not-found: Be more explicit when ignoring path
components.
- service: Use ConditionPathExists=!/run/ostree-booted.
+ Backends:
- zypp: Return error if invalid package IDs are detected.
- Various changes related to aptcc and slack.
- Drop PK-zypp-return-error-invalid-package-ids.patch: fixed
upstream.
- Drop autoconf-archive and automake BuildRequires and no longer
call autoreconf: no patch changes the build system.
- Replace --enable/disable-systemd-updates configure parameter with
- -enable/disable-offline-update: the relevant systemd-updates
parameters have not been valid since PackageKit 1.0.0.
- Drop --with-default-backend=zypp configure parameter: this has
not been udnerstood since PackageKit 1.0. PK just used the one
and only backend installed in the distro.

==== bijiben ====
Subpackages: bijiben-lang gnome-shell-search-provider-bijiben

- Pass --disable-Werror to configure: this is released code and we
don't have to fail when any dependency deprecates, but still
supports, some functions.

==== curl ====
Subpackages: libcurl-devel libcurl4

- Sort a bit with spec-cleaner
- Install license with the library

==== dracut ====

- 40network: disable arping, it is no longer part of default installation
(bsc#1078245)
* Adds 0557-40network-make-arping-optional.patch
- 40network: replace brctl, it is longer part of default installation
(bsc#1078245)
* Adds 0558-40network-remove-brctl-dependency.patch

==== ffmpeg ====
Subpackages: libavcodec-devel libavcodec57 libavdevice57 libavfilter6
libavformat57 libavresample-devel libavresample3 libavutil-devel libavutil55
libpostproc54 libswresample-devel libswresample2 libswscale-devel libswscale4

- Enable mpeg1video and mpeg2video in enable_decoders, and remove
it from disable-decoders call given to configure, mpeg2 now
available in openSUSE.
- enable video stabilization/deshaking via libvidstab (optional)

==== fftw3 ====
Subpackages: fftw3-devel libfftw3-3 libfftw3_threads3

- Switch to openmpi2 instead of openmpi (bsc#1082302),
apart from ppc64 as openmpi2 does not support it.

==== fluidsynth ====

- Switch to cmake macros
- Use %license to install license
- Disable optional lash support as we try to remove lash
- Format with spec-cleaner

==== gfxboot ====
Version update (4.5.29 -> 4.5.33)

- Translated using Weblate (Dutch)
- 4.5.33
- Translated using Weblate (Ukrainian)
- 4.5.32
- Translated using Weblate (Finnish)
- 4.5.31
- Translated using Weblate (Finnish)
- 4.5.30

==== gnome-themes-standard ====
Subpackages: gnome-themes-accessibility gnome-themes-accessibility-gtk2
gtk2-metatheme-adwaita gtk2-theming-engine-adwaita gtk3-metatheme-adwaita
metatheme-adwaita-common

- Ensure gtk2-32bit engine has the proper supplements to be
automatically selected.

==== gobject-introspection ====
Subpackages: girepository-1_0 libgirepository-1_0-1

- go-find-deps.sh: add riscv64 to x64bitarch.

==== graphene ====
Version update (1.6.0 -> 1.6.2)

- Update to version 1.6.2:
+ Mostly fixes for the Meson build, to ensure it's a bit more
idiomatic and conforms to what newer versions of Meson expect
from a project.
- Do a minor spec clean, use autosetup and license macros.
- Stop exporting LANG=C.UTF-8, fixed upstream.
- Stop exporting i586 conditional SUSE_ASNEEDED=0, fixed upstream.
- Pass explict enable-gtk-doc=true, enable-gobject-types=true,
enable-introspection=true, enable-gcc-vector=true,
enable-sse2=true and enable-arm-neon=true to meson, ensure we
build the features we want.
- Following the above, add gtk-doc BuildRequires and package the
now built documentation in devel subpackage.
- Stop using sed to ensure we are using python3, fixed upstream.
- Add fdupes BuildRequires and macro, remove duplicate files.

==== gtk3 ====
Version update (3.22.26 -> 3.22.28)
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut
gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-immodule-xim gtk3-lang
gtk3-tools libgtk-3-0 typelib-1_0-Gtk-3_0

- Update to version 3.22.28:
+ Improve frame clock accuracy (bgo#787665).
+ Bugs fixed: bgo#793442.
- Update to version 3.22.27:
+ Require libcloudproviders 0.2.5.
+ The Emoji chooser can now be used with GtkTextView as well.
+ The Emoji chooser avoids fallback sequences that break the
grid.
+ GTK+ is now using ~/.config/gtk-3.0/settings.ini when using
Wayland without dconf.
+ Make fuse-mounted network filesystems show up in Other
Locations.
+ The font chooser dialog supports search now.
+ Bugs fixed: bgo#737175, bgo#741633, bgo#771986, bgo#774248,
bgo#779009, bgo#786123, bgo#786509, bgo#786528, bgo#787089,
bgo#787128, bgo#789054, bgo#789160, bgo#789268, bgo#790029,
bgo#790031, bgo#790033, bgo#790201, bgo#790270, bgo#790862,
bgo#790963, bgo#791039, bgo#791062, bgo#791234, bgo#791281,
bgo#791363, bgo#791549, bgo#791650, bgo#791710, bgo#791943,
bgo#792279, bgo#792459, bgo#792624.
+ Updated translations.
- Drop
gtk3-placesview-Present-FUSE-reachable-network-shares-in-.patch:
fixed upstream.

==== issue-generator ====

- Use %license instead of %doc [bsc#1082318]

==== kalzium ====
Subpackages: kalzium-lang

- BuildRequire ocaml(Facile) (instead of ocaml-facile) to fix
building the equation solver on Leap 42.3 and higher, where the
ocaml-facile devel files have been split out into an extra
ocaml-facile-devel package

==== kdump ====

- kdump-always-kexec_load-if-kexec_file_load-fails.patch: Try
kexec_load(2) if kexec_file_load(2) fails for any reason
(bsc#1080916).
- kdump-calibrate-do-not-add-KDUMP_PHYS_LOAD-to-RAM.patch:
calibrate: Do not add KDUMP_PHYS_LOAD to required RAM.
- kdump-bootloader-filter-out-KDUMPTOOL_FLAGS.patch: bootloader:
Filter out KDUMPTOOL_FLAGS (bsc#1072584).

==== kexec-tools ====

- kexec-tools-ppc64-parse-ibm-dynamic-memory.patch: kexec/ppc64:
add support to parse ibm, dynamic-memory-v2 property
(bsc#1081789, LTC#164625).
- kexec-tools-add-a-helper-function-to-add-ranges.patch: kexec: add
a helper function to add ranges (bsc#1081789, LTC#164625).

==== ksshaskpass5 ====
Version update (5.12.1 -> 5.12.2)
Subpackages: ksshaskpass5-lang

- Update to 5.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.2.php
- Changes since 5.12.1:
* None

==== libao ====
Version update (1.2.0 -> 1.2.2+git20180114.d522165)
Subpackages: libao-devel libao-plugins4 libao4

- Add baselibs.conf to sources
- Switch to _service as there are no real upstream releases for
long time
- Update to version 1.2.2+git20180114.d522165:
* Check memory allocations for success
* Enable pulse build in travis
* pulse: fix missing include warning for nanosleep
* travis: Test on both linux and osx.
* Bump version and release date on docs
* Add an update-doc-version target
* Revert "Insure that the alsa plugin links against libao, since the plugin
calls ao_is_big_endian from libao."
* Drop the old debian/ directory
* Replace autogen.sh with a simple wrapper about autoreconf.
* Enable AM_SILENT_RULES when it's available.

==== libinput ====
Version update (1.9.4 -> 1.10.0)
Subpackages: libinput-udev libinput10

- Update to new upstream release 1.10.0
* Dropping of the touchpad hysteresis. Previously, we employed
a hysteresis to avoid pointer wobbles. A side-effect of that
hysteresis was that small pointer motion wasn't as reactive
as it should be. A previous attempt in 2016 to drop it failed
(too many devices still needed it) so this time round we have
a different approach: we analyse the event sequence from the
touchpad and if we find it doesn't wobble, we disable the
hysteresis for good. In most cases, this happens fast enough
that you won't even notice, resulting in a more reactive
pointer.
* Touchpad tapping now handles palm detection where applicable,
resting a palm on a touchpad while tapping should not confuse
libinput anymore. Previously, palm touches were treated like
any other touch, causing unexpected 2 and 3-finger clicks.
* Some of the newer Wacom tablets (and older, worn-out ones)
can have a leftover pressure on tip up. This caused libinput
to miss out on the proximity event, leading to a constantly
in-proximity tool. A new threshold for proximity out fixes
this.
- Remove 0001-evdev-add-a-quirk-to-disable-debouncing-on-the-MS-Na.patch
(included upstream)
- Add 0001-evdev-add-a-quirk-to-disable-debouncing-on-the-MS-Na.patch

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-logical
libvirt-daemon-driver-storage-mpath libvirt-daemon-driver-storage-rbd
libvirt-daemon-driver-storage-scsi libvirt-daemon-driver-uml
libvirt-daemon-driver-vbox libvirt-daemon-lxc libvirt-daemon-qemu
libvirt-daemon-xen libvirt-libs

- libxl: round memory values to next 1MiB increment
ef71caea-libxl-memalign.patch
bsc#1082041

==== mariadb ====
Version update (10.2.12 -> 10.2.13)
Subpackages: libmysqld19 mariadb-client mariadb-errormessages

- update to 10.2.13 GA
* notable changes
* InnoDB updated to 5.7.21
* Galera wsrep library updated to 25.3.23
* MDEV-13869 - MariaDB slow start
* MDEV-14611 - ALTER TABLE EXCHANGE PARTITION does not work
properly when used with DATA DIRECTORY
* MDEV-15249 - Crash in MVCC read after IMPORT TABLESPACE
* Foreign key bugs:
* MDEV-15199 - Referential integrity broken in ON DELETE
CASCADE/MDEV-14222 Unnecessary 'cascade' memory allocation
for every updated row
* MDEV-15219 - FOREIGN KEY CASCADE or SET NULL operations will
not resume after lock wait
* MDEV-15042 - INSERT ON DUPLICATE KEY UPDATE produces error
1032 (Can't find record)
* MDEV-13205 - InnoDB: Failing assertion:
!dict_index_is_online_ddl(index) upon ALTER TABLE
* MDEV-14958 - Merge new release of InnoDB MySQL 5.7.21 to 10.2
* MDEV-15165 - InnoDB purge for index on virtual column is
trying to access an incomplete record
* MDEV-15143 - InnoDB: Rollback of trx with id 0 completed
* MDEV-11415 - Remove excessive undo logging during ALTER
TABLE?ALGORITHM=COPY
* MDEV-15016 - multiple page cleaner threads use a lot of CPU
* MDEV-14941 - Timeouts on persistent statistics tables caused
by MDEV-14511
* MDEV-14985 - innodb_undo_log_truncate may be blocked if
transactions were recovered at startup
* MDEV-14441 - InnoDB hangs when setting
innodb_adaptive_hash_index=OFF during UPDATE
* MDEV-14887 - On a 32-bit system, MariaDB 10.2 mishandles
data file sizes exceeding 4GiB
* fixes for the following security vulnerabilities:
* CVE-2018-2562, CVE-2018-2622, CVE-2018-2640, CVE-2018-2665,
CVE-2018-2668, CVE-2018-2612
* release notes and changelog:
https://mariadb.com/kb/en/library/mariadb-10213-release-notes/
https://mariadb.com/kb/en/library/mariadb-10213-changelog/
* fixes [bsc#1058729] and [bsc#1068906]
- refresh mariadb-10.2.10-disable_openssl_compatibility_check.patch
- refresh mariadb-10.2.3-group.patch

==== multipath-tools ====
Version update (0.7.3+38+suse.a16beed5280a -> 0.7.3+52+suse.08a969b7fce0)
Subpackages: kpartx multipath-tools-rbd

- Update to version 0.7.3+52+suse.08a969b7fce0:
- Add limited support for displaying native NVMe multipath
(bsc#1082419)
* libmultipath: foreign/nvme: implement path display
* multipathd: use foreign API
* multipath: use foreign API
* libmultipath/foreign: nvme foreign library
* libmultipath/print: add "%G - foreign" wildcard
* libmultipath: API for foreign multipath handling
* libmultipath: print: use generic API for get_x_layout()
* libmultipath: print: convert API to generic data type
* libmultipath: "generic multipath" interface
* libmultipath: add vector_convert()
* libmultipath: add vector_free_const()
* libmultipath: get rid of selector "hack" in print.c
- Fix locking errors detected by coverity check (bsc#1082418)
* checkers/rbd: missing pthread_lock() on failure path
* libmultipath: fix deadlock in tur.c

==== os-prober ====

- revert os-prober-05efi-udevinfo.patch as it messed up with strings
that could be named differently in which even with non ascil characters.

==== pam-config ====
Version update (0.94 -> 0.95)

- Use %license instead of %doc [bsc#1082318]
- Update to version 0.95:
- fix migration from pam_unix2/pam_pwcheck to pam_unix/pam_cracklib

==== parted ====
Subpackages: libparted0 parted-lang

- libparted: Canonicalize /dev/md/ paths (bsc#1078820)
- add: libparted-canonicalize-dev-md-paths.patch
- add: tests-add-helper-require_swap_.patch
- add: tests-add-dev-md-check-to-t6100.patch
- libparted: Fix partition device naming for all devices
(bsc#1078820, bsc#1081547)
- The "_part%d" suffix which has been used for SLE10 compatibility
is wrong now as the kernel does not use that any more and
uses "p%d" instead.
- amend: libparted-partition-naming.patch
- refresh: libparted-fix-nvme-partition-naming.patch
- refresh: libparted-fix-NVDIMM-partition-naming.patch

==== polkit-kde-agent-5 ====
Version update (5.12.1 -> 5.12.2)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.12.2
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.12.2.php
- Changes since 5.12.1:
* None

==== protobuf ====

- Add adding-Release_CompareAndSwap-64-bit-variant.patch
* Fix compile error undefined reference to
`google::protobuf::internal::Release_CompareAndSwap(long volatile*, long,
long)'
on s390x https://github.com/google/protobuf/issues/3937

==== publicsuffix ====
Version update (20180125 -> 20180218)

- update to 20180218:
* Add YesCourse private entry for official.academy
* Add schokokeks.net
* Add 2038.io
* Adding cloud66.ws customer domain for Cloud66
* Add linkyard.cloud

==== python-M2Crypto ====
Version update (0.28.2 -> 0.29.0)

- Update to 0.29.0 (Fixes of some small bugs)
- Require python-xml that is used by some parts of M2crypto

==== python-base ====
Subpackages: libpython2_7-1_0 libpython2_7-1_0-32bit python-devel python-xml

- Add python-sorted_tar.patch (boo#1081750)

==== python-cffi ====
Version update (1.11.2 -> 1.11.4)
Subpackages: python2-cffi python3-cffi

- specfile:
* delete patch cffi-loader.patch; included upstream
- update to version 1.11.4:
* Windows: reverted linking with python3.dll, because virtualenv
does not make this DLL available to virtual environments for
now. See Issue #355. On Windows only, the C extension modules
created by cffi follow for now the standard naming scheme
foo.cp36-win32.pyd, to make it clear that they are regular CPython
modules depending on python36.dll.
- changes from version 1.11.3:
* Fix on CPython 3.x: reading the attributes __loader__ or __spec__
from the cffi-generated lib modules gave a buggy
SystemError. (These attributes are always None, and provided only
to help compatibility with tools that expect them in all modules.)
* More Windows fixes: workaround for MSVC not supporting large
literal strings in C code (from
ffi.embedding_init_code(large_string)); and an issue with
Py_LIMITED_API linking with python35.dll/python36.dll instead of
python3.dll.
* Small documentation improvements.

==== python3 ====
Subpackages: python3-curses python3-dbm python3-tk

- Drop python3-tk and python3-idle recommends to reduce python3
always pulling X stack bsc#1081751

==== python3-base ====
Subpackages: libpython3_6m1_0

- ctypes-pass-by-value.patch: Fix pass by value for structs on aarch64
- Add python3-sorted_tar.patch (boo#1081750)

==== samba ====
Subpackages: libdcerpc-binding0 libdcerpc-binding0-32bit libdcerpc0
libdcerpc0-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0
libndr-nbt0-32bit libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit
libnetapi0 libnetapi0-32bit libsamba-credentials0 libsamba-credentials0-32bit
libsamba-errors0 libsamba-errors0-32bit libsamba-hostconfig0
libsamba-hostconfig0-32bit libsamba-passdb0 libsamba-passdb0-32bit
libsamba-policy0 libsamba-util0 libsamba-util0-32bit libsamdb0 libsamdb0-32bit
libsmbclient-devel libsmbclient0 libsmbconf0 libsmbconf0-32bit libsmbldap2
libsmbldap2-32bit libtevent-util0 libtevent-util0-32bit libwbclient0
libwbclient0-32bit samba-client samba-client-32bit samba-doc samba-dsdb-modules
samba-kdc samba-kdc-32bit samba-libs samba-libs-32bit samba-python
samba-winbind samba-winbind-32bit

- samba fails to build with glibc2.27; (bsc#1081042);

==== system-config-printer ====
Subpackages: python3-cupshelpers system-config-printer-applet
system-config-printer-common system-config-printer-common-lang
system-config-printer-dbus-service udev-configure-printer

- Do not recommend dbus(com.redhat.NewPrinterNotification) as this
would pull in desktop applets also on a server installation
(boo#1081691)

==== tiff ====
Subpackages: libtiff-devel libtiff5 libtiff5-32bit

- bsc#1081690: Add tiff-4.0.9-bsc1081690-CVE-2018-5784.patch
Fix uncontrolled resource consumption in TIFFSetDirectory

==== vim ====
Version update (8.0.1442 -> 8.0.1525)
Subpackages: gvim vim-data vim-data-common

- Updated to revision 1525, fixes the following problems
* Compiler complains about uninitialized variable. (Tony Mechelynck)
* Missing -D_FILE_OFFSET_BITS=64 may cause problems if a library is compiled
with it.
* Cannot act on edits in the command line.
* Acessing freed memory after window command in auto command. (gy741)
* Still too many old style tests.
* Segmentation fault when Ruby throws an exception inside :rubyfile command.
* Slow redrawing with DirectX.
* Endless loop when gui_mch_stop_blink() is called while blink_state is
BLINK_OFF. (zdohnal)
* It is difficult to set the python home directory properly for Python
2.7 and 3.5 since both use $PYTHONHOME.
* Terminal test fails on some systems. (jonathonf)
* Terminal test fails on some slow terminals.
* When in silent mode too much output is buffered.
* If $SHELL contains a space then the default value of 'shell' is
incorrect. (Matthew Horan)
* Timer test on travis Mac is still flaky.
* Clojure now supports a shebang line.
* Filetype detection test does not check all scripts.
* Cannot handle change of directory.
* Missing file in patch.
* Missing another file in patch.
* Missing yet another file in patch.
* Test fails without 'autochdir' option.
* Completing directory after :find does not add slash.
* Python2 and python3 detection not tested. (Matej Cepl)
* Older GTK versions don't have gtk_entry_get_text_length().
* Libvterm doesn't handle illegal byte sequence correctly.
* Illegal memory access in del_bytes().
* When package path is a symlink adding it to 'runtimepath' happens at
the end.
* Integer overflow when using regexp pattern. (geeknik)
* On MS-Windows CursorIM highlighting no longer works.
* MS-Windows: nsis installer is a bit slow.
* MS-Windows: D&D fails between 32 and 64 bit apps.
* Visual C 2017 has multiple MSVCVER numbers.
* Invalid memory access in read_redo(). (gy741)
* Screen isn't always updated right away.
* Redraw flicker when moving the mouse outside of terminal window.
* Unnecessary condition for "len" being zero.
* Insert mode completion state is confusing.
* Patch missing change.
* Clearing a pointer takes two lines.
* Using feedkeys() does not work to test Insert mode completion. (Lifepillar)
* Searchpair() might return an invalid value on timeout.
* Reduntant conditions.
* Weird autocmd may cause arglist to be changed recursively.
* Accessing invalid memory with "it". (Dominique Pelle)
* Test 14 fails.
* Emacs tags no longer work. (zdohnal)
* There is no easy way to get the global directory, esp. if some windows
have a local directory.
* Number of spell regions is spread out through the code.
* The minimum width of the popup menu is hard coded.
* Memory leak in balloon_split().
* Completion items cannot be annotated.
* No autocmd triggered in Insert mode with visible popup menu.
* Having 'pumwidth' default to zero has no merit.
* Clearing a pointer takes two lines.
* Getting the jump list requires parsing the output of :jumps.
* Getjumplist() returns duplicate entries. (lacygoill)
* Out-of-memory situation not correctly handled. (Coverity)
* Possible NULL pointer dereference. (Coverity)
* Out-of-memory situation not correctly handled. (Coverity)
* In out-of-memory situation character is not restored. (Coverity)
* Access memory beyond end of string. (Coverity)
* Win32: the screen may be cleared on startup.
* Debugger can't break on a condition. (Charles Campbell)
* New version of HP NonStop (Tandem) doesn't like the default header
for setenv().
* Timer test is a bit flaky.
* The :drop command is not always available.
* Test for failing drag-n-drop command no longer fails.
* Cannot test if a command causes a beep.
* Some code for the debugger watch expression is clumsy.
* Warning for possibly using NULL pointer. (Coverity)
* The jumplist is not always properly cleaned up.
* Getting the list of changes is not easy.
* BufWinEnter event fired when opening hidden terminal.
* Errors for job options are not very specific.
* Invalid memory acces with pattern using look-behind match. (Dominique
Pelle)
* Error messages suppressed after ":silent! try". (Ben Reilly)
* Getchangelist() does not use argument as bufname().
* Cursor is in the wrong line when using a WinBar in a Terminal window.
* Shift-Tab does not work in a terminal window.
* Popup menu is positioned in the wrong place. (Davit Samvelyan, Boris
Staletic)
* Cannot write and read terminal screendumps.
* Compiler warnings for uninitialized variables. (Tony Mechelynck)
* Using :wqa exits even if a job runs in a terminal window. (Jason Felice)

==== xorg-x11-server ====
Subpackages: xorg-x11-server-sdk xorg-x11-server-wayland

- U_xwayland-Don-t-process-cursor-warping-without-an-xwl.patch,
U_xwayland-Give-up-cleanly-on-Wayland-socket-errors.patch,
U_xwayland-avoid-race-condition-on-new-keymap.patch,
U_xwayland-remove-dirty-window-unconditionally-on-unre.patch:
* Various crash and bug fixes in XWayland server (bgo#791383,
bgo#790502).

==== xournal ====

- Fix BuildRequires so it lists all the needed, specific
libraries.

==== yp-tools ====

- Use %license instead of %doc [bsc#1082318]


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages