Mailinglist Archive: opensuse-factory (1193 mails)

< Previous Next >
[opensuse-factory] Different go versions in Tumbleweed
Hi,

does it make sense to have 5 different go versions in Tumblweed while
the really old 1.4 is the default which does not even support cross
compilation? Running `update-alternatives` to use 1.9 is not enough
becuase GOROOT still links to the 1.4 path so I manually have to change it.
And to make it worse if I install just the package `go` all of these
versions are pulled in.

Maybe Go 1.4 is needed to bootstrap Go compilation but besides that do
we really have to keep all the Go versions because of the First Factory
Policy?
As far as I know we do not keep other old packages (at least not the old
version) around in Tumbleweed even though they are in SLES.
Can't we do this for go or at least not pull in all the in between
versions and change the default to the latest go package?

Regards
Tim








< Previous Next >
Follow Ups