Mailinglist Archive: opensuse-factory (1193 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180216 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180216

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
appstream-glib (0.7.4+git.3 -> 0.7.5)
attica-qt5 (5.42.0 -> 5.43.0)
baloo5 (5.42.0 -> 5.43.0)
bluez-qt (5.42.0 -> 5.43.0)
breeze5-icons (5.42.0 -> 5.43.0)
csmash
cyrus-sasl
dleyna-renderer (0.5.0 -> 0.6.0)
extra-cmake-modules (5.42.0 -> 5.43.0)
frameworkintegration (5.42.0 -> 5.43.0)
irssi (1.1.0 -> 1.1.1)
kactivities-stats (5.42.0 -> 5.43.0)
kactivities5 (5.42.0 -> 5.43.0)
kalarmcal
karchive (5.42.0 -> 5.43.0)
kauth (5.42.0 -> 5.43.0)
kbookmarks (5.42.0 -> 5.43.0)
kcmutils (5.42.0 -> 5.43.0)
kcodecs (5.42.0 -> 5.43.0)
kcompletion (5.42.0 -> 5.43.0)
kconfig (5.42.0 -> 5.43.0)
kconfigwidgets (5.42.0 -> 5.43.0)
kcoreaddons (5.42.0 -> 5.43.0)
kcrash (5.42.0 -> 5.43.0)
kdbusaddons (5.42.0 -> 5.43.0)
kdeclarative (5.42.0 -> 5.43.0)
kded (5.42.0 -> 5.43.0)
kdelibs4support (5.42.0 -> 5.43.0)
kdesignerplugin (5.42.0 -> 5.43.0)
kdesu (5.42.0 -> 5.43.0)
kdewebkit (5.42.0 -> 5.43.0)
kdnssd-framework (5.42.0 -> 5.43.0)
kdoctools (5.42.0 -> 5.43.0)
kemoticons (5.42.0 -> 5.43.0)
kfilemetadata5 (5.42.0 -> 5.43.0)
kglobalaccel (5.42.0 -> 5.43.0)
kguiaddons (5.42.0 -> 5.43.0)
kholidays (17.12.2 -> 5.43.0)
khtml (5.42.0 -> 5.43.0)
ki18n (5.42.0 -> 5.43.0)
kiconthemes (5.42.0 -> 5.43.0)
kidletime (5.42.0 -> 5.43.0)
kimageformats (5.42.0 -> 5.43.0)
kinit (5.42.0 -> 5.43.0)
kio (5.42.0 -> 5.43.0)
kirigami2 (5.42.0 -> 5.43.0)
kitemmodels (5.42.0 -> 5.43.0)
kitemviews (5.42.0 -> 5.43.0)
kjobwidgets (5.42.0 -> 5.43.0)
kjs (5.42.0 -> 5.43.0)
kjsembed (5.42.0 -> 5.43.0)
knewstuff (5.42.0 -> 5.43.0)
knotifications (5.42.0 -> 5.43.0)
knotifyconfig (5.42.0 -> 5.43.0)
kpackage (5.42.0 -> 5.43.0)
kparts (5.42.0 -> 5.43.0)
kpeople5 (5.42.0 -> 5.43.0)
kplotting (5.42.0 -> 5.43.0)
kpty (5.42.0 -> 5.43.0)
krename (4.0.9 -> 5.0.0)
kross (5.42.0 -> 5.43.0)
krunner (5.42.0 -> 5.43.0)
kservice (5.42.0 -> 5.43.0)
ktexteditor (5.42.0 -> 5.43.0)
ktextwidgets (5.42.0 -> 5.43.0)
kunitconversion (5.42.0 -> 5.43.0)
kwallet (5.42.0 -> 5.43.0)
kwayland (5.42.0 -> 5.43.0)
kwidgetsaddons (5.42.1 -> 5.43.0)
kwindowsystem (5.42.0 -> 5.43.0)
kxmlgui (5.42.0 -> 5.43.0)
kxmlrpcclient5 (5.42.0 -> 5.43.0)
libKF5ModemManagerQt (5.42.0 -> 5.43.0)
libKF5NetworkManagerQt (5.42.0 -> 5.43.0)
libstorage-ng (3.3.158 -> 3.3.164)
mariadb
oxygen5-icon-theme (5.42.0 -> 5.43.0)
perl-DateTime (1.45 -> 1.46)
perl-Encode (2.94 -> 2.96)
perl-Net-DNS (1.14 -> 1.15)
plasma-framework (5.42.0 -> 5.43.0)
postfix
prison-qt5 (5.42.0 -> 5.43.0)
purpose (1.2.1 -> 5.43.0)
python-ipaddress (1.0.18 -> 1.0.19)
python-kiwi (9.12.8 -> 9.12.9)
python-numpy
quagga
solid (5.42.0 -> 5.43.0)
sonnet (5.42.0 -> 5.43.0)
sox
strace (4.20 -> 4.21)
sudo (1.8.21p2 -> 1.8.22)
syntax-highlighting (5.42.0 -> 5.43.0)
systemd-rpm-macros
threadweaver (5.42.0 -> 5.43.0)
tomcat (9.0.2 -> 9.0.5)
virt-bootstrap
yast2 (4.0.50 -> 4.0.53)
yast2-bootloader (4.0.17 -> 4.0.18)
yast2-control-center (3.3.0 -> 4.0.0)
yast2-firewall (4.0.12 -> 4.0.14)
yast2-packager (4.0.37 -> 4.0.39)
yast2-pkg-bindings (4.0.7 -> 4.0.9)
yast2-storage-ng (4.0.93 -> 4.0.97)

=== Details ===

==== appstream-glib ====
Version update (0.7.4+git.3 -> 0.7.5)
Subpackages: appstream-glib-lang libappstream-builder8 libappstream-glib8

- Update to version 0.7.5:
+ Add as_app_parse_data().
+ Add as_store_get_apps_by_provide().
+ Add more GObject Introspection annotations for Python.
+ Describe connection problems/HTTP errors when validating
images.
+ Do not use an 'enable' prefix for meson arguments.
+ Don't expect an enum when really passing a bitfield.
+ Don?t fall back to en if other languages are available.
+ Explicitly require a new enough json-glib.
+ Fix a crash when calling as_release_add_location() directly.
+ Fix appstream-compose when using new-style desktop IDs.
+ Fix compile with GCab v1.0.
+ Generate icons and samples for emoji fonts..
+ Never change the default screenshot when processing AppData.
+ Support OARS v1.1 additions.
+ Use pngquant to make the application icons take up less space.
- Add pngquant Requires: new runtime dependency to make the
application icons take up less space.

==== attica-qt5 ====
Version update (5.42.0 -> 5.43.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== baloo5 ====
Version update (5.42.0 -> 5.43.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* baloo-tools: Make all output messages translatable
* build baloo executables with "ecm_mark_nongui"
* balooctl status: Produce parseable output
* Fix KIO Slave tagged folder deep copies. This breaks listing tagged folders
in the tag tree, but is better than broken copies.
* Skip queueing newly unindexable files and remove them from the index
immediately.
* Revert "Changing file xattrs (tag, rating, comment) should cause a file to
be reindexed. If the ctime changed, the file can be reindexed."
* baloosearch: Send summary to stderr
* balooctl status: translatable message
* Delete newly unindexable moved files from the index.
* Simplify BasicIndexingJob xattr indexing.
* Changing file xattrs (tag, rating, comment) should cause a file to be
reindexed. If the ctime changed, the file can be reindexed.
* validate baloo_file.desktop
* balooctl use global fileIndexDbPath().

==== bluez-qt ====
Version update (5.42.0 -> 5.43.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* No need to initialize m_usableAdapterwith nullptr

==== breeze5-icons ====
Version update (5.42.0 -> 5.43.0)

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Too many changes to list here

==== csmash ====

- FIx buildRequires so metapackages xorg-x11-devel, Mesa-devel
are not required anymore.

==== cyrus-sasl ====
Subpackages: cyrus-sasl-crammd5 cyrus-sasl-devel cyrus-sasl-digestmd5
cyrus-sasl-gssapi cyrus-sasl-plain libsasl2-3 libsasl2-3-32bit

- bsc#983938 `After=syslog.target` left-overs in several unit files
- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== dleyna-renderer ====
Version update (0.5.0 -> 0.6.0)

- Update to version 0.6.0:
+ Ensure that g_context.watchers has a valid value.
+ Used core functionality dleyna_core_prv_convert_udn_to_path for
persistent path.
+ [m4]:
- Don't use bash arrays in m4 macros.
- Don't use bash "let" builtin.
- Use AS_VAR_APPEND macro instead of "+=".
+ Avoid any attempts to delete the same dlr_upnp_t twice.
+ Uninitialized argument value in prv_open_uri_cb.
- Do a minor spec cleanup, add missing COPYING.
- Add libtool BuildRequires and pass autoreconf, bootstrap tarball.
- Pass --disable-static to configure, ensure we do not build any
static files.

==== extra-cmake-modules ====
Version update (5.42.0 -> 5.43.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* ecm_install_icons: refer to non-deprecated KDE_INSTALL_ICONDIR
* FindQtWaylandScanner.cmake: Use qmake-query for HINT
* Make sure to search for Qt5-based qmlplugindump
* ECMToolchainAndroidTest doesn't exist anymore (kde#389519)
* Don't set the LD_LIBRARY_PATH in prefix.sh
* Add FindSeccomp to find-modules
* Fall back to language name for translations lookup if locale name fails
* Android: Add more includes

==== frameworkintegration ====
Version update (5.42.0 -> 5.43.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== irssi ====
Version update (1.1.0 -> 1.1.1)

- update to 1.1.1 (bsc#1081238):
- Restore compatibility with OpenSSL < 1.0.2 (#820, #831)
- Fix test compilation on some platforms (#815, #816)
- Fix portability and backwards compatibility of test runner
(#818, #845)
- Prevent use after free error during the execution of some
commands. Found by Joseph Bisch (GL#17, GL!24).
- Revert netsplit print optimisation due to crashes (#465, #809,
[#812], #819, #824). CVE-2018-7054
- Fix use after free when SASL messages are received in
unexpected order (GL#26, GL!33). CVE-2018-7053
- Fix null pointer dereference in the tab completion when an
empty nick is joined (GL#24, GL!31). CVE-2018-7050
- Fix use after free when entering oper password (GL#22,
GL!32).
- Fix null pointer dereference when too many windows are
opened (GL#27, #837). CVE-2018-7052
- Fix out of bounds access in theme strings when the last
escape is incomplete. Credit to Oss-Fuzz (#842). CVE-2018-7051
- Fix out of bounds write when using negative counts on window
resize (GL#25, GL#29, #836).
- Minor help correction. By William Jackson (#834).

==== kactivities-stats ====
Version update (5.42.0 -> 5.43.0)

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kactivities5 ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kalarmcal ====
Subpackages: kalarmcal-lang libKF5AlarmCalendar5

- Remove requirement on versioned kholidays-devel, the move to
Frameworks has changed version number

==== karchive ====
Version update (5.42.0 -> 5.43.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kauth ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kauth-devel libKF5Auth5 libKF5Auth5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix linking regression introduced by d47f645a7 (wrong "const")

==== kbookmarks ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kcmutils ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kcmutils-devel libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Adds tooltips to the two buttons on each entry

==== kcodecs ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kcodecs-devel libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kcompletion ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kcompletion-devel libKF5Completion5 libKF5Completion5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix incorrect emission of textEdited() by KLineEdit (kde#388798, kde#373004)

==== kconfig ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5
libKF5ConfigCore5-lang libKF5ConfigGui5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Use Ctrl+Shift+, as the standard shortcut for "Configure <Program>"

==== kconfigwidgets ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kcoreaddons ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kcoreaddons-devel kcoreaddons-lang libKF5CoreAddons5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* KUrlMimeData: fix handling of PreferLocalUrls
* Match also spdx keys LGPL-2.1 & LGPL-2.1+
* Use the much faster urls() method from QMimeData
* Next try to fix build on windows
* Make it compiles on windows
* Compile commenting remove_defintion(QT_NO_CAST_FROM_ASCII )
* Optimize inotify KDirWatch backend: map inotify wd to Entry
* Optimize: use QMetaObject::invokeMethod with functor
* Add benchmarks for KDirWatch
* Use QSignalSpy::wait instead of QTest::wait where possible
* Verify that the file was opened
* Verify that the path is valid and writable

==== kcrash ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kdbusaddons ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5
libKF5DBusAddons5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kdeclarative ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5Declarative5-lang libKF5QuickAddons5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* API dox: note @since & whattodo with deprecated KDeclarative::initialize()
* [ConfigModule] Re-use QML context and engine if any
* [ConfigPropertyMap] Add missing include
* [ConfigPropertyMap] Don't emit valueChanged on initial creation

==== kded ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kded-devel kded-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Don't export kded5 as a CMake target

==== kdelibs4support ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kdelibs4support-devel kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* autotests: attempt to repair kmimetypetest on CI
* Add Windows notes for network related test applications
* Refactor Solid::NetworkingPrivate to have a shared and platform specific
implementation
* Fix mingw compile error "src/kdeui/kapplication_win.cpp:212:22: error:
'kill' was not declared in this scope"
* Fix kded dbus name in solid-networking howto

==== kdesignerplugin ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Make kdoctools dependency optional

==== kdesu ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kdesu-devel libKF5Su5 libKF5Su5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Make KDESU_USE_SUDO_DEFAULT mode build again
* Make kdesu work when PWD is /usr/bin

==== kdewebkit ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kdnssd-framework ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kdoctools ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kdoctools-devel kdoctools-lang libKF5DocTools5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* customization/entities/contributor.entities - fix typo . missing '>'
* rename KDE-Partitionsmanager to Partitionsverwaltung, KDE does not make any
sense here

==== kemoticons ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kfilemetadata5 ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kfilemetadata5-devel kfilemetadata5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix build with >=attr-2.4.48

==== kglobalaccel ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccel5-lang libKF5GlobalAccelPrivate5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Use cmake function 'kdbusaddons_generate_dbus_service_file' from
kdbusaddons to generate dbus service file (kde#382460)

==== kguiaddons ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix linking of created QCH file into QtGui docs

==== kholidays ====
Version update (17.12.2 -> 5.43.0)

- Update to 5.43.0
* Now part of KDE Frameworks 5
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php

==== khtml ====
Version update (5.42.0 -> 5.43.0)
Subpackages: khtml-devel libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== ki18n ====
Version update (5.42.0 -> 5.43.0)
Subpackages: ki18n-devel libKF5I18n5 libKF5I18n5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix finding libintl when "cross"-compiling native Yocto packages

==== kiconthemes ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kiconthemes-devel libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kidletime ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kimageformats ====
Version update (5.42.0 -> 5.43.0)

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kinit ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kinit-devel kinit-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix cross-compiling with MinGW (MXE)

==== kio ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kio-core kio-devel kio-lang

- Add patch to fix a problem that made kio copy files too slowly (kde#384561)
* 0001-Dont-stat-etc-localtime-between-read-and-write.patch
- Add patch to fix kdialog writing files with .bin extension in chrome
when downloading files (kde#382437)
* 0001-Fix-bug-382437-Regression-in-kdialog-causes-wrong-file-ext.patch
- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Too many changes to list here
- Dropped patches, now upstream:
* 0001-Fix-KFilePreviewGenerator-LayoutBlocker.patch
* fix-overlap-of-first-item-in-kfileplacesview.patch

==== kirigami2 ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Update to 5.43.0
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Too many changes to list here

==== kitemmodels ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* KRearrangeColumnsProxyModel: fix crash when there's no source model
* KRearrangeColumnsProxyModel: reimplement sibling() so it works as expected

==== kitemviews ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kitemviews-devel libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kjobwidgets ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Code de-duplication in byteSize(double size) (kde#384561)

==== kjs ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kjs-devel kjs-devel-lang libKF5JS5 libKF5JSApi5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Make kdoctools dependency optional

==== kjsembed ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kjsembed-devel libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Unexport kjscmd
* Make kdoctools dependency optional

==== knewstuff ====
Version update (5.42.0 -> 5.43.0)
Subpackages: knewstuff-core-devel knewstuff-devel libKF5NewStuff5
libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== knotifications ====
Version update (5.42.0 -> 5.43.0)
Subpackages: knotifications-devel libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix loading NotifyByExecute (kde#389284)

==== knotifyconfig ====
Version update (5.42.0 -> 5.43.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kpackage ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kpackage-devel kpackage-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kparts ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kparts-devel libKF5Parts5 libKF5Parts5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kpeople5 ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kpeople5-devel kpeople5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kplotting ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kpty ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kpty-devel libKF5Pty5 libKF5Pty5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== krename ====
Version update (4.0.9 -> 5.0.0)

- Update to 5.0.0:
* Ported to Qt5 and KDE Frameworks 5
- Drop no longer necessary patches:
* gcc6-fix.patch
* fix-freetype2-includes.patch
* krename-4.0.7_add_common_names_to_FindLIBPODOFO.patch
* desktop-files.diff
- Let %suse_update_desktop_file add a GenericName instead of using
a patch for that

==== kross ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kross-devel kross-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== krunner ====
Version update (5.42.0 -> 5.43.0)
Subpackages: krunner-devel libKF5Runner5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kservice ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kservice-devel kservice-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== ktexteditor ====
Version update (5.42.0 -> 5.43.0)
Subpackages: ktexteditor-devel ktexteditor-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* improve line heigh computation try to avoid cutting of parts of glyphs
* Fix: View jumps when Scroll past end of document is enabled (kde#306745)
* KateView unit test: simplify finding KateViewInternal
* Use at least the requested width for the argument hint tree
* ExpandingWidgetModel: find the right-most column based on location
* Simplify code: return early to reduce indentation depth

==== ktextwidgets ====
Version update (5.42.0 -> 5.43.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kunitconversion ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5
libKF5UnitConversion5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kwallet ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 kwalletd5-lang libKF5Wallet5
libkwalletbackend5-5

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kwayland ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kwayland-devel

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix typo

==== kwidgetsaddons ====
Version update (5.42.1 -> 5.43.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.1:
* autotest: enforce en_US locale and make it pass (it was relying on fr, oops)
* Fix compiler warning, a quint16 is always <= 0xFFFF
* autotests: more QCOMPAREs to debug CI failure
* KDateComboBox: fix dateChanged() not emitted after typing a date
(kde#364200)
* KMultiTabBar: Fix regression in conversion to new style connect()

==== kwindowsystem ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* autotests: set LIBRARY_OUTPUT_DIRECTORY so platform plugins are found
uninstalled

==== kxmlgui ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kxmlgui-devel libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== kxmlrpcclient5 ====
Version update (5.42.0 -> 5.43.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== libKF5ModemManagerQt ====
Version update (5.42.0 -> 5.43.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== libKF5NetworkManagerQt ====
Version update (5.42.0 -> 5.43.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== libstorage-ng ====
Version update (3.3.158 -> 3.3.164)
Subpackages: libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#468
- use parted with --ignore-busy (see bsc#1058667)
- added convenience functions
- 3.3.164
- merge gh#openSUSE/libstorage-ng#467
- cleanup
- added integration test
- added jfs support (boo#1078552)
- 3.3.163
- merge gh#openSUSE/libstorage-ng#466
- improve ruby bindings
- 3.3.162
- merge gh#openSUSE/libstorage-ng#465
- extended is_usable_as_blk_device()
- 3.3.161
- merge gh#openSUSE/libstorage-ng#464
- use system devicegraph during probe
- merge gh#openSUSE/libstorage-ng#463
- added function is_usable_as_blk_device()
- added function is_usable_as_partitionable()
- 3.3.160
- merge gh#openSUSE/libstorage-ng#462
- added function to immediately activate/deactivate mount point
- added documentation
- code cleanup
- 3.3.159

==== mariadb ====
Subpackages: libmysqld19 mariadb-client mariadb-errormessages

- add dependency on which for galera scripts

==== oxygen5-icon-theme ====
Version update (5.42.0 -> 5.43.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== perl-DateTime ====
Version update (1.45 -> 1.46)

- updated to 1.46
1.46 2018-02-11
- Fixed the formatting for the CLDR "S" symbol. It could in some cases round
_up_ to 1 instead of truncating a value. For example, the "SSS" symbol would
format 999,999,999 nanoseconds as "1.000". Fixed by Gianni Ceccarelli. PR
[#71].

==== perl-Encode ====
Version update (2.94 -> 2.96)

- updated to 2.96
see /usr/share/doc/packages/perl-Encode/Changes

==== perl-Net-DNS ====
Version update (1.14 -> 1.15)

- updated to 1.15
see /usr/share/doc/packages/perl-Net-DNS/Changes

==== plasma-framework ====
Version update (5.42.0 -> 5.43.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-lang plasma-framework-private

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Define property in Units.qml for the Plasma styles
* Include cstdlib for std::free
* windowthumbnail: Fix the GLXFBConfig selection code
* Revert "[Plasma Dialog] Call window effects only if visible" (kde#389352)
* [Default Tooltip] Fix sizing (kde#386260, kde#389371)
* [Examples] Fix build
* parametrize qqc2 version
* don't multiply svg sizes by devicepixelratio
* [Plasma Dialog] Call window effects only if visible
* [Plasma Theme] Guard against invalid KPluginInfo object (kde#389152)
* Fix one source of log spam referenced in Bug 388389 (Empty filename passed
to function)
* [Calendar] Adjust the calendar toolbar anchors
* API dox: Use code markup for described dataUpdated slot signature
* [ConfigModel] Set QML context on ConfigModule (kde#388766)
* [Icon Item] Treat sources starting with a slash as local file
* fix RTL appearance for ComboBox (kde#387558)

==== postfix ====
Subpackages: postfix-doc

- bsc#1065411 Package postfix should require package system-user-nobody
- bsc#1080772 postfix smtpd throlle getting "hello" if no sasl auth
was configured

==== prison-qt5 ====
Version update (5.42.0 -> 5.43.0)

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== purpose ====
Version update (1.2.1 -> 5.43.0)
Subpackages: purpose-lang

- Update to 5.43.0
* New feature release
* Now part of KDE Frameworks 5
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 1.2.1:
* Too many changes to list here

==== python-ipaddress ====
Version update (1.0.18 -> 1.0.19)

- update to version v1.0.19
* Synchronize with Python3's ipaddress module of the day

==== python-kiwi ====
Version update (9.12.8 -> 9.12.9)

- Bump version: 9.12.8 ? 9.12.9
- Update .virtualenv.dev-requirements.txt
sphinx 1.7.0 is not compatible with travis-sphinx
thus we stick with 1.6.7 until travis-sphinx followed
the sphinx changes
- Add restrictions to Path.remove_hierarchy
When an iso file is used as repo, this iso will be loop mounted on
the host and bind mounted into the image root as long as the image
builds. When the mount is released a recursive cleanup of the complete
path happens. This is done by calling Path.remove_hierarchy. However
if a sub path of the mount path contains a system root directory
which is mandatory for the Linux root system it is not allowed
to be deleted even if it is empty at the time of the mount cleanup.
Thus this patch adds a lookup for protected directory names and
only runs the recursive deletion as long as no protected member
is part of the path. This fixes bsc#1080301
- Initial support for building Debian/Ubuntu packages in spec
This adds support for producing the main kiwi package as well as the
packages for the dracut modules to be used when building Debian-based
distribution images with KIWI.
The Debian/Ubuntu package is built using debbuild:
https://github.com/ascherer/debbuild
- Fixed build_pxe_root_filesystem documentation
The article still used filename references from v7 code stream
This patch updates the docs to match the sources it refers to
- Update dropped features documentation
The information on the partition based install method was
unclear and misleading. This patch clarifies the documentation
in this regard
- Delete obsolete ovf format value
Support for ova has been added which makes the ovf format
value obsolete and redundant
- OVA: Print a user-friendly message if ovftool is not available
- OVA: Require ovftype="vmware"

==== python-numpy ====
Subpackages: python2-numpy python3-numpy

- riscv.patch: Add support for RISC-V
- Don't use openblas on m68k and riscv64
- Avoid misparsing of indented conditionals

==== quagga ====
Subpackages: libospf0 libospfapiclient0 libzebra1

- Applied security fix for bgpd DoS via specially crafted BGP
UPDATE messages (CVE-2017-16227,bsc#1065641)
[+ quagga-CVE-2017-16227-bgpd-Fix-AS_PATH-size-calculation.patch]
- Applied security fix for bgpd bounds check issue via attribute
length (CVE-2018-5378,Quagga-2018-0543,bsc#1079798)
[+ Quagga-2018-0543-bgpd.bsc1079798.patch]
- Applied security fix for bgpd double free when processing UPDATE
message (CVE-2018-5379,Quagga-2018-1114,bsc#1079799)
[+ Quagga-2018-1114-bgpd.bsc1079799.patch]
- Applied security fix for bgpd code-to-string conversion tables
overrun (CVE-2018-5380,Quagga-2018-1550,bsc#1079800)
[+ Quagga-2018-1550-bgpd-bsc1079800.patch]
- Applied security fix for bgpd infinite loop on certain invalid
OPEN messages (CVE-2018-5381,Quagga-2018-1975,bsc#1079801)
[+ Quagga-2018-1975-bdpd.bsc1079801.patch]

==== solid ====
Version update (5.42.0 -> 5.43.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-devel solid-imports
solid-tools

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* unset maintainer
* [UDisks] Only ignore non-user backing file if it is known (kde#389358)
* [UDisks] Ignore non-user mounts (kde#379516)
* [UDisks Device] Show loop device with their backing file name and icon

==== sonnet ====
Version update (5.42.0 -> 5.43.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5
sonnet-devel

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Find Aspell dictionaries on Windows
* Fix compilation of just the UI-less host tools

==== sox ====
Subpackages: libsox3

- Added patches:
* CVE-2017-11332.patch: Fixed the startread function in wav.c, which allowed
remote attackers to cause a DoS (divide-by-zero) via a crafted wav file.
(CVE-2017-11332 bsc#1081140)
* CVE-2017-11358.patch: Fixed the read_samples function in hcom.c, which
allowed remote attackers to cause a DoS (invalid memory read) via a crafted
hcom file. (CVE-2017-11358 bsc#1081141)
* CVE-2017-11359.patch: Fixed the wavwritehdr function in wav.c, which
allowed remote attackers to cause a DoS (divide-by-zero) when converting a
a crafted snd file to a wav file. (CVE-2017-11359 bsc#1081142)
* CVE-2017-15370.patch: Fixed a heap-based buffer overflow in the ImaExpandS
function of ima_rw.c, which allowed remote attackers to cause a DoS during
conversion of a crafted audio file. (CVE-2017-15370 bsc#1063439)
* CVE-2017-15371.patch: Fixed an assertion abort in the function
sox_append_comment() in formats.c, which allowed remote attackers to cause
a DoS during conversion of a crafted audio file. (CVE-2017-15371
bsc#1063450)
* CVE-2017-15372.patch: Fixed a stack-based buffer overflow in the
lsx_ms_adpcm_block_expand_i function of adpcm.c, which allowed remote
attackers to cause a DoS during conversion of a crafted audio file.
(CVE-2017-15372 bsc#1063456)
* CVE-2017-15642.patch: Fixed an Use-After-Free vulnerability in
lsx_aiffstartread in aiff.c, which could be triggered by an attacker by
providing a malformed AIFF file. (CVE-2017-15642 bsc#1064576)
* CVE-2017-18189.patch: Fixed a NULL pointer dereference triggered by a
corrupt header specifying zero channels in the startread function in
xa.c, which allowed remote attackers to cause a DoS (CVE-2017-18189
bsc#1081146).
- Removed sox-doublefree.patch

==== strace ====
Version update (4.20 -> 4.21)

- Update to strace 4.21
* Changes in behaviour
* Warning is now issued when -F option is used.
* Warning is now issued when a tracee with unsupported personality
is attached.
* Unknown syscall numbers are now printed in hexadecimal form.
* Improvements
* Implemented decoding of netlink descriptor attributes as file descriptors.
* Implemented decoding of hugetlb page size selection flags.
* Implemented decoding of BPF_PROG_TEST_RUN, BPF_PROG_GET_NEXT_ID,
BPF_MAP_GET_NEXT_ID, BPF_PROG_GET_FD_BY_ID, BPF_MAP_GET_FD_BY_ID,
and BPF_OBJ_GET_INFO_BY_FD commands of bpf syscall.
* Enhanced decoding of get_thread_area, memfd_create, modify_ldt,
perf_event_open, reboot, s390_guarded_storage, s390_pcio_mmio_read,
s390_pci_mmio_write, s390_runtime_instr, s390_sthyi, set_thread_area,
and shmget syscalls.
* Implemented decoding of KVM_* and DM_LIST_DEVICES ioctl commands.
* Implemented decoding of riscv_flush_icache syscall.
* Enhanced decoding of getsockopt and setsockopt syscalls for SOL_NETLINK
level.
* Enhanced decoding of BPF_MAP_CREATE command of bpf syscall.
* Print values returned by mq_open syscall and first arguments
of mq_getsetattr, mq_notify, mq_timedreceive, and mq_timedsend syscalls
as file descriptors.
* Added decoding of get_tls syscall on arm.
* Added -e trace=%pure option for tracing system calls with no arguments that
never fail.
* Updated lists of IPV6_*, MAP_*, MEMBARRIER_CMD_*, MSG_*, NT_*, PKEY_*,
SHM_*, and TCP_* constants.
* Added manual page for the strace-log-merge command.
* Updated lists of ioctl commands from Linux 4.15.
* Implemented biarch support for s390x.
* Implemented an optional support for symbol demangling in strace -k output
(activated by --with-libiberty configure option).
* Information about availability of demangling and reliable personality
decoding (on architectures with multiple personalities) is now available
in strace -V output.
* Added decoding of pkey_alloc, pkey_free, and pkey_mprotect syscalls on
powerpc and powerpc64.
* Enhanced manual page.
* Bug fixes
* Fixed multi-personality support in cross builds.
* Added mq_getsetattr, mq_notify, mq_open, mq_timedreceive, and mq_timedsend
syscalls to %desc tracing set.
* Fixed path tracing support for mmap syscalls with indirect arguments and
for old select syscall.
* Fixed decoding of arm-specific (__ARM_NR_*) syscalls.
* Fixed open mode flags decoding.
* Fixed corner cases in handling of strace -ff -ttt logs by strace-log-merge.
* Error counts that exceed one billion are now printed correctly in call
summary output.
* Fixed call summary header for x32 personality.
* Changes of tracee personalities are reported more reliably.
* Fixed the case when strace attaches to a tracee being inside exec and its
first syscall stop is syscall-exit-stop instead of syscall-enter-stop,
which messed up all the syscall state tracking.
* Fixed printing of higher 32 bits of the return value for x32 personality.
- update-futex-test-in-accordance-with-kernel-s-v4.15-.patch: removed

==== sudo ====
Version update (1.8.21p2 -> 1.8.22)

- The sudo distribution files are now signed with a new pgp key.
Refresh sudo.keyring
- Update to 1.8.22 [bsc#1080793]
* Commands run in the background from a script run via sudo will
no longer receive SIGHUP when the parent exits and I/O logging
is enabled
* A particularly offensive insult is now disabled by default
* The description of sudo -i now correctly documents that the
env_keep and env_check sudoers options are applied to the
environment
* Fixed a crash when the system's host name is not set
* The sudoers2ldif script now handles #include and #includedir
directives.
* Fixed a bug where sudo would silently exit when the command
was not allowed by sudoers and the passwd_tries sudoers option
was set to a value less than one.
* Fixed a bug with the listpw and verifypw sudoers options and
multiple sudoers sources. If the option is set to all a
password should be required unless none of a user's sudoers
entries from any source require authentication.
* Fixed a bug with the listpw and verifypw sudoers options in
the LDAP and SSSD back-ends. If the option is set to any and
the entry contained multiple rules, only the first matching
rule was checked. If an entry contained more than one matching
rule and the first rule required authentication but a
subsequent rule did not, sudo would prompt for a password when
it should not have.
* When running a command as the invoking user (not root), sudo
would execute the command with the same group vector it was
started with. Sudo now executes the command with a new group
vector based on the group database which is consistent with how
su(1) operates.
* Fixed a double free in the SSSD back-end that could occur when
ipa_hostname is present in sssd.conf and is set to an unqualified
host name.
* When I/O logging is enabled, sudo will now write to the terminal
even when it is a background process. Previously, sudo would only
write to the tty when it was the foreground process when I/O
logging was enabled. If the TOSTOP terminal flag is set, sudo
will suspend the command (and then itself) with the SIGTTOU signal.
* A new authfail_message sudoers option that overrides the default
N incorrect password attempt(s).
* An empty sudoRunAsUser attribute in the LDAP and SSSD backends
will now match the invoking user. This is more consistent with
how an empty runas user in the sudoers file is treated.
* Documented that in check mode, visudo does not check the owner /
mode on files specified with the -f flag
* It is now an error to specify the runas user as an empty string
on the command line. Previously, an empty runas user was treated
the same as an unspecified runas user
* When timestamp_type option is set to tty and a terminal is
present, the time stamp record will now include the start time
of the session leader. When the timestamp_type option is set
to ppid or when no terminal is available, the start time of the
parent process is used instead. This significantly reduces the
likelihood of a time stamp record being re-used when a user logs
out and back in again.
* The sudoers time stamp file format is now documented in the new
sudoers_timestamp manual.
* Visudo will now use the SUDO_EDITOR environment variable (if
present) in addition to VISUAL and EDITOR.
- rebase sudoers2ldif-env.patch
- cleanup with spec-cleaner

==== syntax-highlighting ====
Version update (5.42.0 -> 5.43.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* Fix C# var regex
* Support for underscores in numeric literals (Python 3.6) (kde#385422)
* AppArmor: Fix style
* Highlight Khronos Collada and glTF files
* Fix ini highlighting of values containing ; or # characters
* AppArmor: new keywords, improvements & fixes

==== systemd-rpm-macros ====

- Fix %systemd_post(): it's never called during package removal
Also make it useful by restoring its original implementation.
- Import more definitions from upstream (v237)

==== threadweaver ====
Version update (5.42.0 -> 5.43.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.43.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
* None

==== tomcat ====
Version update (9.0.2 -> 9.0.5)
Subpackages: tomcat-admin-webapps tomcat-el-3_0-api tomcat-jsp-2_3-api
tomcat-lib tomcat-servlet-4_0-api tomcat-webapps

- Update to Tomcat 9.0.5. See changelog at
http://tomcat.apache.org/tomcat-9.0-doc/changelog.html#Tomcat_9.0.5_(markt)

==== virt-bootstrap ====

- Add ExclusiveArch: x86_64 ppc64 ppc64le s390x aarch64. These are
the same archs as listed for libguestfs, which is a dependency.

==== yast2 ====
Version update (4.0.50 -> 4.0.53)

- Fixed list of the URL schemes without host, fixes processing
URLs with the "hd:/" scheme (bsc#1077310)
- 4.0.53
- Add a method to get the list of available license translations
for a given product (related to FATE#322276).
- 4.0.52
- Firewalld: Added interfaces helpers (fate#323460)
- 4.0.51

==== yast2-bootloader ====
Version update (4.0.17 -> 4.0.18)

- fix nil exception for device with filesystem that is not mounted
(bsc#1081018)
- 4.0.18

==== yast2-control-center ====
Version update (3.3.0 -> 4.0.0)
Subpackages: yast2-control-center-qt

- Do not included unused RPC headers (boo#1081118).
- 4.0.0

==== yast2-firewall ====
Version update (4.0.12 -> 4.0.14)

- fate#323460
- updated summary in autoyast client to work with new firewalld
api
- 4.0.14
- AutoYaST: added 'enable_firewall', 'start_firewall' and
'FW_LOG_DROP_CRIT' to the list of supported properties for
SuSEFirewall2 profiles and fixed a typo with 'FW_LOG_DROP_ALL'
(fate#323460).
- 4.0.13

==== yast2-packager ====
Version update (4.0.37 -> 4.0.39)

- Display licenses translations (related to FATE#322276).
- 4.0.39
- Also display the licenses stored in the RPM-MD repository
metadata, fixes displaying the license e.g. for SLE15-HA
product on the Packages DVD (bsc#1057223)
- 4.0.38

==== yast2-pkg-bindings ====
Version update (4.0.7 -> 4.0.9)

- always scan media for products to allow media identification
(bsc#1080983)
- 4.0.9
- Add a PrdLicenseLocales function to get the list of available
license translations for a given product (related to
FATE#322276).
- 4.0.8

==== yast2-storage-ng ====
Version update (4.0.93 -> 4.0.97)

- Adjusted the suggested and minimum sizes of all the booting
partitions, both in the storage proposal and in the Partitioner
validations (bsc#1076851 and fate#318196).
- 4.0.97
- Fix hwinfo parsing to support more than one device_file property
(bsc#1080999)
- 4.0.96
- Split detection of problematic boot scenarios into errors and
warnings. With warnings user can continue, but not with errors.
(bsc#1074475)
- 4.0.95
- PowerPC: do not require /boot partition for non-PowerNV
(bsc#1070139).
- Partitioner: do not enforce partition id for /boot/efi
(bsc#1078707).
- 4.0.94


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages