Mailinglist Archive: opensuse-factory (745 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180127 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180127

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
autoyast2 (4.0.22 -> 4.0.24)
branding-openSUSE
gfxboot (4.5.23 -> 4.5.25)
glibc
glibc
kde-branding-openSUSE
libreoffice
libstorage-ng (3.3.112 -> 3.3.140)
obs-service-source_validator (0.9 -> 0.12)
qemu
qemu-linux-user
ucode-intel
yast2 (4.0.35 -> 4.0.39)
yast2-country (4.0.16 -> 4.0.17)
yast2-firewall (4.0.8 -> 4.0.9)
yast2-installation (4.0.22 -> 4.0.26)
yast2-network (4.0.13 -> 4.0.14)
yast2-packager (4.0.29 -> 4.0.32)
yast2-pkg-bindings (4.0.5 -> 4.0.6)
yast2-storage-ng (4.0.70 -> 4.0.76)

=== Details ===

==== autoyast2 ====
Version update (4.0.22 -> 4.0.24)
Subpackages: autoyast2-installation

- Selecting evaluated/given product for installation.
fate#323450
- 4.0.24
- Display more details when the package solver fails
- Using ProductFeatures.SetSection instead of
ProductFeatures.SetOverlay in order to set product features.
This is a follow up of bsc#1070726.
- 4.0.23

==== branding-openSUSE ====
Subpackages: gfxboot-branding-openSUSE grub2-branding-openSUSE
plymouth-branding-openSUSE wallpaper-branding-openSUSE
xfce4-splash-branding-openSUSE yast2-qt-branding-openSUSE

- Fixup product version for Leap based on sle_version, and for
Tumbleweed set it to 'openSUSE Tumbleweed'.

==== gfxboot ====
Version update (4.5.23 -> 4.5.25)

- Translated using Weblate (Japanese)
- 4.5.25
- Translated using Weblate (Slovak)
- merge gh#openSUSE/gfxboot#29
- add config file entries to specify a title for the main screen
(bsc#1077188)
- fix bug processing serial menu entries (bsc#1075852)
- 4.5.24

==== glibc ====
Subpackages: glibc-32bit glibc-locale-32bit

- getcwd-absolute.patch: make getcwd(3) fail if it cannot obtain an
absolute path (CVE-2018-1000001, bsc#1074293, BZ #22679)
- dl-init-paths-overflow.patch: Count components of the expanded path in
_dl_init_path (CVE-2017-1000408, CVE-2017-1000409, bsc#1071319, BZ
[#22607], BZ #22627)
- fillin-rpath-empty-tokens.patch: Check for empty tokens before dynamic
string token expansion (CVE-2017-16997, bsc#1073231, BZ #22625)

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale nscd

- getcwd-absolute.patch: make getcwd(3) fail if it cannot obtain an
absolute path (CVE-2018-1000001, bsc#1074293, BZ #22679)
- dl-init-paths-overflow.patch: Count components of the expanded path in
_dl_init_path (CVE-2017-1000408, CVE-2017-1000409, bsc#1071319, BZ
[#22607], BZ #22627)
- fillin-rpath-empty-tokens.patch: Check for empty tokens before dynamic
string token expansion (CVE-2017-16997, bsc#1073231, BZ #22625)

==== kde-branding-openSUSE ====
Subpackages: kdelibs4-branding-openSUSE ksplash-qml-branding-openSUSE
ksplashx-branding-openSUSE

- Fixup product version for Leap based on sle_version, and for
Tumbleweed set it to 'openSUSE Tumbleweed'.
- Use %posttrans for initrd creation (bsc#1066666)
- Also require grub2 when using the new update-bootloader-rpm-macros:
Otherwise the installer might install the branding package before
grub2, resulting in /etc/default/grub to not exist and the theme
failing to activate.
- Support %posttrans with macros provided by update-bootloader-rpm-macros
package (bsc#997317)
- enable grub2-branding-openSUSE also for %%arm
- Change version back to 13.3
- Update from git to get yast theme updates (pr#60)
- Add yast2-qt-branding-openSUSE back and remove Supplements
- Much less breakage
- Drop yast2-qt-branding-openSUSE (boo#955381)
- Fix xfce4-splash-branding-openSUSE conflicts
- grub2 theme: use blueish color for timeout bar.
- Update branding with final touches.
- plymouth script: revert to single sized backround image. The
one in the current branding deck fades out to black.
- Update plymouth script: loading different backgrounds based on
screen aspect ratio.
- Update branding for Tumbleweed with new graphics.
- Reuse .spec file from Leap branding package.
- enable grub theme on aarch64
- Update the tarball to fix the kde-branding patches for KDE 4.14.3
- fix bashisms in post/postun script
- Fix plymouth theme
- Replace Grub2 and gfxboot themes with mint on black instead of
white on mint
- Update KSplash for 13.2 branding
- plymouth-plugin-label is not required anymore:
+
https://github.com/openSUSE/branding/commit/e02d63e4ef11b7d9ec2e9a22326bfb83c1aba310
+ http://lists.opensuse.org/opensuse-arm/2014-10/msg00032.html
update go git:
- updated KDM theme for 13.2
- reduced svg file size with Inkscape > Vacuum Defs
- fix merge conflicts
- Lower openSUSE logo in grub2 by 5px to improve spacing under OS title
- replace grub2 openSUSE logo with high resolution badge
- add openSUSE logo to gfxboot images
- new yast branding location now handled by git makefile, remove mv
from spec file
- Initial openSUSE 13.2 branding
- yast branding needs to be installed in /usr/share/YaST2/theme/current
now
- Update YaST installer look to similar to sle12
- set version to 13.2 - let the games begin
- Update for kdm : readd traditionnal username field
fix bnc#844247 for nis login
fix bnc#841719 clickable list again
- Move tarball compression to xz and save 20% of space
- github 13.1 Makefile adapted to new tar.xz
- New tarball with fixes for userlist in kdm

https://github.com/Caig/branding/commit/c0e079b539b615ae393c912ba6e6c40116926291
bnc#842140
- remove workaround for bnc#782703
- Add Requires(post): kdm for the kdm-branding to make sure that
the configuration file kdmrc is installed before the branding
is installed. This due to possible sequencing errors that could
end up with the wrong theme for kdm.
- grub2: updated release number text
- Reduce the amount of KDM settings in sysconfig/displaymanager to
purely autologin. This enables that KDM can be configured again
through the normal KDE systemsettings module. (bnc#267903)
- Rename branding file to SUSE-brand (FATE#316269).
- revert parts of fix for bnc#768686 to get installation steps
readable again
- sync the 2 changes files with a pre_checkin.sh
- updated tar without gimp
- gimp will be unbranded in 13.1, so cleanup of gimp
- split kde and gimp branding into a spec file of it's own to leave
kde out of the Factory:Core project
- Drop kdm-branding-upstream BuildRequires, not needed since usage
of _kde_branding_version macro
- Utilize the new variable _kde_branding_version for the provides/
requires of the KDE branding packages
- Increase version to 13.1
- update from git to update kde patch
- add a conflict for other xfce4-splash-branding (otherproviders
not necessary in 12.1+)
- fix dir conflict with grub2
- fix the %post of plymouth branding to still set openSUSE default
even if in live cd buildenv (bnc#804321)
- YaST installation hyperlink color darkened
- Plymouth statup/shutdown progress fade tuned
- one more update for the kdm colors
- Fix summary.
- (KDM) added support for domain logins
- (KDM) changed background color of userlist box
- Exclude upstream body-background
- Final 12.3 kdelibs branding
- Tuning to kdm branding
- Optimised plymouth theme file sizes
- gfxboot now using fifthleg font
- YaST2 installer theme using 12.3 green
- Cleaner plymouth boot theme with fade down on shutdown
- Improved Grub 2 Theme (ilmehtar & anditosan)
- Improved xfce splash (victorhck)
- Updated gfxboot backgrounds (tux93)
- Grub 2 Theme based on 12.3 grow design
- gfxboot art based on 12.3 grow design
- YaST installer art based on 12.3 grow design
- xfce splash based on 12.3 grow design
- gimp splash based on 12.3 grow design
- Fix Plymouth 4:3 aspect ratio so it shows vine design
- Plymouth now supports several aspect ratios
- Update of plymouth theme for 12.3 based on grow design
- Updated 12.3 KDM theme
- fix product version in gfxboot welcome screen
- update from git with kdm and kpslashx updates
- remove more bootsplash
- Restore gfxboot welcome text
- Initial 12.3 branding based on the 'grow' design
- bump version to 12.3 and get rid of bootsplash theming
- remove reference to grub2-efi-mkconfig (bnc#782891)
- add a /usr/share/libyui/theme symlink as long as yast looks there
for themeing
- Add new welcome text for install splash
- Update to the grub2 theme to include also the theming for
the terminal windows (bnc#770107)
- Add the openSUSE branding for the Plymouth bootsplash
- remove /boot/grub2/backgrounds
- let grub2-branding supplement grub2
- Fix grub2 config not update on UEFI system. (bnc#770031)
- make grub2 branding optional (for arm)
- reworked grub2 branding packages and named them grub2-branding-XXX
(changes are in git tree)
- Fixed sources for grub2 (now in gitorious -art repo)
- Removed patch for grub2
- Add grub2-gfxconsole branding package
- Fixes for bnc#763262 kdm theme, panel is again png due to
QSvgRender not able to handle full svg.
Default themes is now called openSUSE in place of SUSE (also
fixed in sysconfig/displaymanager
- Fixes for ksplash-qml-openSUSE bnc#763266 : openSUSE logo now
stick to size in kdm for smooth transition. KDE animation position
at better place.
- Fixes for bnc #763266 about ksplash-qml-openSUSE (bad name &
missing file main.qml
- Fixes for bnc #763262 size of boxes and logo, background for
users list.
- Add kdm branding for 12.2
- Add extra license for xfce subpackage (bnc#758793).
- Fully updated design for 12.2
- ksplash-qml-suse added
- Update summaries in subpackages.
- fix for bnc #742777: yast theme without background image
- initial update to 12.2 design
- bumb version
- fixed style of combo boxes (bnc# 725952)
- fix one colour code for yast
- fixed colors of scollbars in installation
- readd gimp as buildreqiures
- let kdm-branding provide the same version as branding-upstream
- Change gimp-branding-openSUSE packaging to not depend on the gimp
version, so we don't have to rebuild the package when gimp
changes.
- enable kdelibs diff now
- add gimp branding
- add a COPYING for the xfce splash screen
- add branding for xfce4 splash screen
- prepare to patch kdelibs4 branding from upstream
- Keep the touch required by update-alternatives here, instead of
moving it to the Makefile.
- Move check logic to the Makefile.
- move install logic in the Makefile
- Improve GNOME-related checks in %check so that they cover the
dynamic wallpaper and work with the new layout for static
wallpaper.
- Update openSUSE.tar.gz from git:
+ More aspect ratios supported
+ Updated dynamic GNOME wallpapers
- Update openSUSE.tar.gz from git:
+ Artwork has been updated.
+ Progress bar in bootsplash got removed since systemd doesn't
support it.
+ Now includes the files needed for GNOME wallpapers.
- Create dynamic-wallpaper-branding-openSUSE subpackage:
+ This contains the dynamic wallpaper as used in GNOME.
+ This replaces (with appropriate Provides/Obsoletes) the
previous openSUSE-dynamic-wallpaper package we had.
+ Install the files from the tarball needed for the dynamic
wallpaper.
+ Use update-alternatives in %post/%postun of this subpackage to
override the default wallpaper in GNOME: we prefer the dynamic
version over the static one.
- Drop wallpaper-branding-openSUSE.xml.in and
wallpaper-openSUSE-default-static.xml sources: they're now
shipped openSUSE.tar.gz, so we don't have to create them.
- Move various consistency checks from %install to %check.
- provide susegreeter-branding
- use jpg as kdm background
- add kdm theme from Marcus
- adopt ksplashx to new logo position
- move ksplashx and kde wallpaper here too
- update bootsplash graphics
- fix %ifarch logic - and update to azul previews
- Add missing update-alternatives Requires(post)/Requires(postun)
to wallpaper-branding-openSUSE, since this is now using
update-alternatives.
- gfxboot is only on x86_64 and %ix86
- Import logic for the XML file used by GNOME to describe the
default wallpaper from desktop-data-openSUSE:
+ Add wallpaper-branding-openSUSE.xml.in and
wallpaper-openSUSE-default-static.xml source files.
+ Check in %install that wallpaper-openSUSE-default-static.xml
lists the right default wallpapers.
+ Use update-alternatives in %post/%postun of
wallpaper-branding-openSUSE for the openSUSE-default.xml file.
- Remove unneeded GraphicsMagick, fam, inkscape and php5
BuildRequires.
- Add update-desktop-files and call %suse_update_desktop_file on
the .desktop files describing the wallpapers.
- fix backward compat
- move yast2-qt branding here
- integrate wallpaper logic here too
- move details logic into art's Makefile
- add gfxboot branding here
- add bootsplash branding here
- bump version
- increase version number.
- increase version number

==== libreoffice ====
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-draw
libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3
libreoffice-icon-themes libreoffice-impress libreoffice-kde4
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-hu
libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN
libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreofficekit

- Require xorg-x11-fonts otherwise nothing is shown
- Do not pull in liberation2-fonts wrt bsc#1077375#c5

==== libstorage-ng ====
Version update (3.3.112 -> 3.3.140)
Subpackages: libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#436
- added sanity check
- propagate exception to ruby
- 3.3.140
- merge gh#openSUSE/libstorage-ng#435
- propagate exception to ruby
- 3.3.139
- Translated using Weblate (Slovak)
- 3.3.138
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- 3.3.137
- Translated using Weblate (Spanish)
- 3.3.136
- Translated using Weblate (Polish)
- 3.3.135
- Translated using Weblate (Polish)
- 3.3.134
- Translated using Weblate (Slovak)
- 3.3.133
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- 3.3.132
- Translated using Weblate (Slovak)
- 3.3.131
- Translated using Weblate (Slovak)
- 3.3.130
- Translated using Weblate (Slovak)
- 3.3.129
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- 3.3.128
- Translated using Weblate (Slovak)
- 3.3.127
- Translated using Weblate (Slovak)
- 3.3.126
- Translated using Weblate (Slovak)
- Translated using Weblate (Slovak)
- 3.3.125
- merge gh#openSUSE/libstorage-ng#431
- Update libstorage-ng.spec.in
- 3.3.124
- merge gh#openSUSE/libstorage-ng#434
- find crypttab entries by correct block device
- coding style
- removed unused parameters
- Translated using Weblate (German)
- 3.3.123
- merge gh#openSUSE/libstorage-ng#433
- added helper function
- improved probing of LUKs
- added unit test
- allow to find unused mockups
- removed unused mockups
- use name from crypttab when activating LUKS
- allow to include more information in graphviz output
- removed unused parser
- 3.3.122
- Translated using Weblate (German)
- 3.3.121
- Translated using Weblate (Slovak)
- 3.3.120
- Translated using Weblate (German)
- 3.3.119
- merge gh#openSUSE/libstorage-ng#432
- updated
- 3.3.118
- merge gh#openSUSE/libstorage-ng#430
- Revert "Add libstorage-ng-lang Recommends"
- 3.3.117
- merge gh#openSUSE/libstorage-ng#429
- Add libstorage-ng-lang Recommends
- 3.3.116
- merge gh#openSUSE/libstorage-ng#428
- use /etc/fstab and /proc/mounts for probing NFS
- added NFS unit test
- 3.3.115
- merge gh#openSUSE/libstorage-ng#427
- extended integration test
- 3.3.114

==== obs-service-source_validator ====
Version update (0.9 -> 0.12)

- Update to version 0.12:
* fix for continous lines in macros
- Update to version 0.11:
* fix for macro continuation
* activating initial test cases
* .gitignore for vim swap files
- Update to version 0.10:
* Do not call helpers/spec_query with --unique-sources in 70-baselibs
* Keep if statements in line continuation contexts
* Fix --keep-name-conditionals code in helpers/spec_query

==== qemu ====
Subpackages: qemu-arm qemu-block-curl qemu-block-dmg qemu-block-gluster
qemu-block-iscsi qemu-block-rbd qemu-block-ssh qemu-extra qemu-ipxe qemu-ksm
qemu-kvm qemu-lang qemu-ppc qemu-s390 qemu-seabios qemu-sgabios qemu-tools
qemu-vgabios qemu-x86

- Modify BuildRequires python references
- seabios also needed tweaks for python2 vs python3
* Patches added:
seabios-use-python2-explicitly-as-needed.patch
seabios-switch-to-python3-as-needed.patch
- Try to get our story right wrt python2 vs python3 (bsc#1077564)
* Get rid of use of #!/usr/bin/env python in scripts we install
* include proposed upstream build system changes needed for building
with python2 or python3
* Patches dropped:
0032-scripts-avoid-usr-bin-python-refere.patch
* Patches renamed:
0033-Switch-order-of-libraries-for-mpath.patch
- > 0032-Switch-order-of-libraries-for-mpath.patch
0034-i386-kvm-MSR_IA32_SPEC_CTRL-and-MSR.patch
- > 0033-i386-kvm-MSR_IA32_SPEC_CTRL-and-MSR.patch
* Patches added:
0034-qapi-use-items-values-intead-of-ite.patch
0035-qapi-Use-OrderedDict-from-standard-.patch
0036-qapi-adapt-to-moved-location-of-Str.patch
0037-qapi-Adapt-to-moved-location-of-mak.patch
0038-qapi-remove-q-arg-to-diff-when-comp.patch
0039-qapi-ensure-stable-sort-ordering-wh.patch
0040-qapi-force-a-UTF-8-locale-for-runni.patch
0041-scripts-ensure-signrom-treats-data-.patch
0042-configure-allow-use-of-python-3.patch
0043-input-add-missing-JIS-keys-to-virti.patch
0044-Make-installed-scripts-explicitly-p.patch
Make-installed-scripts-explicitly-python3.patch
ui-keycodemapdb-Add-missing-QKeyCode-val.patch
ui-keycodemapdb-Fix-compat-with-py3-dict.patch
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.11
- Fix packaging dependencies (coreutils) for qemu-ksm package
(bsc#1040202)

==== qemu-linux-user ====

- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.11
* Patches dropped:
0032-scripts-avoid-usr-bin-python-refere.patch
* Patches renamed:
0033-Switch-order-of-libraries-for-mpath.patch
- > 0032-Switch-order-of-libraries-for-mpath.patch
0034-i386-kvm-MSR_IA32_SPEC_CTRL-and-MSR.patch
- > 0033-i386-kvm-MSR_IA32_SPEC_CTRL-and-MSR.patch
* Patches added:
0034-qapi-use-items-values-intead-of-ite.patch
0035-qapi-Use-OrderedDict-from-standard-.patch
0036-qapi-adapt-to-moved-location-of-Str.patch
0037-qapi-Adapt-to-moved-location-of-mak.patch
0038-qapi-remove-q-arg-to-diff-when-comp.patch
0039-qapi-ensure-stable-sort-ordering-wh.patch
0040-qapi-force-a-UTF-8-locale-for-runni.patch
0041-scripts-ensure-signrom-treats-data-.patch
0042-configure-allow-use-of-python-3.patch
0043-input-add-missing-JIS-keys-to-virti.patch
0044-Make-installed-scripts-explicitly-p.patch

==== ucode-intel ====

- Update to microcode version: 20171117 (bsc#1068839)
- - New Platforms --
CFL U0 (06-9e-0a:22) 70
CFL B0 (06-9e-0b:2) 72
SKX H0 (06-55-04:b7) 2000035
GLK B0 (06-7a-01:1) 1e
APL Bx (06-5c-09:3) 2c
- - Updates --
KBL Y0 (06-8e-0a:c0) 66->70
- Remove code in intel-microcode2ucode.c that refers to
GenuineIntel.bin , previously in binary blob package.
- Remove binary blob package again. This was intended to be used
by linuxrc, but the firmware files can simply be concatenated.
- Update to version 20170707 (bsc#1048133, bsc#1043358):
KBL H0 (06-8e-09:c0) 62
KBL Y0 (06-8e-0a:c0) 66
KBL B0 (06-9e-09:2a) 5e
SKX H0 (06-55-04:97) 2000022
- Update to version 20170511:
BDX-ML B0/M0/R0 (06-4f-01:ef) b00001f->b000021
Skylake D0 (06-4e-03:c0) 9e->ba
Broadwell ULT/ULX E/F-step (06-3d-04:c0) 24->25
ULT Cx/Dx (06-45-01:72) 1f->20
Crystalwell Cx (06-46-01:32) 16->17
Broadwell Halo E/G-step (06-47-01:22) 16->17
HSX EX E0 (06-3f-04:80) d->f
Skylake R0 (06-5e-03:36) 9e->ba
Haswell Cx/Dx (06-3c-03:32) 20->22
HSX C0 (06-3f-02:6f) 39->3a
- Update to version 20161104.
- Update to version 20160714.
- Should fix bsc#987358, a bug which got introduced with the last
release.
- Should finally fix "Intel Skylake bug" (bnc#993639), previous
releases since Jan 2016 may or may not have completely fixed it.
- Update to version 20160607, no changelog available
- Fix dependency on coreutils for initrd macros (boo#958562)
- Call missing initrd macro at postun (boo#958562)
- Fix Url and Source0
- Add GenuineIntel.bin to ucode-intel-blob
- Update to version 20151106
* No changelog available
- Use download Url as source
- Add ucode-intel-blob subpackage to get the full microcode.dat
directly
- Update to microcode 20150121.
- Pre require coreutils (bnc#914169).
- Do not try to reload/update microcode at runtime after package
installation. Only supported way of updating microcode is via
early microcode update via initrd. bnc#896736
- Update to Intel microcode version 20140624 (bnc#896736, fate#317896)
This microcode disables lock elision on CPUs which are known to
not work reliable with this feature
- Update to Intel microcode version 20140624 (bnc#885213)
- Delete mkinitrd scripts. This is done via %rpm regenerate_initrd_* macros
(bnc#894160)
- Update to Intel microcode version 20140430 (bnc#876073)
- Regenerate the initrd in %posttrans (fate#313506)
- ucode 20140122, no changelog available.
- Loading firmware needs udev to be running
- Add mkinitrd script to add Intel microcode to initrd.
This is needed because microcode driver is built in or gets loaded
automatically via udev early. Therefore the microcode has to be available
in initrd already.
This must not be mixed up with early micorcode loading. This feature will
not be implemented via mkinitrd. Dracut is doing early microcode loading.
- bnc#847158
- mkinitrd scripts:
- mkinitrd_setup-intel_microcode.sh
Adding microcode to the initrd
- mkinitrd_boot-intel_microcode.sh
Triggering the reload at boot
- Correct Supplements string so that the package gets correctly installed
on machines with Intel CPUs
bnc#847158
- ucode 20130906, no changelog available.
- ucode 20130808, as usual, no changelog available.
- Run spec-cleaner
- Initial packaging. Moved microcode from microctl_ctl package.

==== yast2 ====
Version update (4.0.35 -> 4.0.39)

- Firewalld: Added methods to the wrapper class for opening ports
by YaPI modules (fate#323460 bsc#1071548 bsc#1076837)
- 4.0.39
- CWM: Add possibility to define abort handler for CWM.show
(needed for expert partitioner fate#318196)
- 4.0.38
- Firewalld: Added missing firewalld service file to the Makefile
(fate#323460).
- 4.0.37
- CWMFirewallInterfaces: Replaced SuSEFirewall2 by firewalld.
(fate#323460)
- 4.0.36

==== yast2-country ====
Version update (4.0.16 -> 4.0.17)
Subpackages: yast2-country-data

- Unify openSUSE and SLE console fonts maps (bsc#1068814).
- 4.0.17

==== yast2-firewall ====
Version update (4.0.8 -> 4.0.9)

- AutoYaST: fixed default valur for log denied packets when using
SuSEFIrewall2 profiles (fate#323460)
- 4.0.9

==== yast2-installation ====
Version update (4.0.22 -> 4.0.26)

- Start performing real installation with as much memory as
possible (bsc#1076768)
- 4.0.26
- Read the root_subvolume_read_only setting from its new location
(moved by libstorage-ng) in the control file (boo#1077047).
- 4.0.25
- save keyboard settings before console settings (bsc#1076798)
- 4.0.24
- Update YaST2-Firstboot.service: Depreciate plymouth --wait, add
conflict to plymouth start service.
- Update YaST2-Second-Stage.service: Depreciate plymouth deactivate
command and add conflict to plymouth start service. For that will
block TTY device activation(bsc#1042554).
- 4.0.23

==== yast2-network ====
Version update (4.0.13 -> 4.0.14)

- bnc#1056109
- improved device name collision recognition when applying device
renaming according to the AY profile
- 4.0.14

==== yast2-packager ====
Version update (4.0.29 -> 4.0.32)

- Display a correct product license and release notes at upgrade
from SLE12, correctly filter out the old installed products
(fate#1076513)
- 4.0.32
- Hot fix for big memory consumption during NET installer with
whole TW repo (bsc#1076768)
- 4.0.31
- Do not display the license again when going back (bsc#1069124)
- 4.0.30

==== yast2-pkg-bindings ====
Version update (4.0.5 -> 4.0.6)

- Log more details in PkgQueryProvides call
(related to bsc#1072634)
- 4.0.6

==== yast2-storage-ng ====
Version update (4.0.70 -> 4.0.76)

- Properly detect snapshots subvolumes (bsc#1076321 and
bsc#1076335).
- 4.0.76
- Partitioner: allow to resize LVM volume groups.
- Part of fate#318196.
- 4.0.75
- Partitioner: consider all sizes entered by the user as base of 2
despite the units not being consistent with the International
System. Thus, 1KB (which in the IS actually means 1000 bytes)
becomes equivalent to 1KiB (which is 1024 bytes).
- fix proposal dialog error when there are no disks (bsc#1057430)
- Avoid partitioning checks error when using old settings format.
- Needed for bsc#1059160, bsc#1055747 and bsc#1063957.
- Partitioner: button to resize LVM logical volumes now works as
expected (part of fate#31896).
- 4.0.74
- Consider all free spaces when deciding which partitions
distribution is better (bsc#1077051).


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups