Mailinglist Archive: opensuse-factory (745 mails)

< Previous Next >
Re: [opensuse-factory] new requirement bundle-lang-common-ar, re: New Tumbleweed snapshot 20180117 released!
20.01.2018 15:41, Patrick Shanahan пишет:
* Andrei Borzenkov <arvidjaar@xxxxxxxxx> [01-20-18 01:46]:
20.01.2018 09:24, Andrei Borzenkov пишет:
20.01.2018 01:11, Patrick Shanahan пишет:

You can workaround it by pre-installing the "correct"
bundle-common-lang-XX (probably XX == en). But this also means there is
no indication what language user prefers. Do we have any place where
locales user wants to have on the system are recorded?


Looking at my TW VM I have bundle-lang-common-en which apparently comes
via Supplements namespace:language(en). Are you running with
no-recommends by default?

yes

But anyway, this sounds wrong. Requires does not offer any means to
select the right package so the whole still relies on the correct
package being selected by Supplements; but then what is the print of
using Requires in the first place?

since en/english is default, there is no need or I have failed for years
to find a need to install "lang" packages and have none on my system(s).

Yes, that's why I think this Requires is wrong. Message catalogs hardly
can be considered mandatory.
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >