Mailinglist Archive: opensuse-factory (400 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20180109 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20180109

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
amarok
apache2
aspell-en (2016.11.20 -> 2017.08.24)
attica-qt5 (5.40.0 -> 5.41.0)
baloo5 (5.40.0 -> 5.41.0)
bluez-qt (5.40.0 -> 5.41.0)
breeze5-icons (5.40.0 -> 5.41.0)
cmake
doxygen (1.8.13 -> 1.8.14)
epiphany (3.26.3 -> 3.26.5.1)
extra-cmake-modules (5.40.0 -> 5.41.0)
frameworkintegration (5.40.0 -> 5.41.0)
fstrm (0.2.0 -> 0.3.2)
gegl-unstable (0.3.20 -> 0.3.26)
gtk2 (2.24.31 -> 2.24.31+20171209.61d5c82f5c)
icu (59.1 -> 60.2)
kactivities-stats (5.40.0 -> 5.41.0)
kactivities5 (5.40.0 -> 5.41.0)
karchive (5.40.0 -> 5.41.0)
kauth (5.40.0 -> 5.41.0)
kbookmarks (5.40.0 -> 5.41.0)
kcmutils (5.40.0 -> 5.41.0)
kcodecs (5.40.0 -> 5.41.0)
kcompletion (5.40.0 -> 5.41.0)
kconfig (5.40.0 -> 5.41.0)
kconfigwidgets (5.40.0 -> 5.41.0)
kcoreaddons (5.40.0 -> 5.41.0)
kcrash (5.40.0 -> 5.41.0)
kdbusaddons (5.40.0 -> 5.41.0)
kdebase4-workspace
kdeclarative (5.40.0 -> 5.41.0)
kded (5.40.0 -> 5.41.0)
kdelibs4support (5.40.0 -> 5.41.0)
kdesignerplugin (5.40.0 -> 5.41.0)
kdesu (5.40.0 -> 5.41.0)
kdewebkit (5.40.0 -> 5.41.0)
kdnssd-framework (5.40.0 -> 5.41.0)
kdoctools (5.40.0 -> 5.41.0)
kemoticons (5.40.0 -> 5.41.0)
kfilemetadata5 (5.40.0 -> 5.41.0)
kglobalaccel (5.40.0 -> 5.41.0)
kguiaddons (5.40.0 -> 5.41.0)
khtml (5.40.0 -> 5.41.0)
ki18n (5.40.0 -> 5.41.0)
kiconthemes (5.40.0 -> 5.41.0)
kidletime (5.40.0 -> 5.41.0)
kimageformats (5.40.0 -> 5.41.0)
kinit (5.40.0 -> 5.41.0)
kio (5.40.0 -> 5.41.0)
kirigami2 (5.40.0 -> 5.41.0)
kitemmodels (5.40.0 -> 5.41.0)
kitemviews (5.40.0 -> 5.41.0)
kjobwidgets (5.40.0 -> 5.41.0)
kjs (5.40.0 -> 5.41.0)
kjsembed (5.40.0 -> 5.41.0)
kmediaplayer (5.40.0 -> 5.41.0)
knewstuff (5.40.0 -> 5.41.0)
knotifications (5.40.0 -> 5.41.0)
knotifyconfig (5.40.0 -> 5.41.0)
kpackage (5.40.0 -> 5.41.0)
kparts (5.40.0 -> 5.41.0)
kpeople5 (5.40.0 -> 5.41.0)
kplotting (5.40.0 -> 5.41.0)
kpty (5.40.0 -> 5.41.0)
kross (5.40.0 -> 5.41.0)
krunner (5.40.0 -> 5.41.0)
kservice (5.40.0 -> 5.41.0)
ksmtp
kteatime
ktexteditor (5.40.0 -> 5.41.0)
ktextwidgets (5.40.0 -> 5.41.0)
kunitconversion (5.40.0 -> 5.41.0)
kwallet (5.40.0 -> 5.41.0)
kwayland (5.40.0 -> 5.41.0)
kwidgetsaddons (5.40.0 -> 5.41.0)
kwindowsystem (5.40.0 -> 5.41.0)
kxmlgui (5.40.0 -> 5.41.0)
kxmlrpcclient5 (5.40.0 -> 5.41.0)
libKF5ModemManagerQt (5.40.0 -> 5.41.0)
libKF5NetworkManagerQt (5.40.0 -> 5.41.0)
libabw (0.1.1 -> 0.1.2)
libeXosip2 (4.1.0 -> 5.0.0)
libgda
libkipi
libmspub (0.1.2 -> 0.1.3)
libqt4
libreoffice (5.4.3.2 -> 6.0.0.1)
libyaml (0.1.6 -> 0.1.7)
opencc
oxygen5-icon-theme (5.40.0 -> 5.41.0)
perl-Archive-Zip (1.59 -> 1.60)
perl-DBI (1.637 -> 1.639)
perl-DateTime (1.44 -> 1.45)
perl-HTTP-Message (6.13 -> 6.14)
perl-JSON (2.97000 -> 2.97001)
perl-Moose (2.2006 -> 2.2009)
perl-Net-DNS (1.13 -> 1.14)
perl-PadWalker (2.2 -> 2.3)
perl-Set-Object (1.38 -> 1.39)
plasma-framework (5.40.0 -> 5.41.0)
poppler (0.61.1 -> 0.62.0)
poppler-qt5 (0.61.1 -> 0.62.0)
prison-qt5 (5.40.0 -> 5.41.0)
remmina (1.2.0~rcgit.24 -> 1.2.0~rcgit.26)
solid (5.40.0 -> 5.41.0)
sonnet (5.40.0 -> 5.41.0)
syntax-highlighting (5.40.0 -> 5.41.0)
threadweaver (5.40.0 -> 5.41.0)

=== Details ===

==== amarok ====
Subpackages: amarok-lang

- Add patch to avoid automatic network requests (boo#1070899):
* disable-web-plugins-by-default.patch
- Also disable all scripts by default
- Fix loading of scripts:
* load-scrips-without-qca.patch

==== apache2 ====
Subpackages: apache2-devel apache2-doc apache2-example-pages apache2-prefork
apache2-utils

- build brotli module
- Do not requires w3m, only recommends it.
- do not build with nghttp2 for SLE-12-SP3
- which was split after SLE11

==== aspell-en ====
Version update (2016.11.20 -> 2017.08.24)

- updated to 2017.08.24
* various new words (see SCOWL-README for other changes)

==== attica-qt5 ====
Version update (5.40.0 -> 5.41.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* We depend against 5.7

==== baloo5 ====
Version update (5.40.0 -> 5.41.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Jenkins build fix. (type change)
* Strip down and re-write the baloo tags KIO slave (kde#314373, kde#340098,
kde#376229, kde#332214, kde#340099)
* Remove unused config.h.cmake entries

==== bluez-qt ====
Version update (5.40.0 -> 5.41.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Do not leak rfkill file descriptors. (kde#386886)

==== breeze5-icons ====
Version update (5.40.0 -> 5.41.0)

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Add missing icon sizes (kde#384473)
* add install and uninstall for discover
* add install and uninstall icons for discover

==== cmake ====

- Add feature-suse-python-interp-search-order.patch to make sure
that python3 is found before python2
- switch to using %autopatch
- Do not add no-undefined on module linking, should reduce us a bit
of redefining as most modules dynamically load stuff
- Add cmake-3.10.1_boost-1.66.patch to fix detection of Boost 1.66
(fixes boo#1074314 among other boost-dependant cmake-users)

==== doxygen ====
Version update (1.8.13 -> 1.8.14)

- Update to 1.8.14:
* Many fixes during the one year development cycle:
http://www.stack.nl/~dimitri/doxygen/manual/changelog.html#log_1_8_14
- Switch to python3 instead of python2
- Remove upstream merged doxygen-guard-null-variable.patch
- Refresh patch vhdlparser-no-return.patch
- Kill doxygen-doc subpackages the latex deps keep growing while
it is really easy to download the generated pdfs from upstream

==== epiphany ====
Version update (3.26.3 -> 3.26.5.1)
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Add epiphany-application-mode-fix-desktopfile.patch: application
mode: use strstr() to get base name of the desktop file
(bgo#790781).
- Update to version 3.26.5.1:
+ Correct logic to avoid corrupting session state.
+ Updated translations.
- Update to version 3.26.5:
+ Fix error in sync migration when migrating from 3.26.2 or
earlier.
+ Improved logic to avoid corrupting session state.
- Drop epiphany-session-rework-the-safety-check.patch: Fixed
upstream.
- Update to version 3.26.4:
+ Fix sync failure warnings appearing multiple times
(bgo#790094).
+ Fix tab sync and device name on accounts.firefox.com
(bgo#790370).
+ Make default sync device name translatable (bgo#790905).
+ Several additional misc. improvements to sync support
(including bgo#790819).
+ Flatpak: custom stylesheets are now supported.
+ Flatpak: view page source is now supported.
- Add epiphany-session-rework-the-safety-check.patch: session:
Rework the safety check.

==== extra-cmake-modules ====
Version update (5.40.0 -> 5.41.0)
Subpackages: extra-cmake-modules-doc

- Use python3 sphinx to generate the documentation module
- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Add the description tag to the generated pkgconfig files
* ecm_add_test: Use proper path sep on Windows
* Fix variable name
* restore old behaviour of FindPulseAudio
* Remove FindSasl2.cmake from the ECM's attic.
* Delete the .reviewboardrc file.
* Add FindSasl2.cmake to ECM
* Only pass the ARGS thing when doing Makefiles
* Remove FindGLIB2.cmake and FindPulseAudio.cmake from attic
* Add FindGLIB2.cmake and FindPulseAudio.cmake
* ECMAddTests: set QT_PLUGIN_PATH so locally built plugins can be found
* KDECMakeSettings: more docu about the layout of the build dir

==== frameworkintegration ====
Version update (5.40.0 -> 5.41.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* We depend against qt5.7
* Support downloading the 2nd or 3rd download link from a KNS product
(kde#385429)

==== fstrm ====
Version update (0.2.0 -> 0.3.2)

- Compact description. Fix RPM groups.
- update to 0.3.2
* Accommodate systems without pthread_condattr_setclock
- 0.3.1
* Add support for '-' as a filename for stdin/stdout
* Destroy condition variable and mutexes in fstrm_iothr_destroy()
- 0.3.0
* Output file rotation
* Change state properly in fstrm_writer_close()
* force output flush on sighup
* Build on OS X
- cleanup with spec-cleaner
- use dist tarball instead of github archive

==== gegl-unstable ====
Version update (0.3.20 -> 0.3.26)
Subpackages: gegl-0_3 libgegl-0_3-0

- Update to version 0.3.26:
+ Core:
- Make gegl-chain parser more robust wrt parsing babl formats,
and improved - translatable - error handling.
- Add capabilitity to use per thread input buffers for
multi-threaded filter/composer/composer3 ops, this reduces
contention over the buffer tile locks and improves
multi-threaded performance in some cases without reducing it
for the majority of cases.
+ Buffer:
- Threads no longer blocked while locking tiles, and fixes to
gegL_buffer_copy.
- Better clone accounting in tile cache.
+ Operations:
- exp-combine: code cleanup/simplification.
- libraw: make bounding box handling consistent with rest of
code.
- transform ops: re-enabled multi-threading, reduced some
format conversions and added wiggle-room in
required/invalidated calculations.
- Changes from version 0.3.24:
+ Core:
- Flush opencl side buffers before multi threaded iteration for
point ops, making multi threading + opencl work.
- Add meta-op graph case to gegl_operation_get_source_node.
- Versioning of installed .mo files restored.
- Enable multi-threaded processes by default.
- Stop enabling opencl by default, performance with beignet is
worse than multi-threading, and with nvidia blank results are
being observed in GIMP; maybe improved opencl kernels would
make it competetive with multi threaded cpu?
- Deprecate gegl_operation_context_get_source, replace usage
with gegl_operation_context_get_object.
+ Buffer: More multi-thread proofing.
+ Operations:
- median-blur: now op coming out of the GEGL workshop.
- exposure: increase old lingering constant enabling larger
range of valid inputs.
- transform: turn off multi-threading, it was currently
degrading overall performance.
- ppm-load: fix file-loader registration.
- Changes from version 0.3.22:
+ Core:
- Refactored graph traversals to use topological sorts.
- Completely avoid loading plug-ins .so with -gpl3 in filename
unless the application using GEGL explicitly has enabled GPL3
operations.
- Replace custom property redirection for meta-ops with
GBinding.
- Reduced temporary buffer allocation overhead in mipmap
downscaling.
- Do divide and conquer on higher level in point
filter/composer op base-classes.
- Migrated from intltool to GNU gettext.
+ Buffer: Tweak nohalo and lohalo samplers to be orders of
magnitude faster for scale factors > ~3% while also removing
possible hangs.
+ Operations:
- Improved threading awareness/capabilities of
gegl:copy-buffer, gegl:wind, gegl:color-enhance,
gegl:photocopy, gegl:matting-levin, npd, contrast-curve,
noise-spread, noise-pick, noise- slur, transform ops.
- Use of more modern GLib APIs like g_clear_ and make use of
the fact that g_free is already NULL safe.
- Fixed grayscale behavior of gegl:noise-hurl.
- OpenCL vs CPU consistency fix for gegl:threshold, and
optimization of gegl:wavelet-blur by decomposing to two 1d
passes.
- median-blur, perform binning in a more perceptual space.
- hue-chroma: added OpenCL support.
- threshold: make opencl match cpu.
- wavelet-blur: decompose for performance.
- illusion: performance improvement permitting partial result
computation.
- grey: add fast path for alpha-less input buffers.
- new ops in workshop: spherize, color-to-alpha-plus,
shadows-highlights.
- Drop intltool BuildRequires: No longer needed following upstream
port to gettext.

==== gtk2 ====
Version update (2.24.31 -> 2.24.31+20171209.61d5c82f5c)
Subpackages: gtk2-data gtk2-devel gtk2-immodule-amharic gtk2-immodule-inuktitut
gtk2-immodule-thai gtk2-immodule-vietnamese gtk2-immodule-xim gtk2-lang
gtk2-tools gtk2-tools-32bit libgtk-2_0-0 libgtk-2_0-0-32bit typelib-1_0-Gtk-2_0

- Sync summaries with gtk4.
- Manually move the position of "Group System/Libraries" line,
which was moved automatically by format_spec_file, above the
comment of "Requires: hicolor-icon-theme":
https://lists.opensuse.org/opensuse-packaging/2017-07/msg00062.html
- Update to version 2.24.31+20171209.61d5c82f5c:
+ Fix updating the widget accessible description when using its
tooltip
+ Fix introspection builds on Visual Studio 2017
+ imcontextxim: Fix showing glyph in status window
+ Visual Studio builds: Improve binary security
+ Fixed: If can?t add child, don?t add to child info
+ ComboBox: Don?t let modes disconnect each other
+ Enter submenus when activating their parent item
+ ComboBox: Don?t pile up ::grab-broken handlers
+ testcombo: Test grid :row- and :column-span-column
+ Updated translations.
- Switch to git checkout via source service.
- Following the above, remove gnome-common BuildRequires and
gnome-autogen.sh call. Replace with libtool BuildRequires and
autogen.sh call, also add gtk-doc BuildRequires and pass
- -enable-gtk-doc to configure.
- Clean up patch numbering.
- Drop gtk2-window-dragging.patch: Fixed upstream (bgo#554057).
- Drop bugzilla-131498-allow-xim-for-all-languages.patch: This
patch was only applied to work around a missing recommends for
scim-32Bit, stop doing that, as we should not fix errors in other
packages in a toolkit.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.

==== icu ====
Version update (59.1 -> 60.2)

- Drop dangling symlinks /usr/lib64/icu/*.inc
- Update to new upstream release 60.2
* ICU 60 provides full support for the Unicode 10.0 release
with many new characters and many property improvements.
Locale data is updated to CLDR 32, which adds several
languages and data improvements. A new number formatting API
has been added.

==== kactivities-stats ====
Version update (5.40.0 -> 5.41.0)

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Start fixing libKActivitiesStats.pc:

==== kactivities5 ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Qt5Core is required.
* Fix race that starts kactivitymanagerd multiple times
* Remove code duplication

==== karchive ====
Version update (5.40.0 -> 5.41.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kauth ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kauth-devel libKF5Auth5 libKF5Auth5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* We depend against 5.7
* Allow to only build the kauth-policy-gen code generator
* Add a note about calling the helper from multithreaded applications.

==== kbookmarks ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5 libKF5Bookmarks5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* do not show edit bookmarks action if keditbookmarks is not installed
* port from deprecated KAuthorized::authorizeKAction to authorizeAction
* cleanup and sort headers

==== kcmutils ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kcmutils-devel libKF5KCMUtils5 libKF5KCMUtils5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* keyboard navigation in and out QML kcms

==== kcodecs ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kcodecs-devel libKF5Codecs5 libKF5Codecs5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Port to qCDebug

==== kcompletion ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kcompletion-devel libKF5Completion5 libKF5Completion5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Do not crash when setting new line edit on an editable combo box
* KComboBox: Return early when setting editable to previous value
* KComboBox: Reuse the existing completion object on new line edit
* Fix some clzay warning
* API dox: don't refer to being "KDE" widgets, use class names intead

==== kconfig ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5
libKF5ConfigCore5-lang libKF5ConfigGui5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* KConfig: fix autotest on CI with trailing slash in HOME.
* Repair broken test after commit ee2b394599.
* Fix some clazy warning
* Use Q_FALLTHROUGH
* Don't look for /etc/kderc every single time

==== kconfigwidgets ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5 libKF5ConfigWidgets5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Convert qWarning to qCWarning
* Port to qCDebug
* Update default colors to match new colors in D7424

==== kcoreaddons ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kcoreaddons-devel kcoreaddons-lang libKF5CoreAddons5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Autotest: fix for HOME having a trailing slash
* Input validation of SubJobs
* Warn about errors when parsing json files
* Install mimetype definitions for kcfg/kcfgc/ui.rc/knotify & qrc files
* Add a new function to measure the length by text.
* Keep widgets optional, as it's a test
* Look for Qt5 rather than Qt5Widgets
* Remove unused code
* Fix KAutoSave bug on file with white space in it

==== kcrash ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kdbusaddons ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5
libKF5DBusAddons5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Use qCDebug/qCWarning

==== kdebase4-workspace ====

- Remove Requires: polkit-kde-agent-1 as it got dropped

==== kdeclarative ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5Declarative5-lang libKF5QuickAddons5

- Dropped patches, now upstream:
- MouseEventListener-Allow-accepting-mouse-event.patch

==== kded ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kded-devel kded-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* We depend against 5.7
* kded: remove dbus calls to ksplash.

==== kdelibs4support ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kdelibs4support-devel kdelibs4support-lang libKF5KDELibs4Support5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kdesignerplugin ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* It compiles fine with QT_NO_CAST_FROM_ASCII

==== kdesu ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kdesu-devel libKF5Su5 libKF5Su5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kdewebkit ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kdnssd-framework ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5 libKF5DNSSD5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Make it compiles
* Make it compiles with strict flags
* It compiles fine with QT_NO_CAST_FROM_BYTEARRAY

==== kdoctools ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kdoctools-devel kdoctools-lang libKF5DocTools5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Update Brasilian Portuguese translation
* Update Russian translation
* Update Russian translation
* Update customization/xsl/ru.xml (nav-home was missing)

==== kemoticons ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Build with QT_NO_CAST_FROM_ASCII
* KEmoticons: port plugins to JSON and add support for loading with
KPluginMetaData
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Code cleanups

==== kfilemetadata5 ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kfilemetadata5-devel kfilemetadata5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* The usermetadatawritertest requires Taglib. Therefore if Taglib isn't
around, we shouldn't try to build something that requires it. This fixes the
build on Windows.
* Port to debug category
* Fix UserMetaData unit tests.
* User meta data (xattr key-value) unit tests.
* Simplify empty rating check.
* If the property value is null, remove the user.xdg.tag attribute.
(kde#376117)
* Open files in TagLib extractor readonly

==== kglobalaccel ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccel5-lang libKF5GlobalAccelPrivate5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Remove double look-up
* Group some blocking dbus calls
* We depend against 5.7
* kglobalacceld: Avoid loading an icon loader for no reason
* generate correct shortcut strings
* Port to debug category

==== kguiaddons ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== khtml ====
Version update (5.40.0 -> 5.41.0)
Subpackages: khtml-devel libKF5KHtml5 libKF5KHtml5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== ki18n ====
Version update (5.40.0 -> 5.41.0)
Subpackages: ki18n-devel libKF5I18n5 libKF5I18n5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kiconthemes ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kiconthemes-devel libKF5IconThemes5 libKF5IconThemes5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* We depend against 5.7

==== kidletime ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kimageformats ====
Version update (5.40.0 -> 5.41.0)

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kinit ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kinit-devel kinit-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kio ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kio-core kio-devel kio-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Too many changes to list here
- Dropped patches, now upstream:
* kio-5.40-fix-directory-creation.patch

==== kirigami2 ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kirigami2-lang libKF5Kirigami2-5

- Remove baselibs.conf:
* Not needed
* Update to 5.41.0

==== kitemmodels ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Update comment for new Qt 5.10 API
* Port to qCDebug

==== kitemviews ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kitemviews-devel libKF5ItemViews5 libKF5ItemViews5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kjobwidgets ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5 libKF5JobWidgets5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kjs ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kjs-devel kjs-devel-lang libKF5JS5 libKF5JSApi5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kjsembed ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kjsembed-devel libKF5JsEmbed5 libKF5JsEmbed5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kmediaplayer ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kmediaplayer-devel libKF5MediaPlayer5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== knewstuff ====
Version update (5.40.0 -> 5.41.0)
Subpackages: knewstuff-core-devel knewstuff-devel libKF5NewStuff5
libKF5NewStuff5-lang libKF5NewStuffCore5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Fix some clazy warning
* Revert "Detach before setting the d pointer" (kde#386156)
* do not install development tool to aggregate desktop files
* [knewstuff] Do not leak ImageLoader on error

==== knotifications ====
Version update (5.40.0 -> 5.41.0)
Subpackages: knotifications-devel libKF5Notifications5 libKF5Notifications5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Make it compile with QT_NO_CAST_FROM_ASCII
* Add explicit
* We already depend against 5.7.0

==== knotifyconfig ====
Version update (5.40.0 -> 5.41.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5 libKF5NotifyConfig5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Build with strict compile flags

==== kpackage ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kpackage-devel kpackage-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Fix trivial clazy warnings
* Properly do strings in the kpackage framework
* Don't try to generate metadata.json if there's no metadata.desktop
* fix kpluginindex caching
* Improve error output

==== kparts ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kparts-devel libKF5Parts5 libKF5Parts5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* KPartsApp template: remove bogus translation strings

==== kpeople5 ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kpeople5-devel kpeople5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kplotting ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kpty ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kpty-devel libKF5Pty5 libKF5Pty5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== kross ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kross-devel kross-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== krunner ====
Version update (5.40.0 -> 5.41.0)
Subpackages: krunner-devel libKF5Runner5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Fix some clazy wrning
* Autogenerate it too
* Remove unused include
* Port to autogenerated category file
* KRunner template: remove bogus translation strings

==== kservice ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kservice-devel kservice-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Fix compile with QT_NO_CAST_FROM_ASCII

==== ksmtp ====
Subpackages: ksmtp-lang libKPimSMTP5

- Add another patch to fix sending of emails with certain servers:
* 0002-Send-the-correct-hostname-with-the-HELO-EHLO-command.patch
* Fixed kde#387926

==== kteatime ====
Subpackages: kteatime-lang

- Remove unused Qt5DBus and libqimageblitz-devel build requirements
(the latter is Qt4-based anyway)

==== ktexteditor ====
Version update (5.40.0 -> 5.41.0)
Subpackages: ktexteditor-devel ktexteditor-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Use directly QStringLiteral
* We depend against 5.7
* API dox: fix section id
* Plugin template: remove bogus translation strings
* Fix VI-Mode buffer commands
* Remove unused member variable
* prevent accidental zooming.
* autotests: Remove dep on Qt5::Script again
* Fix: Missing dependencies for ktexeditor autotests

==== ktextwidgets ====
Version update (5.40.0 -> 5.41.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5 libKF5TextWidgets5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Convert it
* Port to new connect api (when possible)

==== kunitconversion ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5
libKF5UnitConversion5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Port from QDom to QXmlStreamReader
* Use https for downloading currency exchange rates
* Remove some remove_definition

==== kwallet ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 kwalletd5-lang libKF5Wallet5
libkwalletbackend5-5

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Fix some clazy warning
* Port to qCDebug
* Remove some remove_definition
* Port to qCDebug

==== kwayland ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kwayland-devel

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Fix testWaylandFullscreenShell.
* Expose wl_display_set_global_filter as a virtual method
* Fix kwayland-testXdgShellV6.
* Add support for zwp_idle_inhibit_manager_v1
* [server] Support inhibiting the IdleInterface

==== kwidgetsaddons ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5 libKF5WidgetsAddons5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Avoid inconsistent passworddialog
* Set enable_blur_behind hint on demand.
* KDateComboBox: port to Qt5 connect syntax, remove Q_PRIVATE_SLOTs.
* autotests: replace member with local scoped pointer
* KPageListView: Update width on font change

==== kwindowsystem ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5 libKF5WindowSystem5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* [KWindowEffectsPrivateX11] Add reserve() call

==== kxmlgui ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kxmlgui-devel libKF5XmlGui5 libKF5XmlGui5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Compile with stricter compilation flags
* Use qCDebug
* Fix translation of toolbar name when it has i18n context

==== kxmlrpcclient5 ====
Version update (5.40.0 -> 5.41.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5 libKF5XmlRpcClient5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== libKF5ModemManagerQt ====
Version update (5.40.0 -> 5.41.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== libKF5NetworkManagerQt ====
Version update (5.40.0 -> 5.41.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Remove redundant map look-ups
* Don't do unnecessary QString allocations to convert parts of it into strings

==== libabw ====
Version update (0.1.1 -> 0.1.2)

- Version update to 0.1.2:
* Fix several issues identified by Coverity.
* Parse paragraph and cell borders.
* Improve parsing of lists.
* Fix build with boost >= 1.59.
* Make the output of abw2* --help more compatible with help2man.
* Fix various problems when parsing broken files found by oss-fuzz.
* Require C++11 for build.
* Parse fields. (tdf#74466)
* Parse floating (not inline) images. (tdf#74463)
* Parse text boxes.
* Drop outdated MSVC project files.
* Set minimal width/height of inline images (which usually do not have
dimensions set in the file) to 1 inch. (tdf#74462)

==== libeXosip2 ====
Version update (4.1.0 -> 5.0.0)

- Update to 5.0.0:
* major API update: add a new parameter to eXosip_call_build_prack in order
to create the PRACK
for this specific response and not for the latest.
* major API update: removal of eX_refer.h API. REFER are now handled with
subscriptions APIs.
eXosip_refer_build_request removed
eXosip_refer_send_request removed
* major API update: subscription now handle both SUBSCRIBE and REFER with the
same APIs:
eXosip_subscription_build_initial_refer ADDED
eXosip_subscribe_build_initial_request renamed
eXosip_subscription_build_initial_subscribe
eXosip_subscribe_send_initial_request renamed
eXosip_subscription_send_initial_request
eXosip_subscribe_build_refresh_request renamed
eXosip_subscription_build_refresh_request
eXosip_subscribe_send_refresh_request renamed
eXosip_subscription_send_refresh_request
eXosip_subscribe_remove renamed eXosip_subscription_remove
EXOSIP_IN_SUBSCRIPTION_* and EXOSIP_SUBSCRIPTION_* events may now relate to
REFER subscription.
* major API change: eXosip_automatic_refresh is obsolete and has been removed.
only use eXosip_automatic_action instead
* API update:
eXosip_options_send_request returns a positive transaction id (tid) on
success.
eXosip_publish returns a positive transaction id (tid) on success.
note: eXosip_message_send_request was already returing the transaction id
(tid) on success.
* new API options:
EXOSIP_OPT_REMOVE_PREROUTESET: to keep Route Set
EXOSIP_OPT_SET_SIP_INSTANCE: define +sip.instance parameter in Contact headers
EXOSIP_OPT_ENABLE_USE_EPHEMERAL_PORT: option to use/not use ephemeral port in
Contact.
EXOSIP_OPT_ENABLE_REUSE_TCP_PORT: option to reuse port.
EXOSIP_OPT_AUTO_MASQUERADE_CONTACT: option to enable automatic masquerading
for Contact headers.
EXOSIP_OPT_UDP_LEARN_PORT: obsolete and will be removed in the future.
EXOSIP_OPT_SET_DEFAULT_CONTACT_DISPLAYNAME: define a display name to be added
in Contact headers
* new API options: (high load traffic use-case: DO NOT USE FOR COMMON USAGE)
EXOSIP_OPT_SET_MAX_MESSAGE_TO_READ: set the number of message to read at once
for each network processing.
EXOSIP_OPT_SET_MAX_READ_TIMEOUT: set the period in nano seconds during we
read for sip message.
EXOSIP_OPT_GET_STATISTICS: retreive numerous statistics.
* rewrite/update autotools and ./configure options
- -enable-pthread=[autodetect|force]
autodetect POSIX threads or force -DHAVE_PTHREAD [default=autodetect]
- -enable-semaphore=[autodetect|semaphore|sysv]
select your prefered semaphore [default=autodetect].
* fix bug when reading sip message longuer than 8000 over UDP and TLS.
* improve eXosip_add_authentication_info to avoid duplicate credentials
* if a SUBSCRIBE is rejected, the context will be released automatically
* add failover after a DNS failure.
* fallback to SRV even if we receive a NOTFOUND reply for NAPTR.
* fix route set with strict router.
* rename usage of -DHAVE_CARES_H into -DHAVE_ARES_H real name of header.
* remove warnings mainly related to socket API
(getnameinfo/bind/accept/recv/connect/sendto)
* rewrite all loop using iterator to improve performance (useful for high
load traffic)
* rewrite Via and Contact management: both will now contains the IP of the
real network interface
instead of the default one.
* improve NAPTR failover, more reliable // add failover for 503 answer
* improve interval to force REGISTER refresh upon network error and failover.
* improve TCP socket management
* add a callback to simplify/optimize/accelerate usage of wakelocks in
android application using exosip2.
* improve TLS, add TLSv1.1, TLSv1.2, disable weak cipher (FREAK) and enable
ECDHE cipher.
* add support for SNI tls extension (openssl 1.0.2)
* add try/except on windows to catch possible missing qwave (windows server)
* implement a timeout (32 seconds) for establishing a TCP and TLS connection.
* if a connection is failing, report the failure asap.
* fix memory leak in eXosip_call_get_referto
* remove extra connect on socket for TCP and TLS (not allowed for tcp stream)
* fix to correctly discard INVITE retransmission with same branch received
after original INVITE was replied
* add WSACleanup for each WSAStartup call (windows)
* do not include contact in BYE and CANCEL
* fix to use sips when appropriate (in Contact)
* fix to avoid handling negative content-length
* do not start naptr for incoming transactions.
* fix bug when rseq is empty but exist
* add support for QOS on windows.
* improve connection handling/failure detection, keep alive options, in TLS,
TCP, UDP.
* update static IDs (cid/did/rid/pid) to use range from 0 to INT_MAX to avoid
possible collision
* other minor updates.
- Drop libeXosip2-sslverifypaths.patch: fixed upstream.
- Add openssl110-fix.patch: fix build with openssl 1.1.0.

==== libgda ====
Subpackages: libgda-5_0-4 libgda-5_0-4-lang libgda-5_0-bdb libgda-5_0-sqlite
libgda-ui-5_0-4 libgda-ui-5_0-plugins

- Added patches:
* libgda-jre10.patch: detect JRE 10's version string.
* libgda-5.2.4-nojavah.patch: instead of javah invocation, use
javac's -h option; this bumps build requirement to
java-devel >= 1.8
- Modified patches:
* libgda-jre18.patch
* libgda-jre9.patch
+ Don't patch generated configure, but the source java.m4 file
- Run spec cleaner and add dependency on autoconf, automake and
libtool in order to regenearate the configure and Makefile.in
files.

==== libkipi ====
Subpackages: libKF5Kipi32_0_0 libkipi-data libkipi-devel

- Add Conflicts: for older (pre-SLPP-valid) libKF5Kipi package
to the -data subpackage (boo#1069775)

==== libmspub ====
Version update (0.1.2 -> 0.1.3)

- Version update to 0.1.3:
* Workaround a build error on some 32-bit systems.
* Parse table row and column sizes. (tdf#89061)
* Fix various problems when parsing broken files, found with the help of
american-fuzzy-lop and oss-fuzz.
* Make the output of pub2foo --help more compatible with help2man.
* Extract more metadata from documents.
* Require C++11 for build.
* Drop outdated MSVC project files.
* Handle table cells containing multiple paragraphs correctly. (tdf#89393)
* Parse more text formatting attributes: all underline types, small
caps, all caps, outline, emboss, engrave, shadow.
* Parse text language.
* Various minor changes and improvements.

==== libqt4 ====
Subpackages: libqt4-32bit libqt4-qt3support libqt4-qt3support-32bit libqt4-sql
libqt4-sql-32bit libqt4-sql-sqlite libqt4-sql-sqlite-32bit libqt4-x11
libqt4-x11-32bit

- Change fix-build-icu59.patch to build qlocale_icu.cpp with
- std=c++11 to support ICU60 headers

==== libreoffice ====
Version update (5.4.3.2 -> 6.0.0.1)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-draw
libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3
libreoffice-impress libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de
libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN
libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreofficekit

- Add libreoffice-poppler-0.62.patch: Fix build with poppler 0.62,
where UTF8.h (explcitly marked as an experimental header) was
renamed to UnicodeMapFuncs.h.
- For now disable qt5 integration as it is utterly broken
* just keep the kde4 one
- Version update to 6.0.0.1:
* RC1 of 6 series, now tests seem to pass
- Reintroduce kde4 subpackage (now qt4 build with openssl-1.1)
- Add the gtk2 subpackage to not pull-in the gtk2 on current desktop
* Also supplement as needed for SLE12
- Supplement properly the qt5 and the plasma5-workspace
- Fix providing libgpg-error0 bsc#1072061 when bundling
- Version update to 6.0.0.0.beta2:
* Many fixes in gpg4libre and all around
- Seems we no longer need the _r.so directly, no mentions in code
- Do not upse otherproviders() as it is not needed with new rpms
- Merge up all the icon themes as they have intermixed deps
- Tweak up langpack generating to work with new gettext .mo files
* Those macros are pretty ugly
- Add patch to not bother checking qt4 bugs:
* kde5-configure-checks.patch
- Start updating to release 6.0.0.0.beta1:
* Code for Qt5 UI
* No longer flickering opengl backend
* Tons of updates
* Collada and gltf are removed upstream
* Online help re-integrated even better
- Remove merged patches:
* 0001-Adapt-getcompver.awk-to-Java-9.patch
* 0001-This-hunk-breaks-jdk9-build.patch
* 0002-Detect-libjawt-automatically-on-java9-too.patch
* java-encoding.patch
* gnome-documents-check-ntimeoutid.patch
- Drop no longer needed patches:
* libreoffice-hotfix-disablebrokenshapetest.patch
* disable-flaky-hsqldb-test.patch

==== libyaml ====
Version update (0.1.6 -> 0.1.7)

- update to 0.1.7
* Fixed segfault in yaml_string_write_handler
* Fixed invalid simple key assertion (CVE-2014-9130)
* Fixed error handling in some examples
- remove CVE-2014-9130.patch
- fixed upstream in 946596172d140497b560e016e581accb0a92cca4
- cleanup spec file with spec-cleaner

==== opencc ====
Subpackages: libopencc2 opencc-data

- Use python3 for all the operations do not implicitely inherit py2

==== oxygen5-icon-theme ====
Version update (5.40.0 -> 5.41.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None

==== perl-Archive-Zip ====
Version update (1.59 -> 1.60)

- updated to 1.60
see /usr/share/doc/packages/perl-Archive-Zip/Changes
1.60 Tue 19 Dec 2017
- RT 123913 Wrong shell bang in examples/selfex.pl

==== perl-DBI ====
Version update (1.637 -> 1.639)

- updated to 1.639
see /usr/share/doc/packages/perl-DBI/Changes

==== perl-DateTime ====
Version update (1.44 -> 1.45)

- updated to 1.45
see /usr/share/doc/packages/perl-DateTime/Changes
1.45 2017-12-29
1.45 2017-12-26
- Added month_length(), quarter_length() and year_length()
methods. Implemented by Dan Stewart. PR #70.

==== perl-HTTP-Message ====
Version update (6.13 -> 6.14)

- updated to 6.14
- Add some useful examples in HTTP::Request (GH #92)
Batch requests are now explained.
- PUT and PATCH docs updated (GH #84)
- Trim trailing "\r" from status line so message() doesn't
return it (GH #87)
- Bring test coverage of HTTP::Config to 100% (GH #85)
- Add 103 Early Hints to HTTP::Status (GH #94)

==== perl-JSON ====
Version update (2.97000 -> 2.97001)

- updated to 2.97001
see /usr/share/doc/packages/perl-JSON/Changes
2.97001 2017-12-21
- updated backportPP with JSON::PP 2.97001

==== perl-Moose ====
Version update (2.2006 -> 2.2009)

- updated to 2.2009
see /usr/share/doc/packages/perl-Moose/Changes
2.2009 2017-11-29
[BUG FIXES]
- Some hash native trait methods (notably clear and delete) were broken in
various ways when the associated attribute's type allowed for coercion of
the hash values and coercion was enabled for the hash. Reported by Ralf
Bartel in RT #12737.
[TESTS]
- fixed tests (new in 2.2008) that sometimes fail under Windows.
2.2008 2017-11-21
[BUG FIXES]
- fixed empty exception messages under -d (new issue in 2.2007)
- updated to 2.2007
see /usr/share/doc/packages/perl-Moose/Changes
2.2007 2017-11-12
[DOCUMENTATION]
- The Moose::Manual::Attributes pod has been amended to clarify that
'required' attributes can be satisfied with a 'default' or 'builder' sub,
and that 'ro' attributes can be set through the constructor.
- The Moose::Manual::Types pod has been amended to recommend
Params::ValidationCompiler and Moops instead of older modules (which are
slow and/or deprecated).
- other small documentation fixes (thanks to Chris Weyl and Anirvan
Chatterjee!)
[OTHER]
- some dead code has been removed (thanks, Jens Berthold!)
- all Moose exception classes have been made immutable.

==== perl-Net-DNS ====
Version update (1.13 -> 1.14)

- updated to 1.14
see /usr/share/doc/packages/perl-Net-DNS/Changes

==== perl-PadWalker ====
Version update (2.2 -> 2.3)

- updated to 2.3
see /usr/share/doc/packages/perl-PadWalker/Changes
2.3 Fri 10 Nov 2017 18:26:29 GMT
- Make tests work with -Ddefault_inc_excludes_dot
https://rt.cpan.org/Public/Bug/Display.html?id=120421

==== perl-Set-Object ====
Version update (1.38 -> 1.39)

- updated to 1.39
see /usr/share/doc/packages/perl-Set-Object/Changes.pod
=head1 1.39, 2018-01-08
=over
=item *
Skip installing Changes.pod (PR #5, kentfredric)
=back

==== plasma-framework ====
Version update (5.40.0 -> 5.41.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-lang plasma-framework-private

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Too many changes to list here

==== poppler ====
Version update (0.61.1 -> 0.62.0)
Subpackages: libpoppler-cpp0 libpoppler-devel libpoppler-glib8 poppler-tools

- make introspection scanner (g-ir-scanner) work with older build envs
- Update to version 0.62.0:
+ Core:
- Stop supporting lcms1 and openjpeg1.
- Open files that state 8 bits as third field of W
(fdo#103469).
- GfxLabColorSpace::parse: fix crash in broken documents
(fdo#103582).
- Fixes: leak if parseDA fails. And UTF test fail.
- Include glibc.h where needed.
- Document the meaning of the 'type' integer of a shading.
- INSTALL: add debug options.
+ Qt5: add API to let the rendering process callback to get a
partial rendering (fdo#103372).
+ Qt4: remove the Qt4 frontend.
+ Utils:
- Support unicode on windows console.
- pdfsig: install man page.
- sort encoding list.
+ Glib: demo: fix warning.
- Remove Qt4 poppler package following upstream change.
- Drop conditional use of openjpeg-devel BuildRequires and mainly
use pkgconfig(libopenjp2) instead, following upstream change.
- Drop Provides/Obsoletes meant for pristine openSUSE 10.3,
11.1/(SLE 11) and 11.4 releases.

==== poppler-qt5 ====
Version update (0.61.1 -> 0.62.0)
Subpackages: libpoppler-qt5-1 libpoppler-qt5-devel

- Update to version 0.62.0:
+ Core:
- Stop supporting lcms1 and openjpeg1.
- Open files that state 8 bits as third field of W
(fdo#103469).
- GfxLabColorSpace::parse: fix crash in broken documents
(fdo#103582).
- Fixes: leak if parseDA fails. And UTF test fail.
- Include glibc.h where needed.
- Document the meaning of the 'type' integer of a shading.
- INSTALL: add debug options.
+ Qt5: add API to let the rendering process callback to get a
partial rendering (fdo#103372).
+ Qt4: remove the Qt4 frontend.
+ Utils:
- Support unicode on windows console.
- pdfsig: install man page.
- sort encoding list.
+ Glib: demo: fix warning.
- Remove Qt4 poppler package following upstream change.
- Drop conditional use of openjpeg-devel BuildRequires and mainly
use pkgconfig(libopenjp2) instead, following upstream change.
- Drop Provides/Obsoletes meant for pristine openSUSE 10.3,
11.1/(SLE 11) and 11.4 releases.

==== prison-qt5 ====
Version update (5.40.0 -> 5.41.0)

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Remove cmake warning
* Add Aztec code generator

==== remmina ====
Version update (1.2.0~rcgit.24 -> 1.2.0~rcgit.26)
Subpackages: remmina-lang remmina-plugin-rdp remmina-plugin-vnc
remmina-plugin-xdmcp

- Rename the plugin 'remmina-plugins-gnome' in 'remmina-plugin-secret'
- Added remmina-plugin-exec which allows execution of local commands
- Upgraded to 1.2.0-rcgit.26
Implemented enhancements:
* Allow external commands without protocols in create connection dialog
* Option to completely hide the floating toolbar when in fullscreen.
* Option to run Pre Command before ANYTHING else
* Rename the plugin 'remmina-plugins-gnome' in 'remmina-plugins-secret'
* Variables for pre- and post-commands
* Implement an exec protocol plugin
* Add SPICE Native WebDAV shared folder support
* Added encryption algorithms options for SSH
* SSH tunnel and pre/post commands improvements
* Prior commands improvements
* Add avahi host discovery for ssh and sftp plugins
Fixed bugs:
* Un-check of "Fullscreen on the same monitor as the connection window" won't
save
* Remmina resets screen resolution settings in RDP shortcut
* SSH Tunneling is broken with SSH Agent with public key
* Align SFTP and SSH plugins authentication and tunnel functionalities.
* ssh_userauth_publickey_auto: should accept empty passphrase
* Un-check of 'Fullscreen on the same monitor'
Other improvements:
* Updated translations
* Fixed typos
* Remove a couple of legacy "resolution" fields

==== solid ====
Version update (5.40.0 -> 5.41.0)
Subpackages: libKF5Solid5 libKF5Solid5-lang solid-devel solid-imports
solid-tools

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Faster UDevManager::devicesFromQuery

==== sonnet ====
Version update (5.40.0 -> 5.41.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetCore5-lang libKF5SonnetUi5
sonnet-devel

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Cache value before loop
* Make it compile with strict flags
* Fix generate debug file
* Clean up. Initialize value. Remove qt check
* Autogenerate debug category files
* Modernize code. Use new connect api. Assign directly parent etc.
* Make it possible to crosscompile sonnet
* If dictionnary is already set, return true;

==== syntax-highlighting ====
Version update (5.40.0 -> 5.41.0)
Subpackages: libKF5SyntaxHighlighting5 libKF5SyntaxHighlighting5-lang

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* Add PKGUILD to bash syntax
* JavaScript: include standard mime types
* debchangelog: add Bionic Beaver
* Update SQL (Oracle) syntax file (kde#386221)
* SQL: move detecting comments before operators
* crk.xml: added <?xml> header line

==== threadweaver ====
Version update (5.40.0 -> 5.41.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.41.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
* None


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups