Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
Re: [opensuse-factory] latest evolution 3.26.3-1.1 is NOT compatible with latest libwebkit2gtk-4_0-37 2.18.4-1.1
Am Montag, den 08.01.2018, 12:08 +0100 schrieb Knurpht - Gertjan Lettink:
Op maandag 8 januari 2018 11:34:53 CET schreef Rainer Klier:
Am Montag, den 08.01.2018, 11:16 +0100 schrieb Dominique Leuenberger /
DimStar:

How? Using zypper dup?


no.

i opened yast and selected both (evolution and libwebkit2gtk) for update.
both were updated from the same tumbleweed repo.
evolution to version 3.26.3-1.1, and libwebkit2gtk-4_0-37 to version
2.18.4-1.1


no conflict or dependency error was shown.
everything was "green" and ok, even after check in yast for any problems.
so i continued to install the updates.


and that's wrong. TW should *only* be updated through 'zypper dup'. Nothing
else.


but why?
tumbleweed repos are like every other repos.
instead of using the leap repos, or before, the 13.x repos, i now simply use
the tumbleweed repos.
and additionally some other repos like mozilla, libreoffice, KDE,...

i don't want to update everything every day.
i still want to update, for example, only evolution to latest version.

and normally this also works.
i do it this way now for a long time.

is the answer to this issue really "only use zypper dup"?
i think the dependencies should be solved in yast when selecting the packages.
i think it is not ok, that yast does not know or show any dependency problem
when selecting single packages, and that it
only works, when updating the whole system every time.
and if there are really so much packages dependent to each others, it should be
shown in yast.
so, when selecting, for example, evolution for an update, all the other needed
packages should automatically be selected
for update, like it is normal and usual in yast.

because otherwise for an user it is not understandable why the behaviour is
different, if you use the leap or the
tumbleweed repos.

and nowhere in https://en.opensuse.org/openSUSE:Tumbleweed_upgrade (which is
the documentation for how to use/move to
the tumblewwed repos) is stated, that from this point on in the future you
can't use yast anymore for updates, but have
to use "zypper dup".
it is however written, that you have to use "zypper dup" to do the
switch/upgrade from older/other repos to tumbleweed,
but not, that this will be the only supported upgrade path in the future.
--


Best Regards | Freundliche Grüße | Cordialement | Cordiali Saluti |
Atenciosamente | Saludos Cordiales


DI Rainer Klier


Research & Development, DevOps




_________________________________________________________





Namirial GmbH






< Previous Next >
Follow Ups