Mailinglist Archive: opensuse-factory (536 mails)

< Previous Next >
Re: [opensuse-factory] QGIS
  • From: Wolfgang Bauer <wbauer@xxxxxx>
  • Date: Wed, 03 Jan 2018 23:10:40 +0100
  • Message-id: <2150469.eFUNAlS6Mn@amiga>
Am Mittwoch, 3. Januar 2018, 21:39:00 schrieb Vojtěch Zeisek:
Hm, so we can choose from not really working and not installable
application...? :-( IMHO the first option is the way to go now...

Well, the current qgis should not require/use qca at all.
qca is (was) for Qt3, but qgis is Qt4 based.

The dependency on qca is specified manually in the specfile, seems to be a
(accidental) left-over from previous versions.

A submit request to remove that dependency is pending:
https://build.opensuse.org/request/show/561330

But you should be able to just "ignore" that requirement when installing qgis.

A probably bigger problem is that it requires libQtWebKit4 though, which we
are trying to get rid of. It is still available in Tumbleweed currently, but
not for very long anymore I suppose.
Although it could still be provided in the same repo as qgis (which is not
part of Tumbleweed anyway).

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >