Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171216 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171216

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
NetworkManager
dracut
glib2
glibc
glibc
issue-generator
kdelibs4
libgit2-glib
libqca2
libqt4
libsodium (1.0.15 -> 1.0.16)
llvm (4.0.1 -> 5.0.0)
llvm4
llvm5 (4.0.1 -> 5.0.0)
snapper
texlive
texlive-specs-m
texlive-specs-n
vsftpd
xmms2

=== Details ===

==== NetworkManager ====
Subpackages: NetworkManager-devel NetworkManager-lang libnm-glib-vpn1
libnm-glib4 libnm-util2 libnm0 typelib-1_0-NM-1_0 typelib-1_0-NMClient-1_0
typelib-1_0-NetworkManager-1_0

- Remove reference to deprecated and dropped ifcfg-suse plugin from
configuration.

==== dracut ====

- Switch back to fipvlan for bnx2fc (bsc#1052840)
* adds 0548-95fcoe-Switch-back-to-using-fipvlan-for-bnx2fc.patch
- 95fcoe: Allow bnc2x driver more time to complete DCB negotiation (bsc#1052840)
* adds 0549-fcoe-up-Increase-sleeptime-to-13s.patch
- 95fcoe: add timeout initqueue entries (bsc#1052840)
* adds 0550-95fcoe-add-timeout-initqueue-entries.patch
- Fix task limit in emergency.service (same as in dracut-emergency.service)
(bsc#1019938)
* adds 0547-Fix-task-limit-in-emergency.service-the-same-change-.patch
- Fix logic for applying
0541-Make-sure-70-persistent-net.rules-is-included-in-ini.patch
- Support AMD CPU families 0x16 and 0x17 (bsc#1072424)
* Adds 0545-Add-early-microcode-support-for-AMD-family-16h.patch
* Adds 0546-Support-Microcode-Updates-for-AMD-CPU-Family-0x17.patch
- Make ip=dhcp work. Previously, a network interface specifier was required.
The new behaviour matches documented behaviour.
Adds 0544-40network-Make-ip-dhcp-work.patch
- Remove 00systemd-bootchart, which is gone from systemd for some time
(bsc#1067279)
Adds 0543-Remove-00systemd-bootchart.patch
- Ensure 0541-Make-sure-70-persistent-net.rules-is-included-in-ini.patch is
not applied on Leap either

==== glib2 ====
Subpackages: glib2-devel glib2-lang glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Add glib2-gsettings-overrides-per-session.patch: gsettings
default value can be overridden depending on session
(bgo#746592 bsc#1070090).

==== glibc ====
Subpackages: glibc-32bit glibc-locale-32bit

- tst-tlsopt-powerpc.patch: fix tst-tlsopt-powerpc (bcn#1070419)
- powerpc-hwcap-bits.patch: Update HWCAP for powerpc (bnc#1070420)
- malloc-tcache-check-overflow.patch: Fix integer overflow in malloc when
tcache is enabled (CVE-2017-17426, bnc#1071479, BZ #22375)
- Add _multibuild
- glob64-s390.patch: no compat glob64 on s390
- noversion.tar.bz2: remove unused source

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale nscd

- tst-tlsopt-powerpc.patch: fix tst-tlsopt-powerpc (bcn#1070419)
- powerpc-hwcap-bits.patch: Update HWCAP for powerpc (bnc#1070420)
- malloc-tcache-check-overflow.patch: Fix integer overflow in malloc when
tcache is enabled (CVE-2017-17426, bnc#1071479, BZ #22375)
- Add _multibuild
- glob64-s390.patch: no compat glob64 on s390
- noversion.tar.bz2: remove unused source

==== issue-generator ====

- Enable more network devices to be shown on s390x [bsc#1071776]
- Remove systemd require again, systemd-preset-branding is fixed.

==== kdelibs4 ====
Subpackages: kdelibs4-core libkde4 libkdecore4 libksuseinstall1

- Add 0001-Make-kssl-compile-against-OpenSSL-1.1.0.patch (backported
from KF5's kdelibs4support) to allow building with openSSL 1.1.0

==== libgit2-glib ====

- Fix spelling project names again. Adjust RPM group.

==== libqca2 ====

- BuildIgnore libopenssl-1_1_0-devel to avoid conflict

==== libqt4 ====
Subpackages: libqt4-32bit libqt4-qt3support libqt4-qt3support-32bit libqt4-sql
libqt4-sql-32bit libqt4-sql-sqlite libqt4-sql-sqlite-32bit libqt4-x11
libqt4-x11-32bit

- Add proper patch headers to:
* no-ssl3.patch
* qt4-openssl-1.1.0pre-3.patch
- Remove patch, not needed:
* qt-everywhere-opensource-src-4.8.7-gcc7.patch
- add patches from mageia to fix build with openssl-1.1
- add no-ssl3.patch
- add qt4-openssl-1.1.0pre-3.patch
- add qt-everywhere-opensource-src-4.8.7-openssl.patch
- add qt-everywhere-opensource-src-4.8.7-gcc7.patch

==== libsodium ====
Version update (1.0.15 -> 1.0.16)

- Update to 1.0.16
* Signatures computations and verifications are now way faster
on 64-bit platforms with compilers supporting 128-bit
arithmetic (gcc, clang, icc). This includes the WebAssembly
target.
* New low-level APIs for computations over edwards25519:
crypto_scalarmult_ed25519(), crypto_scalarmult_ed25519_base(),
crypto_core_ed25519_is_valid_point(), crypto_core_ed25519_add(),
crypto_core_ed25519_sub() and crypto_core_ed25519_from_uniform()
(elligator representative to point).
* crypto_sign_open(), crypto_sign_verify_detached() and
crypto_sign_edwards25519sha512batch_open` now reject public
keys in non-canonical form in addition to low-order points.
* The library can be built with ED25519_NONDETERMINISTIC defined
in order to use synthetic nonces for EdDSA. This is disabled
by default.
* sodium_stackzero() was added to wipe content off the stack.
* The Salsa20-based PRNG example is now thread-safe on platforms
with support for thread-local storage, optionally mixes bits
from RDRAND.
* Argon2 and scrypt are slightly faster on Linux.

==== llvm ====
Version update (4.0.1 -> 5.0.0)

- Rename python-lldb to python3-lldb to match the renamed package
in llvm4 and llvm5 after switch to python3. Fix its dependency.
- Update to version 5.0.0
* See:
+ http://llvm.org/releases/5.0.0/docs/ReleaseNotes.html
+ http://llvm.org/releases/5.0.0/tools/clang/docs/ReleaseNotes.html
+
http://llvm.org/releases/5.0.0/tools/clang/tools/extra/docs/ReleaseNotes.html

==== llvm4 ====
Subpackages: libLLVM4 libclang4

- Rename python3-lldb to python3-lldb4 so it can work with llvm
meta package.
- Rename python packages to follow naming conventions.
- Remove unnecessary dependencies on python3.

==== llvm5 ====
Version update (4.0.1 -> 5.0.0)
Subpackages: libc++-devel libc++1 libc++abi-devel libc++abi1

- Rename python3-lldb to python3-lldb5 so it can work with llvm
meta package.
- Rename python packages to follow naming conventions.
- Remove unnecessary dependencies on python3.
- Make opt-viewer not require python2.
* opt-viewer-Do-not-require-python-2.patch

==== snapper ====
Subpackages: libsnapper4 snapper-zypp-plugin

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== texlive ====

- Replace Mesa-libGL-devel and libOSMesa-devel BuildRequires with
pkgconfig(gl) and pkgconfig(osmesa).
- Drop Mesa-libglapi-devel Buildequires: not needed by texlive for
a while already.
- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.
- Disable by a build conditions using zypper way of posttrans scripts
as we already use %posttrans. Nevertheless correct naming scheme
(boo#1069445)

==== texlive-specs-m ====

- Disable by a build conditions using zypper way of posttrans scripts
as we already use %posttrans. Nevertheless correct naming scheme
(boo#1069445)

==== texlive-specs-n ====

- Disable by a build conditions using zypper way of posttrans scripts
as we already use %posttrans. Nevertheless correct naming scheme
(boo#1069445)

==== vsftpd ====

- Make sure to also require group nobody and user ftp bsc#1070653

==== xmms2 ====
Subpackages: libxmmsclient-glib1 libxmmsclient6 xmms2-plugin-base

- BuildRequire python-xml explicitly
- Use openssl < 1.1


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages